Subject: [manet] DLEP v1

From: "Kang, Jaewon" <[email-masked]>
Date: Tue, 9 Aug 2011 12:04:13 -0400

Stan,

I have a question about the operation of a Router's ARP protocol in conjunction with DLEP.

>From the document, it seems like the ARP protocol is enabled or disabled based on the DLEP messages and can be controlled per modem device. For example, a Router has two modem devices with and without DLEP capabilities. On page 52 in the document, the ARP protocol is enabled only after the Router and the Client exchange Neighbor Up/Neighbor Up ACK orders. In this case, is it true that the ARP protocol is still operational for the other modem (without DLEP)?
If so, can we control the ARP protocol per modem at the Router?
If not, the MAC information retrieved from the modem without DLEP will not be instantiated in the Router's neighbor table.
Or are we assuming that all modem device should talk DLEP protocol?

Thanks.

Jae from Telcordia

---

From: Stan Ratliff <[email-masked]>
Date: Tue, 9 Aug 2011 12:58:27 -0400

Jae,

That's really an implementation issue. The idea was that a Neighbor Up  
with Layer 3 addresses supplied by the modem would allow code to  
populate the ARP table immediately. ARP (as well as inARP, Reverse  
ARP, etc) are also available if/when a Neighbor Up is received without  
the Layer 3 addressing information.

Regards,
Stan

On Aug 9, 2011, at 12:04 PM, Kang, Jaewon wrote:

> Stan,
>
> I have a question about the operation of a Router’s ARP protocol in  
> conjunction with DLEP.
>
> From the document, it seems like the ARP protocol is enabled or  
> disabled based on the DLEP messages and can be controlled per modem  
> device. For example, a Router has two modem devices with and without  
> DLEP capabilities. On page 52 in the document, the ARP protocol is  
> enabled only after the Router and the Client exchange Neighbor Up/ 
> Neighbor Up ACK orders. In this case, is it true that the ARP  
> protocol is still operational for the other modem (without DLEP)?
> If not, the MAC information retrieved from the modem without DLEP  
> will not be instantiated in the Router’s neighbor table.

---

From: "Kang, Jaewon" <[email-masked]>
Date: Tue, 9 Aug 2011 14:31:58 -0400

OK. It looks like the DLEP protocol at the Router inserts an ARP entry into the ARP cache when it receives a Neighbor Up order while the legacy ARP protocol is still in operation at the Router.

Jae.

From: Stan Ratliff [mailto:[email-masked]]
Sent: Tuesday, August 09, 2011 12:58 PM
To: Kang, Jaewon
Cc: [email-masked]
Subject: Re: [manet] DLEP v1

Jae,

That's really an implementation issue. The idea was that a Neighbor Up with Layer 3 addresses supplied by the modem would allow code to populate the ARP table immediately. ARP (as well as inARP, Reverse ARP, etc) are also available if/when a Neighbor Up is received without the Layer 3 addressing information.

Regards,
Stan

Stan,

Thanks.

Jae from Telcordia