Subject: Re: [manet] NHDP's Packet and Message

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 13 Jul 2012 11:36:08 +0200

>Subject: Re: [manet] I-D Action: draft-ietf-manet-nhdp-sec-02.txt
>From: Henning Rogge <hrogge at googlemail.com>
>Date: Thu, 12 Jul 2012 21:11:14 +0200
>
> I agree,
>
> packet signatures are a different kind of context. Instead of
> authenticating a message for the rest of the network, they deal with
> neighbor authentication. The packet signature will never be forwarded
> and might even work on a totally different key-scheme.

Please note that NHDP's packets may be used in the control plane with
DLEP or it may be bridged between node neighbors (encapsulated in
frames instead of IP packets), so it does not always need forwarding.

AB

>
> Henning Rogge
>
> On Thu, Jul 12, 2012 at 9:08 PM, Ulrich Herberg <ulrich at herberg.name>
> wrote:
>> Dear Chris,
>>
>> I agree that we need to provide similar mechanisms as in NHDP-sec for TC
>> messages as well. I don't think that signing the packet is enough, since
>> that does not provide end-to-end security. Instead, I suggest to submit a
>> draft OLSRv2-sec that specifies how to calculate ICVs for TC messages,
>> and
>> how to handle these messages in OLSRv2.
>>
>> However, I believe that it would be beneficial for certain applications
>> to
>> also be able to sign/verify packets. But I don't think that the NHDP-sec
>> document is the right place for this, since other applications (e.g.
>> DYMO)
>> may not use HELLO messages at all, but would still like to sign/verify
>> packets.
>> Maybe it would be better to have an extra document "packet-sec" which
>> specifies how to sign/verify packets?
>>
>> Best
>> Ulrich
>>
>>
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 13 Jul 2012 13:41:46 +0200

Am 13.07.2012 11:36, schrieb Abdussalam Baryun:
>> From: Henning Rogge<hrogge at googlemail.com>
>> I agree,
>>

NHDP messages will notbe sent over the control plane of DLEP, because 
DLEP keeps control traffic and data-traffic separated and the 
control-plane will be definitely no MANET interface, so you wont use 
NHDP on it.

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Neuenahrer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de
GPG: E1C6 0914 490B 3909 D944 F80D 4487 C67C 55EC CFE0