Subject: Re: [manet] NHDP-MIB: ifType

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 6 Jul 2012 07:34:26 +0200

+1

I need the NHDP as a MANET interface for the DSRv2, which I suggested
for DSRv2 before, so I like/agree that you consider the flag ifType,
thanks very much,

It is interesting if most manet routings use NHDP or even be possible
to use in future, because I think it is a MANET interface as specified
in OLSRv2.

AB
++++++++
> Hi,
>
> we are currently working on a revised ID of the NHDP-MIB, as follow-up
> on requests during the IESG review. Amongst others, one request from
> Thomas Nadeau may affect other MIB documents as well, which is why I
> post it on the mailing list.
>
> The current interface table in the NHDP-MIB is a copy of the interface
> MIB, with potentially many entries that are not MANET interfaces (but
> still waste space). What we are really interested in is monitoring and
> managing NHDP interfaces. Thomas Nadeau suggested to ask IANA to
> specify a ifType=MANET (as allowed by RFC2863 and the IANAifType
> registry), and to list only those in the NHDP-MIB. Bob and I propose
> that IANA allocates such an ifType, which covers all MANET WG
> protocols, i.e. ifType=MANET would be used for interfaces running
> NHDP, OLSRv2, SMF, DYMO, etc. In the NhdpIfTable, there is an
> additional boolean flag which determines whether the interface uses
> NHDP or not (i.e., if a router runs both DYMO and NHDP, the DYMO-only
> interfaces would be listed in the nhdpIfTable, but the boolean flag is
> false).
>
>
> Best regards
> Ulrich
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 6 Jul 2012 09:52:48 +0000

I'll also note that the WG doesn't need DSRv2, even if you have permission from the original authors to use their work (which I see no sign of). The WG is charted to produce one reactive protocol. Multiplicity of protocols is a bad, not a good, thing, unless there is a pressing reason for it. In the reactive space the WG's adopted solution has been DYMO. Now that having stalled - though it may now be out of that stall - may (no stronger than that) open up the possibility that another protocol already developed to a similar maturity could be considered. LOADng claims to be that, I haven't examined that claim. But a new protocol is clearly not that.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 06 July 2012 06:34
To: [email-masked]
Cc: manet
Subject: Re: [manet] NHDP-MIB: ifType

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

+1

AB
++++++++
> interfaces would be listed in the nhdpIfTable, but the boolean flag is
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 6 Jul 2012 14:13:21 +0200

Hi Chris,

the point for me is not an individual understanding of the charter, MY
effort is aimed to the community needs. So I RECOMMEND that any
IETF-WG respects the community or even IETF-participant needs. I
respect the WG charter and I am participating, so I hope the WG
comments on my work. I know there is a need in DSRv2 and the future
will prove my point, I will remind you of this in the future don't
worry,

AB
=========
On 7/6/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> I'll also note that the WG doesn't need DSRv2, even if you have permission
> from the original authors to use their work (which I see no sign of). The WG
> is charted to produce one reactive protocol. Multiplicity of protocols is a
> bad, not a good, thing, unless there is a pressing reason for it. In the
> reactive space the WG's adopted solution has been DYMO. Now that having
> stalled - though it may now be out of that stall - may (no stronger than
> that) open up the possibility that another protocol already developed to a
> similar maturity could be considered. LOADng claims to be that, I haven't
> examined that claim. But a new protocol is clearly not that.
>
> --
> Christopher Dearlove

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 6 Jul 2012 12:19:08 +0000

How can you know there is a need for DSRv2? It's not in the WG charter, and I've not seen anyone else on the list support the idea.

-----Original Message-----
From: Abdussalam Baryun [mailto:[email-masked]] 
Sent: 06 July 2012 13:13
To: Dearlove, Christopher (UK)
Cc: [email-masked]; manet
Subject: Re: [manet] NHDP-MIB: ifType

Hi Chris,

AB
=========

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 6 Jul 2012 09:41:56 -0700

Abdussalam,

note that this has nothing to do with the protocol itself, but only for the
MIB. So, unless you draft a MIB module, you will not need the ifType.

If you want to discuss DSRv2 (which I doubt the WG should work on), please
open a new email thread, since this thread was only about the NHDP-MIB
draft.

Best
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 6 Jul 2012 23:12:20 +0200

I am sorry I will never post in your threads, if you like that,

AB

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 6 Jul 2012 14:24:20 -0700

That is not what I said. I just recommended that this email thread is about
the ifType in the NHDP-MIB, not about DSRv2, and that such a discussion (if
desired) should be in another email with different subject.

Best
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 6 Jul 2012 23:34:58 +0200

Hi Ulrich,

You mention routing protocols already please read in your thread,

 > NHDP or not (i.e., if a router runs both DYMO and NHDP, the

Please note that DYMO will not use NHDP,  only if using RFC5444. I
just mentioned the DSRv2 I am doing,

AB
============================================================

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Sat, 7 Jul 2012 17:00:22 +0000

Classification: UNCLASSIFIED
Caveats: NONE

Our proposal is not mandating the use of NHDP.  Instead it is flexible and
allows whatever combination of MANET control protocols that makes sense.

Thanks, Bob 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Abdussalam Baryun
Sent: Friday, July 06, 2012 5:35 PM
To: Ulrich Herberg
Cc: manet
Subject: Re: [manet] NHDP-MIB: ifType

Hi Ulrich,

 > additional boolean flag which determines whether the interface uses  >
NHDP or not (i.e., if a router runs both DYMO and NHDP, the  > DYMO-only

Please note that DYMO will not use NHDP,  only if using RFC5444. I just
mentioned the DSRv2 I am doing,

AB
============================================================
On 7/6/12, Ulrich Herberg <[email-masked]> wrote:
> That is not what I said. I just recommended that this email thread is 
> about the ifType in the NHDP-MIB, not about DSRv2, and that such a 
> discussion (if
>> > note that this has nothing to do with the protocol itself, but only 
>> > for
>> the
>> > open a new email thread, since this thread was only about the 
>> > NHDP-MIB draft.
>> >
>> > Best
>> > Ulrich
>> >
>> >> I need the NHDP as a MANET interface for the DSRv2, which I 
>> >> suggested for DSRv2 before, so I like/agree that you consider the 
>> >> flag ifType, thanks very much,
>> >>
>> >> It is interesting if most manet routings use NHDP or even be 
>> >> possible to use in future, because I think it is a MANET interface 
>> >> as specified in OLSRv2.
>> >>
>> >> AB
>> >> ++++++++
>> >> > Hi,
>> >> >
>> >> > we are currently working on a revised ID of the NHDP-MIB, as 
>> >> > follow-up on requests during the IESG review. Amongst others, 
>> >> > one request from Thomas Nadeau may affect other MIB documents as 
>> >> > well, which is why I post it on the mailing list.
>> >> >
>> >> > The current interface table in the NHDP-MIB is a copy of the 
>> >> > interface MIB, with potentially many entries that are not MANET 
>> >> > interfaces (but still waste space). What we are really 
>> >> > interested in is monitoring and managing NHDP interfaces. Thomas 
>> >> > Nadeau suggested to ask IANA to specify a ifType=MANET (as 
>> >> > allowed by RFC2863 and the IANAifType registry), and to list 
>> >> > only those in the NHDP-MIB. Bob and I propose that IANA 
>> >> > allocates such an ifType, which covers all MANET WG protocols, 
>> >> > i.e. ifType=MANET would be used for interfaces running NHDP, 
>> >> > OLSRv2, SMF, DYMO, etc. In the NhdpIfTable, there is an 
>> >> > additional boolean flag which determines whether the interface 
>> >> > uses NHDP or not (i.e., if a router runs both DYMO and NHDP, the 
>> >> > DYMO-only interfaces would be listed in the nhdpIfTable, but the 
>> >> > boolean flag is false).
>> >> >
>> >> >
>> >> > Best regards
>> >> > Ulrich
>> >> >
>> >>
>> >
>>
>

Classification: UNCLASSIFIED
Caveats: NONE

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 12 Jul 2012 20:31:47 -0700

I agree with Bob

Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 13 Jul 2012 13:23:50 +0200

+1

Flexible is always good for a general neighbor discover technique as NHDP,

AB
======================