Subject: Re: [manet] Discussing LOADng suggestions

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 4 Jul 2012 13:43:35 +0200

Hi Thomas,

>Just for information, the coming version of LOADng will use 5444 (cleanly).

but <draft-clausen-lln-loadng-04> last draft: does not use RFC5444

I am interested to know about the LOADng, while you requested its
consideration in MANET, but we still not much discussed the status of
the work, as now some participant and I thought that LOADng didn't use
RFC5444. Please give us some input of updated issues. As was waiting
for the new version which was expected within June as per one
co-author discussion. Thanking you,

Best Regards
Abdussalam Baryun
===============

To: "Dearlove, Christopher (UK)" <Chris.Dearlove at baesystems.com>
Subject: Re: [manet] Status of DLEP-draft at Cisco?
From: Thomas Heide Clausen <ietf at thomasclausen.org>

Just for information, the coming version of LOADng will use 5444 (cleanly).

-- 
Thomas Heide Clausen
http://www.thomasclausen.org
================================================
>Abdussalam,

>we are aware that the LOADng draft needs some updates, before it could
be considered by the MANET WG, notably support for RFC5444 and some
editorial updates. We plan to work on these in the next days, and will
submit a new revision likely next week. So, just stay tuned!

>Best
>Ulrich

On Wed, May 30, 2012 at 3:45 AM, Abdussalam Baryun
<abdussalambaryun at gmail.com> wrote:
> On 5/29/12, JP Vasseur <jpv at cisco.com> wrote:
>>
>> We already have two different WG: MANET and ROLL.
>>
>
> Yes we know. That is why LOADng authors should choose either to serve
> LLN that is considered by ROLL WG or they choose serving MANET, and it
> is considered by MANET WG. But the question is which suggestion option
> do you think is better for LOADng-draft?
>
>>MANET is tasked, amongst other, to publish a reactive
>>routing protocol.
>
> MANET is tasked to publish routing protocols that serve the MANET
> network. IMO, MANET-WG is not tasked to publish protocols serving only
> LLN just because the protocol is reactive. Please note that LOADng
> protocol does not even mention MANET nor mobile routers in its draft,
> which confuses its purpose, the authors should look into that.
>
> Abdussalam Baryun

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 4 Jul 2012 13:48:04 +0200

> but <draft-clausen-lln-loadng-04> last draft: does not use RFC5444

Hence the use of the phrase "the coming version will....".

Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 31 Jul 2012 15:45:58 +0200

Hi Thomas and All

I am interested in LOADng and did discuss about it from May 2012 until
now. I gave comments [1] on LOADng but no respond so far, I asked from
before for more discussion but there was no, and hope that we don't
forget the past comments on any document in ietf. The LOADng SHOULD
specify use case that are related to MANET not LLN. I suggest that the
word LLN taken out of the name as well and specify mobility [1-2].

IMHO this protocol was intended as for ROLL WG not for MANET WG, but
then changed its direction to MANET [3]. However, please note that
*ONLY* some LLNs are MANETs, and *ONLY* some MANETs are LLNs. That
said, LOADng SHOULD specfy where is its limits. Then we can discuss
adoption.

[1] http://www.ietf.org/mail-archive/web/manet/current/msg12924.html
[2] http://www.ietf.org/mail-archive/web/manet/current/msg12928.html
[3] http://www.ietf.org/mail-archive/web/manet/current/msg12933.html

thanking you,
AB
===========

---

From: Henning Rogge <[email-masked]>
Date: Tue, 31 Jul 2012 06:49:08 -0700

> said, LOADng SHOULD specfy where is its limits. Then we can discuss

Could you state an example what would be considered a LLN but not a
MANET. I normally consider LLNs a subset of what we call MANETs.

Henning Rogge

-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: Mukul Goyal <[email-masked]>
Date: Tue, 31 Jul 2012 12:32:02 -0500 (CDT)

The wireless network of "fixed" temperature monitoring sensors and HVAC controllers in a building. This network is an LLN. Not sure if it qualifies as a MANET (since nothing is mobile).

Thanks
Mukul

----- Original Message -----
From: "Henning Rogge" <[email-masked]>
To: "Abdussalam Baryun" <[email-masked]>
Cc: "manet" <[email-masked]>
Sent: Tuesday, July 31, 2012 8:49:08 AM
Subject: Re: [manet] Discussing LOADng suggestions

Henning Rogge

-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 31 Jul 2012 10:37:35 -0700

MANETs are not defined by mobility. It is rather about very dynamic
topologies. Otherwise, community networks such as FunkFeuer would also not
be qualified as MANETs.

Ulrich

On Tue, Jul 31, 2012 at 10:32 AM, Mukul Goyal <[email-masked]> wrote:

> The wireless network of "fixed" temperature monitoring sensors and HVAC
> controllers in a building. This network is an LLN. Not sure if it qualifies
> as a MANET (since nothing is mobile).
>
> Thanks
> Mukul
>

---

From: Antonin Bas <[email-masked]>
Date: Tue, 31 Jul 2012 19:44:16 +0200

According to MANET charter,

The purpose of the MANET working group is to standardize IP routing
  protocol functionality suitable for wireless routing application within
  both static and dynamic topologies with increased dynamics due to node
  motion or other factors.

So I don't think MANETs are defined by mobility, but by "increased
dynamics",which can be due to motion, but also to lossy links.

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Tue, 31 Jul 2012 17:48:41 +0000

> MANETs are not defined by mobility. It is rather about very dynamic topologies. Otherwise, community networks such as FunkFeuer would also not be qualified as MANETs.

Well, they shouldn't be.

Ronald

Thanks
Mukul

----- Original Message -----
From: "Henning Rogge" <[email-masked]>
To: "Abdussalam Baryun" <[email-masked]>
Cc: "manet" <[email-masked]>
Sent: Tuesday, July 31, 2012 8:49:08 AM
Subject: Re: [manet] Discussing LOADng suggestions

Henning Rogge

This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 31 Jul 2012 10:58:51 -0700

Why not? They use MANET routing protocols because they have a dynamic
multi-hop topology and constrained resources. I know many MANET deployments
where routers are not mobile.

Ulrich

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Tue, 31 Jul 2012 20:07:11 +0200

+1

Carles

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Tue, 31 Jul 2012 18:23:23 +0000

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Antonin Bas
>Sent: dinsdag 31 juli 2012 19:44
>To: Ulrich Herberg
>Cc: manet; Abdussalam Baryun

Strange wording, in my opinion. It seems to me that if the network _topology_ is truly static, you do not need a routing protocol at all. (Note that just as the absence of movement does not imply a static topology, a static topology does not imply stationary nodes).

>dynamics",which can be due to motion, but also to lossy links.

So why aren't they called ANETs?

Ronald
>> topologies. Otherwise, community networks such as FunkFeuer would also
>> not be qualified as MANETs.
>>
>> Ulrich
>>
>>
>>> The wireless network of "fixed" temperature monitoring sensors and
>>> HVAC controllers in a building. This network is an LLN. Not sure if
>>> it qualifies as a MANET (since nothing is mobile).
>>>
>>> Thanks
>>> Mukul
>>>
>>> > IMHO this protocol was intended as for ROLL WG not for MANET WG,
>>> > but then changed its direction to MANET [3]. However, please note
>>> > that

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 31 Jul 2012 11:26:04 -0700

Ronald,

On Tue, Jul 31, 2012 at 11:23 AM, Velt, R. (Ronald) in 't <
[email-masked]> wrote:

> Strange wording, in my opinion. It seems to me that if the network
> _topology_ is truly static, you do not need a routing protocol at all.

I agree.

> (Note that just as the absence of movement does not imply a static
> topology, a static topology does not imply stationary nodes).
>
> >

Or DANET ("dynamic"). It just did not sound as nice when the term was
created.

Best
Ulrich

---

From: Teco Boot <[email-masked]>
Date: Tue, 31 Jul 2012 22:32:05 +0200

LLN and MANET share the characteristic that they are networks.
LLN are not mobile/dynamic and ad hoc per se. I say they are 
related to MANET. Either strongly or loosely, for what it matter.

I am against adopting work that concurs with ROLL. I have 
nothing against having LOADng as candidate for the MANET 
reactive protocol. When LLN market accept it next to, or 
instead of, RPL, so be it.

Teco

Op 31 jul. 2012, om 20:26 heeft Ulrich Herberg het volgende geschreven:

> Ronald,
> 
> On Tue, Jul 31, 2012 at 11:23 AM, Velt, R. (Ronald) in 't <[email-masked]> wrote:
> 
> Strange wording, in my opinion. It seems to me that if the network _topology_ is truly static, you do not need a routing protocol at all.
> 
> 
> I agree.
> 
>  
> (Note that just as the absence of movement does not imply a static topology, a static topology does not imply stationary nodes).
> 
> >
> Or DANET ("dynamic"). It just did not sound as nice when the term was created.
> 
> Best
> Ulrich
> 
> 
>  
> 
> Ronald
> >

---

From: Joseph Macker <[email-masked]>
Date: Tue, 31 Jul 2012 14:48:08 -0700

I think a large set of WG comments and consensus input from the meeting was
clear that the LLN needs to be deemphasized as the primary purpose if
adopted as manet. See minutes when published.

The verbage in the present document needs to emphasize more the MANET
problem set as the fundamental direction and I think that can be
accomplished.  Since it derives somewhat from AODV MANET design I think
that is relatively straightforward if the authors commit.  I sensed
agreement on this at the meeting. However, it should also pointed out why
going beyond older AODV designs is helpful for manet problem areas such as
improvements in heterogeneity support, simplification where sensible,
improved control plane flooding, better IPv6 support, and a eventually
clear border gateway specification (e.g., although there are several ways
to do that in reactive cases but an initial approach should be specified).

---

From: Henning Rogge <[email-masked]>
Date: Tue, 31 Jul 2012 15:32:39 -0700

> Strange wording, in my opinion. It seems to me that if the network _topology_ is truly static, you do not need a routing protocol at all. (Note that just as the absence of movement does not imply a…

I think you are underestimating the amount of dynamics in large
stationary radio network, especially built on 802.11 technology. We
need MANET protocols in this community networks as Funkfeuer.

Henning

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Tue, 31 Jul 2012 23:45:29 +0000

Henning,

>From: Henning Rogge [mailto:[email-masked]]
>Sent: woensdag 1 augustus 2012 0:33
>To: Velt, R. (Ronald) in 't
>Cc: Antonin Bas; Ulrich Herberg; manet; Abdussalam Baryun
>_topology_ is truly static, you do not need a routing protocol at all. (Note that
>just as the absence of movement does not imply a static topology, a static
>topology does not imply stationary nodes).
>
>I think you are underestimating the amount of dynamics in large stationary
>radio network, especially built on 802.11 technology. We need MANET
>protocols in this community networks as Funkfeuer.

Where in the sentences quoted above do I underestimate the dynamics of large stationary radio networks?

Ronald

>
>Henning
>--
>Steven Hawkings about cosmic inflation: "An increase of billions of billions of
>percent in a tiny fraction of a second. Of course, that was before the present
>government."

---

From: Henning Rogge <[email-masked]>
Date: Tue, 31 Jul 2012 16:47:00 -0700

I was just getting the feeling that you are supporting this "they are
not MANET".

Henning Rogge