Subject: [manet] DSRv2 the first effort idea of Reactive using NHDP

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 6 Jul 2012 23:21:33 +0200

Please note that I am working on DSRv2 which will submit to MANET WG.
My idea of NHDP used in a reactive protocol was not worked on yet, the
DSRv2 was the first to announce this use of NHDP with reactive.
Furthermore,  I don't think there is restrictions on submitting I-Ds
to MANET WG, please read the charter and give me an excluding
statement. If yes there is this issue as you refer, I recommend only
the Chair or AD to educate me on stop the work I already am doing for
weeks. I think when I submit WG then can discuss further,

AB
=======

On 7/6/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> How can you know there is a need for DSRv2? It's not in the WG charter, and
> I've not seen anyone else on the list support the idea.
>
> --
> Christopher Dearlove
> Senior Principal Engineer, Communications Group
> Communications, Networks and Image Analysis Capability
> BAE Systems Advanced Technology Centre
> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
> Tel: +44 1245 242194 |  Fax: +44 1245 242124
> [email-masked] | http://www.baesystems.com
>
> BAE Systems (Operations) Limited
> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre,
> Farnborough, Hants, GU14 6YU, UK
> Registered in England & Wales No: 1996687
>
>
> -----Original Message-----
> From: Abdussalam Baryun [mailto:[email-masked]]
> Sent: 06 July 2012 13:13
> To: Dearlove, Christopher (UK)
> Cc: [email-masked]; manet
> Subject: Re: [manet] NHDP-MIB: ifType
>
> ----------------------! WARNING ! ----------------------
> This message originates from outside our organisation,
> either from an external partner or from the internet.
> Keep this in mind if you answer this message.
> Follow the 'Report Suspicious Emails' link on IT matters
> for instructions on reporting suspicious email messages.
> --------------------------------------------------------
>
> Hi Chris,
>
> the point for me is not an individual understanding of the charter, MY
> effort is aimed to the community needs. So I RECOMMEND that any
> IETF-WG respects the community or even IETF-participant needs. I
> respect the WG charter and I am participating, so I hope the WG
> comments on my work. I know there is a need in DSRv2 and the future
> will prove my point, I will remind you of this in the future don't
> worry,
>
> AB
> =========
> On 7/6/12, Dearlove, Christopher (UK) <[email-masked]>
> wrote:
>> I'll also note that the WG doesn't need DSRv2, even if you have
>> permission
>> from the original authors to use their work (which I see no sign of). The
>> WG
>> is charted to produce one reactive protocol. Multiplicity of protocols is
>> a
>> bad, not a good, thing, unless there is a pressing reason for it. In the
>> reactive space the WG's adopted solution has been DYMO. Now that having
>> stalled - though it may now be out of that stall - may (no stronger than
>> that) open up the possibility that another protocol already developed to
>> a
>> similar maturity could be considered. LOADng claims to be that, I haven't
>> examined that claim. But a new protocol is clearly not that.
>>
>> --
>> Christopher Dearlove
>> Senior Principal Engineer, Communications Group
>> Communications, Networks and Image Analysis Capability
>> BAE Systems Advanced Technology Centre
>> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
>> Tel: +44 1245 242194 |  Fax: +44 1245 242124
>> [email-masked] | http://www.baesystems.com
>>
>> BAE Systems (Operations) Limited
>> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace
>> Centre,
>> Farnborough, Hants, GU14 6YU, UK
>> Registered in England & Wales No: 1996687
>>
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Abdussalam Baryun
>> Sent: 06 July 2012 06:34
>> To: [email-masked]
>> Cc: manet
>> Subject: Re: [manet] NHDP-MIB: ifType
>>
>> ----------------------! WARNING ! ----------------------
>> This message originates from outside our organisation,
>> either from an external partner or from the internet.
>> Keep this in mind if you answer this message.
>> Follow the 'Report Suspicious Emails' link on IT matters
>> for instructions on reporting suspicious email messages.
>> --------------------------------------------------------
>>
>> +1
>>
>> I need the NHDP as a MANET interface for the DSRv2, which I suggested
>> for DSRv2 before, so I like/agree that you consider the flag ifType,
>> thanks very much,
>>
>> It is interesting if most manet routings use NHDP or even be possible
>> to use in future, because I think it is a MANET interface as specified
>> in OLSRv2.
>>
>> AB
>> ++++++++
>>> Hi,
>>>
>>> we are currently working on a revised ID of the NHDP-MIB, as follow-up
>>> on requests during the IESG review. Amongst others, one request from
>>> Thomas Nadeau may affect other MIB documents as well, which is why I
>>> post it on the mailing list.
>>>
>>> The current interface table in the NHDP-MIB is a copy of the interface
>>> MIB, with potentially many entries that are not MANET interfaces (but
>>> still waste space). What we are really interested in is monitoring and
>>> managing NHDP interfaces. Thomas Nadeau suggested to ask IANA to
>>> specify a ifType=MANET (as allowed by RFC2863 and the IANAifType
>>> registry), and to list only those in the NHDP-MIB. Bob and I propose
>>> that IANA allocates such an ifType, which covers all MANET WG
>>> protocols, i.e. ifType=MANET would be used for interfaces running
>>> NHDP, OLSRv2, SMF, DYMO, etc. In the NhdpIfTable, there is an
>>> additional boolean flag which determines whether the interface uses
>>> NHDP or not (i.e., if a router runs both DYMO and NHDP, the DYMO-only
>>> interfaces would be listed in the nhdpIfTable, but the boolean flag is
>>> false).
>>>
>>>
>>> Best regards
>>> Ulrich
>>>
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>>
>>
>> ********************************************************************
>> This email and any attachments are confidential to the intended
>> recipient and may also be privileged. If you are not the intended
>> recipient please delete it from your system and notify the sender.
>> You should not copy it or use it for any purpose nor disclose or
>> distribute its contents to any other person.
>> ********************************************************************
>>
>>
>
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 06 Jul 2012 15:04:04 -0700

Hello Abdussalam,

The idea of DYMO, renamed AODVv2 in the last revision, was exactly
to integrate AODV and DSR.  The previous protocols were published
as Experimental, and the integrated protocol is to be published as a
Proposed Standard.   In this way, publication of a new protocol named
"DSRv2" is likely to inhibit the intended effect of having a single
Proposed Standard reactive protocol.

Moreover, it is not true that AODVv2 would not use NHDP.  In fact,
the intention is exactly the opposite.  The Proposed Standard reactive
protocol SHOULD be able to use NHDP, as presumably should any
future protocols promulgated within [manet].

Finally, please observe that a major distinguishing factor for DSR
was the inclusion of source routing, which survived in DYMO until
we obtained results showing that inclusion of the source route did
actually cause a loss of performance in many cases.  It would be a
big contribution if you were able to exhibit clear results that would
resolve the mystery behind these results, but in the meantime it
seems unlikely that we should include Path Accumulation or the
more restricted version of Source Routing as specified in DSR.

Even if we had those results, and thus the mystery were resolved,
the proper course of action would not be to specify DSRv2. Instead,
we should then specify an extension to the Proposed Standard
reactive protocol enabling the proper use of Path Accumulation.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Sat, 7 Jul 2012 00:07:03 +0200

Very Incorrect postulate. 

LOADng, AODV, and other reactive protocols can well be used with NHDP -- and this, without requiring any special provisioning.

The reason there's no I-D stating that is that it's....well...obvious and requires no special provisioning or considerations for interoperability....

Should we have a specification for how to use HTTP with TCP also?

-- 
Thomas Heide Clausen
http://www.thomasclausen.org/

"Any simple problem can be made insoluble if enough meetings are held to
 discuss it."
   -- Mitchell's Law of Committees

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 7 Jul 2012 00:43:51 +0200

I thought that one participant say that we need only one reactive,
so if we include LOAD we can include others,

AB

On 7/7/12, Thomas Heide Clausen <[email-masked]> wrote:
> LOADng, AODV, and other reactive protocols can well be used with NHDP -- and
> this, without requiring any special provisioning.
>
> The reason there's no I-D stating that is that it's....well...obvious and
> requires no special provisioning or considerations for interoperability....
>