Subject: [manet] A proposal - differentiating the document and the protocol

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 2 Nov 2012 11:16:44 +0000

Before making a proposal, I'm going to introduce a distinction here between the DYMO and LOADng documents and protocols.

I'm of the opinion that the LOADng document is a greatly superior presentation to the DYMO document. (I'm not really interested in why that has come about.)

I think that regardless of whether one makes design decisions favouring DYMO or LOADng where they differ - and let's not forget they overlap a lot - it would actually be easier to modify the LOADng document to specify DYMO than it would be to modify the DYMO document to achieve that. And in practice I think if making decisions it is unlikely that all would favour DYMO over LOADng.

So what I think would be best for the WG is not a simply "option 1" or even (as it may appear I'm suggesting, but  I'm not) "option 2" but rather to agree to take the LOADng document, and a list of where DYMO and LOADng differ, and thrash out where they do, what the WG reactive protocol should do - either as a definite choice, or as an option (but not too many options please- and some could be separate specifications).

This would not of course be LOADng, so we'd have to change the document name. And there I suggest we have a candidate name - AODVv2. (Which is why I have recently taken to saying DYMO when referring to that document.) After all, the one thing we are agreed on is that the protocol being developed is derived from AODV.

The editors of this new document would have to agree that what goes in it is WG consensus (which should follow proper technical consideration of the issues). If they found it impossible to have other than their way to do things, they'd have to move on. If that left no one editing it, obviously we don't have a consensus of people prepared to do the work and option 3 would win.

So now I'm partly off the fence I've been sitting on. But only partly. I haven't yet formed a view on e.g. should this AODVv2 have IRREPs as standard, IRREPs as an option in the main draft, IRREPs as a separate draft option, no IRREPs. I'd like to move on to those discussions.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Teco Boot <[email-masked]>
Date: Fri, 2 Nov 2012 13:04:41 +0100

This is more or less what I suggested before, perhaps not as clearly as Chris. I suggested to use the manet-dymo document track. We don't have to, but I do not see any argument for renaming.

But first, let's get in a cooperative mode. I kindly ask al to cool down a bit. Seen the energy on this list, my conclusion is that we all want a great reactive MANET protocol as proposed standard.

Teco

Op 2 nov. 2012, om 12:16 heeft Dearlove, Christopher (UK) het volgende geschreven:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 2 Nov 2012 12:11:45 +0000

As I said, I think the LOADng document will be much easier to adapt.

Two comments there. First, it's odd reading that document, which I'm not an author of, as large amounts feel like I did write them. That is of course because it borrows the style of OLSRv2/NHDP, in turn adopted from (but improved on) that on RFC 3626.

Second, is that a good style? Well, I would refer you to Barry Leiba's comments on OLSRv2 in the ID tracker as it goes through the IESG. It even got a YES (not just a no objection)  from him on that account.

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 02 November 2012 12:05
To: Dearlove, Christopher (UK)
Cc: [email-masked]
Subject: Re: [manet] A proposal - differentiating the document and the protocol

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Teco

---

From: Emmanuel Baccelli <[email-masked]>
Date: Fri, 2 Nov 2012 13:11:27 +0100

Hi Chris,
I'm a bit of an outsider on this discussion, and I must admit I have not
read the latest competing documents (I plan on doing that over the
weekend). I therefore cannot claim yet I support your offer (or not).
But let me however say that I definitely support a down-to-earth,
technically-focused approach to go forward with the consensus
standards-track reactive protocol MANET is supposed to deliver. And I think
your proposal complies with such requirements - already a good start.
Cheers,
Emmanuel

But if your basic assumptions are correct (concerning document
readability), and if we

On Fri, Nov 2, 2012 at 12:17 PM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> Before making a proposal, I'm going to introduce a distinction here
> between the DYMO and LOADng documents and protocols.
>
> I'm of the opinion that the LOADng document is a greatly superior
> presentation to the DYMO document. (I'm not really interested in why that
> has come about.)
>
> I think that regardless of whether one makes design decisions favouring
> DYMO or LOADng where they differ - and let's not forget they overlap a lot
> - it would actually be easier to modify the LOADng document to specify DYMO
> than it would be to modify the DYMO document to achieve that. And in
> practice I think if making decisions it is unlikely that all would favour
> DYMO over LOADng.
>
> So what I think would be best for the WG is not a simply "option 1" or
> even (as it may appear I'm suggesting, but  I'm not) "option 2" but rather
> to agree to take the LOADng document, and a list of where DYMO and LOADng
> differ, and thrash out where they do, what the WG reactive protocol should
> do - either as a definite choice, or as an option (but not too many options
> please- and some could be separate specifications).
>
> This would not of course be LOADng, so we'd have to change the document
> name. And there I suggest we have a candidate name - AODVv2. (Which is why
> I have recently taken to saying DYMO when referring to that document.)
> After all, the one thing we are agreed on is that the protocol being
> developed is derived from AODV.
>
> The editors of this new document would have to agree that what goes in it
> is WG consensus (which should follow proper technical consideration of the
> issues). If they found it impossible to have other than their way to do
> things, they'd have to move on. If that left no one editing it, obviously
> we don't have a consensus of people prepared to do the work and option 3
> would win.
>
> So now I'm partly off the fence I've been sitting on. But only partly. I
> haven't yet formed a view on e.g. should this AODVv2 have IRREPs as
> standard, IRREPs as an option in the main draft, IRREPs as a separate draft
> option, no IRREPs. I'd like to move on to those discussions.
>
> --
> Christopher Dearlove

---

From: Teco Boot <[email-masked]>
Date: Fri, 2 Nov 2012 13:30:03 +0100

(document track: the history of ietf-manet-dymo).
I suggested in my posting, dd 16 oktober, to use draft-ietf-manet-dymo-23 as placeholder for an updated text coming from the LOADng corner. I expected more that just s/LLN/MANET/. And I expected some cooperation. I still do.

There is nothing wrong to have the same document format for both our core protocols. In the contrary !

Teco

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 2 Nov 2012 12:35:52 +0000

I just wanted to point out I'm familiar with the LOADng style. But that is not why I say it is a superior presentation, or why I say it's a better starting point - even for DYMO. I've got a lot of ink on a paper copy of dymo-23 that convinced me of that.

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 02 November 2012 12:30
To: Dearlove, Christopher (UK)
Cc: [email-masked]
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Teco

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 2 Nov 2012 12:43:37 +0000

We always SHOULD be in cooperative mode with our WG drafts and avoid
interrupts from other drafts

AB

On Fri, Nov 2, 2012 at 12:04 PM, Teco Boot <[email-masked]> wrote:

> This is more or less what I suggested before, perhaps not as clearly as
> Chris. I suggested to use the manet-dymo document track. We don't have to,
> but I do not see any argument for renaming.
>
> But first, let's get in a cooperative mode. I kindly ask al to cool down a
> bit. Seen the energy on this list, my conclusion is that we all want a
> great reactive MANET protocol as proposed standard.
>
> Teco
>
>
> > The editors of this new document would have to agree that what goes in
> it is WG consensus (which should follow proper technical consideration of
> the issues). If they found it impossible to have other than their way to do

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 2 Nov 2012 12:52:29 +0000

Hi Chris,

I always thought that LOADng is different than AODVv2 in deployments but
similar in documentations, that is why the LOADng document SHOULD be
modified, it should represent the real deployment specification and
applicability. Usually it is required by the IETF that all standard
protocol document present a section for *Applicability*, I think this will
be the main difference between DYMO/AODVv2 and LOADng documents. I don't
like to take sides for our assigned work flow, because in the end we are
working for the WG progress works (DYMO not LOADng docs).

I will provide my review on differences without showing
advantages/disadvantages, because in the end we want all a reactive
protocol to become standard as soon as possible without delays.

Abdussalam Baryun
University of Glamorgan, UK

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 2 Nov 2012 12:56:57 +0000

I have no objection for your recommend process for the dymo work flow, as
long as we don't change the I-D's abstract and aim.

AB

On Fri, Nov 2, 2012 at 12:30 PM, Teco Boot <[email-masked]> wrote:

> I suggested in my posting, dd 16 oktober, to use draft-ietf-manet-dymo-23
> as placeholder for an updated text coming from the LOADng corner. I
> expected more that just s/LLN/MANET/. And I expected some cooperation. I
> still do.
>
> > Two comments there. First, it's odd reading that document, which I'm not
> an author of, as large amounts feel like I did write them. That is of
> course because it borrows the style of OLSRv2/NHDP, in turn adopted from
> (but improved on) that on RFC 3626.
> >
> > Second, is that a good style? Well, I would refer you to Barry Leiba's
> comments on OLSRv2 in the ID tracker as it goes through the IESG. It even
> got a YES (not just a no objection)  from him on that account.
> >
> > --
> > Christopher Dearlove
> > But first, let's get in a cooperative mode. I kindly ask al to cool down
> a bit. Seen the energy on this list, my conclusion is that we all want a
> >> So now I'm partly off the fence I've been sitting on. But only partly.
> I haven't yet formed a view on e.g. should this AODVv2 have IRREPs as

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Nov 2012 07:41:49 -0700

Dear Chris,

personally, what you propose makes sense to me. 

Regards
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 2 Nov 2012 16:17:19 +0000

Hi Ulrich,

I think that Chris's proposal was not accepted by LOADng co-authors as I
understood from following up the WG history (they don't agree to change the
name of protocol). As you are one co-author do I understand that you
support the Chris's proposal,
AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 2 Nov 2012 16:24:28 +0000

Does All WG, support the proposal stating:

Chris>This would not of course be LOADng, so we'd have to change the
document name. And there I suggest we have a candidate name - AODVv2.
(Which is why I have recently taken to saying DYMO when referring to that
document.) After all, the one thing we are agreed on is that the protocol
being developed is derived from AODV.
I hope we can agree on the above suggestion to go forward,

Regards
AB

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 16:30:45 +0000

> This would not of course be LOADng, so we'd have to change the document name. And there I suggest we have a candidate name - AODVv2. (Which is why I have recently taken to saying DYMO when referrin…

JP> I would be extremely supportive of this, just do the reverse BUT we would end up with the same results:
* Take the DYMO document
* Change the name to AODVv2
* List where both protocol differ
* Use options when required.

I think that this is also what Charlie proposed.

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 16:32:20 +0000

On Nov 2, 2012, at 1:04 PM, Teco Boot wrote:

> This is more or less what I suggested before, perhaps not as clearly as Chris. I suggested to use the manet-dymo document track.

JP> Same here, agree.

> We don't have to, but I do not see any argument for renaming.
> 

JP> There seems to be so much sensitivity … renaming would help a lot there.

> But first, let's get in a cooperative mode. I kindly ask al to cool down a bit. Seen the energy on this list, my conclusion is that we all want a great reactive MANET protocol as proposed standard.

JP> Indeed.

Thanks,.

JP.

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 16:33:20 +0000

> As I said, I think the LOADng document will be much easier to adapt.

JP> I had the opposite feeling and … DYMO is the MANET WG document too.

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Nov 2012 09:34:22 -0700

Hi Abdussalam,

there was indeed some hesitance to change the name from some of the authors
(not me). I cannot speak for them here. My intuition is that if the name of
the protocol is the only factor that avoids the reactive protocol from
proceeding in the WG, this can be solved.

As far as I can see from the discussions so far, there is a clear consensus
that option 3 is not viable. Now, if we want to proceed with the reactive
document, the question is from which document to start. Chris mentioned
that even if we wanted the specification of 100%, it would be far quicker
to start from the LOADng draft. I propose that we can start working based
on the LOADng draft (possibly rename it?), look at each item that is in
DYMO and consider whether and in which way it should be incorporated in the
draft.

Best
Ulrich

On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun <
[email-masked]> wrote:

> On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg <[email-masked]>wrote:
>
>> Dear Chris,
>>

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Nov 2012 09:37:33 -0700

typo...

On Fri, Nov 2, 2012 at 9:34 AM, Ulrich Herberg <[email-masked]> wrote:

> [...]Chris mentioned that even if we wanted the specification of 100%, it
> would be far quicker to start from the LOADng draft. [...]
>

"100% DYMO"

---

From: Jon Black <[email-masked]>
Date: Fri, 2 Nov 2012 09:58:16 -0700 (PDT)

I agree that from reading both documents it would make much more sense to start with the LOADng draft and enhance it with the items from DYMO that the working group feel are necessary.

The LOADng draft seems like a much better basis to start from.  I don't see why Charlie and group can't start with LOADng as the base.

Jon

________________________________
 From: "Dearlove, Christopher (UK)" <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Friday, November 2, 2012 5:16 AM
Subject: [manet] A proposal - differentiating the document and the protocol

---

From: Jon Black <[email-masked]>
Date: Fri, 2 Nov 2012 10:01:21 -0700 (PDT)

It does have a good style, clear, clean and distinct (as does OLSRv2).  It is something that I can read and start to implement.  I can't say the same for the DYMO draft in its current state.

Jon

________________________________
 From: "Dearlove, Christopher (UK)" <[email-masked]>
To: Teco Boot <[email-masked]> 
Cc: "[email-masked]" <[email-masked]> 
Sent: Friday, November 2, 2012 6:11 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 02 November 2012 12:05
To: Dearlove, Christopher (UK)
Cc: [email-masked]
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Teco

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 17:10:48 +0000

On Nov 2, 2012, at 12:24 PM, Abdussalam Baryun wrote:

Chris>This would not of course be LOADng, so we'd have to change the document name. And there I suggest we have a candidate name - AODVv2. (Which is why I have recently taken to saying DYMO when referring to that document.) After all, the one thing we are agreed on is that the protocol being developed is derived from AODV.
I hope we can agree on the above suggestion to go forward,

I would but starting with DYMO as the base document and go from there, which is I think that Charlie proposed.

Thanks.

JP.

Regards
AB

On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg <[email-masked]<mailto:[email-masked]>> wrote:
Dear Chris,

Regards
Ulrich

On Nov 2, 2012, at 4:16, "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>> wrote:

> Tel: +44 1245 242194<tel:%2B44%201245%20242194> |  Fax: +44 1245 242124<tel:%2B44%201245%20242124>
> [email-masked]<mailto:[email-masked]> | http://www.baesystems.com<http://www.baesystems.com/>
>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 17:13:07 +0000

Hi,

On Nov 2, 2012, at 12:34 PM, Ulrich Herberg wrote:

Hi Abdussalam,

there was indeed some hesitance to change the name from some of the authors (not me). I cannot speak for them here. My intuition is that if the name of the protocol is the only factor that avoids the reactive protocol from proceeding in the WG, this can be solved.

JP> I do not think that this is the only issue … applicability and use of existing mechanisms in DYMO (potentially marked as optional is another one).

As far as I can see from the discussions so far, there is a clear consensus that option 3 is not viable.

JP> Not sure … I hope that you are right. I guess that option 3 would be the result of a lack of consensus between 1 and 2 *but* I cannot
speak for the chairs.

Now, if we want to proceed with the reactive document, the question is from which document to start. Chris mentioned that even if we wanted the specification of 100%, it would be far quicker to start from the LOADng draft. I propose that we can start working based on the LOADng draft (possibly rename it?), look at each item that is in DYMO and consider whether and in which way it should be incorporated in the draft.

JP> And I propose the opposite … We're back to the original question.

Thanks.

JP.

Best
Ulrich

On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ulrich,

I think that Chris's proposal was not accepted by LOADng co-authors as I understood from following up the WG history (they don't agree to change the name of protocol). As you are one co-author do I understand that you support the Chris's proposal,
AB
On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg <[email-masked]<mailto:[email-masked]>> wrote:
Dear Chris,

Regards
Ulrich

---

From: Jon Black <[email-masked]>
Date: Fri, 2 Nov 2012 10:16:27 -0700 (PDT)

This seems to make good sense.  The name should not be issue.  We need a good solid base to start from.  It would appear that if there are working interoperable implementation based on the LOADng draft then this indicates that the draft is implementable.  Again, having read both I could build something based on the LOADng draft and I (and I'm only talking for me) couldn't based on the DYMO draft.

I much prefer starting with something simple and understandable and adding what is missing rather than starting with something more difficult to understand trying to remove things that are not needed.

Jon

________________________________
 From: Ulrich Herberg <[email-masked]>
To: Abdussalam Baryun <[email-masked]> 
Cc: "Dearlove, Christopher (UK)" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Friday, November 2, 2012 10:34 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Hi Abdussalam,

As far as I can see from the discussions so far, there is a clear consensus that option 3 is not viable. Now, if we want to proceed with the reactive document, the question is from which document to start. Chris mentioned that even if we wanted the specification of 100%, it would be far quicker to start from the LOADng draft. I propose that we can start working based on the LOADng draft (possibly rename it?), look at each item that is in DYMO and consider whether and in which way it should be incorporated in the draft. 

Best
Ulrich

On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun <[email-masked]> wrote:

Hi Ulrich,

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 17:16:56 +0000

Jon,

You did not reply to my former email - will you be in Atlanta to have a technical discussion based on our email exchanges ?

Thanks.

JP.

On Nov 2, 2012, at 12:58 PM, Jon Black wrote:

Jon

________________________________
From: "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 2, 2012 5:16 AM
Subject: [manet] A proposal - differentiating the document and the protocol

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 17:21:01 +0000

so … should we start with a completely new document then ?

On Nov 2, 2012, at 1:16 PM, Jon Black wrote:

Jon

________________________________
From: Ulrich Herberg <[email-masked]<mailto:[email-masked]>>
To: Abdussalam Baryun <[email-masked]<mailto:[email-masked]>>
Cc: "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 2, 2012 10:34 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

On Nov 2, 2012, at 4:16, "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>> wrote:

> Tel: +44 1245 242194<x-msg://242/> |  Fax: +44 1245 242124<x-msg://242/>

---

From: Christopher Dearlove <[email-masked]>
Date: Fri, 2 Nov 2012 18:02:56 +0000

However the LOADng document is much better written, and a much better starting point.

-- 
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 18:11:13 +0000

I think different (this is fine !).

Cheers.

JP.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 02 Nov 2012 11:58:27 -0700

Hello folks,

I am trying to finish a new revision to the existing DYMO document to
make the RFC 5444 compliance, improve terminology, and repair some
other things which didn't get done because I ran out of time before the
I-D submission deadline.   It is my belief that if the WG document is in
good shape, it will make for a much clearer way forward.

I want to respond to the comments, but insofar as the WG document
has editorial errors, I want to make it clear that I am committed to
fixing them as a very high priority.

The value of "quicker" depends a lot on the desired result.  There is an
obvious "extreme" case where we publish a document which really
serves a very restricted case (say, only three nodes).  That could be
done in a matter of days, I guess.  I do not mean that the LOADng
document is anywhere near that restrictive, but that the argument
has to be taken in context.  Moreover, I would like to point out that
the same urgency was expressed to me last year about this time,
and at that time the intention was to persuade me that the metric
for "weak links" could not be changed.  In the meantime, I am happy
to report that that metric has now been removed.

Since the existing WG document is targeted at a greater scope of
applicabililty than the LOADng, if we can get the existing WG document
published with expedient and priority effort then it seems we would
achieve a much more worthy goal -- all the while offering LOADng
compatibility for the metering applications under current discussion.

Regards,
Charlie P.

On 11/2/2012 9:34 AM, Ulrich Herberg wrote:
> Hi Abdussalam,
>
> there was indeed some hesitance to change the name from some of the 
> authors (not me). I cannot speak for them here. My intuition is that 
> if the name of the protocol is the only factor that avoids the 
> reactive protocol from proceeding in the WG, this can be solved.
>
> As far as I can see from the discussions so far, there is a clear 
> consensus that option 3 is not viable. Now, if we want to proceed with 
> the reactive document, the question is from which document to start. 
> Chris mentioned that even if we wanted the specification of 100%, it 
> would be far quicker to start from the LOADng draft. I propose that we 
> can start working based on the LOADng draft (possibly rename it?), 
> look at each item that is in DYMO and consider whether and in which 
> way it should be incorporated in the draft.
>
> Best
> Ulrich
>
>
>
> On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi Ulrich,
>     I think that Chris's proposal was not accepted by LOADng
>     co-authors as I understood from following up the WG history (they
>     don't agree to change the name of protocol). As you are one
>     co-author do I understand that you support the Chris's proposal,
>     AB
>     On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Dear Chris,
>
>         On Nov 2, 2012, at 4:16, "Dearlove, Christopher (UK)"
>         <[email-masked]
>         <mailto:[email-masked]>> wrote:
>
>         > Before making a proposal, I'm going to introduce a
>         distinction here between the DYMO and LOADng documents and
>         protocols.
>         >
>         > I'm of the opinion that the LOADng document is a greatly
>         superior presentation to the DYMO document. (I'm not really
>         interested in why that has come about.)
>         >
>         > I think that regardless of whether one makes design
>         decisions favouring DYMO or LOADng where they differ - and
>         let's not forget they overlap a lot - it would actually be
>         easier to modify the LOADng document to specify DYMO than it
>         would be to modify the DYMO document to achieve that. And in
>         practice I think if making decisions it is unlikely that all
>         would favour DYMO over LOADng.
>         >
>         > So what I think would be best for the WG is not a simply
>         "option 1" or even (as it may appear I'm suggesting, but  I'm
>         not) "option 2" but rather to agree to take the LOADng
>         document, and a list of where DYMO and LOADng differ, and
>         thrash out where they do, what the WG reactive protocol should
>         do - either as a definite choice, or as an option (but not too
>         many options please- and some could be separate specifications).
>         >
>         > This would not of course be LOADng, so we'd have to change
>         the document name. And there I suggest we have a candidate
>         name - AODVv2. (Which is why I have recently taken to saying
>         DYMO when referring to that document.) After all, the one
>         thing we are agreed on is that the protocol being developed is
>         derived from AODV.
>         >
>         > The editors of this new document would have to agree that
>         what goes in it is WG consensus (which should follow proper
>         technical consideration of the issues). If they found it
>         impossible to have other than their way to do things, they'd
>         have to move on. If that left no one editing it, obviously we
>         don't have a consensus of people prepared to do the work and
>         option 3 would win.
>         >
>         > So now I'm partly off the fence I've been sitting on. But
>         only partly. I haven't yet formed a view on e.g. should this
>         AODVv2 have IRREPs as standard, IRREPs as an option in the
>         main draft, IRREPs as a separate draft option, no IRREPs. I'd
>         like to move on to those discussions.
>         >
>         > --
>         > Christopher Dearlove
>         > Tel: +44 1245 242194 <tel:%2B44%201245%20242194> |  Fax: +44
>         1245 242124 <tel:%2B44%201245%20242124>
>         > [email-masked]
>         <mailto:[email-masked]> | http://www.baesystems.com
>         >
>         > Registered Office: Warwick House, PO Box 87, Farnborough
>         Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
>         > [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>

-- 
Regards,
Charlie P.

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Fri, 2 Nov 2012 19:12:55 +0000

This a great news - see in line

On Nov 2, 2012, at 2:58 PM, Charles E. Perkins wrote:

Hello folks,

I cannot agree more.

Thanks.

JP.

Regards,
Charlie P.

Best
Ulrich

Regards
Ulrich

--
Regards,
Charlie P.

---

From: Daniel He <[email-masked]>
Date: Fri, 2 Nov 2012 20:25:20 +0000

I also agree with Chris. If we have a solid draft like LOADng already, why
we cann't reuse it
as a start point. I saw both drafts were derivated from AODV and LOADng has
progressed
somehow in security mechanism although it is not perfect and I view it is
too overhead to
insure end-to-end security at routing level. DYMO has certainly not
progressed that much
although we can trust Charlie for his reputation work and he has ability to
make his reactive
routing protocol progress.

The question seems to me whether we start to work on LOADng or start to
work on DYMO
to make this discussion move forward. What is the advantage and
disadvantage to do so?
Any risk or how much work needs to be done before we can possibly establish
a solid draft?

Cheers,
Dan

-- 
Dan He
---------------------
Tel: +44-788-686-3428

---

From: Jon Black <[email-masked]>
Date: Fri, 2 Nov 2012 13:37:15 -0700 (PDT)

From: JP Vasseur (jvasseur) <[email-masked]>

[Jon] I hardly think that we would end up with the same results.  Adding required and necessary improvements to a good base is significantly faster and easier than trying to understand and remove unnecessary concepts, features, ...

Jon

---

From: Jon Black <[email-masked]>
Date: Fri, 2 Nov 2012 14:10:53 -0700 (PDT)

It is not completely new and it is much more mature.  It has been being developed for quite some time, it has implementations, it has interoperability.  Age of a document is not a good criteria.  Something can be written quite a long time ago and nothing done on it.  Another document/protocol may come along, gain critical mass, gain experience and even though younger may be a much better starting point.

Jon

________________________________
 From: JP Vasseur (jvasseur) <[email-masked]>
To: Jon Black <[email-masked]>; Ulrich Herberg <[email-masked]>; Abdussalam Baryun <[email-masked]>; "Dearlove, Christopher (UK)" <[email-masked]>; "[email-masked] List" <[email-masked]> 
Sent: Friday, November 2, 2012 11:21 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

>>>> I think that regardless of whether one makes design decisions favouring DYMO or LOADng where they differ - and let's not forget they overlap a lot - it would actually be easier to modify the LOADng document to specify DYMO than it would be to modify the DYMO
 document to achieve that. And in practice I think if making decisions it is unlikely that all would favour DYMO over LOADng.
>>>>
>>>> So what I think would be best for the WG is not a simply "option 1" or even (as it may appear I'm suggesting, but  I'm not) "option 2" but rather to agree to take the LOADng document, and a list of where DYMO and LOADng differ, and thrash out where they do,
 what the WG reactive protocol should do - either as a definite choice, or as an option (but not too many options please- and some could be separate specifications).
>>>>
>>>> This would not of course be LOADng, so we'd have to change the document name. And there I suggest we have a candidate name - AODVv2. (Which is why I have recently taken to saying DYMO when referring to that document.) After all, the one thing we are agreed
 on is that the protocol being developed is derived from AODV.
>>>>
>>>> The editors of this new document would have to agree that what goes in it is WG consensus (which should follow proper technical consideration of the issues). If they found it impossible to have other than their way to do things, they'd have to move on. If
 that left no one editing it, obviously we don't have a consensus of people prepared to do the work and option 3 would win.

---

From: C Chauvenet <[email-masked]>
Date: Fri, 2 Nov 2012 22:41:38 +0000

Hi all,

If we add mechanisms to LOADng or prune some from DYMO, we end up with a different protocol, so I think that we will need to change the name of the resulting protocol. I support the AODVv2 naming for the reactive protocol of MANET, if chairs decide to go forward and do not take option 3).

It seems that charlie is working hard on updating the DYMO draft, by addressing reviews of the document. These reviews contains most of the improvements (readability, RFC5444 compliance ....) that people found missing in DYMO. I think that would make sense to wait for the next update of DYMO before choosing between LOADng and DYMO. I think that the WG want something good, rather than something quick.
In addition, we would benefit from the work that charlie is currently doing, rather that skip it if we made a decision based on the actual DYMO version.

Cédric.

Le 2 nov. 2012 à 22:10, Jon Black a écrit :

Jon

________________________________
From: JP Vasseur (jvasseur) <[email-masked]<mailto:[email-masked]>>
To: Jon Black <[email-masked]<mailto:[email-masked]>>; Ulrich Herberg <[email-masked]<mailto:[email-masked]>>; Abdussalam Baryun <[email-masked]<mailto:[email-masked]>>; "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]> List" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 2, 2012 11:21 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Jon

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

On Nov 2, 2012, at 4:16, "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>> wrote:

> Tel: +44 1245 242194<x-msg://3114/> |  Fax: +44 1245 242124<x-msg://3114/>

---

From: C Chauvenet <[email-masked]>
Date: Fri, 2 Nov 2012 23:31:25 +0000

One thing that popped up in my mind :

Are we trying to do the merge between DYMO and LOADng that has previously failed ??

Regardless from which document we start, I understood (from Charlie massages) that LOADng authors were not OK to merge their document with functionalities from DYMO . Did I missed something here ?

Cédric.

Le 2 nov. 2012 à 23:41, C Chauvenet a écrit :

Hi all,

Cédric.

Jon

Jon

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Nov 2012 16:45:00 -0700

Cédric,

the merge did not fail for technical but for process reasons. We offered
Charlie to be editor, together with Thomas. Charlie is already author of
LOADng. In my opinion (I can't speak for anyone else), that has not
changed.
If we start the merge from the LOADng document, we would be far quicker to
come to an RFC. As said, we can then look at each option, see if it's
suitable or not, and if it should be part of the core or rather be in a
companion document.

Best
Ulrich

On Fri, Nov 2, 2012 at 4:31 PM, C Chauvenet <[email-masked]> wrote:

>  Regardless from which document we start, I understood (from Charlie
> massages) that LOADng authors were not OK to merge their document with
> functionalities from DYMO . Did I missed something here ?
>
>  Cédric.
>
>  If we add mechanisms to LOADng or prune some from DYMO, we end up with a
> different protocol, so I think that we will need to change the name of the
> resulting protocol. I support the AODVv2 naming for the reactive protocol
> of MANET, if chairs decide to go forward and do not take option 3).
>
>  It seems that charlie is working hard on updating the DYMO draft, by
> addressing reviews of the document. These reviews contains most of the
> improvements (readability, RFC5444 compliance ....) that people found
> missing in DYMO. I think that would make sense to wait for the next update
> of DYMO before choosing between LOADng and DYMO. I think that the WG want
> something good, rather than something quick.
> In addition, we would benefit from the work that charlie is currently
> doing, rather that skip it if we made a decision based on the actual DYMO
> version.
>
>  Cédric.
>
>   It is not completely new and it is much more mature.  It has been being
> developed for quite some time, it has implementations, it has
> interoperability.  Age of a document is not a good criteria.  Something can
> be written quite a long time ago and nothing done on it.  Another
> document/protocol may come along, gain critical mass, gain experience and
> even though younger may be a much better starting point.
>
> Jon
>
>   ------------------------------
> *From:* JP Vasseur (jvasseur) <[email-masked]>
> *To:* Jon Black <[email-masked]>; Ulrich Herberg <
> [email-masked]>; Abdussalam Baryun <[email-masked]>;
> "Dearlove, Christopher (UK)" <[email-masked]>; "
> [email-masked] List" <[email-masked]>
> *Sent:* Friday, November 2, 2012 11:21 AM
> *Subject:* Re: [manet] A proposal - differentiating the document and the
> protocol
>
>   This seems to make good sense.  The name should not be issue.  We need
> a good solid base to start from.  It would appear that if there are working
> interoperable implementation based on the LOADng draft then this indicates
> that the draft is implementable.  Again, having read both I could build
> something based on the LOADng draft and I (and I'm only talking for me)
> couldn't based on the DYMO draft.
>
> I much prefer starting with something simple and understandable and adding
> what is missing rather than starting with something more difficult to
> understand trying to remove things that are not needed.
>
> Jon
>
>
>   ------------------------------
> *From:* Ulrich Herberg <[email-masked]>
> *To:* Abdussalam Baryun <[email-masked]>
> *Cc:* "Dearlove, Christopher (UK)" <[email-masked]>; "
> [email-masked]" <[email-masked]>
> *Sent:* Friday, November 2, 2012 10:34 AM
> *Subject:* Re: [manet] A proposal - differentiating the document and the
> protocol
>
> Hi Abdussalam,
>
> authors (not me). I cannot speak for them here. My intuition is that if the
> name of the protocol is the only factor that avoids the reactive protocol
> from proceeding in the WG, this can be solved.
>
> consensus that option 3 is not viable. Now, if we want to proceed with the
> reactive document, the question is from which document to start. Chris
> mentioned that even if we wanted the specification of 100%, it would be far
> quicker to start from the LOADng draft. I propose that we can start working
> based on the LOADng draft (possibly rename it?), look at each item that is
> in DYMO and consider whether and in which way it should be incorporated in
> the draft.
>
>  Best
> Ulrich
>
>
>

---

From: Jiazi YI <[email-masked]>
Date: Sat, 3 Nov 2012 00:45:30 +0100

Hi Cedric, 

The LOADng always welcome good ideas from DYMO if it can help improving the protocol. 
But Charlie insists starting from DYMO. 
What I believe is that, the WG should begin with the document in better shape, as suggested by Chris. 

best

Jiazi

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 3 Nov 2012 08:26:26 +0000

Hi Cedrix,

Completely agreeing with you; this is what I called option 1+.

Thanks.

JP.

On Nov 2, 2012, at 6:41 PM, C Chauvenet wrote:

Hi all,

Cédric.

Jon

Jon

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 3 Nov 2012 08:35:05 +0000

I was about to ask the same question … merge did not happen for a number of reasons (that I do not all know by the way), thus the questions
from the chairs. I fail to understand why we cannot start from the WG document (result of years of work) and quickly improve it. By the way, as
a reminder, I'd rather do the right thing that rushing out.

On Nov 2, 2012, at 7:45 PM, Ulrich Herberg wrote:

Cédric,

the merge did not fail for technical but for process reasons. We offered Charlie to be editor, together with Thomas. Charlie is already author of LOADng. In my opinion (I can't speak for anyone else), that has not changed.
If we start the merge from the LOADng document, we would be far quicker to come to an RFC. As said, we can then look at each option, see if it's suitable or not, and if it should be part of the core or rather be in a companion document.

Best
Ulrich

On Fri, Nov 2, 2012 at 4:31 PM, C Chauvenet <[email-masked]<mailto:[email-masked]>> wrote:
One thing that popped up in my mind :

Cédric.

Hi all,

Cédric.

Jon

Jon

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 3 Nov 2012 08:36:57 +0000

Hi,

On Nov 2, 2012, at 7:45 PM, Jiazi YI wrote:

Hi Cedric,

I cannot speak for Charlie, but you may not have missed that many of this list insist on starting with the WG document
and welcome improvements. I seriously do not think that one can chime in with an individual submission, claim that the
WG document is not good and strongly request to replace it by they document. This is ignoring years of excellent work
from a WG.

best

Jiazi

On Nov 3, 2012, at 12:31 AM, C Chauvenet <[email-masked]<mailto:[email-masked]>> wrote:

Cédric.

Hi all,

Cédric.

Jon

Jon

Hi Abdussalam,

Best
Ulrich

Regards
Ulrich

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 3 Nov 2012 04:27:39 -0500 (CDT)

> I think that would make sense to wait for the next update of DYMO before choosing between LOADng and DYMO. I think that the WG want something good, rather than something quick.  

I totally agree.

Thanks
Mukul

----- Original Message -----
From: "JP Vasseur (jvasseur)" <[email-masked]>
To: "C Chauvenet" <[email-masked]>
Cc: "Christopher Dearlove (UK)" <[email-masked]>, "[email-masked] List" <[email-masked]>
Sent: Saturday, November 3, 2012 3:26:26 AM
Subject: Re: [manet] A proposal - differentiating the document and        the        protocol

Hi Cedrix, 

Thanks. 

JP. 

Hi all,  

Cédric. 

Jon 

From: JP Vasseur (jvasseur) < [email-masked] > 
To: Jon Black < [email-masked] >; Ulrich Herberg < [email-masked] >; Abdussalam Baryun < [email-masked] >; "Dearlove, Christopher (UK)" < [email-masked] >; " [email-masked] List" < [email-masked] > 
Sent: Friday, November 2, 2012 11:21 AM 
Subject: Re: [manet] A proposal - differentiating the document and the protocol 

Jon 

From: Ulrich Herberg < [email-masked] > 
To: Abdussalam Baryun < [email-masked] > 
Cc: "Dearlove, Christopher (UK)" < [email-masked] >; " [email-masked] " < [email-masked] > 
Sent: Friday, November 2, 2012 10:34 AM 
Subject: Re: [manet] A proposal - differentiating the document and the protocol 

Hi Abdussalam, 

Best 
Ulrich 

On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun < [email-masked] > wrote: 

Hi Ulrich, 

AB 

On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg < [email-masked] > wrote: 

Dear Chris, 

Regards 
Ulrich

---

From: Christopher Dearlove <[email-masked]>
Date: Sat, 3 Nov 2012 11:07:06 +0000

Sunk cost fallacy. It's not important how much work was spent on a document. What matters is what state the document is in.

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 3 Nov 2012 11:16:06 +0000

So lets wait a bit and decide without rush.

JP Vasseur
Cisco Fellow

Sent from my iPhone

On 3 nov. 2012, at 12:07, "Christopher Dearlove" <[email-masked]<mailto:[email-masked]>> wrote:

--
Christopher Dearlove
[email-masked]<mailto:[email-masked]> (iPhone)
[email-masked]<mailto:[email-masked]> (home)

On 3 Nov 2012, at 08:36, "JP Vasseur (jvasseur)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Hi Cedric,

best

Jiazi

On Nov 3, 2012, at 12:31 AM, C Chauvenet <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

Cédric.

Hi all,

Cédric.

Jon

________________________________
From: JP Vasseur (jvasseur) <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
To: Jon Black <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>; Ulrich Herberg <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>; Abdussalam Baryun <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>; "Dearlove, Christopher (UK)" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>; "<mailto:[email-masked]>[email-masked]<mailto:[email-masked]> List" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 2, 2012 11:21 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Jon

________________________________
From: Ulrich Herberg <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
To: Abdussalam Baryun <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
Cc: "Dearlove, Christopher (UK)" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>; "<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 2, 2012 10:34 AM
Subject: Re: [manet] A proposal - differentiating the document and the protocol

Hi Abdussalam,

Best
Ulrich

On Fri, Nov 2, 2012 at 9:17 AM, Abdussalam Baryun <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:
Hi Ulrich,

I think that Chris's proposal was not accepted by LOADng co-authors as I understood from following up the WG history (they don't agree to change the name of protocol). As you are one co-author do I understand that you support the Chris's proposal,
AB
On Fri, Nov 2, 2012 at 2:41 PM, Ulrich Herberg <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:
Dear Chris,

Regards
Ulrich

On Nov 2, 2012, at 4:16, "Dearlove, Christopher (UK)" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

> <mailto:[email-masked]> [email-masked]<mailto:[email-masked]> | <http://www.baesystems.com/> http://www.baesystems.com
>
> <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
> <https://www.ietf.org/mailman/listinfo/manet> https://www.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/manet>https://www.ietf.org/mailman/listinfo/manet

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 3 Nov 2012 06:18:23 -0500 (CDT)

Give Charlie a chance! It is not too hard, esp for some one lie Charlie, to significantly improve a document's readability etc. in one edit cycle.

Thanks
Mukul

----- Original Message -----
From: "Christopher Dearlove" <[email-masked]>
To: "JP Vasseur (jvasseur)" <[email-masked]>
Cc: "Axel Colin de Verdière" <[email-masked]>, "[email-masked] List" <[email-masked]>
Sent: Saturday, November 3, 2012 6:07:06 AM
Subject: Re: [manet] A proposal - differentiating the document and	the	protocol

On 3 Nov 2012, at 08:36, "JP Vasseur (jvasseur)" < [email-masked] > wrote: 

Hi, 

Hi Cedric,  

best 

Jiazi 

On Nov 3, 2012, at 12:31 AM, C Chauvenet < [email-masked] > wrote: 

Cédric. 

Hi all,  

Cédric. 

Jon 

Jon 

Hi Abdussalam, 

Best 
Ulrich 

Hi Ulrich, 

AB 

Dear Chris, 

Regards 
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 4 Nov 2012 13:43:26 +0100

I agree to focus on our work flow and give the priority/chance to the
WG documents to process its progress without interrupts. There was no
announcements of interrupts authority, there is no reason to rush nor
to kill this valuable WG item. I agree to give chance to authors of
Dymo and participants to make this WG draft better for progress (not
later than 3 months).

AB

On 11/3/12, Mukul Goyal <[email-masked]> wrote:
> Give Charlie a chance! It is not too hard, esp for some one lie Charlie, to
> significantly improve a document's readability etc. in one edit cycle.
>
> Thanks
> Mukul
>
> Sunk cost fallacy. It's not important how much work was spent on a document.
> What matters is what state the document is in.
>
> --
> Christopher Dearlove