Subject: Re: [manet] Flooding: how to make a normative reference?

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 1 Nov 2012 15:41:10 +0000

It will be interesting to have the flooding algorithm I-D as you mentioned
so we can refer by MANET protocols, but also I support that OLSRv2 has no
need to take out such technique (as chris mentioned). However, your
suggestion will give more flexibility to AODVv2 as a MANET protocol.

I also agree that AODVv2 should not reference OLSRv2 as normative for your
mentioned reasons.

AB

On Tue, Oct 30, 2012 at 7:39 PM, Charles E. Perkins
<[email-masked]>wrote:

>
> Hello folks,
>
> I think it is well recognized that brute force flooding often leads to
> poor performance in ad hoc networks with many nodes.  Thus, we
> have RFC 6621 to describe various other approaches.  Plus, we have
> MPR flooding as described in the OLSRv2 document.
>
> For reactive, it is quite important to enable "better" algorithms
> for flooding.  AODVv2 could quite reasonable use a MPR-based
> flooding, or flooding based over any connected dominating set.
>
> It seems wrong to have AODVv2 cite OLSRv2 in any normative
> fashion, just to get access to the MPR flooding mechanism which
> can run independently of the routing protocol (and, perhaps,
> should do so).  It also seems wrong to cite RFC 6621 in any
> normative fashion since that is an Experimental specification.
>
> Don't we need to have some Proposed Standard documents that
> specify more scalable approaches to flooding, that are independent
> of routing protocols?
>
> I guess it's too late to suggest that the MPR specification should
> be pulled out of OLSRv2 for this purpose...
>
> I looked back for some discussion about this on the list, but I
> didn't find it, but my search was hardly exhaustive.
>
> --
> Regards,
> Charlie P.
>
> ______________________________**_________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/manet<https://www.ietf.org/mailman/listinfo/manet>
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 1 Nov 2012 17:20:22 +0100

You know of RFC6621, yes?

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

On 1 nov. 2012, at 16:41, Abdussalam Baryun <[email-masked]> wrote:

> It will be interesting to have the flooding algorithm I-D as you mentioned so we can refer by MANET protocols, but also I support that OLSRv2 has no need to take out such technique (as chris mentioned). However, your suggestion will give more flexibility to AODVv2 as a MANET protocol.
>  
> I also agree that AODVv2 should not reference OLSRv2 as normative for your mentioned reasons.
>  
> AB
> 
> On Tue, Oct 30, 2012 at 7:39 PM, Charles E. Perkins <[email-masked]> wrote:
>> 
>> Hello folks,
>> 
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 1 Nov 2012 18:33:50 +0000

Hi Thomas,

Ok, I understand your point, but I thought that RFC6621 is a routing
protocol not a flooding. So we can consider multicast forwarding as a
special flooding for OLSRv2-MPR, and AODVv2. I will look into it again.
thanks,

AB

On Thu, Nov 1, 2012 at 4:20 PM, Thomas Heide Clausen <[email-masked]
> wrote:

> On Tue, Oct 30, 2012 at 7:39 PM, Charles E. Perkins <[email-masked]
> > wrote:
>
>>
>> Hello folks,
>>