Subject: [manet] Management use cases for MANETs

From: Ulrich Herberg <[email-masked]>
Date: Fri, 2 Nov 2012 12:17:31 -0700

Hi [manet] participants,

I am forwarding an email from Benoit that was sent to [email-masked], since
it concerns MANET. COMAN is a new activity (not yet a WG) relating to
management of constrained devices and networks. As I mentioned at the last
IETF, Benoit cleared his DISCUSS on the NHDP-MIB if we commit to write a
document about applicability and use cases of management of MANET routers.

In COMAN, an individual ID was presented
(draft-ersue-constrained-mgmt) that discusses use cases of management. Note
that this is an early draft and will possibly be split in multiple drafts.
There is some discussion whether that should include mobility or not
(currently, MANET is excluded but mesh networks are not, which I think
needs some more discussion, as both are about dynamic topologies). Anyway,
similar to Benoit, it is unclear to me whether this draft or any work in
COMAN (if it was to become a WG) would satisfy the request for a use
case/applicability document, or if MANET should work on a separate draft.

As the next OLSRv2-MIB revision will be submitted next Monday, (which I
consider ready for WGLC) this is something we need to seriously consider.

Opinions?

Thanks
Ulrich

On Fri, Nov 2, 2012 at 4:45 AM, Benoit Claise <[email-masked]> wrote:

>  Hi,
>
> One point regarding MANET.
> I believe that it deserves its own document: "MANET network management
> considerations". Actually, when looking at draft-ietf-manet-nhdp-mib part
> of the IESG review, one of the outcome was that such a document was
> required.
> I cleared my DISCUSS on draft-ietf-manet-nhdp-mib with this COMMENT
>
> Note regarding the applicability statement: This is solved, as we
> discussed, but I'll keep this little sentence in one
> corner of my head "A fuller discussion of MANET network management use
> cases and challenges will be provided elsewhere."
>
>  How/If this "MANET network management considerations" draft relates to
> the draft-ersue-constrained-mgmt, I'm not sure at this point in time.
>
>

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Fri, 2 Nov 2012 19:46:34 +0000

Classification: UNCLASSIFIED
Caveats: NONE

Ulrich,

It was my understanding that, as you mentioned, Benoit had cleared the
discuss on the NHDP-MIB conditioned upon the working group drafting a MANET
management use case document.  I know that you and James Nguyen had
contributed some material to Mehmet's draft.  I would hope that you and
James could start to pull together a draft for the MANET WG for us to meet
our commitment to Benoit.  I would be glad to help review and comment but
prefer not to edit.

Thoughts?

Thanks, Bob

Robert G. Cole
Comm:  443.395.8744
Email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ulrich Herberg
Sent: Friday, November 02, 2012 3:18 PM
To: [email-masked]
Cc: Ersue, Mehmet (NSN - DE/Munich); Benoit Claise
Subject: [manet] Management use cases for MANETs

Hi [manet] participants,

In COMAN, an individual ID was presented (draft-ersue-constrained-mgmt) that
discusses use cases of management. Note that this is an early draft and will
possibly be split in multiple drafts. There is some discussion whether that
should include mobility or not (currently, MANET is excluded but mesh
networks are not, which I think needs some more discussion, as both are
about dynamic topologies). Anyway, similar to Benoit, it is unclear to me
whether this draft or any work in COMAN (if it was to become a WG) would
satisfy the request for a use case/applicability document, or if MANET
should work on a separate draft.

Opinions?

Thanks
Ulrich

	Hi,
	
	One point regarding MANET.
	I believe that it deserves its own document: "MANET network
management considerations". Actually, when looking at
draft-ietf-manet-nhdp-mib part of the IESG review, one of the outcome was
that such a document was required. 
	I cleared my DISCUSS on draft-ietf-manet-nhdp-mib with this COMMENT

		Note regarding the applicability statement: This is solved,
as we
		discussed, but I'll keep this little sentence in one 
		corner of my head "A fuller discussion of MANET network
management use
		cases and challenges will be provided elsewhere."

	How/If this "MANET network management considerations" draft relates
to the draft-ersue-constrained-mgmt, I'm not sure at this point in time.

Classification: UNCLASSIFIED
Caveats: NONE

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 3 Nov 2012 08:02:54 +0000

Hi Ulrich,

On Nov 2, 2012, at 3:17 PM, Ulrich Herberg wrote:

Hi [manet] participants,

I am forwarding an email from Benoit that was sent to [email-masked]<mailto:[email-masked]>, since it concerns MANET. COMAN is a new activity (not yet a WG) relating to management of constrained devices and networks. As I mentioned at the last IETF, Benoit cleared his DISCUSS on the NHDP-MIB if we commit to write a document about applicability and use cases of management of MANET routers.

In COMAN, an individual ID was presented (draft-ersue-constrained-mgmt) that discusses use cases of management. Note that this is an early draft and will possibly be split in multiple drafts. There is some discussion whether that should include mobility or not (currently, MANET is excluded but mesh networks are not, which I think needs some more discussion, as both are about dynamic topologies). Anyway, similar to Benoit, it is unclear to me whether this draft or any work in COMAN (if it was to become a WG) would satisfy the request for a use case/applicability document, or if MANET should work on a separate draft.

As the next OLSRv2-MIB revision will be submitted next Monday, (which I consider ready for WGLC) this is something we need to seriously consider.

Opinions?

It would make a lot of sense to work on a separate document on the subject matter.

Thanks for forwarding.

JP.

Thanks
Ulrich

On Fri, Nov 2, 2012 at 4:45 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

One point regarding MANET.
I believe that it deserves its own document: "MANET network management considerations". Actually, when looking at draft-ietf-manet-nhdp-mib part of the IESG review, one of the outcome was that such a document was required.
I cleared my DISCUSS on draft-ietf-manet-nhdp-mib with this COMMENT

How/If this "MANET network management considerations" draft relates to the draft-ersue-constrained-mgmt, I'm not sure at this point in time.

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Joseph Macker <[email-masked]>
Date: Sat, 3 Nov 2012 10:55:03 -0400

Thanks Ulrich for pointing this out since we have dynamic meshes in our
charter both mobility and dynamic topology aspects would be relevant.
Community network related manet deployments etc come to mind.

On Fri, Nov 2, 2012 at 3:17 PM, Ulrich Herberg <[email-masked]> wrote:

> Hi [manet] participants,
>
> I am forwarding an email from Benoit that was sent to [email-masked],
> since it concerns MANET. COMAN is a new activity (not yet a WG) relating to
> [email-masked]

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 4 Nov 2012 14:14:19 +0100

Hi Ulrich,

I support that each Mib draft to provide with its management use cases
(within a section) for its MANETs applicability. Proactive
applicabilities are not similar to Reactive applicabilities.

AB

---

From: Ulrich Herberg <[email-masked]>
Date: Sun, 4 Nov 2012 05:17:51 -0800

Abdussalam,

Benoit's request was for a dedicated MANET use case draft *in addition* to
a shorter applicability section in each MIB document.

Best regards
Ulrich

On Sun, Nov 4, 2012 at 5:14 AM, Abdussalam Baryun <
[email-masked]> wrote:

> since

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 4 Nov 2012 14:33:53 +0100

Hi Ulrich,

I think making one draft submitted for management of use case for
MANETs is not suitable now until we finish the charter requirements of
a standard Proactive and a standard Reactive. After that phase with
both RFCs including RFC2501 we will be able to identify many related
issues. I recommend the start but the WGLC of this draft should be
only after finishing the both RFCs requirements.

AB

On 11/4/12, Ulrich Herberg <[email-masked]> wrote:
>> >> to

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 4 Nov 2012 15:09:30 -0000

Abdussalam,

Your thought is noted.
However, several ADs have expressed a strong desire to see the WG discuss how
MANETs are managed. This request was made during the review and discussion of
the NHDP MIB module when two things emerged:

- The authors of the MIB modules were adding function to the module on
   the assumption that the features were needed, but without a guiding
   framework

- There was no common understanding of how MANETs are managed

The OPS ADs basically allowed the NHDP MIB module to be approved conditional on
the WG taking on a work item to resolve these issues. The alternative was that
the MB module would be blocked pending this work, so I think we got a good deal,
but we are now expected to follow through.

Adrian

> Abdussalam Baryun
> Sent: 04 November 2012 13:34
> To: Ulrich Herberg
> Cc: Ersue, Mehmet (NSN - DE/Munich); Benoit Claise; [email-masked]
> Subject: Re: [manet] Management use cases for MANETs
> 
> Hi Ulrich,
> 
> management

---

From: James Nguyen <[email-masked]>
Date: Sun, 4 Nov 2012 14:18:41 -0500

Hi Ulrich,

Please count me in if the WG agrees to draft a MANET use cases.

James

-- 
James Nguyen
Email: [email-masked]

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Mon, 5 Nov 2012 14:15:00 +0000

Abdussalam,

Our agreement with Benoit was that each MIB document would have a short
applicability statement (where specific protocol mgmt considerations could
be highlighted), but that a more general MANET management use case draft
would be developed to capture broader issue and futures.

Thanks, Bob

Robert G. Cole
Comm:  443.395.8744

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Abdussalam Baryun
Sent: Sunday, November 04, 2012 8:14 AM
To: Ulrich Herberg
Cc: Ersue, Mehmet (NSN - DE/Munich); Benoit Claise; [email-masked]
Subject: Re: [manet] Management use cases for MANETs

Hi Ulrich,

I support that each Mib draft to provide with its management use cases
(within a section) for its MANETs applicability. Proactive applicabilities
are not similar to Reactive applicabilities.

AB

On 11/2/12, Ulrich Herberg <[email-masked]> wrote:
> since it concerns MANET. COMAN is a new activity (not yet a WG) 
> relating to management of constrained devices and networks. As I 
> mentioned at the last IETF, Benoit cleared his DISCUSS on the NHDP-MIB 
> if we commit to write a document about applicability and use cases of
management of MANET routers.
> (draft-ersue-constrained-mgmt) that discusses use cases of management. 
> Note that this is an early draft and will possibly be split in multiple
drafts.
> needs some more discussion, as both are about dynamic topologies). 
> Anyway, similar to Benoit, it is unclear to me whether this draft or 
> any work in COMAN (if it was to become a WG) would satisfy the request 
> for a use case/applicability document, or if MANET should work on a
separate draft.
>
> As the next OLSRv2-MIB revision will be submitted next Monday, (which 
> I consider ready for WGLC) this is something we need to seriously
consider.
>> draft-ietf-manet-nhdp-mib part of the IESG review, one of the outcome 
>> was that such a document was required.
>> discussed, but I'll keep this little sentence in one corner of my 
>> head "A fuller discussion of MANET network management use cases and 
>> challenges will be provided elsewhere."
>>

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Mon, 5 Nov 2012 14:19:22 +0000

Adrian,

I agree, we did get a good deal.  Also, there are folks in the WG who have
expressed interest in working on the draft and helping in review.  

Thx, Bob

Robert G. Cole
Comm:  443.395.8744

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Adrian Farrel
Sent: Sunday, November 04, 2012 10:09 AM
To: 'Abdussalam Baryun'; 'Ulrich Herberg'
Cc: 'Ersue, Mehmet (NSN - DE/Munich)'; 'Benoit Claise'; [email-masked]
Subject: Re: [manet] Management use cases for MANETs

Abdussalam,

Your thought is noted.
However, several ADs have expressed a strong desire to see the WG discuss
how MANETs are managed. This request was made during the review and
discussion of the NHDP MIB module when two things emerged:

The OPS ADs basically allowed the NHDP MIB module to be approved conditional
on the WG taking on a work item to resolve these issues. The alternative was
that the MB module would be blocked pending this work, so I think we got a
good deal, but we are now expected to follow through.

Adrian

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Abdussalam Baryun
> > Benoit's request was for a dedicated MANET use case draft *in 
> > addition* to a shorter applicability section in each MIB document.
> >
> > Best regards
> > Ulrich
> >
> >> I support that each Mib draft to provide with its management use 
> >> cases (within a section) for its MANETs applicability. Proactive 
> >> > it concerns MANET. COMAN is a new activity (not yet a WG) 
> >> > mentioned at the
> >> last
> >> > IETF, Benoit cleared his DISCUSS on the NHDP-MIB if we commit to 
> >> > write a document about applicability and use cases of management 
> >> > of MANET
> >> routers.
> >> >
> >> Note
> >> > that this is an early draft and will possibly be split in 
> >> > multiple
> >> drafts.
> >> > There is some discussion whether that should include mobility or 
> >> > not (currently, MANET is excluded but mesh networks are not, 
> >> > which I think needs some more discussion, as both are about dynamic
topologies).
> >> Anyway,
> >> > similar to Benoit, it is unclear to me whether this draft or any 
> >> > work in COMAN (if it was to become a WG) would satisfy the 
> >> > request for a use case/applicability document, or if MANET should 
> >> > work on a separate draft.
> >> >
> >> > As the next OLSRv2-MIB revision will be submitted next Monday, 
> >> > (which I consider ready for WGLC) this is something we need to 
> >> > seriously consider.
> >> >
> >> > Opinions?
> >> >
> >> > Thanks
> >> > Ulrich
> >> >
> >> >> considerations". Actually, when looking at 
> >> >> draft-ietf-manet-nhdp-mib
> >> part
> >> >> of the IESG review, one of the outcome was that such a document 
> >> >> was required.
> >> >> Note regarding the applicability statement: This is solved, as 
> >> >> we discussed, but I'll keep this little sentence in one corner 
> >> >> of my head "A fuller discussion of MANET network management
> use
> >> >>  How/If this "MANET network management considerations" draft 
> >> >> relates to the draft-ersue-constrained-mgmt, I'm not sure at 
> >> >> this point in time.
> >> >>
> >> >>
> >> >
> >>
> >