Subject: [manet] Fwd: I-D Action: draft-herberg-lln-loadng-mib-01.txt

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 7 Nov 2012 16:04:47 +0000

Dear Authors,

Are you expecting to use SNMPv2 is constrained networks ? As you know, the IETF came up with different ways of managing
networks that are indeed constrained (CoRE).

Thanks.

JP.

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: I-D Action: draft-herberg-lln-loadng-mib-01.txt
Date: November 7, 2012 9:28:22 AM EST
To: <[email-masked]<mailto:[email-masked]>>
Reply-To: <[email-masked]<mailto:[email-masked]>>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title           : Definition of Managed Objects for the Lightweight On-demand Ad hoc Distance-vector Routing Protocol - Next Generation (LOADng)
Author(s)       : Ulrich Herberg
                         Robert G. Cole
                         Thomas Heide Clausen
Filename        : draft-herberg-lln-loadng-mib-01.txt
Pages           : 43
Date            : 2012-11-07

Abstract:
  This memo defines a portion of the Management Information Base (MIB)
  for use with network management protocols in the Internet community.
  In particular, it describes objects for configuring parameters of the
  Lightweight On-demand Ad hoc Distance-vector Routing Protocol - Next
  Generation (LOADng) process on a router.  The MIB module defined in
  this memo, denoted LOADng-MIB, also reports state.  While LOADng is
  layer agnostic and can be run with different address families (e.g.,
  on L2 using MAC addreses, or on L3 using IP addresss), this MIB
  module assumes that LOADng is used on L3, and uses only IPv4/IPv6
  addresses.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-herberg-lln-loadng-mib

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-herberg-lln-loadng-mib-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-herberg-lln-loadng-mib-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 7 Nov 2012 11:53:06 -0500

Hi JP,

The answer is: it depends. Some MANET deployments may use SNMP, other, more
constrained MANETs don't. For these more constrained networks, other
protocols may be more suitable (or management may not be possible).

Regard
Ulrich

On Wed, Nov 7, 2012 at 11:04 AM, JP Vasseur (jvasseur)
<[email-masked]>wrote:

>  Dear Authors,
>
>  Are you expecting to use SNMPv2 is constrained networks ? As you know,
> the IETF came up with different ways of managing
>  *From: *<[email-masked]>
>  *Subject: **I-D Action: draft-herberg-lln-loadng-mib-01.txt*
>  *Date: *November 7, 2012 9:28:22 AM EST
>  *To: *<[email-masked]>
>  *Reply-To: *<[email-masked]>
>
>
> Title           : Definition of Managed Objects for the Lightweight
> On-demand Ad hoc Distance-vector Routing Protocol - Next Generation (LOADng)
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 7 Nov 2012 21:40:09 +0000

Hi Ulrich,

On Nov 7, 2012, at 11:53 AM, Ulrich Herberg wrote:

Hi JP,

The answer is: it depends. Some MANET deployments may use SNMP, other, more constrained MANETs don't.

JP> Absolutely.

For these more constrained networks, other protocols may be more suitable (or management may not be possible).

JP> It might be worth spelling it out clearly - happy to help.

Thanks.

JP.

Regard
Ulrich

On Wed, Nov 7, 2012 at 11:04 AM, JP Vasseur (jvasseur) <[email-masked]<mailto:[email-masked]>> wrote:
Dear Authors,

Thanks.

JP.

Begin forwarded message:

Abstract:

[email-masked]<mailto:[email-masked]>

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Henning Rogge <[email-masked]>
Date: Wed, 7 Nov 2012 22:43:13 +0100

On Wed, Nov 7, 2012 at 10:40 PM, JP Vasseur (jvasseur)
<[email-masked]> wrote:
> constrained MANETs don't.
>
> JP> Absolutely.
>

It doesn't help that NetSNMP (which seems to be the default OpenSource
SNMP implementation) is a messy and bloated thing either.

Henning Rogge
-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 7 Nov 2012 16:59:31 -0500

Hi JP,

similar to the other MIB documents, there will be a brief applicability
statement section. Note that the MIB module itself represents an API, not a
protocol.
Most importantly, we need the MANET use case draft for having a detailed
discussion on applicability/use cases etc. of management of MANETs.

Best regards
Ulrich

On Wed, Nov 7, 2012 at 4:40 PM, JP Vasseur (jvasseur) <[email-masked]>wrote:

>  For these more constrained networks, other protocols may be more
> suitable (or management may not be possible).
>
>
> On Wed, Nov 7, 2012 at 11:04 AM, JP Vasseur (jvasseur) <[email-masked]
> > wrote:
>
>> Dear Authors,
>>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Thu, 8 Nov 2012 17:31:30 +0000

Hi,

On Nov 7, 2012, at 10:59 PM, Ulrich Herberg wrote:

Hi JP,

similar to the other MIB documents, there will be a brief applicability statement section. Note that the MIB module itself represents an API, not a protocol.
Most importantly, we need the MANET use case draft for having a detailed discussion on applicability/use cases etc. of management of MANETs.

In total agreement ! This was my last comment at the mic today … very accurate applicability statement is a MUST for both.

Thanks.

JP.

Best regards
Ulrich

On Wed, Nov 7, 2012 at 4:40 PM, JP Vasseur (jvasseur) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ulrich,

Hi JP,

JP> Absolutely.

Thanks.

JP.

Regard
Ulrich

Thanks.

JP.

Begin forwarded message:

Abstract: