Subject: [manet] draft-ietf-manet-dymo-24x.txt

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 29 Nov 2012 18:03:04 -0800

Hello folks,

I have completed the first really coherent revision of AODVv2 since I
took the editorial pen last year.  I want to read through it just a bit 
more,
and I expect to submit it to the Internet Draft directories tomorrow.
In the meantime, here is the current version:
http://www.psg.com/~charliep/txt/ietf85/draft-ietf-manet-dymo-24x.txt

I have made a big effort to improve the readability and organization
of the text; other than that, there have been very few technical changes.
The section on precursors (optional feature) has been mostly rewritten,
and most other sections have had very heavy editing to reflect the
terminology revision.

Some things clarified or changed or made more definite:
- When a node generates a RteMsg (RREQ or RREP), it always
    increments its sequence number
- RFC 5444 compliance (many changes for this)
- New MsgTLV for RERR, to enable unicast route error to PktSource
- New MsgTLV for RREQ, to enable destination-only RREP
- SeqNum field required for all "Added Node" AddrBlk (optional
    feature)
Making RREP and RREQ always to increment sequence number
some beneficial simplifications in route table update description.

I think the only thing unfinished right now is to enable alternate
metrics.  Some of the mechanism is specified (and was before in
DYMO) but it needs a few more paragraphs.  If I can do that for
tomorrow, I will do so.

Comments on the prerelease are, as always, welcome.

I will also post some relevant issues to the Issue Tracker soon.

-- 
Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 29 Nov 2012 18:04:51 -0800

Hello again folks,

I forgot to mention that I have already submitted the Intermediate
Route Reply document to the Internet Draft directories:
http://www.ietf.org/internet-drafts/draft-perkins-irrep-02.txt

It is compatible with the base draft, and uses the same
approach to terminology.

Regards,
Charlie P.

On 11/29/2012 6:03 PM, Charles E. Perkins wrote:
> took the editorial pen last year.  I want to read through it just a 
> bit more,

-- 
Regards,
Charlie P.

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Fri, 30 Nov 2012 15:17:54 +0000

Charlie, 

Speaking as a WG participant, I'd rather see you submit the draft via the normal process in order to get the WG's review. 

Speaking as a WG co-chair, I'd *really* rather see you submit the draft before the WG invests the cycles in a review. How does inviting WG review of a "prerelease" version of an accepted document improve the process?

Regards,
Stan

On Nov 29, 2012, at 9:04 PM, Charles E. Perkins wrote:

>> took the editorial pen last year.  I want to read through it just a bit more,
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 30 Nov 2012 08:14:36 -0800

Hello Stan,

O.K.  I was planning to submit it today anyway.  It has been several
weeks since the last MANET meeting, and I was happy to have
beaten it into shape especially compared to the last two releases.

You are right that people will spend their time more efficiently
by waiting for the release to the Internet Drafts directories.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 1 Dec 2012 02:26:59 +0100

I don't mind either way processing it, as long our WG documents go forward,

AB

On 11/30/12, Charles E. Perkins <[email-masked]> wrote:
>> Speaking as a WG participant, I'd rather see you submit the draft via the
>> normal process in order to get the WG's review.
>>
>> Speaking as a WG co-chair, I'd *really* rather see you submit the draft
>> before the WG invests the cycles in a review. How does inviting WG review
>> of a "prerelease" version of an accepted document improve the process?
>>
>> Regards,
>> Stan
>>