Subject: Re: [manet] [Technical Errata Reported] RFC6621 (3499)

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 1 Mar 2013 11:30:59 -0000

"any" is correct English and appears in the text that has been approved in the
Errata Report

> -----Original Message-----
> From: Abdussalam Baryun [mailto:[email-masked]]
> Sent: 01 March 2013 04:43
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; RFC Errata System
> Subject: Re: [manet] [Technical Errata Reported] RFC6621 (3499)
> 
> >    7.  For each interface "w" in "N2" where "N1(w)" has only one member,
> > "x",
> >        select "x" as an MPR:
> >
> >        A.  Add "x" to the set "MPR" and remove "x" from "N1".
> >
> >        B.  For each interface "z" in "N2(x)", remove "z" from "N2".
> >
> >        C.  For each interface "y" in "N1", remove any interfaces in
> >            "N2(x)" from "N2(y)".
> 
> AB>edit>
>   7.  For each interface "w" in "N2" where "N1(w)" has only one member,
>        "n",  select "n" as an MPR:
> 
>         A.  Add "n" to the set "MPR" and remove "n" from "N1".
> 
>         B.  For each interface "z" in "N2(w)", remove "z" from "N2".
> 
>         C.  For each interface "y" in "N1", remove all interfaces in
>             "N2(w)" from "N2(y)".
> 
> In your errata proposal for the point 7-C please advise do you mean
> *any* or *ALL*, because any may mean one only but all is a must for
> all that are in N2(w) to be removed. I think you mean all,
> 
> Please discuss, or advise,
> 
> AB

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 1 Mar 2013 11:30:59 -0000

In my view the new text in 7 is clear on the meaning of x.
No further change is needed.
I have already approved the Errata Report.
Adrian

> Sent: 01 March 2013 03:19
> To: manet
> [email-masked]; [email-masked]
> The *x* in the line 7 is different to others, it was interface, then
> became memebr of an interface,
> 
> AB>edit> replace *x* in 7 to *n*
> 
> (still not complete the review check of RFC6621, this thread does not
> include a last date for review)
> AB
> 
> On 2/26/13, RFC Errata System <[email-masked]> wrote:
> >
> > The following errata report has been submitted for RFC6621,
> > "Simplified Multicast Forwarding".
> >
> > --------------------------------------
> > You may review the report below and at:
> > http://www.rfc-editor.org/errata_search.php?rfc=6621&eid=3499
> >
> > --------------------------------------
> > Type: Technical
> > Reported by: Errol Lloyd <[email-masked]>
> >
> > Section: B.4.
> >
> > Original Text
> > -------------
> >   1.  Initialize the set "MPR" to empty.
> >
> >    2.  Initialize the set "N1" to include all 1-hop neighbors of "n0".
> >
> >    3.  Initialize the set "N2" to include all 2-hop neighbors, excluding
> >        "n0" and any routers in "N1".  Nodes that are only reachable via
> >        "N1" routers with router priority values of NEVER are also
> >        excluded.
> >
> >    4.  For each interface "y" in "N1", initialize a set "N2(y)" to
> >        include any interfaces in "N2" that are 1-hop neighbors of "y".
> >
> >    5.  For each interface "x" in "N1" with a router priority value of
> >        "ALWAYS" (or using the CF relay algorithm), select "x" as an MPR:
> >
> >    6.  For each interface "z" in "N2", initialize the set "N1(z)" to
> >        include any interfaces in "N1" that are 1-hop neighbors of "z".
> >
> >    7.  For each interface "x" in "N2" where "N1(x)" has only one member,
> >        select "x" as an MPR:
> >
> >        B.  For each interface "z" in "N2(x)", remove "z" from "N2" and
> >            delete "N1(z)".
> >
> >    8.  While "N2" is not empty, select the interface "x" in "N1" with
> >        the largest router priority that has the number of members in
> >        "N_2(x)" as an MPR:
> >
> > Corrected Text
> > --------------
> >   1.  Initialize the set "MPR" to empty.
> >
> >    2.  Initialize the set "N1" to include all 1-hop neighbors of "n0".
> >
> >    3.  Initialize the set "N2" to include all 2-hop neighbors, excluding
> >        "n0" and any routers in "N1".  Nodes that are only reachable via
> >        "N1" routers with router priority values of NEVER are also
> >        excluded.
> >
> >    4.  For each interface "y" in "N1", initialize a set "N2(y)" to
> >        include any interfaces in "N2" that are 1-hop neighbors of "y".
> >
> >    5.  For each interface "x" in "N1" with a router priority value of
> >        "ALWAYS" (or using the CF relay algorithm), select "x" as an MPR:
> >
> >    6.  For each interface "z" in "N2", initialize the set "N1(z)" to
> >        include any interfaces in "N1" that are 1-hop neighbors of "z".
> >
> >    8.  While "N2" is not empty, select the interface "x" in "N1" with
> >        the highest router priority [break ties in favor of the node with the
> >
> >        largest number of members in "N_2(x)"] as an MPR:
> >
> > Notes
> > -----
> > There are three changes:
> > On line 7, the first and second occurrences of x are replaced by w, and then
> > x is given as the name of the sole member of N1(w).
> >
> > On line 7B, the phrase 'delete "N1(z)" is dropped to be consistent with the
> > rest of the algorithm.
> >
> > On line 8 some rewording is done for clarification.
> >
> > This errata prepared in consultation with Justin Dean and Gus Macker.
> >
> > Instructions:
> > -------------
> > This errata is currently posted as "Reported". If necessary, please
> > use "Reply All" to discuss whether it should be verified or
> > rejected. When a decision is reached, the verifying party (IESG)
> > can log in to change the status and edit the report, if necessary.
> >
> > --------------------------------------
> > RFC6621 (draft-ietf-manet-smf-14)
> > --------------------------------------
> > Title               : Simplified Multicast Forwarding
> > Publication Date    : May 2012
> > Author(s)           : J. Macker, Ed.
> > Category            : EXPERIMENTAL
> > Source              : Mobile Ad-hoc Networks
> > Area                : Routing
> > Stream              : IETF
> > Verifying Party     : IESG
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/manet
> >