Subject: [manet] Review of draft-dearlove-manet-olsrv2-rmpr-optimization-00

From: Ulrich Herberg <[email-masked]>
Date: Tue, 16 Jul 2013 15:05:32 -0700

It looks like a reasonable draft to me. Two comments:
 - add an example topology to illustrate the issue
 - is there any implementation/deployment/simulation experience
showing use cases for that optimization? (i.e., how much is traffic
reduced for certain topologies? does the mechanism also have drawbacks
such as reduced load balancing and resulting energy drain for battery
driven routers etc)

Ulrich

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 17 Jul 2013 09:20:50 +0000

With regard to whether this causes a problem, there are two answers:
(a) This is just permission to do something. There's nothing mandatory about it. Like all aspects of MPR selection, this is the implementer/deployer's problem.
(b) But even if we ignore (a), no, it should not have this effect. This is handling cases where there's a known better two hop route to a neighbour than the one hop route. Given that, you'll never use the one hop route. (Recall that this is only about routing MPRs.) So if you never use the one hop route, then the value as a routing MPR is useless because that just means we'll advertise a link in TC messages that will never be used.

For experience, this derives from work by Philippe Jacquet and colleagues (that's how it got into the metrics draft - it wasn't in the very first draft, though that might have been unpublished pre -00, I don't recall). So there is some experience there. However checking that the precise specification given is neither too loose (which would make it wrong) or too tight (which would mean we could improve it) needs to be part of the review process. (Having brought up PJ's name, I should clarify he hasn't signed off on this formulation.)

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ulrich Herberg
Sent: 16 July 2013 23:06
To: Thomas Clausen; Dearlove, Christopher (UK); [email-masked]
Subject: [manet] Review of draft-dearlove-manet-olsrv2-rmpr-optimization-00

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Ulrich
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 17 Jul 2013 10:08:29 -0700

Thank you for the explanations.

Best regards
Ulrich