Subject: [manet] New OLSRv2 and NHDP related IDs

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 12 Jul 2013 17:18:58 +0000

We have submitted three IDs today, one is a -01 revision of one submitted last Monday, two are -00 versions that are a -00 submitted last Monday divided into two documents.

One describes a multitopology extension to OLSRv2. That a multitopology extension was possible was clear from before metrics were added to OLSRv2. However we decided to walk before we ran there. We have suggested this as experimental, as we currently have no experience with it, but of course Standard Track might be possible in the future.

One key decision was to make MT-OLSRv2 interoperable with basic OLSrv2. There a couple of nits there, and the TLV extensions draft hammers those out. As a significant bonus, this allows a simplification and/or efficiency saving in using multivalue TLVs in NHDP and OLSrv2.

The rmpr-optimisation draft (spelling out routing made the name too long) legitimises an optimisation described in the metric rationale draft. (It is unnecessary to make it work, and interoperate, it just needed to make it technically "legal").

Ulrich - we would like to request a slot at the Berlin meeting to describe these. (Exactly who to present is TBD.)

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 12 Jul 2013 19:43:57 -0700

Chris,

I have updated the agenda:
http://www.ietf.org/proceedings/87/agenda/agenda-87-manet

Regards
Ulrich