Subject: [manet] REPORT-MIB - a question and an offer of help to pull it across the finishing line

From: Thomas Clausen <[email-masked]>
Date: Thu, 27 Feb 2014 15:38:29 +0100

Dear all,

Triggered by the discussions that are ongoing with OPSAWG, it came to my attention that REPORT-MIB is expired, and has been so expired for almost a year (http://tools.ietf.org/html/draft-ietf-manet-report-mib-03 ). 

I note that this is a WG document, and that therefore the WG is - all of us are -  on the hook of seeing it through to publication.

Working on MIBs are really, really, tedious and unexciting and very very important work - so this is definitely *not* complaining, and I want to express my appreciation to the authors for having gotten the document so far. Good job!  I'd like to offer my assistance to the authors (& the WG) in seeing this document through and across the finishing line. I am a huge proponent of the ideas in that document, and have them implemented (but deployed only for test purposes), and I really want to see this published ASAP.

Do you need someone to do an editorial pass? Some specifics that need further development that you have not had cycles to do, but where fresh eyes might help? A review by some directorate, that needs contemplation and folding in?

Authors. WG Chairs, what's the status, and how can I help?

Best,

Thomas

---

From: Joe Macker <[email-masked]>
Date: Thu, 27 Feb 2014 13:40:09 -0500

I am also a fan of type of reporting concepts related to REPORT-MIB they were first inspired way back over a pint in Ireland quite awhile back….a good meeting.

Some of the potential reasons for lapse: I think Bob and I were discussing whether or not there was duplicative work outside manet ( I am definitely not a MGMT standards expert) since some of the concepts are really just generally useful and some "wise" time was taken by Bob to explore who or what else might be doing similar things.  I would actually like to hear his summary thoughts of that exploration.

Bob also has taken input and iterated this a few times to scope it back in complexity  as well as exploring other potential IETF synergies that might be going on in this area (mentioned above).  If you or others implemented related concepts and find them useful thats really a strong motivator to getting it back on track and rediscussing.

-Joe
On Feb 27, 2014, at 9:38 AM, Thomas Clausen <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 27 Feb 2014 21:50:49 +0100

Joe,

> On 27 févr. 2014, at 19:40, Joe Macker <[email-masked]> wrote:
> 

Most successful protocol designs happen - or, at least, start - in bars.

> Some of the potential reasons for lapse: I think Bob and I were discussing whether or not there was duplicative work outside manet ( I am definitely not a MGMT standards expert) since some of the c…

Actually, I think that it's immaterial at this point if there is duplicative work outside of MANET. Or, to put it another way:

	1) I've not yet found any

	2) If there is, then I'm pretty sure that the best way to finding out is to sending it
	   to the IESG. The OPS ADs are pretty sharp, and I am sure that they'd know, and tell us,
	   once they got their eyes on it, or once their directorate does.

	3) This is going for experimental, and (as far as I have uncovered) doesn't collide
	    with anything std.track, at least. It appears a perfectly valid experiment to see if
	    this architecture fits within the unique world of MANETs.

So, while I am very interested in background and explanations, they're always educational, I'd submit that we should not drag our feet on this any longer: revive the document, do the reviews and re-spins, WGLC it and then get it off to Adrian for further processing. Having recently re-read it, my guestimate is that with a bit of concentrated effort, it shouldn't necessitate many months to see it through.

As I said, I'm willing to chip in and help out and do my part to make it go forward.

Best,

Thomas

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Thu, 27 Feb 2014 20:55:20 +0000

Classification: UNCLASSIFIED
Caveats: NONE

Thomas, Joe,

I have not had the time lately to keep up with the REPORT-MIB (as much as I had hoped to) and am happy that there is interest in this capability.  When Joe first proposed it I thought it was a great idea and I still do think it is a valuable capability.  I would be more than happy to have others help or in fact take over ownership of this effort.  I would be glad to help to reinvigorate or transition in any way the WG deems appropriate.

That said, a bit of history.  Our first version of the REPORT-MIB was modeled after RMON2 reporting capabilities after discussions with various Operations Area folks like Bert Wijnen and Andy Bierman.  They had pointed us to previous related work in the RMON WG.  However, the scope was too extensive for an initial experimental capability, so we scoped it back.  Andy Bierman came on as a co-author to help as he was the main author of the initial RMON related capabilities.

Further discussions with Jürgen Schönwälder convinced us that a better model for the REPORT-MIB is as an extension to the work that came out of the DISMAN WG a number of years ago.  I agree with this.  So we had spent some cycles looking at DISMAN capabilities and deciding on the right way to structure the REPORT-MIB as an extension to the DISMAN set of MIBs.  I think this is the right approach and we had written down some initial thoughts on how to do this but we did not issue a revision to the draft and in fact I let it expire.

I am not able to attend the meeting in London, but I would hope and support further discussions on this topic at the WG meetings.  And as I previously mentioned I would welcome and support the WGs recommendations to best move this effort forward.

Thanks, Bob 

US Army CERDEC
QUEST Program, S&TCD
APG, MD

(c) 443.910.4420
(o) 443.395.8744
[email-masked]

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Joe Macker
Sent: Thursday, February 27, 2014 1:40 PM
To: Thomas Clausen
Cc: <[email-masked]>; MANET IETF
Subject: Re: [manet] REPORT-MIB - a question and an offer of help to pull it across the finishing line

I am also a fan of type of reporting concepts related to REPORT-MIB they were first inspired way back over a pint in Ireland quite awhile back..a good meeting.

-Joe

Classification: UNCLASSIFIED
Caveats: NONE

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Thu, 27 Feb 2014 21:08:05 +0000

Thomas said:
"So, while I am very interested in background and explanations, they're always educational, I'd submit that we should not drag our feet on this any longer: revive the document, do the reviews and re-spins, WGLC it and then get it off to Adrian for further processing. Having recently re-read it, my guestimate is that with a bit of concentrated effort, it shouldn't necessitate many months to see it through.

As I said, I'm willing to chip in and help out and do my part to make it go forward."

Two potential ways to proceed:

1) The last posted draft of the REPORT-MIB gave a simple bucket style approach to reporting remotely collected measurements back to a centralized manager.  It is straight forward and as Thomas said with some concentrated effort could finish up rather quickly with an energetic editor.  As an experimental RFC this could provide a useful experimental capability to play with and decide how best to improve upon for later efforts. 

2) A longer term effort would be to rewrite it in the context of the DISMAN set of MIBs.  But this would take more time and more discussions.  

My feeling is that 2) is the best long term approach, but that 1) would provide a more immediate capability to experiment with.

Thanks,  Bob

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 27 Feb 2014 23:15:16 +0100

Bob,

Thank you for the background and guidance - and for confirming my sentiment that with an energetic editorial effort, this document could be really close to a finishing line.

I actually am also (unsurprisingly) well aligned with the two steps you outline below. We need a stable spec, and then some experience - and then fold those together with wherever the rest of the IETF is once we've gotten enough experience to have an informed opinion on what should become standard.

So, I think that 1) is a good - and, even, necessary - stepping sone towards 1. So let's do it?

Thomas

ps: sad to hear that you won't be in London. Might you have time to a teleconf at some point about this?

> On 27 févr. 2014, at 22:08, "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]> wrote:
>