Subject: [manet] Fwd: draft-avula-shwmp-01

From: Mallikarjun Avula <[email-masked]>
Date: Tue, 25 Feb 2014 22:14:26 -0600

Hi

I wish to submit my internet-draft titled "Secure Hybrid Wireless Mesh
Protocol <http://datatracker.ietf.org/doc/draft-avula-shwmp/>" for
consideration towards publishing as an RFC as an independent submission in
Experimental category. Please find attached the updated version of the
draft. I tried to submit but the submission tool hasn't re-opened yet for
submissions yet. I was suggested by the RFC editor to consider asking for
comments from the related working groups to ensure that this work doesn't
conflict with any of the IETF Working Groups. It would be of great help, in
my maiden adventure of submitting an RFC, if you could kindly take a look
at my internet draft and send in your comments/suggestions.

Thanks,
Mallikarjun

---

From: Henning Rogge <[email-masked]>
Date: Wed, 26 Feb 2014 08:59:37 +0100

Hi,

I see two problems with this draft for the IETF Manet WG:

1.) HWMP/IEEE-802.11s (and SHWMP) are layer2 forwarding protocols. The
Manet group deals with routing (layer-3 IP forwarding) protocols.
2.) HWMP has not been published as a RFC, so we cannot easily see what
your protocol is doing. Is there even a full description of 802.11s
freely available somewhere?

Henning Rogge

On Wed, Feb 26, 2014 at 5:14 AM, Mallikarjun Avula <[email-masked]> wrote:
> Protocol" for consideration towards publishing as an RFC as an independent
> submission in Experimental category. Please find attached the updated
> version of the draft. I tried to submit but the submission tool hasn't
> re-opened yet for submissions yet. I was suggested by the RFC editor to
> consider asking for comments from the related working groups to ensure that
> this work doesn't conflict with any of the IETF Working Groups. It would be
> of great help, in my maiden adventure of submitting an RFC, if you could
> kindly take a look at my internet draft and send in your
> comments/suggestions.
>
> Thanks,
> Mallikarjun
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 26 Feb 2014 09:42:31 +0100

> On 26 févr. 2014, at 08:59, Henning Rogge <[email-masked]> wrote:
> 
> Hi,
> 

3) given 2) above, is HWMP available in a form and under a license that permits a non-IEEE body to produce derivative work?

Thomas

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 26 Feb 2014 09:56:47 +0000

I'd actually like to strengthen Henning's two points.
1. The initial text says "In a Wireless Mesh Network (WMN), the default routing protocol is Hybrid Wireless Mesh Protocol (HWMP)." That identifies "wireless mesh network" with "IEEE 802.11 based wireless network", but without even saying it. Both that identification, and the assertion that this is the default, aren't justified here at all and are at least arguable.
2. There isn't an RFC, but in addition this document has no reference for what HWMP is at all. However simply adding a reference (even an open one) would leave this missing connecting material to that reference.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 26 February 2014 08:00
To: Mallikarjun Avula
Cc: MANET IETF
Subject: Re: [manet] Fwd: draft-avula-shwmp-01

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi,

1.) HWMP/IEEE-802.11s (and SHWMP) are layer2 forwarding protocols. The Manet group deals with routing (layer-3 IP forwarding) protocols.
2.) HWMP has not been published as a RFC, so we cannot easily see what your protocol is doing. Is there even a full description of 802.11s freely available somewhere?

Henning Rogge

On Wed, Feb 26, 2014 at 5:14 AM, Mallikarjun Avula <[email-masked]> wrote:
> Protocol" for consideration towards publishing as an RFC as an 
> independent submission in Experimental category. Please find attached 
> the updated version of the draft. I tried to submit but the submission 
> tool hasn't re-opened yet for submissions yet. I was suggested by the 
> RFC editor to consider asking for comments from the related working 
> groups to ensure that this work doesn't conflict with any of the IETF 
> Working Groups. It would be of great help, in my maiden adventure of 
> submitting an RFC, if you could kindly take a look at my internet 
> draft and send in your comments/suggestions.
>
> Thanks,
> Mallikarjun
>
>

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Henning Rogge <[email-masked]>
Date: Wed, 26 Feb 2014 11:28:11 +0100

> 3) given 2) above, is HWMP available in a form and under a license that permits a non-IEEE body to produce derivative work?

I think the linux kernel 802.11 implementation includes 802.11s, so it
should be a GPLv2 implementation available.

Henning Rogge

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 26 Feb 2014 13:08:23 +0100

Implementation =! Specification 

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

> On 26 févr. 2014, at 11:28, Henning Rogge <[email-masked]> wrote:
>

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Wed, 26 Feb 2014 14:34:41 +0000

The former 802.11s (amendment 10 to 802.11) has been absorbed into IEEE 802.11-2012. The latter standard appears to be available at no charge through the IEEE Get Program ( http://standards.ieee.org/about/get/802/802.11.html ) .  HWMP is specified in clause 13.10 of 802.11-2012.

Fwiw, I concur with the other comments made by Henning, Thomas and Christopher.

Ronald in 't Velt

>From: manet [mailto:[email-masked]] On Behalf Of Thomas Heide
>Clausen
>Sent: woensdag 26 februari 2014 13:08
>To: Henning Rogge
>Cc: MANET IETF; Mallikarjun Avula
>>> 3) given 2) above, is HWMP available in a form and under a license that
>permits a non-IEEE body to produce derivative work?
>>

Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. TNO aanvaardt geen aansprakelijkheid voor de inhoud van deze e-mail, de wijze waarop u deze gebruikt en voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Mallikarjun Avula <[email-masked]>
Date: Wed, 26 Feb 2014 09:57:05 -0600

Thank you all for your comments so far and I'd welcome more. I realize that
there is no working group for Wireless Mesh Networks yet so I wanted to
take comments from the closest working group which I think is MANET. I
understand that my internet draft isn't quite suitable for IETF Manet WG as
HWMP is layer-2 forwarding protocol. Is there any suitable WG that I can be
directed to or do you think this draft better qualifies as an 'Independent
Submission' under 'Experimental' category?

On Wed, Feb 26, 2014 at 8:34 AM, Velt, R. (Ronald) in 't <
[email-masked]> wrote:

> The former 802.11s (amendment 10 to 802.11) has been absorbed into IEEE
> 802.11-2012. The latter standard appears to be available at no charge
> through the IEEE Get Program (
> http://standards.ieee.org/about/get/802/802.11.html ) .  HWMP is
> specified in clause 13.10 of 802.11-2012.
>
> Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u
> niet de geadresseerde bent of dit bericht abusievelijk aan u is
> toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht
> te verwijderen. TNO aanvaardt geen aansprakelijkheid voor de inhoud van
> deze e-mail, de wijze waarop u deze gebruikt en voor schade, van welke aard
> ook, die verband houdt met risico's verbonden aan het elektronisch
> verzenden van berichten.
>
>
>
> This message may contain information that is not intended for you. If you
> are not the addressee or if this message was sent to you by mistake, you
> are requested to inform the sender and delete the message. TNO accepts no
> liability for the content of this e-mail, for the manner in which you use
> it and for damage of any kind resulting from the risks inherent to the
> electronic transmission of messages.
>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 26 Feb 2014 17:23:30 +0100

Hi,

I think the main problem with your document is that it is an extension
of an IEEE document, not an extension of an IETF document or a
standalone.

I am not sure whats the IETF policy about documents like this.

Maybe you are willing to look into AODVv2, your ideas could apply to
this protocol too because HWMP is just an extension of AODV.

Henning Rogge

On Wed, Feb 26, 2014 at 4:57 PM, Mallikarjun Avula <[email-masked]> wrote:
> there is no working group for Wireless Mesh Networks yet so I wanted to take
> comments from the closest working group which I think is MANET. I understand
> that my internet draft isn't quite suitable for IETF Manet WG as HWMP is
> layer-2 forwarding protocol. Is there any suitable WG that I can be directed
> to or do you think this draft better qualifies as an 'Independent
> On Wed, Feb 26, 2014 at 8:34 AM, Velt, R. (Ronald) in 't
> <[email-masked]> wrote:
>>
>> http://standards.ieee.org/about/get/802/802.11.html ) .  HWMP is specified
>> in clause 13.10 of 802.11-2012.
>>
>> niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden,
>> wordt u verzocht dat aan de afzender te melden en het bericht te
>> verwijderen. TNO aanvaardt geen aansprakelijkheid voor de inhoud van deze
>> e-mail, de wijze waarop u deze gebruikt en voor schade, van welke aard ook,
>> die verband houdt met risico's verbonden aan het elektronisch verzenden van
>> berichten.
>>
>>
>>
>> are not the addressee or if this message was sent to you by mistake, you are
>> requested to inform the sender and delete the message. TNO accepts no
>> liability for the content of this e-mail, for the manner in which you use it
>> and for damage of any kind resulting from the risks inherent to the

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 26 Feb 2014 17:40:39 +0100

> On 26 févr. 2014, at 16:57, Mallikarjun Avula <[email-masked]> wrote:
> 
> Thank you all for your comments so far and I'd welcome more. I realize that there is no working group for Wireless Mesh Networks yet so I wanted to take comments from the closest working group which I think is MANET.

I actually do not understand how "mesh" and "MANET" are different, so I am not actually sure what it is you're looking for, or asking, here. 

> I understand that my internet draft isn't quite suitable for IETF Manet WG as HWMP is layer-2 forwarding protocol. Is there any suitable WG that I can be directed to or do you think this draft better qualifies as an 'Independent Submission' under 'Experimental' category?
> 

Speaking only for myself, given that it is a Layer-2 protocol, I do believe that the IETF, or even the ISE is the wrong venue for publication.

As for the maturity level on which to publish, I believe that the first question to ask is: why publish as an RFC at all? 

Best,

Thomas

> 
>> On Wed, Feb 26, 2014 at 8:34 AM, Velt, R. (Ronald) in 't <[email-masked]> wrote:

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 26 Feb 2014 17:11:42 -0000

All,

I don't think that Mallikarjun is proposing that this work be adopted by the MANET WG. The intention, as I understood it, is to have the work published on the Independent Stream as an Experimental RFC. 

The poll is to notify people who might be interested and to solicit reviews and feedback.

I suggest that that feedback be addressed to Mallikarjun if it is  technical or editorial, and to the ISE ([email-masked]) if it is about the advisability of publication.

AFAIK, the Independent Stream is not limited to publication of documents about the Internet or related technologies. The text at http://www.rfc-editor.org/indsubs.html says "relevant to the Internet community." The relevance is presumably for the author to assert and the ISE to verify.

You might think that the scope of the Independent Stream is too wide, but I could not possibly comment. The Independent Stream was established on request (demand?) of the IETF community to prevent the IESG blocking the publication of work, and it would be wrong for me to hold a public view on the topic.

Meanwhile: back to discussing work in scope for the WG :-)

Adrian

> From: manet [mailto:[email-masked]] On Behalf Of Velt, R. (Ronald) in
> 't
> Sent: 26 February 2014 14:35
> To: Thomas Heide Clausen; Henning Rogge
> 802.11-2012. The latter standard appears to be available at no charge through the
> IEEE Get Program ( http://standards.ieee.org/about/get/802/802.11.html ) .
> HWMP is specified in clause 13.10 of 802.11-2012.
> 
> Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de
> geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u
> verzocht dat aan de afzender te melden en het bericht te verwijderen. TNO
> aanvaardt geen aansprakelijkheid voor de inhoud van deze e-mail, de wijze
> waarop u deze gebruikt en voor schade, van welke aard ook, die verband houdt
> met risico's verbonden aan het elektronisch verzenden van berichten.
> 
> 
> 
> This message may contain information that is not intended for you. If you are not
> the addressee or if this message was sent to you by mistake, you are requested
> to inform the sender and delete the message. TNO accepts no liability for the
> content of this e-mail, for the manner in which you use it and for damage of any
> kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 26 Feb 2014 09:35:05 -0800

Mallikarjun,

I concur with what Thomas and others have said. If this draft is an
extension to an IEEE protocol, have you considered proposing the extension
to the relevant IEEE group(s)?

Best regards
Ulrich

On Wed, Feb 26, 2014 at 8:40 AM, Thomas Heide Clausen <
[email-masked]> wrote:

> Thank you all for your comments so far and I'd welcome more. I realize
> that there is no working group for Wireless Mesh Networks yet so I wanted
> to take comments from the closest working group which I think is MANET.
>
>
> I actually do not understand how "mesh" and "MANET" are different, so I am
> not actually sure what it is you're looking for, or asking, here.
>
> I understand that my internet draft isn't quite suitable for IETF Manet WG
> as HWMP is layer-2 forwarding protocol. Is there any suitable WG that I can
> be directed to or do you think this draft better qualifies as an
> 'Independent Submission' under 'Experimental' category?
>
>
> Speaking only for myself, given that it is a Layer-2 protocol, I do
> believe that the IETF, or even the ISE is the wrong venue for publication.
>
> As for the maturity level on which to publish, I believe that the first
> question to ask is: why publish as an RFC at all?
>
> Best,
>
> Thomas
>
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 26 Feb 2014 18:46:39 +0100

(Just want to go on record: it's not that the work isn't interesting as such, it may just not be the right forum - you should really ask a chair or an ADs advice on these matters)

Sent from my iPad

> On 26 févr. 2014, at 18:35, Ulrich Herberg <[email-masked]> wrote:
> 
> Mallikarjun,
> 
> I concur with what Thomas and others have said. If this draft is an extension to an IEEE protocol, have you considered proposing the extension to the relevant IEEE group(s)?
> 
> Best regards
> Ulrich
> 
> 
>> On Wed, Feb 26, 2014 at 8:40 AM, Thomas Heide Clausen <[email-masked]> wrote:
>>

---

From: Joe Macker <[email-masked]>
Date: Wed, 26 Feb 2014 13:28:27 -0500

Right, I think its not a matter of whether the work is interesting or not. Its a classic IEEE/IETF issue. This is basically building off an IEEE L2 protocol framework so it would seem that may be the better forum to consider publication and vetting.  

If there was more of how this interacts with an IP protocol or architecture maybe an IETF ID would be pertinent.  I see some terminology is used from IPSEC and AODV but I do not see IP layer issues directly addressed. 

Correct please me if I am wrong?  Likely the Routing ADs can provide better guidance since these issues may have cropped up in other ways.   Certainly many of us are interesting in L2 mesh routing solutions but we do not have a charter to work these issues.  Certainly manet routing algorithms have crossed over and seem some dual application and how IP protocols would interact with L2 is of interest.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 26 Feb 2014 18:43:35 +0000

I think that regardless of the process etc. questions (not that those are unimportant) if I picked up such an RFC I'd want it to be understandable (in more than just outline, if not every fine detail) stand alone, and where it chose not to repeat existing material, I'd want that referenced not just by document, but by section (at some level). As this is a security document, it would need a strong Security Considerations section (I must admit I haven't got that far in it) to explain itself, as well as good introductory material.

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: manet [mailto:[email-masked]] On Behalf Of Mallikarjun Avula
Sent: 26 February 2014 15:57
To: Velt, R. (Ronald) in 't
Cc: MANET IETF
Subject: Re: [manet] Fwd: draft-avula-shwmp-01

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Thank you all for your comments so far and I'd welcome more. I realize that there is no working group for Wireless Mesh Networks yet so I wanted to take comments from the closest working group which I think is MANET. I understand that my internet draft isn't quite suitable for IETF Manet WG as HWMP is layer-2 forwarding protocol. Is there any suitable WG that I can be directed to or do you think this draft better qualifies as an 'Independent Submission' under 'Experimental' category?

On Wed, Feb 26, 2014 at 8:34 AM, Velt, R. (Ronald) in 't <[email-masked]<mailto:[email-masked]>> wrote:
The former 802.11s (amendment 10 to 802.11) has been absorbed into IEEE 802.11-2012. The latter standard appears to be available at no charge through the IEEE Get Program ( http://standards.ieee.org/about/get/802/802.11.html ) .  HWMP is specified in clause 13.10 of 802.11-2012.

Ronald in 't Velt

>From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Heide
>Clausen
>> On 26 févr. 2014, at 11:28, Henning Rogge <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> <[email-masked]<mailto:[email-masked]>> wrote:
>[email-masked]<mailto:[email-masked]>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 26 Feb 2014 21:03:35 +0100

And I think that Chris is right, also regardless of forum. I happen to be a little disadvantaged, in that I know HWMP (and 802.11s) better than I really care to admit in public, so I hadn't really thought about that aspect that Chris points out.

As for security, that is actually a really tricky thing to get right in general - but in the 802.11 family there's an awful lot of existing security mechanisms and infrastructures to integrate with. That's actually the part that I'm not so familiar with in .11s ;)

Of course, I actually stopped reading when I got to the security considerations section, as such always give me a headache ;)

Cheers,

Thomas

Sent from my iPad

> On 26 févr. 2014, at 19:43, "Dearlove, Christopher (UK)" <[email-masked]> wrote:
> 
> For information regarding Red Flags that you can look out for in emails you receive, click here.
> If you feel the email is suspicious, please follow this process.
>