Subject: Re: [manet] DT output list and WG decision for DLEP

From: John Dowdell <[email-masked]>
Date: Sun, 4 May 2014 17:55:19 +0100

Abdussalam

I do not have time to search just now, but search the DLEP list around the
time of the last conference. The list is there for all to see, on an email
posted by Rick. Nothing is hidden.

John

On Wednesday, April 30, 2014, Henning Rogge <[email-masked]> wrote:

> Hi,
>
> I think Stan is just very busy with other things at the moment. The DT
> thinks we resolved all our open points, so the next draft will be the
> result of the design team to the mailing list. The DT can be shut down
> after this and we can have a look at the result on the Manet List,
> hopefully going towards a WGLC.
>
> Henning Rogge
>
> On Wed, Apr 30, 2014 at 3:53 PM, Abdussalam Baryun
> <[email-masked] <javascript:;>> wrote:
> > I need to see Rick's list mentioned in the 89 WG meeting. As
> > understood from the meeting there was consensus on going for a minimal
> > spec for DLEP and extensions for other future documents (and maybe
> > having WGLC after draft-06 in July 2014).
> >
> > AB
> >
> > _______________________________________________
> > manet mailing list
> > [email-masked] <javascript:;>
> > https://www.ietf.org/mailman/listinfo/manet
>
> _______________________________________________
> manet mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 5 May 2014 17:06:57 +0100

John,

The list mentioned in the meeting by Rick, I understood it was a new
one/update and it was to be sent to WG for the new version -06 to consider,
so I just asked if it can be sent/found and not only mentioned in minutes.
I may misunderstood.

AB

On Sunday, May 4, 2014, John Dowdell wrote:

> On Wednesday, April 30, 2014, Henning Rogge <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> wrote:
>
>> Hi,
>>
>> <[email-masked]> wrote:
>> > [email-masked]
>> [email-masked]

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 5 May 2014 19:59:31 +0000

AB,

The members of the design team reached consensus on content to be changed/added/deleted from -05 to create a -06. IIRC, Rick's email contained a synopsis of the conclusions reached by the members of the DT. For the record, I'll note again - the opinions of the DT are just that: Opinions. As always, it is up to the Working Group as a whole to reach consensus on any WG document.

As Henning mentioned in his email, I've been incredibly busy with my "day job" recently. I still plan on posting an 06 version of DLEP prior to the next IETF meeting for the working group to consider and comment on. As of this writing, I cannot provide a ETA - I'm still pretty swamped. As was also mentioned by Henning (and Rick in his original email), the DT decided to cease operation at the last IETF, as the members had reached consensus on all of the DT-chartered items.

Regards,
Stan

On May 5, 2014, at 12:06 PM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:

John,

The list mentioned in the meeting by Rick, I understood it was a new one/update and it was to be sent to WG for the new version -06 to consider, so I just asked if it can be sent/found and not only mentioned in minutes. I may misunderstood.

AB

I do not have time to search just now, but search the DLEP list around the time of the last conference. The list is there for all to see, on an email posted by Rick. Nothing is hidden.

John

On Wednesday, April 30, 2014, Henning Rogge <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
Hi,

Henning Rogge

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 6 May 2014 23:37:55 +0200

FWIW, I also recall discussions in London about a "list of issues pending resolution" that was to be posted to [email-masked] - but I do not think that I have seen that list yet.

And yes, I am the person compulsively checking the secret DLEP list on a daily basis, given that I am not allowed to receive mails sent to it in my email client.

Thomas

Sent from my iPad

> On 5 mai 2014, at 18:06, Abdussalam Baryun <[email-masked]> wrote:
> 
> John,
>

---

From: "Taylor, Rick" <[email-masked]>
Date: Wed, 7 May 2014 08:24:41 +0000

I prepared a list of issues and resolutions (the outstanding issues on the list were all resolved to the satisfaction of the DT members at London).

I have yet to post it to the ‘main’ list as I was waiting on feedback from the other DT members to make sure I hadn’t missed anything vital, but as that was some time ago I will give the DT members a last chance to protest on this list before sending it to here.

How does that sound?

Rick

From: manet [mailto:[email-masked]] On Behalf Of Thomas Heide Clausen
Sent: 06 May 2014 22:38
To: Abdussalam Baryun
Cc: manet
Subject: Re: [manet] DT output list and WG decision for DLEP

FWIW, I also recall discussions in London about a "list of issues pending resolution" that was to be posted to [email-masked]<mailto:[email-masked]> - but I do not think that I have seen that list yet.

Thomas

Sent from my iPad

On 5 mai 2014, at 18:06, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
John,

AB

John

Henning Rogge

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet
The information contained within this e-mail and any files attached to this e-mail is private and in addition may include commercially sensitive information. The contents of this e-mail are for the intended recipient only and therefore if you wish to disclose the information contained within this e-mail or attached files, please contact the sender prior to any such disclosure. If you are not the intended recipient, any disclosure, copying or distribution is prohibited. Please also contact the sender and inform them of the error and delete the e-mail, including any attached files from your system. Cassidian Limited, part of the Airbus Defence and Space division. Registered Office: Quadrant House, Celtic Springs, Coedkernew, Newport , NP10 8FZ. Registered in England and Wales under company number 04191036

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 7 May 2014 11:31:10 +0200

> On 7 mai 2014, at 10:24, "Taylor, Rick" <[email-masked]> wrote:
> 

It sounds a lot less frustrating than being kept completely in the dark ;)

Thomas

---

From: Rick Taylor <[email-masked]>
Date: Wed, 7 May 2014 15:34:13 +0000

Hi All,

Here is my updated list of TODOs that became DONEs (I reckon we should get
the output of our meeting on the main WG list while there is still lots of post meeting activity)

Stan has committed to updating the session initiation description to place the
TCP server in the modem, so the initial part of the protocol is:  Modem
broadcasts UDP Hello packets containing version, ident and TCP
address/port.  Router TCP connects, session initiation occurs via the new TCP
connection.

Credit windowing will stay in the document, but will be clearly marked as an
optional part of the protocol.  There was some concern raised over the clarity
of the current text which will need to be address before last call.

Vendor extensions will be defined using a new Data Item, containing a OUI
(or something from an existing registry) and space for a payload.  There will
need to be some guidance verbiage to characterise what is a valid vendor
extension and what is not.

There was clarification of what both ends of a DLEP session must do on
receipt of an unrecognized signal and data item.  For a data item, the receiver
MUST ignore the data item, for a signal the recipient MUST send an error
status signal and terminate the TCP connection.

There will be no facility in DLEP v1 for vendor extended signals.  Any extra
signals will require an uplift of the verion of the protocol and require a new
draft.

There will be no such thing as a Peer Characteristic Request.  This will prevent
abuse and misuse of the DLEP protocol to act as a configuration mechanism.

The latency and EFT metrics were agreed to be fundamentally the same metric,
whether EFT is used to measure the latency or some other algorithm, and so EFT
will be dropped from the draft, leaving latency, with some text covering the use
of EFT for defining latency.  Also, it was decided that latency should be defined as a
32-bit positive number of microseconds.

There was further discussion concerning multiple QoS flows with seperate
metrics across a single link.  This was agreed to be pushed out to another
draft after DLEP v1, after some analysis that the proposed approach
(hierarchical data items) will not break existing DLEP v1 implementations.  Stan
agreed to double check that the text specified 16bit length values for all TLVs
(data and signals).

There was discussion about enumerating error codes, and potential error
text.  The status signal MUST include an error code, 0 being success, others to
be enumerated after close analysis of the protocol, plus an optional free
text field to carry loggable information, capped at 80 bytes, utf8 encoded.

There was discussion of confidence values for metrics, and this was rejected
as a core DLEP mechanism, and the suggestion was to use an extension data
item TLV instead.

In light of achieving their goal of listing the outstanding points that needed
to be resolved before DLEP can make progress to WG last-call, and actually
achieving suitable consensus to resolve the outstanding issues to the
satisfaction of one of the authors present, the DT decided to not apply for a
continuation of their charter, and to instead announce "Mission Complete"

Rick

________________________________
From: manet [[email-masked]] on behalf of Thomas Heide Clausen [[email-masked]]
Sent: 07 May 2014 10:31
To: Taylor, Rick
Cc: manet
Subject: Re: [manet] DT output list and WG decision for DLEP

On 7 mai 2014, at 10:24, "Taylor, Rick" <[email-masked]<mailto:[email-masked]>> wrote:

How does that sound?

Thomas

Rick

Thomas

Sent from my iPad

AB

John

On Wednesday, April 30, 2014, Henning Rogge <[email-masked]<UrlBlockedError.aspx>> wrote:
Hi,

Henning Rogge

---

From: Teco Boot <[email-masked]>
Date: Wed, 7 May 2014 17:39:30 +0200

> It sounds a lot less frustrating than being kept completely in the dark ;)

There is nothing in the dark. The outcome of last meeting is on DLEP DT list. We wait on updated draft, where DT members check agreed issues and posted remarks are processed. Then, we release to MANET WG for feedback.

Teco

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 7 May 2014 16:50:26 +0000

On May 7, 2014, at 5:31 AM, Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>> wrote:

How does that sound?

It sounds a lot less frustrating

…for you, anyway… ;-)

Regards,
Stan

than being kept completely in the dark ;)

Thomas

Rick

Thomas

Sent from my iPad

AB

John

On Wednesday, April 30, 2014, Henning Rogge <[email-masked]<x-msg://379/>> wrote:
Hi,

Henning Rogge