Subject: [manet] Question to ADOVv2 applicability statement

From: Thomas Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 12:20:58 -0400

The draft states:

> The AODVv2 routing protocol is designed for stub (i.e., non-transit)   or disconnected (i.e.,
> from the Internet) mobile ad hoc networks   (MANETs).

Does this mean that this protocol does not support "attached network", as are known from OLSRv2 (and OLSR, even)? 

If the answer is "yes, it does support attached networks" then the statement quoted above is incorrect. 

If the answer is "no, it does not support attached network" then the statement quoted is correct -- but, it's a limitation of the protocol that I am not enthusiastic about

Sent from my iPad

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 16:48:48 +0000

I'm going to disagree here to some extent.

First, if we allow one (and only one) attached network then we can consider the MANET as a stub. (Obviously no attached networks is disconnected.)

So what about more than one attached network?

Just to get it out of the way, from insider the MANET, there is a definite issue as to whether those attached networks can be the same, different but overlapping, or must be disjoint. But that's not the issue here.

If we can have two (or more) attached networks, we could make the MANET a transit network. Which is a case some people want. But you could still make it behave only as if a stub from multiple places (I'd have to check my terminology to check if that's also classified as a stub).

So I think the two issues (stub only, number of attached networks) are related (because there's an impossible combination) but stub does not automatically exclude multiple attached networks.

I'm not sure what AODVv2 is offering here.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Thomas Clausen
Sent: 22 July 2014 17:21
To: manet
Subject: [manet] Question to ADOVv2 applicability statement

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Sent from my iPad
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 12:56:49 -0400

I think that you, actually, are not disagreeing with me here, Chris. 

I am not sure I understand what AODVv2 offers, either, in the context of "more than one attached network" - but, you do put it more eloquently than I.

> On 22 Jul 2014, at 12:48, "Dearlove, Christopher (UK)" <[email-masked]> wrote:
>