Subject: [manet] Submission of AODVv2 draft revision 04

From: Charlie Perkins <[email-masked]>
Date: Sun, 20 Jul 2014 23:22:44 -0700

Hello folks,

draft-ietf-manet-aodvv2-04.txt has been have submitted
for consideration.

The draft does not include proposed revisions for all of the
outstanding issues, and I fully expect that another revision will
be needed soon, especially after some reasonable text is crafted
to resolve the issues surrounding the security and threat models
affecting AODVv2.  Nevertheless, the inclusion of the new
appendix exhibiting some first-draft versions of algorithms for
processing AODVv2 messages seemed to merit publication of
release ...-04 as soon as possible.

I had intended to submit this revision before the IETF
Internet Draft deadline.  Unfortunately for me (and apparently
quite a few others) the deadline on Friday was a big surprise;
I had expected the deadline to be on the following Monday.
Please excuse this unintended delay.  My mistake will, I hope,
suggest closer tracking of possible changes in the submission
deadline for future IETF meetings.

I hope the submission will be considered useful for the
discussion this week, in conjunction with recent emails and
creation of new issues to summarize some other recent
discussion.

Regards,
Charlie P.

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 21 Jul 2014 15:39:39 +0100

Charlie,

Can you just confirm that the version you just posted is identical (i.e. 100%
the same) to the version you previously posted at
http://www.psg.com/~charliep/ietf90/draft-ietf-manet-aodvv2-pre04.txt

A

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Charlie Perkins
> Sent: 21 July 2014 07:23
> To: Mobile Ad Hoc Networks mailing list
> Subject: [manet] Submission of AODVv2 draft revision 04
> 
> Hello folks,
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 21 Jul 2014 11:08:22 -0700

Hello Adrian and all,

> http://www.psg.com/~charliep/ietf90/draft-ietf-manet-aodvv2-pre04.txt

No, I made the following revisions:
- fixed remaining instances of "retransmit" to instead use "regenerate"
- included information in the algorithms about when to insert AckReq TLV.

I submitted the document this morning quite early; when performing
rfcdiff just now I noticed a cut-and-paste error in section 13.5 that
should have been deleted.  It looks pretty much out of place, and so it
should be easy to ignore.  If bothersome, I can resubmit the document
to delete that now, or I can just wait until after the [manet] meeting
tomorrow.  I expect that the discussion tomorrow will suggest other
editorial revisions.

Regards,
Charlie P.