Subject: [manet] #46 (aodvv2): What is needed from IP and ICMP (submitted for Chris Dearlove)

From: "manet issue tracker" <[email-masked]>
Date: Mon, 21 Jul 2014 03:42:27 -0000

#46: What is needed from IP and ICMP (submitted for Chris Dearlove)

 The protocol needs many things from IP, such as failed routing
 notification, and interacts with it in ways such as queuing packets.
 It also interacts (sends and receives) with ICMP, and I'm not sure
 what else. This needs to be put together, so the reader can see what
 is needed to be able to implement this.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-manet-
  [email-masked]  |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  minor        |  Milestone:
Component:  aodvv2       |    Version:
 Severity:  Active WG    |   Keywords:  IP/ICMP interaction
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <https://tools.ietf.org/wg/manet/trac/ticket/46>
manet <http://tools.ietf.org/manet/>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 20 Jul 2014 21:39:35 -0700

Hello Chris,

I am pretty sure that the only things needed from IP and ICMP are
features that are already mandated by IP (including ICMP).  If there
were danger that AODVv2 might require optional features of IP or
optional features of ICMP, I could understand your concern.  As it is,
I do not understand exactly what is needed to enhance implementability
of the specification.

The only thing expected from ICMP is delivery of Destination Unreachable
(Type 3 Code 1).  Is this something that implementations are unlikely
to provide?

I am confused about what (other than ICMP) AODVv2 "needs" from
IP that could cause a problem.  True, we do expect IP to find the proper
outgoing interface, and to perform longest-prefix-first matching, and
so on...

Do you have an example of some other protocol specification that
lists these kinds of dependencies?

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 12:37:16 +0000

Just for a start you also need to know that IP routes are requested, that packets are flowing, and to have the ability to queue packets. I'm pretty sure not all of those are mandated by IP. The routing protocol also needs to see ICMP messages - is that normal?

As I said, it's a matter of what the whole architecture looks like.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: 21 July 2014 05:40
To: [email-masked]; [email-masked]; Dearlove, Christopher (UK)
Subject: Re: [manet] #46 (aodvv2): What is needed from IP and ICMP (submitted for Chris Dearlove)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello Chris,

I am pretty sure that the only things needed from IP and ICMP are features that are already mandated by IP (including ICMP).  If there were danger that AODVv2 might require optional features of IP or optional features of ICMP, I could understand your concern.  As it is, I do not understand exactly what is needed to enhance implementability of the specification.

The only thing expected from ICMP is delivery of Destination Unreachable (Type 3 Code 1).  Is this something that implementations are unlikely to provide?

I am confused about what (other than ICMP) AODVv2 "needs" from IP that could cause a problem.  True, we do expect IP to find the proper outgoing interface, and to perform longest-prefix-first matching, and so on...

Do you have an example of some other protocol specification that lists these kinds of dependencies?

--
Regards,
Charlie P.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 15:00:52 +0200

> On 22 Jul 2014, at 14:37 , Dearlove, Christopher (UK) <[email-masked]> wrote:
> 

Just to pile on to what Chris says here.
There is this whole thing of an “active route” being one that is actually used for forwarding data traffic, and that the IP stack needs to somehow record and report this to the protocol.

That’s actually a pretty invasive operation, and I am not certain that all platforms allow for that, and I know that there’re platforms where you really don’t want to do that.

Such things scope pretty narrowly the applicability of the protocol, and it therefore must be called out in the applicability statement (currently this constraint is buried pretty deep in section 5 and 6).

There’re — as Chris indicate — a lot of things of this nature, where this protocol interacts in “non-traditional” ways with the IP stack, and these need to be called out very explicitly. 

This both to allow identifying the platforms on which this protocol can be made operate (and those where it cannot), and to correctly identify the complexity of implementing this protocol on a given platform.

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "manet issue tracker" <[email-masked]>
Date: Tue, 22 Jul 2014 18:10:19 -0000

Changes (by [email-masked]):

 * owner:  [email-masked] => [email-masked]

-- 
-----------------------------------+------------------------------------
 Reporter:  [email-masked]  |       Owner:  [email-masked]
     Type:  defect                 |      Status:  new
 Priority:  minor                  |   Milestone:
Component:  aodvv2                 |     Version:
 Severity:  Active WG Document     |  Resolution:
 Keywords:  IP/ICMP interaction    |
-----------------------------------+------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/manet/trac/ticket/46#comment:1>
manet <http://tools.ietf.org/manet/>