Subject: [manet] Topologies and Metrics

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 4 Jul 2014 13:38:07 +0000

The more I think about this, the more I believe that the correct approach is to go with what we currently have, topology = metric, in the current Experimental draft. This gives us something where we don't try to make a rushed approach to whether we can split the concepts well, that we can implement more easily and experiment with, in particular to find out how useful it is. The only downside is possibly larger messages.

We can then later, if someone comes up with a good idea that we can kick around, update to a new Experimental RFC, or not if nothing good comes along. Otherwise we run the risk of not taking something that (I hope) is good today rather than the possibility of something better later. Without throwing away that latter possibility.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 04 Jul 2014 15:59:00 +0200

> The more I think about this, the more I believe that the correct approach is
> to go with what we currently have, topology = metric, in the current
> Experimental draft.

It's experimental.  There's certainly space for multiple simultaneous
experiments.

-- Juliusz

---

From: Christopher Dearlove <[email-masked]>
Date: Fri, 4 Jul 2014 15:07:53 +0100

Indeed, though I think starting with this one (as Henning already has) is what I'd do.

--  
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

On 4 Jul 2014, at 14:59, Juliusz Chroboczek <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Thomas Clausen <[email-masked]>
Date: Fri, 4 Jul 2014 16:12:10 +0200

Chris, all,

On Jul 4, 2014, at 15:38, Dearlove, Christopher (UK) <[email-masked]> wrote:

> The more I think about this, the more I believe that the correct approach is to go with what we currently have, topology = metric, in the current Experimental draft. This gives us something where we don’t try to make a rushed approach to whether we can split the concepts well, that we can implement more easily and experiment with, in particular to find out how useful it is. The only downside is possibly larger messages.
>  

I fully agree with you on the above. A bit of a backstory might be in order….

When the initial versions of this I-D were posted, the authors (together and apart) tried to work out different ways of separating “metric” and “topology” — turns out that a lot of the “simple, easy” (as well as not-so-simple and a good deal harder) approaches don’t work, and that those that might (emphasis on might) work were quite horrible....

Contemplating the “deployment space” that I know of, I think that what we came up with in this specification is a reasonable compromise: considering the “metrics” as “topology type” extending the administratively assigned metrics code-point space.

The advantage is that we know it works (yes, there’s running code), and is fairly clean and simple.

As Chris says, this is experimental - i.e., non-prescriptive. The idea is to get more experiences with multi-topology routing. Part of that experience will (I hope) lead to an epiphany as to how to do something that’s better (or a realization that we either need no more, or can’t do better). That’s when we should spin a new either experimental or PS version.

Thomas

> [email-masked] | http://www.baesystems.com
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 4 Jul 2014 16:49:04 +0200

On Fri, Jul 4, 2014 at 3:38 PM, Dearlove, Christopher (UK)
<[email-masked]> wrote:
> We can then later, if someone comes up with a good idea that we can kick
> around, update to a new Experimental RFC, or not if nothing good comes
> along. Otherwise we run the risk of not taking something that (I hope) is
> good today rather than the possibility of something better later. Without
> throwing away that latter possibility.

I have no problem with this... the new experimental draft should only
be "compatible" with this one, so we can combine both of them.

Henning

---

From: Christopher Dearlove <[email-masked]>
Date: Fri, 4 Jul 2014 16:12:52 +0100

A hypothetical replacement draft could even be incompatible with this one, although compatibility would be ideal of course.

> On 4 Jul 2014, at 15:49, Henning Rogge <[email-masked]> wrote:
>

---

From: Thomas Clausen <[email-masked]>
Date: Fri, 4 Jul 2014 17:39:54 +0200

> A hypothetical replacement draft could even be incompatible with this one, although compatibility would be ideal of course.

I’m guessing that what Henning means by “compatible” means “the two can run on the same devices at the same time and provide complementary functionalities/services”. 

I’m guessing that what Chris means when he talks about a “replacement draft” is that “interoperability between old and new would be good, but not required”

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 5 Jul 2014 00:55:17 +0100

I agree with not separating them, which seems the simpler multitopology
routing, but we can add one section in the draft to identify WG future
considerations of multitopology as with separation and may identify the
challenges that Thomas and Chris observed.

AB

On Friday, July 4, 2014, Thomas Clausen wrote:

> Chris, all,
>
> On Jul 4, 2014, at 15:38, Dearlove, Christopher (UK) <
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> The more I think about this, the more I believe that the correct approach
> is to go with what we currently have, topology = metric, in the current
> Experimental draft. This gives us something where we don’t try to make a
> rushed approach to whether we can split the concepts well, that we can
> implement more easily and experiment with, in particular to find out how
> useful it is. The only downside is possibly larger messages.
>
> When the initial versions of this I-D were posted, the authors (together
> and apart) tried to work out different ways of separating “metric” and
> “topology” — turns out that a lot of the “simple, easy” (as well as
> not-so-simple and a good deal harder) approaches don’t work, and that those
> that might (emphasis on might) work were quite horrible....
>
> Contemplating the “deployment space” that I know of, I think that what we
> came up with in this specification is a reasonable compromise: considering
> the “metrics” as “topology type” extending the administratively assigned
> metrics code-point space.
>
> As Chris says, this is experimental - i.e., non-prescriptive. The idea is
> to get more experiences with multi-topology routing. Part of that
> experience will (I hope) lead to an epiphany as to how to do something
> that’s better (or a realization that we either need no more, or can’t do
> better). That’s when we should spin a new either experimental or PS version.
>
> Thomas
>
>
>
> --
> Christopher Dearlove
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');> |
> http://www.baesystems.com
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Sun, 6 Jul 2014 23:20:37 +0000

Chris,

Speaking as  a WG participant - I completely agree with you here. If we're going to publish as experimental, then let's publish what we have. If people want to experiment further, that's great. The further experiments may (or may not) result in follow-on drafts. Either way, let's move forward with the current approach.

Just my 2-cents-worth.

Regards,
Stan

On Jul 4, 2014, at 9:38 AM, "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>> wrote:

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com<http://www.baesystems.com/>

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet