Subject: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-03.txt

From: [email-masked]
Date: Fri, 04 Jul 2014 07:19:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

        Title           : Multi-Topology Extension for the Optimized Link State Routing Protocol version 2 (OLSRv2)
        Authors         : Christopher Dearlove
                          Thomas Heide Clausen
	Filename        : draft-ietf-manet-olsrv2-multitopology-03.txt
	Pages           : 20
	Date            : 2014-07-04

Abstract:
   This specification describes an extension to the Optimized Link State
   Routing Protocol version 2 (OLSRv2) to support multiple routing
   topologies, while retaining interoperability with OLSRv2 routers that
   do not implement this extension.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multitopology/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-manet-olsrv2-multitopology-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-olsrv2-multitopology-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Henning Rogge <[email-masked]>
Date: Tue, 8 Jul 2014 09:26:25 +0200

>         Filename        : draft-ietf-manet-olsrv2-multitopology-03.txt

The new draft looks fine... have to check my implementation again that
it does the right job.

could you maybe replace the (FGAN) reference to (Fraunhofer FKIE)?
FGAN doesn't exist anymore, it became three Fraunhofer institutes in
2009 (and my institute is Fraunhofer FKIE).

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 8 Jul 2014 08:46:43 +0000

We'll put that in our next working draft version, so when we change for another reason (I live in hope it will be
somewhere down the line) we'll make it. That will be before an RFC!

I suspect your implementation will need a few minor changes, first to simply always put the MPR_TYPES
TLV in, and second to treat a message with and without it differently.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 08 July 2014 08:26
To: [email-masked]
Cc: MANET IETF; [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-03.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

>         Filename        : draft-ietf-manet-olsrv2-multitopology-03.txt

The new draft looks fine... have to check my implementation again that it does the right job.

Henning Rogge

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Henning Rogge <[email-masked]>
Date: Tue, 8 Jul 2014 18:21:42 +0200

> somewhere down the line) we'll make it. That will be before an RFC!

Thank you.
> TLV in, and second to treat a message with and without it differently.

The implementation is only on -02 level (with a few bugs I assume). I
will inform you when I think its -03 capable.

Henning Rogge