Subject: [manet] Ready for WGLC: Advancing draft-ietf-manet-nhdp-optimization & draft-clausen-manet-rfc6779bis

From: Thomas Clausen <[email-masked]>
Date: Mon, 28 Jul 2014 15:33:22 +0200

Dear WG Chairs, co-authors, all,

As indicated in Toronto, the authors believe that the remaining issue with draft-ietf-manet-nhdp-optimization was how to properly do the updates to the MIB module of RFC6779.

We believe that Toronto confirmed that the way forward was to do an RFC6779bis document, which reflects the MIB considerations section (Section 6) from draft-ietf-manet-nhdp-optimization, which the WG already adopted, into RFC6779.

As Ulrich indicated in his recent mail, this is what draft-clausen-manet-rfc6779bis does — nothing more, nothing less.

I believe that with this issue resolved, draft-ietf-manet-nhdp-optimization & draft-clausen-manet-rfc6779bis essentially are ready for WGLC. 

As a reminder, both documents aims publication as an Proposed Standard RFCs.

Procedurally, I would like to enter a rapid succession of:

	1)	Submission of draft-clausen-manet-rfc6779bis-00 as draft-ietf-manet-rfc6779bis-00

	2)	Submission of draft-ietf-manet-nhdp-optimization-01, with the only difference to -00
		being section 6 removed, and replaced by a reference to 
		draft-clausen-manet-rfc6779bis-00 as draft-ietf-manet-rfc6779bis-00

	3)	A WGLC being issued for both these documents, concurrently.

WG Chairs, would you kindly let us know your thoughts on this matter, at your earliest convenience, so that we may aim at a WGLC soon, such that the WG will have visible progress to report at the RTG Area Open Meeting?

Respectfully,

Thomas

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 29 Jul 2014 14:36:03 +0000

Thomas,

On Jul 28, 2014, at 9:33 AM, Thomas Clausen <[email-masked]<mailto:[email-masked]>> wrote:

I don't agree with you here, mainly because:
1. draft-clausen-manet-rfc6779bis-00 technically isn't even a WG document,
2. You state the documents are ready for WGLC, then outline a proposal for updating them. I'd rather see any known edits go into WGLC, instead of either running concurrently with WGLC.

Here's what I propose going forward:
1. I'll issue an email calling for WG adoption of draft-clausen-manet-rfc6779bis
2. If the WG adopts draft-clausen-rfc6779bis, then you can update draft-ietf-manet-nhdp-optimization (or, if you feel certain about WG adoption, you are free to update nhdp-optimization at any time)
3. If the WG adopts draft-clausen-rfc6779bis, I will then call for WGLC on both documents, once the update to draft-ietf-manet-nhdp-optimization is done.

Regards,
Stan

Respectfully,

Thomas
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 29 Jul 2014 14:38:50 +0000

Working group participants - 

This is a call to adopt draft-clausen-manet-rfc6779bis as a Working Group document. If you have issues with the WG accepting this document, please note them on the list before close of business on Aug 5, 2014. Lack of a response will be seen as a vote to accept the document. 

Regards,
Stan

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 29 Jul 2014 16:52:29 +0200

Sounds like something which can offer progress, Stan, so please proceed with that. 

Thomas

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

> On 29 juil. 2014, at 16:36, Stan Ratliff (sratliff) <[email-masked]> wrote:
> 
> Thomas, 
> 
>> On Jul 28, 2014, at 9:33 AM, Thomas Clausen <[email-masked]> wrote:
>> 
>> 1)
>> Submission of draft-clausen-manet-rfc6779bis-00 as draft-ietf-manet-rfc6779bis-00
>> 
>> 2)
>> Submission of draft-ietf-manet-nhdp-optimization-01, with the only difference to -00
>> 3)
>> A WGLC being issued for both these documents, concurrently.
>> 
>> [email-masked]

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 29 Jul 2014 15:21:35 +0000

Much as I want things to go as quickly as possible, I have to agree with Stan that 6779bis should be accepted as a WG document first. WGLC on both (we'll have the updated drafts ready) directly thereafter will be good.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: Stan Ratliff (sratliff) [mailto:[email-masked]]
Sent: 29 July 2014 15:36
To: Thomas Clausen
Cc: manet; <[email-masked]>; manet-ads; Christopher Dearlove
Subject: Re: [manet] Ready for WGLC: Advancing draft-ietf-manet-nhdp-optimization & draft-clausen-manet-rfc6779bis

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Thomas,

As Ulrich indicated in his recent mail, this is what draft-clausen-manet-rfc6779bis does - nothing more, nothing less.

Regards,
Stan

1)

2)

3)

Respectfully,

Thomas

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 29 Jul 2014 17:36:13 +0200

As long as we get the ball rolling, I am more than happy with what Stan proposes, and what he already has set in motion. Thank you, Stan. 

> On 29 juil. 2014, at 17:21, Dearlove, Christopher (UK) <[email-masked]> wrote:
> 
> Much as I want things to go as quickly as possible, I have to agree with Stan that 6779bis should be accepted as a WG document first. WGLC on both (we’ll have the updated drafts ready) directly thereafter will be good.
>  
> --
> Christopher Dearlove
> [email-masked] | http://www.baesystems.com
> 
> For information regarding Red Flags that you can look out for in emails you receive, click here.
> If you feel the email is suspicious, please follow this process.
> 
> Thomas, 
>