Subject: [manet] MANET action items (as seen by Justin Dean)

From: Justin Dean <[email-masked]>
Date: Tue, 22 Jul 2014 16:35:18 -0400

Notes on action items coming out of the MANET working group meeting. (this
list is not exhaustive of the topics covered in the meeting)

1) A suggestion was made to ask Stan if dlep editing help would be helpful.
If yes who should that person(s) be?

2) What to do with the report MIB; Kill, finish, revise?

3) Request for WG adoption of SMF sec threat document was made.  No one in
the room had read the draft, but there was positive room reaction to
adopting a document with this subject and no negative reaction as measured
by hum.  Please read the draft and comment.

4) Request for WG adoption of OLSRv2 sec threat document was made.  No one
in the room had read the draft, but there was positive room reaction to
adopting a document with this subject and no negative reaction as measured
by hum. Please read the draft and comment.

5) Ulrich volunteered to shepherd multi-topology draft.

6) Request for WG adoption of OLSRv2 multi-path for experimental status was
made.  No one in the room had read the draft, there was mixed but positive
reaction as measured by hum.  Please read the draft and comment.

7) Request for WG adoption of ODMRP was made.  Discussion within the room
touched upon the charter and was generally positive to multicast work but
again charter. No hum was held.

Justin Dean

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 23 Jul 2014 14:18:54 +0200

On Tue, Jul 22, 2014 at 10:35 PM, Justin Dean <[email-masked]> wrote:

> 1) A suggestion was made to ask Stan if dlep editing help would be
> helpful. If yes who should that person(s) be?
>

The WG should read the draft and discuss before adopting or humming and I
hope the chairs consider the high volume of drafts to give me more time
before their decisions.

> by hum. Please read the draft and comment.

I usual not only no read but no discussions. Discussions and reviews are
more important than just reading with no work.

> 5) Ulrich volunteered to shepherd multi-topology draft.

There was not enough time for me to review this work but still will submit
my review

>
> 6) Request for WG adoption of OLSRv2 multi-path for experimental status
> was made.  No one in the room had read the draft, there was mixed but
> positive reaction as measured by hum.  Please read the draft and comment.
>

I reject until we get time to review and do our priorities on other drafts.

> again charter. No hum was held.

I dont support adopting reactive multicast until we finish the reactive
standard

AB

>
>
> Justin Dean
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 28 Jul 2014 15:58:14 +0200

Abdussalam,

On Jul 23, 2014, at 14:18, Abdussalam Baryun <[email-masked]> wrote:

> Notes on action items coming out of the MANET working group meeting. (this list is not exhaustive of the topics covered in the meeting)
> 
> 1) A suggestion was made to ask Stan if dlep editing help would be helpful. If yes who should that person(s) be?
> 
> 3) Request for WG adoption of SMF sec threat document was made.  No one in the room had read the draft, but there was positive room reaction to adopting a document with this subject and no negative reaction as measured by hum.  Please read the draft and comment.
>  
> The WG should read the draft and discuss before adopting or humming and I hope the chairs consider the high volume of drafts to give me more time before their decisions.

The documents were submitted well in advance of the meeting, before the document submission deadline that precedes all IETF meetings, and were announced on the list at about the same time.

There were not a whole lot of new WG documents in MANET this time around, and there were no updates to two of the documents which otherwise are WG documents, made before that official deadline — compared to other WGs, I don’t think that this can be considered a particularly high volume of drafts, and the drafts are not particularly complex nor wrong either.

> 6) Request for WG adoption of OLSRv2 multi-path for experimental status was made.  No one in the room had read the draft, there was mixed but positive reaction as measured by hum.  Please read the draft and comment.
>  

I agree, that it would be good to see forward progress on the documents, for which there has been none. 

As you have no doubt also observed, for both draft-ietf-manet-aodvv2 and draft-ietf-manet-dlep, there have been ample feedback and reviews given on the mailing list, but (for the former) that feedback has not been reflected in the recent versions of the document, and (for the latter) there has been no new version for a while (but, a lot of good discussion).

While the authors of these two documents work to figure out to spin new revisions among themselves, revisions which fold in all the feedback that the WG has provided, the rest of the WG can’t be expected to simply idle when there’re other things to do.

Perhaps your volunteering to help the authors of draft-ietf-manet-aodvv2 and draft-ietf-manet-dlep in the editorial process might be a way for you to contribute to making progress?

> 7) Request for WG adoption of ODMRP was made.  Discussion within the room touched upon the charter and was generally positive to multicast work but again charter. No hum was held.
>  
> I dont support adopting reactive multicast until we finish the reactive standard

For what it’s worth, there’s actually no dependency between ODMRP and the reactive unicast protocol — I would even make the case that ODMRP would work quite nicely on a network on which OLSRv2 provides unicast routing, since ODMRP in that case could take advantage of OLSRv2’s optimized flooding (for example) for diffusing its control messages and maintaining link status tracking. 

Thomas