Subject: Re: [manet] [manet-dlep-rg] DLEP extension draft submitted

From: Henning Rogge <[email-masked]>
Date: Tue, 8 Jul 2014 10:14:21 +0200

On Mon, Jun 30, 2014 at 5:18 PM, Rick Taylor
<[email-masked]> wrote:
> For those who are interested,
>
> We have just submitted an individual draft with a proposed extension to DLEP for layer-3 forwarding modems: http://www.ietf.org/internet-drafts/draft-taylor-manet-l3-dlep-00.txt
>
> We have a slot at IETF90 to present and field any questions.
>
> Of course, any feedback on the list is always welcome.

How does this extension of DLEP interact with a peer (radio or router)
that does NOT support this extension? Can I expect that a standard
DLEP router drops the connection the the "extended DLEP" radio? We
specified that we ignore unknown TLVs in known signals...

Henning Rogge

---

From: Rick Taylor <[email-masked]>
Date: Wed, 9 Jul 2014 12:06:58 +0000

>From: Henning Rogge [mailto:[email-masked]] 

> How does this extension of DLEP interact with a peer (radio or router) that does NOT support this extension? Can I expect that a standard DLEP router drops the connection the the "extended DLEP" radio? We specified that we ignore unknown TLVs in known signals...

This is one of the areas I am really hoping that the core DLEP spec sorts out.  The error handling for this kind of thing is currently too loose for my liking, and I expect to have to change that part of the text as the next draft of DLEP comes out.

Rick

---

From: Henning Rogge <[email-masked]>
Date: Wed, 9 Jul 2014 14:11:51 +0200

> This is one of the areas I am really hoping that the core DLEP spec sorts out.  The error handling for this kind of thing is currently too loose for my liking, and I expect to have to change that p…

The problem I see is that this specification breaks the basic
assumptions of DLEP (the bridged radio). This means its not an
extenstion of the DLEP draft but it shares some signalling.

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 10 Jul 2014 07:23:47 +0100

I see this extension reasonable, it is not able to be interacting with
our DLEPv1 but it may be called DLEP-E to distinguish that it is not
interacting with DLEP. I hope we finish DLEP to look into this interesting
draft.

AB

On Wed, Jul 9, 2014 at 1:11 PM, Henning Rogge <[email-masked]> wrote:

> that does NOT support this extension? Can I expect that a standard DLEP
> router drops the connection the the "extended DLEP" radio? We specified
> that we ignore unknown TLVs in known signals...
> >
> > This is one of the areas I am really hoping that the core DLEP spec
> sorts out.  The error handling for this kind of thing is currently too
> loose for my liking, and I expect to have to change that part of the text
> as the next draft of DLEP comes out.
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>