Subject: Re: [manet] DLEP/satellite - how to arp

From: Toerless Eckert <[email-masked]>
Date: Fri, 25 Jul 2014 04:31:09 -0700

This thread is getting long and discusses a lot of aspects. Maybe split
it up to conclude on different aspects.

I am confused about what options are required to send IP unicast
packets:

1) Non-Broadcast-Multi-Access radio network. Sending of ethernet
multicast/broadcast not supported. Therefore ARP does not work. Therefore
DLEP must announce MAC and IP address of destinations.

2) Broadcast multi-access nework, eg: Satellite. Sending of ethernet
multicast/broadcast supported, ARP works, DLEP does not need to carry
destination IP-addresses, DLEP not required to supplant ARP.

3) Something else: radio network expects routers to insert any DMAC
other than the natural destination MAC address of a destination into
unicast IP packets. Like some default MAC address.

Some mails sounded as if there was an ask for 3). I hope there is not.

Thanks
    Toerless

---

From: Rick Taylor <[email-masked]>
Date: Fri, 25 Jul 2014 13:46:03 +0000

Comments in line

Good plan

packets:

The number of use-cases is starting to grow to greater number than the core DLEP originally tried to address.

This (I believe) is beyond the scope of core DLEP.  I have kit like this, hence my proposed extension, but I would be very happy to merge my work into the core spec.

This is the mode DLEP was developed to address, and expects the modems to operate in.

This I believe is what Brian thinks he needs, not at the packet level, but as a DLEP identifier (which re-uses the MAC).  But my (new) opinion is that 'wildcard' destinations might create more problems than they solve. I don't think what Brian is asking for is unreasonable, in giant hub-spoke networks there has to be a way to manage the load on the spoke DLEP modem agent, I'm just not sure we have the recommended solution for him yet. 

Cheers,

Rick

---

From: "Snyder, Brian" <[email-masked]>
Date: Fri, 25 Jul 2014 13:53:14 +0000

I would say I'm more in line with requesting #2.  ie: DLEP not required to supplant ARP.

brian

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]] 
Sent: Friday, July 25, 2014 9:46 AM
To: Toerless Eckert; Snyder, Brian
Cc: [email-masked]; Stan Ratliff (sratliff)
Subject: RE: [manet] DLEP/satellite - how to arp

Comments in line

Good plan

packets:

> 1) Non-Broadcast-Multi-Access radio network. Sending of ethernet
multicast/broadcast not supported. Therefore ARP does not work. Therefore DLEP must announce MAC and IP address of destinations.

> 2) Broadcast multi-access nework, eg: Satellite. Sending of ethernet
multicast/broadcast supported, ARP works, DLEP does not need to carry destination IP-addresses, DLEP not required to supplant ARP.

> 3) Something else: radio network expects routers to insert any DMAC
other than the natural destination MAC address of a destination into unicast IP packets. Like some default MAC address.

Cheers,

Rick

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 25 Jul 2014 10:28:08 -0700

> This (I believe) is beyond the scope of core DLEP.  I have kit like this, hence my proposed extension, but I would be very happy to merge my work into the core spec.

Oh. That makes me surprised. I thought this is the use case why DLEP can signal
not only MAC address, but also IP-address of destinations. If not for this use-case,
what then is the signaling of the IP-address of a destination good for ?
> This I believe is what Brian thinks he needs, not at the packet level, but as a DLEP identifier (which re-uses the MAC).  But my (new) opinion is that 'wildcard' destinations might create more prob…

Right, but when we only do this at the DLEP level, thats the other mail thread.
Here i am just trying to figure out if there are any use cases expecting that
routers fudge around with actual data packet DMACs. And i am happy if not ;-)

Cheers
    Toerless