Subject: Re: [manet] New DLEP reference implementation?

From: Rick Taylor <[email-masked]>
Date: Wed, 23 Jul 2014 19:25:01 +0000

Rex

The main objective of DLEP is to hide the details of the operation and topology of the radio net from attached routers and just provide a simple common signalling protocol for the local link between one radio and its attached modems.

Any reference implementation must follow this abstraction by definitely not getting into specific modem/waveform modelling.

Hope that helps

Rick

Sent from my HTC

----- Reply message -----
From: "Snyder, Brian" <[email-masked]>
To: "Rex Buddenberg" <[email-masked]>, "Rick Taylor" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [manet] New DLEP reference implementation?
Date: Wed, Jul 23, 2014 14:35

Rex,

I would have check with the suits about sharing anything like that. I'm not sure what the status is, I'm guessing (even mostly sure) its considered proprietary.  Regardless though, it's a different discussion that doesn't have anything to do with DLEP or MANET in particular.

Thanks,
Brian

-----Original Message-----
From: Rex Buddenberg [mailto:[email-masked]]
Sent: Wednesday, July 23, 2014 2:18 PM
To: Rick Taylor
Cc: Snyder, Brian; [email-masked]
Subject: Re: [manet] New DLEP reference implementation?

Rick, Brian,

Working the interface between layer 2 and layer 3 is always, er, interesting.  One of the things I was suggesting was use of IEEE 802's agreed language for layer 2 artifacts (e.g. BS and SS instead of 'modem').  This is a social problem getting a couple of different engineering communities talking accurately.
     I probably was a little overextending this by delving into the specific MAC parts of 802.16 ... back some of that up.

'Radio magic'.  Here we have another case of multiple communities communicating awkwardly (I have the scars*).  802.16 was derived from DOCSIS.  The working group essentially used the layer 2 MAC from DOCSIS and bolted on a radio interface instead of cable.  So I'd have a hard time saying anything that I'd waved at you earlier 'radio magic'.  'MAC magic' perhaps.

*if you want a sample, track down the 101 different uses of the term 'waveform'.

Brian, I would be interested in more information about
> our entire tdma access control
Most satcom programs have been somewhat proprietary about such information.

Hopefully shedding light and not so much heat.

b

On Wed, 2014-07-23 at 17:41 +0000, Rick Taylor wrote:
> Rex,
>
> I'm with Brian on this one, in DLEP terms what you discuss is definitely 'radio magic', and the intention of a reference implementation is to demonstrate via code how one might go about implementing DLEP for a router or radio.  The details of the radio is definitely out of scope; I don't want to get caught up in a TDMA/CDMA/whatever emulator.
>
> My musings about a console interface to the DLEP code in radio mode is more along the lines of:
>
> >New Link Radio 3 to Radio 2
> Radio 3 is now linked to radio by link 7.
> >Link 7 CDR 2300, Up
> Link 7 now up, CDR: 2300Kbps.
> DLEP Destination_Up signals sent to: Radio 3, Radio 2.
> >Quit
> Goodbye...
>
> Does that clarify?
>
> Rick

---

From: Rex Buddenberg <[email-masked]>
Date: Wed, 23 Jul 2014 13:39:45 -0700

On Wed, 2014-07-23 at 19:25 +0000, Rick Taylor wrote:
> Rex
> 
> 
> The main objective of DLEP is to hide the details of the operation and
> topology of the radio net from attached routers and just provide a
> simple common signalling protocol for the local link between one radio
> and its attached modems.

Violently agreeing, Rick.
> 
> 
> Any reference implementation must follow this abstraction by
> definitely not getting into specific modem/waveform modelling.

Also again we agree.

Writing a layer 2/layer 3 interface protocol must be difficult -- we've
tried many times and for naught.  (Not just in MANET -- autconf, pilc;
IEEE 802 has also got a false start or two -- 802.23).  While the
interface needs to be simple, it needs to be crafted from knowledge of
the complexities on both sides of the layer boundary -- apparently not
an easy paradox.

> I would have check with the suits about sharing anything like that.
> I'm not sure what the status is, I'm guessing (even mostly sure) its
> considered proprietary.  Regardless though, it's a different
> discussion that doesn't have anything to do with DLEP or MANET in
> particular.
> 
> Thanks,
> Brian
> 
> Working the interface between layer 2 and layer 3 is always, er,
> interesting.  One of the things I was suggesting was use of IEEE 802's
> agreed language for layer 2 artifacts (e.g. BS and SS instead of
> 'modem').  This is a social problem getting a couple of different
> engineering communities talking accurately.  
>      I probably was a little overextending this by delving into the
> specific MAC parts of 802.16 ... back some of that up.
> 
> 'Radio magic'.  Here we have another case of multiple communities
> communicating awkwardly (I have the scars*).  802.16 was derived from
> DOCSIS.  The working group essentially used the layer 2 MAC from
> DOCSIS and bolted on a radio interface instead of cable.  So I'd have
> a hard time saying anything that I'd waved at you earlier 'radio
> magic'.  'MAC magic' perhaps.
> 
> 
> > I'm with Brian on this one, in DLEP terms what you discuss is
> definitely 'radio magic', and the intention of a reference
> implementation is to demonstrate via code how one might go about
> implementing DLEP for a router or radio.  The details of the radio is
> definitely out of scope; I don't want to get caught up in a
> TDMA/CDMA/whatever emulator.
> >