Subject: [manet] Fwd: New Version Notification for draft-ietf-manet-olsrv2-dat-metric-01.txt

From: Henning Rogge <[email-masked]>
Date: Tue, 22 Jul 2014 16:08:41 +0200

Hi,

I uploaded an update to my DAT metric draft to the IETF database.

The update is a minor one, moving "one bit" of the metric range from the
"link speed" to the "packet loss" part, changing the "minimal link
speed" to 1000 (instead of 1024) and adding an appendix that talks about
my experience with stabilizing the raw linkspeed of an interface.

Unless someone finds another problem with the draft I think we should
consider going towards WGLC...

Henning Rogge

-------- Forwarded Message --------
Subject: New Version Notification for
draft-ietf-manet-olsrv2-dat-metric-01.txt
Date: Tue, 22 Jul 2014 07:01:54 -0700
From: [email-masked]
To: Emmanuel Baccelli <[email-masked]>, Henning Rogge
<[email-masked]>, Emmanuel Baccelli
<[email-masked]>, Henning Rogge
<[email-masked]>

A new version of I-D, draft-ietf-manet-olsrv2-dat-metric-01.txt
has been successfully submitted by Henning Rogge and posted to the
IETF repository.

Name:		draft-ietf-manet-olsrv2-dat-metric
Revision:	01
Title:		Packet Sequence Number based directional airtime metric for OLSRv2
Document date:	2014-07-22
Group:		manet
Pages:		16
URL:
http://www.ietf.org/internet-drafts/draft-ietf-manet-olsrv2-dat-metric-01.txt
Status:
https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-dat-metric/
Htmlized:
http://tools.ietf.org/html/draft-ietf-manet-olsrv2-dat-metric-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-olsrv2-dat-metric-01

Abstract:
   This document specifies an directional airtime link metric for usage
   in OLSRv2.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 16:14:05 +0200

> On 22 Jul 2014, at 16:08 , Henning Rogge <[email-masked]> wrote:
> 
> Hi,
> 
> consider going towards WGLC…

That’s just awesome. 

I read the previous version (-00) and had a few nits (and they were just nits). Didn’t get time to type them up, but will try to do so this week, and in passing look at the RFCdiff to -01.

FWIW, my review resulted only in nits, of the sort that can easily be folded in during a WGLC. 

So I vividly encourage that a WGLC be issued for this document.

Thomas

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Henning Rogge <[email-masked]>
Date: Tue, 22 Jul 2014 17:20:01 +0200

> So I vividly encourage that a WGLC be issued for this document.

I would also be okay to insert the 'nits' and release a -02 draft in a month...

xml2rfc makes it easy to insert changes without worrying about
references and pages.

Henning Rogge

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 17:29:01 +0200

> On 22 Jul 2014, at 17:20 , Henning Rogge <[email-masked]> wrote:
> 

Sure, but I se absolutely no reason to postpone a WGLC a month for that. Let’s get it launched…

Thomas

---

From: Justin Dean <[email-masked]>
Date: Tue, 22 Jul 2014 11:36:29 -0400

Henning I would very much like to make these changes in my code (yes I have
an implementation) and provide it for interop testing.  It would be nice to
catch any glaring mistakes/omissions in the draft that us humans may have
missed.

Justin

On Tue, Jul 22, 2014 at 11:29 AM, Thomas Heide Clausen <
[email-masked]> wrote:

> >> I read the previous version (-00) and had a few nits (and they were
> just nits). Didn’t get time to type them up, but will try to do so this
> week, and in passing look at the RFCdiff to -01.
> >>

---

From: Henning Rogge <[email-masked]>
Date: Tue, 22 Jul 2014 17:37:42 +0200

> catch any glaring mistakes/omissions in the draft that us humans may have

You implemented this in your NHDP implementation? Yes, we definitely
should repeat our interop test!

(how is your OLSRv2 implementation coming?)

Henning Rogge

---

From: Justin Dean <[email-masked]>
Date: Tue, 22 Jul 2014 12:46:29 -0400

No it's implemented in my not yet publicly released OLSRv2 code.  (which is
at the point I would be comfortable passing it along to you)

Our OLSRv2 implementation state: Written, compiling, running, adding routes
and only crashing on occasion...So about 25-25% finished ;p

Justin

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 12:47:55 -0400

> On 22 Jul 2014, at 12:46, Justin Dean <[email-masked]> wrote:
> 
> No it's implemented in my not yet publicly released OLSRv2 code.  (which is at the point I would be comfortable passing it along to you)
> 
> Our OLSRv2 implementation state: Written, compiling, running, adding routes and only crashing on occasion...

I'm sure, Justin, that with a little effort you can get it to the point where it will be crashing all the time ;)

> So about 25-25% finished ;p
>  
> Justin
> 
>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 23 Jul 2014 12:49:34 +0200

> and only crashing on occasion...So about 25-25% finished ;p

Interop tests would be a great way to find new creative crashes. ;)

Henning Rogge