Subject: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

From: "manet issue tracker" <[email-masked]>
Date: Mon, 21 Jul 2014 03:46:00 -0000

#48: Single address per interface per router (submitted for Chris Dearlove)

 The model is of routers with a single address per interface. In OLSRv2
 this wasn't considered acceptable. The authors defined multiple addresses
 per interface, the WG required supporting unnumbered interfaces which
 shared addresses.

-- 
-----------------------------------+-----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect                 |     Status:  new
 Priority:  minor                  |  Milestone:
Component:  aodvv2                 |    Version:
 Severity:  Active WG Document     |   Keywords:  Router addressability
-----------------------------------+-----------------------------------

Ticket URL: <https://tools.ietf.org/wg/manet/trac/ticket/48>
manet <http://tools.ietf.org/manet/>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 20 Jul 2014 21:45:26 -0700

Hello Chris,

AODVv2 does not impose this restriction.  It has, for a long time,
enabled multiple router addresses per interface.  I will look again,
but as of now I do not see where any such restriction has been
imposed.  If you have identified where this restriction is implied
or stated directly, please let me know as soon as possible.

Unnumbered interfaces have never been suggested as appropriate
for inclusion of the feature set for any reactive protocol that was
under consideration within [manet], all the way since the very
initiation of the working group.  At least not within my memory.

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 12:39:29 +0000

In at least one place in the draft (sorry, I don't have the time to find it again now) it explicitly says one address per interface.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: 21 July 2014 05:45
To: [email-masked]; Dearlove, Christopher (UK); [email-masked]
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello Chris,

AODVv2 does not impose this restriction.  It has, for a long time, enabled multiple router addresses per interface.  I will look again, but as of now I do not see where any such restriction has been imposed.  If you have identified where this restriction is implied or stated directly, please let me know as soon as possible.

Unnumbered interfaces have never been suggested as appropriate for inclusion of the feature set for any reactive protocol that was under consideration within [manet], all the way since the very initiation of the working group.  At least not within my memory.

--
Regards,
Charlie P.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 15:18:39 +0200

> On 22 Jul 2014, at 14:39 , Dearlove, Christopher (UK) <[email-masked]> wrote:
> 

Not sure if this is the place that Chris is thinking of, but in my review I encountered things such as:

 Blacklist.Node
      The IP address of the node that did not verify bidirectional
      connectivity.

Which looks like it is assumed that a “node” (I assume that this means “router” and will be fixed in a coming version, as has been requested multiple times) has a single IP address (that’s what the use of the definite article implies, is it not?)

Also:

 AODVv2 supports routers with
   multiple interfaces, as long as each interface has its own (unicast
   routeable) IP address

“address” - singular, not plural.

There were other instances of such, these were just the first I saw when glancing over my review.

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Henning Rogge <[email-masked]>
Date: Tue, 22 Jul 2014 15:22:06 +0200

On 07/22/2014 03:18 PM, Thomas Heide Clausen wrote:
> 
>> On 22 Jul 2014, at 14:39 , Dearlove, Christopher (UK)
>> <[email-masked] <mailto:[email-masked]>>
>> wrote:
>>
>> In at least one place in the draft (sorry, I don't have the time to
>> find it again now) it explicitly says one address per interface.
>>
> 
> Which looks like it is assumed that a “node” (I assume that this means
> “router” and will be fixed in a coming version, as has been requested
> multiple times) has a single IP address (that’s what the use of the
> definite article implies, is it not?)
> 
> Also:
> 

Just a thought,

does this mean we cannot run AODVv2 with IPv6 linklocal addresses? In
the presence of VLAN interfaces these addresses can be the same for
multiple interfaces of the same node.

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 22 Jul 2014 15:46:11 +0200

> On 22 Jul 2014, at 15:22 , Henning Rogge <[email-masked]> wrote:
> 

That would be my reading of it, yes.

I should add that this was one of the arguments that was made for enabling OLSRv2 to use (in the right context, and with constraints specified in the document) “duplicated” addresses, unnumbered interfaces, etc.

As Chris indicated, the reactive protocol, as currently designed, appears less capable than OLSRv2 on this point.

I think that with this limitation identified, it should be called out as one of the aspects narrowing the applicability scope of this protocol, in the applicability statement.

Thomas

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 13:50:52 +0000

The second of these was the point I had in mind. The first is an associated issue.

There are various complexities in OLSRv2 that relate to addressing of interfaces (not shared between routers, but possibly shared between interfaces) and gateways (can overlap and share). We think we got them right (though without a formal proof, so it’s possible we missed something – I think we caught one right at the last post-IESG point). But some took some work.

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: Thomas Heide Clausen [mailto:[email-masked]]
Sent: 22 July 2014 14:19
To: Dearlove, Christopher (UK)
Cc: Charles Perkins; [email-masked]; [email-masked]
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.

On 22 Jul 2014, at 14:39 , Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:

 Blacklist.Node

      connectivity.

Also:

   routeable) IP address

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]]
Sent: 21 July 2014 05:45
To: [email-masked]<mailto:[email-masked]>; Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

Hello Chris,

#48: Single address per interface per router (submitted for Chris
Dearlove)

--
Regards,
Charlie P.

[email-masked]<mailto:[email-masked]>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 22 Jul 2014 09:14:11 -0700

Hello Chris,

OLSRv2 is much more demanding regarding the determination of which
IP addresses belong to which routers.  Basically, AODVv2 does not care.
DSR did not care either.  In fact, I am not aware of any reactive protocol
for which this was ever an issue.  What matters is the establishment of
a routing path from source to destination.

I will fix the wording about handling blacklisted addresses as suggested.
If you have other instances, please do not hesitate to point them out.

Regards,
Charlie P.

On 7/22/2014 6:50 AM, Dearlove, Christopher (UK) wrote:
> There are various complexities in OLSRv2 that relate to addressing of 
> interfaces (not shared between routers, but possibly shared between 
> interfaces) and gateways (can overlap and share). We think we got them 
> right (though without a formal proof, so it’s possible we missed 
> something – I think we caught one right at the last post-IESG point). 
> But some took some work.
>
> -- 
>
> Christopher Dearlove
>
> [email-masked] <mailto:[email-masked]> | 
> http://www.baesystems.com
>
> *From:*Thomas Heide Clausen [mailto:[email-masked]]
> *Sent:* 22 July 2014 14:19
> *To:* Dearlove, Christopher (UK)
> *Cc:* Charles Perkins; [email-masked]; 
> [email-masked]
> *Subject:* Re: [manet] #48 (aodvv2): Single address per interface per 
> router (submitted for Chris Dearlove)
>
> **** WARNING ****
>
> /This message originates from outside our organisation, either from an 
> external partner or the internet.//
> /Consider carefully whether you should click on any links, open any 
> attachments or reply./
> /For information regarding //*/Red Flags/*/that you can look out for 
> in emails you receive, click here 
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.//
> /If you feel the email is suspicious, please follow this process 
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.//
>
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>     In at least one place in the draft (sorry, I don't have the time
>     to find it again now) it explicitly says one address per interface.
>
>     [email-masked]
>     <mailto:[email-masked]> | http://www.baesystems.com
>
>     To: [email-masked] <mailto:[email-masked]>; Dearlove, Christopher
>     (UK); [email-masked]
>     <mailto:[email-masked]>
>     Subject: Re: [manet] #48 (aodvv2): Single address per interface
>     per router (submitted for Chris Dearlove)
>
>     ----------------------! WARNING ! ---------------------- This
>     message originates from outside our organisation, either from an
>     external partner or from the internet.
>     Follow the 'Report Suspicious Emails' link on IT matters for
>     instructions on reporting suspicious email messages.
>     enabled multiple router addresses per interface.  I will look
>     again, but as of now I do not see where any such restriction has
>     been imposed.  If you have identified where this restriction is
>     implied or stated directly, please let me know as soon as possible.
>
>     Unnumbered interfaces have never been suggested as appropriate for
>     inclusion of the feature set for any reactive protocol that was
>     [email-masked] <mailto:[email-masked]>

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 16:32:10 +0000

I’m not sure what you are suggesting is more “demanding”. More limiting, yes. I’m not sure what point you are making with “does not care”.

As for pointing out other instances, no, I don’t have the time. Having pointed out an area of issue it should be the author/editor’s responsibility to check for consistency. Or at least that’s my attitude as an author.

From: Charles E. Perkins [mailto:[email-masked]]
Sent: 22 July 2014 17:14
To: Dearlove, Christopher (UK)
Cc: [email-masked]; [email-masked]
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

*** WARNING ***

Hello Chris,

Regards,
Charlie P.

From: Thomas Heide Clausen [mailto:[email-masked]]
Sent: 22 July 2014 14:19
To: Dearlove, Christopher (UK)
Cc: Charles Perkins; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

*** WARNING ***

 Blacklist.Node

      connectivity.

Also:

   routeable) IP address

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]]
Sent: 21 July 2014 05:45
To: [email-masked]<mailto:[email-masked]>; Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] #48 (aodvv2): Single address per interface per router (submitted for Chris Dearlove)

Hello Chris,

--
Regards,
Charlie P.

--

Regards,

Charlie P.