Subject: [manet] #43 (aodvv2): Reliance on bidirectional paths (submitted for Chris Dearlove)

From: "manet issue tracker" <[email-masked]>
Date: Mon, 21 Jul 2014 03:37:13 -0000

#43: Reliance on bidirectional paths (submitted for Chris Dearlove)

 The protocol relies on links being bidirectional. It must therefore
 provide a means to ensue that. It's not good enough to list several
 possibilities - that will not offer interoperability. It is fine of course
 to offer allowing additional reasons to exclude links, but there needs to
 be a basic non-optional mechanism for something that the protocol will not
 work without.

-- 
-----------------------------------+-----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect                 |     Status:  new
 Priority:  minor                  |  Milestone:
Component:  aodvv2                 |    Version:
 Severity:  Active WG Document     |   Keywords:  bidirectional
-----------------------------------+-----------------------------------

Ticket URL: <https://tools.ietf.org/wg/manet/trac/ticket/43>
manet <http://tools.ietf.org/manet/>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 20 Jul 2014 21:12:41 -0700

Hello Chris,

Perhaps it would be better to identify the proper protocol method as
part of the applicability statement.  If no other means are available, then
AODVv2 nodes could be required to use the blacklist mechanism, which
is intended to provide bidirectionality.

It seems unwise to require additional protocol mechanisms for cases
in which layer 2 already guarantees bidirectional links.  This could also
be included as a statement within the applicability section.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Jul 2014 12:30:21 +0000

The key thing is that two independent implementations need to interoperate and not use unidirectional links. At the moment that wouldn't happen.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: 21 July 2014 05:13
To: [email-masked]; Dearlove, Christopher (UK); [email-masked]
Subject: Re: [manet] #43 (aodvv2): Reliance on bidirectional paths (submitted for Chris Dearlove)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hello Chris,

Perhaps it would be better to identify the proper protocol method as part of the applicability statement.  If no other means are available, then
AODVv2 nodes could be required to use the blacklist mechanism, which is intended to provide bidirectionality.

It seems unwise to require additional protocol mechanisms for cases in which layer 2 already guarantees bidirectional links.  This could also be included as a statement within the applicability section.

Regards,
Charlie P.

--
Regards,
Charlie P.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************