Subject: [manet] request for WG adoption: draft-yi-manet-olsrv2-multipath

From: Jiazi YI <[email-masked]>
Date: Tue, 29 Jul 2014 21:29:49 +0200

Dear chairs,

The draft draft-yi-manet-olsrv2-multipath has been presented in IETF
meeting in Toronto.
There are a lot of constructive comments from the WG during & after the
meeting, detailed in

http://www.ietf.org/mail-archive/web/manet/current/msg16613.html
http://www.ietf.org/mail-archive/web/manet/current/msg16740.html

The feedback is very helpful and exciting. We thus folded them in the new
revision of the draft as soon as possible, which is now available today at

http://tools.ietf.org/html/draft-yi-manet-olsrv2-multipath-02

This draft aims for publication as an *Experimental* Track RFC. The
motivation of being an experimental RFC and experiments points have been
illustrated in

http://tools.ietf.org/html/draft-yi-manet-olsrv2-multipath-02#section-1.1

As a reminder, there are multiple open-source implementations available for
this protocol and they are now running and being tested in different
networks. The multi-path routing has attracted great interest from both
industry and academia.

We believe it's time to publish the protocol as an experimental RFC, based
on the experiences we obtained in the last decade. It would be great help
for the engineers and researchers interested in the multi-path approach for
MANET, and push it to a standard track protocol eventually.

Therefore, we would like to know your opinion on the draft, and kindly
request a call for WG adoption.

As always, we are looking forward to further comments on the draft from all
the WG participants.

regards

Jiazi

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 30 Jul 2014 00:01:08 +0100

Jiazi,
 
I want to thank you for the responsible approach of labelling this Experimental.
 
Authors, I would welcome it if you formally asked the PIM working group to provide multicast review of this work.
 
Chairs as/when you poll for adoption, please make sure that that cross-WG review has taken place and that any feedback is considered.
 
Thanks!
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jiazi YI
Sent: 29 July 2014 20:30
To: manet; <[email-masked]>; manet-ads
Subject: request for WG adoption: draft-yi-manet-olsrv2-multipath
 
Dear chairs, 
 
The draft draft-yi-manet-olsrv2-multipath has been presented in IETF meeting in Toronto. 
There are a lot of constructive comments from the WG during & after the meeting, detailed in 

The feedback is very helpful and exciting. We thus folded them in the new revision of the draft as soon as possible, which is now available today at 

This draft aims for publication as an *Experimental* Track RFC. The motivation of being an experimental RFC and experiments points have been illustrated in 

As a reminder, there are multiple open-source implementations available for this protocol and they are now running and being tested in different networks. The multi-path routing has attracted great interest from both industry and academia. 
 
We believe it's time to publish the protocol as an experimental RFC, based on the experiences we obtained in the last decade. It would be great help for the engineers and researchers interested in the multi-path approach for MANET, and push it to a standard track protocol eventually. 
 
Therefore, we would like to know your opinion on the draft, and kindly request a call for WG adoption. 
 
As always, we are looking forward to further comments on the draft from all the WG participants. 
 
regards
 
Jiazi

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 31 Jul 2014 13:38:02 +0000

Working Group Participants -

This is a call to adopt draft-yi-manet-olsrv2-multipath as a working group document. If you have issues with the WG accepting this document, please note them on the list before close of business on Aug 14, 2014. To properly gauge the overall WG interest in this draft, I ask that WG participants in favor of adoption please state so, on the list, prior to the Aug 14 deadline.

Regards,
Stan

On Jul 29, 2014, at 3:29 PM, Jiazi YI <[email-masked]<mailto:[email-masked]>> wrote:

Dear chairs,

regards

Jiazi
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Thomas Clausen <[email-masked]>
Date: Thu, 31 Jul 2014 16:46:09 +0200

Stan,

I'm in favor ; I believe that this is a worthy experiment for the WG to be undertaking, as an extension to OLSRv2.

Thomas

Sent from my iPad

> On 31 Jul 2014, at 15:38, "Stan Ratliff (sratliff)" <[email-masked]> wrote:
> 
>> On Jul 29, 2014, at 3:29 PM, Jiazi YI <[email-masked]> wrote:
>> 
>> Dear chairs, 
>> 
>> [email-masked]
> [email-masked]

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 31 Jul 2014 08:26:32 -0700

+1 in favor of adoption.

(btw, type 128 for MP_OLSRv2 in Table 1/Section 12.1  is already taken
by SMF_TYPE):
http://www.iana.org/assignments/manet-parameters/manet-parameters.xhtml#message-tlv-hello

On Thu, Jul 31, 2014 at 7:46 AM, Thomas Clausen
<[email-masked]> wrote:
> This is a call to adopt draft-yi-manet-olsrv2-multipath as a working group
> document. If you have issues with the WG accepting this document, please
> note them on the list before close of business on Aug 14, 2014. To properly
> gauge the overall WG interest in this draft, I ask that WG participants in
> favor of adoption please state so, on the list, prior to the Aug 14
> deadline.
>
> Regards,
> Stan
>
>

---

From: Jiazi YI <[email-masked]>
Date: Thu, 31 Jul 2014 23:56:05 +0200

Oops... yes. Thanks for pointing it out.
Will fix in the next revision.

best

Jiazi

On Thu, Jul 31, 2014 at 5:26 PM, Ulrich Herberg <[email-masked]> wrote:

> > I'm in favor ; I believe that this is a worthy experiment for the WG to
> be
> > undertaking, as an extension to OLSRv2.
> >
> > Thomas
> >
> > Sent from my iPad
> >
> meeting
> > in Toronto.