Subject: [manet] OLSRv2-Routed MANET Management

From: Justin Dean <[email-masked]>
Date: Tue, 22 Jul 2014 14:43:29 -0400

While only C is required to be the same and many settings can change
autonomously without breaking the protocol that isn't the same thing as the
protocol working well in those
scenarios. The key thing is that management doesn't need to happen across
ALL routers at the same time which makes management quite a bit easier.

Is the v4 and v6 thing true?  Henning mentioned that his implementation
uses both v4 and
v6 in the same packet but with different messages.  To say that OLSRv2
can't do this
without running multiple instances isn't 100% true.

---

From: Henning Rogge <[email-masked]>
Date: Wed, 23 Jul 2014 12:47:05 +0200

On Tue, Jul 22, 2014 at 8:43 PM, Justin Dean <[email-masked]> wrote:
> Is the v4 and v6 thing true?  Henning mentioned that his implementation uses
> both v4 and
> v6 in the same packet but with different messages.  To say that OLSRv2 can't
> do this

Yes, my implementation can transport both IPv4 TCs and IPv6 TCs within
the same RFC5444 packet.

I am already working on a draft to present this "flooding
optimization" mechanism to the WG.

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 23 Jul 2014 11:34:17 +0000

This needs care to extend the right things.

Putting mixed address sized messages in a packet relates to the 5444 multiplexer. This may be no more than an observation that the 5444 multiplexer already permits that. (I don't think it's stressed, but if it weren't allowed we'd have put the address length field in the packet header, not the message header).

But there is an issue as to how the multiplexer handles a received packet with IPv4 and IPv6 TCs. (If you can handle that, the sending side is easy.) 5444 says that the multiplexer sends the TC to OLSRv2. It doesn't allow for the possibility of there being more than one OLSRv2, whether easily separated (by address length) or not. Even an easy separation is not a defined feature.

Which gives two possibilities that I see
(a) Extend multiplexer to allow use of message address length as well as message type in deciding the destination of a message. This only handles that special case, not a more general case of multiple instantiations of a protocol.
(b) TCs (any message length) are sent to "OLSRv2", which is allowed internal structure of separate instantiations, by address length or otherwise, of 7181. This needs repeating for each protocol (obviously NHDP). If "or otherwise" is accepted, this can be a more general concept, but it's also rather fuzzy. Also are the separate instantiations independent or not?

Neither is entirely nice. It's one of those things easy to do in code, but getting the model right in a draft is at least slightly tricky. I think it's worth a discussion on the issue, including the broader question of multiple instantiations.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 23 July 2014 11:47
To: Justin Dean
Cc: [email-masked]
Subject: Re: [manet] OLSRv2-Routed MANET Management

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

On Tue, Jul 22, 2014 at 8:43 PM, Justin Dean <[email-masked]> wrote:
> Is the v4 and v6 thing true?  Henning mentioned that his 
> implementation uses both v4 and
> can't do this without running multiple instances isn't 100% true.

Yes, my implementation can transport both IPv4 TCs and IPv6 TCs within the same RFC5444 packet.

I am already working on a draft to present this "flooding optimization" mechanism to the WG.

Henning Rogge

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 23 Jul 2014 13:42:20 +0200

I did ask th authors about the C issue and I still not sure how can one
constant only can manage to make the protocol managed. However thanks for
your input and discussion.

AB

---

From: Henning Rogge <[email-masked]>
Date: Wed, 23 Jul 2014 13:43:55 +0200

> Putting mixed address sized messages in a packet relates to the 5444 multiplexer. This may be no more than an observation that the 5444 multiplexer already permits that. (I don't think it's stresse…

Sure.

> (b) TCs (any message length) are sent to "OLSRv2",

I implemented option (b).

> which is allowed internal structure of separate instantiations, by address length or otherwise, of 7181. This needs repeating for each protocol (obviously NHDP). If "or otherwise" is accepted, this can be a more general concept, but it's also rather fuzzy. Also are the separate instantiations independent or not?

Keeping the two parts mostly separated might be the easiest way to
implement it. I have chosen to put everything within the same data
structure.

So in dualstack mode I see all routers twice in the database (once
IPv4 and once IPv6), with a cross reference because of my dualstack
optimization (my implementation knows which IPv4 originator is which
IPv6 originator).

Henning Rogge