Subject: Re: [manet] #46 (aodvv2): What is needed from IP and ICMP (submitted for Chris Dearlove)

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 8 Sep 2014 00:01:48 +0200

Hi Chris,

I think you may misunderstand MANET  reactive routing. I don't see your
reply answers the editor question of examples of AODVv2 needs from IP or
ICMP. You mention that the protocol needs to see ICMP, what is the problem
with that as RFC3561 already has similar issue and already accepted by WG.

AB

On Tuesday, July 22, 2014, Dearlove, Christopher (UK) wrote:

> Just for a start you also need to know that IP routes are requested, that
> packets are flowing, and to have the ability to queue packets. I'm pretty
> sure not all of those are mandated by IP. The routing protocol also needs
> to see ICMP messages - is that normal?
>
> As I said, it's a matter of what the whole architecture looks like.

I think MANET still did not specify its whole architecture.

>
> --
> Christopher Dearlove
> Senior Principal Engineer, Information Assurance Group
> Communications, Networks and Image Analysis Capability
> BAE Systems Advanced Technology Centre
> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
> Tel: +44 1245 242194 |  Fax: +44 1245 242124
> [email-masked] | http://www.baesystems.com
>
> BAE Systems (Operations) Limited
> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre,
> Farnborough, Hants, GU14 6YU, UK
> Registered in England & Wales No: 1996687
>
>
> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: 21 July 2014 05:40
> To: [email-masked]; [email-masked]; Dearlove,
> Christopher (UK)
> Subject: Re: [manet] #46 (aodvv2): What is needed from IP and ICMP
> (submitted for Chris Dearlove)
>
> ----------------------! WARNING ! ---------------------- This message
> originates from outside our organisation, either from an external partner
> or from the internet.
> Consider carefully whether you should click on any links, open any
> attachments or reply.
> Follow the 'Report Suspicious Emails' link on IT matters for instructions
> on reporting suspicious email messages.
> --------------------------------------------------------
>
> Hello Chris,
>
> I am pretty sure that the only things needed from IP and ICMP are features
> that are already mandated by IP (including ICMP).  If there were danger
> that AODVv2 might require optional features of IP or optional features of
> ICMP, I could understand your concern.  As it is, I do not understand
> exactly what is needed to enhance implementability of the specification.
>
> The only thing expected from ICMP is delivery of Destination Unreachable
> (Type 3 Code 1).  Is this something that implementations are unlikely to
> provide?
>
> I am confused about what (other than ICMP) AODVv2 "needs" from IP that
> could cause a problem.  True, we do expect IP to find the proper outgoing
> interface, and to perform longest-prefix-first matching, and so on...
>
> Do you have an example of some other protocol specification that lists
> these kinds of dependencies?
>
>
> On 7/20/2014 8:42 PM, manet issue tracker wrote:
> > #46: What is needed from IP and ICMP (submitted for Chris Dearlove)
> >
> >   The protocol needs many things from IP, such as failed routing
> >   notification, and interacts with it in ways such as queuing packets.
> >   It also interacts (sends and receives) with ICMP, and I'm not sure
> >   what else. This needs to be put together, so the reader can see what
> >   is needed to be able to implement this.
> >
>
> --
> Regards,
> Charlie P.
>
> ********************************************************************
> This email and any attachments are confidential to the intended
> recipient and may also be privileged. If you are not the intended
> recipient please delete it from your system and notify the sender.
> You should not copy it or use it for any purpose nor disclose or
> distribute its contents to any other person.
> ********************************************************************
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Christopher Dearlove <[email-masked]>
Date: Sun, 7 Sep 2014 23:06:50 +0100

First, I think you'll find I understand everything a lot better than either you do, or you think I do.

Second, AODV was an experimental protocol. AODVv2 is aiming at Proposed Standard. Which requires a higher standard - which it doesn't meet, AODVv1 was actually better specified than AODVv2 is.

--  
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

> On 7 Sep 2014, at 23:01, Abdussalam Baryun <[email-masked]> wrote:
> 
> Hi Chris,
> 
> I think you may misunderstand MANET  reactive routing. I don't see your reply answers the editor question of examples of AODVv2 needs from IP or ICMP. You mention that the protocol needs to see ICMP, what is the problem with that as RFC3561 already has similar issue and already accepted by WG. 
> 
> AB
> 
>> Just for a start you also need to know that IP routes are requested, that packets are flowing, and to have the ability to queue packets. I'm pretty sure not all of those are mandated by IP. The routing protocol also needs to see ICMP messages - is that normal?
>> 
>> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
>> To: [email-masked]; [email-masked]; Dearlove, Christopher (UK)
>> Subject: Re: [manet] #46 (aodvv2): What is needed from IP and ICMP (submitted for Chris Dearlove)
>> 
>> ----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
>> Consider carefully whether you should click on any links, open any attachments or reply.
>> Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
>> I am pretty sure that the only things needed from IP and ICMP are features that are already mandated by IP (including ICMP).  If there were danger that AODVv2 might require optional features of IP or optional features of ICMP, I could understand your concern.  As it is, I do not understand exactly what is needed to enhance implementability of the specification.
>> 
>> The only thing expected from ICMP is delivery of Destination Unreachable (Type 3 Code 1).  Is this something that implementations are unlikely to provide?
>> 
>> I am confused about what (other than ICMP) AODVv2 "needs" from IP that could cause a problem.  True, we do expect IP to find the proper outgoing interface, and to perform longest-prefix-first matching, and so on...
>> 
>> Do you have an example of some other protocol specification that lists these kinds of dependencies?
>> 
>>

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 8 Sep 2014 00:08:10 +0200

> On 08 Sep 2014, at 00:01, Abdussalam Baryun <[email-masked]> wrote:
> 
> Hi Chris,
> 
> I think you may misunderstand MANET  reactive routing.

I sincerely doubt that Chris misunderstands MANET routing (reactive, or otherwise)  ... in fact, he's co-author of the majority of RFCs produced by the MANET wg, so I think that he's been around the field by now...

> I don't see your reply answers the editor question of examples of AODVv2 needs from IP or ICMP. You mention that the protocol needs to see ICMP, what is the problem with that as RFC3561 already has similar issue and already accepted by WG. 

1) RFC3561 is an experimental RFC

2) The fact that there is a problem in RFC3561 is no excuse for repeating that same problem
    in a subsequent protocol description.

Thomas

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 08 Sep 2014 10:20:48 -0700

Hello folks,

I did not follow-up on this in July because I didn't see exactly
what I needed to respond to.  But since there is more discussion
I'll give it a try anyway.

On 9/7/2014 3:01 PM, Abdussalam Baryun wrote:
> Hi Chris,
>
> I think you may misunderstand MANET  reactive routing. I don't see 
> your reply answers the editor question of examples of AODVv2 needs 
> from IP or ICMP. You mention that the protocol needs to see ICMP, what 
> is the problem with that as RFC3561 already has similar issue and 
> already accepted by WG.
>
> AB
>
>     Just for a start you also need to know that IP routes are
>     requested, that packets are flowing, and to have the ability to
>     queue packets.
>

Here I am not sure who "you" is, but perhaps I will reformulate
to hazard a guess at an answer...

On Tuesday, July 22, 2014, Dearlove, Christopher (UK) wrote something 
that Charlie interprets as follows:
> AODVv2 needs the following:
>     - information that IP routes are requested
>     - information that packets are flowing
>     - the ability to queue packets.

Tautologically, a reactive protocol reacts when a route is needed.
One might say that a route is requested when an application tries to
send a packet.  The fundamental concept of reactive routing is to
avoid creating routes that are not needed, and the way that has been
used to know whether a route is needed is when an application tries
to send a packet.

If an application tries to send a packet, and the route is available, the
packet has to wait until the route is available.  So, yes, queuing a
packet is needed.

This has been known for 20 years.

>     I'm pretty sure not all of those are mandated by IP. The routing
>     protocol also needs to see ICMP messages - is that normal?
>

As a matter of fact, looking at the state of routing in the Internet,
reactive routing is not normal.  So, no, these ideas are not normal,
depending on your definition.  However, if you restrict your determination
of "normality" to the space of reactive protocols, then yes, these
ideas and techniques are quite normal.

This has also been the case for a very long time.

>     As I said, it's a matter of what the whole architecture looks like.

I'm not sure what to make of this...

-- 
Regards,
Charlie P.

---

From: Christopher Dearlove <[email-masked]>
Date: Mon, 8 Sep 2014 18:45:20 +0100

I'm really not able t check the full context here, as I'm on holiday this week.

I think that "you" was colloquially the routing protocol.

But the point is, as you agree, this is not normal in the Internet. Doesn't matter if this has been known in the ad hoc routing field for 20 years. This is intended to be a proposed standard in what is the wider Internet community. Which experience has shown is not familiar with these matters, or various other things, some of them simpler.

This needs specifying for that reason. And also because people who want to implement it know what capabilities they need. If they need queueing in the IP stack they need to be told they need queuing in the IP stack. And that makes it clear this needs to be more than a routing protocol if that capability is not available as standard, which I think you just agreed it's not. Knowledge in the ad hoc routing community isn't enough.

On 8 Sep 2014, at 18:20, Charles E. Perkins wrote:

>> Just for a start you also need to know that IP routes are requested, that packets are flowing, and to have the ability to queue packets.
> 
> On Tuesday, July 22, 2014, Dearlove, Christopher (UK) wrote something that Charlie interprets as follows:
>> I'm pretty sure not all of those are mandated by IP. The routing protocol also needs to see ICMP messages - is that normal?
>

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 9 Sep 2014 00:02:58 +0200

Agree fully with Chris.

Reactive MANET protocol does "Weird Things" and have "Weird Interaction" with respect to the network layer, IP, and the forwarding path for data -- "Weird" in comparison with that which is "usual IP" (such as what a proactive routing protocol does), at least.

Different reactive protocols are doing different "Weird Things" and have different "Weird Interactions", of course. That's expected.

If considering implementing, deploying, a given reactive protocol on a given platform, it is imperative to have those things clearly spelled out - in a first order, to understand if it is even feasible, second if it is a good idea to do so. A good place to do so is the "Applicability Statement" of a protocol specification.

For starters, as Perkins describes reactive protocol behavior in the below, the "best effort" semantics is if not suspended, then substantially re-interpreted by having a device queue packets for which it has no matching routing table entries. 

Similarly, as Perkins describes reactive protocol behavior in the below, routing table "misses" somehow must be intercepted and signaled to the routing process, which must do something (generate control plane traffic). That, too, is a departure from how IP routing (usually) works.

I am not judging if this is a good or a bad thing to do -- but if it is done, then it most definitely, absolutely, needs to be called out.

And, this is another of those things that the WG has been requesting for years, with the same arguments, and which the current authors of the reactive WG protocol specification continues to ignore. 

Respectfully,

Thomas

> On 08 Sep 2014, at 19:45, Christopher Dearlove <[email-masked]> wrote:
>