Subject: [manet] DLEP-13 question

From: "MATTY, Steven" <[email-masked]>
Date: Wed, 13 May 2015 14:05:01 +0000

Hi Stan et al,

A quick question popped into my head whilst going through the latest DLEP draft regarding the Relative Link Quality Receive (RLQR) and Transmit (RLQT) data items. These are both defined as :
"A non-dimensional 8-bit integer,   1-100, representing relative link quality.  A value of 100 represents a link of the highest quality.  Any value greater than 100 MUST be considered as invalid."

My question is, should a value of 0 (zero) also be considered as invalid, or would it worth specifying the range as 0-100 ?

Regards

Steve

This email (including any attachments) may contain confidential
and/or privileged information or information otherwise protected
from disclosure. If you are not the intended recipient, please
notify the sender immediately, do not copy this message or any
attachments and do not use it for any purpose or disclose its
content to any person, but delete this message and any attachments
from your system. Airbus Defence and Space Limited disclaims any and all liability if this email transmission was virus corrupted,
altered or falsified.
-o-
Airbus Defence and Space Limited, Registered in England and Wales No. 2449259
Registered Office:
Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS, England

---

From: Henning Rogge <[email-masked]>
Date: Wed, 13 May 2015 16:12:55 +0200

On Wed, May 13, 2015 at 4:05 PM, MATTY, Steven
<[email-masked]> wrote:
> “A non-dimensional 8-bit integer,   1-100, representing relative link quality.  A value of 100 represents a link of the highest quality.  Any value greater than 100 MUST be considered as invalid.”
>
>
>

I think you found another typo...

RFC5578 defined metric as 0-100.

Henning Rogge

---

From: Stan Ratliff <[email-masked]>
Date: Wed, 13 May 2015 10:22:13 -0400

SIGH.....

I guess there will be yet another "DLEP du jour" tonight... ;-)

Regards,
Stan

On Wed, May 13, 2015 at 10:12 AM, Henning Rogge <[email-masked]> wrote:

> > A quick question popped into my head whilst going through the latest
> DLEP draft regarding the Relative Link Quality Receive (RLQR) and Transmit
> (RLQT) data items. These are both defined as :
> >
> > “A non-dimensional 8-bit integer,   1-100, representing relative link
> quality.  A value of 100 represents a link of the highest quality.  Any
> value greater than 100 MUST be considered as invalid.”
> >
> >
> >
> > My question is, should a value of 0 (zero) also be considered as
> invalid, or would it worth specifying the range as 0-100 ?
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Wiggins, David - 0665 - MITLL" <[email-masked]>
Date: Wed, 13 May 2015 16:20:53 +0000

You might also want to specify the invalid values for Prefix Length, as is
now done for Add/Drop, Resources, and RLQ.

Thanks for hanging in there!

David

From:  Stan Ratliff <[email-masked]>
Date:  Wednesday, May 13, 2015 at 10:22 AM
To:  Henning Rogge <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  Re: [manet] DLEP-13 question

SIGH..... 

Regards,
Stan