Subject: [manet] Barry Leiba's No Objection on draft-ietf-manet-olsrv2-multitopology-05: (with COMMENT)

From: "Barry Leiba" <[email-masked]>
Date: Tue, 26 May 2015 10:27:32 -0700

Barry Leiba has entered the following ballot position for
draft-ietf-manet-olsrv2-multitopology-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multitopology/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Let's please have a brief, non-blocking discussion of the "updates"
status here.  As I read this, I don't see how this updates either 7181 or
7188.  It clearly doesn't update 7188: it's just using an extension
mechanism that was specified in 7188.  I also don't think it updates
7181, because it's specifying an optional (indeed, experimental)
extension.  Here: does someone reading 7181, with no interest in
implementing this experimental extension, need to read (or even know
about) this document?  I think the answer is no.

(There's also the spurious "XXXX" in the updates list, which should be
removed.)

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 27 May 2015 10:51:23 +0000

It's a philosophy question, what does updates mean? Is there a formal RFC Editor definition? This does, at the least, update IANA registries established by 7181 and I think 7188 and XXXX (draft-ietf-manet-tlv-naming that we expect to be an RFC before or with this).

But honestly, I and co-author don't care one way or the other, if the IESG picks an answer, we'll implement it. I will probably have to let my co-author handle the mechanics of this, I may be unavailable shortly for at least a week.

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: Barry Leiba [mailto:[email-masked]] 
Sent: 26 May 2015 18:28
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Barry Leiba's No Objection on draft-ietf-manet-olsrv2-multitopology-05: (with COMMENT)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Let's please have a brief, non-blocking discussion of the "updates"
status here.  As I read this, I don't see how this updates either 7181 or 7188.  It clearly doesn't update 7188: it's just using an extension mechanism that was specified in 7188.  I also don't think it updates 7181, because it's specifying an optional (indeed, experimental) extension.  Here: does someone reading 7181, with no interest in implementing this experimental extension, need to read (or even know
about) this document?  I think the answer is no.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 27 May 2015 13:28:39 +0200

Confirm that we just want to "do the right thing" and are taking advice from the IESG on what that is. And will implement it. 

I am officially on vacation this week - but, as you can see, can't keep away from mails. I am fully back in the salt mines come Monday. 

Thomas

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

> On 27 mai 2015, at 12:51, Dearlove, Christopher (UK) <[email-masked]> wrote:
>

---

From: Barry Leiba <[email-masked]>
Date: Wed, 27 May 2015 07:55:31 -0400

I know what you mean about "can't keep away".  :-)
Ok, thanks, both, for the responses.  We'll figure this minor thing out in
the IESG, and no need for you to waste more time thinking about it.

Barry

On Wednesday, May 27, 2015, Thomas Heide Clausen <[email-masked]>
wrote:

> Confirm that we just want to "do the right thing" and are taking advice
> from the IESG on what that is. And will implement it.
>
> I am officially on vacation this week - but, as you can see, can't keep
> away from mails. I am fully back in the salt mines come Monday.
>
> Thomas
>
>
> --
> Thomas Heide Clausen
> > On 27 mai 2015, at 12:51, Dearlove, Christopher (UK) <
> [email-masked] <javascript:;>> wrote:
> >
> > It's a philosophy question, what does updates mean? Is there a formal
> RFC Editor definition? This does, at the least, update IANA registries
> established by 7181 and I think 7188 and XXXX (draft-ietf-manet-tlv-naming
> that we expect to be an RFC before or with this).
> >
> > But honestly, I and co-author don't care one way or the other, if the
> IESG picks an answer, we'll implement it. I will probably have to let my
> co-author handle the mechanics of this, I may be unavailable shortly for at
> least a week.
> >
> > --
> > Christopher Dearlove
> <javascript:;>
> > From: Barry Leiba [mailto:[email-masked] <javascript:;>]
> > Sent: 26 May 2015 18:28
> > To: The IESG
> > Cc: [email-masked] <javascript:;>;
> [email-masked] <javascript:;>;
> [email-masked] <javascript:;>
> > Subject: Barry Leiba's No Objection on
> draft-ietf-manet-olsrv2-multitopology-05: (with COMMENT)
> >
> > ----------------------! WARNING ! ---------------------- This message
> originates from outside our organisation, either from an external partner
> or from the internet.
> > Follow the 'Report Suspicious Emails' link on IT matters for
> instructions on reporting suspicious email messages.
> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> > status here.  As I read this, I don't see how this updates either 7181
> or 7188.  It clearly doesn't update 7188: it's just using an extension
> mechanism that was specified in 7188.  I also don't think it updates 7181,
> because it's specifying an optional (indeed, experimental) extension.
> Here: does someone reading 7181, with no interest in implementing this
> experimental extension, need to read (or even know

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 27 May 2015 17:11:49 +0000

On 5/26/15, 1:27 PM, "Barry Leiba" <[email-masked]> wrote:

Barry:

Hi!

>mechanism that was specified in 7188.

Some of the registries defined in 7188 are updated in this document to fit
the MT operation.

The same applies to the spurious ³XXXX² reference, which really is trying
to point to draft-ietf-manet-tlv-naming.

>I also don't think it updates

Right, the answer to that is no..so I can see taking that away.

Thanks!

Alvaro.