Subject: Re: [manet] DLEP-17: initial assignment tables & nearby text

From: Rick Taylor <[email-masked]>
Date: Wed, 9 Mar 2016 10:26:37 +0000

Comments inline...

On 24/11/15 17:47, RJ Atkinson wrote:
>
> 1. Signals/Messages
> --------------------
> Section 9.0, 3rd paragraph, says:
> 	“The core DLEP signals and messages are:”
>
> Table 1, which contains also items that I had not thought
> were “core DLEP signals and messages” (e.g. Private Use
> allocation), then follows.
>
> My suggestion is to change the text above to read:
> 	“The core DLEP signals and messages have Type Code
>           values from 1 to 16, inclusive.  The initial values
>           for the DLEP Signals & Messages Registry are found
>           in Table 1.”
>

I'm really not sure this adds anything except extra text.

>
> 2. Data Items
> --------------
> Section 10.0, 2nd paragraph, says:
> 	“The core DLEP data items are:”
>
> Table 2, which contains also items that I had not thought
> were “core DLEP data items” (e.g. Private Use allocation)
> then follows.
>
> My suggestion is to change the quoted text above to read:
> 	“The core DLEP data items have Type Code values
> 	from 1 to 20, inclusive.  The initial values for
>          the DLEP Data Item Registry are found in Table 2.”

I'm really not sure this adds anything except extra text.

>
> 3. Status Codes
> ---------------
> (We don’t seem to have a defined set of “core” DLEP status codes,
> which is OK with me, but unexpected after defining “core” values
> earlier.)
>
> I suggest inserting the following sentence just before
> Table 3:
> 	“The initial values for the DLEP Status Codes Registry
> 	are found in Table 3.”
>

Hmm.. we don't define 'core status codes' so I'm not convinced. 
However, we may have to move the Signal, Message, data Item and 
status-code tables into the IANA section, in which case, some text like 
this will have to be included.

>
> 4. Extension Types
> ------------------
>
> (editorial)
> Section 12.6 says in part:
> 	“Current allocations are:”
>
> This ought instead to read:
> 	“Initial allocations are:”
>
> because the reader’s definition of “current” is "when
> they are reading the specification", rather than
> "the date that the specification was written”.
>
> The “current” set is whatever the IANA Registry web page
> says on the “current day” that one looks at that registry.

s/current/initial/

On to the next mail,

Rick

---

From: Randal Atkinson <[email-masked]>
Date: Thu, 10 Mar 2016 15:17:01 -0500

> On 9Mar2016, at 05:26, Rick Taylor <[email-masked]> wrote:
> 
> Comments inline...
> 

The proposed text clarifies, for example, that Private Use items
are NOT “Core DLEP signals and messages”.  As of DLEP-17,
the table referenced included the whole set of values.

If the intention is that “Core DLEP signals and messages”
DO include Private Use Items, then it is not clear why
we defined a concept of “Core” items.

> I'm really not sure this adds anything except extra text.

See above.  Either we don’t need a concept of “Core”
items because everything is “Core” xor the “Core” items
need to be crisply specified.  DLEP-17 indicated the
entire table, not just items 1-20, are “Core” items.

> Hmm.. we don't define 'core status codes' so I'm not convinced. 

I agree it didn’t.  I merely noted that it was a surprise.

> this will have to be included.

I believe that the table of initial values for any IANA-managed registry
belongs in the IANA Considerations Section.  Certainly that is a very
common place for them.