Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-21.txt

From: "MATTY, Steven" <[email-masked]>
Date: Mon, 21 Mar 2016 18:10:23 +0000

A couple of nits (sorry!) :

9.20 - Missing parenthesis around Section 4.3.1. in final para
12.1 - Dynamic Link Event Protocol should be Dynamic Link Exchange Protocol
12.5- 132 is listed twice. I think the range for "Specification Required" should be 133 - 239
12.8 (very minor) "a IPv4" and "a IPv6" -> "an IPv4" and "an IPv6"

Steve

>-----Original Message-----
>From: manet [mailto:[email-masked]] On Behalf Of internet-
>[email-masked]
>Sent: Monday, March 21, 2016 5:14 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [manet] I-D Action: draft-ietf-manet-dlep-21.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>This draft is a work item of the Mobile Ad-hoc Networks of the IETF.
>
>        Title           : Dynamic Link Exchange Protocol (DLEP)
>        Authors         : Stan Ratliff
>                          Bo Berry
>                          Cisco Systems
>                          Darryl Satterwhite
>                          Rick Taylor
>	Filename        : draft-ietf-manet-dlep-21.txt
>	Pages           : 63
>	Date            : 2016-03-21
>
>Abstract:
>   When routing devices rely on modems to effect communications over
>   wireless links, they need timely and accurate knowledge of the
>   characteristics of the link (speed, state, etc.) in order to make
>   routing decisions.  In mobile or other environments where these
>   characteristics change frequently, manual configurations or the
>   inference of state through routing or transport protocols does not
>   allow the router to make the best decisions.  A bidirectional, event-
>   driven communication channel between the router and the modem is
>   necessary.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/
>
>There's also a htmlized version available at:
>https://tools.ietf.org/html/draft-ietf-manet-dlep-21
>
>A diff from the previous version is available at:
>https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-21
>
>
>Please note that it may take a couple of minutes from the time of submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/manet
>
>This mail has originated outside your organization, either from an external
>partner or the Global Internet.
>Keep this in mind if you answer this message.
>

This email (including any attachments) may contain confidential and/or privileged information or information otherwise protected from disclosure. If you are not the intended recipient, please notify the sender immediately, do not copy this message or any attachments and do not use it for any purpose or disclose its content to any person, but delete this message and any attachments from your system. Airbus Defence and Space Limited disclaims any and all liability if this email transmission was virus corrupted, altered or falsified.
-o-
Emails to Airbus Defence and Space Limited may be processed, recorded and monitored outside the UK.
-o-
Airbus Defence and Space Limited, Registered in England and Wales No. 2449259
Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS, England

---

From: Rick Taylor <[email-masked]>
Date: Tue, 22 Mar 2016 14:52:25 +0000

Thanks Steve,

Comments inline...

> A couple of nits (sorry!) :

Not your fault!

> 9.20 - Missing parenthesis around Section 4.3.1. in final para

Actually I've just found a couple of these, replaced with ", see Section 
XXX"

> 12.1 - Dynamic Link Event Protocol should be Dynamic Link Exchange Protocol

Doh!

> 12.5- 132 is listed twice. I think the range for "Specification Required" should be 133 - 239

Yes, that's the problem with having these values in 2 tables.  Fixed

> 12.8 (very minor) "a IPv4" and "a IPv6" -> "an IPv4" and "an IPv6"

I'm not sure, you and I (as Brits) would agree, not sure how the rest of 
the WG feel.

I will be holding off an uplift to let others have a read, and wait for 
feedback on credit-windowing as well.

Rick

---

From: Stan Ratliff <[email-masked]>
Date: Tue, 22 Mar 2016 10:58:06 -0400

> feedback on credit-windowing as well.

Just an FYI - this is stuff we can fix as publication progresses. There are
going to be nits along the way...

Regards,
Stan

---

From: Rick Taylor <[email-masked]>
Date: Tue, 22 Mar 2016 14:59:57 +0000

On 22/03/16 14:58, Stan Ratliff wrote:
>
>
> On Tue, Mar 22, 2016 at 10:52 AM, Rick Taylor
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>     Thanks Steve,
>
>     Comments inline...
>
> Just an FYI - this is stuff we can fix as publication progresses. There
> are going to be nits along the way...

I agree, this shouldn't block the document IMHO.

Rick

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Mar 2016 15:42:24 +0000

I think "an IP ..." is pretty clear, whether you go by spelling or pronunciation.

We had a trickier case in OLSRv2, where we use "an MPR", because we expect that to be read as "an em-pee-arr".

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Rick Taylor
Sent: 22 March 2016 14:52
To: MATTY, Steven
Cc: [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-21.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.

Thanks Steve,

Comments inline...

Not your fault!

> 9.20 - Missing parenthesis around Section 4.3.1. in final para

Actually I've just found a couple of these, replaced with ", see Section XXX"

Doh!

> 12.8 (very minor) "a IPv4" and "a IPv6" -> "an IPv4" and "an IPv6"

I'm not sure, you and I (as Brits) would agree, not sure how the rest of the WG feel.

I will be holding off an uplift to let others have a read, and wait for feedback on credit-windowing as well.

Rick

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************