Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-25.txt

From: Lou Berger <[email-masked]>
Date: Wed, 16 Nov 2016 09:04:10 +0900

Thanks Stan.  I have some concerns over the following new text:

> If the router and modem support both IPv4 and IPv6, the
   IPv6 transport MUST be used for the DLEP session.

To me the choice of v6 vs v4 *usage* is a deployment choice and not a
protocol interop issue.  The new text literally precludes an operator
from choosing v4 in their network.  I think this is inappropriate and
means that the protocol can't be deployed in certain combinations (i.e.,
an implementation that supports v6 but a network that chooses not to.)

Lou

On 10/29/2016 1:26 AM, Stan Ratliff wrote:
> Lou, 
>
> That was an AD request.
>
> Regards,
> Stan
>
>
> On Fri, Oct 28, 2016 at 12:17 PM, Lou Berger <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Can elaborate on the new v6 requirement?  It doesn't impact
>     interoperability and may not be the right default for all.
>
>     Lou
>
>     On October 28, 2016 11:44:40 AM Stan Ratliff
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>>     Hello WG participants, 
>>
>>     As you can see, we posted a new version of DLEP. This addresses
>>     comments from the AD review, and clarifies handling of IPv4/IPv6
>>     address and subnet Data Items (issue brought on-list be David
>>     Wiggins). 
>>
>>     Regards,
>>     Stan
>>
>>
>>
>>
>>     On Fri, Oct 28, 2016 at 11:31 AM, <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>
>>
>>         A New Internet-Draft is available from the on-line
>>         Internet-Drafts directories.
>>         This draft is a work item of the Mobile Ad-hoc Networks of
>>         the IETF.
>>
>>                 Title           : Dynamic Link Exchange Protocol (DLEP)
>>                 Authors         : Stan Ratliff
>>                                   Shawn Jury
>>                                   Darryl Satterwhite
>>                                   Rick Taylor
>>                                   Bo Berry
>>                 Filename        : draft-ietf-manet-dlep-25.txt
>>                 Pages           : 74
>>                 Date            : 2016-10-28
>>
>>         Abstract:
>>            When routing devices rely on modems to effect
>>         communications over
>>            wireless links, they need timely and accurate knowledge of the
>>            characteristics of the link (speed, state, etc.) in order
>>         to make
>>            routing decisions.  In mobile or other environments where
>>         these
>>            characteristics change frequently, manual configurations
>>         or the
>>            inference of state through routing or transport protocols
>>         does not
>>            allow the router to make the best decisions.  A
>>         bidirectional, event-
>>            driven communication channel between the router and the
>>         modem is
>>            necessary.
>>
>>
>>         The IETF datatracker status page for this draft is:
>>         https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/
>>         <https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/>
>>
>>         There's also a htmlized version available at:
>>         https://tools.ietf.org/html/draft-ietf-manet-dlep-25
>>         <https://tools.ietf.org/html/draft-ietf-manet-dlep-25>
>>
>>         A diff from the previous version is available at:
>>         https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-25
>>         <https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-25>
>>
>>
>>         Please note that it may take a couple of minutes from the
>>         time of submission
>>         until the htmlized version and diff are available at
>>         tools.ietf.org <http://tools.ietf.org>.
>>
>>         Internet-Drafts are also available by anonymous FTP at:
>>         ftp://ftp.ietf.org/internet-drafts/
>>         <ftp://ftp.ietf.org/internet-drafts/>
>>
>>         _______________________________________________
>>         manet mailing list
>>         [email-masked] <mailto:[email-masked]>
>>         https://www.ietf.org/mailman/listinfo/manet
>>         <https://www.ietf.org/mailman/listinfo/manet>
>>
>>
>>     _______________________________________________
>>     manet mailing list
>>     [email-masked] <mailto:manet%40ietf.org>
>>     https://www.ietf.org/mailman/listinfo/manet
>>     <https://www.ietf.org/mailman/listinfo/manet>
>>
>

---

From: Stan Ratliff <[email-masked]>
Date: Tue, 15 Nov 2016 19:19:39 -0500

Lou,

I 100% agree with you. But this was an AD (Alvaro) "request". I use
"request" in quotes, as it was along the lines of "an offer you can't
refuse"...

Regards,
Stan

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 16 Nov 2016 00:27:06 +0000

Lou:

Hi!

Would "SHOULD " make you feel better?  I can live with that.

Thanks!

Alvaro.

Thumb typed and autocorrected.

On Nov 16, 2016, at 9:19 AM, Stan Ratliff <[email-masked]<mailto:[email-masked]>> wrote:

Lou,

I 100% agree with you. But this was an AD (Alvaro) "request". I use "request" in quotes, as it was along the lines of "an offer you can't refuse"...

Regards,
Stan

On Tue, Nov 15, 2016 at 7:04 PM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:

Lou

On 10/29/2016 1:26 AM, Stan Ratliff wrote:
> Lou,
>
> That was an AD request.
>
> Regards,
> Stan
>
>
> On Fri, Oct 28, 2016 at 12:17 PM, Lou Berger <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>>     Hello WG participants,
>>
>>     On Fri, Oct 28, 2016 at 11:31 AM, <[email-masked]<mailto:[email-masked]>
>>     <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>
>>
>>         tools.ietf.org<http://tools.ietf.org> <http://tools.ietf.org>.
>>
>>         [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>>     [email-masked]<mailto:[email-masked]> <mailto:manet%40ietf.org<mailto:manet%2540ietf.org>>

---

From: Stan Ratliff <[email-masked]>
Date: Tue, 15 Nov 2016 20:01:26 -0500

Alvaro,

I'm fine with SHOULD.

Regards,
Stan

On Tue, Nov 15, 2016 at 7:27 PM, Alvaro Retana (aretana) <[email-masked]>
wrote:

> On Nov 16, 2016, at 9:19 AM, Stan Ratliff <[email-masked]> wrote:
>
> Lou,
>

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 16 Nov 2016 01:04:28 +0000

FYI..

There was a discussion in the room (before your sound came on).  We all agree on the intent, but maybe the language is not clear enough.  I think Lou got an AI to suggest txt -- check the minutes.  ;-)

Thanks!

Alvaro.

Thumb-typed and autocorrected..

On Nov 16, 2016, at 10:01 AM, Stan Ratliff <[email-masked]<mailto:[email-masked]>> wrote:

Alvaro,

I'm fine with SHOULD.

Regards,
Stan

On Tue, Nov 15, 2016 at 7:27 PM, Alvaro Retana (aretana) <[email-masked]<mailto:[email-masked]>> wrote:
Lou:

Hi!

Thanks!

Alvaro.

Lou,

Regards,
Stan

Lou

---

From: Rick Taylor <[email-masked]>
Date: Wed, 16 Nov 2016 02:46:15 +0000

All,

I would be happy with SHOULD, the intention is to say "If you've got
IPv6, please use it, it's the Right Thing (TM), particularly because of
link-local addressing, but we do understand that it might not be right
for your deployment for some undisclosed reason."

I believe RFC6919 might have some useful terminology...

Rick

On Wed, 2016-11-16 at 01:04 +0000, Alvaro Retana (aretana) wrote:
> FYI..
> 
> There was a discussion in the room (before your sound came on).  We
> all agree on the intent, but maybe the language is not clear enough.
>  I think Lou got an AI to suggest txt -- check the minutes.  ;-)
> 
> Thanks!
> 
> Alvaro.
> 
> On Nov 16, 2016, at 10:01 AM, Stan Ratliff <[email-masked]>
> wrote:
> 
> > Alvaro, 
> > 
> > I'm fine with SHOULD. 
> > 
> > Regards,
> > Stan
> > 
> > 
> > On Tue, Nov 15, 2016 at 7:27 PM, Alvaro Retana (aretana) <aretana@c
> > isco.com> wrote:
> > > Lou:  
> > > 
> > > Hi!
> > > 
> > > > I 100% agree with you. But this was an AD (Alvaro) "request". I
> > > > use "request" in quotes, as it was along the lines of "an offer
> > > > you can't refuse"... 
> > > > 
> > > > Regards,
> > > > Stan
> > > > 
> > > > 
> [email-masked]