Subject: [manet] [Editorial Errata Reported] RFC7181 (4872)

From: RFC Errata System <[email-masked]>
Date: Wed, 30 Nov 2016 02:22:18 -0800 (PST)

The following errata report has been submitted for RFC7181,
"The Optimized Link State Routing Protocol Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7181&eid=4872

--------------------------------------
Type: Editorial
Reported by: Nikolai Malykh <[email-masked]>

Section: 16.2

Original Text
-------------
   TC messages MAY be generated in response to a change in the
   information that they are to advertise, indicated by a change in the
   ANSN in the Neighbor Information Base.  In this case, a router MAY
   send a complete TC message and, if so, MAY restart its TC message
   schedule.  Alternatively, a router MAY send an incomplete TC message
   with at least the newly advertised network addresses (i.e., not
   previously, but now, an N_orig_addr or in an N_neighbor_addr_list in
   a Neighbor Tuple with N_advertised = true or an AL_net_addr) in its
   Address Blocks, with associated Address Block TLV(s).  Note that a
   router cannot report removal of advertised content using an
   incomplete TC message.

Corrected Text
--------------
   TC messages MAY be generated in response to a change in the
   information that they are to advertise, indicated by a change in the
   ANSN in the Neighbor Information Base.  In this case, a router MAY
   send a complete TC message and, if so, MAY restart its TC message
   schedule.  Alternatively, a router MAY send an incomplete TC message
   with at least the newly advertised network addresses (i.e., not
   previously, but now, an N_orig_addr or an N_neighbor_addr_list in
   a Neighbor Tuple with N_advertised = true or an AL_net_addr) in its
   Address Blocks, with associated Address Block TLV(s).  Note that a
   router cannot report removal of advertised content using an
   incomplete TC message.

Notes
-----
Unnecessary preposition "in"

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7181 (draft-ietf-manet-olsrv2-19)
--------------------------------------
Title               : The Optimized Link State Routing Protocol Version 2
Publication Date    : April 2014
Author(s)           : T. Clausen, C. Dearlove, P. Jacquet, U. Herberg
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 30 Nov 2016 10:39:53 +0000

Author writing.

Were this erratum to be correct, it would be an editorial change of really minute significance.

But in fact it is wrong. The "in" distinguishes the cases of N_orig_addr and an N_neighbor_addr_list. The former is a single address, the latter is a list of addresses. Therefore one looks for the address as the former, or in (the word that should not be deleted) the latter.

This erratum must be rejected.

(And unlike the previous erratum I handled, which was useful, do we need such trivial editorial nits even if correct? It took me significant time just to find the missing word in the paragraph - for the benefit of others, it's in the seventh line.)

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 30 November 2016 10:22
To: [email-masked]; Dearlove, Christopher (UK); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC7181 (4872)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

The following errata report has been submitted for RFC7181, "The Optimized Link State Routing Protocol Version 2".

Section: 16.2

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary. 

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************