Subject: [manet] [Editorial Errata Reported] RFC6130 (4866)

From: RFC Errata System <[email-masked]>
Date: Tue, 15 Nov 2016 04:49:35 -0800 (PST)

The following errata report has been submitted for RFC6130,
"Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6130&eid=4866

--------------------------------------
Type: Editorial
Reported by: Nikolai Malykh <[email-masked]>

Section: 4.3.2

Original Text
-------------
   o  For each MANET interface, within every time interval equal to the
      corresponding REFRESH_INTERVAL, sent HELLO messages MUST
      collectively include all of the relevant information in the
      corresponding Link Set and the Neighbor Information Base.  Note
      that when determining whether to include information in a HELLO
      message, the sender MUST consider all times up to the latest time
      when it may send its next HELLO message on this MANET interface.

   o  For each MANET interface, within every time interval equal to the
      corresponding REFRESH_INTERVAL, sent HELLO messages MUST
      collectively include all of the relevant information in the
      corresponding Link Set and the Neighbor Information Base.

Corrected Text
--------------
   o  For each MANET interface, within every time interval equal to the
      corresponding REFRESH_INTERVAL, sent HELLO messages MUST
      collectively include all of the relevant information in the
      corresponding Link Set and the Neighbor Information Base.  Note
      that when determining whether to include information in a HELLO
      message, the sender MUST consider all times up to the latest time
      when it may send its next HELLO message on this MANET interface.

Notes
-----
The second statement is already contained in the first one.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6130 (draft-ietf-manet-nhdp-15)
--------------------------------------
Title               : Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)
Publication Date    : April 2011
Author(s)           : T. Clausen, C. Dearlove, J. Dean
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 15 Nov 2016 13:25:48 +0000

Author writing.

Nikolai (to whom my thanks, and I expect that of my co-authors) has indeed spotted an error that the authors (and reviewers) missed after I don't know how many readings, but the resolution is not correct.

Rather, it is the other paragraph that should be deleted. Because the paragraph following the two quoted paragraphs, which I copy here:

   o  When determining whether to include a given piece of neighbor
      information in a HELLO message, it is not sufficient to consider
      whether that information has been sent in the interval of length
      REFRESH_INTERVAL up to the current time.  Instead, the router MUST
      consider the interval of length REFRESH_INTERVAL that will end at
      the latest possible time at which the next HELLO message will be
      sent on this MANET interface.  (Normally, this will be
      HELLO_INTERVAL past the current time, but MAY be earlier if this
      router elects to divide its neighbor information among more than
      one HELLO message in order to reduce the size of its HELLO
      messages.)  All neighbor information MUST be sent in this
      interval, i.e., the router MUST ensure that this HELLO message
      includes all neighbor information that has not already been
      included in any HELLO messages sent since the start of this
      interval (normally, the current time - (REFRESH_INTERVAL -
      HELLO_INTERVAL)).

contains the additional information in the longer paragraph, expanded to explain what it means.

(I don't have my records to hand, but I strongly suspect we split the paragraph in two, expanded the second half - possibly in response to review comments - but failed to delete the original.

Thus the resolution is to delete the first paragraph:

OLD:

NEW:

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 15 November 2016 12:50
To: [email-masked]; Dearlove, Christopher (UK); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC6130 (4866)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

The following errata report has been submitted for RFC6130, "Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP)".

Section: 4.3.2

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary. 

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Nikolai Malykh <[email-masked]>
Date: Tue, 15 Nov 2016 16:50:18 +0300

Dear Cristoffer,

you are completely right and your solution is more correct than my one.

SY,
Nikolai

2016-11-15 16:25 GMT+03:00 Dearlove, Christopher (UK) <
[email-masked]>:

> Author writing.
>
> Nikolai (to whom my thanks, and I expect that of my co-authors) has indeed
> spotted an error that the authors (and reviewers) missed after I don't know
> how many readings, but the resolution is not correct.
>
> Rather, it is the other paragraph that should be deleted. Because the
> paragraph following the two quoted paragraphs, which I copy here:
>
> (I don't have my records to hand, but I strongly suspect we split the
> paragraph in two, expanded the second half - possibly in response to review
> comments - but failed to delete the original.
>
> To: [email-masked]; Dearlove, Christopher (UK);
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> ----------------------! WARNING ! ---------------------- This message
> originates from outside our organisation, either from an external partner
> or from the internet.
> The following errata report has been submitted for RFC6130, "Mobile Ad Hoc
> Network (MANET) Neighborhood Discovery Protocol (NHDP)".
>
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party can log in to change the status
> and edit the report, if necessary.
>