Subject: [manet] Call for acceptance as Working Group documents

From: Stan Ratliff <[email-masked]>
Date: Mon, 28 Nov 2016 10:26:19 -0500

Hello working group participants,

One of the items identified during the WG meeting in Seoul was to formally
request, via the list, Working Group adoption of 5 extension drafts related
to DLEP. This email is that formal request.

The drafts are:
1.
https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00.html
2. https://tools.ietf.org/html/draft-cheng-manet-dlep-pause-extension-00
3. https://tools.ietf.org/html/draft-cheng-manet-dlep-multi-hop-extension-00
4. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00
5. https://tools.ietf.org/html/draft-cheng-manet-dlep-da-credit-extension-00

I have put all 5 extensions on this email for expediency only; please do
not assume that they must be adopted as a group. The chairs would greatly
appreciate thoughts from the WG, both positive and negative, by December
12.

For purposes of determining WG consensus, a lack of a response will be seen
as indicating support for adopting the draft (e.g. silence == acceptance).

Regards,
Stan

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 28 Nov 2016 10:44:04 -0500

David,

Oops. I claim Monday morning fogginess after the long holiday weekend, and
being insufficiently caffeinated, as my excuse! ;-)

WG,
My apologies for the duplication. There are but 4 extensions, but the
question to the WG is the same: To adopt, or not to adopt?

Regards,
Stan

On Mon, Nov 28, 2016 at 10:33 AM, Wiggins, David - 0665 - MITLL <
[email-masked]> wrote:

> Hi Stan,
>
> I think #1 and #4 are the same thing, aren't they?
>
> David
>
> From: manet <[email-masked]> on behalf of Stan Ratliff <
> [email-masked]>
> Date: Monday, November 28, 2016 at 10:26 AM
> To: MANET IETF <[email-masked]>
> Subject: [manet] Call for acceptance as Working Group documents
>
> 1. https://tools.ietf.org/html/draft-cheng-manet-dlep-
> latency-extension-00.html
> For purposes of determining WG consensus, a lack of a response will be
> seen as indicating support for adopting the draft (e.g. silence ==
> acceptance).
>
> Regards,
> Stan
>
>

---

From: Rick Taylor <[email-masked]>
Date: Mon, 28 Nov 2016 17:29:53 +0000

Stan, All,

I seem to remember there was some discussion over whether the documents
should be accepted as WG documents in their current form, or the
contained concepts reformulated into different documents for the WG.
 Where/how that happens is the chairs/authors call.

There was discussion in Seoul about:

A) Producing a base document to define 'sub-TLVs' in DLEP for the use
by extensions. (Used by #2 and #4)

B) Writing a draft describing the use of Flows in DLEP, whether
DiffServ or otherwise differentiated, in a general sense, referring to
the sub-TLVs document.

C) Perhaps merging some of the good ideas from the #5 and the existing
credit-windowing extension into a single draft, addressing perceived
issues in both.

D) Extending #1 to cover all the relevant metrics in core DLEP.

I have already offered to collaborate on A and B.  So I vote for #1,
#2, #3 to be accepted, and #5 merged.

Contentious maybe...

Rick

On Mon, 2016-11-28 at 10:44 -0500, Stan Ratliff wrote:
> David, 
> 
> Oops. I claim Monday morning fogginess after the long holiday
> weekend, and being insufficiently caffeinated, as my excuse! ;-) 
> 
> WG, 
> On Mon, Nov 28, 2016 at 10:33 AM, Wiggins, David - 0665 - MITLL <Davi
> [email-masked]> wrote:
> > Hi Stan,
> > 
> > From: manet <[email-masked]> on behalf of Stan Ratliff <rat
> > [email-masked]>
> > One of the items identified during the WG meeting in Seoul was to
> > formally request, via the list, Working Group adoption of 5
> > extension drafts related to DLEP. This email is that formal
> > request. 
> > 
> > The drafts are: 
> > 1. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-exten
> > sion-00.html
> > I have put all 5 extensions on this email for expediency only;
> > please do not assume that they must be adopted as a group. The
> > chairs would greatly appreciate thoughts from the WG, both positive
> > and negative, by December 12. 
> > 
> > For purposes of determining WG consensus, a lack of a response will
> > be seen as indicating support for adopting the draft (e.g. silence
> > == acceptance). 
> > 
> > Regards,
> > Stan
> > 
> > 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Lou Berger <[email-masked]>
Date: Mon, 28 Nov 2016 13:16:44 -0500

I support adoption (no surprise, I'm a contributor to all).

I'm fine with adopting then doing the changes or doing the restructuring
(queue parameters in own doc, merge credit extensions) then adopting -
is the chair's call.

Lou

PS I'm not aware of any IPR that applies to these documents.

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 28 Nov 2016 18:47:04 +0000

All, 

I think we have to first focus on adopting the drafts (some of them? all? none? That's the WG's call).  Then we can sort-out what restructuring should be done. 

Regards,
Stan

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Monday, November 28, 2016 1:17 PM
> To: Rick Taylor <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [manet] Call for acceptance as Working Group documents
> 
> (queue parameters in own doc, merge credit extensions) then adopting - is
> the chair's call.
> 
> Lou
> 
> > I seem to remember there was some discussion over whether the
> > documents should be accepted as WG documents in their current form, or
> > the contained concepts reformulated into different documents for the
> WG.
> >>> extension drafts related to DLEP. This email is that formal request.
> >>>
> >>> The drafts are:
> >>> 1.
> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_
> >>> html_draft-2Dcheng-2Dmanet-2Ddlep-2Dlatency-
> 2Dexten&d=DgICAg&c=LlUvi
> >>> dvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=6d
> >>> wQTMiMIWZZcxS2FW_XBJky-J-BfvCBGzn4k8jyFEI&s=ANa8fzRPRpn1KD-
> IB6msobnd
> >>> _t8KIKpXDCbWK6zIFtY&e=
> >>> sion-00.html
> >>> 2.
> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_
> >>> html_draft-2Dcheng-2Dmanet-2Ddlep-2Dpause-
> 2Dextensi&d=DgICAg&c=LlUvi
> >>> dvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=6d
> >>> wQTMiMIWZZcxS2FW_XBJky-J-
> BfvCBGzn4k8jyFEI&s=Wv6qbM0mWkXcfS_hVjugB-xs
> >>> stRUoMW7UbF7s1a2o8w&e=
> >>> on-00
> >>> 3.
> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_
> >>> html_draft-2Dcheng-2Dmanet-2Ddlep-2Dmulti-2Dhop-
> 2Dext&d=DgICAg&c=LlU
> >>> vidvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=
> >>> 6dwQTMiMIWZZcxS2FW_XBJky-J-
> BfvCBGzn4k8jyFEI&s=Zqsf8OPHI2iNaHbNzC8GPz
> >>> tIQGL6o0uEXispDAg400g&e=
> >>> ension-00
> >>> 4.
> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_
> >>> html_draft-2Dcheng-2Dmanet-2Ddlep-2Dlatency-
> 2Dexten&d=DgICAg&c=LlUvi
> >>> dvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=6d
> >>> wQTMiMIWZZcxS2FW_XBJky-J-BfvCBGzn4k8jyFEI&s=ANa8fzRPRpn1KD-
> IB6msobnd
> >>> _t8KIKpXDCbWK6zIFtY&e=
> >>> sion-00
> >>> 5.
> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_
> >>> html_draft-2Dcheng-2Dmanet-2Ddlep-2Dda-2Dcredit-
> 2Dext&d=DgICAg&c=LlU
> >>> vidvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=
> >>> 6dwQTMiMIWZZcxS2FW_XBJky-J-
> BfvCBGzn4k8jyFEI&s=Pfm1aX9PLkAMWkC1fpHoMH
> >>> mtldAPycgMVePRoYWBGNI&e=
> >>> ension-00
> >>>
> >> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mai
> >> lman_listinfo_manet&d=DgICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbL
> >> W5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=6dwQTMiMIWZZcxS2FW_XBJky-J-BfvCBGzn4
> >> k8jyFEI&s=hr-_ixL6nDbaQUKJS3SWWMc7ZCa0MELuJ87hjJ_Vg2w&e=
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_manet&d=DgICAg&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5
> > r8KZAL9L_yqNON1dbKtMa-Wbxna8&m=6dwQTMiMIWZZcxS2FW_XBJky-J-
> BfvCBGzn4k8j
> > yFEI&s=hr-_ixL6nDbaQUKJS3SWWMc7ZCa0MELuJ87hjJ_Vg2w&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_manet&d=DgICAg&c=LlUvidvlhStGUSx
> Ql0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=6dwQTMiMIWZZcxS2FW_XBJky-J-BfvCBGzn4k8jyFEI&s=hr-
> _ixL6nDbaQUKJS3SWWMc7ZCa0MELuJ87hjJ_Vg2w&e=

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 28 Nov 2016 18:56:02 +0000

Lou, 

Thanks for reminding me on the potential IPR issues. Just to make sure that base is completely covered, can I please hear from the other co-authors on the extensions as to any IPR claims that might exist? 

Regards,
Stan

---

From: "Cheng, Bow-Nan - 0665 - MITLL" <[email-masked]>
Date: Mon, 28 Nov 2016 19:32:53 +0000

No IPR issues on the MITLL side of the house.

--
Bow-Nan Cheng, Ph.D.
MIT Lincoln Laboratory
Tactical Networks Group
244 Wood St Lexington MA 02420
781-981-4997

On 11/28/16, 1:56 PM, "manet on behalf of Ratliff, Stanley"
<[email-masked] on behalf of [email-masked]> wrote:

>Lou, 
>
>Thanks for reminding me on the potential IPR issues. Just to make sure
>that base is completely covered, can I please hear from the other
>co-authors on the extensions as to any IPR claims that might exist?
>
>Regards,
>Stan
>
>
>>is
>==========================================================================
>==================================================================

---

From: Rick Taylor <[email-masked]>
Date: Tue, 29 Nov 2016 10:21:12 +0000

In which case: +1 for adoption of all.

Rick

On Mon, 2016-11-28 at 18:47 +0000, Ratliff, Stanley wrote:
> All, 
> 
> I think we have to first focus on adopting the drafts (some of them?
> all? none? That's the WG's call).  Then we can sort-out what
> restructuring should be done. 
> 
> 
> Regards,
> Stan
> 
> 
> > 
> =====================================================================
> =====================================================================
> ==

---

From: "Wiggins, David - 0665 - MITLL" <[email-masked]>
Date: Tue, 29 Nov 2016 16:19:40 +0000

We are for adoption as well.

David

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 30 Nov 2016 13:39:23 +0100

I do not believe that, at this time, this WG should adopt any new I-Ds, and certainly not 5 (or 4) new documents in one go.

Explanation:

Existing WG documents, which have cleared WGLC 4-5 months ago, are still pending WG chair write-up - this despite frequent reminders:

	https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multipath/history/

Given the highly limited bandwidth that we observe from the WG chairs, it would simply be foolhardily to push more documents into the WG.

I’d suggest “flushing the buffers” before committing the WG (and, thereby the chairs) to any additional work — which WG adoption of these documents effectively would be.

This should not, of course, preclude the authors of these documents from developing them as individual I-Ds until such time that the buffers are empty, and the chair-bandwidth-problem has been addressed.

It’s effectively a congestion control problem — which, I believe, a certain IETF developed protocol addresses by promptly reducing the window size to one, then and wait for an acknowledgement of data successfully getting through before doubling the window size. With the document cited above being the one “timing out”, I believe that this acknowledgement would be “it has been published as an RFC” ...

So count me down as “don’t adopt these documents at this point in time”, to let time for the congestion issues to be sorted out..

Best,

Thomas

PS: on a different note, I am not perfectly sure that “silence == consensus” is entirely kosher process … 

> On 28 Nov 2016, at 16:44, Stan Ratliff <[email-masked]> wrote:
> 
> David, 
> 
> Oops. I claim Monday morning fogginess after the long holiday weekend, and being insufficiently caffeinated, as my excuse! ;-) 
> 
> WG, 
> My apologies for the duplication. There are but 4 extensions, but the question to the WG is the same: To adopt, or not to adopt? 
> 
> Regards,
> Stan
> 
> 
> On Mon, Nov 28, 2016 at 10:33 AM, Wiggins, David - 0665 - MITLL <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Stan,
> 
> From: manet <[email-masked] <mailto:[email-masked]>> on behalf of Stan Ratliff <[email-masked] <mailto:[email-masked]>>
> To: MANET IETF <[email-masked] <mailto:[email-masked]>>
> One of the items identified during the WG meeting in Seoul was to formally request, via the list, Working Group adoption of 5 extension drafts related to DLEP. This email is that formal request. 
> 
> The drafts are: 
> 1. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00.html <https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00.html>
> 2. https://tools.ietf.org/html/draft-cheng-manet-dlep-pause-extension-00 <https://tools.ietf.org/html/draft-cheng-manet-dlep-pause-extension-00>
> 3. https://tools.ietf.org/html/draft-cheng-manet-dlep-multi-hop-extension-00 <https://tools.ietf.org/html/draft-cheng-manet-dlep-multi-hop-extension-00>
> 4. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00 <https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00>
> 5. https://tools.ietf.org/html/draft-cheng-manet-dlep-da-credit-extension-00 <https://tools.ietf.org/html/draft-cheng-manet-dlep-da-credit-extension-00>
> 
> I have put all 5 extensions on this email for expediency only; please do not assume that they must be adopted as a group. The chairs would greatly appreciate thoughts from the WG, both positive and negative, by December 12. 
> 
> For purposes of determining WG consensus, a lack of a response will be seen as indicating support for adopting the draft (e.g. silence == acceptance). 
> 
> Regards,
> Stan
> 
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 30 Nov 2016 22:41:05 +0200

Hi Thomas and Stan,

It is good to know that some participants agree with the strategy mentioned
before, when some drafts were announced for adoption like multi-topology,
multipath and multicast,  I wanted that we focus to complete the pending
issues like aodv, however, that strategy was not followed by the group
because some people around the world may be interested in such adoption. I
still support that strategy so we get time to discuss and review, but few
authors in this WG may not  agree.

Therefore, I will say that I accept to adopt only one dlep-extension,
which I am interested in the dlep-multi-hop ,

Best Regards

Abdussalam

On Wed, Nov 30, 2016 at 2:39 PM, Thomas Heide Clausen <
[email-masked]> wrote:

> I do not believe that, at this time, this WG should adopt any new I-Ds,
> and certainly not 5 (or 4) new documents in one go.
>
> Explanation:
>
> Existing WG documents, which have cleared WGLC 4-5 months ago, are still
> pending WG chair write-up - this despite frequent reminders:
>
> Given the highly limited bandwidth that we observe from the WG chairs, it
> would simply be foolhardily to push more documents into the WG.
>
> I’d suggest “flushing the buffers” before committing the WG (and, thereby
> the chairs) to any additional work — which WG adoption of these documents
> effectively would be.
>
> This should not, of course, preclude the authors of these documents from
> developing them as individual I-Ds until such time that the buffers are
> empty, and the chair-bandwidth-problem has been addressed.
>
> It’s effectively a congestion control problem — which, I believe, a
> certain IETF developed protocol addresses by promptly reducing the window
> size to one, then and wait for an acknowledgement of data successfully
> getting through before doubling the window size. With the document cited
> above being the one “timing out”, I believe that this acknowledgement would
> be “it has been published as an RFC” ...
>
> So count me down as “don’t adopt these documents at this point in time”,
> to let time for the congestion issues to be sorted out..
>
> Best,
>
> Thomas
>
>> formally request, via the list, Working Group adoption of 5 extension
>> drafts related to DLEP. This email is that formal request.
>>
>> The drafts are:
>> 1. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-
>> extension-00.html