Subject: Re: [manet] manet Digest, Vol 160, Issue 6

From: "James A. (Jim) Stevens" <[email-masked]>
Date: Thu, 7 Sep 2017 17:55:01 -0500

what about radio routing hops below IP, e.g. for a mesh network below IP?

This would tell the router how many radio hops (as contrasted to IP hops)
away a neighbor is.

Jim Stevens

On Thu, Sep 7, 2017 at 2:00 PM, <[email-masked]> wrote:

> Send manet mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/manet
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of manet digest..."
>
>
> Today's Topics:
>
>    1. Thoughts on draft-dlep-lid (Henning Rogge)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 7 Sep 2017 12:57:53 +0200
> From: Henning Rogge <[email-masked]>
> To: <[email-masked]>
> Subject: [manet] Thoughts on draft-dlep-lid
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"; format=flowed
>
> I had some time to look at draft-dlep-lid and there is one thing I am
> wondering about.
>
> I wonder if leaving out the MAC TLV is a bit too tough on many DLEP
> implementations, we are talking about the "primary key" for the neighbors.
>
> Whats about adding a "IP hops" TLV instead, which tells the router how
> many IP hops a neighbor is away?
>
> Default value would be zero (briding distance), but routing radios would
> report something like 2 (two routers in between, one on each radio).
>
> This value might also be useful later for "multihop routing" radios.
>
> Henning Rogge
> --
> Diplom-Informatiker Henning Rogge , Fraunhofer-Institut f?r
> Kommunikation, Informationsverarbeitung und Ergonomie FKIE
> Kommunikationssysteme (KOM)
> Zanderstrasse 5, 53177 Bonn, Germany
> Telefon +49 228 50212-469
> mailto:[email-masked] http://www.fkie.fraunhofer.de
>
>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>
> ------------------------------
>
> End of manet Digest, Vol 160, Issue 6
> *************************************
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 8 Sep 2017 07:24:42 +0200

> This would tell the router how many radio hops (as contrasted to IP hops)

Good argument...

maybe "this radio does IP routing" could be just a boolean flag
(similar to "needs unicast traffic to determine MCS" and "does not
support RX/TX broadcast/multicast" while this flag tells the router
the number of radio hops to the target.

Henning

---

From: Rick Taylor <[email-masked]>
Date: Fri, 8 Sep 2017 09:16:10 +0000

Hi James,

There was a draft extension that might exactly meet you requirements:

https://tools.ietf.org/id/draft-cheng-manet-dlep-multi-hop-extension-00
.txt

Cheers

Rick 

On Thu, 2017-09-07 at 17:55 -0500, James A. (Jim) Stevens wrote:
> This would tell the router how many radio hops (as contrasted to IP
> hops) away a neighbor is.
> 
> Jim Stevens
> 
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 8 Sep 2017 11:37:10 +0200

> https://tools.ietf.org/id/draft-cheng-manet-dlep-multi-hop-extension-00

I knew I had forgot something...

So this draft could be combined with a "IP routing" flag of the radio?

I am still a little bit worried about the "id" draft that removes the
mandatory MAC tlv from the Neighbor up/down/update messages.

Henning