Subject: Re: [manet] Alissa Cooper's Discuss on draft-ietf-manet-dlep-pause-extension-06: (with DISCUSS and COMMENT)

From: Alvaro Retana <[email-masked]>
Date: Mon, 6 May 2019 14:26:59 -0400

Alissa:

Hi!

Do my answers satisfy your DISCUSS question?  If not, what are your
expectations?

Thanks!

Alvaro.

On April 11, 2019 at 9:49:39 AM, Alvaro Retana ([email-masked])
wrote:

On April 11, 2019 at 9:06:50 AM, Alissa Cooper ([email-masked]) wrote:

Is there any scope limitation to the functionality that could potentially
be characterized as further "development of DLEP"? I ask because from a
quick read of the base specification, it doesn’t look like pause/resume was
contemplated, and as you note this was not explicitly called out in the
charter whereas credit windowing was. I’m wondering what the boundary is
around the functionality DLEP is expected to provide as a protocol.

In short, I believe the boundary is simply “whatever the users need”.

When we re-chartered (a couple of years ago), the WG thought that credit
windowing would be the focus (there was a document in progress, etc.), but
that has changed to include this extension, and others.  The community
working on DLEP is a very close-knit group with related (it not
significantly overlapping) users — the focus of the work then follows what
their users require.

At some point we should think about generalizing the charter.

Thanks!

Alvaro.

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 10 May 2019 10:04:45 -0400

I cleared, but it would be good to think about a charter update to capture the full scope of the work the group is expecting to do.

Thanks,
Alissa

> On May 6, 2019, at 2:26 PM, Alvaro Retana <[email-masked]> wrote:
> 
> Alissa:
> 
> Hi!
> 
> Do my answers satisfy your DISCUSS question?  If not, what are your expectations?
> 
> Thanks!
> 
> Alvaro.
> 
> On April 11, 2019 at 9:49:39 AM, Alvaro Retana ([email-masked] <mailto:[email-masked]>) wrote:
> 
>> On April 11, 2019 at 9:06:50 AM, Alissa Cooper ([email-masked] <mailto:[email-masked]>) wrote:
>> 
>>> Is there any scope limitation to the functionality that could potentially be characterized as further "development of DLEP"? I ask because from a quick read of the base specification, it doesn’t look like pause/resume was contemplated, and as you note this was not explicitly called out in the charter whereas credit windowing was. I’m wondering what the boundary is around the functionality DLEP is expected to provide as a protocol.
>> 
>> When we re-chartered (a couple of years ago), the WG thought that credit windowing would be the focus (there was a document in progress, etc.), but that has changed to include this extension, and others.  The community working on DLEP is a very close-knit group with related (it not significantly overlapping) users — the focus of the work then follows what their users require.
>>