Subject: Re: [Masque] [Webtransport] WGLC for draft-ietf-masque-h3-datagram

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 4 Apr 2022 17:11:44 +0000

Hi all,

I also reviewed the draft and have opened some issues. Two are editorial, but maybe those three are not:

Related to Magnus' issue, I have also one that at least needs some clarification:

Paragraph on use of capsule protocol and http datagrams is unclear
https://github.com/ietf-wg-masque/draft-ietf-masque-h3-datagram/issues/165

The next issue is about use of normative language, which I think we need to address properly to ensure interoperability:

SHOULD or MUST intermediaries forward unknown capsulate types without modification?
https://github.com/ietf-wg-masque/draft-ietf-masque-h3-datagram/issues/167

And I opened the following issue for discussion:

Default behaviour of unknown capsule types
https://github.com/ietf-wg-masque/draft-ietf-masque-h3-datagram/issues/173
As I say in the issue we might conclude that the current spec is fine but I want to make sure this was considered appropriately.

Otherwise the draft looks good to move ahead!

Mirja

On 04.04.22, 18:54, "Masque on behalf of Magnus Westerlund" <[email-masked] on behalf of magnus.westerlund=[email-masked]> wrote:

    Hi,

    I have reviewed draft-ietf-masque-h3-datagram using today's editors copy on
    github. 

    I have submitted an number of issues (168-175) and also was behind 167.

    I think the most significant ones are the implications of 

    https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-670d1fa4e96878e1&q=1&e=aaf8a034-5d17-46fb-93c0-c6d6d964327d&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-h3-datagram%2Fissues%2F167
    https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-0fb9eadc07d83918&q=1&e=aaf8a034-5d17-46fb-93c0-c6d6d964327d&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-h3-datagram%2Fissues%2F168

    As these are about relation to HTTP Intermediaries, Interoperability of
    implementations and what HTTP extensions using HTTP Datagram needs to define
    to become interoperable. 

    Also 
    https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-904925fb875f1988&q=1&e=aaf8a034-5d17-46fb-93c0-c6d6d964327d&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-h3-datagram%2Fissues%2F169
    will likely require some discussion as it is a question of what general
    capabilities HTTP datagrams should have rather than the immediate usage in
    Extended Connect for the MASQUE use cases. 

    Cheers

    Magnus Westerlund

---

From: David Schinazi <[email-masked]>
Date: Mon, 4 Apr 2022 13:20:10 -0700

Thanks for the great review Mirja!

Lucas and I will get PRs out for the editorial issues shortly, and we can
keep discussing the following non-editorial issues on GitHub:
#167: SHOULD or MUST intermediaries forward unknown capsule types without
modification?
#173: Default endpoint behaviour of unknown capsule types

David

On Mon, Apr 4, 2022 at 10:12 AM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> The next issue is about use of normative language, which I think we need
> to address properly to ensure interoperability:
>
> As I say in the issue we might conclude that the current spec is fine but
> I want to make sure this was considered appropriately.
>
> On 04.04.22, 18:54, "Masque on behalf of Magnus Westerlund" <
> [email-masked] on behalf of magnus.westerlund=
> [email-masked]> wrote:
>
>     Hi,
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>