Subject: Re: [Masque] WGLC for draft-ietf-masque-connect-udp

From: Lucas Pardue <[email-masked]>
Date: Tue, 5 Apr 2022 20:11:44 +0100

Hi,

(moving WebTrans and HTTP lists to BCC)

I have completed my review of draft-ietf-masque-connect-udp. I have opened
a number of editorial issues on GitHub that can subjectively improve the
readability of this document, I'll leave it to the editor's discretion on
whether to address these and I'll follow up on issues/PRs as needed.

>From a technical point of view, I believe this document is ready to proceed.

Cheers
Lucas

On Mon, Mar 21, 2022 at 6:18 PM Eric Kinnear <ekinnear=
[email-masked]> wrote:

> (Cross-posting to MASQUE, HTTPBIS, and WebTransport)
>
> This email initiates the WGLC for draft-ietf-masque-connect-udp, located
> here:
>
> https://datatracker.ietf.org/doc/draft-ietf-masque-connect-udp/
>
> Please review the document and send any comments to the MASQUE mailing
> list. HTTPBIS and WebTransport are cc’d given the overlap in technology.
>
> This call will run in parallel to draft-ietf-masque-h3-datagram and
> conclude on April 8.
>
> Best,
> Eric and Chris
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 05 Apr 2022 12:49:10 -0700

I support Lucas’s issues/comments. I didn’t see any other issues in my review. So, I think this document is ready to progress.

Best,
Tommy

> On Apr 5, 2022, at 12:11 PM, Lucas Pardue <[email-masked]> wrote:
> 
> Hi,
> 
> I have completed my review of draft-ietf-masque-connect-udp. I have opened a number of editorial issues on GitHub that can subjectively improve the readability of this document, I'll leave it to the editor's discretion on whether to address these and I'll follow up on issues/PRs as needed.
> 
> On Mon, Mar 21, 2022 at 6:18 PM Eric Kinnear <ekinnear=[email-masked] <mailto:[email-masked]>> wrote:
> This email initiates the WGLC for draft-ietf-masque-connect-udp, located here:
> 
> https://datatracker.ietf.org/doc/draft-ietf-masque-connect-udp/ <https://datatracker.ietf.org/doc/draft-ietf-masque-connect-udp/>
> 
> Please review the document and send any comments to the MASQUE mailing list. HTTPBIS and WebTransport are cc’d given the overlap in technology.
> 
> This call will run in parallel to draft-ietf-masque-h3-datagram and conclude on April 8.
> 
> Best,
> Eric and Chris
> -- 
> Masque mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/masque <https://www.ietf.org/mailman/listinfo/masque>
> -- 
> Masque mailing list
> [email-masked]

---

From: Ben Schwartz <[email-masked]>
Date: Tue, 5 Apr 2022 17:30:23 -0400

I've opened a last-call proposal to remove the default template:
https://github.com/ietf-wg-masque/draft-ietf-masque-connect-udp/pull/107

To summarize: I think we can do better, and this is a problem that deserves
a proper design with its own draft.

---

From: David Schinazi <[email-masked]>
Date: Tue, 5 Apr 2022 15:53:08 -0700

Hi Ben, please file an issue so we can have the discussion there.

Thanks,
David

On Tue, Apr 5, 2022 at 2:30 PM Ben Schwartz <bemasc=
[email-masked]> wrote:

> To summarize: I think we can do better, and this is a problem that
> deserves a proper design with its own draft.
>

---

From: David Schinazi <[email-masked]>
Date: Tue, 5 Apr 2022 17:02:12 -0700

Thank you Lucas and Tommy for your thorough review. I agreed with all but
one of your issues.
Since all the issues filed were editorial, I made PRs and merged them to
avoid merge conflicts;
if you find any resolution you don't love please let me know and I'll be
happy to update the editor's copy.

David

On Tue, Apr 5, 2022 at 12:49 PM Tommy Pauly <tpauly=
[email-masked]> wrote:

> I support Lucas’s issues/comments. I didn’t see any other issues in my
> review. So, I think this document is ready to progress.
>
> Best,
> Tommy
>
> I have completed my review of draft-ietf-masque-connect-udp. I have
> opened a number of editorial issues on GitHub that can subjectively improve
> the readability of this document, I'll leave it to the editor's discretion
> on whether to address these and I'll follow up on issues/PRs as needed.
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 11 Apr 2022 13:13:05 +0000

Hi all,

I also reviewed the draft last week. Sorry for my late mail but I just realized that I never actually finished this mail after my review.

I reviewed the document and it is well written and clear. Thanks to the authors! I open a few small issues on GitHub for purely editorial things that I thought could need clarification and there were addressed by the authors immediately and therefore are already closed. Thanks for the quick reply!

So in summary everything that is written in draft is in well in shape and ready. However, I still have concerns about moving this draft forward to publication because of the parts that are not written down in this draft, which is capsule negotiation. Capsulate negotiation is the missing piece at the moment and I think we need to get a better understanding how this should be realized before we move ahead. Particularly I’m not sure if capsule negotiation should stay in the separate draft. Maybe this would make it possible to move this draft ahead a bit faster but if it risks interoperability problems because every extensions comes up with a slightly different scheme, that would not be worth it. I assume most extensions would need negotiation and therefore providing a default way for negotiation as part of the base spec seems important to me. However, at least I would like to get the full picture how all components work together before we move ahead with publication.

Mirja

From: Masque <[email-masked]> on behalf of Tommy Pauly <tpauly=[email-masked]>
Date: Tuesday, 5. April 2022 at 21:49
To: Lucas Pardue <[email-masked]>
Cc: MASQUE <[email-masked]>
Subject: Re: [Masque] WGLC for draft-ietf-masque-connect-udp

Best,
Tommy

On Apr 5, 2022, at 12:11 PM, Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Cheers
Lucas

On Mon, Mar 21, 2022 at 6:18 PM Eric Kinnear <ekinnear=[email-masked]<mailto:[email-masked]>> wrote:
(Cross-posting to MASQUE, HTTPBIS, and WebTransport)

Best,
Eric and Chris
--
Masque mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/masque
--
Masque mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/masque

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 11 Apr 2022 14:36:18 +0100

Hey Mirja,

On Mon, Apr 11, 2022 at 2:13 PM Mirja Kuehlewind <
[email-masked]> wrote:

> Hi all,
>
>
>
> I also reviewed the draft last week. Sorry for my late mail but I just
> realized that I never actually finished this mail after my review.
>
>
>
> I reviewed the document and it is well written and clear. Thanks to the
> authors! I open a few small issues on GitHub for purely editorial things
> that I thought could need clarification and there were addressed by the
> authors immediately and therefore are already closed. Thanks for the quick
> reply!
>

Thanks for the review!

>
>
> So in summary everything that is written in draft is in well in shape and
> ready. However, I still have concerns about moving this draft forward to
> publication because of the parts that are not written down in this draft,
> which is capsule negotiation. Capsulate negotiation is the missing piece at
> the moment and I think we need to get a better understanding how this
> should be realized before we move ahead. Particularly I’m not sure if
> capsule negotiation should stay in the separate draft. Maybe this would
> make it possible to move this draft ahead a bit faster but if it risks
> interoperability problems because every extensions comes up with a slightly
> different scheme, that would not be worth it. I assume most extensions
> would need negotiation and therefore providing a default way for
> negotiation as part of the base spec seems important to me. However, at
> least I would like to get the full picture how all components work together
> before we move ahead with publication.
>

The extensibility angle doesn't personally worry me so much. We have
well-defined and well-trodden HTTP mechanisms such as header fields,
settings or frames that can be used. Or capsules can be used for a similar
purpose. The needs of the extension might dictate the use of any of these,
and I think it will work. Or it might need something more advanced that
only it knows about.

I don't think we need to go further with trying to define a generic or
abstract negotiation framework over the available primitives. I don't think
holding publication would reveal new information in a reasonable timeframe
If we are worried about fragmentation of approaches, that's something the
standards process of those extensions can help catch.

Cheers,
Lucas

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 11 Apr 2022 15:56:33 +0000

Hi,

I bit late, but I have review -08 of the draft and filed 6 issues (#139-144) https://github.com/ietf-wg-masque/draft-ietf-masque-connect-udp/issues/139

I think when these address it is ready. I do note that this is really a minimal viable product. I think several extensions are likely needed in near time to make the protocol a bit more useful in various scenarios.

Cheers

Magnus

From: Masque <[email-masked]> On Behalf Of Eric Kinnear
Sent: den 21 mars 2022 19:18
To: MASQUE <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [Masque] WGLC for draft-ietf-masque-connect-udp

Best,
Eric and Chris

---

From: David Schinazi <[email-masked]>
Date: Mon, 11 Apr 2022 10:37:24 -0700

Thank you for your reviews Mirja and Magnus!
We've addressed all your editorial comments, thanks for helping make the
document clearer.

To Mirja's point about capsule registration, I agree with Lucas's reply -
delaying this document would not provide benefits in any near time frame,
the better solution is to have these extensions be developed inside the
MASQUE WG and we'll collectively ensure that the mechanism is sound and
reusable.

David

On Mon, Apr 11, 2022 at 8:56 AM Magnus Westerlund <magnus.westerlund=
[email-masked]> wrote:

> Hi,
>
>
>
> I bit late, but I have review -08 of the draft and filed 6 issues
> (#139-144)
> https://github.com/ietf-wg-masque/draft-ietf-masque-connect-udp/issues/139
>
>
>
> I think when these address it is ready. I do note that this is really a
> minimal viable product. I think several extensions are likely needed in
> near time to make the protocol a bit more useful in various scenarios.
>
>
>
> Cheers
>
>
>
> Magnus
>
>
>
>
>
> *From:* Masque <[email-masked]> *On Behalf Of *Eric Kinnear
> *Sent:* den 21 mars 2022 19:18
> *To:* MASQUE <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* [Masque] WGLC for draft-ietf-masque-connect-udp
>
>
>