Subject: [media-types] New media type request: application/stream+json

From: James M Snell <[email-masked]>
Date: Thu, 11 Oct 2012 09:37:21 -0700

Hello all,

I would like to request the registration of a new "application/stream+json"
media type [1] to represent JSON Activity Stream v1.0 document resources [2]

[1] http://www.ietf.org/id/draft-snell-activity-streams-type-01.txt
[2] http://activitystrea.ms/specs/json/1.0/

The I-D is informational as the Activity Streams specification is not an
IETF-produced document. The data format is not vendor specific and is
implemented in a broad range of application types. It is a proper subset of
JSON so the +json suffix should be appropriate.

- James

---

From: James M Snell <[email-masked]>
Date: Sat, 13 Oct 2012 12:01:59 -0700

Already in use in deployed applications and not my invention.

On Sat, Oct 13, 2012 at 11:56 AM, Mark Nottingham <[email-masked]> wrote:

> "stream" is a *really* generic word.
>
> Is this in use already? If it's not widely deployed, I'd suggest
> "application/activity-stream+json" or similar.
>
> Cheers,
>
>
> On 12/10/2012, at 3:37 AM, James M Snell <[email-masked]> wrote:
>
> > Hello all,
> >
> > I would like to request the registration of a new
> "application/stream+json" media type [1] to represent JSON Activity Stream
> v1.0 document resources [2]
> >
> > _______________________________________________
> > media-types mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/media-types
>
> --
> Mark Nottingham   http://www.mnot.net/
>
>
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 14 Oct 2012 05:56:08 +1100

Is this in use already? If it's not widely deployed, I'd suggest "application/activity-stream+json" or similar.

Cheers,

On 12/10/2012, at 3:37 AM, James M Snell <[email-masked]> wrote:

> Hello all, 
> 
> I would like to request the registration of a new "application/stream+json" media type [1] to represent JSON Activity Stream v1.0 document resources [2]
> 
> The I-D is informational as the Activity Streams specification is not an IETF-produced document. The data format is not vendor specific and is implemented in a broad range of application types. It is a proper subset of JSON so the +json suffix should be appropriate. 
> 
> - James

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 14 Oct 2012 06:02:42 +1100

OK, never mind.