Subject: [media-types] MIME Type registration

From: Eric Turcotte <[email-masked]>
Date: Fri, 16 Nov 2012 15:29:50 +0000

Hi,
I would like to register (in the standards tree) a new MIME type that has been defined in 3GPP working group SA4. The 3GPP specification where this is defined is:
http://www.3gpp.org/ftp/Specs/archive/26_series/26.346/26346-980.zip.

In that sepecification, section C.14 has the MIME type registration information, and is extracted bellow for your consideration/review.
Please let me know if additional information or questions you may have.
Thank you,
Eric Turcotte

C.14    Registration of MIME type "application/mbms-schedule+xml"
The MIME-Type registration for "application/mbms-schedule+xml" identifies XML documents that follows the schema " urn:3gpp:metadata:2011:MBMS:scheduleDescription " defined in clause 11.2A.2.

Type name: application

Subtype name: mbms-schedule+xml

Required parameters:

None

Optional parameters:

charset: As specified in RFC 3023 [83] for media type application/xml.

Encoding considerations:

This is an XML document and the encoding considerations are the same as for media type "application/xml" defined in RFC 3023 [83].

Security considerations:

The information present in this media format is used to configure the receiving application. Thus the usage of the fomat is vulnerable to attacks modifying or spoofing the content of this format. It is recommended to use source authentication and integrity protection.

Interoperability considerations:

None

Published specification:

3GPP TS 26.346

Applications which use this media type:

3GPP MBMS based applications

Additional information:

Magic number(s): None

File extension(s):

Macintosh file type code(s):

Person & email address to contact for further information:

Eric Turcotte ([email-masked])
3GPP TSG SA WG4

Intended usage: COMMON

Restrictions on usage:

None

Author:

3GPP TSG SA WG4

Change controller:

3GPP TSG SA WG4

---

From: Ned Freed <[email-masked]>
Date: Fri, 16 Nov 2012 09:00:43 -0800 (PST)

A couple of comments...

> This is an XML document and the encoding considerations are the same as for
> media type "application/xml" defined in RFC 3023 [83].

It's fine to add this, but you still need to specify the encoding. If the
type is limited to utf-8 and similar charsets 8bit is appropriate, if
utf-16 variants are allowed it needs to be binary.

> The information present in this media format is used to configure the
> receiving application. Thus the usage of the fomat is vulnerable to attacks
> modifying or spoofing the content of this format. It is recommended to use
> source authentication and integrity protection.

You should also comment on any need, or the lack of any need, for privacy
protection. That is, does this configuration information contain passwords
or keys similar things?

> 3GPP TSG SA WG4

				Ned

---

From: Eric Turcotte <[email-masked]>
Date: Mon, 19 Nov 2012 15:00:02 +0000

Dear Ned,
Thanks for your comments. Please see my reply below [et nov 19].
BR,
Eric. 

-----Original Message-----
From: Ned Freed [mailto:[email-masked]] 
Sent: November-16-12 12:01 PM
To: Eric Turcotte
Cc: [email-masked]
Subject: Re: [media-types] MIME Type registration

A couple of comments...

> This is an XML document and the encoding considerations are the same 
> as for media type "application/xml" defined in RFC 3023 [83].

It's fine to add this, but you still need to specify the encoding. If the type is limited to utf-8 and similar charsets 8bit is appropriate, if
utf-16 variants are allowed it needs to be binary.

=========
[et nov 19] The encoding is limited to UTF-8 so it should be 8bit as you mention.
==========

> receiving application. Thus the usage of the fomat is vulnerable to 
> attacks modifying or spoofing the content of this format. It is 
> recommended to use source authentication and integrity protection.

You should also comment on any need, or the lack of any need, for privacy protection. That is, does this configuration information contain passwords or keys similar things?

=========
[et nov 19] No there is no need for privacy protection, as the configuration information does not contain passwords or keys or similar.

Would you be OK with the following text (adding 1 sentence at the end?

The information present in this media format is used to configure the receiving application. Thus the usage of the fomat is vulnerable to attacks modifying or spoofing the content of this format. It is 
recommended to use source authentication and integrity protection. The information carried in the media format does not contain any private information such as passwords or keys.
=========

> Eric Turcotte ([email-masked]) 3GPP TSG SA WG4

				Ned

---

From: Ned Freed <[email-masked]>
Date: Mon, 19 Nov 2012 08:58:47 -0800 (PST)

> Thanks for your comments. Please see my reply below [et nov 19].

Specific responses inline, but your changes address my concerns. I'll also
note that since this is a standards tree type you'll need to submit it
using whatever process 3GPP has for such things.

				Ned

> [et nov 19] The encoding is limited to UTF-8 so it should be 8bit as you mention.

Then I would suggest something like:

  Encoding considerations: 8bit

  The content of this media type is always utf-8.

> The information present in this media format is used to configure the receiving
> application. Thus the usage of the fomat is vulnerable to attacks modifying or
> spoofing the content of this format. It is recommended to use source
> authentication and integrity protection. The information carried in the media
> format does not contain any private information such as passwords or keys.

Sounds good to me!

> _______________________________________________
> media-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types

---

From: Eric Turcotte <[email-masked]>
Date: Tue, 20 Nov 2012 16:20:54 +0000

Hi Ned,
As a results of your comments, it seems there may be updates needed in the 3GPP sepcifications, and I can work/submit those at next 3GPP SA4 meeting (end of Jan 2013). Only Annex C.14 would be modified for the following 2 aspects:
=============
1- with respect to encoding
   Encoding considerations
   8bit.
   This is an XML document and the encoding considerations are the same as for media type "application/xml" defined in RFC 3023 [83].
2- with respect to security
   Security considerations:
   The information present in this media format is used to configure the receiving application. Thus the usage of the fomat is vulnerable   to attacks modifying or spoofing the content of this format. It is recommended to use source authentication and integrity protection. The 
information carried in the media format does not contain any private information such as passwords or keys.
============
I will wait a bit to see if there are other comments, befor proceeding to next steps with this.
Thanks,
Eric.

-----Original Message-----
From: Ned Freed [mailto:[email-masked]] 
Sent: November-19-12 11:59 AM
To: Eric Turcotte
Cc: Ned Freed; [email-masked]
Subject: Re: [media-types] MIME Type registration

> Thanks for your comments. Please see my reply below [et nov 19].

Specific responses inline, but your changes address my concerns. I'll also note that since this is a standards tree type you'll need to submit it using whatever process 3GPP has for such things.

				Ned

> It's fine to add this, but you still need to specify the encoding. If 
> the type is limited to utf-8 and similar charsets 8bit is appropriate, 
> if

> > The information present in this media format is used to configure 
> > the receiving application. Thus the usage of the fomat is vulnerable 
> > to attacks modifying or spoofing the content of this format. It is 

> recommended to use source authentication and integrity protection. The 
> information carried in the media format does not contain any private information such as passwords or keys.

Sounds good to me!