Subject: RE: [mediactrl] RE: mixer protocol req. - general protocol commen ts

From: Eric Burger <[email-masked]>
Date: Fri, 10 Dec 2004 02:41:50 GMT

My thoughts on virtual media servers:

barf, barf, barf, barf, barf, barf, barf, barf, barf, barf, barf

[too lazy to do ASCII art of piles of yellow and brown chunky stuff -- I
hope the visual image gets the point across]

Lots of application complexity, lots of application server complexity, lots
of media server complexity, and at the end of the day, you get less
functionality.

Why go there if we don't have to?

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Thursday, December 09, 2004 2:21 PM
> To: Tim Melanchuk; Eric Burger
> Cc: Roni Even; MixerControl
> Subject: Re: [mediactrl] RE: mixer protocol req. - general protocol
> comments
> 
> 
> 
> Can I abstract this away to say that things will generally 
> work as: The AS
> sends a commend to the MS and says try to make this so. The 
> the AS says, yes
> I can do that or no, I did not have the 
> resources/capabilities to do what
> you requested. 
> 
> The questions in my mind is do we have a model where a give bit of DSP
> platform was divided into some number of virtual MS and each MS was
> configured separately and was controlled by one one AS. Or is the DSP
> hardware configured as one MS and many AS can connect to it 
> and compete for
> the resources on it. I can see eitehr model working.
> 
> I believe we all agree that a single AS can control many MS.
> 
> 
> 
> On 12/8/04 5:48 PM, "Tim Melanchuk" <[email-masked]> wrote:
> 
> >> 
> >>> 3. The protocol should enable many AS to work with the same
> >>> MS (is this
> >>> really needed???)
> >>> 
> >>> [timm] we see this out in the world. a large carrier grade MS will
> >>> support multiple ASs where a smaller enterprize MS may not. hence,
> >>> i think that the capability should be allowed/supported by the
> >>> protocol, but not required by an MS.
> >>> 
> >>> RE: My question is if there a need to allow many AS to work
> >>> with one MS
> >>> not based on any virtual allocation. This requirement 
> makes it more
> >>> complicated for the AS to decide which of the MS he is 
> managing can be
> >>> used for a new conference specially if he does not know 
> what is the
> >>> resources usage on the MS by the other AS.
> >> 
> >> 
> >> That's H.248-think.  If you use Oracle, do you need to 
> know what resources
> >> the other applications are using?  No.  You ask your 
> query, and either you
> >> get a result or you get told the server is too busy.  Same 
> thing here if
> >> your using a session-level protocol [yes, hidden ding on 
> MGCP-like markups
> >> :-].
> >> 
> > afaik, both mgcp and h.248 have response codes indicating the server
> > is currently too busy to service a request. so, although i tend to
> > agree with the solution, i don't see significant difference here.
> > [no hidden dings on any markups ;-) ]
> 
--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 10 Dec 2004 20:36:51 GMT

Well that was not the most amazing deep and technical argument but it did
have a very concise and convincing summary. Ok, I am convinced.

On 12/9/04 7:02 PM, "Eric Burger" <[email-masked]> wrote:

> Ubiquity Software does not control or endorse the content, messages or
> information found in this mail list and it specifically disclaims any
> liability with regard to these communications.
> Ubiquity Software reserves the right the restrict access to any communications
> in violation of the Terms and Conditions of Use for this website or as
> otherwise deemed improper.

---

From: Tim Melanchuk <[email-masked]>
Date: Fri, 10 Dec 2004 21:08:54 GMT

very articulate ;-) and full of assumptions.
a proper virtualization should make a virtual ms
look the same as a physical ms to an application.
such as choice should be up to ms vendors if
they perceive a marketplace need for such a thing.
i think our protocol discussions should be more
focused whether there are any requirements for
resource/mgt reservation  and if so, how are
those realized.
timm

Eric Burger wrote:

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]]
Sent: Thursday, December 09, 2004 2:21 PM
To: Tim Melanchuk; Eric Burger
Cc: Roni Even; MixerControl
Subject: Re: [mediactrl] RE: mixer protocol req. - general protocol
comments