Subject: Re: [mediactrl] Going forward with media server control - resend

From: Cullen Jennings <[email-masked]>
Date: Sun, 10 Apr 2005 18:01:33 +0100 (BST)

I like the diagram - might want to show RTP from Participant to MS

On 2/7/05 12:31 PM, "Chris Boulton" <[email-masked]> wrote:

> Hi all,
> Got some questions/observations on the current set of media
> control requirements:-
> 
> Architecture:-
> 
> I'm not sure I fully agree with the diagram.  Can you explain more about
> the role of the proxy server in this architecture?  I personally thought
> the diagram should look as follows:-
> 
> 
>                       XCON Protocol               +--------+
>              +----------------------------------->|  XCON  |
>              |                                  __|________|_
>              |        SIP                      | Application |
>              |     +-------------------------->| Server/Focus|
>              |     |                           |   (B2BUA)   |
>              |     |                           |_____________|
>              |     |                               |    ^
>              |     |                               |    |
>              |     v                               |    |
>         _____________                          SIP |    |
>        |             |                             |    |AS-MS
>        | Participant |                             |    |Protocol
>        |_____________|                             |    |
>                                                    |    |
>                                                    |    |
>                                                    |    |
>                                                   _v____v_
>                                                  |        |
>                                                  | Media  |
>                                                  | Server |
>                                                  |________|
> 
> 
> In this model the AS acts as a B2BUA which bridges the participant from
> the Media server.  The AS would create a control leg between the media
> server to negotiate the 'AS-MS' reliable control channel.  A participant
> would then have an associated SIP session (for media etc.)
> 
> 
> General Protocol
> 
> 11.  The MS should send a summary report when the session is terminated
> by the AS.
> 
> Can we clarify this a little more please?  When we talk about 'session'
> - are we referring to the Control session (reliable pipe that
> set-up/control messages are being sent) OR the SIP session representing
> an endpoint (Media negotiation).
> 
> 13.  The MS should support DTMF detection (in band tones and RFC2833)
> 
> Should this really say something like 'The protocol should support the
> reporting of DTMF digits detected using in band tones and RFC 2833'.
> 
> 14.  The protocol shall include redundancy procedures.
> 
> Is this referring to the signaling protocol - If so wouldn't the focus
> be on the associated SIP session for redundancy?  How does this impact
> the new protocol?
> 
> 16.  The AS should be able to reserve resources on the MS.  The
>    resources models should be simple.  (this requirement needs more
>    discussion)
> 
> I really think that we should start this discussion - especially when we
> mention having 1:many and many:1 relationships.  How are we considering
> this with multiple AS potentially connecting to one MS.  The only way I
> can think of involves a centralized resource manager that certainly
> moves away from being simple.   Same applies to 18:- 18.  The MS shall
> inform the AS about any changes in it capacities.  The changes may be
> due to reservation, internal usage or due to some malfunction.
> 
> 21.  The MS shall supply the AS with sufficient information for the
>    event package.
> 
> Can you clarify this please?
> 
> -----Original Message-----
> From: Even, Roni [mailto:[email-masked]]
> Sent: 31 January 2005 08:37
> To: [email-masked]
> Subject: [mediactrl] Going forward with media server control - resend
> 
> Hi guys,
> I submitted the attached draft.
> Are we going to have a BOF in Minneapolis or an informal meeting
> Roni
> 
> 
> This email and any attached files are confidential and copyright protected.
> If you are not the addressee, any dissemination, distribution or copying of
> this communication is strictly prohibited.  Unless otherwise expressly agreed
> in writing, nothing stated in this communication shall be legally binding.
> 
> --------------------------
> Ubiquity Software does not control or endorse the content, messages or
> information found in this mail list and it specifically disclaims any
> liability with regard to these communications.
> Ubiquity Software reserves the right the restrict access to any communications
> in violation of the Terms and Conditions of Use for this website or as
> otherwise deemed improper.
--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 11 Apr 2005 09:40:53 +0100 (BST)

XCON Protocol               +--------+
              +----------------------------------->|  XCON  |
              |                                  __|________|_
              |        SIP                      | Application |
              |     +-------------------------->| Server/Focus|
              |     |                           |   (B2BUA)   |
              |     |                           |_____________|
              |     |                               |    ^
              |     |                               |    |
              |     |                               |    |
              |     |                           SIP |    |
              |     |                               |    |AS-MS
              |     |                               |    |Protocol
              |     |                               |    |
              |     |                               |    |
              |     |                               |    |
              |     |                               |    |
              |     |                              _v____v_
           ___|_____v____                         |        |
          |             |                         | Media  |
          | Participant |<==========RTP==========>| Server |
          |_____________|                         |________|

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: 10 April 2005 18:00
To: Chris Boulton; Roni Even; MixerControl
Subject: Re: [mediactrl] Going forward with media server control -
resend

>              +----------------------------------->|  XCON  |

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation.  All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in a writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding.  Thank you.

---

From: Eric Burger <[email-masked]>
Date: Wed, 13 Apr 2005 03:03:38 +0100 (BST)

Great!

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Chris
> Boulton
> Sent: Monday, April 11, 2005 4:41 AM
> To: Cullen Jennings; Roni Even; MixerControl
> Subject: RE: [mediactrl] Going forward with media server control -
> resend
> 
> 
> 
> 
>  
>                        XCON Protocol               +--------+
> > I really think that we should start this discussion - 
> especially when
> we
> > this with multiple AS potentially connecting to one MS.  
> The only way
> I
> > this communication is strictly prohibited.  Unless 
> otherwise expressly
> agreed
> Information contained in this e-mail and any attachments are 
> intended for the use of the addressee only, and may contain 
> confidential information of Ubiquity Software Corporation.  
> All unauthorized use, disclosure or distribution is strictly 
> prohibited.  If you are not the addressee, please notify the 
> sender immediately and destroy all copies of this email.  
> Unless otherwise expressly agreed in a writing signed by an 
> officer of Ubiquity Software Corporation, nothing in this 
> communication shall be deemed to be legally binding.  Thank you.
> 
> 
> Ubiquity Software does not control or endorse the content, 
> messages or information found in this mail list and it 
> specifically disclaims any liability with regard to these 
> communications.
> Ubiquity Software reserves the right the restrict access to 
> any communications in violation of the Terms and Conditions 
> of Use for this website or as otherwise deemed improper.
>