Subject: RE: [mediactrl] How to get this work into a WG

From: "Even, Roni" <[email-masked]>
Date: Mon, 22 May 2006 08:25:43 +0100

<span style='font-size:
12.0pt'>Hi Martin,

<span style='font-size:
12.0pt'>I reviewed draft-dolly-xcon-mediacntrlframe-01 and here are my
comments. My general view when writing this feedback is that we address the
requirements for the communication between the AS and MS and not only the
protocol. When we define the solution framework that is the place to say what is
done in the protocol and what will be done using other means. This is important
in order to have a gap analysis and find what the protocol need to address. 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>1. The draft should be renamed requirements draft and not framework, it
was agreed in Dallas,
see the meeting report. Here is part of it

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>"  Framework document will be renamed Requirements Document.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>- Scott: need a more detailed requirements document. Should include the
scope. Scott

<span style='font-size:
12.0pt'>  will have a shot at writing qualifiers for IVR and conferencing
to refine

<span style='font-size:
12.0pt'>  the requirements. It needs to explain why we need to do a
SIP-oriented

<span style='font-size:
12.0pt'>  media control protocol, as opposed to lower-level H.248-style
decomposition."

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>2.  In the overview you have a list of items that are out of scope
to this document. I think that all the items are in scope for the requirements
but they may be out of scope for the protocol since there may be other means to
achieve them. The document has the following items out of scope

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>Media session establishment – I think that there are requirements
for media session establishment, even your list has MCP-11. So there are
requirement but the framework may show the solution and mention that they will
be done by different means then the AS to MS protocol.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>Mechanism for MS to advertise its capabilities – I see two kinds
of capabilities one is functionality and the other is capacities. The requirement
to be able to advertise them is important and is needed see you requirement
MCP-8 and MCP-15

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>Ability to move an existing conference from the current MS to a
different one. - This is a specific required functionality that may be used by
applications servers, if it implies that there are requirements stemming from
the requirement then the requirements should be listed, the solution may not
require any new protocol.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>3. From my document I see the following requirements missing

<span style='font-size:
12.0pt'>From the general section: 4, 5, 7, 8, 9, 11, 14, 15, 18, 19, 20

<span style='font-size:
12.0pt'>From the announcement section: 1, 2, 3, 4. Also that announcement may
include voice, audio (like music), slides or video clips, maybe also Instant
messages.

<span style='font-size:
12.0pt'>From the media mixing section: 1-6 and 8

<span style='font-size:
12.0pt'>All the IVR section. BTW this will explain why we need simple and
complicated IVR mechanisms.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>4. Some comments on the requirements in your draft

<span style='font-size:
12.0pt'> MCP -04 The second sentence is not a requirement but a proposed
solution.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>MCP-07 What about session based IM, what about text for people with
disabilities.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>MCP-09 is very confusing it lists all the options is that a
requirement. My suggestion is to say that the solution MUST enable one control
channel between an AS and MS and may support multiple channels.

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>In MCP-14 change compatability to compatibility

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'>Thanks

<span style='font-size:
12.0pt'>Roni Even

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
12.0pt'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma> Dolly, Martin C,
ALABS [mailto:[email-masked]] 
Sent: Sunday, May 21, 2006 6:33 PM
To: Even, Roni; Chris Boulton;
Adnan Saleem; Cullen Jennings; [email-masked]
Cc: Burger, Eric
Subject: RE: [mediactrl] How to
get this work into a WG

<span style='font-size:
12.0pt'> 

<span
style='font-size:10.0pt;color:blue'>Roni,

<span style='font-size:
12.0pt'> 

<span
style='font-size:10.0pt;color:blue'>Requirements in this document are included
in the current framework document. As discuss, many times, if you feel that
some of the requirements in your document are not covered, then please
highlight those and they will be added.

<span style='font-size:
12.0pt'> 

<span
style='font-size:10.0pt;color:blue'>Cheers,

<span style='font-size:
12.0pt'> 

<span
style='font-size:10.0pt;color:blue'>Martin

<span style='font-size:
12.0pt'> 

<font size=3
face="Times New Roman">

<span
style='font-size:10.0pt;font-family:Tahoma;font-weight:bold'>From:<font
size=2 face=Tahoma>
[email-masked]
[mailto:[email-masked]] <span style='font-weight:
bold'>On Behalf Of Even, Roni
Sent: Sunday, May 21, 2006 8:49 AM
To: Chris Boulton; Adnan Saleem;
Cullen Jennings; [email-masked]
Cc: Burger, Eric
Subject: RE: [mediactrl] How to
get this work into a WG

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Hi

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>During the last meeting I mentioned the
requirement document I wrote when we started the work. It is attached here; I
thought it will be added to the list of document in 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'><a rel="nofollow"
href="http://flyingfox.cantata.com/i-d/mediactrl/">http://flyingfox.cantata.com/i-d/mediactrl/

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>BTW: I agree with Chris answers about the
work and want to mention that MSML and MSCML are not the only proprietary
protocols that support this interface. Polycom has its XML API that supports
this functionality and MS has proposed CCCP for the protocol.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>I think that the consensus was to define a
protocol that will be inline with the requirements and the framework and not to
point at some vendors implementations.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Of course we can leverage the knowledge
that was learnt by the manufacturers to create a good solution as fast as we can.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Regards

<span style='font-size:
10.0pt;font-family:Arial;color:navy'>Roni Even

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=3
face="Times New Roman">

<span style='font-size:10.0pt;
font-family:Tahoma;font-weight:bold'>From:<font size=2
face=Tahoma>
[email-masked]
[mailto:[email-masked]] <span style='font-weight:
bold'>On Behalf Of Chris Boulton
Sent: Tuesday, May 09, 2006 3:40
PM
To: Adnan Saleem; Cullen Jennings;
[email-masked]
Cc: Burger, Eric
Subject: RE: [mediactrl] How to
get this work into a WG

<span style='font-size:
12.0pt'> 

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<span
style='font-size:10.0pt'>Cullen,

I want to point out that we have rough consensus (imho) on the "control
framework" ID (<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt"
target="_blank">http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt),
from an architectural perspective and the direction this is going.

<span style='font-size:10.0pt;
font-family:Arial;color:navy;font-weight:bold;font-style:italic'>[Chris
Boulton] That’s really good to hear.

<font size=2
face="Times New Roman">However, there is no
consensus on the remaining IDs identified below.

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] I’m not sure consensus was at all
proposed – certainly not by me.  That’s jumping the gun a
little.  I was just pointing out that we have current examples of how
Control Packages are written in-line with the framework.

<span style='font-size:
10.0pt;font-family:Arial;color:navy'> 

<font size=2
face="Times New Roman">Convedia in particular
objects to the "extension" IDs listed below, covering IVR and
conference control.

<font size=3
face="Times New Roman"> 

<font size=2
face="Times New Roman">     
- (<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-0"
target="_blank"><a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-01.txt">http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-01.txt).

<font size=2
face="Times New Roman">     
- (<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-pack"
target="_blank"><a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-package-00.txt">http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-package-00.txt).

<font size=2
face="Times New Roman">     
- (<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-pa"
target="_blank"><a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-package-00.txt">http://www.ietf.org/internet-drafts/draft-boulton-conference-control-package-00.txt).

<font size=3
face="Times New Roman"> 

<font size=2
face="Times New Roman">The above <font
face="Times New Roman">new IDs essentially provide a subset
and duplication of the what MSML, and MSCML to a good extent, have already
provided for years.

<font size=3 color=navy
face="Times New Roman"> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>[Chris Boulton] Totally understand your position.  All
I will say is that:-

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>-<span style='font-size:7.0pt;
color:navy'>          <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>yes, you are correct in that
this does provide duplication of MSML and MSCML.  The intention was to use
and build on the experiences gained from such languages to provide a solution
that architecturally fits with the new Control Framework.

<font size=2
color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy'>-<span style='font-size:7.0pt;
color:navy'>          <font
size=2 color=navy face=Arial><span style='font-size:10.0pt;font-family:Arial;
color:navy;font-weight:bold;font-style:italic'>Yes it provides subsets of
functionality.  This again was the intention to provide a modular
approach.  We are thinking (and received quite a large amount of feedback
from media control group) from the agnostic point of view that not everyone wants
to implement a large scripting language for simple IVR interactions.  It
should be possible to select exactly what you need to fit your requirements.

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>If you have got any more detail on your technical objections
I think it would be great to have some discussion.

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>Best Regards,

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'>Chris.

<span
style='font-size:10.0pt;font-family:Arial;color:navy;font-weight:bold;
font-style:italic'> 

<font size=3
face="Times New Roman"> 

<font size=3
face="Times New Roman"> 

<st1:City
 w:st="on">Garland<font
size=2> / Adnan

<span
style='font-size:10.0pt'>-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On
Behalf Of Chris
Boulton
Sent: May 8, 2006 2:36 AM
To: Cullen Jennings; MixerControl
Cc: Burger, Eric
Subject: RE: [mediactrl] How to get this work into a WG

Hi Cullen (donning AD cap),

We are still very much actively discussing this work and have met at
every IETF since Paris
(I think) - including a Beer BOF and a Meal BOF
:-).

        A long time ago, we had talked about
asking the SpeachSC chairs
if 
        that WG might take on this work. Is
there still interest in
that? 
       
Very much so - we have been discussing this regularly and I think we had
hoped (Eric will confirm but I know he is snowed under at the moment) to
move towards IETF working group towards the end of this year/maybe early
next.

        PS - A short summary of the status
of where we are, what we
have, and 
        where various parties might want to
eventually get to might be
really 
        helpful for me.

We are at the point where we have a Control Framework which has been
discussed at length at previous meetings
(<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework"
target="_blank">http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework
-02.txt) which aims to fulfill the detail outlined in the Requirements
document
(<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-dolly-xcon-mediacntrlframe-01"
target="_blank">http://www.ietf.org/internet-drafts/draft-dolly-xcon-mediacntrlframe-01
.txt).  This is an agnostic approach that is not 'Media Server' specific
and aims to provide a core connection management system using SIP.

The authors of the Framework have also created a number of extensions to
the Control Framework that provides modules for achieving various levels
of Media Server Control.

- First extension provides simple IVR functionality
(<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-0"
target="_blank">http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-0
1.txt).

- There is an extension to the SIMPLE IVR functionality for the purpose
of using VXML
(<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-pack"
target="_blank">http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-pack
age-00.txt).

- This extensions provides conferencing capabilities
(<a rel="nofollow"
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-pa"
target="_blank">http://www.ietf.org/internet-drafts/draft-boulton-conference-control-pa
ckage-00.txt).

If you need anymore information then give me a shout.

Best Regards,

Chris.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
On Behalf Of Cullen
Jennings
Sent: 07 May 2006 16:11
To: MixerControl
Subject: [mediactrl] How to get this work into a WG

A long time ago, we had talked about asking the SpeachSC chairs if 
that WG might take on this work. Is there still interest in that? 
With my AD hat on, I have no idea what is the best way to do this yet 
but I am looking for input on what the next logical steps are with 
all the work that has been happing here.

Thanks, Cullen

PS - A short summary of the status of where we are, what we have, and 
where various parties might want to eventually get to might be really 
helpful for me.
--------------------------
Ubiquity Software does not control or endorse the content, messages or
information found in this mail list and it specifically disclaims any
liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any
communications in violation of the Terms and Conditions of Use for this
website or as otherwise deemed improper.

Information contained in this e-mail and any attachments are intended for the
use of the addressee only, and may contain confidential information of Ubiquity
Software Corporation.  All unauthorized use, disclosure or distribution is
strictly prohibited.  If you are not the addressee, please notify the
sender immediately and destroy all copies of this email.  Unless otherwise
expressly agreed in writing signed by an officer of Ubiquity Software
Corporation, nothing in this communication shall be deemed to be legally
binding.  Thank you.

--------------------------
Ubiquity Software does not control or endorse the content, messages or
information found in this mail list and it specifically disclaims any liability
with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications
in violation of the Terms and Conditions of Use for this website or as
otherwise deemed improper.

---

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Mon, 22 May 2006 20:18:22 +0100

<FONT face=Arial 
color=#0000ff size=2>Roni, Thanks, Martin

From: Even, Roni 
[mailto:[email-masked]] Sent: Monday, May 22, 2006 3:28 
AMTo: Dolly, Martin C, ALABS; Chris Boulton; Adnan Saleem; Cullen 
Jennings; [email-masked]: Burger, 
EricSubject: RE: [mediactrl] How to get this work into a 
WG

<SPAN 
style="FONT-SIZE: 12pt">Hi Martin,
<SPAN 
style="FONT-SIZE: 12pt">I reviewed draft-dolly-xcon-mediacntrlframe-01 and here 
are my comments. My general view when writing this feedback is that we address 
the requirements for the communication between the AS and MS and not only the 
protocol. When we define the solution framework that is the place to say what is 
done in the protocol and what will be done using other means. This is important 
in order to have a gap analysis and find what the protocol need to address. 

<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">1. The draft should be renamed requirements draft and 
not framework, it was agreed in <st1:place 
w:st="on">Dallas, see the meeting report. Here is part of 
it
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">"  Framework document will be renamed Requirements 
Document.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">- Scott: need a more detailed requirements document. 
Should include the scope. Scott
<SPAN 
style="FONT-SIZE: 12pt">  will have a shot at writing qualifiers for IVR 
and conferencing to refine
<SPAN 
style="FONT-SIZE: 12pt">  the requirements. It needs to explain why we need 
to do a SIP-oriented
<SPAN 
style="FONT-SIZE: 12pt">  media control protocol, as opposed to lower-level 
H.248-style decomposition."
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">2.  In the overview you have a list of items that 
are out of scope to this document. I think that all the items are in scope for 
the requirements but they may be out of scope for the protocol since there may 
be other means to achieve them. The document has the following items out of 
scope
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">Media session establishment – I think that there are 
requirements for media session establishment, even your list has MCP-11. So 
there are requirement but the framework may show the solution and mention that 
they will be done by different means then the AS to MS 
protocol.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">Mechanism for MS to advertise its capabilities – I see 
two kinds of capabilities one is functionality and the other is capacities. The 
requirement to be able to advertise them is important and is needed see you 
requirement MCP-8 and MCP-15
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">Ability to move an existing conference from the current 
MS to a different one. - This is a specific required functionality that may be 
used by applications servers, if it implies that there are requirements stemming 
from the requirement then the requirements should be listed, the solution may 
not require any new protocol.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">3. From my document I see the following requirements 
missing
<SPAN 
style="FONT-SIZE: 12pt">From the general section: 4, 5, 7, 8, 9, 11, 14, 15, 18, 
19, 20
<SPAN 
style="FONT-SIZE: 12pt">From the announcement section: 1, 2, 3, 4. Also that 
announcement may include voice, audio (like music), slides or video clips, maybe 
also Instant messages.
<SPAN 
style="FONT-SIZE: 12pt">From the media mixing section: 1-6 and 
8
<SPAN 
style="FONT-SIZE: 12pt">All the IVR section. BTW this will explain why we need 
simple and complicated IVR mechanisms.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">4. Some comments on the requirements in your 
draft
<SPAN 
style="FONT-SIZE: 12pt"> MCP -04 The second sentence is not a requirement 
but a proposed solution.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">MCP-07 What about session based IM, what about text for 
people with disabilities.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">MCP-09 is very confusing it lists all the options is 
that a requirement. My suggestion is to say that the solution MUST enable one 
control channel between an AS and MS and may support multiple 
channels.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">In MCP-14 change compatability to 
compatibility
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt">Thanks
<SPAN 
style="FONT-SIZE: 12pt">Roni Even
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<DIV 
style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">

<FONT 
face="Times New Roman" size=3>

<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
face=Tahoma size=2> Dolly, 
Martin C, ALABS [mailto:[email-masked]] <SPAN 
style="FONT-WEIGHT: bold">Sent: Sunday, May 21, 2006 6:33 
PMTo: Even, Roni; Chris 
Boulton; Adnan Saleem; Cullen Jennings; 
[email-masked]<SPAN 
style="FONT-WEIGHT: bold">Cc: Burger, Eric<SPAN 
style="FONT-WEIGHT: bold">Subject: RE: [mediactrl] How to get this 
work into a WG
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: blue">Roni,
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: blue">Requirements in this document are included 
in the current framework document. As discuss, many times, if you feel that some 
of the requirements in your document are not covered, then please highlight 
those and they will be added.
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: blue">Cheers,
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: blue">Martin
<SPAN 
style="FONT-SIZE: 12pt"> 
<FONT 
face="Times New Roman" size=3>

<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
face=Tahoma size=2> 
[email-masked] 
[mailto:[email-masked]] <SPAN 
style="FONT-WEIGHT: bold">On Behalf Of Even, Roni<SPAN 
style="FONT-WEIGHT: bold">Sent: Sunday, May 21, 2006 8:49 
AMTo: Chris Boulton; Adnan 
Saleem; Cullen Jennings; [email-masked]<SPAN 
style="FONT-WEIGHT: bold">Cc: Burger, Eric<SPAN 
style="FONT-WEIGHT: bold">Subject: RE: [mediactrl] How to get this 
work into a WG
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Hi
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">During the last meeting 
I mentioned the requirement document I wrote when we started the work. It is 
attached here; I thought it will be added to the list of document in 

<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"><A rel="nofollow" 
href="http://flyingfox.cantata.com/i-d/mediactrl/">http://flyingfox.cantata.com/i-d/mediactrl/ 

<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">BTW: I agree with Chris 
answers about the work and want to mention that MSML and MSCML are not the only 
proprietary protocols that support this interface. Polycom has its XML API that 
supports this functionality and MS has proposed CCCP for the 
protocol.
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">I think that the 
consensus was to define a protocol that will be inline with the requirements and 
the framework and not to point at some vendors 
implementations.
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Of course we can 
leverage the knowledge that was learnt by the manufacturers to create a good 
solution as fast as we can.
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Regards
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Roni 
Even
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<DIV 
style="BORDER-RIGHT: medium none; PADDING-RIGHT: 0cm; BORDER-TOP: medium none; PADDING-LEFT: 4pt; PADDING-BOTTOM: 0cm; BORDER-LEFT: blue 1.5pt solid; PADDING-TOP: 0cm; BORDER-BOTTOM: medium none">

<FONT 
face="Times New Roman" size=3>

<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:<FONT 
face=Tahoma size=2> 
[email-masked] 
[mailto:[email-masked]] <SPAN 
style="FONT-WEIGHT: bold">On Behalf Of Chris Boulton<SPAN 
style="FONT-WEIGHT: bold">Sent: Tuesday, May 09, 2006 3:40 
PMTo: Adnan Saleem; Cullen 
Jennings; [email-masked]<SPAN 
style="FONT-WEIGHT: bold">Cc: Burger, Eric<SPAN 
style="FONT-WEIGHT: bold">Subject: RE: [mediactrl] How to get this 
work into a WG
<SPAN 
style="FONT-SIZE: 12pt"> 
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-SIZE: 10pt">Cullen,I want to point out that we have rough 
consensus (imho) on the "control framework" ID (<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt" 
target=_blank>http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt), 
from an architectural perspective and the direction this is 
going.
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
Boulton] That’s really good to hear.

<FONT face="Times New Roman" 
size=2>However, there is no consensus on the 
remaining IDs identified below.
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
Boulton] I’m not sure consensus was at all proposed – certainly not by me.  
That’s jumping the gun a little.  I was just pointing out that we have 
current examples of how Control Packages are written in-line with the 
framework.
<SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"> 

<FONT face="Times New Roman" 
size=2>Convedia in particular objects to the 
"extension" IDs listed below, covering IVR and conference 
control.

<FONT face="Times New Roman" 
size=3> 

<FONT face="Times New Roman" 
size=2>      - (<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-0" 
target=_blank><A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-01.txt">http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-01.txt).

<FONT face="Times New Roman" 
size=2>      - (<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-pack" 
target=_blank><A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-package-00.txt">http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-package-00.txt).

<FONT face="Times New Roman" 
size=2>      - (<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-pa" 
target=_blank><A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-package-00.txt">http://www.ietf.org/internet-drafts/draft-boulton-conference-control-package-00.txt).

<FONT face="Times New Roman" 
size=3> 

<FONT face="Times New Roman" 
size=2>The above <FONT 
face="Times New Roman">new IDs essentially provide a subset 
and duplication of the what MSML, and MSCML to a good extent, have already 
provided for years.

<FONT face="Times New Roman" 
color=navy size=3><SPAN 
style="FONT-SIZE: 12pt; COLOR: navy"> 
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">[Chris 
Boulton] Totally understand your position.  All I will say is 
that:-
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<FONT 
face=Arial color=navy size=2><SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">-<FONT 
color=navy size=1><SPAN 
style="FONT-SIZE: 7pt; COLOR: navy">          
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">yes, 
you are correct in that this does provide duplication of MSML and MSCML.  
The intention was to use and build on the experiences gained from such languages 
to provide a solution that architecturally fits with the new Control 
Framework.
<FONT 
face=Arial color=navy size=2><SPAN 
style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">-<FONT 
color=navy size=1><SPAN 
style="FONT-SIZE: 7pt; COLOR: navy">          
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">Yes 
it provides subsets of functionality.  This again was the intention to 
provide a modular approach.  We are thinking (and received quite a large 
amount of feedback from media control group) from the agnostic point of view 
that not everyone wants to implement a large scripting language for simple IVR 
interactions.  It should be possible to select exactly what you need to fit 
your requirements.
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">If 
you have got any more detail on your technical objections I think it would be 
great to have some discussion.
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">Best 
Regards,
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial">Chris.
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<FONT face="Times New Roman" 
size=3> 

<FONT face="Times New Roman" 
size=3> 

<st1:City 
w:st="on"><SPAN 
style="FONT-SIZE: 10pt">Garland<FONT 
size=2> / Adnan
<SPAN 
style="FONT-SIZE: 10pt">-----Original Message-----From: 
[email-masked][<A rel="nofollow" 
href="mailto:[email-masked]">mailto:[email-masked]]On 
Behalf Of ChrisBoultonSent: May 8, 2006 2:36 AMTo: Cullen Jennings; 
MixerControlCc: Burger, EricSubject: RE: [mediactrl] How to get this 
work into a WGHi Cullen (donning AD cap),We are still very 
much actively discussing this work and have met atevery IETF since 
Paris (I think) 
- including a Beer BOF and a Meal 
BOF:-).        A long time ago, 
we had talked about asking the SpeachSC 
chairsif         that WG might 
take on this work. Is there still interest 
inthat?        Very much so 
- we have been discussing this regularly and I think we hadhoped (Eric will 
confirm but I know he is snowed under at the moment) tomove towards IETF 
working group towards the end of this year/maybe 
earlynext.        PS - A short 
summary of the status of where we are, what wehave, 
and         where various parties 
might want to eventually get to might 
bereally         helpful for 
me.We are at the point where we have a Control Framework which has 
beendiscussed at length at previous meetings(<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework" 
target=_blank>http://www.ietf.org/internet-drafts/draft-boulton-sip-control-framework-02.txt) 
which aims to fulfill the detail outlined in the Requirementsdocument(<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-dolly-xcon-mediacntrlframe-01" 
target=_blank>http://www.ietf.org/internet-drafts/draft-dolly-xcon-mediacntrlframe-01.txt).  
This is an agnostic approach that is not 'Media Server' specificand aims to 
provide a core connection management system using SIP.The authors of the 
Framework have also created a number of extensions tothe Control Framework 
that provides modules for achieving various levelsof Media Server 
Control.- First extension provides simple IVR functionality(<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-0" 
target=_blank>http://www.ietf.org/internet-drafts/draft-boulton-ivr-control-package-01.txt).- 
There is an extension to the SIMPLE IVR functionality for the purposeof 
using VXML(<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-pack" 
target=_blank>http://www.ietf.org/internet-drafts/draft-boulton-ivr-vxml-control-package-00.txt).- 
This extensions provides conferencing capabilities(<A rel="nofollow" 
href="http://www.ietf.org/internet-drafts/draft-boulton-conference-control-pa" 
target=_blank>http://www.ietf.org/internet-drafts/draft-boulton-conference-control-package-00.txt).If 
you need anymore information then give me a shout.Best 
Regards,Chris.-----Original Message-----From: 
[email-masked][<A rel="nofollow" 
href="mailto:[email-masked]">mailto:[email-masked]] 
On Behalf Of Cullen<st1:City 
w:st="on">JenningsSent: 07 May 2006 16:11To: 
MixerControlSubject: [mediactrl] How to get this work into a WGA 
long time ago, we had talked about asking the SpeachSC chairs if that 
WG might take on this work. Is there still interest in that? With my AD 
hat on, I have no idea what is the best way to do this yet but I am 
looking for input on what the next logical steps are with all the work 
that has been happing here.Thanks, CullenPS - A short summary of 
the status of where we are, what we have, and where various parties 
might want to eventually get to might be really helpful for 
me.--------------------------Ubiquity Software does not control or 
endorse the content, messages orinformation found in this mail list and it 
specifically disclaims anyliability with regard to these 
communications.Ubiquity Software reserves the right the restrict access to 
anycommunications in violation of the Terms and Conditions of Use for 
thiswebsite or as otherwise deemed improper.Information 
contained in this e-mail and any attachments are intended for the use of the 
addressee only, and may contain confidential information of Ubiquity Software 
Corporation.  All unauthorized use, disclosure or distribution is strictly 
prohibited.  If you are not the addressee, please notify the sender 
immediately and destroy all copies of this email.  Unless otherwise 
expressly agreed in writing signed by an officer of Ubiquity Software 
Corporation, nothing in this communication shall be deemed to be legally 
binding.  Thank you.--------------------------Ubiquity 
Software does not control or endorse the content, messages or information found 
in this mail list and it specifically disclaims any liability with regard to 
these communications.Ubiquity Software reserves the right the restrict 
access to any communications in violation of the Terms and Conditions of Use for 
this website or as otherwise deemed 
improper.