Subject: RE: [MEDIACTRL] Endpoint Signaling

From: "Braudes, Robert \(Bob\)" <[email-masked]>
Date: Tue, 14 Nov 2006 05:29:01 -0500

Hi Eric,

I also agree, and if it turns out that we need to modify any protocols going directly to the endpoint we should submit it to the appropriate working group (e.g. mmusic, avt,...) rather than addressing it in mediactrl.

Bob

-----Original Message-----
From: Lorenzo Miniero [mailto:[email-masked]] 
Sent: Tuesday, November 14, 2006 9:55 AM
To: [email-masked]
Subject: Re: [MEDIACTRL] Endpoint Signaling

Hi Eric,

> As I was revising the charter, I stumbled upon something related to 
> Roni's and Lorenzo's discussion on BFCP that relates directly to Dave 
> Oran's concern.  Namely,
>
>   Shall mediactrl entertain signaling directly between the
>   user endpoint and the media server?
>
> I would offer the answer is "no."  That restriction means that if we 
> receive floor control commands, they will come from the application server.
> Likewise, while the media server will most likely do VCR controls (or 
> trick-play controls, i.e., FF, REW, Pause), they will not be directly 
> from the end-user.
>   

I absolutely agree on that, since it would actually give each 'application' in the AS more control upon the users and resources it is managing.

> Of course, there is nothing to prevent a user endpoint from looking 
> like an application server, nor is there anything to prevent us from 
> deciding that if we do floor control, it will look like BFCP.  
> However, I would like to clarify that we will NOT be working on a 
> user-end-point to media server protocol in mediactrl.
>   

I agree, with its features the mediactrl is of much more interest to complex applications, that the end-points would use and refer to to take advantage of these features.

> The language I have put into the most recent draft charter reads as follows:
>
>    The expected deployment architecture for a media server
>    in the context of mediactrl is as a server to application
>    servers.  It is not expected that end user endpoints will
>    have a direct signaling relationship to the media server.
>
>
> Any dissent?  Speak now before I update the charter.
>   

Ok for me.

Cheers,
Lorenzo

--
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

-- 
Il messaggio e' stato analizzato alla ricerca di virus o
contenuti pericolosi da MailScanner, ed e'
risultato non infetto.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl

---

From: <[email-masked]>
Date: Tue, 14 Nov 2006 09:52:35 -0500

Likewise, I agree (strongly) with the position as offered by Eric below.

cheers,

Gary

-----Original Message-----
From: Braudes, Robert (Bob) [mailto:[email-masked]] 
Sent: Tuesday, November 14, 2006 5:29 AM
To: Lorenzo Miniero; [email-masked]
Subject: RE: [MEDIACTRL] Endpoint Signaling

Hi Eric,

Bob

-----Original Message-----
From: Lorenzo Miniero [mailto:[email-masked]] 
Sent: Tuesday, November 14, 2006 9:55 AM
To: [email-masked]
Subject: Re: [MEDIACTRL] Endpoint Signaling

Hi Eric,

Ok for me.

Cheers,
Lorenzo