Subject: RE: [MEDIACTRL] Updates to Charter

From: "Chris Boulton" <[email-masked]>
Date: Mon, 4 Dec 2006 09:38:43 -0000

2) Mention we will work with AVT and MMUSIC for appropriate topics

[Chris Boulton] Probably SIP as well (e.g. new headers etc in Control
Framework).

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation.  All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding.  Thank you.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Mon, 4 Dec 2006 12:36:47 +0100

I did send the following mail to the list before the BOF.

I think it did encompass Chris's concern.

Keith

From:	[email-masked] on behalf of Drage,
Keith (Keith) [[email-masked]]
Sent:	05 October 2006 21:25
To:	Eric Burger; IETF mediactrl
Subject:	RE: [mediactrl] Proposed Charter

There is a paragraph in the P2PSIP draft charter:

"The work planned for the P2PSIP working group is distinct from, but
requires close participation with other IETF WGs, particularly SIP,
SIPPING, SIMPLE, BEHAVE and MMUSIC. The group cannot modify the baseline
SIP behavior, define a new version of SIP, or attempt to produce a
parallel protocol for session establishment. If the group determines
that any capabilities requiring an extension to SIP are needed, the
group will seek to define such extensions within the SIP working group
using the SIP change process (RFC 3427).
Similarly, existing tools developed in the BEHAVE and MMUSIC groups will
be used for NAT traversal, with extensions or changes desired to support
P2PSIP created in these groups."

I would suggest that we would have something along the same lines in any
draft media-control charter. (It may well be worth a scan of the P2PSIP
charter for other issues that might be included - because I think that
is a well written document).

Regards

Keith

> -----Original Message-----
> From: Chris Boulton [mailto:[email-masked]] 
> Sent: 04 December 2006 09:39
> To: Cullen Jennings; Media Control
> Subject: RE: [MEDIACTRL] Updates to Charter
> 
> 
> [Chris Boulton] Probably SIP as well (e.g. new headers etc in 
> Control Framework).
> 
> 
> 
> Information contained in this e-mail and any attachments are 
> intended for the use of the addressee only, and may contain 
> confidential information of Ubiquity Software Corporation.  
> All unauthorized use, disclosure or distribution is strictly 
> prohibited.  If you are not the addressee, please notify the 
> sender immediately and destroy all copies of this email.  
> Unless otherwise expressly agreed in writing signed by an 
> officer of Ubiquity Software Corporation, nothing in this 
> communication shall be deemed to be legally binding.  Thank you.
> 
>

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 04 Dec 2006 12:53:40 +0100

Hi Keith,

> is a well written document).

I'm not sure I'd like a line as "The group cannot [..] attempt to 
produce a parallel protocol for session establishment" in the charter. 
While it's OK for P2PSIP (since it's still SIP), in MediaCtrl it would 
mean a decision has already been taken to use SIP (and/or extensions to 
it) as protocol between the AS and the MS. Is it actually so?

Regards,
Lorenzo

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

-- 
Il messaggio e' stato analizzato alla ricerca di virus o
contenuti pericolosi da MailScanner, ed e'
risultato non infetto.

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Mon, 4 Dec 2006 13:04:26 +0100

Note that I did expect the words are an extract from the P2PSIP charter, and they will need some tailoring to fit mediacontrol.

However I think that allowing mediacontrol to go out and develop a session control protocol per se will need considerably more discussion on the charter. I have always assumed it was a SIP adjunct.

Keith 

> From: Lorenzo Miniero [mailto:[email-masked]] 
> Sent: 04 December 2006 11:54
> To: [email-masked]
> Subject: Re: [MEDIACTRL] Updates to Charter
> 
> Hi Keith,
> 
> > SIPPING, SIMPLE, BEHAVE and MMUSIC. The group cannot modify the 
> > baseline SIP behavior, define a new version of SIP, or attempt to 
> > produce a parallel protocol for session establishment. If the group 
> > determines that any capabilities requiring an extension to SIP are 
> > needed, the group will seek to define such extensions 
> within the SIP 
> > working group using the SIP change process (RFC 3427).
> > Similarly, existing tools developed in the BEHAVE and MMUSIC groups 
> > will be used for NAT traversal, with extensions or changes 
> desired to 
> > support P2PSIP created in these groups."
> >
> > I would suggest that we would have something along the same 
> lines in 
> > any draft media-control charter. (It may well be worth a 
> scan of the 
> > P2PSIP charter for other issues that might be included - because I 
> > think that is a well written document).
> >
> > Regards
> >
> > Keith
> >   
> 
> 
> I'm not sure I'd like a line as "The group cannot [..] 
> attempt to produce a parallel protocol for session 
> establishment" in the charter. 
> While it's OK for P2PSIP (since it's still SIP), in MediaCtrl 
> it would mean a decision has already been taken to use SIP 
> (and/or extensions to
> Dipartimento di Informatica e Sistemistica Università degli 
> Studi di Napoli "Federico II"

---

From: "Even, Roni" <[email-masked]>
Date: Mon, 4 Dec 2006 14:09:31 +0200

The motivation for this work was to define the control protocol between the AS and MS taking into account that the AS and MS will have SIP stacks for session establishments between the terminals and the AS or MS anyhow, so we can leverage SIP for establishing the control connection between the AS and MS.
Roni Even

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Monday, December 04, 2006 2:04 PM
> To: Lorenzo Miniero; [email-masked]
> Note that I did expect the words are an extract from the P2PSIP charter,
> and they will need some tailoring to fit mediacontrol.
> 
> However I think that allowing mediacontrol to go out and develop a session
> control protocol per se will need considerably more discussion on the
> charter. I have always assumed it was a SIP adjunct.
> 
> Keith
> 
> **************************************************************************
> **********
> This footnote confirms that this email message has been scanned by
> PineApp Mail-SeCure for the presence of malicious code, vandals & computer
> viruses.
> **************************************************************************
> **********
> 
>

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 4 Dec 2006 04:54:53 -0800

Yes - this is the sort of thing I was thinking of (and agree with  
Chriss too).

On Dec 4, 2006, at 3:36 AM, Drage, Keith ((Keith)) wrote:

> baseline
> will

---

From: Eric Burger <[email-masked]>
Date: Wed, 06 Dec 2006 17:16:45 -0500

Read the charter:

Last line:
"If the work group requires extensions to SIP, the work group will forward
those extensions to the SIP work group for consideration and refinement."

On 12/4/06 4:38 AM, "Chris Boulton" <[email-masked]> wrote:

> Information contained in this e-mail and any attachments are intended for the
> use of the addressee only, and may contain confidential information of
> Ubiquity Software Corporation.  All unauthorized use, disclosure or
> distribution is strictly prohibited.  If you are not the addressee, please
> notify the sender immediately and destroy all copies of this email.  Unless
> otherwise expressly agreed in writing signed by an officer of Ubiquity
> Software Corporation, nothing in this communication shall be deemed to be
> legally binding.  Thank you.
> 
>