Subject: [MEDIACTRL] FW: I-D ACTION:draft-boulton-mmusic-sdp-control-package-attribute-00.txt

From: "Chris Boulton" <[email-masked]>
Date: Wed, 14 Nov 2007 09:18:09 -0000

All,

As discussed at length on the MEDIACTRL mailing list, I have submitted a
draft on using an SDP attribute as a hint to Control Packages that can
potentially be used in a Control Framework session (submitted to
MMUSIC).  It's a '00' so it's a bit rough around the edges, take a look
and let me know what you think.

Chris.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 13 November 2007 19:15
To: [email-masked]
Subject: I-D
ACTION:draft-boulton-mmusic-sdp-control-package-attribute-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: A Session Description Protocol (SDP) Control
Package Attribute
	Author(s)	: C. Boulton
	Filename	:
draft-boulton-mmusic-sdp-control-package-attribute-00.txt
	Pages		: 13
	Date		: 2007-11-13
	
   This document defines a new Session Description Protocol (SDP) media-
   level attribute: "ctrl-package".  The "ctrl-package" attribute
   conveys details of the SIP Control Framework extension packages that
   are supported by a client participating in an offer/answer exchange.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-boulton-mmusic-sdp-control-pac
kage-attribute-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-boulton-mmusic-sdp-control-package-attribute-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-boulton-mmusic-sdp-control-package-attribute-00.t
xt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Lorenzo Miniero <[email-masked]>
Date: Wed, 14 Nov 2007 11:30:58 +0100

Hi Chris,

I think the draft is fine. The only doubt I have is about the provided example:

    [..]
    a=ctrl-package:basic-ivr

where is "basic-ivr" coming from? If precise info about packages is to come from
packages themselves, then I think this line would better look like:

    a=ctrl-package:msc-basic-ivr/1.0

that is, exactly as it would then subsequently appear in SYNCH negotiations.
Otherwise, I think the draft only needs some clarifications upon how packages
are addressed, and then it'll be perfectly ok.

Cheers,
Lorenzo

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

> implementation to automatically retrieve the ASCII version of the

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 14 Nov 2007 10:58:32 -0000

Fair point.  It will be updated in the next version - hopefully with an official WG token :-).

Thanks.

Chris.

-----Original Message-----
From: Lorenzo Miniero [mailto:[email-masked]] 
Sent: 14 November 2007 10:31
To: Chris Boulton
Cc: [email-masked]
Subject: Re: [MEDIACTRL] FW: I-D ACTION:draft-boulton-mmusic-sdp-control-package-attribute-00.txt

Hi Chris,

    [..]
    a=ctrl-package:basic-ivr

Cheers,
Lorenzo

---

From: Xiao Wang <[email-masked]>
Date: Fri, 16 Nov 2007 10:34:06 +0800

Hi, Chris
	I'm glad to read this draft. You provide a method to negotiate
control packages by SDP, and define the SDP attribute of control packages. I
think you maybe missing some handle about UAC and UAS.
1、Before sending SDP offer, how does UAC know which control packages UAS
supports;
2、If UAC wish some control packages but UAS can not support all or part,
what to do by UAC.
For example, UAC send SDP offer containing control packages A, B, C, UAS
return SDP answer containing control packages B,C.

Xiao
> From: Chris Boulton [mailto:[email-masked]]
> Sent: Wednesday, November 14, 2007 5:18 PM
> To: [email-masked]
> Subject: [MEDIACTRL] FW:
> I-DACTION:draft-boulton-mmusic-sdp-control-package-attribute-00.txt
>
> All,
>

---

From: "Chris Boulton" <[email-masked]>
Date: Fri, 16 Nov 2007 10:22:18 -0000

Hi, Chris

[Chris Boulton] This is out of the scope of this document + out of scope of the core SIP Control Framework.  We currently have an MRB draft which I am working on (http://www.ietf.org/internet-drafts/draft-boulton-mediactrl-mrb-00.txt) and I can also see potential for other mechanisms to discover package support.

[Chris Boulton] That is the purpose of this attribute.  A UAC might say 'hey - the UAS can't support A but lets carry on' OR it might say 'I can't continue without A so lets call so lets give up'.  This doc is intended to give both sides a hint as to what it initially supported so that they can make implementation specific choices.

Chris.

Xiao

---

From: Xiao Wang <[email-masked]>
Date: Mon, 19 Nov 2007 10:31:10 +0800

inline

Xiao

> Sent: Friday, November 16, 2007 6:22 PM
> To: Xiao Wang
> Cc: [email-masked]
> Subject: RE: [MEDIACTRL] FW:
> [Chris Boulton] This is out of the scope of this document + out of scope
of
> the core SIP Control Framework.  We currently have an MRB draft which I am
> working on
> (http://www.ietf.org/internet-drafts/draft-boulton-mediactrl-mrb-00.txt)
> and I can also see potential for other mechanisms to discover package
support.
[Xiao Wang]OK, if you give some hints in this draft that the mechanisms of
discovering package can be
find in mrb draft, I think it will be better.

> [Chris Boulton] That is the purpose of this attribute.  A UAC might say
'hey
> - the UAS can't support A but lets carry on' OR it might say 'I can't
continue
> without A so lets call so lets give up'.  This doc is intended to give
both
> sides a hint as to what it initially supported so that they can make
> implementation specific choices.
>
[Xiao Wang]As you said, the mrb can support to discover package, so I think
whether the mrb can have
the ability to find which server supports A package and which server
supports B package, the mrb can combine
the two servers to the UAC, so the UAC will not give up call.