Subject: [MEDIACTRL] Java API for Media Server Control (JSR309)

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 2 Nov 2007 14:26:55 +0000

See below for updated information on a proposed Java API for media control.

The chairs may want to consider some sort of liaison between this WG and the JSR activity (although there is an overlap of individuals on this WG and the JSR Expert Group).

Scott

The Early Draft Review Specification for JSR 309 Media Server Control API
is now available for Review at

http://jcp.org/aboutJava/communityprocess/edr/jsr309/index.html

This JSR defines an API for the generic Media Server Control. Modern IP and SIP based Media Servers are designed to perform various smart functions with media streams. Most of the Media Servers are also designed to act as an MRF (Media Resource Function) in 3G and IMS environments.
Typical non-exhaustive functions provided by the Media Server would include IVR, Conferencing, Speech Recognition Services, TTS (text to speech) Services, etc.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "MUNSON, GARY A (GARY A)" <[email-masked]>
Date: Mon, 5 Nov 2007 17:10:49 -0500

Hi Scott,

For the education-challenged such as myself, is this API internal to the
Application Server, and relies on some other protocols (such as what
Mediactrl will specify) for the external AS-MS control communication?
That seems to be what the diagram in the .pdf file on Core-rationale
seems to indicate.

Thanks.

Gary

-----Original Message-----
From: McGlashan, Scott [mailto:[email-masked]] 
Sent: Friday, November 02, 2007 10:27 AM
To: [email-masked]
Subject: [MEDIACTRL] Java API for Media Server Control (JSR309)

See below for updated information on a proposed Java API for media
control.

The chairs may want to consider some sort of liaison between this WG and
the JSR activity (although there is an overlap of individuals on this WG
and the JSR Expert Group).

Scott

The Early Draft Review Specification for JSR 309 Media Server Control
API
is now available for Review at

This JSR defines an API for the generic Media Server Control. Modern IP
and SIP based Media Servers are designed to perform various smart
functions with media streams. Most of the Media Servers are also
designed to act as an MRF (Media Resource Function) in 3G and IMS
environments.
Typical non-exhaustive functions provided by the Media Server would
include IVR, Conferencing, Speech Recognition Services, TTS (text to
speech) Services, etc.

---

From: "McGlashan, Scott" <[email-masked]>
Date: Mon, 5 Nov 2007 23:41:05 +0000

Hi Gary,

Exactly right: JSR 309 does not define a protocol itself, only the Java API. So it needs a protocol - like MediaCtrl - when the AS and MS are distributed and need to communicate over a standardized protocol. It still remains to be seen if we make JSR 309 and the mediaCtrl framework and packages work together, but it seems like a good idea.

Scott

-----Original Message-----
From: MUNSON, GARY A (GARY A) [mailto:[email-masked]]
Sent: Monday, November 05, 2007 23:11
To: McGlashan, Scott; [email-masked]
Subject: RE: [MEDIACTRL] Java API for Media Server Control (JSR309)

Hi Scott,

For the education-challenged such as myself, is this API internal to the Application Server, and relies on some other protocols (such as what Mediactrl will specify) for the external AS-MS control communication?
That seems to be what the diagram in the .pdf file on Core-rationale seems to indicate.

Thanks.

Gary

-----Original Message-----
From: McGlashan, Scott [mailto:[email-masked]]
Sent: Friday, November 02, 2007 10:27 AM
To: [email-masked]
Subject: [MEDIACTRL] Java API for Media Server Control (JSR309)

Scott

The Early Draft Review Specification for JSR 309 Media Server Control API is now available for Review at

This JSR defines an API for the generic Media Server Control. Modern IP and SIP based Media Servers are designed to perform various smart functions with media streams. Most of the Media Servers are also designed to act as an MRF (Media Resource Function) in 3G and IMS environments.
Typical non-exhaustive functions provided by the Media Server would include IVR, Conferencing, Speech Recognition Services, TTS (text to
speech) Services, etc.

---

From: "Krishna Prasad Kalluri" <[email-masked]>
Date: Tue, 6 Nov 2007 07:47:58 +0100

Hi Gary,

Your understanding is correct.
The purpose of the API is protocol agnostic between AS & MS. The API users (application developers) need not worry about the protocols used between AS and MS communication.

But in the JSR-309-documentation.pdf there was description about DTMF or VFU received in SIP-INFO. So it means the usage of MSCML  between AS & MS was assumed. As this API purpose to be protocol agnostic its better to keep the examples generic and show how to inject the DTMF information received from MS into Media group

/Krishna

-----Original Message-----
From: MUNSON, GARY A (GARY A) [mailto:[email-masked]]
Sent: Mon 2007-11-05 23:10
To: McGlashan, Scott; [email-masked]
Subject: RE: [MEDIACTRL] Java API for Media Server Control (JSR309)
 
Hi Scott,

Thanks.

Gary

-----Original Message-----
From: McGlashan, Scott [mailto:[email-masked]] 
Sent: Friday, November 02, 2007 10:27 AM
To: [email-masked]
Subject: [MEDIACTRL] Java API for Media Server Control (JSR309)

Scott

---

From: Diego B <[email-masked]>
Date: Tue, 06 Nov 2007 12:54:12 +0200

Hi;
One of our interest in both groups is the ability to provide
a JSR 309 Driver on top of MediaCTL protocol.
This way we can provide a JSR 309 driver that works with any media 
server implementing MediaCTRL,
not depending on the media server providing a specific JSR 309 driver.
So the best thing is to monitor both WG and try to synchronize efforts, 
at least on the
common issues: IVR and Conference packages / Core objects.
The ideal thing will be to have a perfect matching between, for 
example,  the IVR ( basic and advanced ) packages in
MediaCTRL and the IVR objects defined in JSR 309.

Several members from the IVR design team are also in the JSR 309 expert 
group, I believe
a liaison between the activities is a good idea to at least be 
synchronized on each group work.

Regards
Diego B

---

From: "Brandt, Marc (OpenCall tech & stds)" <[email-masked]>
Date: Mon, 12 Nov 2007 21:50:47 +0000

We wanted to correct the perception that DTMF or SIP-INFO would actually be related to a specific media control protocol like MSCML. It is actually not the case, the point here is about the transport of media related events over SIP between the UA and the AS, not at the AS-MS level. The JSR 309 API is designed so that it copes with this practice which is in the real world some times used. I think there are RFCs and recent drafts talking about DTMF related over SIP (and SIP event packages) .

Although this is not a practice that always gets good press in IETF (transport over SIP), that is something JSR 309 wanted to consider and leverage as there are other examples of media related events that are not passed on the RTP flow but still need to be understood at the MS level, hence hiding the variety of protocols underneath.

I think this should deserve joint attention from both groups and maybe clarify the needs and impacts on the mediactrl protocol level as well so that a better solution is defined. But again this is also about how UAs communicate with AS that we have to cope with.

Marc
JSR 309 co-spec lead

-----Original Message-----
From: Krishna Prasad Kalluri [mailto:[email-masked]]
Sent: Tuesday, November 06, 2007 7:48 AM
To: MUNSON, GARY A (GARY A); McGlashan, Scott; [email-masked]
Subject: RE: [MEDIACTRL] Java API for Media Server Control (JSR309)

Hi Gary,

/Krishna

-----Original Message-----
From: MUNSON, GARY A (GARY A) [mailto:[email-masked]]
Sent: Mon 2007-11-05 23:10
To: McGlashan, Scott; [email-masked]
Subject: RE: [MEDIACTRL] Java API for Media Server Control (JSR309)

Hi Scott,

Thanks.

Gary

-----Original Message-----
From: McGlashan, Scott [mailto:[email-masked]]
Sent: Friday, November 02, 2007 10:27 AM
To: [email-masked]
Subject: [MEDIACTRL] Java API for Media Server Control (JSR309)

Scott

---

From: Eric Burger <[email-masked]>
Date: Sun, 25 Nov 2007 15:01:14 -0800

I have discussed the idea of a liaison between JSR 309 and mediactrl with
the spec leads of JSR 309.

The participants in JSR 309 and mediactrl are much the same.  At this point
in time the directions of JSR 309 and mediactrl have not diverged.  Thus,
the IETF mediactrl WG chairs and JCP JSR 309 specification leads decided
that this is not the time to submit a formal liaison between the two
organizations.

If you personally feel the two groups are diverging or have other concerns
that would indicate the necessity of submitting a formal liaison between the
JCP and IETF, please contact the chairs directly with your concerns.

On 11/2/07 9:26 AM, "McGlashan, Scott" <[email-masked]> wrote:

> The chairs may want to consider some sort of liaison between this WG and the
> JSR activity (although there is an overlap of individuals on this WG and the
> JSR Expert Group).
> 
> Scott
> 
> 
> This JSR defines an API for the generic Media Server Control. Modern IP and
> SIP based Media Servers are designed to perform various smart functions with
> media streams. Most of the Media Servers are also designed to act as an MRF
> (Media Resource Function) in 3G and IMS environments.
> Typical non-exhaustive functions provided by the Media Server would include
> IVR, Conferencing, Speech Recognition Services, TTS (text to speech) Services,
> etc.
> 
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.