Subject: [MEDIACTRL] Using SRGS in IVR draft

From: Spencer Dawkins <[email-masked]>
Date: Tue, 29 Jan 2008 14:13:33 -0600

Eric and I are hearing that the design team thinks their work on IVR is 
almost complete, and we have an opportunity to finish one discussion point 
and help them get the next revision out quickly...

KPML and SRGS - is anybody actually using SRGS in IVR systems *for DTMF*, or 
are people just talking about something that could be done?

Thanks,

Spencer, as co-chair 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Dan York <[email-masked]>
Date: Tue, 29 Jan 2008 20:55:50 -0500

Spencer,

We are aware that some of our customers heavily use SRGS for DTMF.   
Is the discussion about removing support for SRGS from the Basic IVR  
draft?

Regards,
Dan

On Jan 29, 2008, at 3:13 PM, Spencer Dawkins wrote:

> Eric and I are hearing that the design team thinks their work on  
> IVR is almost complete, and we have an opportunity to finish one  
> discussion point and help them get the next revision out quickly...
>
> KPML and SRGS - is anybody actually using SRGS in IVR systems *for  
> DTMF*, or are people just talking about something that could be done?
>
> Thanks,
>
> Spencer, as co-chair

-- 
Dan York, CISSP, Director of Emerging Communication Technology
Office of the CTO    Voxeo Corporation     [email-masked]
Phone: +1-407-455-5859  Skype: danyork  http://www.voxeo.com
Blogs: http://blogs.voxeo.com  http://www.disruptivetelephony.com

Bring your web applications to the phone.
Find out how at http://evolution.voxeo.com

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 29 Jan 2008 23:21:03 -0600

Hi, Dan,

I didn't mean to give the impression that any action was imminent - Eric and I are just making sure whether people are actually using both KPML and SRGS for DTMF IVR work.

Thanks,

Spencer
  ----- Original Message ----- 
  From: Dan York 
  To: Spencer Dawkins 
  Cc: [email-masked] 
  Sent: Tuesday, January 29, 2008 7:55 PM
  Subject: Re: [MEDIACTRL] Using SRGS in IVR draft

  Spencer,

  We are aware that some of our customers heavily use SRGS for DTMF.  Is the discussion about removing support for SRGS from the Basic IVR draft?

  Regards,
  Dan

    Eric and I are hearing that the design team thinks their work on IVR is almost complete, and we have an opportunity to finish one discussion point and help them get the next revision out quickly...

    KPML and SRGS - is anybody actually using SRGS in IVR systems *for DTMF*, or are people just talking about something that could be done?

    Thanks,

    Spencer, as co-chair

---

From: "McGlashan, Scott" <[email-masked]>
Date: Wed, 30 Jan 2008 10:45:26 +0000

We are definitely using SRGS for DTMF. It is also the required format for JSR 309.

The questions the design team is looking at are:

(a) should we have one custom DTMF grammar format which compliant implementations of the basic IVR package must support?

(b) if yes to (a), what format should be manadatory?

The current version of the package allows a custom DTMF grammar, but does not mandate any format. The editors note says:

 [Editors note: The format of the custom DTMF grammar is not yet defined. Possibilities include: [SRGS] <file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#SRGS> [H.248.1] <file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#H.248.1>  and [RFC4730]<file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#RFC4730>. If more than one format is permitted, then an additional input parameter "grammartype" would indicate the format used in the grammar parameter.]

If we were to mandate a format, there seems to be two major candidates, each with pros and cons (both are supported in the field):

1. SRGS: powerful format supporting both DTMF and speech input, used in VoiceXML and other standards. This allows developers to use the same DTMF format consistently in the base package, the VoiceXML package, ASR package. etc. The downside is that SRGS does support long press and double press features.

2. KPML DTMF format: basically H248.1 DRegex format with some fixes. This format is simpler and targeted specifically at DTMF and supports long and double key presses. On the downside, it doesn't apply to speech formats, not used in VoiceXML and would require developers to learn 2 formats, and platforms to support 2 formats, for speech and VoiceXML usage.

I would like to get more input from the group on these questions before updating the spec - should we mandate one format and, if so, which one?

thanks

Scott

________________________________
From: Spencer Dawkins [mailto:[email-masked]]
Sent: Wednesday, January 30, 2008 06:21
To: Dan York
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Using SRGS in IVR draft

Hi, Dan,

Thanks,

Spencer
----- Original Message -----
From: Dan York<mailto:[email-masked]>
To: Spencer Dawkins<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Sent: Tuesday, January 29, 2008 7:55 PM
Subject: Re: [MEDIACTRL] Using SRGS in IVR draft

Spencer,

Regards,
Dan

Thanks,

Spencer, as co-chair

--
Dan York, CISSP, Director of Emerging Communication Technology
Office of the CTO    Voxeo Corporation     [email-masked]<mailto:[email-masked]>
Phone: +1-407-455-5859  Skype: danyork  http://www.voxeo.com
Blogs: http://blogs.voxeo.com  http://www.disruptivetelephony.com

---

From: [email-masked]
Date: Wed, 30 Jan 2008 12:29:15 +0100

I think that (a) has to be supported. As to (b), if (and only if) we  
have to make something mandatory, I would definitely go for SRGS.

Simon

Quoting "McGlashan, Scott" <[email-masked]>:

> (a) should we have one custom DTMF grammar format which compliant   
> implementations of the basic IVR package must support?
>
> The current version of the package allows a custom DTMF grammar, but  
>  does not mandate any format. The editors note says:
>
>  [Editors note: The format of the custom DTMF grammar is not yet   
> defined. Possibilities include: [SRGS]   
> <file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#SRGS> [H.248.1] <file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#H.248.1>  and [RFC4730]<file:///C:/smcglashan/ietf/control/basic-ivr/releases/draft-boulton-ivr-control-package-05.html#RFC4730>. If more than one format is permitted, then an additional input parameter "grammartype" would indicate the format used in the grammar   
> parameter.]
>
> If we were to mandate a format, there seems to be two major   
> candidates, each with pros and cons (both are supported in the field):
>
> 1. SRGS: powerful format supporting both DTMF and speech input, used  
>  in VoiceXML and other standards. This allows developers to use the   
> same DTMF format consistently in the base package, the VoiceXML   
> package, ASR package. etc. The downside is that SRGS does support   
> long press and double press features.
>
> 2. KPML DTMF format: basically H248.1 DRegex format with some fixes.  
>  This format is simpler and targeted specifically at DTMF and   
> supports long and double key presses. On the downside, it doesn't   
> apply to speech formats, not used in VoiceXML and would require   
> developers to learn 2 formats, and platforms to support 2 formats,   
> for speech and VoiceXML usage.
>
> I would like to get more input from the group on these questions   
> before updating the spec - should we mandate one format and, if so,   
> which one?
>
> thanks
>
> Scott
>
>
>
> I didn't mean to give the impression that any action was imminent -   
> Eric and I are just making sure whether people are actually using   
> both KPML and SRGS for DTMF IVR work.
>
> Thanks,
>
> Spencer
> Eric and I are hearing that the design team thinks their work on IVR  
>  is almost complete, and we have an opportunity to finish one   

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Dan York <[email-masked]>
Date: Wed, 30 Jan 2008 08:45:12 -0500

Scott,

Thank you for the great explanation.  Just to be clear I believe you  
meant in #1 below that SRGS does NOT support long and double press  
features, correct?

When I asked my (Voxeo) colleague Dan Burnett about this, he  
responded that his preference would be:

- to mandate support for SRGS,
- to permit support for KPML DTMF, and
- to work within W3C to extend SRGS to provide support for long and  
double keypresses.

and added that he would be willing to help push these SRGS extensions  
along with W3C.

So if I translate that into IETF lingo it would be that  
implementations SHALL support SRGS and MAY support KPML, with the  
idea being that over time we could (if we chose to do so) phase out  
the KPML usage and wind up only with SRGS.

It seems a reasonable approach to me.

Regards,
Dan

On Jan 30, 2008, at 5:45 AM, McGlashan, Scott wrote:

> The current version of the package allows a custom DTMF grammar,  
> but does not mandate any format. The editors note says:
>
> defined. Possibilities include: [SRGS] [H.248.1]  and [RFC4730]. If  
> more than one format is permitted, then an additional input  
> parameter "grammartype" would indicate the format used in the  
> grammar parameter.]
>
> 1. SRGS: powerful format supporting both DTMF and speech input,  
> used in VoiceXML and other standards. This allows developers to use  
> the same DTMF format consistently in the base package, the VoiceXML  
> 2. KPML DTMF format: basically H248.1 DRegex format with some  
> fixes. This format is simpler and targeted specifically at DTMF and  
> Is the discussion about removing support for SRGS from the Basic  
> IVR draft?
>
> Regards,
> Dan
>

---

From: "McGlashan, Scott" <[email-masked]>
Date: Thu, 31 Jan 2008 12:32:23 +0000

sorry for the typo - I meant that SRGS does not support long and double key press.

Support from Voxeo in W3C to extend SRGS with these features is much apprecated - thanks.

If there are no objections from the group to the proposal for custom DTMF grammar formats that

 implementations SHALL support SRGS and MAY support KPML

then I'll add that in the next basic IVR draft.

thanks

Scott

________________________________
From: Dan York [mailto:[email-masked]]
Sent: Wednesday, January 30, 2008 14:45
To: McGlashan, Scott
Cc: Spencer Dawkins; [email-masked]; Dan Burnett
Subject: Re: [MEDIACTRL] Using SRGS in IVR draft

Scott,

Thank you for the great explanation.  Just to be clear I believe you meant in #1 below that SRGS does NOT support long and double press features, correct?

When I asked my (Voxeo) colleague Dan Burnett about this, he responded that his preference would be:

- to mandate support for SRGS,
- to permit support for KPML DTMF, and
- to work within W3C to extend SRGS to provide support for long and double keypresses.

and added that he would be willing to help push these SRGS extensions along with W3C.

So if I translate that into IETF lingo it would be that implementations SHALL support SRGS and MAY support KPML, with the idea being that over time we could (if we chose to do so) phase out the KPML usage and wind up only with SRGS.

Regards,
Dan

thanks

Scott

Hi, Dan,

Thanks,

Spencer
----- Original Message -----
From: Dan York<mailto:[email-masked]>
To: Spencer Dawkins<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Sent: Tuesday, January 29, 2008 7:55 PM
Subject: Re: [MEDIACTRL] Using SRGS in IVR draft

Spencer,

Regards,
Dan

Thanks,

Spencer, as co-chair