Subject: [MEDIACTRL] Chair calling concensus on transport protocol support

From: Spencer Dawkins <[email-masked]>
Date: Tue, 29 Jan 2008 12:16:21 -0600

Based on one of the longer threads to date, this is the way Eric and I are 
calling it:

MEDIACTRL protocols will assume a reliable underlying transport protocol, 
and will not duplicate functionality provided at the transport level.

Note: I don't think there's any need for 2119 language in this sentence - 
it's about a an assumption the working group is making, not about a choice 
that implementers will make. 2119 language is appropriate in the remaining 
sentences, which do govern implementation choices.

MEDIACTRL implementations MUST support TLS as a transport-level security 
mechanism, although use of TLS in specific deployments is optional.

MEDIACTRL implementations MUST support TCP as a transport protocol. 
MEDIACTRL implementations MAY support SCTP as a transport protocol.

If you think we're horribly misreading the working group consensus, please 
let us know really, really soon.

Thanks,

Spencer 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 29 Jan 2008 20:25:17 +0200

Looks OK to me
Roni

> -----Original Message-----
> From: Spencer Dawkins [mailto:[email-masked]]
> Sent: Tuesday, January 29, 2008 8:16 PM
> To: [email-masked]
> Subject: [MEDIACTRL] Chair calling concensus on transport protocol support
>

---

From: "Chris Boulton" <[email-masked]>
Date: Tue, 29 Jan 2008 18:45:32 -0000

Looks good to me.

Chris.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 29 January 2008 18:25
To: Spencer Dawkins; [email-masked]
Subject: RE: [MEDIACTRL] Chair calling concensus on transport protocol
support

Looks OK to me
Roni

This email was protected during delivery to Avaya with TLS encryption

---

From: Diego Besprosvan <[email-masked]>
Date: Tue, 29 Jan 2008 20:57:23 +0200

Fine with me

---
Diego Besprosvan (:--:)
MailVision Ltd.
[email-masked]
www.mailvision.com

On Jan 29, 2008, at 8:16 PM, Spencer Dawkins wrote:

> Based on one of the longer threads to date, this is the way Eric  
> and I are calling it:
>
> MEDIACTRL protocols will assume a reliable underlying transport  
> protocol, and will not duplicate functionality provided at the  
> transport level.
>
> Note: I don't think there's any need for 2119 language in this  
> sentence - it's about a an assumption the working group is making,  
> not about a choice that implementers will make. 2119 language is  
> appropriate in the remaining sentences, which do govern  
> implementation choices.
>
> MEDIACTRL implementations MUST support TLS as a transport-level  
> security mechanism, although use of TLS in specific deployments is  
> optional.
>
> If you think we're horribly misreading the working group consensus,  
> please let us know really, really soon.
>
> Thanks,
>
> Spencer
>
>
>

---

From: "Adnan Saleem" <[email-masked]>
Date: Tue, 29 Jan 2008 11:33:59 -0800

I'm ok with this.

Adnan 

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]] 
Sent: January 29, 2008 10:16 AM
To: [email-masked]
Subject: [MEDIACTRL] Chair calling concensus on transport protocol
support

Based on one of the longer threads to date, this is the way Eric and I
are calling it:

MEDIACTRL protocols will assume a reliable underlying transport
protocol, and will not duplicate functionality provided at the transport
level.

Note: I don't think there's any need for 2119 language in this sentence
- it's about a an assumption the working group is making, not about a
choice that implementers will make. 2119 language is appropriate in the
remaining sentences, which do govern implementation choices.

Thanks,

Spencer

---

From: Dan York <[email-masked]>
Date: Tue, 29 Jan 2008 16:20:02 -0500

Looks fine to me,
Dan

-- 
Dan York, CISSP, Director of Emerging Communication Technology
Office of the CTO    Voxeo Corporation     [email-masked]
Phone: +1-407-455-5859  Skype: danyork  http://www.voxeo.com
Blogs: http://blogs.voxeo.com  http://www.disruptivetelephony.com

Bring your web applications to the phone.
Find out how at http://evolution.voxeo.com

---

From: [email-masked]
Date: Tue, 29 Jan 2008 22:52:46 +0100

Ok for me.

Lorenzo

Quoting Spencer Dawkins <[email-masked]>:

> Spencer _______________________________________________
> MEDIACTRL mailing list
> [email-masked]

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

---

From: "MUNSON, GARY A (GARY A)" <[email-masked]>
Date: Tue, 29 Jan 2008 20:54:36 -0500

Sounds good to me. Thanks.

Gary

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]] 
Sent: Tuesday, January 29, 2008 1:16 PM
To: [email-masked]
Subject: [MEDIACTRL] Chair calling concensus on transport protocol
support

are 
calling it:

protocol, 

Note: I don't think there's any need for 2119 language in this sentence
- 
it's about a an assumption the working group is making, not about a
choice 
that implementers will make. 2119 language is appropriate in the
remaining 
sentences, which do govern implementation choices.

please 

Thanks,

Spencer

---

From: [email-masked]
Date: Wed, 30 Jan 2008 11:03:51 +0100

I'm ok with this.

Simon

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 30 Jan 2008 13:44:28 +0100

Hi, 

A small question for clarification.

>MEDIACTRL implementations MUST support TLS as a 
>transport-level security mechanism, although use of TLS in 
>specific deployments is optional.

Does this mean that in non-TLS deployments I can use MEDIACTRL without
TLS?

Or, does it mean that I must add TLS to non-TLS deployments in order to
use MEDIACTRL?

Regards,

Christer

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 30 Jan 2008 15:01:03 +0200

Christer,
It means that you must support TLS but you can use TCP to establish
connection
Roni

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, January 30, 2008 2:44 PM