Subject: [MEDIACTRL] mixing real time text

From: "Tim Melanchuk" <[email-masked]>
Date: Mon, 28 Jan 2008 08:53:38 -0800

the design team is starting work on a mixing package. one of the issues that
has come up has to do with mixing real-time text. unlike IVR, where text
can essentially be treated as a negotiated payload type, mixing also
requires
specification of how multiple participant streams get combined into an
output stream, and how participants get identified in that stream.

we are not sure how this would be done for real-time text.  does anyone have

experience mixing text or can point to any implementations or examples? we
have thought of chat rooms, but they are line-by-line (IM), not
character-by-character (RTT).

thanks,
timm
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Xiao Wang <[email-masked]>
Date: Tue, 29 Jan 2008 18:21:58 +0800

Hi, Tim

         I don't understand your "real-time text". Will you give some use
cases to mixing real-time text?

Xiao

  _____  

From: Tim Melanchuk [mailto:[email-masked]] 
Sent: Tuesday, January 29, 2008 12:54 AM
To: [email-masked]
Subject: [MEDIACTRL] mixing real time text

thanks,
timm

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 29 Jan 2008 12:29:44 +0200

Hi,

By Real-time text we mean ITU-T T.140 conversional text. The RTP payload
is in http://tools.ietf.org/html/rfc4103

Roni Even

________________________________

From: Xiao Wang [mailto:[email-masked]] 
Sent: Tuesday, January 29, 2008 12:22 PM
To: 'Tim Melanchuk'; [email-masked]
Subject: RE: [MEDIACTRL] mixing real time text

Hi, Tim

         I don't understand your "real-time text". Will you give some
use cases to mixing real-time text?

Xiao

________________________________

the design team is starting work on a mixing package. one of the issues
that

we are not sure how this would be done for real-time text.  does anyone
have 
experience mixing text or can point to any implementations or examples?
we
have thought of chat rooms, but they are line-by-line (IM), not
character-by-character (RTT).

thanks,
timm

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 29 Jan 2008 07:11:23 -0600

What Roni said.

If I understand correctly, the high-level difference is that IM/chat isn't transmitted until someone types a complete thought, and then presses "send", while in RTT, each keystroke is transmitted as it is pressed.

So IM/chat is easier - you type "The problem with mixing RTT is picking a boundary to use in mixing - a letter? a word?" and Roni types, at the same time, "the problem with mixing RTT is attributing the text from different sources in a meaningful way", and the mixed text stream contains two complete thoughts.

If you are both typing at the same time in RTT, a naive word-at-a-time mixing strategy might give you

The problem with the problem mixing RTT is with mixing pickingRTT is attributing  a boundarythe text  to from different use sources in a meaningful way in mixing - a letter? a word?

A naive byte-at-a-time strategy would be even more jumbled.

I hope this helps!

Spencer
  ----- Original Message ----- 
  From: Even, Roni 
  To: Xiao Wang ; Tim Melanchuk ; [email-masked] 
  Sent: Tuesday, January 29, 2008 4:29 AM
  Subject: RE: [MEDIACTRL] mixing real time text

  Hi,

  By Real-time text we mean ITU-T T.140 conversional text. The RTP payload is in http://tools.ietf.org/html/rfc4103

  Roni Even

------------------------------------------------------------------------------

  Hi, Tim

           I don't understand your "real-time text". Will you give some use cases to mixing real-time text?

  Xiao

------------------------------------------------------------------------------

  can essentially be treated as a negotiated payload type, mixing also requires 

  thanks,
  timm

------------------------------------------------------------------------------