Subject: [MEDIACTRL] Basic IVR package sematics questions

From: "Even, Roni" <[email-masked]>
Date: Sat, 2 Feb 2008 23:32:43 +0200

Hi,

I was trying to look at some flows and have questions

The draft says that the items in a prompt list are played one after the other.

1.	What about if I have a play announcement and after it prompt and collect. Does the prompt and collect need to wait till the play  announcements finishes. The general question is if each of the template dialogs need to complete before another starts and the play announcement is the more interesting since no input is involved.
2.	If I would like to play music and play the prompt on top of the music, how can I do it, my understating is that the current prompt and collect defines only sequential order, the same will be for video and audio which may be to separate streams. The current text has something about them being separate but does not specify how to play them simultaneously. 

Roni Even

_______________________________________________
MEDIACTRL mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: [email-masked]
Date: Sun, 03 Feb 2008 14:48:26 +0100

Hi Roni,

from my understanding of the drafts:

1. yes, the playannouncement can't be currenty skipped (e.g. by  
pressing a DTMF); probably adding something like the 'dtmfterm' in  
promptandrecord would be good;

2. you can surely have the effect you want with some twist: for  
instance, you could create a small conference instance in the MS,  
attach the user and a music source to it, and then feed the  
announcement to the conference instead of playing it to the user  
directly; this would achieve what you want, even if not in a very  
straightforward way... about having two separate streams of the same  
media type (in this case audio) in the same prompt, I don't know if  
it's envisaged and how it should be dealt by the package according to  
the specification: some additional text is probably needed to clarify  
this.

Regards,
Lorenzo

Quoting "Even, Roni" <[email-masked]>:

> 1.	What about if I have a play announcement and after it prompt and   
> collect. Does the prompt and collect need to wait till the play    
> announcements finishes. The general question is if each of the   
> template dialogs need to complete before another starts and the play  
>  announcement is the more interesting since no input is involved.
> 2.	If I would like to play music and play the prompt on top of the   
> music, how can I do it, my understating is that the current prompt   
> and collect defines only sequential order, the same will be for   
> video and audio which may be to separate streams. The current text   
> has something about them being separate but does not specify how to   
> play them simultaneously.
>
>
>
>
>
> Roni Even
>
>

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]
_______________________________________________
MEDIACTRL mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Even, Roni" <[email-masked]>
Date: Sun, 3 Feb 2008 16:05:21 +0200

Lorenzo,
Thanks, 

I also think that the current meaning is that the announcement need to terminate before starting the prompt and collect. I just could not find any text saying that each of this template dialogs is synchronous and must be terminated before the next one is executed by the MS

As for multiple streams, we need to specify how you tell the MS to display two separate streams at the same time for audio and video.

As for creating a conference and feeding the music and speech message, this will be not simple for barge-in to stop the music since the AS will need to handle it and not the MS

Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, February 03, 2008 3:48 PM
> To: Even, Roni
> Cc: [email-masked]
> Subject: Re: [MEDIACTRL] Basic IVR package sematics questions
> 
> Hi Roni,
>