Subject: Re: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

From: "Even, Roni" <[email-masked]>
Date: Mon, 4 Feb 2008 17:25:15 +0200

Hi,
I think that the draft needs some text and flow about using one control
channel and multiple control channels if the MS is mixing. 

I find this missing and that also makes it difficult to understand the
join in the conference package.

Roni

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]]
> Sent: Tuesday, January 29, 2008 7:59 PM
> To: [email-masked]
> Subject: [MEDIACTRL] Pseudo WGLC - SIP Control Framework
> 
> We have a document that is not perfect as a formal requirements
document,
> but the chairs think should be sufficient to give to the SIP Work
Group to
> get what we need done.
http://tools.ietf.org/html/draft-ietf-mediactrl-sip-control-framework-00
> 
> If if you do not think it is sufficient, or needs other requirements,
> please
> speak up now.  The focus is on requirements, not the solution; SIP
will
> give
> us the solution.  The directions to the SIP work group will be
something
> like, "Take the requirements, feel free to ignore the solution in the
> document."
> 
> This is a Pseudo Work Group Last Call, in that we have no intention of
> publishing this document.  The expectation is the agreed-upon
requirements
> will become a section in the protocol document produced by the SIP
work
> group.
> 
> You have until 15 February to make your comments.
> 
> Thanks.
> 
> --
> The mediactrl Chairs
> 
> 
> Notice:  This email message, together with any attachments, may
contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and
affiliated
> entities,  that may be confidential,  proprietary,  copyrighted
and/or
> legally privileged, and is intended solely for the use of the
individual
> or entity named in this message. If you are not the intended
recipient,
> and have received this message in error, please immediately return
this by
> email and then delete it.
> 
> 
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
_______________________________________________
MEDIACTRL mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Tim Melanchuk" <[email-masked]>
Date: Mon, 4 Feb 2008 12:24:33 -0800

i'm not sure that i follow handing this off to the SIP group. there are a
couple extensions to SIP in the draft, and these could be handed off,
or, more appropriately, dealt with separately. for example, communicating
the set of packages could be done without SIP headers (e.g. over the control
channel).

i view the control framework primarily as 2 things:

a) a usage of SIP and hence appropriate to SIPPING, and
b) a new control "framing" protocol that defines some mechanisms
    and base messages for control interactions. examples of these
    are the SYNC, CONTROL, and REPORT messages and the
    basic packages structure.

i'm worried that this latter, will be lost in the SIP WG and is most
appropriately done in mediactrl since we are relying on the
package structure defined in the framework for differrent chucks
of media server control functionality (eg. ivr, conferencing).

timm

On Jan 29, 2008 9:59 AM, Eric Burger <[email-masked]> wrote:

> We have a document that is not perfect as a formal requirements document,
> but the chairs think should be sufficient to give to the SIP Work Group to
> get what we need done.
>
> speak up now.  The focus is on requirements, not the solution; SIP will
> give
> us the solution.  The directions to the SIP work group will be something
> publishing this document.  The expectation is the agreed-upon requirements
> will become a section in the protocol document produced by the SIP work
> group.
>
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>
>

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 4 Feb 2008 20:59:16 -0000

i'm not sure that i follow handing this off to the SIP group. there are
a 
couple extensions to SIP in the draft, and these could be handed off,
or, more appropriately, dealt with separately. for example,
communicating
the set of packages could be done without SIP headers (e.g. over the
control
channel). 

[Chris Boulton] Just to clarify - there are no SIP extensions currently
in the draft.  The headers you refer to were moved into the Control
Channel SYNCH message in the latest version of the draft and the new SDP
attributes were defined in a separate draft as a hint. 

timm

We have a document that is not perfect as a formal requirements
document,
but the chairs think should be sufficient to give to the SIP Work Group
to
get what we need done.

Thanks.

--
The mediactrl Chairs

Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it.

---

From: "Mary Barnes" <[email-masked]>
Date: Tue, 5 Feb 2008 16:40:16 -0600

Scott, 
 
If I understood Chris, his point is that this document doesn't make any
normative SIP changes, thus if any other WG were to review and make
recommendations, it would be more appropriate for the SIPPING WG, which
is where we have developed quite a few other frameworks that use SIP as
a basis (e.g., Conferencing, Session policy framework, etc.).  [Note:
this is me speaking as an individual and not as chair of SIPPING].
 
Another suggestion might be to toss this document up to the RAI area for
expert review since it does span several WGs.
 
Mary. 

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of McGlashan, Scott
Sent: Tuesday, February 05, 2008 5:45 AM
To: Chris Boulton; Tim Melanchuk; Eric Burger
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

Eric, 
 
I'm confused - the SIP Control Framework doesn't extend SIP in anyway
since package negotiation is done in the SDP. So why would we pass this
doc to the SIPPING group? The majority of the spec is about the channel
protocol as Timm points out.
 
Scott

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Chris Boulton
Sent: Monday, February 04, 2008 21:59
To: Tim Melanchuk; Eric Burger
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

timm

Thanks.

--
The mediactrl Chairs

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 6 Feb 2008 09:08:34 +0200

Hi,

Reading the current draft I would say that in term of the relationship
to SIP it looks similar to BFCP work that was done in XCON and MMUSIC. I
am not sure if it was discussed in SIPPING but Mary may know.

I am mentioning the current draft since I think that it still need to
explain how to use in the conference case a single and multiple AS-MS
control connections.

Roni

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mary Barnes
Sent: Wednesday, February 06, 2008 12:40 AM
To: McGlashan, Scott; Chris Boulton; Tim Melanchuk; Eric Burger
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

Scott, 

Mary. 

Eric, 

Scott

timm

Thanks.

--
The mediactrl Chairs

---

From: "McGlashan, Scott" <[email-masked]>
Date: Wed, 6 Feb 2008 09:52:39 +0000

hi Mary,

I agree with another group reviewing the document but I thought Eric was talking about transfering the document to the SIPPING group and it was that which confused me.

scott

________________________________
From: Mary Barnes [mailto:[email-masked]]
Sent: Tuesday, February 05, 2008 23:40
To: McGlashan, Scott; Chris Boulton; Tim Melanchuk; Eric Burger
Cc: [email-masked]
Subject: RE: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

Scott,

If I understood Chris, his point is that this document doesn't make any normative SIP changes, thus if any other WG were to review and make recommendations, it would be more appropriate for the SIPPING WG, which is where we have developed quite a few other frameworks that use SIP as a basis (e.g., Conferencing, Session policy framework, etc.).  [Note: this is me speaking as an individual and not as chair of SIPPING].

Another suggestion might be to toss this document up to the RAI area for expert review since it does span several WGs.

Mary.

From: [email-masked] [mailto:[email-masked]] On Behalf Of McGlashan, Scott

Eric,

I'm confused - the SIP Control Framework doesn't extend SIP in anyway since package negotiation is done in the SDP. So why would we pass this doc to the SIPPING group? The majority of the spec is about the channel protocol as Timm points out.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Boulton

[Chris Boulton] Just to clarify - there are no SIP extensions currently in the draft.  The headers you refer to were moved into the Control Channel SYNCH message in the latest version of the draft and the new SDP attributes were defined in a separate draft as a hint.

timm
On Jan 29, 2008 9:59 AM, Eric Burger <[email-masked]<mailto:[email-masked]>> wrote:
We have a document that is not perfect as a formal requirements document,
but the chairs think should be sufficient to give to the SIP Work Group to
get what we need done.

If if you do not think it is sufficient, or needs other requirements, please
speak up now.  The focus is on requirements, not the solution; SIP will give
us the solution.  The directions to the SIP work group will be something
like, "Take the requirements, feel free to ignore the solution in the
document."

Thanks.

--
The mediactrl Chairs

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
MEDIACTRL mailing list
[email-masked]<mailto:[email-masked]>
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Wed, 6 Feb 2008 10:17:16 +0000

And just to clarify before someone points it out, my question was about the SIP WG not the SIPPING WG since that was the WG Eric mentioned in his original mail. Apologies for any confusion.

scott

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of McGlashan, Scott
Sent: Wednesday, February 06, 2008 10:53
To: Mary Barnes; Chris Boulton; Tim Melanchuk; Eric Burger
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Pseudo WGLC - SIP Control Framework

hi Mary,

scott

Scott,

Mary.

Eric,

Scott

timm

Thanks.

--
The mediactrl Chairs