Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-ivr-control-package-03.txt

From: [email-masked]
Date: Fri, 28 Nov 2008 05:30:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Media Server Control Working Group of the IETF.

	Title           : An Interactive Voice Response (IVR) Control Package for the Media Control Channel Framework
	Author(s)       : S. McGlashan, et al.
	Filename        : draft-ietf-mediactrl-ivr-control-package-03.txt
	Pages           : 140
	Date            : 2008-11-28

This document defines a Media Control Channel Framework Package for
Interactive Voice Response (IVR) dialog interaction on media
connections and conferences.  The package defines dialog management
request elements for preparing, starting and terminating dialog
interactions, as well as associated responses and notifications.
Dialog interactions are specified in a dialog language.  This package
defines a lightweight IVR dialog language (supporting prompt
playback, runtime controls, DTMF collect and media recording) and
allows other dialog languages to be used.  The package also defines
elements for auditing package capabilities and IVR dialogs.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mediactrl-ivr-control-package-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 28 Nov 2008 13:36:21 +0000

As you can see, the IVR ControlPackage has been updated to -03 following mailing list discussion and review. Thanks to all those who provided reviews comments - much appreciated.

The detailed change list is at the top in Section 9 of the ID (and below in this email). There are no functionality changes, but 3 main areas where we'd appreciate careful review.

1. Conformance language generally. We've removed the RECOMMENDED and tried to clean up the MUSTs, SHOULDs and MAYs (reducing MUSTs and eliminating SHOULD where sensible).

2. Security Section Section 7. This has been re-written with clearer security policy (same one is used in the mixer package).

3. Appendix on VoiceXML usage. Particularly appreciated feedback from those using this package with VoiceXML.

Thanks

Scott

  The following are the major changes between the -03 and -02 versions.

   o  Conformance language: Removed unnecessary MUSTs, especially for
      error codes.  Removed lowercase 'should', 'must' and 'may'.

   o  Introduction: Clarified which MediaCtrl IVR Requirements are
      satisfied by this package.  Added link to Security Considerations
      Section (also in Section 4.0 and 4.4).

   o  4.0: Element definitions.  Changed RECOMMENDED to MUST for MS
      support of communication protocols in URIs.

   o  4.2.2:<dialogstart>: Changed RECOMMENDED to MAY for MS support of
      multiple dialogs on same connection or conference.  Changed
      RECOMMENDED to MUST for using <stream> in cases where connection
      has multiple streams of the same type.

   o  4.2.2.2:<stream>: Changed RECOMMENDED to MUST for use of common
      media attribute values.

   o  4.2.2.1: <subscribe>: Clarified that if the MS does not support a
      subscription specified in a foreign namespace, then the MS
      generates a 431 error response.

   o  4.2.4: <response>: Clarified that a dialogid with an empty string
      value is used when the request is syntactically invalid.

   o  4.2.5.1: <dialogexit>: Added reserved range of status codes, and
      tightened up the wording.

   o  4.3.1.3:<collect>: Clarified that termtimeout attribute default of
      0s meaning no delay.

   o  4.3.1.1.1: <variable>: Changed RECOMMENDED to MAY for MS support
      of date, time and digits <variable>s.  Clarified value attribute
      format for date, time and digits.

   o  4.3.1.1.3: <par>: Removed RECOMMENDED for MS support of parallel
      playback of different media.  Added error response code (435) if
      MS does not support parallel playback configuraton.

   o  4.3.1.1.3.1: <seq>: Removed RECOMMENDED for MS support of
      sequential playback of same media within a <par> (error case
      already covered by <par> configuration not supported response
      code).

   o  4.3.1.4:<record>: Removed RECOMMENDED for MS support of parallel
      recording of different media.  Clarified wording around uploading
      recording data to a media resource location.

   o  4.3.1.4: <record>: Clarified the definition of vadinitial and
      vadfinal.  Changed the default values to false.  Added a response
      error (434) for when the MS does not support VAD.

   o  4.3.1.5: <media>.  Removed unnecesaary SHOULD for MS ignoring
      fetchtimeout, soundLevel, clipBegin and clipEnd when <media> used
      for recording.  Clarified definition of loc and type attributes
      with stronger conformance language.  Similar clarifications of
      type attributes in <dialogprepare>, <dialogstart> and <grammar>.

   o  4.3.2.4.1: <mediainfo>: Clarified usage and strengthen conformance
      language.

   o  4.4.2.22: <grammartypes>: Changed MUST to MUST NOT for inclusion
      of mandatory SRGS grammar format.  Updated examples.

   o  Updated schema.

   o  Security Considerations: Major update.  Added examples showing
      malicious attacks when channel security is not correctly
      addressed.  Added more details on multiple channel cases including
      administrator and monitor channels as well as channel handover.

   o  Removed affliations in Contributors and Acknowledgements sections.

   o  Added Appendix A describing how to use VoiceXML with this package
      if it is supported by the MS.

   o  Corrected typos and nits.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, November 28, 2008 14:30
To: [email-masked]
Cc: [email-masked]
Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-ivr-control-package-03.txt

This document defines a Media Control Channel Framework Package for Interactive Voice Response (IVR) dialog interaction on media connections and conferences.  The package defines dialog management request elements for preparing, starting and terminating dialog interactions, as well as associated responses and notifications.
Dialog interactions are specified in a dialog language.  This package defines a lightweight IVR dialog language (supporting prompt playback, runtime controls, DTMF collect and media recording) and allows other dialog languages to be used.  The package also defines elements for auditing package capabilities and IVR dialogs.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl