Subject: [MEDIACTRL] Working Group Last Call on draft-ietf-mediactrl-mixer-control-package-02.txt

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 4 Nov 2008 12:57:32 -0600

This e-mail is kicking off a two-week WGLC on the following draft, which 
will end on November 19, just before our face-to-face meeting in 
Minneapolis.

It's a great time to read the draft carefully - discussion of WGLC comments 
is on the agenda for Minneapolis, and our goal is to finish IVR and MIXER 
and start serious work on MRB.

Thanks,

Spencer, as co-chair

>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
> This draft is a work item of the Media Server Control Working Group of the 
> IETF.
>
>
> Title           : A Mixer Control Package for the Media Control Channel 
> Framework
> Author(s)       : T. Melanchuk, et al.
> Filename        : draft-ietf-mediactrl-mixer-control-package-02.txt
> Pages           : 89
> Date            : 2008-11-03
>
> This document defines a Mixer Control Package for the Media Control
> Channel Framework.  This Control Package aims to fulfill Conferencing
> requirements using the SIP Control Framework.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mediactrl-mixer-control-package-02.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 10 Nov 2008 13:22:54 -0600

I'm sending along some comments, mostly editorial, on the MIXER draft. In
general, I'm pleased with the readability of the draft.

Maybe more than nits:

In the abstract, I see "This Control Package aims to fulfill Conferencing 
requirements..."

- s/aims to fulfill/fulfills/ ?

- can you describe Conferencing requirements more precisely, just so it's 
clear what you're referring to?

I noticed in 5.2.1.1 that the description for trying to create a 
conferenceid that already exists (407) ends with "and MUST NOT create the 
conference". Well, that was the problem in the first place, right? I think 
you're trying to say "and MUST NOT affect the existing conference", or 
something like that? If so, this comment applies in other descriptions of 
407 as well (in 5.2.2.2, the description of 407 says "and MUST NOT modify 
the join" - same in 5.2.2.3 for 407, same in 5.2.2.4 for 407...)

In 5.2.1.4.1, and elsewhere in the spec, I never saw a description of how 
"nbest" is set - is the value of N strictly under the MS control, so the AS 
doesn't know what value of N the MS is using? If so, it might be nice to 
point this out. If not, I never saw the value being set by the AS...

Nits:

s/A simple audio mix/A simple audio mixer/

s/one of the conferences available/one of the conference's available/

s/that participants audio/that participant's audio/

s/the MS MUST ignored/the MS MUST ignore/g (at least twice)

s/whsipered/whispered/

---

From: "McGlashan, Scott" <[email-masked]>
Date: Tue, 11 Nov 2008 10:53:00 +0000

Thanks for the mixer review Spencer. I'll apply the changes.

Two issues:

1. "I noticed in 5.2.1.1 that the description for trying to create a conferenceid that already exists (407) ends with "and MUST NOT create the conference". Well, that was the problem in the first place, right? "

No. This is a <createconference> request to create a new conference where the identifier is already used for another conference on the MS. All conferences must have unique ids on the MS. So I think it is correct to say this new conference is not created. I can see how the wording needs some clarification though and I will fix it.

2. "In 5.2.1.4.1, and elsewhere in the spec, I never saw a description of how "nbest" is set - is the value of N strictly under the MS control, so the AS doesn't know what value of N the MS is using? If so, it might be nice to point this out. If not, I never saw the value being set by the AS..."

Good catch. Any objections to adding an attribute on <audio-mixing> so that the AS can specify N?

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Dawkins
Sent: Monday, November 10, 2008 20:23
To: [email-masked]
Subject: Re: [MEDIACTRL] Working Group Last Call ondraft-ietf-mediactrl-mixer-control-package-02.txt

I'm sending along some comments, mostly editorial, on the MIXER draft. In general, I'm pleased with the readability of the draft.

Maybe more than nits:

In the abstract, I see "This Control Package aims to fulfill Conferencing requirements..."

- can you describe Conferencing requirements more precisely, just so it's clear what you're referring to?

I noticed in 5.2.1.1 that the description for trying to create a conferenceid that already exists (407) ends with "and MUST NOT create the conference". Well, that was the problem in the first place, right? I think you're trying to say "and MUST NOT affect the existing conference", or something like that? If so, this comment applies in other descriptions of
407 as well (in 5.2.2.2, the description of 407 says "and MUST NOT modify the join" - same in 5.2.2.3 for 407, same in 5.2.2.4 for 407...)

In 5.2.1.4.1, and elsewhere in the spec, I never saw a description of how "nbest" is set - is the value of N strictly under the MS control, so the AS doesn't know what value of N the MS is using? If so, it might be nice to point this out. If not, I never saw the value being set by the AS...

Nits:

s/whsipered/whispered/

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 11 Nov 2008 10:24:04 -0600

Hi, Scott,

Response inline...

Spencer

----- Original Message ----- 
From: "McGlashan, Scott" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>; <[email-masked]>
Sent: Tuesday, November 11, 2008 4:53 AM
Subject: RE: [MEDIACTRL] Working Group Last 
Callondraft-ietf-mediactrl-mixer-control-package-02.txt

Two issues:

1. "I noticed in 5.2.1.1 that the description for trying to create a 
conferenceid that already exists (407) ends with "and MUST NOT create the 
conference". Well, that was the problem in the first place, right? "

No. This is a <createconference> request to create a new conference where 
the identifier is already used for another conference on the MS. All 
conferences must have unique ids on the MS. So I think it is correct to say 
this new conference is not created. I can see how the wording needs some 
clarification though and I will fix it.

<Spencer> - I think you and I are talking about two halves of a whole - 
You're saying "don't create a new conference with a duplicate conferenceid", 
and I'm saying "don't change the existing conference with this conferenceid 
as a result of the errored operation" - does that sound right? If so, I 
agree with your half, and I think both are important enough to mention. 
</Spencer>

---

From: "McGlashan, Scott" <[email-masked]>
Date: Tue, 11 Nov 2008 17:22:51 +0000

You are quite right, Spencer. I'll clarify both aspects.

Thanks

Scott

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]]
Sent: Tuesday, November 11, 2008 17:24
To: McGlashan, Scott
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Working Group Last Callondraft-ietf-mediactrl-mixer-control-package-02.txt

Hi, Scott,

Response inline...

Spencer

----- Original Message -----
From: "McGlashan, Scott" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>; <[email-masked]>
Sent: Tuesday, November 11, 2008 4:53 AM
Subject: RE: [MEDIACTRL] Working Group Last Callondraft-ietf-mediactrl-mixer-control-package-02.txt

Two issues:

<Spencer> - I think you and I are talking about two halves of a whole - You're saying "don't create a new conference with a duplicate conferenceid", and I'm saying "don't change the existing conference with this conferenceid as a result of the errored operation" - does that sound right? If so, I agree with your half, and I think both are important enough to mention.
</Spencer>