Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-mixer-control-package-03.txt

From: [email-masked]
Date: Fri, 28 Nov 2008 05:30:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Media Server Control Working Group of the IETF.

	Title           : A Mixer Control Package for the Media Control Channel Framework
	Author(s)       : S. McGlashan, et al.
	Filename        : draft-ietf-mediactrl-mixer-control-package-03.txt
	Pages           : 96
	Date            : 2008-11-28

This document defines a Media Control Channel Framework Package for
managing mixers for media conferences and connections.  The package
defines request elements for managing conference mixers, managing
mixers between conferences and/or connections, as well as associated
responses and notifications.  The package also defines elements for
auditing package capabilities and mixers.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mediactrl-mixer-control-package-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 28 Nov 2008 13:38:48 +0000

As you can see, the Mixer Control Package has been updated to -03 following mailing list discussion and review. Thanks to all those who provided reviews and comments - much appreciated.

The detailed change list is at the top in Section 9 of the ID (and below in this email). There are one or two minor functionality changes (added 'n' attribute for nbest audio-mixing, changes to error status codes), but 2 main areas where we'd appreciate careful review:

1. Conformance language generally. We've tried to clean up the MUSTs, SHOULDs and MAYs (reducing MUSTs and eliminating RECOMMENDED/SHOULD where sensible).

2. Security Section Section 7. This has been re-written with clearer security policy (same one is used in the ivr package).

Thanks

Scott

   The following are the major changes between the -03 and -02 versions.

   o  Corrected various typos and nits.

   o  Conformance language: Removed unnecessary MUSTs, especially for
      error codes.  Changed most RECOMMENDEDs to MUST or MAY.  Removed
      lowercase 'should', 'must' and 'may'.

   o  Tidied up Abstract

   o  Removed old Introduction section (it just duplicated the
      abstract).  Replaced it with the old Overview Section.  Section
      numbering changed!

   o  Introduction: Clarified which MediaCtrl Requirements are satisfied
      by this package.

   o  4.2.1.1: <createconference>: Clarified that an attempt to create a
      conference with an identifier already used by an existing
      conference does not affect the existing conference (405 error
      response).

   o  4.2.1.4.1: <audio-mixing>: Added a 'n' attribute for the number of
      participants to be included in nbest audio mixing.

   o  4.2.1.4.3: <video-switch>: Clarified that the active speaker in
      video switching is the loudest speaker.

   o  4.2.1.4.4: <subscribe>: Clarified that if a subscription specified
      in a foreign namespace element or attribute is not supported by
      the MS, then the MS generates a 428 error response.  Changed
      conformance support for <active-talkers-sub> from SHOULD to MUST.
      Removed 422 error response.

   o  4.2.2: Joining Elements: Added text to the empty section.

   o  4.2.2.2, 4.2.2.3, 4.2.2.4: <join>, <modifyjoin> and <unjoin>:
      Clarified that join operation failures do not affect existing
      stream properties of the entities (407 and new 422 error
      response).  Clarified stream failure errors in <modifyjoin> and
      <unjoin>.

   o  4.2.2.2: <join>.  Clarified that <stream> elements can be used to
      independently control properties of the media flow in different
      directions.  Added a response code (422) for when the MS does not
      support a media stream configuation.

   o  4.2.2.2: <join>.  Clarified that error responses are generated if
      id1 or id2 reference a conference or connection which does not
      exist.  Added an error status code (412) for non-existant
      connections.

   o  4.2.2.5: <stream>: Changed the definition so that in each child
      element, the media stream affected is indicated by the value of
      the direction attribute of the parent element.  Added examples of
      controlling the media flow properties.

   o  4.2.4.2: <unjoin-notify>.  Added reserved range of status codes.
      Changed code from 1 to 0 for the unjoin case.  Changed code from 3
      to 1 for execution error.

   o  4.2.4.3: <conferenceexit>.  Added reserved range of status codes.
      Changed code from 1 to 0 for the destroyconference case (align
      with IVR).  Added a code for conference exiting due to exceeding
      its maximum duration.

   o  Schema: Adding missing version attribute on <mscmixer>.

   o  Security Considerations: Major update.  Added examples showing
      malicious attacks when channel security is not correctly
      addressed.  Added more details on multiple channel cases including
      administrator and monitor channels as well as channel handover.

   o  Removed affliations in Contributors section.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, November 28, 2008 14:30
To: [email-masked]
Cc: [email-masked]
Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-mixer-control-package-03.txt

This document defines a Media Control Channel Framework Package for managing mixers for media conferences and connections.  The package defines request elements for managing conference mixers, managing mixers between conferences and/or connections, as well as associated responses and notifications.  The package also defines elements for auditing package capabilities and mixers.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl