Subject: Re: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-05: difference between interdigitTimeout and termTimeout

From: "McGlashan, Scott" <[email-masked]>
Date: Mon, 2 Mar 2009 17:57:09 +0000

Hi Jean-Francois,

Good catch - the language around interdigit and term timeouts was in need of clarification. Let me know if the revision in -06 works for you.

thanks

Scott

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Friday, February 27, 2009 19:41
To: [email-masked]
Subject: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-05: difference between interdigitTimeout and termTimeout

I would like to know what is the difference between the interdigitTimeout and termTimeout <collect> attributes.  Under what condition should each of these timers be started and be stopped?

Should I reuse definitions from rfc3525.txt section 7.1.14.2 DigitMap Timers where:
* interdigitTimeout: would correspond to the rfc3525 long duration timeout;
* termTimeout:  would correspond to the rfc3525 short duration timeout (i.e. when one digitmap has been matched, but more matches are possible).

Can you clarify the usage of these timers?

thanks

Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

---

From: Jean-Francois Bertrand <[email-masked]>
Date: Mon, 2 Mar 2009 10:43:55 -0800

Hi Scott,

thanks for the clarification.  -06 is now clear.

/JF
________________________________________
From: McGlashan, Scott [[email-masked]]
Sent: Monday, March 02, 2009 12:57 PM
To: Jean-Francois Bertrand; [email-masked]
Subject: RE: [MEDIACTRL] draft-ietf-mediactrl-ivr-control-package-05: difference between interdigitTimeout and termTimeout

Hi Jean-Francois,

thanks

Scott

thanks