Subject: Re: [MEDIACTRL] Supporting a Codec

From: Eric Burger <[email-masked]>
Date: Fri, 17 Apr 2009 16:16:38 -0500

So from the lack of response, we will take out reporting codecs.  Right?

On Mar 28, 2009, at 2:04 PM, Eric Burger wrote:

> When a media server reports it supports a codec, what does this  
> mean?  The MS can support a codec for recording or playback but not  
> for real-time and vice-versa.  The MS may support receiving and  
> sending a codec, but may not support transcoding.
>
> Is this a tractable problem?
>
> If it is a tractable problem, is it useful?  Will people really use  
> the result of the query to make a decision of some type?  If so,  
> what?  This is an alternative way of asking for use cases.
>
> Time for Eric's Rule of Spec Threats: If we cannot figure out what  
> to do with the information, let us not report it.  My hunch is this  
> will make some use cases crawl out of the  
> woodwork._______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl

---

From: "Roni Even" <[email-masked]>
Date: Sat, 18 Apr 2009 01:01:41 +0300

Eric,
I assume that the MS may report this in the context of a package it supports
if it wants to differentiate between these modes even though in my view an
MS support for a codec is orthogonal to the support of recording, real-time
and so on.
Lack of response to your question is disturbing since I would think that
there is no interest in this work at all for multimedia if no one has any
opinion
Roni Even 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Eric Burger
Sent: Saturday, March 28, 2009 10:04 PM
To: [email-masked]
Subject: [MEDIACTRL] Supporting a Codec

When a media server reports it supports a codec, what does this mean?   
The MS can support a codec for recording or playback but not for real- time
and vice-versa.  The MS may support receiving and sending a codec, but may
not support transcoding.

If it is a tractable problem, is it useful?  Will people really use the
result of the query to make a decision of some type?  If so, what?  This is
an alternative way of asking for use cases.

Time for Eric's Rule of Spec Threats: If we cannot figure out what to do
with the information, let us not report it.  My hunch is this will make some
use cases crawl out of the woodwork.

---

From: Eric Burger <[email-masked]>
Date: Mon, 20 Apr 2009 14:19:45 -0400

I agree (disturbing), but I say it comes out if we cannot get anyone  
to say, "I Care."

On Apr 17, 2009, at 6:01 PM, Roni Even wrote:

> the
> to do