Subject: [MEDIACTRL] msc-mixer: Discriminating between a non-existing connectionid and a non-existing conferenceid in <join>

From: Jean-Francois Bertrand <[email-masked]>
Date: Tue, 20 Oct 2009 05:31:42 -0700

Section 4.2.2.2. of http://tools.ietf.org/html/draft-ietf-mediactrl-mixer-control-package-07  specifies that:

  "If id1 or id2 specify a conference identifier and the conference does
   not exist on the MS, the MS reports an error (406).  If id1 or id2
   specify a connection identifier and the connection does not exist on
   the MS, the MS reports an error (412)."

While there are well-defined rules on how to create a connectionid, the conferenceid is basically free-form.

How can one distinguishes between an non-existing conferenceid and non-existing connectionid in a <join> request?

thanks

/Jean-François Bertrand
Software Engineer
Broadsoft

---

From: Lorenzo Miniero <[email-masked]>
Date: Wed, 21 Oct 2009 10:17:34 +0200

On Tue, 20 Oct 2009 05:31:42 -0700
Jean-Francois Bertrand <[email-masked]> wrote:

> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
> 

I guess that, so long as you make sure the ':' is never used when you
build a conferenceid, you can use that token to differentiate
between them. In our implementation, only alphanumeric characters are
used to build conferenceid identifiers, so that works.

L.

-- 
Lorenzo Miniero <[email-masked]>

---

From: Jean-Francois Bertrand <[email-masked]>
Date: Wed, 21 Oct 2009 06:16:12 -0700

From: Lorenzo Miniero [[email-masked]]
(...)
On Tue, 20 Oct 2009 05:31:42 -0700
> How can one distinguishes between an non-existing conferenceid and non-existing connectionid in a <join> request?
(...)

L.

[[JF]]  This was my point, without such rules it is impossible to discriminate between a connectionid and a conferenceid.  And without well defined rules, it is unlikely that different implementations will choose the same token and thus very likely that a given Media Server will not be able to report the 412 error response. 

If id1 or id2 does not exist on the Media Server, shouldn't it always respond with a 406?

/JF