Subject: [MEDIACTRL] An implementation question about BYE and <unjoin>

From: Victor Paulsamy <[email-masked]>
Date: Thu, 1 Oct 2009 01:38:21 -0700

An AS sends a <join> toward a MS to create media stream between two RTP
sessions terminated on the MS.

At the time of <join>, the two SIP dialogs, referenced in id1 and id2
attributes are available.

Suppose, if one of the parties hung up by emitting a BYE toward the AS, what
is envisioned as an acceptable behavior for the controlling AS from
MEDIACTRL perspective (this is one of the loose ends that wasn't specified):

1. the AS sends a BYE to cleanup the session; but never sends <unjoin>,
forcing MS to remove the media stream between the two entities -- implicitly
-- as the SIP session is cleaned up upon receiving BYE?

or

2. the AS sends <unjoin> first to the MS to remove the established media
stream and then BYE to cleanup the session?

Thanks in advance.

--victor

---

From: Lorenzo Miniero <[email-masked]>
Date: Thu, 1 Oct 2009 11:00:26 +0200

Hi Victor,

I can give you my view of the thing, that reflects the way we
implemented our prototype MS and AS. The way we do it is to always try
and do it the clean way, when possible: which means, first the protocol
(the explicit <unjoin>) and then the BYE. Of course we also implemented
support for the other approach, otherwise the mixer package would not be
able to get rid of the resources at asynchronous events.

L.

On Thu, 1 Oct 2009 01:38:21 -0700

-- 
Lorenzo Miniero <[email-masked]>

---

From: Stéphane Bastien <[email-masked]>
Date: Thu, 1 Oct 2009 05:16:21 -0700

Hi,

In draft-ietf-mediactrl-mixer-control-package-07 section 4.2.4.2 <unjoin-notify>, status code 2 is used when a connection is terminated.

At BroadSoft, we implemented this section of the spec as: if the Media Server receives a SIP BYE that terminates a connection that was joined with another connection or conference, the Media Server must transmit an <unjoin-notify> with status code 2.

Stéphane

From: [email-masked] [mailto:[email-masked]] On Behalf Of Victor Paulsamy
Sent: 1 octobre 2009 04:38
To: [email-masked]
Subject: [MEDIACTRL] An implementation question about BYE and <unjoin>

An AS sends a <join> toward a MS to create media stream between two RTP sessions terminated on the MS.

At the time of <join>, the two SIP dialogs, referenced in id1 and id2 attributes are available.

Suppose, if one of the parties hung up by emitting a BYE toward the AS, what is envisioned as an acceptable behavior for the controlling AS from MEDIACTRL perspective (this is one of the loose ends that wasn't specified):

1. the AS sends a BYE to cleanup the session; but never sends <unjoin>, forcing MS to remove the media stream between the two entities -- implicitly -- as the SIP session is cleaned up upon receiving BYE?

or

2. the AS sends <unjoin> first to the MS to remove the established media stream and then BYE to cleanup the session?

Thanks in advance.

--victor