Subject: [MEDIACTRL] Control Framework SDP Review - Issue 2

From: Chris Boulton <[email-masked]>
Date: Fri, 02 Oct 2009 12:06:56 +0100

Issue 2:

Another question I have relates to SDP Offer/Answer.  It looks like the
intention is that the CFW session last exactly the length of the SIP
INVITE dialog usage (note that this terminology [from RFC 5057] should
probably be used rather than "SIP dialog").

[Chris] We will align terminology with RFC 5057.

Does this mean that it is
forbidden, despite offer/answer semantics, to add or remove a cfw
session in a SIP re-INVITE?   If so, this should probably be stated
explicitly.

[Chris] This is a really good point.  Your are correct that linking the cfw session does then imply that one, and only one cfw session must exist in the SDP during the lifetime of that SIP INVITE dialog.  Are there any objections for adding explicit text calling this out?

-- 
Chris Boulton
CTO & Co-founder
NS-Technologies <http://www.ns-technologies.com>
m: +44.7876.476681

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 2 Oct 2009 11:10:47 +0000

No objections from me.

Thanks for these clarifications!

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Boulton
Sent: Friday, October 02, 2009 13:07
To: [email-masked]
Subject: [MEDIACTRL] Control Framework SDP Review - Issue 2

Issue 2:

Another question I have relates to SDP Offer/Answer.  It looks like the intention is that the CFW session last exactly the length of the SIP INVITE dialog usage (note that this terminology [from RFC 5057] should probably be used rather than "SIP dialog").

--
Chris Boulton
CTO & Co-founder
NS-Technologies <http://www.ns-technologies.com>
m: +44.7876.476681
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 2 Oct 2009 13:26:49 +0200

I'm ok with the change.

L.

On Fri, 2 Oct 2009 11:10:47 +0000

-- 
Lorenzo Miniero <[email-masked]>