Subject: Re: FW: Application for port-number

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 14 Jan 2000 10:58:49 -0600

Further to this point, I would propose the following modification to section
7.2.9.  Following the sentence "MGCs should support both  encoding
formats.": add the sentence: "If an MGC does not support a given encoding
method, it MUST at least be able to recognize a ServiceChange command within
that encoding and be able to return an error reply indicating error 501 -
Not implemented."

> -----Original Message-----
> From: Taylor, Tom-PT [CAR:B904:EXCH]
> Sent: Friday, January 14, 2000 10:45 AM
> To:   [email-masked]
> Subject:      Re: FW: Application for port-number
>
> On your first point, the only purpose of these ports is to give the MG
> somewhere to go to initiate the association.  If it's TCP, the MG port is
> fixed at that point.  If it's UDP, the MG can signal which port it wants
> to receive at.
>
> I thought about your second point, but figured the outcome would be the
> same, regardless: if the MGC doesn't understand a particular encoding, it
> will have no choice but to ignore the association attempt, since it won't
> even be able to recognize the protocol.  Perhaps that's a hole we should
> fix so the MG can at least be told that the MGC doesn't understand it.
>
>       -----Original Message-----
> From:   Christian Huitema [SMTP:[email-masked]]
> Sent:   Friday, January 14, 2000 10:22 AM
> To:     Taylor, Tom-PT [CAR:B904:EXCH];
> [email-masked]
> Subject:        Re: FW: Application for port-number
>
>       At 01:35 PM 1/12/00 -0600, Tom-PT Taylor wrote:
> >I've requested a single port number pair (TCP/UDP) for Megaco/H.248.  See
>
> >below.
>
>       In fact, it would make sense to require separate port numbers for
> the MG
> and for the MGC, to facilitate the writing of ACL in firewalls or similar
> devices. Also, it might make sense to use separate port numbers for the
> text and ASN.1 encodings -- that would limit confusion.
> -- Christian Huitema
>

---

From: Michael Thomas <[email-masked]>
Date: Fri, 14 Jan 2000 15:26:22 -0800

> that encoding and be able to return an error reply indicating error 501 -

   If you have different ports for text and binary
   (which I think is by far the most sensible), an
   MGC would just not listen on that port which
   would generate a host unreachable ICMP when the
   MG tried to send a message. If an MG sees that
   and has the capability to switch over, it would
   just look at the ECONNREFUSED and use that as
   the cue to try the other port/encoding.

   Seems a whole lot easier to me.

         Mike