Subject: Wildcard Response

From: Qiu Xiuping <[email-masked]>
Date: Thu, 20 Jan 2000 22:13:33 +0800

Hi, Harpreet Singh Anand£¡

My comment is marked with Qiu

At 00-1-20 18:01:00 you wrote£º
The only useful wildcard operation for AuditValue seems to be a wildcard audit of the packages. MGC can send a wild card AuditValue command having TerminationId as * and AuditDescriptor having only one
audit item, viz Package Descriptor. In the reply, MG would send a send a single reply with termination id as * and a single package descriptor having the union of all the packages that are supported on all
the terminations in the MG.

*****************************************************************************************************

Qiu :
But wildcard operation is not not only useful for AuditValue really.
It is useful for other commands also.  Let's think of its common usage .

I think the wildcard operation as below:

1. sends a command with all wildcard TerminationID

2. response for each wildcarded TerminationID

TransactionReply {
		TransactionID ,
		ActionReply {
  			ContextID ,
			CommandReply {
				TerminationID,............
				TerminationID, ...........
				TerminationID, ........... ( the following parameters may be different)
					}
In this kind of  reply , TerminationID standars for wildcarded Termination case,
The following parameters may be different.

3. Union Reply

TransactionReply {
		TransactionID,
		ActionReply {
			ContextID ,
			CommandReply {
				 * , .................( the following parameters should be the same)
					}
In this kind of reply , the TerminationID is * , standards for all TerminationID,
but the result must be the same.

My question is, if the following parameters are different. how can the reply be united ?

Regards,
Xiuping Qiu
_______________________________________________

Xiuping Qiu
Huawei Technologies Co., Ltd.
Mail to   [email-masked]
Visit     http://www.huawei.com.cn
_______________________________________________

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jan 2000 11:58:46 -0500

I think I dealt with this in a prior reply.  If it's still not
clear, ask again.

Brian

> -----Original Message-----
> From: Qiu Xiuping [mailto:[email-masked]]
> Sent: Thursday, January 20, 2000 9:14 AM
> To: [email-masked]
> Subject: Wildcard Response
> 
> 
> The only useful wildcard operation for AuditValue seems to be 
> a wildcard audit of the packages. MGC can send a wild card 
> AuditValue command having TerminationId as * and 
> AuditDescriptor having only one
> audit item, viz Package Descriptor. In the reply, MG would 
> send a send a single reply with termination id as * and a 
> single package descriptor having the union of all the 
> packages that are supported on all
>                               TerminationID, ........... ( 
> the following parameters may be different)
>                                       }