Subject: Choosing of ephemeral / physical Termination.

From: Sachin Mittal <[email-masked]>
Date: Tue, 25 Jan 2000 19:30:30 +0530

Annex B.1 says that "The CHOOSE TerminationID $ may be used to signal to the MG
that it has to create an
ephemeral Termination or select an idle physical Termination".
How can MG determine when to create an ephemeral termination and when to choose
idle physical termination.??
What is the logic behind this decision making?

regards
-Sachin Mittal

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 26 Jan 2000 16:06:46 -0500

Generally determined by the "kind" of termination requested.
Which is in turn, easily discernable from the Media command.

However, upon reflection, I think it's not a good answer.
I'd propose that we not allow selection of a physical termination,
in which case choose is always create an ephemeral.  In particular,
the following is perfectly legal:
Context=${Add=${}}
What do you get?

Brian

> -----Original Message-----
> From: Sachin Mittal [mailto:[email-masked]]
> Sent: Tuesday, January 25, 2000 9:01 AM
> To: [email-masked]
> Subject: Choosing of ephemeral / physical Termination.
>
>

---

From: Sachin Mittal <[email-masked]>
Date: Thu, 27 Jan 2000 11:35:50 +0530

Its true that the type of termination should not be identified by looking into
the descriptor
information. Somewhere in the text this should be added that " $ if it appears
alone indicates
ephemeral termination and partial $ (ex foo$) indicates selection of a physical
termination
(a circuit within a trunk group)".

"Rosen, Brian" <[email-masked]> on 01/27/2000 02:36:46 AM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sachin Mittal/HSS)

Subject:  Re: Choosing of ephemeral / physical Termination.

Brian

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 27 Jan 2000 15:09:24 -0600

I think one could interpret Context=${Add=${}} as follows:

"Create a new context.  Allocate a terminationID and any software resources
required to hold more information about that termination when that
information is provided.  Return an error if there is any attempt to
activate a media flow before there is enough information to do so."  Not
sure why you'd do this really -- it means extra messaging to follow up.

> From: Rosen, Brian [SMTP:[email-masked]]
> Sent: Wednesday, January 26, 2000 4:07 PM

---

From: Sachin Mittal <[email-masked]>
Date: Mon, 31 Jan 2000 13:22:22 +0530

The point that "$" is for choosing ephemeral is not yet added in V14. Is it that
the discussion
is not yet complete? What about foo$ representing choose physical.

Sachin Mittal <[email-masked]> on 01/27/2000 11:35:50 AM

Please respond to [email-masked]

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 31 Jan 2000 09:15:02 -0500

I believe we have not reached consensus on this issue, so I did not
change the text.  Tom, is that your view?

Brian

> Sent: Monday, January 31, 2000 2:52 AM

---

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 31 Jan 2000 10:58:52 -0500

I don't think we are disagreeing here.  My proposed rules are clarifications
of the current situation -- if anything, they would go into an Implementor's
guide, but maybe they are obvious enough that there's no need to state them.

> From: Christian Groves [SMTP:[email-masked]]
> Sent: Monday, January 31, 2000 10:27 AM
> Cc:   Taylor, Tom-PT [CAR:B904:EXCH]
> Hello all,
> I believe that we have diverged from the first email in this thread. We
> do not need rules to determine what media and bearer is instantiated.
>
> For a physical termination a certain terminationID schema will be
> assigned by the MG. ie. /myscheme/physical/trunk/circuit
> If the MGC wanted to CHOOSE a physical termination it could either
> wildcard 'trunk' or 'circuit'.
>
> For a emphemeral terminatoion a certain terminationID schema will be
> assigned by the MG. The MGC by various means would be aware of this
> scheme.
> ie. /myscheme/euphemeral/IP
> If the MGC wanted to CHOOSE a euphemeral termination it could wilcard
> the 'IP'
>
> The 'physical' and 'ephemeral' could be anything in the the MG assigned
> scheme that would differentiate the two.
>
> If the MGC doesn't care which one then it CHOOSES on the
> 'ephemeral'/'physical' level. The MG can determine which one to return
> from ANY information in the media descriptors. This is something for the
> MG to decide, not something that needs to be specified in rules in H248
> because they'll probably change according to your application, resource
> allocation algorithms in the MG, etc. I do agree that an error should be
> returned if the MG cannot determine the terminationID.
>
> I think the scope of this is also limited to the ADD command. The ADD
> will return a fully specified terminationID which can then be referenced
> in Move, Modify, Subtract etc.
>
> Regards, Christian
>
> Tom-PT Taylor wrote:
> >
> > Right, we haven't converged yet.  I have a suggestion which may
> > resolve this, that we add these rules
> >
> > (1) If the MGC provides too little information in an Add command for
> > the MG to select the bearer type for that termination, the MG must
> > reject the command with [appropriate error].  In practice, this means
> > either that the terminationID in the command provides the necessary
> > information, or else that at least one instance of a Local or Remote
> > descriptor must be present, containing a c= line with a specified
> > nettype (or the Annex C equivalent).
> >
> > (2) If the MGC provides too little information in an Add, Move, or
> > Modify command for the MG to determine the medium to be carried in a
> > given stream, the MG must reject the command with [appropriate
> > error].  The MG has three ways to determine medium:
> >
> >  - streamID unspecified defaults to streamID=1 and medium=audio
> >  - medium has already been specified for that streamID for another
> > termination in the same context
> >  - explicit specification of medium in an m= line (or the Annex C
> > equivalent) in an instance of Local or Remote for the given streamID.
> >
> >      Sent:   Monday, January 31, 2000 9:15 AM

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 31 Jan 2000 14:39:49 -0500

Just checking my assumptions:
        For a physical termination, you want to be able to say:
                MyDS3/3/$
       meaning, you choose any DS0 you want in the 3rd DS1 of a DS3,
assuming that
         was how my MG named the DS0s (such a structure NOT being required).
Could
        I also ask for MyDS3/$/$?

        For an ephemeral termination, suppose that I knew, by discovery or
        provisioning that RTP bearers were named RTP/nnnn and ATM bearers
were
        named AAL1/nnnn/nn.  Can I Add=AAL1/0003/$, which means create an
        ephemeral for an ATM AAL1 bearer, with the MG choosing the
subchannel?

Brian

> From: Christian Groves [mailto:[email-masked]]
> >      > > How can MG determine when to create an ephemeral
> termination
> >      > > and when to choose

---

From: Sachin Mittal <[email-masked]>
Date: Tue, 1 Feb 2000 09:34:31 +0530

Christian,
if MGC is aware of patterns of such kind, then
the issues/assumptions are as mentioned by Brian
But the original point was the the appearance
of $ with NO PRE-STRING and POST-STRING attached to it.
In that case how can you figure out what to choose.
I am not in favor of looking at media descriptor, etc
because they may not appear with the ADD.
Can we say ADD is successful if there doesn't yet
exist a "star connection" in the context in which atleast
one other termination is present ???

"Rosen, Brian" <[email-masked]> on 02/01/2000 01:09:49 AM

Brian