Subject: Service Change for Ephemeral terminations.

From: Madhu Babu <[email-masked]>
Date: Wed, 12 Jan 2000 18:33:51 +0530

Hi brian, list
     I have a small query. The service change command is exchanged between MG
and MGC to bring and take terminations out of service. Does this indicate that
when its generated it implies only for the physical terminations? Assuming a
scenario where from a set of IP addresses at MG, one of the IP address is
rendered unusable (due to say hardware failure). How will this be indicated from
MG to MGC using MEGACO? Such an indication may be required in case where, MGC
specifies IP address and port numbers for ephemeral terminations.

regards

Madhubabu
Hughes Software Systems.

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 12 Jan 2000 08:24:38 -0500

It makes good sense to use the ServiceChange command in that case too.  I
expect you're really looking for a way to provide a bulk notification.  One
possibility would be to model transmission interfaces such as your NICs as
terminations -- something I've suggested before.  It would take a package
with a couple of properties:
 - type of interface
 - list of associated (i.e. supported) terminations
The behaviour of terminations supporting this package would be that aside
from the above properties the only relevant one is serviceState.

> -----Original Message-----
> From: Madhu Babu [SMTP:[email-masked]]
> Sent: Wednesday, January 12, 2000 8:04 AM
> To:   [email-masked]
> Subject:      Service Change for Ephemeral terminations.
>
> Hi brian, list

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jan 2000 08:19:15 -0500

I'd say that it would be reasonable for the MG to tell
the MGC that the ephemerals were out of service with
the ServiceChange command.  The MGC should respond with
Subtracts which will destroy the ephemerals.  An
interesting question is what else it should do.  Generally
we have avoided including in the protocol things we
deemed to be a "management" or "maintenance" function.
The issue here is that if the MGC asks for a new connection,
it might get an error. What to do?  Take the MG out of service?
Suppose there were more than one interface; it isn't
necessary to take the whole MG down.

I think that this is not a big enough problem to solve now.
The answer to the question is yes, use the ServiceChange,
the MGC will subtract the ephemerals, and the state between
the MG and MGC will be rationalized.

Brian

> From: Madhu Babu [mailto:[email-masked]]
> To: [email-masked]