Subject: Re: Comments on v13 draft

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jan 2000 12:09:50 -0500

I have had some connectivity problems while traveling, and am way
behind on comments to V13.  On the other hand, today is the day
we wish to settle the text, if at all possible.

My comments with [br] below

> -----Original Message-----
> From: John Segers [mailto:[email-masked]]
> Sent: Thursday, January 20, 2000 10:28 AM
> To: [email-masked]
> Subject: Re: Comments on v13 draft
>
>
> Harpreet,
>
> I realize that I'm not Brian, but would like to comment on some of the
> points you raise nevertheless :)
>
> Cheers,
>
> John
>
> Harpreet Singh Anand wrote:
> >
> > Hello Brian,
> >
> > Some editorial comments / issues on v13 draft:
> >
> > 1. In the v13 draft, there is no mention of audit of
> ephemeral terminations
> > (Washington Issue #1). Has this idea been dropped ?
>
> I remember the lively discussions in Washington, but only part of the
> proposed resolution (a ROOT property).  Tom and/or Brian may
> be able to
> take this one.
[br] oh boy, I forgot to put the terminationId name pattern in
the root package.  Sorry, I'll get that done today.
That allows you do audit ephemerals if the name pattern shows up.
Of course, once instantiated, you can audit an ephemeral now, the
question was whether you could do so before you instantiated one.

> > 2. SDP related:
> >
> >  - Details on the changes required in the SDP grammer
> (symbol to be used for
> > wildcard etc.) are missing.
> >
> >  - The specification should give details of the SDP fields
> (example network
> > type, media type, transport type, any
> > additional attributes) that would be used in MEGACOP.
> Similar information has
> > been provided in MGCP and is useful
> > for achieving interoperability. Similarly ATM bearer
> description in SDP should
> > also be defined (or a pointer given to
> > the relevant document).
>
> The usual mode of operation is that Brian handles the text/SDP related
> stuff and I focus on the binary.  So, again, I call upon Brian to take
> up this question.
[br] Yep, more stuff for me to do today

> > 3. For audit value what is the difference between
> ObservedEventsDescriptor and
> > EventBuffer Descriptor. Only
> > EventBuffer Descriptor should be sufficient. Similarly for
> Audit Capabilities,
> > what would be returned in
> > EventBufferDescriptor ?
>
> Yes, there's something strange here.  How about this:
>
> - When EventBuffer descriptor is included in a request from MGC to MG,
> it indicates which events the MG must detect when no Events descriptor
> is active.
> - When an MG is audited by means of AuditValue, it returns events that
> are in the buffer in ObservedEvents descriptor
> - When an MG is audited by means of AuditValue, it returns the events
> that it will detect when no Events descriptor is active in EventBuffer
> descriptor.
[br] That is correct.  You also get ObservedEvents in the Notify.
Notice that EventsDescriptor and EventBufferDescriptor both
are sent by the MGC and not changed by the MG (when you audit
them, they come back the same as when the MGC sent them).
ObservedEvents tells you what has been detected.  After you send
an Events Descriptor, the items you would see in it would be
those in that Events Descriptor.  Once one of them is detected,
those you would see would be those in the EventBuffer descriptor.
Of course there can be overlap of events in both descriptors.

>
> > 4. Section 7.3: Error Codes 466, 467: There is no need of
> sending these error
> > descriptors as these are supposed to be
> > handled by the ALF and is not an error condition.
>
> Does the ALF protect against the megaco application sending duplicate
> requests?
[br]It should ignore duplicate requests, so is not an error

> > 5. Sec 7.1.12:  Audit Descriptor: Media Descriptor has been
> removed from the
> > list of items that can be send in Audit
> > Descriptor. However, it has not been removed from the ABNF rules
> > (auditReturnParameter and auditItem).
>
> Actually, it seems that Media descriptor wasn't in the table in v12
> either.  I added it.
[br] someone tell me why you can't audit Media?  You have to be
able to do that, right?   The real thing is that you can't audit
a single stream.  You could audit Local, but that would always get
you Stream=1.

> > 6. Sec 7.1.12: Audit Descriptor: Event Buffer descriptor
> should be added to the
> > table.
>
> Yes.
>
> > 7. Sec 7.1.18: Second paragraph: "The Topology Descriptor
> precedes any commands
> > within an action. ". However
> > according to the ABNF rule, actionRequest, context
> properties can come only
> > before the first command.
>
> Uncareful use of language on my part.  Change to "The Topology
> Descriptor precedes the commands of an action." ok?
>
> > 8. Sec 7.2.5: Audit Value:  Second paragraph: "If the
> TerminationId is
> > wildcarded, only one command return is
> > generated, with the contents containing the union of the
> values of all
> > Terminations matching the wildcard.". This can be
> > rephrased as " If the command is wildcarded, ....". Same
> comment for Sec 7.2.6
>
> I think you're right.  How about "If a wildcarded response is
> requested,
> [...]"?
>
> > 9. Section 7.2.8:  " 6. Failover - sent from MG to MGC to
> indicate the primary
> > MG is out of service and a secondary
> > MG is taking over." Failover is also used by MG when the
> MGC initiates
> > switchover, in this Failover indicates that the
> > active MGC is going out of service and it is redirecting MG
> to connect to a
> > separate MGC.
>
> Absolutely right.
>
> > 10. Section 7.2.8: Summary of use of properties in the
> Service Descriptor:
> > "Profile required if terminationID is not
> > ROOT, optional otherwise". Shouldn't this be the other way
> round that is
> > "Profile required if terminationID is
> > ROOT, optional otherwise"
>
> Yes.
>
> > 11. Section 8.2.2: "If a command is marked as optional, the
> MG has the choice of
> > executing it or not, and if it does
> > execute it, it returns the Response, or Error. " This line
> should be removed.
>
> Ok.
>
> > ABNF related:
> >
> > 1. Sec 7.1.5; This section mentions that the properties can
> take a value CHOOSE.
> > But the ABNF rule parmValue does
> > not allow choose.
>
> You're right.  I'll leave it to the ABNF experts to deal with
> this.  The
> ASN.1 allows CHOOSE value to be used.
>
> > 2. Sec 7.1.7: LocalControl Descriptor: reserve has been
> defined as a parameter
> > to LocalControl Descriptor but is is
> > missing in the ABNF.
>
> You're right.  I'll leave it to the ABNF experts.  ASN.1 is fixed.
>
> > 3.  Sec 7.1.14: The new text in DigitMap Descriptor section
> explains that the
> > possible letters in the digit map string can
> > be from A to k but the same has not been reflected in the ABNF.
>
> You're right.  I'll leave it to the ABNF experts.
>
> > Regards,
> > Harpreet
> >
> > _________________________________
> > Harpreet Singh Anand
> > Ficon Technology
> > E-mail :  mailto:[email-masked]
> > Web    :  http://www.ficon-tech.com
>
> --
> John Segers                                  email: [email-masked]
> Lucent Technologies                                        Room HE 306
> Dept. Forward Looking Work                      phone: +31 35 687 4724
> P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

------------
Brian Rosen, Principal Engineer
Marconi (Formerly FORE Systems)
1000 FORE Drive, Warrendale, PA 15086
(724) 742-6826  mailto:[email-masked]

---

From: Chuong Nguyen <[email-masked]>
Date: Fri, 21 Jan 2000 11:40:59 -0600

> [br] Yep, more stuff for me to do today

[cnn] Since you are going to clarify SDP.  Can I do the following?
            Remote{SDP{}}
Will I get a syntax error?  I am trying to tell MG to clear out its Remote
SDP info.
I want to keep the stream but I do not know the new Remote SDP info yet.

> a single stream.  You could audit Local, but that would always get

Yes, I want to be able to audit Media for all streams down to each stream
Local and Remote Descriptors.
This will allow MGC to rebuild any database that it needs for each context
after MGC somehow
lost these info.
Are you saying that one can audit Media for a streams but one can't specify
a specific stream to
audit?

thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****