Subject: Re: Completion Event for signal timeout

From: Tom-PT Taylor <[email-masked]>
Date: Sun, 23 Jan 2000 19:56:39 -0500

If it's an optional parameter for signals it makes life a lot easier -- you
can say exactly which signal you want to get the report for with no fuss.

> -----Original Message-----
> From: Rosen, Brian [SMTP:[email-masked]]
> Sent: Friday, January 21, 2000 5:44 PM
> To:   [email-masked]
> Subject:      Completion Event for signal timeout
>
> It has been suggested that we have a way to find out that a signal
> (or signal list) of type TIMEOUT have an event which could be
> triggered when the timer expired.  We can generalize this to
> completion of any signal.
>
> I propose that we define an event in generic called sc, signal completion,
> which has a parameter, a list of the names of events to
> report completion.
>
> The alternative is to add syntax to signals.  I think it's better
> to make it an event - it looks like an event, acts like an event,
> it is an event.
>
> Brian

---

From: John Segers <[email-masked]>
Date: Mon, 24 Jan 2000 13:09:28 +0100

I'll second that.  If it's an event, I don't see how we can get
granularity finer than signals descriptor level.

John

> Tom-PT Taylor wrote:
>
> If it's an optional parameter for signals it makes life a lot easier
> -- you can say exactly which signal you want to get the report for
> with no fuss.
>

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: Christian Groves <[email-masked]>
Date: Tue, 25 Jan 2000 11:04:57 +0100

G'Day Tom,

I agree with this. I think it makes sense to be able to say this for
each signal.

Cheers, Christian