Subject: Re: Property types and parameter types

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 3 Jan 2000 10:20:26 -0500

I had not been aware anyone wanted "sub lists".

If we REALLY need it, we should put it in, and as you observe,
it should be the same in 12.1.2 and 12.2.

Brian

> -----Original Message-----
> From: Gunnar Hellstrom [mailto:[email-masked]]
> Sent: Wednesday, December 29, 1999 5:47 AM
> To: [email-masked]
> Subject: Property types and parameter types
> 
> 
> In the work with packages, I have hit a little inconsistency 
> that I would
> like to have clarified:
> 
> There is a difference in H.248 version 12 between the types valid for
> properties and the types valid for parameters.
> Among property types, "Lists or sub-list" and "Boolean" are 
> missing. The
> definition of Enumeration is also different: 12.1.2 Indicates "List of
> possible values" while 12.2 indicates "One of a list of 
> possible unique
> values".
> 
> I suggest that the types defined for parameters in 12.2 is 
> copied also to
> 12.1.2.
> 
> Specifically I have a need to distinguish between
> 
> 1) One value from an Enumeration. I intend to call that type 
> "Enumeration".
> 
> 2) A selection of one or more values from an Enumeration. I 
> intend to call
> that type "sub-list"
> 
> Is this according to general understanding?
> 
> Examples:
> 
> Property Call types
> Type:   Sub-list
> Possible Values:
>         fax
>         text
>         data
> Description:
> A set of enabled call types monitored for in the call type 
> discrimination
> package.
> (may be set to "fax, text" if we are only interested in 
> supporting these
> types)
> 
> 
> Property Call type
> Type: Enumeration
> Possible values:
>         fax
>         text
>         data
> Description:
> One specific call type that is selected or detected.
> ( may be set to "text" during a text conversation call )
> 
> Is it allowed to do as in the example, to enumerate the 
> possible values for
> the members in the sub-list under "Possible values" ?
> 
> 
> Regards
> Gunnar
> ______________________________________
> Gunnar Hellström
> Omnitor AB
> Alsnögatan 7, 4tr
> S-116 41 Stockholm
> Sweden
> 
> Mob +46 708 204 288
> Tel +46 8 556 002 03
> Fax +46 8 556 002 06
> Video +46 8 556 002 05
> Txt (All kinds) +46 8 556 002 05
> E-mail [email-masked]
> WWW:     http://www.omnitor.se
>

---

From: Gunnar Hellstrom <[email-masked]>
Date: Mon, 3 Jan 2000 23:22:05 +0100

We have to make up our minds here.
If Enumeration is interpreted as it is written in the info on Packages in
12.1.2, it would be allowed to select a list from the possible values.

I need that definition in a number of places, and I believe others do it
also.
Isn´t it a need to specify a number of different tones to listen for out of
a richer Enumeration or List of all defined tones? That would be a Sub-list
as I understand it.

--
In 12.2, the definition of Enumeration is more strict and allows only ONE
value out of the enumeration.

There is no definition of a Sub-list.

So, is there agreement on that the definitions from 12.2 should also be in
12.1.2 with further clarification of Sub-list from below?

Regards
Gunnar Hellstrom

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Monday, January 03, 2000 4:20 PM
> To: 'Gunnar Hellstrom'; [email-masked]
> Subject: RE: Property types and parameter types
>
>