Subject: Choose option with wild card termination name

From: Sachin Mittal <[email-masked]>
Date: Fri, 21 Jan 2000 14:30:43 +0530

Hi rayhan,list
     The Termination ID description given in the section 6.2.2 say that the
termination names can be specified which enables MG to choose a circuit
within a trunk group. The text grammar defined  for TerminatinID is as follows:

TerminationID = "ROOT" / pathNAME / "$" / "*"  and
pathNAME = ["*"] NAME *("/" / "*"/ ALPHA / DIGIT /"_" )
          ["@" pathDomainName ]

the pathNAME rule doesn't have any "$" in it which enable MG to identify that
its a wild card CHOOSE request. Can you clarify this query of mine.

regards
-Sachin Mittal

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jan 2000 14:16:55 -0500

> -----Original Message-----
> From: Sachin Mittal [mailto:[email-masked]]
> Sent: Friday, January 21, 2000 4:01 AM
> To: [email-masked]
> Subject: Choose option with wild card termination name
>
>
> Hi rayhan,list
We will have to fix this.  Anyone got a suggestion?  The big
problem is that you have to allow, but not require, hierarchical
names, so something like
pathName = ["*"] NAME *( "/" [NAME / "*" / "$") ["@" pathdomainName]
is not okay.  Just adding "$" after "/" / "*" / ALPHA is
not good, you only get to have one $.

Brian