Subject: Re: Comments on Interim AH-within-MEGACO Description

From: [email-masked]
Date: Mon, 17 Jan 2000 15:17:08 -0600

> A *much* better option is to not require AH at
> all, but instead use ESP.

Remember, this is *AH-within-megaco*, so your
objections don't really apply in this case.  Not
that I'm all that fond of this mechanism (I'm all
for cramming real IPSec down everybody's throats
for this application), but it sure beats ESP-within-
megaco.

Melinda

---

From: Michael Thomas <[email-masked]>
Date: Mon, 17 Jan 2000 14:32:45 -0800

> for this application), but it sure beats ESP-within-

Sure it does. I was aware that we were talking
about AH within MEGACO, and still find no reason
to not use an ESP header instead of an AH header.
Given AH's added complications of having to take
the immutable part of the IP header into account
for the hash, that seems like even less reason
to use AH.

Not that I think that application layer ESP is all
that great of an idea in comparison to using IPSec
either.

                Mike