Subject: Audit Descriptor and AuditValue command discrepancy

From: Sachin Mittal <[email-masked]>
Date: Mon, 17 Jan 2000 13:37:20 +0530

Hi all,
The Audit Descriptor description says it can be empty but ABNF doesn't support
that.
The Audit command description shows Audit descriptor is not optional but
auditRequest
in ABNF means it is optional.

When in AuditValue command ContextID is ALL and TerminationID is ROOT
the TransactionRequest and TransactionReply will be of the form
TransactionRequest(TransactionId {
                   ALL { AuditValue... },
                   C2 { Command ... Command } })
TransactionReply(TransactionID {
                 C1 { AuditValueToken EQUAL CtxToken ( terminationIDList / LBRKT
errorDescriptor RBRKT ) ... },
                 C2 { AuditValueToken EQUAL CtxToken ( terminationIDList / LBRKT
errorDescriptor RBRKT ) ... },
                 C3 { AuditValueToken EQUAL CtxToken ( terminationIDList / LBRKT
errorDescriptor RBRKT ) ... },
                 ...
                 ...
                 C2 { Reponse ... Response } })
How it is possible to figure out when the responses for ALL case is ending ?
Also it is specified that this case returns "List of all ContextIds" but it also
returns TerminationIds
Moreover, I think in this case any value other than empty in AuditDescriptor
should be an error.

Is my understanding correct ???

regards
-Sachin Mittal
Hughes Software Systems.

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 17 Jan 2000 13:44:50 -0500

We have been talking about this very thing.  I believe empty Audit
means send no Statistics when used in Subtract.  It's also a way
to get a no=op command if anyone wanted one.

We will fix this one way or the other.

Brian

> -----Original Message-----
> From: Sachin Mittal [mailto:[email-masked]]
> Sent: Monday, January 17, 2000 3:07 AM
> To: [email-masked]
> Subject: Audit Descriptor and AuditValue command discrepancy
>
>
> Hi all,