Subject: Re: Completion Event for signal timeout

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 24 Jan 2000 22:09:36 -0500

Does my proposal accomplish the goals?  It seems to me that it does, and
avoids a couple of problems alluded to earlier (Event Buffer).

Brian

> -----Original Message-----
> From: John Segers [mailto:[email-masked]]
> Sent: Monday, January 24, 2000 7:09 AM
> To: [email-masked]
> Subject: Re: Completion Event for signal timeout
>
>
> I'll second that.  If it's an event, I don't see how we can get
> granularity finer than signals descriptor level.
>
> John
>
> > Tom-PT Taylor wrote:
> >
> > If it's an optional parameter for signals it makes life a lot easier
> > -- you can say exactly which signal you want to get the report for
> > with no fuss.
> >
> >      -----Original Message-----
> >      From:   Rosen, Brian [SMTP:[email-masked]]
> >      Sent:   Friday, January 21, 2000 5:44 PM
> >      To:     [email-masked]
> >      Subject:        Completion Event for signal timeout
> >
> >      It has been suggested that we have a way to find out that a
> >      signal
> >      (or signal list) of type TIMEOUT have an event which could be
> >      triggered when the timer expired.  We can generalize this to
> >      completion of any signal.
> >
> >      I propose that we define an event in generic called sc, signal
> >      completion,
> >      which has a parameter, a list of the names of events to
> >      report completion.
> >
> >      The alternative is to add syntax to signals.  I think
> it's better
> >
> >      to make it an event - it looks like an event, acts
> like an event,
> >
> >      it is an event.
> >
> >      Brian
>
> --
> John Segers                                  email: [email-masked]
> Lucent Technologies                                        Room HE 306
> Dept. Forward Looking Work                      phone: +31 35 687 4724
> P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954
>

---

From: John Segers <[email-masked]>
Date: Tue, 25 Jan 2000 09:02:03 +0100

Brian,

I tried finding your proposal, but all I found was "I propose that we
define an event in generic called sc, signal completion, which has a
parameter, a list of the names of events to report completion." (in a
message you sent to the list last Friday).  Can you repost the proposal
you're talking about?

John