Subject: Re: Subtract Command with wildcard Termination Name

From: Michael Thomas <[email-masked]>
Date: Thu, 27 Jan 2000 09:07:03 -0800

Rosen, Brian writes:
 > Not a bad idea, but a little late.

   Sure, but what this says to me is that Move
   should be a proper superset of Add. If Add
   can move something from the null context,
   Move should be able to as well. Essentially,
   Add is just a macro for Move (null, ...).

   Is there some reason why restricting Move is
   a good thing?

          Mike
 >
 > Brian
 >
 > > -----Original Message-----
 > > From: Michael Thomas [mailto:[email-masked]]
 > > Sent: Thursday, January 27, 2000 11:59 AM
 > > To: Rosen, Brian
 > > Cc: 'Michael Thomas'; [email-masked]'
 > > Subject: RE: Subtract Command with wildcard Termination Name
 > >
 > >
 > > Rosen, Brian writes:
 > >  > Can't say I have a really good reason, but I think that two ways
 > >  > to do the same thing are a bad idea.
 > >
 > >    Occam's Razor: nuke Add. :-)
 > >
 > >       Mike
 > >  >
 > >  > Brian
 > >  >
 > >  > > -----Original Message-----
 > >  > > From: Michael Thomas [mailto:[email-masked]]
 > >  > > Sent: Thursday, January 27, 2000 11:45 AM
 > >  > > To: Rosen, Brian
 > >  > > Cc: [email-masked]
 > >  > > Subject: Re: Subtract Command with wildcard Termination Name
 > >  > >
 > >  > >
 > >  > > Rosen, Brian writes:
 > >  > >  > It is legal to move a termination to a new context, but we
 > >  > >  > wanted to not allow that from null context.
 > >  > >
 > >  > >    Why is this? If you allowed it, it seems that
 > >  > >    Add would just be a subset of Move.
 > >  > >
 > >  > >         Mike
 > >  > >  >
 > >  > >  > Brian
 > >  > >  >
 > >  > >  > > -----Original Message-----
 > >  > >  > > From: [email-masked] [mailto:[email-masked]]
 > >  > >  > > Sent: Thursday, January 27, 2000 12:59 AM
 > >  > >  > > To: Rosen, Brian
 > >  > >  > > Cc: [email-masked]
 > >  > >  > > Subject: Re: Subtract Command with wildcard Termination Name
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > > Agreed that "Choose in a ContextId is create a new one".
 > >  > >  > > Does this mean that
 > >  > >  > > in MOVE $ in ContextID is allowed (Move a termination to a
 > >  > >  > > "new" context)? Or is
 > >  > >  > > it that
 > >  > >  > > $ in ContextID is only allowed in case of ADD?
 > >  > >  > >
 > >  > >  > > We need to add the following line somewhere in the text:
 > >  > >  > > "A $ in ContextID means to CREATE a new context and except
 > >  > >  > > ADD (and MOVE ??)
 > >  > >  > > it can't appear in any other command"
 > >  > >  > >
 > >  > >  > > Regarding ContextID * and $ in Subtract our thinking was:
 > >  > >  > > 1) ContextID * means "search for a termination in all
 > >  > >  > > contexts and subtract from
 > >  > >  > > it"
 > >  > >  > > 2) ContextId $ means "find the context in which the
 > >  > >  > > termination exists and
 > >  > >  > > subtract it from that context"
 > >  > >  > > By this logical meaning it seems that both are
 > > valid. But now
 > >  > >  > > we agree to what
 > >  > >  > > you say and (2) is not allowed.
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > > "Rosen, Brian" <[email-masked]> on 01/27/2000 02:38:52 AM
 > >  > >  > >
 > >  > >  > > Please respond to "Rosen, Brian" <[email-masked]>
 > >  > >  > >
 > >  > >  > > To:   [email-masked]
 > >  > >  > > cc:    (bcc: Sachin Mittal/HSS)
 > >  > >  > >
 > >  > >  > > Subject:  Re: Subtract Command with wildcard
 > > Termination Name
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > > Just sent a couple of messages that address this:
 > >  > >  > > Choose in a ContextId is create a new one
 > >  > >  > >
 > >  > >  > > Brian
 > >  > >  > >
 > >  > >  > > > -----Original Message-----
 > >  > >  > > > From: Sachin Mittal [mailto:[email-masked]]
 > >  > >  > > > Sent: Tuesday, January 25, 2000 9:38 AM
 > >  > >  > > > To: [email-masked]
 > >  > >  > > > Subject: Re: Subtract Command with wildcard
 > > Termination Name
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > > OK "*"  is allowed. Is "$" allowed ? Where MGC
 > > indicating MG
 > >  > >  > > > that choose
 > >  > >  > > >  the context  in which the given Termination exist and
 > >  > >  > > > subtract the termination.
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > > "Rosen, Brian" <[email-masked]> on 01/25/2000 08:39:42 AM
 > >  > >  > > >
 > >  > >  > > > Please respond to "Rosen, Brian" <[email-masked]>
 > >  > >  > > >
 > >  > >  > > > To:   [email-masked]
 > >  > >  > > > cc:    (bcc: Sachin Mittal/HSS)
 > >  > >  > > >
 > >  > >  > > > Subject:  Re: Subtract Command with wildcard
 > > Termination Name
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > > I think this is headed in the wrong direction.
 > > Subtract of
 > >  > >  > > wildcarded
 > >  > >  > > > contextId was explicitly allowed for,
 > >  > >  > > > among other things, the response to a
 > > ServiceChange with mass
 > >  > >  > > > out of service
 > >  > >  > > > operations pending.
 > >  > >  > > > The MGC must subtract all calls, and do it in a hurry.
 > >  > >  > > >
 > >  > >  > > > It is also useful in a wildcard Audit, with or without W-.
 > >  > >  > > >
 > >  > >  > > > So I think it is allowed, period.
 > >  > >  > > >
 > >  > >  > > > Brian
 > >  > >  > > >
 > >  > >  > > > -----Original Message-----
 > >  > >  > > > From: Tom-PT Taylor [mailto:[email-masked]]
 > >  > >  > > > Sent: Monday, January 24, 2000 10:06 AM
 > >  > >  > > > To: [email-masked]
 > >  > >  > > > Subject: Re: Subtract Command with wildcard
 > > Termiantion Name
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > > Your question has a couple of wider implications.
 > >  My first
 > >  > >  > > > reaction was to
 > >  > >  > > > say this was an error, because in principle the MGC can
 > >  > >  > > > always know which
 > >  > >  > > > context a termination is in, through audits if necessary.
 > >  > >  > > > Then I checked
 > >  > >  > > > out our audit response syntax and realized that the MGC
 > >  > >  > > > cannot determine the
 > >  > >  > > > current context of a termination if it doesn't
 > > know it already.
 > >  > >  > > >
 > >  > >  > > > I think the answer has to be that we change the production
 > >  > >  > > > auditOther to
 > >  > >  > > > include the context ID.
 > >  > >  > > >
 > >  > >  > > > e.g. auditOther = EQUAL TerminationID LBRKT
 > > CtxToken EQUAL
 > >  > >  > > ContextID
 > >  > >  > > > terminationAudit RBRKT
 > >  > >  > > >
 > >  > >  > > > Then the answer to your original question is that it
 > >  > > is an error.
 > >  > >  > > >
 > >  > >  > > >         -----Original Message-----
 > >  > >  > > > From:   Sachin Mittal [SMTP:[email-masked]]
 > >  > >  > > > Sent:   Sunday, January 23, 2000 11:56 PM
 > >  > >  > > > To:     [email-masked]
 > >  > >  > > > Subject:        Subtract Command with wildcard
 > > Termiantion Name
 > >  > >  > > >
 > >  > >  > > >         Hi!
 > >  > >  > > >      Here is a small query regarding the case
 > > where ContextID
 > >  > >  > > > is "*" and
 > >  > >  > > > Termination Name is fully-specified. Does this
 > > implies that
 > >  > >  > > > MGC intends to
 > >  > >  > > > Subtract the specific termination from
 > >  > >  > > > "whichever" context it appears in ? Or it is an
 > > error because
 > >  > >  > > > a termination
 > >  > >  > > > can
 > >  > >  > > > exist only in one context and
 > >  > >  > > > ContextID = "*" for a specific termination is an error ?
 > >  > >  > > >
 > >  > >  > > >         Regards
 > >  > >  > > > MadhuBabu
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  > >
 > >  > >  >
 > >  > >  >
 > >  > >
 > >  >
 > >  >
 > >
 >
 >

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 27 Jan 2000 12:00:48 -0500

Brian