From: Mehul Shah <[email-masked]>
Date: Wed, 12 Jan 2000 17:32:49 -0600

Hi,

(1) MGCP is based on the model, which involves Endpoint Handling and
Connection Handling whereas
     Megaco standard is based on the model, which has Terminations and
Contexts. Megaco standard
     even considers RTP/RTCP sessions as Terminations which is not the case
in MGCP protocol.

(2) Megaco has defined new messages (Message names are different) on top of
MGCP messages.

(3) Adding new features with Megaco protocol is much more simpler than with
MGCP. We have to
     manuplate only Terminations.

(4) Megaco has seperate document for packages compared to MGCP. Also Megaco
has defined more
    new packages.

(5) MGCP protocol uses UDP whereas Megaco is open for both UDP as well as
TCP.

(6) Megaco seems to be binary protocol whereas MGCP is text based protocol
(I am not sure about this).

(7) In short, Megaco standard is removing the weak points of MGCP protocol.

Please let me know if you require any other information.

Thanks and Regards,
Mehul K. Shah,
IPCell Technologies Inc.,
Richardson Dallas.

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Arvind Saxena
Sent: Wednesday, January 12, 2000 3:23 PM
To: [email-masked]
Subject:

Can any body explain the difference between MGCP and Megaco Standard ?
Thanks.
--------------------------------------------------
Arvind K. Saxena
Nortel Networks
3500 Carling Avenue
Mail Stop 043/63/F6
Nepean, Ontario K2H 8E9 (Canada)
----------------------------------------------------
Tel: 613-768-2203 (ESN: 398)
Fax: 613 768 -4069
E-Mail: [email-masked]

---

From: Cary FitzGerald <[email-masked]>
Date: Wed, 12 Jan 2000 16:46:17 -0800

I think that it would be fair to say that there has been
considerable debate as to whether most of the points below
represent strengths or weaknesses.

Rather than risk re-igniting the debate, I would refer you
to the extensive mail archive for the megaco WG.  In the
end, the WG never reached consensus on many of  the most
contentious questions.  The WG chair took an entirely
reasonable step to make certain decisions, at one point
resorting to resolving an un-resolvable technical debate by
flipping a coin (which was probably the most reasonable
thing to do at the time).  No minds were changed as a result
of the coin flip, but a specific point was called resolved
and the debate moved on (well, sort of). The end result of
all these decisions is the megaco protocol.

Development for MGCP stopped on the megaco mailing list once
the WG made the decision to proceed with megaco/H.248.
There has been considerable work on MGCP in CableLabs
(www.cablelabs.org).

Cary.

Mehul Shah wrote:

> Hi,(1) MGCP is based on the model, which involves Endpoint
> Handling and Connection Handling whereas     Megaco
> standard is based on the model, which has Terminations and
> Contexts. Megaco standard     even considers RTP/RTCP
> sessions as Terminations which is not the case in MGCP
> protocol.(2) Megaco has defined new messages (Message
> names are different) on top of MGCP messages.(3) Adding
> new features with Megaco protocol is much more simpler
> than with MGCP. We have to      manuplate only
> Terminations.(4) Megaco has seperate document for packages
> compared to MGCP. Also Megaco has defined more    new
> packages.(5) MGCP protocol uses UDP whereas Megaco is open
> for both UDP as well as TCP.(6) Megaco seems to be binary
> protocol whereas MGCP is text based protocol (I am not
> sure about this).(7) In short, Megaco standard is removing
> the weak points of MGCP protocol.Please let me know if you
> require any other information.Thanks and Regards,Mehul K.
> Shah,IPCell Technologies Inc.,Richardson Dallas.
>
>      -------------------------------------------------
>
>      Arvind K. Saxena
>      Nortel Networks
>      3500 Carling Avenue
>      Mail Stop 043/63/F6
>      ---------------------------------------------------
>

---

From: Abdallah Rayhan <[email-masked]>
Date: Thu, 13 Jan 2000 09:49:21 -0500

Nancy Greene has put a document on MEGACO vs MGCP back
in Sept 99. Interested parties could find it in,
<ftp://standards.nortelnetworks.com/megaco/docs/latest/MegacovsMGCPv1.pdf>

Abdallah Rayhan