Subject: Re: Question about Protocol Version Negaotiation

From: Tom-PT Taylor <[email-masked]>
Date: Sun, 23 Jan 2000 19:15:41 -0600

At this point our only backward compatibility mechanism is the fallback to
earlier version.

You make a good point: there is no message by which the MG can reject the
fallback.  The answer, it seems to me, is that it doesn't send one -- it
simply doesn't follow up on its original message and rejects any command the
MGC tries to send it.  If it connected to the MGC (e.g. via TCP) it breaks
the connection.

> -----Original Message-----
> From: Qiu Xiuping [SMTP:[email-masked]]
> Sent: Saturday, January 22, 2000 9:51 AM
> To:   [email-masked]
> Subject:      Question about Protocol Version Negaotiation
>
> Hi, All.
>
> In 11.3 Negotiation of Protocol Version
>
> 1. The first ServiceChange command from MG contains a version number .
> 2. MGC supports only a lower version, then the MGC sends a
> ServiceChangeReply with the lower version . 3. If the MG is unable to
> comply, it will reject the association, with Error 406 Version Not
> Supported.
>
> I wonder what command will MG use in step 3 .
> Will it be notify? but there is no EventDescriptor.
> And is it a TransactionRequest , but it is with Error code.
> IMO, error code is together with TransactionReply but not
> TransactionRequest ?
>
> And another question, I remember it says that MEGACO/H.248 will be
> compatible backwards somewhere.
> Then  if both MG and MGC use the lower version, why there  still exists
> complying problem.
>
>
> Regards,
> Xiuping Qiu
> _______________________________________________
>
> Xiuping Qiu
> Huawei Technologies Co., Ltd.
> Mail to   [email-masked]
> Visit     http://www.huawei.com.cn
> _______________________________________________

---

From: Jo Friedman <[email-masked]>
Date: Mon, 24 Jan 2000 10:33:13 -0700

I have a simple, related question. Where is the current MEGACO
protocol version identified in the spec? Seems like this is
missing.

Tom-PT Taylor wrote:

>
>
> At this point our only backward compatibility mechanism is the
> fallback to earlier version.
>
> You make a good point: there is no message by which the MG can
> reject the fallback.  The answer, it seems to me, is that it
> doesn't send one -- it simply doesn't follow up on its original
> message and rejects any command the MGC tries to send it.  If
> it connected to the MGC (e.g. via TCP) it breaks the
> connection.
>
>      ServiceChangeReply with the lower version . 3. If the MG
>      is unable to comply, it will reject the association, with
>      Error 406 Version Not Supported.
>
>      And another question, I remember it says that MEGACO/H.248
>      will be compatible backwards somewhere.
>      Then  if both MG and MGC use the lower version, why there
>      still exists complying problem.
>
>      Regards,
>      Xiuping Qiu