From: Qiu Xiuping <[email-masked]>
Date: Thu, 20 Jan 2000 19:30:32 +0800

Hi, All .

While reading MEGACO/H.248  version 13,  I meet some questions.

1. In  6.2 “ Terminations may be created which represent multiplexed bearers, “

I don't understand what multiplexed bearer mean.. Will you please give a detailed example?

2. In  6.2.4   property may be declared as "Global"

I don't know how to decalre a property as " Global", I read everything but find nothing more
about it. And  it is the same with the “ "Properties may be read-only or read/write "“ ,
there is  no  place to  declare a property to be  read-only.

3. In 7.1.8 Local and Remote Descriptors
	
 Local refers to the media received by the MG and Remote refers to the media sent by the MG.

I think this sentence is misfortune to be typo error. :-)

4 In 7.1.9 Events Descriptor

The MG shall send a Notify command to the MGC when it detects an event in the Events Descriptor.   “

If so, what is the use of  eventbuffer ?

5 In 7.2.5 AuditValue “.

If the TerminationId is wildcarded, only one command return is generated, with the contents containing the union
of the values of all Terminations matching the wildcard.  This convention may reduce the volume of data required
to audit a group of Terminations “

Will you please give me a example for union of the values of all Terminations matching the wildcard?

6. In 7.2.8 ServiceChange

Restart – indicates that service will be restored on the specified Terminations after expiration of the ServiceChangeDelayThe MG should set serviceState to "inService" upon expiry of ServiceChangeDelay

How to deal with the bad terminations ? They can not be in " inService "” of course.

7 In 8.2.2 TransactionReply

“ If the end of a command cannot be reliably determined it will return 442 Syntax Error in Transaction as the reply to the last action it can parse.”

It seems that "442 Syntax Error in Transaction" should be corrected  to be " 442 Syntax Error in Command "  :-)

8 In 8.2.3 TransactionPending

If a duplicate request is received when pending, the responder may send a duplicate pending immediately,
or continue waiting for its timer to trigger another Transaction Pending.

My question is how to determine to choose which  method?

Regards,
Xiuping Qiu
_______________________________________________

Xiuping Qiu
Huawei Technologies Co., Ltd.
Mail to   [email-masked]
Visit     http://www.huawei.com.cn
_______________________________________________

---

From: Harpreet Singh Anand <[email-masked]>
Date: Thu, 20 Jan 2000 18:01:13 +0530

Hello Qiu Xiuping,

> I don't understand what multiplexed bearer mean.. Will you please give a detailed example?

The multiplexed bearer refers to the case when there are more than one stream with explicit multiplexing method. For example an ATM AAL2 is a multiplexed bearer that can have multiple AAL2 channels within
it. For more details refer to the thread "Washington Issue 8 - Deleting Multiplexed Bearers"

> If so, what is the use of  eventbuffer ?

Event buffer is used for buffering the events specified in EventBuffer descriptor. After sending the notify for the occurence of an event which had been mentioned in the Event Descriptor, the MG starts
waiting for the events specified in the EventBuffer Descriptor (for the case when the EventBuffer flag is set to TRUE).

Till MG receives a new EventDescriptor, it will buffer occurrence of all the events that have been specified in the EventBufferDescriptor.

Thus the event buffer is used for storing the events specified in EventBuffer Descriptor and not the EventDescriptor.

> Will you please give me a example for union of the values of all Terminations matching the wildcard?

The only useful wildcard operation for AuditValue seems to be a wildcard audit of the packages. MGC can send a wild card AuditValue command having TerminationId as * and AuditDescriptor having only one
audit item, viz Package Descriptor. In the reply, MG would send a send a single reply with termination id as * and a single package descriptor having the union of all the packages that are supported on all
the terminations in the MG.

> Restart – indicates that service will be restored on the specified Terminations after expiration of the ServiceChangeDelay. The MG should set serviceState to "inService" upon expiry of ServiceChangeDelay
>

I don't think you can do much about bad terminations. If the termination is bad then it will remain OutOfSerice.

> My question is how to determine to choose which  method?

Choosing a paticular method is implementation dependent and with both the options the protocol should work without any problem. However, for the case where the TransactionPending is sent on receiving the
duplicate request, an additional TransactionPending is getting sent.

IMO, the approach of sending TransactionPending on timeout is simpler and results in less packets on the network.

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com