Subject: Re: Importance of ContextID in ServiceChange command

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 31 Jan 2000 12:47:56 -0500

I've thought about this a bit more, and I think it's wrong.  Where
ServiceChange applies to an individual termination rather than ROOT, the
sender should provide the contextID of the context in which the termination
currently exists.  This makes it easier for the other end to process the
command.

> -----Original Message-----
> From: Sachin Mittal [SMTP:[email-masked]]
> Sent: Monday, January 31, 2000 2:54 AM
> To:   [email-masked]
> Subject:      Re: Importance of ContextID in ServiceChange command
>
>
>
> Need to add this in text. Somehow missed in V14.
>
>
>
>
> Tom-PT Taylor <[email-masked]> on 01/28/2000 02:28:57 AM
>
> Please respond to Tom-PT Taylor <[email-masked]>
>
> To:   [email-masked]
> cc:    (bcc: Sachin Mittal/HSS)
>
> Subject:  Re: Importance of ContextID in ServiceChange command
>
>
>
>
> Good point.
>
> > -----Original Message-----
> > From: Sachin Mittal [SMTP:[email-masked]]
> > Sent: Thursday, January 27, 2000 4:07 AM
> > To:   [email-masked]
> > Subject:      Importance of ContextID in ServiceChange command
> >
> > HI all
> >
> > It should be mentioned somewhere in the text that there is no
> > siginificance of
> > ContextID in case of ServiceChange Command. The ServiceChange command
> > is for terminations and no validation is done on ContextID should be
> done.
>  << File: Internet HTML >>

---

From: Chuong Nguyen <[email-masked]>
Date: Mon, 31 Jan 2000 12:58:45 -0600

It will depends on the scenario.  Therefore it is an implementation
issue.  Thus it should not
be a requirement to provide contextId.
For example, what if someone wants to take a range of terminations out
of service via wildcards.
The contextId would be different for that range of terminations.

For an individual termination, it should be allowed but not mandatory.
But simplicity is better here.

Chuong

Tom-PT Taylor wrote:

> ServiceChange applies to an individual termination rather than ROOT,
> the sender should provide the contextID of the context in which the
> termination currently exists.  This makes it easier for the other end
> to process the command.
>
>      > is for terminations and no validation is done on ContextID
>      should be done.
--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****