Subject: Re: Signalling Failure

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 7 Feb 2000 10:11:50 -0500

Agreed.

We define a General Cause:
        SF - Signal Failure (0x0007)

And we allow Failure Cause to have the name of the signal.

Brian

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
> Sent: Monday, February 07, 2000 9:51 AM
> To: [email-masked]
> Subject: Re: Signalling Failure
>
>
> Yes, such an approach seems reasonable. However, the general
> failure event
> (Cause in Generic I presume) then needs to be expanded a little. More
> specifically, you must be able to specify that:
> 1. You had a signal failure
> 2. Which signal actually failed
>
> -- Flemming
>
>
> Michael Brown wrote:
>
> > I agree with this approach. It has the capability to be as
> specific as
> > needed with the failure cause parameter and as Brian points
> out, it is
> > always available for all packages.
> >
> > Michael
> >
> > "Rosen, Brian" wrote:
> >
> > > I'd rather see failure with the general failure event.
> > > I don't like exceptions.  The general failure event is there
> > > for just this kind of thing - an asynchronous failure.
> > > It has no catches, it's there when you want it.
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Tom-PT Taylor [mailto:[email-masked]]
> > > > Sent: Friday, February 04, 2000 7:13 PM
> > > > To: Brian Rosen; Flemming Andreasen;
> > > > [email-masked]
> > > > Subject: Signalling Failure
> > > >
> > > >
> > > > I've solved the signalling failure problem, maybe.  I add a
> > > > parameter to the
> > > > signal completion event indicating how the signal was
> > > > terminated: timeout,
> > > > event, new signal descriptor, or failure.  The catch is that
> > > > failures are
> > > > only reported for events for which notifyCompletion is TRUE.
> > > >
> > > > Tom Taylor
> > > > Advisor -- Emerging Carrier IP Standards
> > > > E-mail: [email-masked] (internally, Tom-PT Taylor)
> > > > Phone and FAX: +1 613 736 0961
> > > >
>
> --
> ---------------------------------------
> Flemming Andreasen
> Cisco Systems
> ---------------------------------------
>

---

From: Michael Brown <[email-masked]>
Date: Mon, 7 Feb 2000 11:13:25 -0500

Or maybe we use FT or FP (as appropriate) and expand the failurecause to
allow other than Release Cause to include the signal information.

Michael