Subject: Re: Cisco SG16: Service Change

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 4 Feb 2000 15:41:48 -0500

OK if it's OK with Flemming.  I was looking at things the wrong way when I
denied symmetry.

> -----Original Message-----
> From: Rosen, Brian [SMTP:[email-masked]]
> Sent: Friday, February 04, 2000 3:33 PM
> To:   Taylor, Tom-PT [CAR:B904:EXCH]; [email-masked]
> Subject:      RE: Cisco SG16: Service Change
>
> Agreed, and is there any reason the MG can't do the same?  Requests go
> where ServiceChange says, replies go back to whom they came from.  Must
> make sure we handle failover correctly.
>
> Brian
>
>       -----Original Message-----
>       From: Tom-PT Taylor [mailto:[email-masked]]
>       Sent: Friday, February 04, 2000 3:24 PM
>       To: Rosen, Brian; [email-masked]
>       Subject: RE: Cisco SG16: Service Change
>
>
>
>       Proposal: if and only if the MG supplies a ServiceChangeAddress, it
> wants all commands directed to that address.  The MGC would continue to
> send responses back to the address the requests came from, even if this
> requires sending transaction requests in separate messages from
> transaction replies and transaction pending messages.
>
>       It's not symmetric: if the MGC supplies a ServiceChangeAddress, the
> whole association moves over to that address.
>
>               -----Original Message-----
>       From:   Rosen, Brian [SMTP:[email-masked]]
>       Sent:   Friday, February 04, 2000 11:48 AM
>       To:     Taylor, Tom-PT [CAR:B904:EXCH];
> [email-masked]
>       Subject:        RE: Cisco SG16: Service Change
>
>               Excuse me, messages don't matter, transactions do.  A
> message with one request transaction and one response transaction can, and
> most probably will, result in a different
>
>               structure in outgoing messages.  It would not be a big
> burden to have responses going
>       to a different place than transactions, although it might increase
> the number of
>       messages.
>
>       Brian
>
>                       -----Original Message-----
>               From: Tom-PT Taylor [ <mailto:[email-masked]>]
>               Sent: Friday, February 04, 2000 11:31 AM
>               To: Rosen, Brian; [email-masked]
>               Subject: RE: Cisco SG16: Service Change
>
>
>
>                       Glitch warning -- indicated change won't work.  Our
> messages can include both requests and responses, so the address to which
> messages are sent is an all or nothing decision.  I'll try to make things
> consistent with section 9.  Simplest way is by saying that
> ServiceChangeAddress should not be sent by an MG when transport is over
> IP.
>
>                               -----Original Message-----
>               From:   Rosen, Brian [SMTP:[email-masked]]
>               Sent:   Friday, February 04, 2000 9:22 AM
>               [[TomT]]  snip
>               >
>               > Section:         7.2.8 (ServiceChange), fifth last
> paragraph
>               > Category:     Technical, Editorial
>               > Issue no.:     14.8
>               > Issue:          The draft text specifies that "The MGC
> shall use this
>               > Addres, if specified, in its response to the ServiceChange
>               > command and any
>               > subequent commands and responses" and "The MG shall use
> this
>               > address for
>               > any subsequent communication with the MGC". While it makes
>               > sense to require
>               > commands to be sent to this address, it is generally not a
>               > good idea to
>               > require this for responses, e.g. for clustered systems.
> Furthermore,
>               > Section 9 (Transport) also specifies that "Responses to
>               > commands are sent
>               > back to the source address of the commands"
>               > Proposal:     It is strongly recommended, that commands
> will
>               > be sent to the
>               > address specified while responses will always be sent to
> the
>               > source address
>               > they came from.
>               > Status:
>               I agree with this.  The text is inconsistant, so something
> needs
>               to be changed.  Chip's proposal seems the most reasonable
> way
>               to resolve it
>
>
>                               [[TomT]]  snip
>

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 4 Feb 2000 15:59:27 -0500

Looks good to me.

-- Flemming

--
---------------------------------------
Flemming Andreasen
Cisco Systems
---------------------------------------