Subject: Extensibility of Commands and Descriptors

From: "Hascall \"Chip\" Sharp" <[email-masked]>
Date: Mon, 14 Feb 2000 11:10:20 -0500

Immediate feedback is appreciated.

SG116 is currently working on final text for H.248.
However, there is concern (mainly by me) about how
H.248 will be extended in v2 and if it can be extended
easily.

In particular, if megaco or SG16 wants to add a new:
        Command
        Descriptor
        flag or action in a descriptor

And new procedures to use them, can they be added
to v2 in a backward compatible way.  I believe
extensions to parameters has been handled in the packages
definition.

For example, if we find we really do need an Accumulate
action in the EventsDescriptor or a "Process" algorithm, can
the syntax be extended in a backward compatible way.

I think it can, but due to lack of sleep I can't be sure.
I would apprciate if some of you can read through the ABNF
and ASN.1 and make sure the syntax is extendable without major
pain to the parsers.

Thanks,
Chip
-------------------------------------------------------
Chip Sharp                      voice: +1 (919) 472-3121
Consulting Engineer             email:  [email-masked]
Cisco Systems                   http://www.cisco.com/
---------------------------------------------------------

---

From: Abdallah Rayhan <[email-masked]>
Date: Mon, 14 Feb 2000 11:57:56 -0500

There is difference by parsing and functional extensibility of the
protocol.
Parsing extensibility, IMO, means that can v1 parser parse v2 code ? or
vice versa ! The answer is probably NO unless there is a huge common
factor existing between the two and a parser is rewritten to parse v1
and v2.
In other words, this is an implementation issue that is beyond the scope

of the protocol.

Functional extensibility falls in our domain only if we are doing v2
which we
don't. However, the ABNF supports various flexible constructs that can
be easily extended to accommodate new commands and descriptors once
the new functionality is defined. How this new functionality would
interact
with earlier versions of the protocol is a V2 issue.

To summarize, can we extend the protocol ? Definitely we can through
ABNF additions, remember that new functionality will not change the
syntactical construction of the grammar but add new procedures, commands

and descriptors. How would that impact parsing and functional
extensibility
is beyond our mandate at this time, IMO.

Abdallah Rayhan