Subject: Re: H.248 and Megaco Last Call

From: Scott Bradner <[email-masked]>
Date: Wed, 16 Feb 2000 13:14:27 -0500

Chip sez:
> While IETF does not place restrictions on what people can or can't comment
> on, I request that people think very carefully about any substantive
> changes to the document.  Of course, if there is a broken mechanism within
> the scope of defined operation it should be fixed or if you find editorial
> problems, then they should be fixed.   If there is a new feature that you
> have to have, consider saving it for v2.

I'd like to 2nd this - we need to fix things that are broken or fuzzy
but in the interest of coming out of this process with a single standard
please don't engage in featureitis

also - as Tom suggests when it comes time to publish the RFC (standards
track I hope) we can publish the text as it comes out of the ITU with an
adendum if needed to deal with any issues that come up during megaco
or IETF last call of IESG review. The text and the adendum can be
combined in future versions of the RFC.

Scott

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 16 Feb 2000 13:48:13 -0500

I have a problem with this.

There ARE changes in the ITU document.  Functionality was
taken out, functionality was put in.  This was done without the
list - it was a small group of people at the meeting deciding what
went in and what went out.

To now say that it's frozen, no new functionality changes,
is not fair to those not at the meeting.

If IETF last call preceded the ITU meeting, and changes at that
meeting were limited to finalizing wording based on last call comments, then
you could proceed as you have outlined.  With
substantive changes accomplished at the meeting, you must allow
socialization of issues, and you must allow changes.

I don't want frivolous changes, and I don't want new features
at this time.  If ITU had stuck to that, I wouldn't have a problem.

This is irrespective of what I personally think of the changes made.

Brian

> -----Original Message-----
> From: Scott Bradner [mailto:[email-masked]]
> Sent: Wednesday, February 16, 2000 1:14 PM
> To: [email-masked]
> Subject: Re: H.248 and Megaco Last Call
>
>
> Chip sez:

---

From: Scott Bradner <[email-masked]>
Date: Wed, 16 Feb 2000 15:47:11 -0500

> is not fair to those not at the meeting.

I did not say "no changes" I said put the changes at the end not tweak the
words in the main text (i.e put a section at the end
that says "replace section 4.3 with the following")

Scott

---

From: Nancy-M Greene <[email-masked]>
Date: Wed, 16 Feb 2000 22:21:57 -0600

v16 is now available at:

ftp://standards.nortelnetworks.com/megaco/docs/latest

file names:
***NOTE THAT THE MEGACO MACRO IS TURNED OFF IN THESE FILES - that is why
***it looks like there is no IETF boiler plate in the files.

***Refresh your browser to be sure you see the files at the ftp site.

Changebarred against the Megaco/H.248 "white document", i.e. v12:
MegacoH248v16.doc
MegacoH248v16doc.zip
MegacoH248v16.PDF

As the name suggests, changebarred against v15
(=draft-ietf-megaco-protocol-06.txt):
MegacoH248v15to16diff.doc
MegacoH248v15to16doc.zip
MegacoH248v15to16.PDF

...v16 will come out as draft-ietf-megaco-protocol-07.txt shortly...

v15, v14, v13, v12 are still available if you want to look at them. They are
in
ftp://standards.nortelnetworks.com/megaco/docs/Adelaide2000

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Taylor, Tom-PT [CAR:B904:EXCH]
> Sent:         Wednesday, February 16, 2000 3:39 AM
> To:   [email-masked]
> Subject:      H.248 and Megaco Last Call
>
> At some point today we will have text for H.248 which the ITU-T will
> consider to be frozen.  I will make that text available, then we can go
> through Last Call.  Our aim will be to find the bugs and document them.
> My proposal is that the final RFC will be published unchanged from the
> ITU text, but with a must-read appendix containing our Last Call
> conclusions.
>
> The indications are very strong that the head of the U.S. delegation
> will veto the decision of H.248 on procedural grounds.  It will
> therefore be held over for decision in June.  That is why it is so
> important to keep the ITU text intact -- to let their process work
> without further delays.  They will be able to publish our Last Call
> appendix as an H.248 Implementor's Guide, which, despite the name, is
> used in the ITU-T to document bugs rather than just to give
> interpretations.
>
> In the meantime, to make the status of our protocol clear to our
> industry, I propose that we publish it as a Proposed Standard.
>
> Let me review the process we've followed in the last week and a half.
> Obviously I haven't fed back all the issues to the list as I had hoped
> -- there just wasn't time.  We've worked through supper severl nights,
> met all day and into the night last Sunday, and finally knocked the last
> open issue dead at 3:35 am yesterday morning.
>
> Here's how we proceeded.  First we went through the Telcordia and Cisco
> issues, identifying which had been fixed by TD-33 (v14) and which by
> TD-49 (v15).  The stuff which was still open had to be fixed.  Some
> fixes were done at the time, some were held over for further discussion.
>
> Next we went over the input documents themselves: TD-32 (the delta from
> the Red Bank output to v14), and TD-49 (the delta from v14 to
> v15/protocol-06).  Again problems were spotted and solutions devised.
>
> Finally we closed all the remaining open issues, finishing, as I said
> above, in the wee small hours of Tuesday morning.  The unfortunate John
> Segers then wortked through the remainder of the night to add in all the
> approved changes to produce a final document.
>
> Yesterday afternoon that document was reviewed in a final editing pass
> to catch anything John hadn't put in correctly.  Poor John was left
> holding the back in the end -- Glen and I had to go elsewhere and he was
> left to preside.  I hear they finished around 11:00 pm.  Today the
> finished document goes for approval at Working Party level, and tomorrow
> it goes up for decision, with the likely outcome as I indicated above.
>
> I would like to list the H.248 marathoners here.  To a large extent,
> they are the same people who sacrificed their sleep in Red Bank.  I hope
> I don't miss anybody, but if I do, feel free to flame me.  Here is the
> roll call of the red-eye brigade:
> John Segers                           Ranga
> Dendi                           Alf Heidemark
> Glen Freundlich                     Selvam Rengasami
> Larry Forni
> Michael Brown                     Rich Rubin
> Chip Sharp                           Christian Groves
> Steve Magnell                       Stephen Terrill
>
> Just a few statistics about the E-mail which has gotten us to that
> point.  My personal archives go back to mid-1998, and that is where the
> numbers come from.
>
> Total messages on the list to date: 5490
> Top ten correspondents:
>   Brian Rosen (no surprise): 591
>   Me                                   580
>   Nancy Greene                  198
>   Christian Huitema             187
>   Matt Holdrege                  151
>   Chip Sharp                       144
>   John Segers                        91
>   Michael Thomas                 83
>   Henry Sinnreich                  81
>   Paul Sijben                         80
>
> My archives also contain over 1800 messages from editors and the design
> team.  I don't have my own messages in there, but the counts for the top
> five other people are as follows:
>   Brian Rosen                       409
>   Nancy Greene                    294
>   Christian Huitema                 80
>   Christian Groves                  70
>   John Segers                         59
>
> My thanks to everyone.  On to the Last Call!
>
> Tom Taylor
>