Subject: Re: Non-Buffered EventHandling

From: John Segers <[email-masked]>
Date: Tue, 1 Feb 2000 10:55:15 +0100

Brian,

For clarification: is the event also processed when the MG is notifying
the MGC of aa previous event that matched the active events descriptor?

John

"Rosen, Brian" wrote:
>
> When EventBuffer is off, any Events are immediately processed against the
> current EventsDescriptor.  There is no buffering, and the EventBuffer
> descriptor
> is not used.
>
> Brian
>
> > -----Original Message-----
> > From: Bob Lukas [mailto:[email-masked]]
> > Sent: Friday, January 28, 2000 7:10 PM
> > To: [email-masked]
> > Subject: Non-Buffered EventHandling
> >
> >
> > The change in text in v14 regarding Event handling has left
> > me a little
> > confused about event handling when EventBuffer flag is off.
> > The text is
> > explicit about the EventBuffer=on case, but only says
> > "If the EventBuffer flag is off when the new Events
> > Descriptor is received,
> > the queue is flushed and no events are added to it. The
> > default state of
> > EventBuffer is off.",
> > but section 7.1.5 says
> > "The EventBuffer flag specifies whether events are buffered following
> > detection of an event in the Events Descriptor, or processed
> > immediately".
> >
> > After a Notify transaction containing ObservedEvents, what
> > happens to new
> > events detected while EventBuffer is off?
> > Are they discarded until a new Events Descriptor is received,
> > queued then
> > flushed until/when a new Events Descriptor is received, or do
> > they continue
> > to get matched and reported against the previous Events Descriptor?
> > My understanding is that new events would continue to be
> > processed as per
> > the previous Events Descriptor, correct?
> >
> > ________________________________
> > Bob Lukas
> > Broadcom Canada
> > Richmond BC
> > [email-masked]
> >

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 1 Feb 2000 09:01:31 -0500

Yes.  For this reason, MGCs should be prepared to accept more than one
event in the event descriptor, as the syntax allows.

Brian

> From: John Segers [mailto:[email-masked]]
> Sent: Tuesday, February 01, 2000 4:55 AM
> Subject: Re: Non-Buffered EventHandling
>
>
> Brian,
>