Subject: Re: Last Call

From: Nancy-M Greene <[email-masked]>
Date: Tue, 8 Feb 2000 15:19:46 -0600

I have now posted draft-ietf-megaco-protocol-06.txt to 

ftp://standards.nortelnetworks.com/megaco/docs/latest

The differences between v14 and v15 are (I expect) those outlined in Tom's
email Feb 7/2000 with subject: 
"Updates Submitted To ITU Based On Issue Scorecard". You can see the changes
by looking at the doc or pdf file.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Rosen, Brian[SMTP:[email-masked]]
> Sent:         Tuesday, February 08, 2000 3:37 PM
> To:   [email-masked]'
> Cc:   Greene, Nancy-M [CAR:5N40:EXCH]; Taylor, Tom-PT [CAR:B904:EXCH];
> 'John Segers (E-mail)'
> Subject:      draft-ietf-megaco-protocol-06
> 
> <<File: draft-ietf-megaco-protocol-06.txt>>
> Please find attached an update of the Megaco protocol draft:
> 
> This draft is a work item of the Megaco WG.
>  
>  
> Title: MEGACO Protocol 
>  
> Author(s) : F. Cuervo, B. Hill, N. Greene, C. Huitema, A. Ryahan, B.
> Rosen,
> J. Segers
> Filename : draft-ietf-megaco-protocol-06.txt
> Pages : 147
> Date : 08-Feb-2000 
> 
> Abstract:
> MEGACO defines the protocols used between elements of a physically
> decomposed multimedia Gateway consisting of a Media Gateway and a Media
> Gateway Controller.  There are no functional differences from a system
> view between a decomposed gateway, with distributed sub- components
> potentially on more than one physical device, and a monolithic gateway.
> This document does not define how gateways, multipoint control units or
> integrated voice response units (IVRs) work.  Instead it creates a gen-
> eral framework that is suitable for these applications.
> 
> Packet network interfaces may include IP, ATM or possibly others.  The
> interfaces will support a variety of SCN signaling systems, including
> tone signaling, ISDN, ISUP, QSIG, and GSM. National variants of these
> signaling systems will be supported where applicable.
> 
> The protocol definition in this document is common text with ITU Recom-
> mendation H.248.
>  
> ------------
> Brian Rosen, Principal Engineer
> Marconi (Formerly FORE Systems)
> 1000 FORE Drive, Warrendale, PA 15086
> (724) 742-6826  mailto:[email-masked] 
> 
> 
--------------------------------------------------------------------------
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Greene, Nancy-M [CAR:5N40:EXCH]
> Sent:         Tuesday, February 08, 2000 11:10 AM
> To:   [email-masked]
> Subject:      Re: Last Call
> 
> After posting, I noticed that the I-D name in v15 should say
> draft-ietf-megaco-protocol-06.txt, so I have just uploaded the files again
> with this change. The I-D itself, draft-ietf-megaco-protocol-06.txt,
> should be ready later today, and on the IETF ftp site within a day or two.
> 
> Nancy 
> --------------------------------------------------------------------------
> 
> Nancy M. Greene 
> Internet & Service Provider Networks, Nortel Networks 
> T:514-271-7221 (internal:ESN853-1077) E:[email-masked] 
> 
>       ---------- 
> From:   Greene, Nancy-M [CAR:5N40:EXCH] 
> Sent:   Tuesday, February 08, 2000 10:47 AM 
> To:     [email-masked] 
> Subject:        Re: Last Call 
> 
>       v15 is available at: 
> 
>       ftp://standards.nortelnetworks.com/megaco/docs/latest 
> 
>       file names: 
> 
>       MegacoH248v15.doc 
> MegacoH248v15doc.zip 
> MegacoH248v15.PDF 
> 
>       It has change bars against v14. v14 is
> draft-ietf-megaco-protocol-05.txt . 
> 
>       Note that v14, v13, v12 are still available if you want to look at
> them. They are in 
> ftp://standards.nortelnetworks.com/megaco/docs/Adelaide2000 
> 
>       Nancy 
> --------------------------------------------------------------------------
> 
> Nancy M. Greene 
> Internet & Service Provider Networks, Nortel Networks 
> T:514-271-7221 (internal:ESN853-1077) E:[email-masked] 
> 
>               ---------- 
> From:   Taylor, Tom-PT [CAR:B904:EXCH] 
> Sent:   Tuesday, February 08, 2000 8:11 AM 
> To:     [email-masked] 
> Subject:        Last Call 
> 
>               If Last Call is to have anything meaning at all, it must be
> conducted during 
> the present SG 16 meeting. 
> 
>               Nancy is about to put MegacoH248v15 on the site.  I invite
> Last Call 
> comments based on this version of the document.  We can recycle as
> necessary 
> to reflect decisions taken. 
> 
>               Sorry for not drawing the line in early December, when (in
> hindsight) we 
> might have done things more cleanly. 
> 
>               Tom Taylor 
> Advisor -- Emerging Carrier IP Standards 
> E-mail: [email-masked] (internally, Tom-PT Taylor) 
> Phone and FAX: +1 613 736 0961 
> 
> 
>

---

From: John Segers <[email-masked]>
Date: Thu, 10 Feb 2000 20:33:13 +0100

All,

There are a couple of comments that I want to make on the 06 draft of
the megaco protocol.

First, I noticed in the marked up Word version (MegacoH248v15) that some
of the references in section 2 are marked as ITU-only text and are not
present in the published internet draft.  I think that this is an
editing error and that the reference sections in the ITU view and in the
IETF view of the document are not supposed to differ except that the ITU
document does not need to reference RFC 2119 (the RFC explaining use of
key words such as SHALL, SHOULD, MAY, etc.).

Second, and more importantly, there is an issue with the base root
package, for which I certainly have to take part of the blame.  The text
of draft 06 contains the text that Brian proposed for the Pattern,
MaxPatterns and PatternNum properties although there was no consensus to
include this text.  The part where I messed up is that I told Brian that
I wanted to take it out in the document for the Geneva meeting of SG16,
but then I forgot to do so.

Briefly, the reason why I want it taken out is that it is not complete:
it does not address how to convey naming hierarchy information when
using the binary encoding of the protocol, and I don't believe it allows
"plug and play" operation, i.e., knowing about naming patterns does not
take away the need for provisioning.

After discussion in Geneva, the proposal in the meeting here is not to
include the properties on naming patterns.

Cheers,

John

> Nancy-M Greene wrote:
> The differences between v14 and v15 are (I expect) those outlined in
> Tom's email Feb 7/2000 with subject:
> "Updates Submitted To ITU Based On Issue Scorecard". You can see the
> changes by looking at the doc or pdf file.
>
> Nancy
>      Cc:     Greene, Nancy-M [CAR:5N40:EXCH]; Taylor, Tom-PT
>      [CAR:B904:EXCH]; 'John Segers (E-mail)'
>      Author(s) : F. Cuervo, B. Hill, N. Greene, C. Huitema, A. Ryahan,
>      B. Rosen,
>      J. Segers
>      draft-ietf-megaco-protocol-06.txt, so I have just uploaded the
>      files again with this change. The I-D itself,
>      draft-ietf-megaco-protocol-06.txt, should be ready later today,
>      and on the IETF ftp site within a day or two.
>
>      Nancy
>              Note that v14, v13, v12 are still available if you want
>      to look at them. They are in
>                      If Last Call is to have anything meaning at all,
>      it must be conducted during
>                      Nancy is about to put MegacoH248v15 on the site.
>      I invite Last Call
>      comments based on this version of the document.  We can recycle
>      as necessary
>                      Sorry for not drawing the line in early December,
>      when (in hindsight) we

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954