Subject: Re: H.248 Activity

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 11 Feb 2000 12:01:47 -0500

I would have liked the issues brought up promptly after
Washington, a draft issued before the end of the year,
and last call issued two weeks into January.  Water under
the dam.

The rest I agree with.  There is no point in deciding anything
out of Geneva.  After Last Call, it should be stable enough to
do so, but it isn't now.

Brian

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Friday, February 11, 2000 11:54 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: H.248 Activity
>
>
> Rosen, Brian writes:
>  > There is no end of gaming - i.e.. using one or another of the IETF
>  > and ITU processes to get what you want, going on at this time.
>  > Raising issues at the Geneva meeting is an example, but so is
>  > dumping a large number of issues on the list just before last call.
>
> I'm puzzled here: when would you have wanted those
> issues to be brought up? Considering there were at
> least a dozen issues out of DC which were being
> coalesced into v13, v14, and v15 when, exactly,
> would you have people comment on what the editor
> and chair decided was "rough consensus" on the
> list? We're not mind readers, after all, and it's
> certainly not unheard of that one person's idea of
> consensus doesn't match anothers when assembling
> the document. Given the number of issues, it was
> very difficult to keep track of even a subset, let
> alone every one of them.
>
>  > In my PERSONAL opinion, the IETF process must complete, and then
>  > the ITU process must accept the result.  There is no other way
>  > to allow all participants to participate in the result.  The ITU
>  > process is hampered by the ability of the people attending
> meetings to
>  > affect the outcome whatever people not in the meeting think.
>
> In my opinion, this would be the result if the ITU
> process runs the way that it is supposed to run in
> theory -- or at least close anyway. If the IETF
> last call, proposed standard, etc mechanism
> yielded a document which was stable (which seems
> pretty likely), there would be no pressure to make
> sweeping changes between the ITU white paper and
> the decision process.
>
> I am at a complete loss as to what people think
> they have to gain by deciding H.248 in Geneva now;
> it's got an ITU name, in the next while it will
> move to proposed standard in IETF, etc. It's not
> like anybody is being impeded to actually *build*
> H.248 MGC's and MG's. On the other hand, deciding
> H.248 now carries a *huge* risk that whatever is
> decided will be cast in stone, and any unfortunate
> mistakes must be kept backward compatible for time
> immemorial -- with no implementation bakeoffs, etc
> to figure out where we've made boneheaded
> mistakes. This is arguably a deficiency of the ITU
> process, but that *is* their process for better or
> worse.
>
> Are the politics of getting a document rubber
> stamped by the ITU really greater than the need
> for a stable and workable protocol? A protocol
> which collapses under its own weight due to a mad
> rush to get something out because of somebody's
> short term strategic marketing needs would not be
> in *anybody's* interest. Not even Cisco's, since
> we have a long reputation of being technology
> agnostic -- which means that we have to live with
> the result just like everybody else.
>
>               Mike
>

---

From: Stephen Terrill <[email-masked]>
Date: Fri, 11 Feb 2000 19:01:40 +0100

Hi Brian,

My concern is quite simple (and is alone the lines of what Matt Holdrige mentioned), if there is not a stable version very soon, there are other organisations (which have a need of this type of protocol) will develope their own version of the protocol as their own time table will not be met (this is used only as part of the entire system).  This will happen if there is not an indication of stablity in a short time.

I have seen that in the last couple of weeks a flourish of increased activity on the list, which sometimes makes me feel like this is going in circles.  I am not clear how this is to converge when we don´t put a stake in the ground and say "this is MEGACO".  The last call is no longer an indication to me (re SIGTRAN) and it was pointed out by Scott that RFCs can be changed or "re-cycled" (making it difficult to work out what to reference and indicates further unstability).

If decsion was delayed, there isn´t another meeting where we can update this in ITU terms before the middle of the year, and even so, what is to say that the same won´t happen here (after all, 4 months ago, we had assumed that there woudn´t be anychange out of the last meeting).  This protocol has already been in devlopement of over 16 months - too long for protocol development these days.

We have to go with the original plan and decide now.  I am somewhat suprised that this wasn´t even an issue until this thread was started, even though this has been in the planning since the Redbank meeting.

Regards,

..//Steve

PS After all the effert by a large number of people, I am rather dissapointed to find myself having to make these comments.