Subject: Re: Importance of ContextID in ServiceChange command

From: Sachin Mittal <[email-masked]>
Date: Tue, 1 Feb 2000 10:30:04 +0530

I said that because in case of Graceful and Forced whether from MG or MGC, the
MG
does not clear the context by itself and the subtract from MGC does that. So MG
has nothing to do with
contextID (Termination is specified or wildcarded). For restart the basic
assumption is that
it is sent for terminations which are out-of-service ???. And Disconnected,
Handoff, Failover
methods are for root termination.

Thus if MGC provides contextid or not doesn't matter to MG. Do you mean to say
that if
MGC provides a wrong contextid the MG will DISCARD ServiceChange just because
contextid is wrong !!! (so need of checking contextid/ no meaning of contextid
in servicechange)

In my opinion so called "implementation issues" which are in fact a MUST to
consider
for each implementation should find there way into the document.

Chuong Nguyen <[email-masked]> on 02/01/2000 12:28:45 AM

Please respond to Chuong Nguyen <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sachin Mittal/HSS)

Subject:  Re: Importance of ContextID in ServiceChange command

It will depends on the scenario.  Therefore it is an implementation
issue.  Thus it should not
be a requirement to provide contextId.
For example, what if someone wants to take a range of terminations out
of service via wildcards.
The contextId would be different for that range of terminations.

For an individual termination, it should be allowed but not mandatory.
But simplicity is better here.

Chuong

Tom-PT Taylor wrote:

>
>
> I've thought about this a bit more, and I think it's wrong.  Where
> ServiceChange applies to an individual termination rather than ROOT,
> the sender should provide the contextID of the context in which the
> termination currently exists.  This makes it easier for the other end
> to process the command.
>
>      -----Original Message-----
>      From:  Sachin Mittal [SMTP:[email-masked]]
>      Sent:  Monday, January 31, 2000 2:54 AM
>      To:    [email-masked]
>      Subject:       Re: Importance of ContextID in ServiceChange
>      command
>
>
>      Need to add this in text. Somehow missed in V14.
>
>
>
>      Tom-PT Taylor <[email-masked]> on 01/28/2000 02:28:57
>      AM
>
>      Please respond to Tom-PT Taylor <[email-masked]>
>
>      To:   [email-masked]
>      cc:    (bcc: Sachin Mittal/HSS)
>
>      Subject:  Re: Importance of ContextID in ServiceChange command
>
>
>
>      Good point.
>
>      > -----Original Message-----
>      > From: Sachin Mittal [SMTP:[email-masked]]
>      > Sent: Thursday, January 27, 2000 4:07 AM
>      > To:   [email-masked]
>      > Subject:      Importance of ContextID in ServiceChange command
>      >
>      > HI all
>      >
>      > It should be mentioned somewhere in the text that there is no
>      > siginificance of
>      > ContextID in case of ServiceChange Command. The ServiceChange
>      command
>      > is for terminations and no validation is done on ContextID
>      should be done.
>       << File: Internet HTML >>
>
--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 1 Feb 2000 10:17:16 -0500

The phrasing I put in my message "Issue Scorecard" was that the MGC "should"
send the right contextID when a single termination is involved, implying
that the MG could not count on it, but might be able to use it to speed up
processing.

> Sent: Tuesday, February 01, 2000 12:00 AM