Subject: some comments on Appendix A of megaco : Example call flows

From: [email-masked]
Date: Wed, 2 Feb 2000 00:09:16 +0100

Although this appendix is only an example I found it very useful as i went through the megaco protocol.
Here are some errors (at least I believe they are errors!) in the text that might be worth it if corrected...

3- In the description of the local control descriptor and in the ds0 package "ec" is supposed to be a boolean.

16- Add A5555 should be added between context = 5000 and Add = A5556....

18- MG2 notifies the MGC that it has detected event 1234. But Event 1234 has not been defined. It should be defined in 15:

context = $
Add = A5555 { Media {
            Stream = 1 {
                               Local Control { mode = Send Receive} }
            event 1234 {al/of}
            signals {al/ri}...........

18- Fom MGC to MG2 A5555 is modified so that upon detection of a al/on signal ringing is turned off. I guess the same command should be sent to A4444

Hope I have understood the example.
Ameneh

---

From: Nancy-M Greene <[email-masked]>
Date: Wed, 2 Feb 2000 22:28:25 -0500

Ameneh,
thanks for your comments - my comments are below.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:
> [email-masked][SMTP:[email-masked]]
> Sent:         Tuesday, February 01, 2000 6:09 PM
> To:   [email-masked]
> Subject:      some comments on Appendix A of megaco : Example call flows
>
> 3- In the description of the local control descriptor and in the ds0
> package "ec" is supposed to be a boolean.
[Nancy]
Actually, this is an error in the ds0 package (in v14, section E.13.1). I
would have thought that the MGC would want to be able to specify the echo
cancellation algorithm to use. If so, then "on" in that package should be
replaced with "g165", and any other echo cancellation algorithms that might
be used need to be listed.

> 16- Add A5555 should be added between context = 5000 and Add = A5556....
[Nancy]
Yes in step 16,
   Context = 5000 {
      Add = A5556{
should be
   Context = 5000 {
      Add = A5555,
      Add = A5556{
end of chg.

> 18- MG2 notifies the MGC that it has detected event 1234. But Event 1234
> has not been defined. It should be defined in 15:
>
> context = $
> Add = A5555 { Media {
>             Stream = 1 {
>             events = 1234 {al/of},
[Nancy]
Yes, the above change needs to be made to step 15.

> 18- Fom MGC to MG2 A5555 is modified so that upon detection of a al/on
> signal ringing is turned off. I guess the same command should be sent to
> A4444
[Nancy]
It is there actually - see step 19 - in the Modify to A4444, the line
Signals {} stops ringback.

> Hope I have understood the example.
Nancy