Subject: ABNF

From: Chuong Nguyen <[email-masked]>
Date: Wed, 9 Feb 2000 08:28:24 -0600

Hi

terminationAudit = auditReturnParameter *(COMMA auditReturnParameter)

; at-most-once except errorDescriptor
auditReturnParameter = (mediaDescripto/......statisticaDescriptor/....)

Is the "at-most-once" implying the following?

Subtract=t123{Statistics{......}} and

not Subtract=t123{Statistics{...}, Statistics{...}, Statistics{....}}

That is in general wherever the ABNF shows a combination of the above
statements,
the intend is that the command would not have the same descriptor more
than once in the command.
Also in the above statements, only errorDescriptor can be included more
than once in the
command.

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Abdallah Rayhan <[email-masked]>
Date: Wed, 9 Feb 2000 11:09:29 -0500

Your interpretation is correct on both issues. The reason
errorDescriptor can
appear more than once is that a command can contain several descriptors
of
different types and each time one is in error, it would need a
corresponding
errorDescriptor. "In error" means something like stats are lost or no
stats to
report, modem is faulty or whatever. In short, rather than failing the
whole
command, you allow the descriptor to fail and collect all possible other
audit
info about the termination.

Abdallah

Chuong Nguyen wrote:

> auditReturnParameter =
> (mediaDescripto/......statisticaDescriptor/....)
>
> Also in the above statements, only errorDescriptor can be included
> more than once in the
> command.
>
> Thanks
> Chuong
>
> --