Subject: E.13.1 echo cancellation

From: Nancy-M Greene <[email-masked]>
Date: Thu, 3 Feb 2000 10:52:59 -0500

Errata in v14 E.13.1:
Instead of just allowing Echo Cancellation to be  "on", or "off", we need to
allow these possibilities:

Permanently enabled: "on"
Permanently disabled: "off"
Enabled but conformant to G.165/G.168: "g165"
Enabled but conformant to G.164: "g164"

Default is "g165".

Here is the text to be changed in E.13.1 (in blue, if you see it):

E.13.1  Properties
Echo Cancellation
                PropertyID: ec (0x0008)
                By default, the telephony gateways always perform echo
cancellation according to
                G.165/G.168. However, it is necessary, for some calls, to
turn off these operations.
                Type: enumerated
                Possible Values:
                                "on" (when the echo cancellation is
permanently enabled and will disregard any
                                incoming tones)
                                "g165" (when ec is according to G.165/G.168:
ec is on, but will turn
                                itself off when it sees a 2100Hz tone with
phase reversal (i.e. a CED fax tone, or an
                                ANS modem tone)
                                "g164" (when ec is according to G.164)
                                "off" (when it is turned off.)
                                The default is "g165".
        Defined In: LocalControlDescriptor
        Characteristics: read/write

Nancy

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Roy Spitzer <[email-masked]>
Date: Wed, 9 Feb 2000 14:11:36 -0500

Nancy,

There seems to be a terminology problem here.  G.165 and G.168 are echo
cancellation algorithms.  G.164 is an echo suppressor algorithm.  In general
echo cancellators are better than echo suppressors.  Only older style
equipment uses echo suppressors and it only works well for half duplex
communications.  If ec were defined as echo cancellation/echo suppression,
the text is correct.  There does not appear to be an application where echo
suppression and echo cancellation would be simultaneously active.

Regards,
Roy

Roy Spitzer                              Telogy Networks
Phone: 301-515-6531                20250 Century Blvd.
FAX:    301-515-7954                Germantown, MD 20874
email:  [email-masked]

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Thursday, February 03, 2000 10:53 AM
To: [email-masked]
Subject: E.13.1 echo cancellation

Errata in v14 E.13.1:

Default is "g165".

E.13.1  Properties
Echo Cancellation

        PropertyID: ec (0x0008)
By default, the telephony gateways always perform echo cancellation
according to
G.165/G.168. However, it is necessary, for some calls, to turn off these
operations.
Type: enumerated
Possible Values:

        "on" (when the echo cancellation is permanently enabled and will
disregard any
incoming tones)
"g165" (when ec is according to G.165/G.168: ec is on, but will turn
itself off when it sees a 2100Hz tone with phase reversal (i.e. a CED fax
tone, or an
ANS modem tone)
"g164" (when ec is according to G.164)
"off" (when it is turned off.)
The default is "g165".

Nancy

---

From: Nancy-M Greene <[email-masked]>
Date: Wed, 9 Feb 2000 14:41:18 -0600

Hi Roy,
G.165/G.168 is one option, and G.164 is a second option (or you choose to
simply put echo cancellation "on", or you turn it off with "off"), but you
never have more than one of these options. G.164 is there as an "older
version" of echo cancellation, for backwards compatible reasons. We could
change the text explaining ec to be as you say, echo cancellation/echo
suppression, but I don't know whether it is worth it.

Nancy
-------
Nancy M. Greene

> ----------
> From:         Roy Spitzer[SMTP:[email-masked]]
> Sent:         Wednesday, February 09, 2000 2:11 PM
> Subject:      Re: E.13.1 echo cancellation
>
> Nancy,
>

---

From: Chip Sharp <[email-masked]>
Date: Sat, 12 Feb 2000 17:49:32 -0500

>suppression, but I don't know whether it is worth it.

I don't know why anyone would build a MG with a G.164 echo suppressor.
G.165 has been out for ages.
My vote is to have ec equal ON or OFF and provide text that states that
this parameter is used to control echo cancellers and older echo
suppressors.  Or better yet, call it echo control.  It looks like you want
a way to turn on echo control and then let it be disabled in-band.  It
would then need a third option of STAYON.

>----------  From:   Roy
>Spitzer[SMTP:[email-masked]]  Sent:   Wednesday, February 09, 2000
>2:11 PM  To:     [email-masked]  Subject:        Re:
>E.13.1 echo cancellation
>
>Nancy,
>
>There seems to be a terminology problem here.  G.165 and G.168 are
>echo  cancellation algorithms.  G.164 is an echo suppressor algorithm.  In
>general  echo cancellators are better than echo suppressors.  Only older
>style  equipment uses echo suppressors and it only works well for half
>duplex  communications.  If ec were defined as echo cancellation/echo
>suppression,  the text is correct.  There does not appear to be an
>application where echo  suppression and echo cancellation would be
>simultaneously active.
>
>Regards,  Roy
>
>Roy Spitzer                              Telogy Networks  Phone:
>301-515-6531                20250 Century
>Blvd.  FAX:    301-515-7954                Germantown, MD
>20874  email:  [email-masked]
>
>-----Original Message-----  From: Nancy-M Greene
>[<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Thursday, February 03, 2000 10:53 AM  To:
>[email-masked]  Subject: E.13.1 echo cancellation
>
>
>
>Errata in v14 E.13.1:  Instead of just allowing Echo Cancellation to
>be  "on", or "off", we need to  allow these possibilities:
>
>Permanently enabled: "on"  Permanently disabled: "off"  Enabled but
>conformant to G.165/G.168: "g165"  Enabled but conformant to G.164: "g164"
>
>Default is "g165".
>
>E.13.1  Properties  Echo Cancellation
>
>         PropertyID: ec (0x0008)  By default, the telephony gateways
> always perform echo cancellation  according to  G.165/G.168. However, it
> is necessary, for some calls, to turn off these  operations.  Type:
> enumerated  Possible Values:
>
>         "on" (when the echo cancellation is permanently enabled and
> will  disregard any  incoming tones)  "g165" (when ec is according to
> G.165/G.168: ec is on, but will turn  itself off when it sees a 2100Hz
> tone with phase reversal (i.e. a CED fax  tone, or an  ANS modem
> tone)  "g164" (when ec is according to G.164)  "off" (when it is turned
> off.)  The default is "g165".
>
>         Defined In: LocalControlDescriptor          Characteristics:
> read/write
>
>Nancy
>
 > Nancy M. Greene  Internet & Service Provider Networks, Nortel
>Networks  T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

Support NetAid!  http://www.netaid.org
--------------------------------------------------
Chip Sharp                 Consulting Engineering
Cisco Systems              Telco Bio-region
Reality - Love it or Leave it.
--------------------------------------------------

---

From: Nancy-M Greene <[email-masked]>
Date: Sun, 13 Feb 2000 21:44:04 -0500

I would like ec to have values "on" "off" and "g165". "on" means turn on
echo cancellation and don't turn it off no matter what tones you see, and
"g165" means turn on echo cancellation, but turn it off if you see tones
such as those specified in G.165/G.168.

This is what I have already proposed. I also proposed  the "g164" option. If
no one sees a need for it, then that one can be removed.

Nancy

> ----------
> From:         Chip Sharp[SMTP:[email-masked]]
> Sent:         Saturday, February 12, 2000 5:49 PM

---

From: Jerry Skene <[email-masked]>
Date: Mon, 14 Feb 2000 14:20:44 -0500

I may be able to clarify a few issues regarding echo canceller functionality and control.

A new ITU-T Recommendation, G.799.1, is being developed by Study Group 15, Question 21,(of which I am the Rapporteur)  on
media gateways (MG) for VOIP applications. This Recommendation states that G.168 echo cancellers are to be used on all VOIP
calls.

Recommendation G.177, TRANSMISSION PLANNING FOR VOICEBAND SERVICES OVER HYBRID INTERNET/PSTN
CONNECTIONS, also recommends the use of G.168 cancellers on such calls.  G.168 is an improved version of G.165. More
information may be found at:    http://www.coherent.com/tech/g_itu.html.

G.168 cancellers can be disabled by means of in-band tones generated by modems and fax machines. An echo suppressor (not
used much anymore) can be disabled by a 2100Hz tone, whereas an echo canceller requires a 2100Hz tone with periodic phase
reversals. Canceller disable tones should now be referred to as  "G.168 disable tones".

It is not advisable to configure an echo canceller to be permanently on, even in the presence of canceller disable tone, as there
may be voiceband data traffic from modems or fax machines on the circuit. These devices  will not operate properly if the
canceller remains on. In fact, G.168 compliant cancellers cannot be configured to ignore disable tones.

It is sometimes necessary to externally disable a canceller so that the channel can pass bit-transparent data. ITU-T
Recommendation Q.55 has been released recently, that provides such a control channel to disable echo cancellers. The new
VOIP gateway recommendation G.799.1, recommends the use of Q.55 to control external echo cancellers associated with VOIP
gateways. Q.55 was developed by Question 9, Study Group 11 ( I was the editor), and Question 9  is proposing to develop an
H.248 package to carry the necessary information to control echo cancellers and other signal processing equipment supported by
Q.55. The media gateway controller (MGC) should include Q.115 echo control logic, that allows the MGC to generate the
appropriate EC control package. The MGC then sends this to the MG via H.248. If the MG contains internal ECs, these are then
enabled/disabled directly. If the MG does not contain integrated ECs but rather is associated with ECs on the individual E1/T1
trunks feeding the MG, the MG controls these by means of Q.55. Mapping between H.248 packages and Q.55 protocol data units
is done in the MG, according to the mapping protocol beign developed in G.799.1.

Echo canceller commands defined by Q.55 include: EC ON, EC OFF, and NLP ON, NLP OFF. The NLP, or Non Linear Processor,
is a component of an EC that attentuates residual echo. For some applications it may be desirable to turn only the NLP off, and
leave the canceller on.

I hope this clarifies a few things regarding echo cancellers.

Jerry Skene                    |  Tellabs, Inc.
Director,                         |  45085 University Drive
International Standards |  Ashburn, VA 20147.2745
tel:+1 703 724-7302      |  URL: www.tellabs.com
fax: +1 703 724-7202    |  email:[email-masked]