Subject: Comments on V15: ABNF related

From: Shalini Philip <[email-masked]>
Date: Fri, 11 Feb 2000 17:31:29 +0530

Hello Brian,

1. Section 7.1.5 mentions the possibility of CHOOSE wildcard as one of
the property values. However there is no provision for the same in the
ABNF.

2. Digit Map Value in the digitMapDescriptor production should be
optional.

digitMapDescriptor   = DigitMapToken EQUAL digitMapName
                       ( LBRKT digitMapValue RBRKT )

3. VersionToken is not defined.

4. DiscardToken has to be removed, since it is not used anywhere.

Regards,

Shalini Philip
Ficon Technology
E-Mail : mailto:[email-masked]
Web    : http://www.ficon-tech.com

---

From: Tom-PT Taylor <[email-masked]>
Date: Sat, 12 Feb 2000 14:00:40 -0600

Good comments.  People should verify the appropriateness of the fixes
proposed below.

> -----Original Message-----
> From: Shalini Philip [SMTP:[email-masked]]
> Sent: Friday, February 11, 2000 7:01 AM
> To:   [email-masked]
> Subject:      Comments on V15: ABNF related
>
> Hello Brian,
>
        [[TomT]]
        I believe the appropriate solution for this is to add CHOOSE to the
set of possible values of alternativeValue in Annex B.  The ASN.1 already
covers it by allowing CHOOSE in production PropertyParm.

>                        ( LBRKT digitMapValue RBRKT )
        [[TomT]]
        Based on text I just released, I would propose that a
DigitMapDescriptor is used only when the intent is to store a value against
a digit map name.  To activate a digit map, we give the name or value as a
parameter to a digit map completion event.

> 3. VersionToken is not defined.
        [[TomT]]
        Right.  Used in the ServiceChange descriptor.

> 4. DiscardToken has to be removed, since it is not used anywhere.
        [[TomT]]  Right.