Subject: Re: Cisco SG16: Streams

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 2 Feb 2000 17:09:03 -0500

The first issue appears to have been resolved by the new v14 text in 7.1.6.

With respect to the second issue, we now have the means to delete a stream
implicitly on a termination: by specifying Reserve=FALSE and empty Local and
Remote descriptors.  This meets the spirit of what Chip is asking for by
making stream creation and deletion symmetric.  Can we get rid of
Mode=delete?

> -----Original Message-----
> From: Chip Sharp [SMTP:[email-masked]]
> Sent: Tuesday, January 25, 2000 8:03 PM
> To:   [email-masked]
> Subject:      Cisco SG16: Streams
>
> Section:        7.1.4, second paragraph
> Category:       Technical
> Issue:          The draft text specifies that "A stream is identified by a
> StreamID", however there is no uniqueness requirement on the StreamID
> which
> may lead to inconsistent behaviour.
> Proposal:       Since terminations, and thereby streams, may be moved
> between
> different context, it is recommended that StreamIDs are defined to be
> unique within a MG.
>
> v13 Status:     OPEN. No new text.
>
>
> Section:        7.1.7, third paragraph
> Category:       Technical
> Issue:          The draft text specifies that "Mode set to delete is used
> to remove
> a stream from a termination". There is no mention of how to add a stream
> which would seem logical to be able to if you can delete a stream.
> Proposal:       It is recommended that text describing how streams are
> added is
> included.
>
> v13 Status:             OPEN. No text added.
>
> Support NetAid!  http://www.netaid.org
> --------------------------------------------------
> Chip Sharp                 Consulting Engineering
> Cisco Systems              Telco Bio-region
> Reality - Love it or Leave it.
> --------------------------------------------------

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 2 Feb 2000 16:41:05 -0600

What is the syntax for empty local/remote descriptor?

ABNF:
Should "localDescriptor = LocalToken LBRKT octetString RBRKT" be
             "localDescriptor = LocalToken LBRKT [octetString ] RBRKT"
or
something else?

We already have the precedence that empty audit descriptor can be
implemented by the current ABNF:
auditDescriptor = AuditToken LBRKT [auditItem *(COMMA auditItem) ] RBRKT

Chuong

Tom-PT Taylor wrote:

> With respect to the second issue, we now have the means to delete a
> stream implicitly on a termination: by specifying Reserve=FALSE and
> empty Local and Remote descriptors.  This meets the spirit of what
> Chip is asking for by making stream creation and deletion symmetric.
> Can we get rid of Mode=delete?
>
>      StreamID", however there is no uniqueness requirement on the
>      StreamID which
>      Proposal:       Since terminations, and thereby streams, may be
>      moved between
>      Issue:          The draft text specifies that "Mode set to delete
>      is used to remove
>      Proposal:       It is recommended that text describing how
>      streams are added is
>      included.
>
--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****