Subject: ServiceChangeAddress ASN.1 vs ABNF

From: Mukesh Goel <[email-masked]>
Date: Mon, 26 Jun 2000 10:55:36 -0700

Hi,

Please see the descripency in definition of ServiceChangeAddress in
ASN.1 and ABNF.

Please see the excerpt from the document.

A.2 ASN.1 Syntax Specification
------------------------------
ServiceChangeAddress ::= CHOICE
{
portNumber INTEGER(0..65535), -- TCP/UDP port number
ip4Address IP4Address,
ip6Address IP6Address,
domainName DomainName,
deviceName PathName,
mtpAddress OCTET STRING(SIZE(2)),
...
}

B.2 ABNF Specification
----------------------
serviceChangeAddress = ServiceChangeAddressToken EQUAL VALUE
VALUE = quotedString / 1*(SafeChar)

Proposed ABNF Syntax
--------------------
serviceChangeAddress = portNumber /
                       (( domainAddress / domainName )[":" portNumber]) /
                       mtpAddress / deviceName

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 27 Jun 2000 17:06:07 -0400

Anything we can do to clear up inconsistencies is good.
In this case, I think the intent is quite clear, and we
don't expect anyone to have any difficulties specifying
or interpreting a ServiceChangeAddress.

The address has to make sense in the domain of the transport
mechanism. I'm not too fond of overspecifying this kind of
thing, because it requires changes when you allow additional
transports.

Brian

> -----Original Message-----
> From: Mukesh Goel [mailto:[email-masked]]
> Sent: Tuesday, June 27, 2000 1:19 PM
> To: Rosen, Brian
> Subject: FW: ServiceChangeAddress ASN.1 vs ABNF
>
>
> Hi Brian,
>
> Sorry for sending direct mail to you again.
>
> We are going ahead with interop, but I think
> there are still issues with syntax.  Like the one I
> pointed out in the mail included below.
>
> How is ServiceChangeAddress to be interpreted.  In ASN.1
> it is clearly defined, but in ABNF it is TOKEN. How is
> this token supposed to be interpreted.
>
> We need to fix issues like these for having a successful
> interop.
>
> Regards,
> Mukesh.
>
> -----Original Message-----
> From: Mukesh Goel [mailto:[email-masked]]
> Sent: Monday, June 26, 2000 10:56 AM
> To: [email-masked]
> Subject: ServiceChangeAddress ASN.1 vs ABNF
>
>
> Hi,
>