Subject: MG Service Change w.r.t. TCP as transport

From: Mukesh Goel <[email-masked]>
Date: Mon, 26 Jun 2000 10:55:12 -0700

Hi,

Q1: Is MG allowed to include ServiceChangeAddress parameter in case of TCP
as a transport?
Q2: If answer to Q1 is yes, then is MGC supposed to establish connection
back to MG on
      the changed address?

If Q1 and Q2 hold, then MG needs to has to implement a TCP Server.  I
remember the discussion
along the line of MG implementing Server and MGC initiating connection did
not reach any
conclusion.

Any explanation on this issue would be hightly appreciated.

Regards,
Mukesh Goel
Trillium Digital Systems.

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 27 Jun 2000 08:54:26 -0400

> Q1: Is MG allowed to include ServiceChangeAddress parameter
Yes, but it would be pretty unusual.

> Q2: If answer to Q1 is yes, then is MGC supposed to establish
No, I think the MG would have to do that.

> along the line of MG implementing Server and MGC initiating
I don't think the MG needs a TCP server

Brian