Subject: Re: About Packages..

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 7 Jun 2000 22:04:29 -0400

At the MSF, we are working on a set of profiles, which we plan
to make public pretty soon.  You can see the basic outline in
my test profile on the megaco-interop list.  I think that they
will be very good examples of what a profile would look like.
At some point, we should document this in the IETF, I agree.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 5:21 PM
> To: Rosen, Brian
> Cc: SSMudholkar
> Subject: Re: About Packages..
>
>
> Brian,
>
> I agree with Brian, also the profile would define the
> terminations the MG implements in addition to the packages.
>
> While we have profile as part of the grammar, I can not
> find a profile definition and profile requirements statements
> in the megaco draft. Dont we need to come up with
> profile requirements draft? which defines how to define
> profiles and the requirements that a profile must meet
> for megaco!
>
> Abdallah
>
> "Rosen, Brian" wrote:
>
> > No one else seems to have replied to this one.
> >
> > Packages have to be implemented on the MG.  It's not something the
> > MGC decides.  The designer of the MG decides what kind of
> terminations
> > the MG will support, and implements the appropriate packages needed
> > to control that kind of termination.
> >
> > The MGC finds out what packages are implemented via the
> audit command.
> > The MGC has to be built to understand what capabilities a package
> > may have.  That is one reason for the profile mechanism - the MGC
> > can discover the profile before it accepts the MG for service.
> > The profile includes a set of packages that must be implemented.  If
> > the MGC knows how to support a device with a specific profile, by
> > implication it knows how to support terminations with the packages
> > listed in the profile.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: SSMudholkar [mailto:[email-masked]]
> > > Sent: Monday, June 05, 2000 6:37 AM
> > > To: [email-masked]
> > > Subject: About Packages..
> > >
> > >
> > > Hi ,
> > >     A newbee question.
> > >  When an MG comes up is it required that all it's
> > > physical terminations (which will be in null context )
> have to support
> > > some
> > > packages by default or all the packages it has to support will be
> > > specified
> > > by the MGC when a termination is created through ADD command.
> > >
> > > Thanks in advance
> > > -sanjeev
> > >
>

---

From: SSMudholkar <[email-masked]>
Date: Fri, 9 Jun 2000 20:33:13 +0530

Hi,
    In real world implementation ,are MGs supposed to support packages
based on a profile or can it support any set of packages ?

Any clarification on this will be helpful.
Thanks in advance
-sanjeev