Subject: Re: Choosing of ephemeral / physical Termination.

From: Hussain F Mohammad <[email-masked]>
Date: Thu, 8 Jun 2000 04:10:20 -0700

Is this issue closed??

> -----Original Message-----
> From: Chuong Nguyen [mailto:[email-masked]]
> Sent: Thursday, April 06, 2000 10:17 AM
> To: [email-masked]
> Subject: Re: Choosing of ephemeral / physical Termination.
>
>
> Tom,
>
> I was searching through the archives but I am not sure this issue was
> settled.
> Have you make a final decision on this issue yet?
> Is it reflected somewhere in the latest version of the Standard?
>
>
> Thanks
> Chuong
>
>
> On Thu, 27 Jan 2000 15:09:24 -0600, Tom-PT Taylor
> <[email-masked]> wrote:
>
> >I think one could interpret Context=${Add=${}} as follows:
> >
> >"Create a new context.  Allocate a terminationID and any
> software resources
> >required to hold more information about that termination when that
> >information is provided.  Return an error if there is any attempt to
> >activate a media flow before there is enough information to
> do so."  Not
> >sure why you'd do this really -- it means extra messaging to
> follow up.
> >
> >
> >> -----Original Message-----
> >> From: Rosen, Brian [SMTP:[email-masked]]
> >> Sent: Wednesday, January 26, 2000 4:07 PM
> >> To:   [email-masked]
> >> Subject:      Re: Choosing of ephemeral / physical Termination.
> >>
> >> Generally determined by the "kind" of termination requested.
> >> Which is in turn, easily discernable from the Media command.
> >>
> >> However, upon reflection, I think it's not a good answer.
> >> I'd propose that we not allow selection of a physical termination,
> >> in which case choose is always create an ephemeral.  In particular,
> >> the following is perfectly legal:
> >> Context=${Add=${}}
> >> What do you get?
> >>
> >> Brian
> >>
> >> > -----Original Message-----
> >> > From: Sachin Mittal [mailto:[email-masked]]
> >> > Sent: Tuesday, January 25, 2000 9:01 AM
> >> > To: [email-masked]
> >> > Subject: Choosing of ephemeral / physical Termination.
> >> >
> >> >
> >> > Annex B.1 says that "The CHOOSE TerminationID $ may be used
> >> > to signal to the MG
> >> > that it has to create an
> >> > ephemeral Termination or select an idle physical Termination".
> >> > How can MG determine when to create an ephemeral termination
> >> > and when to choose
> >> > idle physical termination.??
> >> > What is the logic behind this decision making?
> >> >
> >> > regards
> >> > -Sachin Mittal
> >> >
> >
>

Send FREE Greetings for Father's Day--or any day!
Click here: http://www.whowhere.lycos.com/redirects/fathers_day.rdct

---

From: Hussain F Mohammad <[email-masked]>
Date: Thu, 8 Jun 2000 21:48:31 -0700

Tom,
Considering a scenrio where a Residential MG supports only point-to-point calls, with only two possible termination types (one physical and other ephemeral) in a single context. Say, MG returns the ADD response without actually knowing the type of termination, there may arise a situation at later stage in the context lifecycle where the unspecified termination type turns out to be the same as the type of other terminationn in the context (physical  & physical or ephemeral & ephemeral). As MG is not capable of supporting such contexts, the only possible way out is to send service change for the terminations in the given context. But this should not have happened and the initial ADD response should have been a failure.

Any other comments
-Hussain.

--

On Thu, 8 Jun 2000 08:30:23
 Tom-PT Taylor wrote:
>Yes, as I recall Brian agreed that my interpretation was a possible one.
>
>> From:        Hussain F Mohammad [SMTP:[email-masked]]
>> Sent:        Thursday, June 08, 2000 7:10 AM

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 9 Jun 2000 08:09:06 -0500

I think that your case is a particular example of the general case where the
MGC asks the MG to do something it does not have the resources to support.
Rather than issue a ServiceChange, the MG issues an appropriate error return
to the command.  It's up to the MGC to clean up.

> From: Hussain F Mohammad [SMTP:[email-masked]]
> Sent: Friday, June 09, 2000 12:49 AM
> To:   Taylor, Tom-PT [NORSE:B901:EXCH]
> Cc:   [email-masked]
> Subject:      RE: Choosing of ephemeral / physical Termination.
>
> Tom,
> Considering a scenrio where a Residential MG supports only point-to-point
> calls, with only two possible termination types (one physical and other
> ephemeral) in a single context. Say, MG returns the ADD response without
> actually knowing the type of termination, there may arise a situation at
> later stage in the context lifecycle where the unspecified termination
> type turns out to be the same as the type of other terminationn in the
> context (physical  & physical or ephemeral & ephemeral). As MG is not
> capable of supporting such contexts, the only possible way out is to send
> service change for the terminations in the given context. But this should
> not have happened and the initial ADD response should have been a failure.
>
>
> Any other comments
> -Hussain.
>
> --
>