Subject: FW: Question about H.248 Add command

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 15 Jun 2000 09:21:25 -0400

The question raised here may be of interest to the list.

> -----Original Message-----
> From: Taylor, Tom-PT [NORSE:B901:EXCH]
> Sent: Wednesday, June 14, 2000 10:16 PM
> To:   [email-masked]'; ISC_DeviceControl
> Subject:      RE: Question about H.248 Add command
>
        [PTT]  It would have been quite reasonable to post this to the
Megaco list.
        The ways I can think of to underspecify Events and Signals
descriptors
        are fairly devious.  On the other hand, if the Add command doesn't
have
        an Events descriptor at all, I would find it reasonable for the MG
to
        return the last value set for that descriptor, since that would
remain
        the current value.  The same logic would apply for Signals, except
that
        I doubt a termination in the null context would have any signals
set.
        Thinking this through, it occurred to me that an auditValue of a
Signals
        descriptor at any time could be misleading, because it wouldn't be
clear
        which signals had already completed.

        All in all you've identified a rather murky area, not completely
thought
        out.  May I have permission to repost this exchange to the Megaco
list?

                -----Original Message-----
        From:   [email-masked] [SMTP:[email-masked]]
        Sent:   Wednesday, June 14, 2000 3:25 PM
        To:     ISC_DeviceControl
        Subject:        Question about H.248 Add command

                I wasn't sure whether to post this to the Megaco list, but I

        thought I would try here first.

                In the H.248 draft (draft-ietf-megaco-protocol-08.txt),
        section 7.2.1 describes the Add command. The last
        paragraph of that section is as follows:

                   All descriptors that can be modified could be returned by
MG
        if a
           parameter was underspecified or overspecified.  ObservedEvents,
           Statistics, and Packages, and the EventBuffer Descriptors are
           returned only if requested in the AuditDescriptor.  Add SHALL NOT
be
           used on a Termination with a serviceState of "OutofService".

                First, the language "could be returned" seems a little too
        loose, but this isn't the forum to address that.  My real
        question is that there are a number of other descriptors
        that can be returned: EventsDescriptor, SignalsDescriptor,
        DigitMapDescriptor.  Are these returned with an under-
        or over-specified parameter? Or only if there was an
        embedded AuditDescriptor in the command? If, for example,
        the EventsDescriptor parameter was overspecified, would
        the MG then return the EventsDescriptor as being the
        event it chose to satisfy the overspecification?

                Regards,
        David Franklin
        Principal Software Engineer
        Natural MicroSystems Corp.
        [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 16 Jun 2000 10:06:19 -0400

I think the intention is really clear.  If the language is
unclear, we can work on it in subsequent editions.

When you get a reply, the descriptors you get are determined
by:

Any under/over specification of a descriptor mentioned in
the command

Something you ask for by using the Audit descriptor.

You don't get any descriptors that aren't in one of those
two categories.  Whenever you under/overspecify a
descriptor, you get the value the MG settled on in the
reply.  If you include an audit, you get the descriptors
you asked for.

It does occur to me that we should state that if you do
both - i.e. underspecify a descriptor AND ask for it
in the Audit descriptor, then you only get one copy of
it in the return.

So, David's example of overspecifying Events would
result in the EventsDescriptor being returned.
If the command does not specify an EventsDescriptor,
the only way you get one returned is to ask for it
with AuditDescriptor.

Since the MG is not synchronous with the MGC, returning
Events and Signals descriptors is always dicey.
Events could occur at any time, and we don't specify,
and don't want to specify, exactly how the MG responds
when an event (or completion of a signal) occurs near
to when a reply containing the event (or signal)
is constructed.

Brian

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Thursday, June 15, 2000 9:21 AM
> To: [email-masked]
> Subject: FW: Question about H.248 Add command
>
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 16 Jun 2000 10:11:46 -0400

I have always assumed without thinking about it that an audit of the Signals
descriptor would return whatever the MGC last set there.  Is this how other
people see it?

> From: Rosen, Brian [SMTP:[email-masked]]
> Sent: Friday, June 16, 2000 10:06 AM
> To:   Taylor, Tom-PT [NORSE:B901:EXCH];
> [email-masked]