Subject: Binary encoding for SDP?

From: Naren Tulpule <[email-masked]>
Date: Mon, 5 Jun 2000 17:01:29 -0700

Hi,
  in annex A of draft-ietf-megaco-protocol-08.txt (5/2/2000); binary
encoding for LocalRemoteDescriptor is given as below. I am having
difficulties in relating this to the text encoding (annex B) where local and
remote descriptors are octetstrings (representing SDP description).
  Can anyone clarify what goes in a property group and a propertyParm?

   LocalRemoteDescriptor ::= SEQUENCE
   {
        propGrps        SEQUENCE OF PropertyGroup,
        ...
   }

   PropertyGroup ::= SEQUENCE OF PropertyParm
where
  PropertyParm ::= SEQUENCE
   {
        name            PkgdName,
        value           SEQUENCE OF OCTET STRING,
        extraInfo       CHOICE
                {
                        relation        Relation,
                        range           BOOLEAN
                } OPTIONAL

   }
   PkgdName ::= OCTET STRING(SIZE(4))

-- Naren.
Narendra C. Tulpule
SMTS, Trillium Digital Systems Inc
12100 Wilshire Bl #1800 LA CA 90025
Ph:  +1-310-442-9222
Fax: +1-310-442-1162

---

From: Christian Groves <[email-masked]>
Date: Tue, 6 Jun 2000 11:34:41 +1000

G'Day Naren,

A PropertyGroup could be seen as a Single Session Description,
PropertyParm are the parameters of that description. Thus the
PropertyGroup allows multiple SessionDescriptions to be sent in one
command. The PropertyGroup is a way delimiting different
SessionDescriptions in the binary version of the protocol. In the text
protocol the "v=" gives you this same functionality.

Cheers, Christian