Subject: The difference between MGCP & MEGACO

From: 전형준 <[email-masked]>
Date: Tue, 27 Jun 2000 22:51:22 +0900

i'm preparing to implement mgc and mg which supports mgcp, because, as i know,
megaco is not yet fixed as an standard.
but we still want to design the mgcp supporting mgc and mg easily migrate to support megaco.

so i investigated the differences, cons & pros between those two protocols.
i found that mgcp only defines text encoding, but megaco guides to mgc support text and binary
encoding. the gateway control commands look similar(only a few differences in their names and
syntax). megaco supports tcp (i think it's for binary encoding.).

is there anybody who can explain the other differences between mgcp and megaco?
and could you advise me how to design mgcp mgc and mg to easily move to megaco supporting systems?

thanks in advance!

---

From: Chip Sharp <[email-masked]>
Date: Tue, 27 Jun 2000 23:48:54 -0400

At 10:51 PM 6/27/00 +0900, =?EUC-KR?B?wPzH/MHY?= wrote:

>I'm preparing to implement MGC and MG which supports MGCP, because, as I know,
>
>MEGACO is not yet fixed as an standard.

ITU approved Recommendation H.248 a couple of weeks ago.  This is
effectively the same as the Megaco protocol.

Two drafts:
draft-ietf-megaco-protocol-08.txt
draft-ietf-megaco-errata-03.txt

have been approved for publishing as standards-track RFCs and are on the
RFC editor's queue.  They will have Proposed Standard status in IETF (not
Standard yet).

Chip

>But we still want to design the MGCP supporting MGC and MG easily migrate
>to support MEGACO.
>
>
>
>So I investigated the differences, cons & pros between those two protocols.
>
>I found that MGCP only defines text encoding, but MEGACO guides to MGC
>support text and binary
>
>encoding. The gateway control commands look similar(Only a few differences
>in their names and
>
>syntax). MEGACO supports TCP (I think it's for binary encoding.).
>
>
>
>Is there anybody who can explain the other differences between MGCP and
>MEGACO?
>
>And could you advise me how to design MGCP MGC and MG to easily move to
>MEGACO supporting systems?
>
>
>
>Thanks in advance!

-------------------------------------------------------------------
Chip Sharp                 CTO Consulting Engineering
Cisco Systems
Reality - Love it or Change it.
http://www.netaid.org
-------------------------------------------------------------------