Subject: Digit Map de-activatioin.

From: Madhu Babu <[email-masked]>
Date: Mon, 19 Jun 2000 12:48:53 +0530

The digit map get activated while the events descriptor which invoked it is
active and it has not completed ( section 7.1.14.4 ).
There is some ambiguity regarding the cases where a digit map completes. The
third bullet indicates that when "an event has
been detected such that a match to a complete alternative event sequence of the
digitmap will be impossible no matter what
additional events are received", does this include events like ON-HOOK or any
other event present in the event descriptor?
If  this is not the case, what is the behavior at MG when the digit map is
active and user goes ON-HOOK, after dialling some digits?

-Madhu Babu.

---

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 19 Jun 2000 07:34:19 -0500

Forgot to copy the list.

> -----Original Message-----
> From: Taylor, Tom-PT [NORSE:B901:EXCH]
> Sent: Monday, June 19, 2000 8:33 AM
> To:   [email-masked]
> Subject:      RE: Digit Map de-activatioin.
>
> Your question assumes the on-hook event has no embedded Events descriptor
> and the MGC does not react to the on-hook by providing a new Events
> descriptor.  Under those assumptions, the digit map will time out and
> report completion accordingly.
>
>       -----Original Message-----
>       From:   Madhu Babu [SMTP:[email-masked]]
>       Sent:   Monday, June 19, 2000 3:19 AM
>       To:     [email-masked]
>       Subject:        Digit Map de-activatioin.
>