Subject: Re: Termination ID in request

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 23 Jun 2000 08:26:31 -0400

> Two Queries:
>
> 1. Based on what request would an audit reply be sent with
> contextTerminationAudit?
contextAudit
For example: Context=1124 {ContextAudit{Topology}}

>
> 2. In section 7.2.7, (Notify) it is mentioned that "The
> TerminationID shall be a
> fully qualified name."
>      Does this mean that TerminationID in NotifyRequest should not be
> wildcarded?
No, you could ask that an event be looked for on a whole bunch
of terminations.  When it occurs on any of them, you get a notify,
for that one termination.  If it occurred on another, you
would get another notify.

---

From: [email-masked]
Date: Mon, 26 Jun 2000 09:30:49 +0530

Hello John,
     After reading the NOTE, the usage of TerminationIDList is clear.

     As regards the second query, it could be possible that MGC instructs MG to
detect for 'OFF HOOK" for a group of terminations (through wildcarding). MG on
detection of
"OFF HOOK" for a set of terminations (almost at the same time), can club these
Notifications and
send back Notify wildcarded!!

                                                   Regards,
                                                   R. Ezhirpavai

John Segers <[email-masked]> on 23/06/2000 18:01:08

Please respond to John Segers <[email-masked]>

To:   [email-masked]
cc:    (bcc: R Ezhirpavai/HSS)

Subject:  Re: Termination ID in request

R.,

Please see the note preceding the ASN.1 definition.  It reads "The ASN.1
specification below contains a clause defining TerminationIDList as a
sequence of TerminationIDs.  The length of this sequence SHALL be one,
except possibly when used in contextAuditResult."

1. In response to an Audit request with ContextID=* and
TerminationID=ROOT.
2. This sentence puzzles me.  If your interpretation is correct, then it
is not possible to instruct multiple terminations to listen for the same
set of events (ouch!).  Any other comments?

Cheers,

John

[email-masked] wrote:
>
> Hello,
>      AmmRequest, Subtract Request, Notify Request should have one and
> only one terminationID (which may be wildcarded) specified. Thus in ASN.1
> notation,
> these requests should not have TerminationIDList, but TerminationID.
>
> Two Queries:
>
> 2. In section 7.2.7, (Notify) it is mentioned that "The TerminationID shall be
a
>                                               Regards,
>                                               R. Ezhirpavai

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 27 Jun 2000 09:04:52 -0400

> send back Notify wildcarded!!

I believe the syntax allows this, so the MGC had better be
prepared to deal with it.  I'd be surprised if it was implemented
for off hook, but for some kind of error, it might be worthwhile.

Brian