Subject: Re: Packages extension queries.

From: Michael Brown <[email-masked]>
Date: Thu, 29 Jun 2000 18:15:29 -0400

Comments inline.

Michael

"Taylor, Tom-PT [NORSE:B901:EXCH]" wrote:

>
>
>      -----Original Message-----
>      From:   Madhu Babu [SMTP:[email-masked]]
>      Sent:   Thursday, June 29, 2000 1:36 AM
>      To:     [email-masked]
>      Subject:        Packages extension queries.
>
>      There are two packages A and B. Package B extends A,
>      Say, properties a1 and a2 are in package A and x1 in package B.
>      1) If a termination realizes package B, does it mean that it also
>      realizes
>      package A?
>      [PTT]
>      Yes.
>
>      2) Can property of package A be addressed as B/a1? If 1) is true,
>      is it that
>      only A/a1 is possible?
>      [PTT]
>      This was discussed in Red Bank when we finalized our package
>      schema, but I can't remember the conclusion.  Christian, John, or
>      Michael, do you remember?
>

I remember that the answer (consensus) was that the preferable way to
refer to a1 is as B/a1. One could use A/a1, because there really is only
one property defined where both names refer to it.

>
>
>      -
>      ----------------------------------------------------------------------------------------------------------------------
>
>      Lets there be third package C, which also extends A. and it also
>      defines a
>      property x1
>      3) Can a termination realize packages B and C ?
>

Well, I would say that the answer is yes that a termination COULD
realize both, but my feeling is that this situation would be due to a
poor definition of  the packages hierarchy. Given your hypothetical
description rather than a real example where this would appear to be a
desirable approach, I would think that C should extend B rather than A.

>
>      -
>      ----------------------------------------------------------------------------------------------------------------
>
>      Lets there be a third package C, which also extends A. and it
>      also defines a
>      property c1
>      A termination realizes both package B and C.
>      4) what will be value of A/a1 which is referred by both B/a1 and
>      C/a1.
>      If B/a1 value is changed is it that the value of C/a1 is also
>      changed?
>

Based on my previous two responses, C/a1 would be changed, but this
situation is one that to me would indicate that the package hierarchy
has not been properly defined. I don't think this should ever happen.

>      -Madhubabu

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 29 Jun 2000 14:41:17 -0500

> 1) If a termination realizes package B, does it mean that it also realizes
> package A?
        [PTT]
        Yes.

> 2) Can property of package A be addressed as B/a1? If 1) is true, is it
> that
> only A/a1 is possible?
        [PTT]
        This was discussed in Red Bank when we finalized our package schema,
but I can't remember the conclusion.  Christian, John, or Michael, do you
remember?
> --------------------------------------------------------------------------
> ----------------------------------------------
> Lets there be third package C, which also extends A. and it also defines a
> property x1
> --------------------------------------------------------------------------
> ----------------------------------------
> Lets there be a third package C, which also extends A. and it also defines
> a
> property c1
> 4) what will be value of A/a1 which is referred by both B/a1 and C/a1.
> If B/a1 value is changed is it that the value of C/a1 is also changed?
>
> -Madhubabu

---

From: Christian Groves <[email-masked]>
Date: Fri, 30 Jun 2000 17:10:07 +1000

G'Day Michael and Tom,

Please see my comments below marked CHG.

Cheers, Christian

Michael Brown wrote:
> >      2) Can property of package A be addressed as B/a1? If 1) is
> >      true, is it that
> >      only A/a1 is possible?
> >      [PTT]
> >      schema, but I can't remember the conclusion.  Christian, John,
> >      or Michael, do you remember?
> >
>
> refer to a1 is as B/a1. One could use A/a1, because there really is
> only one property defined where both names refer to it.

[CHG] That's what I understand.

> desirable approach, I would think that C should extend B rather than

[CHG] I'm not sure of the question or the response but to me even if two
packages B & C extend A with a property x1 then the two instances of x1
are uniquely identified by the package name B&C. The two instances of x1
could be completely different functions but (unfortunately) have the
same name.

> has not been properly defined. I don't think this should ever happen.

[CHG] I think A/al, B/al and C/al will all change because they are the
same property.