Subject: MEGACO: DigitMap - some questions

From: Nurit Shenhar <[email-masked]>
Date: Wed, 20 Dec 2000 09:14:48 +0200

Hi list

No response, so I send my questions again.

Nurit

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]]
Sent: Tuesday, December 05, 2000 2:59 PM
To: [email-masked]
Subject: MEGACO: DigitMap - some questions

Hi list

While implementing the digit map, I read again and again section 7.1.14.5
(DigitMap Procedures) and I have the following questions:

1. In which case do we send a completion event with no match? It seems that
the only possibilities are full match and partial match.

2. In small section 4 in this section, there is a discussion about the 'Z'
option. If I understand correctly, only those alternatives that has 'Z' and
matched the incoming event will stay as candidates, why then it says:
'If alternative event sequences not specifying a long duration event in the
given position remain in the candidate set after application of the
above rules, the observed event duration is treated as irrelevant in
assessing matches to them'.
?

3. And general question: Does the 'Z' means that when the event is finished
we check it's length, or it means that the alternative can be satisfies
during the event if it is long enough?

Best regards

Nurit Shenhar
AudioCodes Ltd.
Direct: +972-3-539-4155
Tel:     +972-3-539-4000
Fax:    +972-3-539-4040
email:  [email-masked]

web:    <http://www.audiocodes.com>

---

From: "Griffeth, Nancy D (Nancy)" <[email-masked]>
Date: Wed, 20 Dec 2000 09:08:31 -0500

Nurit,

I've spent some time going over the digit map processing, so I'll give you
my best shot on part 1 of
your question:

Actually, there are 3 possibilities:
UM - unambiguous match
PM - partial match
FM - full match

UM (unambiguous match) means that the gateway has received a dial string
that matches one of the dial
strings specified by the digit map.  Furthermore, getting more digits will
not give you a different match.

FM (full match) means that the gateway has received a dial string that
matches one of the dial strings specified
in the digit map; more digits might match a different string, but either a
timeout or an unmatchable digit has
been received.

PM (partial match) means not matched, in my view - in other words, some
prefix of a dial string has been
matched, but no full string, and either a timeout or a unmatchable digit has
been received.

As far as I can tell, the unmatchable digits are thrown away, because the
digit map completion event is
disabled with the result that there will be no more digit map processing.

Nancy Griffeth

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 1:15 AM
To: [email-masked]
Subject: MEGACO: DigitMap - some questions

Hi list

Nurit

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]]
Sent: Tuesday, December 05, 2000 2:59 PM
To: [email-masked]
Subject: MEGACO: DigitMap - some questions

Hi list

Best regards

Nurit Shenhar
AudioCodes Ltd.
Direct: +972-3-539-4155
Tel:     +972-3-539-4000
Fax:    +972-3-539-4040