Subject: Re: Modification of event and sig parameter ASN.1 syntax

From: Tom Taylor <[email-masked]>
Date: Thu, 7 Dec 2000 13:05:47 -0500

Do I get the impression that the ASN.1 version of Megaco is only half-defined and you want to finish the job?  I'll remark that the
existence of both binary and text-encoded versions was deemed to be a major threat to interoperability at MGC 2000.  I suppose
it's way too late now to try to persuade people to stick to text implementations?

Tom Taylor

---

From: Paddu Melanahalli <[email-masked]>
Date: Thu, 7 Dec 2000 10:38:15 -0800

Hi,
does anybody arrived at a difference matrix for the new
Megaco RFC and ITU-T draft? If so pls share with us.
Thanks
Paddu
--
                Enthusiasm
You can do anything... if you have Enthusiasm.
Enthusiasm is the yeast makes your hopes rise to the stars.
Enthusiasm is the sparkle in your eyes.
Enthusiasm   with it there is accomplishment,
                       without it there are only alibis
________________________________________________________

Paddu Melanahalli,  Cisco Systems, NSSU
Voice:(408)525 5236 Fax: (408)527 1568  Pgr:(408)788 8275
Email: [email-masked]
________________________________________________________

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 7 Dec 2000 14:09:04 -0600

Tom

Are you suggesting that for the interoperability testing we stick to just text implementations or
from now on all implementations of Megaco should be in text encoded?

Has anyone implemented an MGC that supports both text and binary?

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Troy Cauble <[email-masked]>
Date: Thu, 7 Dec 2000 17:13:37 -0500

> it's way too late now to try to persuade people to stick to text implementations?

Tom,

I'm not sure if this was directed at me, but what the hell...

I'd say it's more than "half-defined", but there are some noticeable
holes.  I would like the job to be finished, but I don't care who
does it.  (I just have to implement it.)  Richard Wu and I each made
some proposals that could be helpful earlier in this thread.

http://standards.nortelnetworks.com/scripts/wa.exe?A2=ind0012&L=megaco&F=&S=&P=409

If you want to be *really picky*, it's not fully specified in the
text encoding either.  Example: A VALUE (as part of a propertyParm
or eventOther, etc.) can be an Integer.  We know this from the
Package definition.  So how is the Integer encoded as a VALUE?
Are these all valid Integer encodings for VALUEs?

        9, 09, 17, F, 0F, 1F, 0xF, twenty-three

I'm looking for words like "decimal integer representation", or
"hexidecimal integer representation with a leading '0x'".

This issue and ASN.1 OCTET STRING issues similar to the one above
were brought up a month ago:

http://standards.nortelnetworks.com/scripts/wa.exe?A2=ind0011&L=megaco&O=A&P=6107

If "MGC 2000" refers to the February iterop, and if these issues
aren't clarified soon, binary interop will be ... interesting.

-troy