Subject: DigMap Related Questions

From: Kris Albert <[email-masked]>
Date: Tue, 5 Dec 2000 21:17:11 -0800

Hi all,
      I have few questions related to the digitmaps

 1. What is the lifespan of a digitmap on a termination? Deos it have anything  to do with what context (Null/Non-Null) termination is in when the digit map  is defined fo the termination?

   2.  On the deletion of a ephemeral termination, Is it required to remove all  the digitmap definitions, which are associated with this termination.

 3. When a parmanent termination moves to NULL Context, will it retain all  the digitmap defined on it(when it was in the context), or will it retain
 only the default(/provisioned) digitmap definitions(if any) on this  termination?

 Are DigMaps defined while termId is in Null context treated as default values  which are restored when the termIf returns to NULL context.

 Thanks in advance,

 kris

Great Gift Idea!  FREE cell phone, internet ready at Lycos Marketplace
 http://www.inphonic.lycos.com/redirect.asp?referringpage=www.lycosd1

---

From: "Taylor, Tom-PT [NORSE:B901:EXCH]" <[email-masked]>
Date: Fri, 8 Dec 2000 12:07:04 -0500

Hi.

> -----Original Message-----
> From: Kris Albert [mailto:[email-masked]]
> Sent: Wednesday, December 06, 2000 12:17 AM
> To: [email-masked]
> Subject: [MEGACO] DigMap Related Questions
>
>
> Hi all,
>  1. What is the lifespan of a digitmap on a termination? Deos
> it have anything  to do with what context (Null/Non-Null)
> termination is in when the digit map  is defined fo the termination?

[PTT]
The basic rule for digit maps specified for an individual termination or a
group of terminations is that stated in the first paragraph of section
6.2.4:
<quote>
If not provisioned otherwise, all descriptors except TerminationState and
LocalControl default to empty/"no value" when a Termination is first created
or returned to the null Context.
</quote>
Provisioned digit maps persist for the life of the termination.  Digit maps
defined on ROOT persist until deleted.

>
>    2.  On the deletion of a ephemeral termination, Is it
> required to remove all  the digitmap definitions, which are
> associated with this termination.

[PTT]
Only if they were defined for this termination alone.

>
>  3. When a parmanent termination moves to NULL Context, will
> it retain all  the digitmap defined on it(when it was in the
> context), or will it retain

[PTT] See 1. above.

>
>  Are DigMaps defined while termId is in Null context treated
> as default values  which are restored when the termIf returns
> to NULL context.

[PTT] No, because of the rule quoted above.  The rule is perhaps too broad
and should have made more exceptions, but it's done now.

---

From: Kris Albert <[email-masked]>
Date: Thu, 14 Dec 2000 04:44:27 -0800

Hi Tom and List!
I have some new queries after Tom's response. Please see the interspersed queries as Kris>.

thanks,
Kris
--

On Fri, 8 Dec 2000 12:07:04
>or returned to the null Context.

Kris> Thanks for the clarification. I have another doubt now. What happens when MGC sets a new value for a provisioned Digit map on a Termid, and later sends an empty Digit map Desc with the same name for that Termination Id ?
Assuming the physical Termination context (Null/Non-Null) is not changed during this process.
What's the expected value for that digit map if an event Descriptor is received after this ? Should the provisioned value be used or an error be returned  assuming that there is no such digit map defined for the Termination ?
Should be the behaviour be different when the Termination is in Null/Non-Null context?
One of the arguments can be that since the default/provisioned values are restored only when a termination returns to the Null context, an error should be returned for any command having such an event Descriptor as the context has not changed yet. But then there is no way and MGC can get the provisioned value for the digit map through an audit until the Termination returns back to Null context.
Would like to know other list member's opinion about it.

>defined on ROOT persist until deleted.

Kris> ROOT termination is different from the physical terminations in that it does not any context associated with it. So what happens in a scenario like above where MGC overrides the provisioned digit map value for the termination and later deletes the definition by sending an empty digit map desc for that termination with the same name. Since ROOT does not has a context associated with, above mentioned Sec 6.2.4 text does not apply to it.
So should the provisioned value for the digit map be restored or the digit map be deleted (and provisioned value be gone until provisioned again)?

>>  http://www.inphonic.lycos.com/redirect.asp?referringpage=www.lycosd1

Get FREE Email/Voicemail with 15MB at Lycos Communications at http://comm.lycos.com

---

From: Kris Albert <[email-masked]>
Date: Mon, 18 Dec 2000 21:58:05 -0800

Hi Tom and List!
Can we assume that silence on the issue means the following consensus.

1. If a provisioned definition on a specific termination is overridden by an empty definition by MGC, while it is in (NULL/Non NULL) context, the digitmap becomes unavailable for the termination in that context even though the digitmap may have a provisioned value defined for the termination.
The provisioned value becomes "visible" only when the termination "returns" to NULL context.
2. In case of ROOT termination, the provisioned value can NEVER be restored once MGC overrides it with a new value. Even an empty value being set by MGC for that digitmap name does not restore the provisioned value and the digitmap becomes undefined for ROOT until set to a new (non-empty) value  by MGC/provisioning.

thanks
Kris

--------- Forwarded Message ---------

DATE: Thu, 14 Dec 2000 04:44:27
From: Kris Albert <[email-masked]>
To: [email-masked]

 Hi Tom and List!

thanks,
Kris
--

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 19 Dec 2000 08:09:39 -0500

>Can we assume that silence on the issue means the following consensus.
Never assume silence = consent!  Especially around meeting time.

>1. If a provisioned definition on a specific termination is overridden
>by an empty definition by MGC, while it is in (NULL/Non NULL) context,
>the digitmap becomes unavailable for the termination in that context
>even though the digitmap may have a provisioned value defined for the
>termination.
Yes
>"returns" to NULL context.
Yes if the override of the definition occurs when the termination
was in a context other than null.

>2. In case of ROOT termination, the provisioned value can NEVER be
>restored once MGC overrides it with a new value. Even an empty value
>being set by MGC for that digitmap name does not restore the provisioned
>value and the digitmap becomes undefined for ROOT until set to a new
>(non-empty) value  by MGC/provisioning.
Yes

Brian
ps - Rosen's Law of Provisioning - "Provisioning is evil"