Subject: Double quote not allowed

From: Paul Long <[email-masked]>
Date: Tue, 19 Dec 2000 16:39:28 -0600

I noticed that the double-quote character (") is not allowed in COMMENT or
quotedString (escaped of course). Was this intentional?

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Tue, 19 Dec 2000 16:54:21 -0600

Whoops! Okay, I see now that it is allowed in COMMENT, but it is still not
allowed in quotedString. Is it okay that a double quote can never appear in
an errorDescriptor or VALUE by way of quotedString?

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Tuesday, December 19, 2000 4:39 PM
To: [email-masked]
Subject: Double quote not allowed

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Sun, 31 Dec 2000 11:30:07 -0600

I noticed that an octet of zero is not allowed in the ABNF octetString. Was
this intentional?

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Sun, 31 Dec 2000 12:05:20 -0600

1. Do these two types of ABNF expressions always have the same semantics in
RFC3015? If so, can someone provide a rationale for the two different yet
equivalent expressions, e.g., are the LBRKTs sometimes needed to
disambiguate the grammar?
        LBRKT [ x ] LBRKT
        [ LBRKT x LBRKT ]

2. Are these two modem-descriptor examples equivalent? If so, why the two
syntaxes?
        md=v90
        md[v90]

3. I assume that the following alternativeValue expressions are all
equivalent to each other, correct?
        5
        [5]
        {5}
        [5:5]

4. The ABNF for secondEventParameter refers to "EmbedSig", which is not
defined. Therefore I assume it should be "embedSig", which is defined. A
simple typo.

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Sun, 31 Dec 2000 12:33:15 -0600

1. Regarding this idiom:
        y = x *x

        ; at-most-once
        x = a / b / c / d

Doesn't the comment refer to the use of x in y rather than x by itself? I
say this because x can only take on one of the alternative values at a time.

2. Are the these comments equivalent?
        ; at-most-once
        ; at-most-once per item
        ; at-most-once of each
        ; at-most-once each of x, y, z
        ; every x at most once

3. Does "exactly once x" mean that x is required and there cannot be
multiple occurrences of x?

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Sun, 31 Dec 2000 13:18:04 -0600

Does "O-" indicate an optional and "W-" a wildcarded command? I can't see
where they could mean anything else, but I also didn't see this defined
anywhere.

Paul Long
ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Sun, 31 Dec 2000 16:33:18 -0600

Here a specific problem I'm having in this area.

Regarding this ABNF from RFC3015:
        terminationStateDescriptor = TerminationStateToken LBRKT
terminationStateParm *( COMMA terminationStateParm ) RBRKT
        ; at-most-once per item
        terminationStateParm =(propertyParm / serviceStates / eventBufferControl )

I assume the comment means that, for example, ServiceStates cannot be
specified as both Test and OutOfService and that Buffer cannot be both OFF
and LockStep. That's pretty straightforward; however, does it mean that only
one propertyParm can be specified or that only one propertyParm per
package/item identifier combination can be specified? IOW, I assume that
this is illegal
        PkgA/ItmA=3, PkgA/ItmA=6
but is the following also illegal?
        PkgA/ItmA=3, PkgA/ItmB=8
The comment isn't at all clear, IMO.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Paul Long
Sent: Sunday, December 31, 2000 12:33 PM
To: [email-masked]
Subject: "Once" is not enough :-)

1. Regarding this idiom:
        y = x *x

        ; at-most-once
        x = a / b / c / d

Paul Long
ipDialog, Inc.