Subject: Fw: Binary encoding in SDP

From: SRD Tian YaMin <[email-masked]>
Date: Thu, 21 Dec 2000 10:31:35 +0800

Hello Sir:
   Below is the question also puzzles me, but nobody answer it.
Now I use PropertyParm.name  = 00006001 , PropertyParm.value = RTPAddrValue,
and
PropertyParm.name  = 00006003 , PropertyParm.value = RTPPortValue
to stand for the RTP address in Local/RemoteDescriptor, and SDP Equivalents
are not used.
I need somebody to justify my thoughts. Can u help me?
Thanks

Tian Yamin

>Hi Sir :
>
>We have a question about binary encoding in SDP, can you help us?
>In Annex A, SDP binary encoding use :
>ProperParm :: = SEQUENCE
>{
>    name    pKgdName,
>    value    SEQUENCE OF OCTET STRING,
>    ....
>}
>
>if I want to encode the following SDP:
>v=0
>c=IN IP4 $
>
>1. What I need to put in PropertyParm.name ?
>v=0                =====> 0000B001
>c=IN IP4 $     =====>  0000B008 or 00006001
>
>2. What I need to put in PropertyParm.value?
>Is ASCII of all the string "v=0" and "c=IN IP4 $" or someing else ?
>
>Best regards
>Yieng-Chang Liao

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 21 Dec 2000 09:16:21 -0500

Your choice of words is confusing, but your choice of parameters
is correct.

When using binary encoding of the Megaco protocol, one does not
use SDP at all. One uses Annex C tags.  For an RTP flow,
RTPAddrValue and RTPPortValue are correct.

Brian

> -----Original Message-----
> From: SRD Tian YaMin [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2000 9:32 PM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: Fw: Binary encoding in SDP
>
>
> Hello Sir:

---

From: "Griffeth, Nancy D (Nancy)" <[email-masked]>
Date: Thu, 21 Dec 2000 10:28:17 -0500

Tian,

Normally, you won't encode SDP.

Instead you use SDP for text encoding and Annex C for binary encoding.

Nancy Griffeth

-----Original Message-----
From: SRD Tian YaMin [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 9:32 PM
To: [email-masked]
Subject: Fw: Binary encoding in SDP

Hello Sir:

Tian Yamin