Subject: clarification in SDP parsing (octet string ) in Local descriptor

From: Panditha Govindaraj <[email-masked]>
Date: Thu, 7 Dec 2000 15:18:09 -0500

Hi

        In the Example call flow of MEGACO RFC 2885

The local descriptor :

The local token follows by an octet string

This Octet string is the part of SDP grammar, In the SDP grammar

it is no where shown that the octet string can have a $ (does this mean
choose wild card) if yes how is this to be handled, as RFC 2327 for SDP

does not support the ($) & ( VAD=X-NNVAD ) operation , How is this suppose
to be handles in the SDP Parser of Megaco

Can somebody suggest me

Here is a copy of the Example

Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4
   a=ptime:30
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 0
a=fmtp:PCMU VAD=X-NNVAD
                     }

Thanks

Govindaraj.P

---

From: Troy Cauble <[email-masked]>
Date: Thu, 7 Dec 2000 16:06:37 -0500

Seems to me that the octetString can have a $.
As for the SDP RFC, I guess they're bending the RFC.

   octetString          = *(nonEscapeChar)
   nonEscapeChar        = ( "\}" / %x01-7C / %x7E-FF )

-troy