Subject: ServiceChangeReason - Optional or not?

From: Troy Cauble <[email-masked]>
Date: Fri, 29 Dec 2000 18:25:20 -0500

Hi all,

ServiceChangeReason is optional in the ABNF encoding,
but not in the ASN.1 encoding.

All of the sample messages in Appendix A that
have ServiceChangeRequests omit it.

Is it optional or not?

-troy

---

From: Troy Cauble <[email-masked]>
Date: Fri, 29 Dec 2000 18:42:34 -0500

> have ServiceChangeRequests omit it.

OK.  I guess an EMPTY serviceChangeReason Value
will correspond to a missing serviceChangeReason
in the ABNF.

So now the question is, how do I encode the following
specification as an OCTET STRING?

From 7.2.8:  [The ServiceChangeReason parameter] consists
of an alphanumeric token (IANA registered) and, optionally,
an explanitory string.

-try