Subject: RE: ABNF syntax query

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Jul 2001 14:14:08 -0400

Lists are items separated by commas in the ABNF.
In this case, it's a list of identifiers, the same as,
for example, the tone list in tonegen.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Monday, July 09, 2001 1:26 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: ABNF syntax query
> 
> 
> "Rosen, Brian" wrote:
> > 
> > I must have been asleep
> > 
> > I don't remember a discussion of making SigId a string.
> > Why?  It's a list.  That should be sufficient.
> 
> List of what?  "List" doesn't really convey any type information.
> 
> Don't say "signal", "signal" is not a type either.
> 
> -troy
>

---

From: Troy Cauble <[email-masked]>
Date: Mon, 09 Jul 2001 14:41:26 -0400

What's an "item"?  Can my item be a comma or contain a 
comma?  What syntax *is* allowed?

We need an actual type indication ("String", "Integer",
"Boolean", etc.) to know how to encode it or decode it
(in both text and ASN.1).

-troy