Subject: Fwd: Re: ABNF syntax query

From: Sarika Gupta <[email-masked]>
Date: Sun, 15 Jul 2001 06:42:57 +0100 (BST)

Hi,
Can anyone please respond on this quickely? It is
urgent since we are trying to implement IVR over
megaco and this issue has become a bottleneck.

Thanks&Regards
sarika
 --- Sarika Gupta <[email-masked]> wrote: > Date:
Fri, 13 Jul 2001 07:18:31 +0100 (BST)
> From: Sarika Gupta <[email-masked]>
> Subject: Re: ABNF syntax query
> To: Troy Cauble <[email-masked]>
> CC: [email-masked], Terry L Anderson
> <[email-masked]>
> 
>  Hi,
> Then how do we fix the "nested double quote issue".
> Can we introduce some type of escape character for
> this  or if we can change the format for the
> varvalue
> , I mean instead of taking quotes as the delimiters
> can we have some other delimiters as <>. But
> introducing a escape character would be a better
> idea
> since that will fix the issue for future also.
> Please suggest what to do asap.
> 
> Thanks&Regards
> Sarika
> 
> --- Troy Cauble <[email-masked]> wrote: > 
> > Sarika,
> > 
> > This Annex M element is type String, which
> requires
> > double quotes
> > as of IG 6.80.
> > 
> > This is a GOOD THING, since it encapsulates the
> new
> > syntax
> > at a level that allows stacks that DON'T support
> the
> > package
> > to parse the message down to the level of that
> > string.
> > 
> > (Allowing packages to introduce new syntax that
> > isn't encapsulated
> > like this would be extremely bad, breaking valid
> > parsers.)
> > 
> > That said, the use of quotedString within the
> > varvalue syntax
> > will cause a nested double quote issue and needs
> to
> > be fixed.
> > 
> > 
> > Terry,
> > 
> > I recently brought this concept up with respect to
> > Annex E.1.2
> > SigID, asking that it be clarified to be type
> String
> > (which
> > requires double quotes via IG 6.80).  I think
> there
> > was a
> > consensus, but no one spoke up and said it was
> going
> > in the IG.
> > 
> > -troy
> > 
> > 
> > 
> > Sarika Gupta wrote:
> > > 
> > > Hi,
> > > In H248 Annex M draft "Advanced Audio Server
> > Package"
> > > the ABNF syntax has been specified explicitely
> for
> > the
> > > Announcemnt paramter of Play signal given below
> > > 
> > > "announcement = LBRKT segSpec *( COMMA segSpec )
> > RBRKT
> > >                         ; LBRKT, RBRKT, COMMA
> are
> > as
> > > defined in H.248 Annex B.
> > > 
> > > ; The segSpec identifies the content of an
> > individual
> > > segment
> > > segSpec = (
> > >                           ( sid *( COMMA embed)
> )
> > >                            ; reference to a
> > > provisioned segment spec followed by zero or
> more
> > >                            ; embedded variable
> > value
> > > specifications
> > >                          / variable
> > >                   )"
> > > 
> > > where as the ABNF for param value defined in
> H248
> > is
> > > 
> > > "parmValue            = (EQUAL alternativeValue/
> > > INEQUAL VALUE)
> > >  alternativeValue     = ( VALUE
> > >                                 / LSBRKT VALUE
> > *(COMMA VALUE) RSBRKT
> > >                          ; sublist (i.e. A AND B
> > AND
> > > ...)
> > >                                 / LBRKT VALUE
> > *(COMMA VALUE) RBRKT
> > >                                  ; alternatives
> > (i.e. A OR B OR ...)
> > > 
> > >                                 /  LSBRKT VALUE
> > COLON VALUE RSBRKT )
> > >                                  ; range"
> > > 
> > > So if we send a Play signal for announcement
> > paramter
> > > its value will be filled using standard signal
> > value
> > > format. So how the announcement ABNF format will
> > map
> > > to the param Value
> > > ABNF format.
> > > 
> > > Regards
> > > Sarika
> > > 
> > >
> >
>
____________________________________________________________
> > > Do You Yahoo!?
> > > Get your free @yahoo.co.uk address at
> > http://mail.yahoo.co.uk
> > > or your free @yahoo.ie address at
> http://mail.yahoo.ie 
> 
>
____________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.co.uk address at
> http://mail.yahoo.co.uk
> or your free @yahoo.ie address at
> http://mail.yahoo.ie
>  

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 20 Jul 2001 09:51:44 -0400

A draft I made a while ago used the escape approach (similar to HTML --
spell out %xx), but then you also have to escape the % sign.  The open
question was whether anything else also needs to be escaped.  I'm pulling
together correspondence I've had on the matter, with hopes of having an
updated draft later today.

-----Original Message-----
From: Sarika Gupta [mailto:[email-masked]]
Sent: Friday, July 13, 2001 2:19 AM
To: Troy Cauble
Cc: [email-masked]; Terry L Anderson
Subject: Re: ABNF syntax query

 Hi,
Then how do we fix the "nested double quote issue".
Can we introduce some type of escape character for
this  or if we can change the format for the varvalue
, I mean instead of taking quotes as the delimiters
can we have some other delimiters as <>. But
introducing a escape character would be a better idea
since that will fix the issue for future also.
Please suggest what to do asap.

Thanks&Regards
Sarika

> Sarika,
> 
> This Annex M element is type String, which requires
> double quotes
> as of IG 6.80.
> 
> This is a GOOD THING, since it encapsulates the new
> syntax
> at a level that allows stacks that DON'T support the
> package
> will cause a nested double quote issue and needs to
> be fixed.
> 
> 
> Terry,
> 
> SigID, asking that it be clarified to be type String
> (which
> requires double quotes via IG 6.80).  I think there
> was a
> consensus, but no one spoke up and said it was going
> in the IG.
> 
> -troy
> 
> 
> 
> Sarika Gupta wrote:
> > 
> > Hi,
> > the ABNF syntax has been specified explicitely for
> the
> >                         ; LBRKT, RBRKT, COMMA are
> as
> >                           ( sid *( COMMA embed) )
> > provisioned segment spec followed by zero or more
> >                            ; embedded variable
> value
> > specifications
> >                          / variable
> >                   )"
> > 
> > where as the ABNF for param value defined in H248
> is
> > 
http://mail.yahoo.ie