Subject: RE: How can MPLS be used for MEGACO

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 16 Jul 2001 09:01:39 -0400

Sure, you make the MG and MGC unaware of MPLS and
let the underlying network handle routing of packets
from hither to yon.  After all, in most systems,
the expected load of voice is expected to be <10%,
so trying to optimize these cases by injecting
MGC knowledge of traffic patterns may not be
very effective.

Brian

> -----Original Message-----
> From: gabbar singh [mailto:[email-masked]]
> Sent: Sunday, July 15, 2001 3:37 AM
> To: [email-masked]
> Subject: How can MPLS be used for MEGACO
> 
> 
> Hi all,
> What ever is published as of today for MPLS and MEGACO
> basically leads to two main approaches for acheiving
> this.
>    Either we use an interworking function(IWF) sitting
> under the MG which 
> runs its own LDP 
> Converts the IP address to a suitable lable
> and makes the MG-MGC architecture unaware of anything
> related to "Traffic Engineering". 
> 
> 	Or let MGC ( or still better, a soft switch ) run the
> LDP come up with suitable lables taking into account
> varied range of information at its disposal (a
> potential area for research)
> 	And then define a new package may be for a MPLS
> termination giving control to MGC at the finest level.
> 	Is there any other possible architecture for
> supporting MPLS...??
> 
> Am I wrong somewhere..??
> 
> 
> 
> 
> ____________________________________________________________
> Do You Yahoo!?
> For regular News updates go to http://in.news.yahoo.com
>

---

From: gabbar singh <[email-masked]>
Date: Mon, 16 Jul 2001 18:16:11 +0100 (BST)

Hi Brian,
I am a bit skeptical about making MGC unaware about
the MPLS traffic.
What if the voice + video traffic tomorrow increases
in percentage.
	Making MGC unawre of MPLS shall lead us to not making
the use of
potential knowledge of MGC in deciding "lables"(which
can be very can be of
tremendous help if we think from the softswitch point
of view).
	If we let MGC's along with other MPLS enabled routers
decide the 
suitable labels and distribute them to MG, what could
be the possible "ways" for doing this ?
	How do we possibly control MPLS level streams ?

 --- "Rosen, Brian" <[email-masked]> wrote: >
Sure, you make the MG and MGC unaware of MPLS and

---

From: Matt Holdrege <[email-masked]>
Date: Mon, 16 Jul 2001 13:06:54 -0700

There is no police force telling you not to involve the MGC in LDP. The MGC 
can do this just as well as any other intelligent node. After all, LDP is 
just a signalling protocol. It's up to you how and where you implement it.