Subject: [Megaco] Query regarding yacc parser resync for megaco

From: Rajat Sharma <[email-masked]>
Date: Wed, 25 Jul 2001 07:33:29 +0100 (BST)

hi! all 

please help me out.

Can anybody tell me that at what level the 
"error" token generated by tha yacc for error recovery

should be placed if we go to the descriptor level then
that w'd need a major effort as a lot many rules need
to be modified to accomodate the "error" token .

thanking in advance 
Rajat Sharma

____________________________________________________________
Do You Yahoo!?
For regular News updates go to http://in.news.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: "Paul Long" <[email-masked]>
Date: Wed, 25 Jul 2001 11:51:45 -0500

Rajat,

These examples show all the places where an error descriptor can occur in a
message. Note that constructs placed within ellipses can be an item in a
list.

Either an MG or MGC can receive these:

1.  MEGACO/1 [123.123.123.4]
    Error = xxx { }

2.  MEGACO/1 [123.123.123.4]
    ...
    Reply = 9998 {
        Error = xxx { } }
    ...

3.  MEGACO/1 [123.123.123.4]
    ...
    Reply = 9998 {
        ...
        Context = - {
             Error = xxx { } } }
        ...
    ...

4.  MEGACO/1 [123.123.123.4]
    ...
    Reply = 9998 {
        ...
        Context = - {
            ...
             ServiceChange = A4444 {
                  Error = xxx { } } } }
            ...
        ...
    ...

Only an MGC can receive these:

5.  MEGACO/1 [123.123.123.4]
    ...
    Reply = 9998 {
        ...
        Context = - {
            ...
             AuditValue = Context {
                  Error = xxx { } } } }
            ...
        ...
    ...
    (Where AuditValue could also be AuditCapability.)

6.  MEGACO/1 [123.123.123.4]
    ...
    Reply = 9998 {
        ...
        Context = - {
            ...
             Add = A4444 {
                  Error = xxx { } } } }
            ...
        ...
    ...
    (Where Add could also be Move, Modify, or Subtract.)

7.  MEGACO/1 [123.123.123.4]
    ...
    Transaction = 9998 {
        ...
        Context = - {
            ...
             Notify = A4444 {
                  ObservedEvents = 38 { at/of }, Error = xxx { } } } }
            ...
        ...
    ...

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Rajat Sharma
Sent: Wednesday, July 25, 2001 1:33 AM
To: [email-masked]
Subject: [Megaco] Query regarding yacc parser resync for megaco

hi! all

please help me out.

thanking in advance
Rajat Sharma