Subject: RE: A doubt reg. Message ID

From: "Kaul, Bharat" <[email-masked]>
Date: Mon, 16 Jul 2001 10:31:59 -0700

Brian/Rajesh,

  MID is just a logical identifier and is not be interpreted either as IP
Address or domain name. It could be either of them as they are unique
identifiers but MID should not be interpreted.

- Bharat

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, July 16, 2001 6:05 AM
To: 'Rajesh N'; [email-masked]
Subject: RE: A doubt reg. Message ID

The message header is used by the receipient for two things:
	1. Determine who sent the message.  This is more of a
	concern for the MGC, which may have a number of MGs
	that it is receiving messages from

	2. Determine where to send a reply.  You always send
	the reply back to where it came from.

In an IP system, the MId can be an IP address or a domain name.

Brian

> -----Original Message-----
> From: Rajesh N [mailto:[email-masked]]
> Sent: Monday, July 16, 2001 2:59 AM
> To: [email-masked]
> Subject: A doubt reg. Message ID
> 
> 
> Hi,
> 
> RFC 3015 talks about binding more than one transactions into 
> a message and 
> using a name( domain address/ domain name / device name) of 
> the sender in 
> the MID field of message header.
> 
> Could someone explain about the importance of this field and 
> what are the 
> various values that can be used in this field. And what is 
> the general 
> opinion about using sender's IP address.
> 
> 
> 
> Regards,
> Rajesh N
>

---

From: Rajesh N <[email-masked]>
Date: Thu, 19 Jul 2001 15:17:18 +0530

Thanks all for the participation in this discussion.

So are we concluding that MID field is used by the reciever just to 
recognize the sender. It is not considered while replying back, rather we 
take the transport address(IP address) of the sender to reply back.

And does it make any difference whether we use domain name/Ip address here??
Thanks
Rajesh

Regards,
Rajesh N

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco