Subject: RE: [Megaco] Agenda For The Meeting

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 24 Jul 2001 08:27:48 -0400

Good points on v2.  Basically we focus on getting a well-functioning
protocol, nothing really new.  Regarding the drafts: I didn't really intend
to cover any of them except to the extent that people wanted to either give
delta reports or raise specific issues.

BTW Wayne Cutler advises me that draft-cutler-megaco-recvpkg-01.txt has been
superseded/replaced by draft-cutler-megaco-mgc-cookie-02.txt.

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Monday, July 23, 2001 8:54 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]
Cc: 'megaco'
Subject: Re: [Megaco] Agenda For The Meeting

G'Day Tom,

Seeing you invited us to start off discussion on the list on the items
below....

With regards to H.248v2 I think the main thing to consider is the time
frame. I believe the itention of approving H.248v2 in Feb2002 is so that
we can produce a relatively clean version of H.248. I think the
implementors' guide has gone a long way to improve the specification and
I think that a version 2 is needed to capture all these changes as well
as other improvements to make the protocol more efficient: ie. auditing
individual properties, transaction pending handling, package extension
of descriptors etc.. 

As for rules for content I'm not sure that we can mandate anything. My
feeling is that H248v2 shouldn't be for large amounts of completely new
functionality but its hard to preclude anything before seeing the idea.
I think its largely a process issue. I don't think any new functionality
should be presented to the February SG16 meeting that hasn't been seen
and agreed to before that time. I think the main thing which needs to be
agreed is a commitment to a february approval date. We can then work
backwards to see when documents should be ready for review etc.

With regards to the drafts list below do you intend to address all of
these at the meeting? I think looking at the MIB is worthwhile. Some of
the other drafts I don't think there's much of a point ie. >
draft-ietf-megaco-h248f-01.txt  as its already published as an Annex to
H.248. Perhaps its just worthwhile going through the Packages Supplement
and making people aware at the meeting what packages are out there?

Regards, Christian

Tom-PT Taylor wrote:
> 
> Could I have suggestions for agenda items for the meeting?  Specific items
> which should be discussed (preferably on the list, to start with) are:
>  -- H.248v2: ground rules for content, process
>  -- initial official work items for us under recharter
>  -- issues with specific documents
> 
> Below is the current list of documents matching draft-*-megaco-*-*.txt on
> the Internet Draft site.  I expect this list will grow in the next few
days.
> In particular, I've submitted an update of the NAS packages draft (and
have
> already noted a couple of discrepancies between the abstract and the
body).
> Please indicate any documents which are obsolete and can be taken off the
> table.
> 
> draft-madhubabu-megaco-qospackage-00.txt
> Megaco/H.248 QoS Packages
> 
> draft-taylor-megaco-enhalpkgs-00.txt
> Megaco/H.248 Enhanced Analog Line Packages
> 
> draft-manyfolks-megaco-caspackage-00.txt
> Megaco/H.248 Basic CAS Packages
> 
> draft-rosen-megaco-namepatterns-00.txt
> Name Pattern Package for Megaco
> 
> draft-cutler-megaco-recvpkg-01.txt
> MGC Recovery Package for Megaco/H248
> 
> draft-ietf-megaco-naspkg-03.txt (submitted)
> Megaco/H.248 NAS Package
> 
> draft-boyle-megaco-alerting-02.txt
> Enhanced Alerting Packages for Megaco/H.248
> 
> draft-cutler-megaco-mgc-cookie-02.txt
> MGC Cookie Package for Megaco/H248
> 
> draft-boyle-megaco-tonepkgs-05.txt
> Supplemental Tones Packages for Megaco/H.248
> (Completed list Last Call)
> 
> draft-doyle-megaco-tonesmib-00.txt
> Tones MIB for Megaco/H.248
> 
> draft-ietf-megaco-r2package-02.txt
> Megaco/H.248 R2 Package
> 
> draft-bouwen-megaco-isdn-data-00.txt
> Extensions to Megaco to support Data in an ISDN D-channel
> 
> draft-ietf-megaco-mib-02.txt
> MEGACO MIB
> 
> draft-rosen-megaco-atm-package-00.txt
> Megaco ATM Package
> 
> draft-bouwen-megaco-isdn-pack-01.txt
> ISDN Package for Megaco
> 
> draft-bouwen-megaco-isdn-bcp-01.txt
> Best Current Practice for Megaco-Sigtran Interaction in ISDN Acces...
> 
> draft-ietf-megaco-h248f-01.txt
> H.248 Annex F (Fax, Text Conversation, and Call discrimination))
> 
> draft-madhu-megaco-callflows-00.txt
> Megaco/H.248 Call flow examples
> 
> draft-levy-megaco-mgdiscovery-01.txt
> Megaco/H.248 Media Gateway Resources Discovery
> 
> draft-bothwell-megaco-mftonepkgs-00.txt
> MF Tone Generation and Detection Packages
> 
> I believe we should also consider:
> 
> draft-taylor-mmusic-sdp-tdm-00.txt
> Conventions for the use of the Session Description Protocol (SDP)f...
> 
> I draw your attention to:
> 
> draft-sijben-rtp-proxy-00.txt
> RTP proxies for firewall traversal
> 
> Tom Taylor
> [email-masked]
> Ph. +1 613 736 0961 (ESN 396 1490)
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/megaco

---

From: "Blatherwick, Peter" <[email-masked]>
Date: Tue, 24 Jul 2001 11:02:52 -0400

Certainly agree that v2 should be our main topic with goal of well functioning protocol.  MIB progress is another big one, and it sure would be good to nail that down pre-version 2.  
 
That said, one item I'd like to see added to version 2 list is explicit rules about profiles, how they are defined, what they are allowed to define, how they are negotiated at ServiceChange, is more than one allowed to be in place at any given time.  This was intentionally deferred in version 1, waaaaaaay back in Washington meeting, leaving only the very simplistic statements we have now with the intent to finish it up in version 2.  This has caused repeated debate and remains pretty open-ended IMHO, leading to a weakness in "well functioning protocol" goal.  
 
Perhaps the way to handle the outstanding packages would be to produce a status list as a meeting outcome, with dates and priorities, to get these completed (or not) in a timely fashion.  Could look similar to what SIP WG has started using to track progress with their nightmare of I-D overload.  
 
-- Peter

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: July 24, 2001 08:28
To: 'Christian Groves'
Cc: 'megaco'
Subject: RE: [Megaco] Agenda For The Meeting

Good points on v2.  Basically we focus on getting a well-functioning protocol, nothing really new.  Regarding the drafts: I didn't really intend to cover any of them except to the extent that people wanted to either give delta reports or raise specific issues.

BTW Wayne Cutler advises me that draft-cutler-megaco-recvpkg-01.txt has been superseded/replaced by draft-cutler-megaco-mgc-cookie-02.txt.

Tom Taylor 

-----Original Message----- 
From: Christian Groves [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Monday, July 23, 2001 8:54 PM 
To: Taylor, Tom-PT [NORSE:B881:EXCH] 
Cc: 'megaco' 
Subject: Re: [Megaco] Agenda For The Meeting 

G'Day Tom, 

Regards, Christian 

Tom-PT Taylor wrote: 
> the Internet Draft site.  I expect this list will grow in the next few days. 
> In particular, I've submitted an update of the NAS packages draft (and have 
> already noted a couple of discrepancies between the abstract and the body). 
> http://www.ietf.org/mailman/listinfo/megaco <http://www.ietf.org/mailman/listinfo/megaco>