Subject: Topology and video conferencing

From: Dan Elbert <[email-masked]>
Date: Wed, 11 Jul 2001 14:56:17 -0500

Hi

What would be the best way to control the topology of the connections for a
video conferencing scenario? Megaco topology descriptor controls allows
topology control only at the termination level and not at the level of a
particular media stream, so if we have both video and audio streams and the
topology for them is different, we have a potential problem. One way to
solve this may be to use different ephemeral terminations for the video
stream and for the audio stream, but then we lose the synchronization. Any
ideas ?

Dan Elbert
Radvision

---

From: Danny Levin <[email-masked]>
Date: Tue, 17 Jul 2001 09:39:37 -0500

Christian,

Topology plus StreamId plus Send/Recv does not enable all routing options.
Let assume you have 3 terminations T1,T2 & T3 and media streams s1 s2

T1 receives s1 from T2 and T3 (full duplex with T2 & T3)
T2 receives s1 & from T1 (full duplex with T1)
T3 receives s1 from T1 (full duplex with T1)

If you isolate (T3 - T2) via Topology (to prevent S1 TO flow between T2 &
T3) you prevent also other streams (such as s2) to flow between T2 & T3 as
well .

Routing at the level of streams (instead of Terminations) will do the work
for any combination

Danny.

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Monday, July 16, 2001 8:10 PM
To: Dan Elbert
Cc: [email-masked]
Subject: Re: Topology and video conferencing

G'Day Dan,

You can specify the stream connection topology by assigning certain
streamIds to certain terminations. You can change the streams to one
way/bothway etc by specifying Send,Receive,Send&receive and inactive.

Cheers, Christian

Dan Elbert wrote:
> 
> Hi
> Video conference is one specific case, but it does seems desirable to have
> some generic solution in Megaco to control how media streams are routed
> inside a context. This could have all kind of applications without the
need
> to define specific packages. Topology would do the job if it was possible
to
> specify the stream id in addition to the termination id. Maybe we should
> consider this for the next Megaco version.
> What do you think ?
> 
> Dan
> 
> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, July 11, 2001 9:23 PM
> To: 'Dan Elbert'
> Cc: [email-masked]
> Subject: Re: Topology and video conferencing
> 
> G'Day Dan,
> 
> I think several approaches are needed to fully specify video
> conferencing and  conference control. I agree with Brian that some
> packages are needed. Things like floor control specification come to
> mind. But other things such as updates to Context Properties to enable
> the specification of mixing parameters are also needed. H.248v2 already
> incorporates a mechanism for the specification of context properties
> through the use of packages.
> 
> Regards, Christian
> 
> "Rosen, Brian" wrote:
> >
> > I've never appreciated topology.
> >
> > I think we should make a package for conference bridges.
> > That would allow us to have all the controls we needed.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Dan Elbert [mailto:[email-masked]]
> > > Sent: Wednesday, July 11, 2001 3:56 PM
> > > To: [email-masked]
> > > Subject: Topology and video conferencing
> > >
> > >
> > >
> > >
> > > Hi
> > >