Subject: RE: How can MPLS be used for MEGACO

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 16 Jul 2001 13:39:12 -0400

I will admit to being ambivalent about the issue.

On the one hand, we have a lot of experience in traffic engineering
for voice networks, which it seems foolish to throw away.
If you create lsps for voice, you want the MGC to control it.

On the other hand, if voice is a small part of the bandwidth,
then there is no point in having the MGC have visibility into
lsps.

When we get to video, neither is true.  I suspect that we
might very well be in a situation where it IS appropriate.
For example, if we have multimegabit video streams, they will
dominate traffic, and doing simple things like call admission
control and codec bit rate control require visibility into
the underlying routing to be effective.  Allowing the MGC
to ask that an lsp be created, and then doing admission
control/bandwidth control into it may be very usefull.

Since the problem doesn't exist right now, I guess I'm hesitant
to do much work.  It's pretty clear HOW we would do it, so, I 
would say, let's wait until we have a need.

Brian

> -----Original Message-----
> From: gabbar singh [mailto:[email-masked]]
> Sent: Monday, July 16, 2001 1:16 PM
> To: [email-masked]
> Subject: RE: How can MPLS be used for MEGACO
> 
> 
> Hi Brian,
> I am a bit skeptical about making MGC unaware about
> the MPLS traffic.
> What if the voice + video traffic tomorrow increases
> in percentage.
> 	Making MGC unawre of MPLS shall lead us to not making
> the use of
> potential knowledge of MGC in deciding "lables"(which
> can be very can be of
> tremendous help if we think from the softswitch point
> of view).
> 	If we let MGC's along with other MPLS enabled routers
> decide the 
> suitable labels and distribute them to MG, what could
> be the possible "ways" for doing this ?
> 	How do we possibly control MPLS level streams ?
> 
>  --- "Rosen, Brian" <[email-masked]> wrote: >
> Sure, you make the MG and MGC unaware of MPLS and
> > let the underlying network handle routing of packets
> > from hither to yon.  After all, in most systems,
> > the expected load of voice is expected to be <10%,
> > so trying to optimize these cases by injecting
> > MGC knowledge of traffic patterns may not be
> > very effective.
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: gabbar singh [mailto:[email-masked]]
> > > Sent: Sunday, July 15, 2001 3:37 AM
> > > To: [email-masked]
> > > Subject: How can MPLS be used for MEGACO
> > > 
> > > 
> > > Hi all,
> > > What ever is published as of today for MPLS and
> > MEGACO
> > > basically leads to two main approaches for
> > acheiving
> > > this.
> > >    Either we use an interworking function(IWF)
> > sitting
> > > under the MG which 
> > > runs its own LDP 
> > > Converts the IP address to a suitable lable
> > > and makes the MG-MGC architecture unaware of
> > anything
> > > related to "Traffic Engineering". 
> > > 
> > > 	Or let MGC ( or still better, a soft switch ) run
> > the
> > > LDP come up with suitable lables taking into
> > account
> > > varied range of information at its disposal (a
> > > potential area for research)
> > > 	And then define a new package may be for a MPLS
> > > termination giving control to MGC at the finest
> > level.
> > > 	Is there any other possible architecture for
> > > supporting MPLS...??
> > > 
> > > Am I wrong somewhere..??
> > > 
> > > 
> > > 
> > > 
> > >
> >
> ____________________________________________________________
> > > Do You Yahoo!?
> > > For regular News updates go to
> > http://in.news.yahoo.com
> > >  
> 
> ____________________________________________________________
> Do You Yahoo!?
> For regular News updates go to http://in.news.yahoo.com
>

---

From: "jmaeng" <[email-masked]>
Date: Mon, 16 Jul 2001 15:22:30 -0500

It seems to me that Brian and Gabber are talking about to different ideas.
Brian said "Allowing the MGC to ask that an lsp be created, and then doing
admission
control/bandwidth control into it may be very useful." I interpreted that a
MGC should ask the traffic manager to set up an lsp (with a certain
bandwidth) and control traffic within the lsp.  Gabber said "If we let MGC's
along with other MPLS enabled routers decide the suitable labels and
distribute them to MG,...".  It sounds like the MGC actively participate in
setting up an lsp.  It makes sense for a MGC to ask the traffic manager to
set up an lsp and then use the lsp the way it wants.  It may not be a good
idea for a MGC to act like a traffic manager
Joon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Monday, July 16, 2001 12:39 PM
To: 'gabbar singh'; [email-masked]
Subject: RE: How can MPLS be used for MEGACO

Brian

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 16 Jul 2001 18:11:41 -0400

HI Brian,
What is the status of the voice over MPLS framework draft
draft-kankkunen-vompls-fw-00.txt??

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of jmaeng
Sent: Monday, July 16, 2001 4:23 PM
To: [email-masked]
Subject: RE: How can MPLS be used for MEGACO

-----Original Message-----

Brian

---

From: Matt Holdrege <[email-masked]>
Date: Tue, 17 Jul 2001 13:58:19 -0700

I'm saying both scenarios are legit and it depends on the network in 
question as to how they will deploy it.