Subject: [Megaco] Regarding Soft Key Package

From: "Anand, Rashim" <[email-masked]>
Date: Thu, 26 Jul 2001 16:49:50 -0700

Hi,
   In the Soft Key Package (ks), Annex G H.248,  the Property ID of Propery
- nskeys ( Number of
softkeys ) is given as 1. This package extends the Label Key package
(labelkey) whose Property - keylist
( Key List ) also has the Property ID 1. Is the clash of the property IDs an
oversight?

Regards,
Rashim

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 27 Jul 2001 09:28:52 -0400

I suspect you're right on this one.  Begin Implementor's Guide for Annex G.

-----Original Message-----
From: Anand, Rashim [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 7:50 PM
To: [email-masked]'
Subject: [Megaco] Regarding Soft Key Package

Hi,

Regards,
Rashim

---

From: "Blatherwick, Peter" <[email-masked]>
Date: Fri, 27 Jul 2001 10:05:56 -0400

Hi Rashim,

Good eyes!  Yes, this does appear to be an oversight.  Affects binary encoding only.  The fix should be as follows.  

In Megaco/H.248 Annex G, Soft Key Package, the following text should replace the existing Properties:
"
Properties
   Number of softkeys
      PropertyID: nskeys (0x0002)
      PropertyType: Integer
      Characteristics: read only
      Defined in: TerminationState 
      Description: Maximum number of individual soft keys. 

   Display size
      PropertyID: sz (0x0003)
      Type: Integer
      Characteristics: read only
      Defined in: TerminationState 
      Description: Maximum number of characters that can be displayed in each softkey. 

   Supported unicode code pages
      PropertyID: cdpgs (0x0004)
      Description: a list of supported unicode pages 
      Type: list of enumerated type
      Defined in: TerminationState. 
      Characteristics: read only
"

IG Editor (Terry): Could you please add the above to the pile for Implementors' Guide, to be rolled into v2.  Would you like me to also supply a problem description, of is the content of this thread enough?  

Cheers,
Peter Blatherwick

-----Original Message-----
From: Anand, Rashim [mailto:[email-masked]]
Sent: July 26, 2001 19:50
To: [email-masked]'
Subject: [Megaco] Regarding Soft Key Package

Hi,

Regards,
Rashim