Subject: RE: Context Properties

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 5 Jul 2001 11:24:09 -0400

I think that Priority is retained until changed as long as the
context exists.

There is a problem with Emergency.  The ASN.1 defines it as
a boolean, and therefore it can be set false.  The ABNF only
has an appearance token.  I'd say that once set, it remains
set for the duration of the context, but I really think it should
have been defined to be a boolean so that it can be turned off.

In practice, I think once set, stays set is just fine.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Thursday, July 05, 2001 11:15 AM
> To: 'Andrew Russell-laing'; [email-masked]
> Cc: 'Kevin Napper'
> Subject: RE: Context Properties
> 
> 
> HI Russell,All,
> IMHO these properties takes their values as long as the context exits.
> Because the Emergency token enables preserve a connection and provide
> preference handling. This  preference is not just message processing
> preference but more than that. The Priority token enables the 
> MG to clear
> low priority calls in case of resource crunch, and this can 
> be done only if
> the priority is valid as long as the context persist. Of 
> course there is no
> statement of this in the protocol and hence only my personal 
> view. Comments
> from others???
> 
> Regards
> Madhubabu
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Andrew
> Russell-laing
> Sent: Thursday, July 05, 2001 6:29 AM
> To: [email-masked]
> Cc: Kevin Napper
> Subject: Re: Context Properties
> 
> 
> 
> 
> 
> Hi,
> 
> RFC3015, defines rules for handling descriptors if they are 
> specified, not
> specified, previously specified etc.
> 
> However there are two context properties  (Priority and 
> Emergency) which do
> not
> fall within the definition of a
> descriptor. The protocol does not appear to define the rules 
> for the absence
> of
> these properties when applied
> to subsequent actions against an existing context.
> 
> My assumption is that if a Context is set up with the Priority  and/or
> Emergency
> properties specified, then any
> subsequent transactions against that context, where these 
> properties are not
> specified, will result in the previous
> values of these properties applying.
> 
> Can you confirm this.
> 
> 
> 
> 
> 
> 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 5 Jul 2001 11:56:13 -0400

HI Brian, All,
One possible work around for the Emergency would be as defined for the Local
Control descriptor. If MGC requires Emergency it will include in every
message, if not included, this gives an indication to the MG and thus will
be used to turn off the same.
Regards
Madhubabu

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, July 05, 2001 11:24 AM
To: 'Madhu Babu Brahmanapally'; Russell-Laing, Andrew; [email-masked]
Cc: Napper, Kevin
Subject: RE: Context Properties

Brian