Subject: RE: From whence they came?

From: [email-masked]
Date: Tue, 17 Jul 2001 17:35:28 +0530

Hi Everybody

    I have a query related to a thread the floated some time back discussing the
mId.

    We had concluded that the address from which the message came need not be
the same as the address indicated in the message header.

    My question is, what exactly goes in the MgcIdToTry and ServiceChangeAddress
? Is it the 'logical' address which goes in the message header or is it the
actual address from which future messages will originate ?
    An observation is that the syntax of 'mId' of the message header is the same
as that of the serviceChangeMgcId of the Service Change command.

  Please clarify.

Regards
Shiv Kumar

---------------------- Forwarded by Shiv Kumar/HSS on 07/17/2001 04:15 PM
---------------------------

"Tom-PT Taylor" <[email-masked]> on 05/11/2001 09:56:37 PM

To:   Vivek Bansal/HSS@HSS
cc:   "'Paul Long'" <[email-masked]>, megaco <[email-masked]> (bcc: Shiv
      Kumar/HSS)

Subject:  RE: From whence they came?

It's a matter of historical development of our understanding of mID,
perhaps, but your example is correct.  There should be no comparison of
actual source with mID.  Your example could have arisen because of a
behind-the-scenes (invisible to the MGC) hot switchover from one MG to its
mate, or because a cluster of physical devices are sharing the load of one
control session, or because the host has multiple network interfaces or ...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 11, 2001 10:43 AM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Cc: 'Paul Long'; megaco
> Subject: RE: From whence they came?
>
>
>
>
> Hello Tom,
>      Does that mean that from a host with IP1 as the IP
> address, a Megaco
> message
> can be sent to the peer with an MId as IP2? Should the
> receiving entity not
> compare the
> source IP address and the IP address in the message header
> (assuming the mID is
> represented by IP address)?
>
> Regards,
> Vivek
>
>
>
>
>
> "Tom-PT Taylor" <[email-masked]> on 05/11/2001 06:13:14 PM
>
> To:   "'Paul Long'" <[email-masked]>, megaco <[email-masked]>
> cc:    (bcc: Vivek Bansal/HSS)
>
> Subject:  RE: From whence they came?
>
>
>
>
> Basically, yes.  It's probably better to use a domain name
> rather than an
> address as an mID tag.
>
> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Thursday, May 10, 2001 8:28 PM
> To: megaco
> Subject: RE: From whence they came?
>
>
> Tom,
>
> Hmmm... Taking a closer look at the spec, I see that the mID
> in the message
> prolog is just used by the receiver as a logical identifier
> for the sender
> and that, in particular, the IP-address forms just have syntactical
> value--they are never used as IP addresses, per se. It looks
> like these mIDs
> are only used when paired up with transaction identifiers to uniquely
> identify transactions, scoped to the receiver. Is this correct? Scary
> thought, but, as long as the sender takes care by using an IP
> address that
> another sender will not use, it appears that the IP address
> in a message mID
> doesn't have to have any relationship to the actual network
> interface of the
> sender. Am I right?
>
> Paul Long
> ipDialog, Inc.
>
> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Thursday, May 10, 2001 5:56 PM
> To: 'Paul Long'; megaco
> Subject: RE: From whence they came?
>
>
> It's partly the difference between a physical and a logical unit in a
> load-sharing architecture where the separate units have
> different addresses.
> There's also the possibility that a single physical unit has multiple
> network interfaces.  Using the address as received in the header is
> important because it gives a beter chnace of the response getting back
> through any intervening firewall.
>
> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Thursday, May 10, 2001 5:40 PM
> To: megaco
> Subject: RE: From whence they came?
>
>
> Tom,
>
> Okay, then, and this may be a stupid question, but what is
> the difference
> between "the peer in an association" and the source of a
> message? IOW, under
> what circumstances might they be different? The reason I was
> confused was
> probably because in H.323 the source of a message is of absolutely no
> consequence.
>
> Paul Long
> ipDialog, Inc.
>
>
>

---

From: "Kaul, Bharat" <[email-masked]>
Date: Tue, 17 Jul 2001 12:26:26 -0700

Shiv,

 When MgcId To Try is being used, it contains information about other MGC to
be contacted (i.e. can contain IP Address or domain name) although the
syntax is same as MID.

MID has different meaning when you use to identify it as source of message
(i.e. it is a logical identifier only) from when you use it in MgcIdToTry.

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 5:05 AM
To: [email-masked]
Subject: RE: From whence they came?

Hi Everybody

    I have a query related to a thread the floated some time back discussing
the
mId.

    We had concluded that the address from which the message came need not
be
the same as the address indicated in the message header.

    My question is, what exactly goes in the MgcIdToTry and
ServiceChangeAddress
? Is it the 'logical' address which goes in the message header or is it the
actual address from which future messages will originate ?
    An observation is that the syntax of 'mId' of the message header is the
same
as that of the serviceChangeMgcId of the Service Change command.

  Please clarify.

Regards
Shiv Kumar

To:   Vivek Bansal/HSS@HSS
cc:   "'Paul Long'" <[email-masked]>, megaco <[email-masked]> (bcc:
Shiv
      Kumar/HSS)

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 17 Jul 2001 21:13:06 -0400

One key point to note is that MGCIdToTry and ServiceChangeAddress are
destination addresses to which the receiver of the ServiceChange is to pass
requests.  Requests from the other end may come from an address different
from the ServiceChangeAddress or the initial contact address. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 8:05 AM
To: [email-masked]
Subject: RE: From whence they came?

Hi Everybody

  Please clarify.

Regards
Shiv Kumar

To:   Vivek Bansal/HSS@HSS

---

From: [email-masked]
Date: Wed, 18 Jul 2001 19:46:25 +0530

Hi Bharat, Tom, All

     Then what is the purpose of the MId in the message header.
     Somewhere down the list it was suggested that it is a logical identifier.
     Then, for some one not implementing the AH yet,  is it the only means to
make sure whether the message is coming from a valid peer entity ?
     If so, then how is this 'MId' conveyed between the peers ?
          Maybe it is pre-configured in case of an MG and its Primary MGC.
          But what happens when the Primary MGC handoffs to another MGC ?
          How does the MG know about that MGC's 'Mid' ?

Regards
Shiv Kumar

"Tom-PT Taylor" <[email-masked]> on 07/18/2001 06:43:06 AM

To:   Shiv Kumar/HSS@HSS, [email-masked]
cc:

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 8:05 AM
To: [email-masked]
Subject: RE: From whence they came?

Hi Everybody

  Please clarify.

Regards
Shiv Kumar

To:   Vivek Bansal/HSS@HSS

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 18 Jul 2001 10:43:15 -0400

The MId simply labels incoming messages so they can be correlated with an
active association.  It should not be considered to be any part of a
security scheme.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 10:16 AM
To: [email-masked]
Subject: RE: From whence they came?

Hi Bharat, Tom, All

     Then what is the purpose of the MId in the message header.
     Somewhere down the list it was suggested that it is a logical
identifier.
     Then, for some one not implementing the AH yet,  is it the only means
to
make sure whether the message is coming from a valid peer entity ?
     If so, then how is this 'MId' conveyed between the peers ?
          Maybe it is pre-configured in case of an MG and its Primary MGC.
          But what happens when the Primary MGC handoffs to another MGC ?
          How does the MG know about that MGC's 'Mid' ?

Regards
Shiv Kumar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 8:05 AM
To: [email-masked]
Subject: RE: From whence they came?

Hi Everybody

  Please clarify.

Regards
Shiv Kumar

To:   Vivek Bansal/HSS@HSS

---

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 18 Jul 2001 11:03:15 -0700

-----Original Message-----

[Naren] True enough. 

Now, in the requests from  the new MGC to our MG; will that MGC use an mId
which is exactly the "MgcIdToTry" given to our MG by the old MGC? 

In that case, "MgcIdToTry" has to be both (a) a valid "resolvable" transport
identifier such as host.domain.com:12345 and (b) a logical opaque handle
which never changes during the control association between our MG and the
new MGC. So MgcIdToTry cannot be something like "Controller1". 

If not, how does the MG know a request came from the new MGC?

All this confusion over mId arose because we have overloaded its use as a
logical handle AND (in some situations) a transport ID (such as IP address).
In v2, we should cleanly seperate the two - e.g. "EntityName" and
"ControlAssociationAddress".

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 18 Jul 2001 15:03:56 -0400

Hi.  I'll be stubborn here and say that the MG has to know that the messages
are coming from the intended MGC by other means.  One of those means might
be that the MGC response to the initial ServiceChange came back to the port
from which the MG dispatched the ServiceChange request.  Another possibility
(requiring prior implementation agreement) is that the MG is provisioned
with the MId by which it will recognize each MGC which is eligible to
control it.

---

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 18 Jul 2001 12:36:06 -0700

-----Original Message-----

[Naren] Hi Tom,

  just to clarify what you are saying, in your scenario the control
association establishment goes like this:

1. MG contacts MGC1 which gives it an "MgcIdToTry = 1.2.3.4" (IP address) in
ServiceChange reply.

2. MG contacts IP address 1.2.3.4 on port 2944 and gets a ServiceChange
reply with mId = "5.6.7.8" (or "Controller1").

3. MG now knows that mId = 5.6.7.8  corresponds to an MGC with IP address
1.2.3.4.

If MG was provisioned with more than two (one?) eligible MGCs, it would not
know until step 3 which MGC it actually is talking to. MgcIdToTry is ALWAYS
a valid transport address (never something like "Controller1" even though it
may fit the mId syntax and in fact may be the mId of the new MGC). 

 -----Original Message----- 
From: Tulpule, Naren [ mailto:[email-masked] <mailto:[email-masked]>
] 
Sent: Wednesday, July 18, 2001 2:03 PM 
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'; [email-masked]

-----Original Message----- 
From: Tom-PT Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ] 

[Naren] True enough.

---

From: "Kaul, Bharat" <[email-masked]>
Date: Tue, 24 Jul 2001 15:13:51 -0700

Tom/List,
 
  I would like to find out if we are on the same page as described below by
Naren on this issue. This thread suddenly stopped without a conclusion and I
would to find out if we concur with suggested behaviour.
 
- Thanks
  Bharat

-----Original Message-----
From: Tulpule, Naren [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 12:36 PM
To: 'Tom-PT Taylor'; [email-masked]
Subject: RE: From whence they came?

-----Original Message-----

[Naren] Hi Tom,

-----Original Message----- 

[Naren] True enough.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 24 Jul 2001 21:04:06 -0400

Yes, I agree.

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

-----Original Message-----
From: Kaul, Bharat [mailto:[email-masked]]
Sent: Tuesday, July 24, 2001 6:14 PM
To: Tulpule, Naren; Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'
Subject: RE: From whence they came?

Tom/List,

- Thanks
  Bharat

-----Original Message-----
From: Tulpule, Naren [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 12:36 PM
To: 'Tom-PT Taylor'; [email-masked]
Subject: RE: From whence they came?

-----Original Message-----

[Naren] Hi Tom,

-----Original Message----- 

[Naren] True enough.