Subject: [Megaco] Z DigitMap Timer Processing in MG

From: [email-masked]
Date: Thu, 26 Jul 2001 23:31:47 +0530

Hi List,

I would like to know in what way MG should handle Z timer processing.
Lets say pattern in Digitmap Definition is "2Z3"
Then after detection of 2, it starts two timers one Long ( L ) timer and another
Z timer. (Suppose Z < L)
Now there is two situations:
i) Digit 3 is detected before Z timeout,
then should MG report the digit string "23" with UM method or it should not
report '3' in Digit String at all.

The text given in Section 7.1.14.3 DigitMap Syntax says
   A "Z" designates a long duration event: placed in front of the
   symbol(s) designating the event(s) which satisfy a given digit
   position, it indicates that that position is satisfied only if the
   duration of the event exceeds the long-duration threshold.  The
       value of this threshold is assumed to be provisioned in the MG.

ii) Digit 3 is detected after Z timeout but before L timeout.
then should MG report the digit string "2Z3" with UM method.

Thanks in advance,
Ashish

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 26 Jul 2001 15:04:19 -0400

You're misinterpreting the role of Z as opposed to the other timers.  All of
the other timers are concerned about the interval until detection of the
first tone or the interval between tones.  Z is concerned with the duration
of the tone itself.

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 2:02 PM
To: [email-masked]; [email-masked]
Subject: [Megaco] Z DigitMap Timer Processing in MG

Hi List,

Then after detection of 2, it starts two timers one Long ( L ) timer and
another

Thanks in advance,
Ashish

---

From: [email-masked]
Date: Fri, 27 Jul 2001 03:26:01 +0530

Hi Tom, List

This means if pattern in Digitmap Definition is "2Z3"
Then after detection of 2,
i) Digit 3 is detected, but duration of event < Z Timer Duration
then should MG report the digit string "2" with PM method with '3' as extra
digit.
ii) Digit 3 is detected  but duration of event > Z Timer Duration
then should MG report the digit string "2Z3" with UM method.

Now if we have two patterns in Digitmap Definition is "2Z3" and "23"
Then after detection of 2,
i) Digit 3 is detected, but duration of event < Z Timer Duration
then should MG report the digit string "23" with UM method as it matches 2nd
pattern.
ii) Digit 3 is detected  but duration of event > Z Timer Duration
then should MG report the digit string "2Z3" with UM method as it matches 1st
pattern.

Thanks in advance,
Ashish

"Tom-PT Taylor" <[email-masked]> on 07/27/2001 12:34:19 AM

To:   Ashish Singh/HSS@HSS, [email-masked]
cc:

Subject:  RE: [Megaco] Z DigitMap Timer Processing in MG

Tom Taylor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 2:02 PM
To: [email-masked]; [email-masked]
Subject: [Megaco] Z DigitMap Timer Processing in MG

Hi List,

Thanks in advance,
Ashish

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 27 Jul 2001 08:07:09 -0400

All correct.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 5:56 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]
Subject: RE: [Megaco] Z DigitMap Timer Processing in MG

Hi Tom, List

then should MG report the digit string "2Z3" with UM method as it matches
1st
pattern.

Thanks in advance,
Ashish

Tom Taylor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 2:02 PM
To: [email-masked]; [email-masked]
Subject: [Megaco] Z DigitMap Timer Processing in MG

Hi List,

Thanks in advance,
Ashish