Subject: two questions : rules of making reply, union reply

From: [email-masked]
Date: Thu, 5 Jul 2001 13:18:16 +0900

Hi, all.

question 1 :

the section 6.2.2 "TerminationIDs" states that
"when ALL is used in the TerminationID of a command, the effect is
identical to repeating the commmand 
with each of matching TerminationIDs. Since each of these commands may
generate a response, the size
of the entire reponse may be large. if individual responses are not
required, a wildcard response may be 
requested."

so how to request to MG whether a response is unioned or not?
In Annex B. subtract and audit commands have optional "W-" tag. 
Is this tags used for this purpose?
if so,  Can a union resonse be used in "subtract" and "audit" command only?

question 2: it's about rules of making reply.

I could not found that how MG makes a resonse.(the rules of makeing reply)
but I guessed like this..

in case of fully qualified command request,
theres no descriptor-level parameters in resonse. (because MG doesn't need
to make a decision. )
example) Transaction = 10005 {
                  Context = 2000 {
                      Modify = A4445 {
                          Media { Stream = 1 {
                                Remote {
                                               v=0
                                               c=IN IP4 125.125.125.111
                                               m=audio 1111 RTP/AVP 4
                                }
                           }
                      }
                    }
                 }
        reply like this..
                Reply = {10005 { context=2000 {modify=A4445}}}

in case of over specified or under specified command request, (in some
properties)
after MG make a decision, only answered properties will be returned.
example) Transaction = 10003 {
                   Context=$ {
                       Add= $ {
                           Media {
                                Stream=1 {
                                       LocalControl {
                                              Mode=ReceiveOnly,
                                              nt/jit=40; in ms
                                       },
                                      Local {
                                                      v=0
                                                      c=IN IP4 $
                                                      m=audio $ RTP/AVP 4
                                                       a=ptime:30
                                      }
                                 }
                             }
                         }}}
reply like this
             Reply=10003 {
                       Add=A4445 {
                           Media {
                                Stream=1 {
                                     Local {
                                                v=0
                                                c=IN IP4 124.124.124.222
                                                m=audio 2222 RTP/AVP 4
                                                 a=ptime:30
                                                 a=recvonly
                                      }
                                  }
                           }}}
                                    
Is this right? / should All MG support this rule?

Thanks In Advance

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 05 Jul 2001 09:33:40 -0400

> if so,  Can a union resonse be used in "subtract" and "audit" command

Impl Guide item 6.24 added the W- and O- to commandRequestList so that
it is available on all commands (& and removed them from subtract and
audit since the other change applies)..
It also added a comment defining
    "W-" indicates an wildcarded response to a command.

> theres no descriptor-level parameters in resonse. (because MG doesn't
> need to make a decision. )
>                                                c=IN IP4
> 125.125.125.111
>                                                       m=audio $
> RTP/AVP 4
>                                                 c=IN IP4
> 124.124.124.222

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla