Subject: RE: [Megaco] Failure of MGC

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 25 Jul 2001 16:58:17 -0400

Works for me.
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, July 25, 2001 4:39 PM
To: 'Terry L Anderson'; Christian Groves
Cc: [email-masked]; [email-masked]
Subject: RE: [Megaco] Failure of MGC

I think (1) ("Disconnected" if reestablishing at same MGC, "Failover" if
trying a new one)is a good solution if agreeable to the list.

Tom Taylor 
[email-masked] 
Ph. +1 613 736 0961 (ESN 396 1490) 

-----Original Message----- 
From: Terry L Anderson [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, July 25, 2001 11:04 AM 
To: Christian Groves 
Cc: [email-masked]; [email-masked] 
Subject: Re: [Megaco] Failure of MGC 

Christian Groves wrote: 

> Hello, 
> 
> I believe 11.5 is correct. The paragraph starts, "If the MG detects a 
> failure of its controlling MGC, it attempts to contact the next MGC on 
> its pre-provisioned list." This is clearly failover. 
> 
> D.1.5, I believe intends "Disconnect" as it is used when communication 
> has been restored (recovered) with the MGC. 

The the wording is wrong as it says "The MS shall use a ServiceChange with 
ServiceChangeMethod set to Disconnected to that the new MGC will  be aware
..."  so it is 
referring to value sent to NEW MGC for restored communication with original
MGC. 

> Disconnect is used when you don't fail over to a completely new MGC. 

Well whichever way we settle, I think the current wording is confusing and
call cases 
should be described in one place. 

So our choice is: 
1) use "failover" in attempts to contact next MGC on pre-provisioned list
(if any) but 
"Disconnected" if (possibly after trying others) one re-tries the original, 
OR 
2) use "Disconnected" in both cases. 

If we choose case 1, I would fix the wording in D.1.5 and spell out BOTH
cases in 11.5. 
Def of Failover in 7.2.8 should include this case (currently it only
includes case of MG 
failure). 
If we choose case 2, I would fix 11.5 to say "disconnected" 

Which do we want?? 

> 
> 
> Regards, Christian 
> 
> Terry L Anderson wrote: 
> > 
> > It DOES look like a contradiction.  I have always wondered about the
11.5 
> > specification to use Failover since this case is not mentioned in the
definition of 
> > failover in 7.2.8 and there the definition of Disconnected does seem to
fit 
> > (agreeing with D.1.5). 
> > 
> > What do others want to do?  Change 11.5 to say "Disconnected"? 
> > 
> > [email-masked] wrote: 
> > 
> > > Hi 
> > > 
> > > Section 11.5 indicates, if the MG detects failure of its controlling
MGC, it 
> > > sends the service change command with Failover method. 
> > > And Section D.1.5 indicates, if more than T-MAX time has elapsed since
the 
> > > sending of initial datagram, the MG concludes that the MGC has failed,
it sends 
> > > the service change command with Disconnected method. 
> > > 
> > > Can you please differentiate between the two? 
> > > 
> > > Regards 
> > > Vivek 
> > > 
> > > _______________________________________________ 
> > > Megaco mailing list 
> > > [email-masked] 
> > > http://www.ietf.org/mailman/listinfo/megaco
<http://www.ietf.org/mailman/listinfo/megaco>  
> > 
> > -- 
> > Waiting for the other shoe to drop but hoping its a one legged man. 
> > ------------------------------------------------------------ 
> > Terry L Anderson              mailto:[email-masked]
<mailto:[email-masked]>  
> > Tel:908.582.7013   Fax:908.582.6729 
> > Lucent Technologies/INS/Voice Over IP Access Networks 
> > Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
> > http://its.lucent.com/~tla <http://its.lucent.com/~tla>  (Lucent
internal) http://www.gti.net/tla <http://www.gti.net/tla>  

-- 
Waiting for the other shoe to drop while hoping it's a one legged man. 
------------------------------------------------------------ 
Terry L Anderson              mailto:[email-masked] <mailto:[email-masked]>

Tel:908.582.7013   Fax:908.582.6729 
Lucent Technologies/INS/Voice Over IP Access Networks 
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
http://its.lucent.com/~tla <http://its.lucent.com/~tla>  (Lucent internal)
http://www.gti.net/tla <http://www.gti.net/tla>

---

From: Christian Groves <[email-masked]>
Date: Thu, 26 Jul 2001 10:17:54 +1000

Work for me also. It was the original intent anyway.

Christian