Subject: underspecified description in RFC 3015

From: [email-masked]
Date: Tue, 3 Jul 2001 18:09:30 +0300

Page 22 of RFC 3015 defines the terms under-specified and over-specified. What I understand here is that if parameters have a list of possible values for the MG to choose from, it is called "over-specified" parameter but the same relation is called as underspecified on page 24 while mentioning about the values that can be assigned to parameters as follows:

Page 22:
 2. Under-specified parameters, using the CHOOSE value, allow the command responder to choose any value it can support.
   3. Over-specified parameters have a list of potential values. The list order specifies the command initiator's order of preference of selection. The command responder chooses one value from the offered list and returns that value to the command initiator.

page 24:
Values assigned to Properties may be simple values (integer/string/enumeration) or may be underspecified, where more than one value is supplied and the MG may make a choice
*  Alternative Values: multiple values in a list, one of which must be selected

Can you please help ?
Thank you.

Ipek Sarac

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 18 Jul 2001 12:09:49 -0400

Sloppy use of language, but does it affect implementation?  I would say page
24 is wrong.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 03, 2001 11:10 AM
To: [email-masked]
Subject: underspecified description in RFC 3015

Page 22 of RFC 3015 defines the terms under-specified and over-specified.
What I understand here is that if parameters have a list of possible values
for the MG to choose from, it is called "over-specified" parameter but the
same relation is called as underspecified on page 24 while mentioning about
the values that can be assigned to parameters as follows:

Page 22:
 2. Under-specified parameters, using the CHOOSE value, allow the command
responder to choose any value it can support.
   3. Over-specified parameters have a list of potential values. The list
order specifies the command initiator's order of preference of selection.
The command responder chooses one value from the offered list and returns
that value to the command initiator.

page 24:
Values assigned to Properties may be simple values
(integer/string/enumeration) or may be underspecified, where more than one
value is supplied and the MG may make a choice
*  Alternative Values: multiple values in a list, one of which must be
selected

Can you please help ?
Thank you.

Ipek Sarac