Subject: SDP Parameters

From: [email-masked]
Date: Mon, 2 Jul 2001 15:51:43 +0530

Hi

Protocol document specifies that the SDP parameter values in Local and Remote
descriptors can be underspecified (CHOOSE - $).
Is there a relationship between the parameter values...actually is it safe to
assume the following:
1.   If Network type is $, address type and address values are also $....seems
logical.
2.   If Network type is specified and Address type is $, address value is also
$....also seems logical.
3.   If Media type is $, transport protocol and payload value are also $...?

MEGACO exceptions to the SDP syntax donot restrict the usage of above values.
Please clarify.......

-Kapil Nayar
Hughes Software Systems

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 2 Jul 2001 09:14:06 -0400

All true, it seems to me, if nonsensical.
The MGC can specify anything it wants, and let the
MG choose anything it wants.  Whether it makes any
sense to do so is questionable.

Address of $ means the MG can send the bits anywhere it wants!

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 02, 2001 6:22 AM
> To: [email-masked]
> Subject: SDP Parameters
> 
> 
> 
> 
> Hi
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 18 Jul 2001 12:06:07 -0400

We probably need a set of conventions on the use of SDP in Megaco.  I
suspect some of the properties would never be wildcarded.  In your third
(and least likely) example, BTW, I would think it possible to specify
transport even if the medium is unspecified. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 02, 2001 6:22 AM
To: [email-masked]
Subject: SDP Parameters

Hi

Protocol document specifies that the SDP parameter values in Local and
Remote
descriptors can be underspecified (CHOOSE - $).
Is there a relationship between the parameter values...actually is it safe
to
assume the following:
1.   If Network type is $, address type and address values are also
$....seems
logical.
2.   If Network type is specified and Address type is $, address value is
also
$....also seems logical.
3.   If Media type is $, transport protocol and payload value are also $...?

MEGACO exceptions to the SDP syntax donot restrict the usage of above
values.
Please clarify.......

-Kapil Nayar
Hughes Software Systems