Subject: Re: IG 6.79 "Cancelling Event Detection" breaks ABNF

From: Troy Cauble <[email-masked]>
Date: Tue, 17 Jul 2001 15:37:50 -0400

No.  I was distracted by other work and stopped pushing it.

I do think numbers 2 through 4 are critical problems though.

-troy

Sharon Welch wrote:
> 
> Greetings,
> 
>   Was there ever a resolution to this issue?  This is the last message I can
> find on the subject.
> 
> Sharon
> 
> Troy Cauble wrote:
> 
> > A summary of the problems discussed in this thread.
> >
> > 1) In the text encoding, some empty descriptors have the form
> >    "Signals {}" while others have "Events".
> >
> > In a Termination Audit:
> >
> > 2) There are two line encodings for an empty Signals descriptor
> >    (text and ASN.1).
> >
> > 3) There are two line encodings each for an empty Events descriptor
> >    or Event Buffer descriptor (ASN.1 only).
> >
> > 4) In the text encoding, EventsToken and EventBufferToken each
> >    have reduce/reduce conflicts because they can represent either
> >    an auditItem token or an empty descriptor in the auditReturnParameter.
> >
> > -troy
> >
> >
> >
> > "Rosen, Brian" wrote:
> > >
> > > I agree with Tom; we did a pass over the ABNF to try to make
> > > all of the empty forms not have braces.  The choice was
> > > completely arbitrary, and as I recall, we decided since it
> > > didn't make any real difference, shorter was better.
> > > If we missed one, we goofed.
> > >
> > > Tom, the problem here seems to be real.  As Troy says, you will get
> > > a reduce conflict in a rules-based parser with this ambiguity.
> > > I'm pretty sure you can ignore the problem, but it's poor design
> > > practice.  You will recall all of the effort Abdallah and Nancy
> > > went through to test out these kinds of things as we developed
> > > the ABNF.  The IG change wasn't verified in the same way, thus
> > > we have this problem.  We need to decide what to do.
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Troy Cauble [mailto:[email-masked]]
> > > > Sent: Thursday, June 07, 2001 6:39 PM
> > > > To: Tom-PT Taylor
> > > > Cc: Rosen, Brian; Christian Groves; MEGACO list
> > > > Subject: Re: IG 6.79 "Cancelling Event Detection" breaks ABNF
> > > >
> > > >
> > > > > Tom-PT Taylor wrote:
> > > > >
> > > > > I'm the one responsible for all this.  I suppose I should
> > > > dig up the thread.
> > > > > Anyway, the intention was definitiely to provide a way of
> > > > signalling empty
> > > > > descriptors.  I think we chose rather arbitrarily between
> > > > the desc{} and desc
> > > > > form, opting for the latter.
> > > >
> > > > Well, an empty Signals Descriptors already uses desc{},
> > > > shouldn't we go for the symmetry?  Didn't we just change
> > > > the original protocol for symmetry reasons?  This would
> > > > be just changing the IG.
> > > >
> > > > -troy
> > > >

---

From: "Sharon Welch" <[email-masked]>
Date: Tue, 17 Jul 2001 15:33:10 -0400

Greetings,

Sharon