Subject: RE: How MPLS is used for Megaco

From: "Kallur, Prasad" <[email-masked]>
Date: Fri, 13 Jul 2001 12:28:00 -0700

Hi Brian,
Completely agree with you and irrespective of whether it is layer violation
or not this is a practical implementation issue that will have to addressed.
Otherwise there will be vendor specific proprietary implementations that
will cause interoperability issues and cause more problems for service
deployment.
Thanks,
Prasad Kallur,
Product Marketing Dir.,
Trillium Digital Systems, an Intel Company,
Ph:310-442-9222, Fax:310-442-1162
email:[email-masked], web:www.trillium.com  

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, July 13, 2001 12:00 PM
To: 'gigyasu balak'; [email-masked]
Subject: RE: How MPLS is used for Megaco

To control direct assignment of a media stream to an MPLS
lsp, an extension to SDP and to Annex C would be needed.
It is unlikely IMO that we would be permitted to do that
in the IETF.  When I tried to talk about that the last time,
I was told it was a "layer violation", a term I heretofore
had not associated with the IETF much.

The very first issue is what is the format of the media
streams?  The MPLS Forum has just released one spec on that
subject, and that is a possibility.  There are other efforts
underway.  We could try to push through an extension for the
former.  The other possibility is that you assume VoIPoMPLS.
In that case, you only need to describe the label.  We could
also try to do that.

In case anyone is wondering why that might be useful,
I would ask you to consider traffic engineering lsps for
voice with admission control into the lsps.  A VERY reasonable
thing to do, layer violation or not.

Brian

> -----Original Message-----
> From: gigyasu balak [mailto:[email-masked]]
> Sent: Friday, July 13, 2001 2:48 PM
> To: [email-masked]
> Subject: How MPLS is used for Megaco
> 
> 
> Hello all
> If MG generates RTP packets over IP how does MPLS be enabled 
> between MG and
> MGC??? Can the MG/MGC differentiate between normal IP, ATM 
> and MPLS??? I
> suppose for IP and ATM already SDP has extensions?? How about MPLS.
> 
> Thanks
> Balaka.
>

---

From: Matt Holdrege <[email-masked]>
Date: Sat, 14 Jul 2001 21:52:00 -0700

It is easy to theorize that the MGC may have access to information that 
would help in traffic management. So yes, an MGC could inject information 
into an MPLS network. How it does that is open for discussion. It could 
speak LDP into the network, or it could send a new megaco message to the MG 
which would do it. However I don't think MG's will necessarily have the 
intelligence to coordinate traffic management info. Therefore a separate 
(probably centralized) traffic management intelligent function might exist 
that would get hints from the MGC. But this is just theory. :-)