Subject: Re:

From: "Atanum" <[email-masked]>
Date: Wed, 4 Jul 2001 16:02:40 +0530

Hi Everybody,
The ABNF spec for megaco defines context property as below

;at-most-once
contextProperty = (topologyDescriptor / priority / EmergencyToken)

This allows contextRequest to have n numbers of topologyDescriptor, priority and EmergencyToken in any combination
according to the ABNF definition...

On the other hand the ASN spec says that ContextRequest will contain only one priority and one emergency and a 
sequence of topologyReq..

In this case which definition one is supposed to follow.....

For a stack supporting both the parser.. it becomes difficult in forming the commands if there is a decrepency in the
grammer of the two spec....

Can anyone please clarify...

Thanking in advance

Atanu Mondal
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture

---

From: Troy Cauble <[email-masked]>
Date: Thu, 05 Jul 2001 09:51:36 -0400

> Atanum wrote:

Here, and in several other places, "at-most-once" means
the RHS components are allowed at most once in any higher
level construct referencing the LHS.

-troy