Subject: about profile

From: [email-masked]
Date: Mon, 9 Jul 2001 15:10:17 +0900

hi, all.

H.248 v1.0 states in section 7.2.8 that "the optional ServiceChangeProfile
parameter specifies the Profile(if any) 
of the protocol supported. Ther ServiceChangeProfile includes the version
of the profile supported".

What is a profile?
What information is included in a profile?
Is there any document about a profile?

thanks in advance.

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Jul 2001 10:28:15 -0400

Megaco, by design, is a flexible protocol.  There is a lot of implementation
freedom so that the protocol can work with a wide variety of MGs.
With this flexibility comes a problem - interoperability at any but the most
basic level.
 
A profile is a mechanism to specify the implementation choices in a
document.
If an MG and an MGC implement a the same profile, there is a very good
chance that they will interoperate.
 
At the moment however, there is not a complete definition of a profile.
There
are, however, some example profiles that you can look at.  My favorite is
the profiles published in draft form by the MSF.  See:
 
http://www.msforum.org/techinfo/MSF-MEDIA-001.00-DRAFT_IA.pdf
<http://www.msforum.org/techinfo/MSF-MEDIA-001.00-DRAFT_IA.pdf> 
and
http://www.msforum.org/techinfo/MSF-MEDIA-002.00-DRAFT_IA.pdf
<http://www.msforum.org/techinfo/MSF-MEDIA-002.00-DRAFT_IA.pdf> 
 
Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 09, 2001 2:10 AM
To: [email-masked]
Subject: about profile

hi, all. 

What is a profile? 

thanks in advance.