Subject: How MPLS is used for Megaco

From: gigyasu balak <[email-masked]>
Date: 13 Jul 2001 12:47:47 MDT

Hello all
If MG generates RTP packets over IP how does MPLS be enabled between MG and
MGC??? Can the MG/MGC differentiate between normal IP, ATM and MPLS??? I
suppose for IP and ATM already SDP has extensions?? How about MPLS.

Thanks
Balaka.

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 13 Jul 2001 16:25:56 -0400

What makes you say the MGC never specifies VPI/VCI?

It would if there was a PVC
It would if there was proxy signalling
It would in some cases if there was an existing SVC using 
AA1/2 and you wanted to describe another bearer.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Friday, July 13, 2001 3:29 PM
> To: 'Rosen, Brian'; 'gigyasu balak'; [email-masked]
> Subject: RE: How MPLS is used for Megaco
> 
> 
> HI Brian,Balaka,All,
> In case of ATM the MGC never specifies any VPI or VCI fields. 
> In case of
> MPLS I wonder why the MGC should give the Label. IMHO the MGC 
> has to only
> indicate the MG that it has to use MPLS for media transfer. 
> Its the MG that
> has to initiate LDP/RSVP-TE or whatever for further media 
> transfer. IMO a
> package defined for this is enough for this purpose. The new 
> package will
> indicate usage of MPLS(if required some more properties for Traffic
> Engineering)
> Regards
> Madhubabu
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rosen, Brian
> Sent: Friday, July 13, 2001 3:00 PM
> To: 'gigyasu balak'; [email-masked]
> Subject: RE: How MPLS is used for Megaco
> 
> 
> To control direct assignment of a media stream to an MPLS
> lsp, an extension to SDP and to Annex C would be needed.
> It is unlikely IMO that we would be permitted to do that
> in the IETF.  When I tried to talk about that the last time,
> I was told it was a "layer violation", a term I heretofore
> had not associated with the IETF much.
> 
> The very first issue is what is the format of the media
> streams?  The MPLS Forum has just released one spec on that
> subject, and that is a possibility.  There are other efforts
> underway.  We could try to push through an extension for the
> former.  The other possibility is that you assume VoIPoMPLS.
> In that case, you only need to describe the label.  We could
> also try to do that.
> 
> In case anyone is wondering why that might be useful,
> I would ask you to consider traffic engineering lsps for
> voice with admission control into the lsps.  A VERY reasonable
> thing to do, layer violation or not.
> 
> Brian
> 
> > -----Original Message-----
> > From: gigyasu balak [mailto:[email-masked]]
> > Sent: Friday, July 13, 2001 2:48 PM
> > To: [email-masked]
> > Subject: How MPLS is used for Megaco
> >
> >
> > Hello all