Subject: Re: query regarding auditReply

From: [email-masked]
Date: Mon, 2 Jul 2001 15:17:29 +0530

Hi all, Baljeet,
     I think we can assume that all the Tokens used in MEGACO grammar are
reserved words and they get precedence
over any ,e.g. Termination ID
     i.e  if the terminationID in auditOther is "Context", since we can get a
ContextToken we will
take it as ContextToken rather than a TerminationID eventhough it is a valid
terminationID.

rgds/
Amit Kalra

[email-masked] on 06/27/2001 07:42:34 PM

To:   [email-masked]
cc:    (bcc: Amit Kalra/HSS)

Subject:  query regarding auditReply

Hi all,
              The MEGACO ABNF grammar has,
 auditReply = (AuditValueToken / AuditCapToken)(contextTerminationAudit /
auditOther)
 auditOther = EQUAL TerminationID LBRKT terminationAudit RBRKT
 contextTerminationAudit = EQUAL CtxToken (terminationIDList / LBRKT
errorDescriptor  RBRKT)

now, if the terminationID in auditOther is "Context" (which is a bit unlikely,
but technically it IS possible)
the parser has no clue as to its parsing auditOther or contextTerminationAudit.

What if the MEGACO message is to be parsed by a parser with no lookahead
whatsoever.
Can't we have all the MEGACO tokens as reserved keywords, thus makin the life of
MEGACO parser developer a bit easier ;-)

Regards,
B.S.Gill

---

From: Troy Cauble <[email-masked]>
Date: Tue, 03 Jul 2001 08:53:45 -0400

I disagree.  It is an unfortunate fact that the protocol 
is context dependent.  This was clarified in the IG 6.54.

Some specific problems were worked around in IG 6.58.
Basically the approach was to reserve, at that point in
the parse, all keywords that might be present at that point
in the parse -- NOT *all* the keywords.

B.S.Gill has found another problem area that should be clarified
in the IG.  There are probably more.

I don't know what's possible in V2, but context free
parsing would be a big improvement.

-troy