Subject: RE: [Megaco] Regarding Generic Announcement Package

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 24 Jul 2001 21:06:04 -0400

I think we goofed on this one.  The intent (I believe) is that the
announcement identifiers are local to the MG and MGC.  Hence it seems more
reasonable that this parameter be a text string.

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

-----Original Message-----
From: Anand, Rashim [mailto:[email-masked]]
Sent: Tuesday, July 24, 2001 8:55 PM
To: [email-masked]'
Subject: [Megaco] Regarding Generic Announcement Package

Hi,
   In Annex K of H.248 the announcement name parameter of the generic
announcement package(an)
has been specified as of enumeration type. However no values have been
specified unlike for eg.
for the announcement direction parameter where there are 3 enumerated values
of the parameter.
Can anyone guide me as to where I can find these values?

Regards,
Rashim

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 25 Jul 2001 12:01:36 +1000

G'Day Tom and Rashim,

I don't think list of ENUM was an error. Basically it leaves people to
define the announcements as they want.

The list could be "a,b,c" or "fred,harry,john" or "hello, this is,
megaco".

There is no "guide" to what these values are as each announcement system
will be made up of its own phrases.

Christian

Tom-PT Taylor wrote:
> announcement identifiers are local to the MG and MGC.  Hence it seems
> more reasonable that this parameter be a text string.
> 
> Tom Taylor

---

From: Troy Cauble <[email-masked]>
Date: Wed, 25 Jul 2001 10:21:25 -0400

Well, either ENUM or STRING "leaves people to define the
announcements they want".

But with ENUM, you pretty much have to publish a Package
and go to IANA for a package number.

STRINGs would allow it to be more informal.

-troy