Subject: [Megaco] TGW to TGW scenario using Megaco

From: "IPEK SARAC" <[email-masked]>
Date: Wed, 25 Jul 2001 17:55:59 +0300

Hello,

I have two questions which are related:

1. Let's consider a Megaco call flow scenario between two trunking SS7
gateways. If UserA is calling UserB through SS7Switch1,TGW1,TGW2,SS7Switch2
in this scenario who produces the "ringing tone" to UserA after s/he dials
the number?
2. In all call flow scenarios in "call flow draft" including a SS7 gateway,
UserA (calling party) waits for the ANM message before adding the physical
and ephemeral connections. How does that make sense? Doesn't that introduce
a delay (i.e. user starts talking but the called party doesn't hear her). So
don't we also have a problem about Modify messages that are send soon after
ANM is received by the calling party.

Thanks in advance
Regards.

Ipek Sarac

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 25 Jul 2001 11:17:13 -0400

If you are really talking a trunking gateway, then neither of
MGs generate ring tone; subscribers aren't connected to
trunk gateways.  Typically ss7Switch2 would generate ringtone.

Message sequences in the examples are just that, examples.
Real sequences have to create one direction audio to allow
ringtone and audio when user B answers to proceed.
Receipt of ANM has to cutover two way audio.

Brian

> -----Original Message-----
> From: IPEK SARAC [mailto:[email-masked]]
> Sent: Wednesday, July 25, 2001 10:56 AM
> To: [email-masked]
> Subject: [Megaco] TGW to TGW scenario using Megaco
> 
> 
> Hello,
>