Subject: [Megaco] Errors in SDP Strings.

From: "Andrew Russell-laing" <[email-masked]>
Date: Tue, 21 Aug 2001 16:07:47 +0100

Hi,

     SDP is an embedded protocol within the H.248 specification and hence the
lines of an SDP string
     are not part of the H.248 protocol. As far as the H.248 syntax is concerned
the SDP string is valid
     provided it conforms to the structure of an octetstring (text encoding).

     If the above assumption is correct, then it does not seem valid to use any
of the H.248 protocol
     error codes to report a SDP protocol syntax error.

     Is this correct and if so what action should an MG take when it detects an
SDP protocol syntax error.

     Any answers ?

     Thanks.

Andrew Russell-Laing
Marconi

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 22 Aug 2001 11:25:39 +1000

I think it should be handled as part of H.248 as SDP is a syntax for the
Local and Remote descriptor and a syntax error should be returned via
H.248 ie. Syntax Error in Command.

Regards, Christian