Subject: RE: [Megaco] Event's detection

From: Dan Elbert <[email-masked]>
Date: Tue, 21 Aug 2001 10:42:45 -0500

There is a parameter "strict " for the off-hook event whereby the off-hook
can be reported even if the phone is already off hook.
So if you use that parameter, after step (6) you return to (1) but asking
for off hook detection even if is of hook, the MG will reply immediately and
the MGC will resync the state.
Set "strict" to either "state" if you want the event to be reported anyway
or to "failWrong" if you want an error message .
By the way, the default behavior if "strict" is not set is not defined, I
once proposed to have "state" as default behavior.

Dan Elbert
RADVISION

-----Original Message-----
From: Safa Mohammad [mailto:[email-masked]]
Sent: Tuesday, August 21, 2001 11:27 AM
To: [email-masked]
Subject: [Megaco] Event's detection

Hi,

Can you please help with the following:

1) MGC asks the MG to listen to off hook
2) MG detects off hook and send notify to the MGC
3) The MGC sends a new events descriptor, asking to listen to on hook
4) The MG detects on hook. Sends notify to the MGC
5) The MG emidiatly (before getting replay form MGC for the notify it
sent in step 4) detects off hook.
     This off hook is ignored because the MG is not asked to listen to
it.
6) The MG gets the reply from the MGC. And the MGC is asking to stop all
the signals (the MGC thinks that the MG is in on hook state)
7) The result is that the off hook in step 5 get lost.

What is the suggested approach to solve this problem.

Thanks

Safa

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 23 Aug 2001 11:07:07 -0400

My recollection is that I agreed with you on making "state" the default.
Any other thoughts, anyone?

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Tuesday, August 21, 2001 11:43 AM
To: 'Safa Mohammad'; [email-masked]'
Subject: RE: [Megaco] Event's detection

Dan Elbert
RADVISION

-----Original Message-----
From: Safa Mohammad [mailto:[email-masked]]
Sent: Tuesday, August 21, 2001 11:27 AM
To: [email-masked]
Subject: [Megaco] Event's detection

Hi,

Thanks

Safa