Subject: [Megaco] MG handover

From: "Ternovsky, Igor" <[email-masked]>
Date: Tue, 14 Aug 2001 06:20:42 +0200

Hello List,

Assume that MG is provisioned with MIDs of MGC1 and MGC2. MGC1 is the
current master.
All of the sudden MG gets a request (not ServiceChange, nor Audit) from
MGC2.
What is the correct MG behavior in this case?

1) accept the request and assume that MGC2 became a new master (implicit
redirection).
	- new Notify s will be sent to MGC2
	[ flush table of confirmed transactions from MGC1 ] 
2) accept the request keeping the old master.
	- new Notify s will be sent to MGC1
	- MG has to keep two tables of confirmed transactions
3) reject the request and wait for ServiceChange with redirection

The second not related question that I posted some time ago, but it passed
unnoticed.

How MGC can turn on/off a silence suppression? There seems to be no the
appropriate SDP attribute.
In MGCP SilenceSuppression is controlled by using LocalConnectionOptions .

Thanks,

Igor Ternovsky
[email-masked]
+972 9 9717414

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Arun Velayudhan" <[email-masked]>
Date: Tue, 14 Aug 2001 09:31:07 -0400

I am new to Megaco, but from MGCP experiance I have a question on this
topic.
Won't MG be provisioned with MGC's domain id.ie MGC1 and MGC2 will have the
same domain but different IPAddress, since they are redundant systems.
So it is irrelavant from MG's prespective which MGC it is talking to.I guess
MG always sends requests/response to the domain defined.Pls clarify.

Arun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Ternovsky, Igor
Sent: Tuesday, August 14, 2001 12:21 AM
To: Megaco (E-mail)
Subject: [Megaco] MG handover

Hello List,

Thanks,

Igor Ternovsky
[email-masked]
+972 9 9717414

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 14 Aug 2001 09:56:57 -0400

Ternovsky, Igor wrote:

>...
Annex C has a property Silencesupp 1008 that can be used for binary 
encoding.

RFC 3108 SDP for ATM Bearer Connections added an attribute a=silenceSupp
that can be used for text encoding (even though it was added for ATM it 
is suitable equally for IP bearers

-- 
Waiting for the other shoe to drop but hoping its a one legged man.
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla