Subject: [Megaco] Event descriptor in Subtract

From: gigyasu balak <[email-masked]>
Date: 17 Aug 2001 08:36:43 MDT

Hello all
Why the MGC cant send event and signal descriptors in Subtract command. This
was a useful feature in MGCP, why not in Megaco.

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 20 Aug 2001 13:20:53 -0400

Because commands are local to a CONTEXT, and after the subtract,
the termination is no longer in that context.  

We could have defined everything differently, but we chose not to.

You are a couple of tokens away to a Modify after the subtract, not
a big deal.

Brian

> -----Original Message-----
> From: gigyasu balak [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 10:37 AM
> To: [email-masked]
> Subject: [Megaco] Event descriptor in Subtract
> 
> 
> Hello all

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 23 Aug 2001 10:45:54 -0400

I assume you're talking about Subtract of a persistent termination.  You get
the desired effect with less ambiguity by including a Modify as well as the
Subtract.  The Modify would have to be in a separate Action if it followed
the Subtract, since the context of the termination will have changed to
NULL.

-----Original Message-----
From: gigyasu balak [mailto:[email-masked]]
Sent: Friday, August 17, 2001 10:37 AM
To: [email-masked]
Subject: [Megaco] Event descriptor in Subtract

Hello all