Subject: [Megaco] Wildcarding Terminations in Topology Descriptor

From: "Andrew Russell-laing" <[email-masked]>
Date: Mon, 6 Aug 2001 11:44:07 +0100

When adding an ephemeral termination to an existing Context  (Fan-Out
Connection), we require to
"Isolate" that ephemeral termination from all other ephemeral terminations in
the context,and set "Oneway"
between the ephemeral termination and the fixed termination in the Context.

To do this we are using the topology descriptor encoding :-

TP { * , $ , Isolate, FixedTerminationId  , $ , OneWay }

The inference from the protocol is that the transaction reply will contain a
topology triple between the ephemeral
termination and each termination determined by the ALL (*).

When dealing with large Fan-out connections of 50 or more terminations, this
causes a large overhead on
message sizes.

Is it valid to use the following as the topology descriptor in the response :-

TP { * , EphemeralTerminationId , Isolate,
     FixedTerminationId  ,EphemeralTerminationId , Sendonly }

thus avoiding a large topology descriptor in the response.

If this is not valid, is there any other way of encoding the response to
overcome this.

Thanks

Andrew Russell-Laing
Marconi

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 07 Aug 2001 11:24:48 +1000

G'Day Andrew,

There is no way currently in H.248 do a wildcarded return on Context
Attributes as its done at a command level. So unfortunately you do get
the individual responses for each wildcarded instance.

Cheers, Christian

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco