Subject: [Megaco] How To make AuditCapabilities Reply at MG for Media e.g. Codecs in Text and Binary

From: "asrarashraf" <[email-masked]>
Date: Wed, 22 Aug 2001 13:23:42 +0500

hi !
	 I am facing problem in making an AuditCapablities reply at MG and tell MGC
about CODECs I do have at Gateway.
Can any one guide  Which of following syntax will be fine.If there is
something else please guide.There is also confusion about IP and Port that
that whether they will be choose($) or a specific on e being used.

First option:-
	MG to MGC:
	   MEGACO/1 [209.110.59.34]:25000
	   Transaction = 1235 {
	     Context = - {
	           AuditCapability  = TermA{
		             Media {
       			          TerminationState { ServiceState = InService,
			                     Buffer = OFF },
			                Stream = 1 {
			                    LocalControl { Mode = SendReceive,
					                       nt/jit=40 },
			                    Local {
					   v=0
					   c=IN IP4 209.110.59.33
					   m=audio $ RTP/AVP  0
					   v=0
					   c=IN IP4 209.110.59.33
					   m=audio $ RTP/AVP 4
					   v=0
					   c=IN IP4 209.110.59.33
					   m=audio $ RTP/AVP  8
					   v=0
					   c=IN IP4 209.110.59.33
					   m=audio $ RTP/AVP  12

				                  },
				}
			}
		}
	}

Second Option:-

MG to MGC:
	   MEGACO/1 [209.110.59.34]:25000
	   Transaction = 1235 {
	     Context = - {
	           AuditCapability  = TermA{
		             Media {
       			          TerminationState { ServiceState = InService,
			                     Buffer = OFF },
			                Stream = 1 {
			                    LocalControl { Mode = SendReceive,
					                       nt/jit=40 },
			                    Local {
					   v=0
					   c=IN IP4 209.110.59.33
					   m=audio $ RTP/AVP  0
					   m=audio $ RTP/AVP 4
					   m=audio $ RTP/AVP  8
					   m=audio $ RTP/AVP  12

				                  },
				}
			}
		}
	}

Thanks
Asrar
Avaz Networks

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Preeti Sharma <[email-masked]>
Date: Wed, 22 Aug 2001 07:31:40 -0400

Hi ,
  I do not have an answer but I think it could also be :

MG to MGC:
           MEGACO/1 [209.110.59.34]:25000
           Transaction = 1235 {
             Context = - {
                   AuditCapability  = TermA{
                             Media {
                                  TerminationState { ServiceState = InService,
                                             Buffer = OFF },
                                        Stream = 1 {
                                            LocalControl { Mode = SendReceive,
                                                               nt/jit=40 },
                                            Local {
                                           v=0
                                           c=IN IP4 209.110.59.33
                                           m=audio $ RTP/AVP  0 4 8 12
                                          },
                                }
                        }
                }
        }
or can it ?
Preeti.

---

From: Troy Cauble <[email-masked]>
Date: Wed, 22 Aug 2001 14:17:26 -0400

>                                            m=audio $ RTP/AVP  12

Asrar,

Note that the following is legal SDP (also?).  I don't know about
the expectations of an H.248 environment, though.  They've bent
a lot of other SDP specifications.

Also, the leading whitespace on the SDP lines in your example
is illegal.

-troy