Subject: [Megaco] Topology support and use

From: Dan Elbert <[email-masked]>
Date: Mon, 13 Aug 2001 10:01:03 -0500

Hi All

The topology descriptor is defined as optional to implement. If the MGC
implements topology and wants to use it with the MG, how can it discover if
the MG supports it ? There seems to be no mechanism to do it, neither by
Audit, by profile, or by returning an error. This makes the topology almost
unusable except in cases that the MGC knows exactly the MG implementation.
Any ideas ?

Dan Elbert
RADVISION

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Dan Elbert <[email-masked]>
Date: Mon, 13 Aug 2001 13:12:30 -0500

OK, then I think that we should add a note in the IG about returning error
444 if the topology is not implemented.

Dan

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, August 13, 2001 1:36 PM
To: 'Dan Elbert'
Subject: RE: [Megaco] Topology support and use

You should get an error if you send a topology descriptor
and the MG doesn't implement topology.  We should agree on
which error: I propose 444 Unsupported or Unknown Descriptor

It would be possible to define a package - TopologySupport,
which had a single property - TopologySupported.  You could
then audit Root to find out.  Maybe we could generalize that
a bit.

Brian

> -----Original Message-----
> From: Dan Elbert [mailto:[email-masked]]
> Sent: Monday, August 13, 2001 11:01 AM
> To: [email-masked]'
> Subject: [Megaco] Topology support and use
>
>
> Hi All
>