Subject: [Megaco] Event's detection

From: Safa Mohammad <[email-masked]>
Date: Tue, 21 Aug 2001 08:27:08 -0700

Hi,

Can you please help with the following:

1) MGC asks the MG to listen to off hook
2) MG detects off hook and send notify to the MGC
3) The MGC sends a new events descriptor, asking to listen to on hook
4) The MG detects on hook. Sends notify to the MGC
5) The MG emidiatly (before getting replay form MGC for the notify it
sent in step 4) detects off hook.
     This off hook is ignored because the MG is not asked to listen to
it.
6) The MG gets the reply from the MGC. And the MGC is asking to stop all
the signals (the MGC thinks that the MG is in on hook state)
7) The result is that the off hook in step 5 get lost.

What is the suggested approach to solve this problem.

Thanks

Safa

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 21 Aug 2001 11:43:37 -0400

HI Safa,
Simple solution is to include offhook in the events descriptor after onhook
is recognized.
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Safa Mohammad
Sent: Tuesday, August 21, 2001 11:27 AM
To: [email-masked]
Subject: [Megaco] Event's detection

Hi,

Thanks

Safa

---

From: Troy Cauble <[email-masked]>
Date: Tue, 21 Aug 2001 12:29:17 -0400

> What is the suggested approach to solve this problem.

See section 7.1.9, where it describes "LockStep" mode and
the EventBufferDescriptor.

Also note that the MGC could ask for both on-hook and off-hook.
But you'd still need LockStep to guarantee ordered delivery.

-troy