Subject: RE: Modem Descriptor: was Re: [Megaco] FW: Topology Descriptor

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 24 Aug 2001 09:05:01 -0400

Assuming no views to the contrary, I'll provide a contribution to the SG 16
meeting proposing this.  It leaves us dependent on the SDP-for-TDM draft I
submitted to MMUSIC for a means to specify modem information in text form.
That's appropriate, since I did the work in furtherance of the NAS
application.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, August 24, 2001 8:49 AM
To: 'Christian Groves'; Taylor, Tom-PT [NORSE:B881:EXCH]
Cc: 'Venkatesh A'; megaco
Subject: RE: Modem Descriptor: was Re: [Megaco] FW: Topology Descriptor

I'm very willing to deprecate modem.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, August 23, 2001 11:28 PM
> To: Tom-PT Taylor
> Cc: 'Venkatesh A'; megaco
> Subject: Modem Descriptor: was Re: [Megaco] FW: Topology Descriptor 
> 
> 
> I'd vote for getting rid of the modem descriptor but brian 
> came up with
> a use case.
> 
> Christian
> 
> Tom-PT Taylor wrote:
> > 
> > The topology descriptor is needed for very specialized situations
> > involving more than two terminations in a context.  An example is
> > where you want the ability for an operator to break into a 
> conference,
> > talk to one party who can still hear the conference in the 
> background,
> > but the operator cannot either hear or talk to the other
> > participants.  It is also useful for legal intercept where 
> you have to
> > route the two directions of media flow for the intercepted 
> termination
> > to separate wiretap terminations.  I'll warn you on this one that in
> > some people's opinion it fails to meet legal requirements in the US
> > because a craftsperson monitoring MGC messages could detect 
> that legal
> > intercept is happening.
> > 
> > As for the modem descriptor, I put out a query ages ago 
> asking whether
> > we could deprecate it.  I got no responses.
> > 
> > -----Original Message-----
> > From: Venkatesh A [mailto:[email-masked]]
> > Sent: Thursday, July 19, 2001 2:22 AM
> > To: megaco
> > Subject: [Megaco] FW: Topology Descriptor - What is the need?
> > 
> > Any answers?
> > 
> > Regards
> > Venkatesh
> > 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Venkatesh A
> > Sent: Wednesday, July 18, 2001 4:03 PM
> > To: [email-masked]
> > Subject: Topology Descriptor - What is the need?
> > 
> > Halo Everybody,
> > 
> > I dont understand the real advantange of implementing the Topology
> > Descriptor in MEGACO.  Can somebody explain it along with a 
> practical
> > situation where it is absolutely necessary?  I want to know the same
> > for
> > Modem Descriptor also.
> > 
> > Thanks in advance.
> > 
> > Venkatesh
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Fri, 24 Aug 2001 10:11:34 -0400

If Topology is very specialized, shouldn't it be a package
rather than a descriptor?

Similarly, why are't the Multiplex and Modem Descriptors packages?

-troy

---

From: Christian Groves <[email-masked]>
Date: Mon, 27 Aug 2001 14:28:06 +1000

G'Day Troy,

Topology is implemented on a context level and as such is really a
property of a context.  It is also being used in many implementations so
I don't think we should change it. Multiplex descriptor is a hybrid in
that it relates to many terminations and provides a link between them. I
am currently writing a contribution to be apply to extend all
descriptors via packages so that we don't have to open up the protocol
in the future.

Before we write off ModemDescriptor completely I brought this up a
couple of months ago and this was the reply from Brian: 
"To remind those who haven't been in the development of
Megaco/H.248 from the beginning, MODEM was supposed to address
the case where (possibly multiple) streams were sent through a
dial-up connection.  It was proposed to use MODEM to control
demodulation, then MULTIPLEX to control demultiplexing, and then
a termination represents each of the streams.  The example used
is H.324 I believe."

If this is still the case then modem may still be needed.

Cheers, Christian