Subject: Re: [Megaco] ServiceChangeReason parameter

From: "Harry Suede" <[email-masked]>
Date: Sat, 04 Aug 2001 01:15:35 +0800

Hi Terry, Christian

I do not see the reason why you want to have the service change reason as a mandatory parameter. This field seems to have significance only in case of RESTART or FAILOVER methods . Apart from these the rest of the methods  indicate either failure (FORCED or HANDOFF) or transient failure (DISCONNECTED) , for which we don't need a reason. 

May be the text can suggest that reason should be sent for some of the parameters like RESTART and if it is not sent, then some default values must be specified for each of them in the protocol.

-Harry

-- 

_______________________________________________
Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 
http://www.net2phone.com/cgi-bin/link.cgi?143 

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 03 Aug 2001 13:33:04 -0400

I am not arguing the issue of whether it is useful but that description in body and the text and binary syntax should all agree.  Whether or not it was wise, it was clearly indicated as required in the description and binary encodings and so the text encoding syntax should agree.  I believe that it was always intended to be required and
changing that now would impact existing implementations.

One might be inclined to argue that since the quotedString part of errorDescriptor is optional so should the serviceChangeReason, but notice that serviceChangeReason is NOT an arbitrary string description.  It is a numeric code optionally followed by a text description (this was clarified in IG 6.86).  So the text description IS optional.
It is the numeric reason code that is required.

--
Waiting for the other shoe to drop but hoping its a one legged man.
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla