Subject: [Megaco] [Megaco]: ABNF, pathDomainName and *

From: Steven Weisz <[email-masked]>
Date: Tue, 21 Aug 2001 15:10:18 -0400

Hi List,

Does the '*' character in the pathDomainName indicate the ALL wildcard? It
seems to be valid but I can't think of any real for having the ALL wildcard
in the domain name.

Steven Weisz

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 23 Aug 2001 15:36:48 -0400

Ah, but it does, sort of.  One is able to wildcard over terminations
matching a given naming pattern, regardless of domain.

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, August 23, 2001 2:42 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]
Cc: [email-masked]'
Subject: Re: [Megaco] [Megaco]: ABNF, pathDomainName and *

pathNAME is also used in TerminationID.
Not that this addresses the original question.
-troy

> Tom-PT Taylor wrote:
> 
> I can see your point.  As far as I can see, pathDomainName is used only in
> pathName, which in turn is used only in deviceName, which is used only in
> mID.
> 
> -----Original Message-----
> From: Steven Weisz [mailto:[email-masked]]
> Sent: Tuesday, August 21, 2001 3:10 PM
> To: [email-masked]'
> Subject: [Megaco] [Megaco]: ABNF, pathDomainName and *
> 
> Hi List,
>

---

From: Steven Weisz <[email-masked]>
Date: Thu, 23 Aug 2001 15:49:25 -0400

Does this imply that within a media gateway we could have terminations with
completely different domain names? And if so what does domain name mean in
this context? From my perspective all my terminations within my Gateway
would have the same domain name, and since comands seem to be directed at a
particular gateway, being able to "Wildcard" the domain name doesn't seem to
be useful. Granted if I've missed something in my understanding of the
protocol, please ignore "my perspective. but let me know what I've missed ;)
 
In a related question if "*" is valid, why not "$"
 
Steve

-----Original Message----- 
From: Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, August 23, 2001 2:42 PM 
To: Taylor, Tom-PT [NORSE:B881:EXCH] 
Cc: [email-masked]' 
Subject: Re: [Megaco] [Megaco]: ABNF, pathDomainName and * 

> From: Steven Weisz [ mailto:[email-masked]
<mailto:[email-masked]> ] 

> seems to be valid but I can't think of any real for having the ALL
wildcard 
<http://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 23 Aug 2001 16:43:07 -0400

"$" should be valid -- have to review that.  We've been treating
terminationIDs as something defined by local convention, so it is possible
some vendor could implement or operator could provision multiple domain
names in the same MG.

-----Original Message-----
From: Steven Weisz [mailto:[email-masked]]
Sent: Thursday, August 23, 2001 3:49 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Troy Cauble'
Cc: [email-masked]'
Subject: RE: [Megaco] [Megaco]: ABNF, pathDomainName and *

 
Steve