Subject: RE: Modem Descriptor: was Re: [Megaco] FW: Topology Descriptor

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 24 Aug 2001 10:53:05 -0400

That takes a BIG change to the protocol definition since 
Packages can't add descriptors, only properties, events,
signals and statistics.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Friday, August 24, 2001 10:12 AM
> Cc: 'megaco'
> Subject: Re: Modem Descriptor: was Re: [Megaco] FW: Topology 
> Descriptor
> 
> 
> 
> If Topology is very specialized, shouldn't it be a package
> rather than a descriptor?
> 
> Similarly, why are't the Multiplex and Modem Descriptors packages?
> 
> -troy
> 
> 
> Tom-PT Taylor wrote:
> > 
> > Assuming no views to the contrary, I'll provide a 
> contribution to the SG 16
> > meeting proposing this.  It leaves us dependent on the 
> SDP-for-TDM draft I
> > submitted to MMUSIC for a means to specify modem 
> information in text form.
> > That's appropriate, since I did the work in furtherance of the NAS
> > application.
> > 
> > -----Original Message-----
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: Friday, August 24, 2001 8:49 AM
> > To: 'Christian Groves'; Taylor, Tom-PT [NORSE:B881:EXCH]
> > Cc: 'Venkatesh A'; megaco
> > Subject: RE: Modem Descriptor: was Re: [Megaco] FW: 
> Topology Descriptor
> > 
> > I'm very willing to deprecate modem.
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: Christian Groves [mailto:[email-masked]]
> > > Sent: Thursday, August 23, 2001 11:28 PM
> > > To: Tom-PT Taylor
> > > Cc: 'Venkatesh A'; megaco
> > > Subject: Modem Descriptor: was Re: [Megaco] FW: Topology 
> Descriptor
> > >
> > >
> > > I'd vote for getting rid of the modem descriptor but brian
> > > came up with
> > > a use case.
> > >
> > > Christian
> > >
> > > Tom-PT Taylor wrote:
> > > >
> > > > The topology descriptor is needed for very specialized 
> situations
> > > > involving more than two terminations in a context.  An 
> example is
> > > > where you want the ability for an operator to break into a
> > > conference,
> > > > talk to one party who can still hear the conference in the
> > > background,
> > > > but the operator cannot either hear or talk to the other
> > > > participants.  It is also useful for legal intercept where
> > > you have to
> > > > route the two directions of media flow for the intercepted
> > > termination
> > > > to separate wiretap terminations.  I'll warn you on 
> this one that in
> > > > some people's opinion it fails to meet legal 
> requirements in the US
> > > > because a craftsperson monitoring MGC messages could detect
> > > that legal
> > > > intercept is happening.
> > > >
> > > > As for the modem descriptor, I put out a query ages ago
> > > asking whether
> > > > we could deprecate it.  I got no responses.
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Fri, 24 Aug 2001 11:34:11 -0400

As Tom surmised, I was really asking if these could 
be properties on other descriptors.  

-troy