Subject: [Megaco] IP Phone question

From: Dan Elbert <[email-masked]>
Date: Thu, 9 Aug 2001 09:01:38 -0500

Hi

If the MG implements the IP phone package, what will be the best way to
display the digits being dialed by the user ?
If the MGC is only waiting for the "ec" event (digitmap matching) then it
will not receive the digits before the number finalize dialing,
and it will not be able to tell the MG to display them.
If the MGC is receiving each digit, then it can tell the MG to display it,
but seems pretty wasteful to do it this way, and generate a lot of traffic.
It seems like there should be some way (property ?) to tell the MG : echo
the dialed digits to the display, using this coordinates.
Any thoughts ?

Dan Elbert
RADVISION

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Blatherwick, Peter" <[email-masked]>
Date: Thu, 9 Aug 2001 10:18:57 -0400

There is no "IP Phone Package" of course, IP Phone Profile specifies use of a set of Packages from Annex G.  How to get key inputs to the display in some automatic way was not addressed in Annex G for a bunch of reasons: 1) the UI of an IP Phone is extremely flexible with possible display inputs coming from many sources, not just keypad; 2) any specified automatic method would be a constraint on user interface design we did not want to impose; 3) there is an easy solution to simply watch all key events; 4) where to stop with such automatic mechanisms and all the constraints/assumptions they imply.   

I'd suggest method 3 (i.e. don't use a digitmap) or implement a product-specific method with the products UI assumptions built in (realizing this will constrain how the MGC side can make use of the UI resource).  

We did consider an "echo" approach by the way, but did not find a clean approach so decided to move on. 

-- Peter Blatherwick

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: August 9, 2001 10:02
To: [email-masked]'
Subject: [Megaco] IP Phone question

Hi

Dan Elbert
RADVISION

---

From: Dan Elbert <[email-masked]>
Date: Thu, 9 Aug 2001 10:48:49 -0500

Sorry, of course I meant the IP Phone profile.
The problem with implementing a product-specific method is that it seems
that the MGC can get out of sync with the display.
So for example if the MGC wants to display something and the MG wants to
display the digits what happens is not very well defined.
On a small display is not be very efficient to reserve a part of the display
for the MG "internal" use.
If somebody goes this approach, is there a way to tell the MGC that at some
point the display capabilities have been changed ? So maybe the MG can take
the display for itself only when it needs it.
Don't using a digitmap doesn't seems a very good solution.

Dan

-----Original Message-----
From: Blatherwick, Peter [mailto:[email-masked]]
Sent: Thursday, August 09, 2001 10:19 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: [Megaco] IP Phone question

There is no "IP Phone Package" of course, IP Phone Profile specifies use of
a set of Packages from Annex G.  How to get key inputs to the display in
some automatic way was not addressed in Annex G for a bunch of reasons: 1)
the UI of an IP Phone is extremely flexible with possible display inputs
coming from many sources, not just keypad; 2) any specified automatic method
would be a constraint on user interface design we did not want to impose; 3)
there is an easy solution to simply watch all key events; 4) where to stop
with such automatic mechanisms and all the constraints/assumptions they
imply.  

I'd suggest method 3 (i.e. don't use a digitmap) or implement a
product-specific method with the products UI assumptions built in (realizing
this will constrain how the MGC side can make use of the UI resource). 

We did consider an "echo" approach by the way, but did not find a clean
approach so decided to move on.

-- Peter Blatherwick

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: August 9, 2001 10:02
To: [email-masked]'
Subject: [Megaco] IP Phone question

Hi

Dan Elbert
RADVISION

---

From: "Blatherwick, Peter" <[email-masked]>
Date: Thu, 9 Aug 2001 11:56:10 -0400

Yup, there are PLENTY of issues for any automatic mechanism.  

One of the tough limitations is Megaco does not provide a way to trigger reflex actions to get signals "played" one termination based on events received at another.  This may become a Version 2 mechanism, but it is not there now.  

-- Peter

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: August 9, 2001 11:49
To: 'Blatherwick, Peter'; Dan Elbert; [email-masked]'
Subject: RE: [Megaco] IP Phone question

Dan

-----Original Message-----
From: Blatherwick, Peter [mailto:[email-masked]]
Sent: Thursday, August 09, 2001 10:19 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: [Megaco] IP Phone question

-- Peter Blatherwick

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: August 9, 2001 10:02
To: [email-masked]'
Subject: [Megaco] IP Phone question

Hi

Dan Elbert
RADVISION