Subject: [Megaco] (no subject)

From: "Atanum" <[email-masked]>
Date: Tue, 7 Aug 2001 20:29:49 +0530

> Hi All,
> 
> I need a clarification on the following :
> 
> In ABNF, streamParm contains localDescriptor and remoteDescriptor  which
> are both defined as "octet string".
> 
> streamParm = ( localDescriptor / remoteDescriptor /
> localControlDescriptor )
> localDescriptor      = LocalToken LBRKT octetString RBRKT
> remoteDescriptor     = RemoteToken LBRKT octetString RBRKT
> 
> 
> In ASN, streamParms contains 2 localRemoteDescriptors which is defined
> as Sequence of PropertyGroup. PropertyGroup in turn is a sequence of
> PropertyParm. 
>    StreamParms ::= SEQUENCE
>    {
>         localControlDescriptor     LocalControlDescriptor
> OPTIONAL,
>         localDescriptor            LocalRemoteDescriptor
> OPTIONAL,
>         remoteDescriptor           LocalRemoteDescriptor
> OPTIONAL,
>         ...
>    }
> 
>    LocalRemoteDescriptor ::= SEQUENCE
>    {
>         propGrps        SEQUENCE OF PropertyGroup,
>         ...
>    }
>    PropertyGroup ::= SEQUENCE OF PropertyParm
> 
> 
> Why is there a difference in the definitions of localDescriptor &
> remoteDescriptor between ASN and ABNF?
> Can anyone kindly clarify the reason for this discrepancy or am I
> missing something?
> 
> Thanks in Advance
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 09 Aug 2001 13:10:50 -0400

They are indeed quite different because of the decision to re-use SDP for
defining the properties of local and remote media streams in the text-encoded
case.  Thus in text-encoding each Descriptor contains an instance of an SDP
announcement.  Binary uses a totally different, binary method of tag/value
pairs that is intended to describe roughly the same information (but there are
clear differences at this time).  So the syntax descriptions are very
different because very different notations are used to describe the media flow
properties.

--
Waiting for the other shoe to drop but hoping its a one legged man.
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla