Subject: [Megaco] Hexa representation for octet string

From: Padmaja Musti <[email-masked]>
Date: Wed, 10 Oct 2001 17:43:36 +0530

Hi,
As per IG Jun 2001 - octetString need to be represented in Hexa format.
This effects SDP,MTP address ... IG does not mention that this Hexa
should be started with 0x. In other cases like Authentication Header
and Packages (IG 6.80) Hexa is always started with "0x". Can
we have a uniform definition.
regards,
Padma.

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Oct 2001 10:14:25 -0400

> we have a uniform definition.

octetString is a misnomer.  It is not in hexadecimal format.

   localDescriptor      = LocalToken LBRKT octetString RBRKT

   remoteDescriptor     = RemoteToken LBRKT octetString RBRKT

   ; octetString is used to describe SDP defined in RFC2327.
   ; Caution should be taken if CRLF in RFC2327 is used.
   ; To be safe, use EOL in this ABNF.
   ; Whenever "}" appears in SDP, it is escaped by "\", e.g., "\}"
   octetString          = *(nonEscapeChar)
   nonEscapeChar        = ( "\}" / %x01-7C / %x7E-FF )

-troy