Subject: RE: [Megaco] What exactly constitutes Version 1 ?

From: "Harry Suede" <[email-masked]>
Date: Tue, 02 Oct 2001 14:27:47 +0800

Hi 

 Thanks for the clarification. The idea of having an ID for capturing the updations also looks fine to me.

 I have one more question regarding the IG just submitted to ITU. Earlier these IGs used to have version numbers which helped us keep track of them. Things got a bit confusing after IGv7. This recent submission also does not seem to have any version number. How does one refer to it ? Should it be called Implementation Guide (June 2001) ? 

 Also, (I know I am being a bit touchy)  the Introduction section of  IG (June 2001) seems to suggest that the corrections are only part of subsequent versions. There should be a line saying that Implementors are advised to conform to this Guide in order to ensure that their implementations are up to date.

Thanks
Harry

-----Original Message-----
From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 1 Oct 2001 10:33:37 -0400
To: "'Harry Suede'" <[email-masked]>, [email-masked]
Subject: RE: [Megaco] What exactly constitutes Version 1 ?

> I'll give you two answers: the practical one, and the formal one.
> 
> The practical answer is that Version 1 consists of the protocol as
> documented in RFC 3015 or ITU-T Rec. H.248 (June, 2000) plus the latest
> approved H.248 Implementor's Guide (June, 2001).  Note that RFC 3015 has a
> few small errors compared with the H.248 document.  The URL you cite
> probably gives the June 2001 approved version of the IG, but for safety you
> should get the official version, just posted last week, at 
> http://www.itu.int/itudoc/itu-t/com16/implgd/h248-ig.html
> 
> The formal answer is that because the IETF lacks the equivalent to the ITU
> Implementor's Guide, RFC 3015 is the official IETF view of Version 1.
> Normally we would recycle that document in a movement toward Draft Standard,
> so you would have an Internet Draft containing the latest view of the
> protocol including corrections.  The problem is that we don't want to risk
> divergence between Megaco and H.248, so the more likely update route will be
> to co-develop the next version of the H.248 Recommendation with SG 16.
> Discussion of this topic at the last IETF meeting revealed a fairly clear
> consensus that Megaco participants don't want to see another version of
> Megaco/H.248 for another year, until we get solid deployment experience.  If
> this is also the list consensus, I can report this view into the next SG 16
> Rapporteur's meeting at the end of the month.
> 
> I am left with one thought.  Should we have an I-D on the table consisting
> of RFC 3015 plus approved corrections (i.e.) the latest approved version of
> the Implementor's Guide?
> 
> -----Original Message-----
> From: Harry Suede [mailto:[email-masked]]
> Sent: Monday, October 01, 2001 4:16 AM
> To: [email-masked]
> Subject: [Megaco] What exactly constitutes Version 1 ?
> 
> 
> Hi All
> 
>  I am a bit unsure about what exactly constitutes 'Version 1' of the MEGACO
> protocol.
> Is it just the RFC 3015 ? Or do the subsequent IGs also form a part of it.
> 
>  RFC 3015 was itself made up of megaco_merged_01.txt and IGv3, right ?
> 
>  Is the document located at 
> ftp://standard.pictel.com/avc-site/0105_Por/PL-015_H248_imp_guide.zip, the
> the latest approved IG ? Where does this doc stand vis-a-vis 'Version 1' ?
> 
>  Could someone please clarify ?
> 
> Regards
> Harry
> 
> -- 
> 
> _______________________________________________
> Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 
> http://www.net2phone.com/cgi-bin/link.cgi?143 
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

-- 

_______________________________________________
Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 
http://www.net2phone.com/cgi-bin/link.cgi?143 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 02 Oct 2001 11:11:36 -0400

As current editor of the IG let me explain a little about it.  Since H.248 is an ITU-T recommendation corrections must follow ITU procedures.  Corrects are handled in an "Implementors Guide."  Implementors Guides are a standard document type in ITU and this constrains us a little bit.  The ITU author's guide defines:

implementors' guide: An implementors' guide is a document which records all identified defects (e.g. typographical errors, editorial errors, ambiguities, omissions or inconsistencies, and technical errors) associated with a Recommendation or a set of Recommendations and their status of correction, from their identification to final
resolution. An implementors' guide is issued by the ITU-T following agreement by a Study Group. Typically, defect corrections are first collected in an implementors' guide and, at a time deemed appropriate by the Study Group, they are used to produce a corrigendum or are included as revisions to a Recommendation.

All IGs (or at least all I have checked) have a statement like the one in the H.248 IG Introduction (with minor variations in wording):

It must be read in conjunction with the Recommendation to serve as an additional authoritative source of information for implementors'. The changes, clarifications and corrections defined herein are expected to be included in future versions of affected H.248 Recommendations

This is intended to imply two things:
1) by "authoritative" it implies that each IG, once approved at a Study Group meeting, becomes an official part of each recommendation (standard) covered by the IG, that is, it affects the current version.
2) the last sentence means that these will also be used in the next version, but the next version will also contain enhancements brought in through contributions that will not appear in the IG.

You might prefer language that made these two points more clearly but this is the standard wording in IGs.

As to "versions", the only official versions are those approved at each Study Group meeting (about every 9 months).  As editor I bring in drafts to each Rapporteurs Meeting in addition to SG meetings.  These are discussed and given preliminary approval by the group but do not carry any official weight at this time.  Because items will
usually be approved at the next SG meeting, they are useful to implementors and so are made available on the SGs draft document site.  The versions approved at SG meetings are then edited (to meet ITU document guidelines) and published by the ITU (I cannot control all details of this published version such as adding any "version" number).
The previous editor also occasionally made available versions between Rapporteur meetings.  These carry even less official status but can show the changes that the editor believes reached consensus on the mailing list.  I will occasionally do the same (especially where the period between rapporteur meetings is long or we have a lot of
changes).

So with with so many types of versions of varying status, it is hard to know how to designate them.  Probably the only reliable way is by date, but you should also keep in mind this varying level of approval:
1) between rapporteurs meetings: editors opinion of mailing list consensus
2) after a rapporteurs meeting: consensus of those attending
3) after a SG meeting: authoritative.

I will try to imply these levels in the coversheet attached to the documents.  The official SG version will not have a coversheet.

These different approval levels also makes it hard to know when it might be useful to generate an integrated version of the recommendation incorporating the changes.  It probably only makes sense after SG approval when the changes become authoritative, but this means that implementors may still want to check the current IG draft to see what
changes are likely to be approved soon.  We have not usually attempted such an integrated version although drafts of H.248v2 that have begun to be presented at meetings usually incorporate IG changes to date.  One must also remember that such an integrated version would not be official, since mistakes could be made in the merge process.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla