Subject: RE: [Megaco] Audio Server - Digits

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 1 Oct 2001 10:42:57 -0400

This is definitiely interesting.  What do other people think: is there a
general requirement to speak a string of digits as a series of N-digit
numbers?

-----Original Message-----
From: CHATRAS Bruno FTRD/DAC/ISS
[mailto:[email-masked]]
Sent: Monday, October 01, 2001 6:13 AM
To: [email-masked]'
Subject: [Megaco] Audio Server - Digits

Tom,

I have question about the use of the variable type "Digits" in H.248 Annex
M.1. I assume that this variable type is intended to be used for
representing telephone numbers in variable announcements. However, I don't
understand how to use it in countries (e.g.; France) where telephone numbers
digits are not spoken one by one.

In France (and possibly is some other countries), 6137360961 (the example
given in H.248 Annex M.1) would be spoken as "Sixty one, thirty seven,
thirty six, zero night, sixty one". 

It seems that we need a new subtype value for supporting this kind of
format. More generally, I think that the subtype should allow to specify the
number of digits to be spoken as a single number. 

cadence = 	"gen" /   		; One by one, no pause
		"nadn" /  		; One by one, North American
DIrectory Number format.
		"group:" 1*DIGIT		; Digits are spoken by
group, with a pause between each group.

Any views ?

Regards,
Bruno

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Mon, 08 Oct 2001 16:10:20 -0400

The Call Progress Tones Generator package specifies
things like "busy tone" and "dial tone".  It doesn't
specify what these are, presumably because they vary
from country to country.  Even the referenced ITU-T 
document, E.180, only specifies really wide, *recommended* 
characteristics.

I always assumed this was deliberate.  Who wants a bunch of
packages with busy_germany and busy_france?  Let the MG decide
what "busy tone" means.

Wouldn't this same approach, general protocol - specific
implementation, apply here too?

-troy

> Tom-PT Taylor wrote: