Subject: RE: [Megaco] Context Id choose

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 22 Oct 2001 11:47:28 -0400

The original intent of CHOOSE was "select one from the eligible set".  The
idea of using it as a placeholder for an unknown context, given that
TerminationID has been specified, is not inconsistent with this meaning, but
I will have to do a search to see whether past discussion has ruled this
out.  Clearly, if two commands in the same action named terminationIDs which
were in different contexts, the eligible set of contexts would be empty.
Going with the "evaluate in order of presentation" rule, that would mean the
first command would succeed and a definite value would be assigned to the
contextID.  The second command would fail with the error that the
terminationID was not in the specified context.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 19, 2001 12:05 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]; [email-masked]; megaco
Subject: RE: [Megaco] Context Id choose

Section 8.1.2 on Context Identifiers specifies
"   The CHOOSE wildcard is used to request that the Media Gateway create
   a new Context."
So the action at MG for a command containing CHOOSE in ContextID shall
create a
new Context.
Thus a Modify is *not* allowed with CHOOSE context

Sachin Mittal

"Kevin Boyle" <[email-masked]> on 10/18/2001 10:19:18 PM

To:   [email-masked], Vivek Bansal/HSS@HSS, megaco <[email-masked]>
cc:    (bcc: Sachin Mittal/HSS)

Subject:  RE: [Megaco] Context Id choose

Modify on a CHOOSE context will work fine as long as the Termination ID is
specified - it will return the context the term is in.  This scenario does
not require an Add/Move.

Kevin

 -----Original Message-----
From:     [email-masked] [mailto:[email-masked]]
Sent:     Thursday, October 18, 2001 7:05 AM
To:  vibansal; megaco
Subject:  Re: [Megaco] Context Id choose

 << File: Wipro_Disclaimer.txt >> Vivek,

  Refer Annex L for the definition of error code ' 412 Name: No ContextIds
available',
  (It implies that 'Move' with ContextId as 'choose' is legal)
Using ContextId as 'choose' for 'Modify' command should also work fine as
long as Modify command is preceeded  with Add/Move command  in the Action to
get the specified termination in the context

Reg
Usha

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 18, 2001 2:17 PM
Subject: [Megaco] Context Id choose

>
>
>
> Hi
>
> I wanted to know if it is right to send context Id choose with MOVE or
MODIFY
> command?
> I could not find the relevant text in the rfc.
>
> Please clarify.
>
> Regards
> Vivek
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 23 Oct 2001 09:37:02 +0530

RE: [Megaco] Context Id chooseUsing 'ANY' for contextId was proposed in the list back in Sept. with the idea that it refers to any existing context (including NULL ) (Ref : Thread with sub 'Wildcard in ContextId' )
   However that was kept as an option for v2  

        8.2.1 seems to imply that usage of ContextId Choose is to instruct the MG to create a new context. If the intent is to also use it as a placeholder for an unknown context, IG needs to be modified/appended  to reflect the same

Reg
Usha

----- Original Message ----- 
  From: Tom-PT Taylor 
  To: [email-masked]' ; Kevin Boyle 
  Cc: [email-masked] ; [email-masked] ; megaco 
  Sent: Monday, October 22, 2001 9:17 PM
  Subject: RE: [Megaco] Context Id choose

  The original intent of CHOOSE was "select one from the eligible set".  The idea of using it as a placeholder for an unknown context, given that TerminationID has been specified, is not inconsistent with this meaning, but I will have to do a search to see whether past discussion has ruled this out.  Clearly, if two commands in the same action named terminationIDs which were in different contexts, the eligible set of contexts would be empty.  Going with the "evaluate in order of presentation" rule, that would mean the first command would succeed and a definite value would be assigned to the contextID.  The second command would fail with the error that the terminationID was not in the specified context.

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] 
  Sent: Friday, October 19, 2001 12:05 AM 
  To: Boyle, Kevin [NCRTP:3Z30:EXCH] 
  Cc: [email-masked]; [email-masked]; megaco 
  Subject: RE: [Megaco] Context Id choose 

  Section 8.1.2 on Context Identifiers specifies 
  "   The CHOOSE wildcard is used to request that the Media Gateway create 
     a new Context." 
  So the action at MG for a command containing CHOOSE in ContextID shall create a 
  new Context. 
  Thus a Modify is *not* allowed with CHOOSE context 

  Sachin Mittal 

  Kevin 

   -----Original Message----- 
  From:     [email-masked] [mailto:[email-masked]] 
  Sent:     Thursday, October 18, 2001 7:05 AM 
  To:  vibansal; megaco 
  Subject:  Re: [Megaco] Context Id choose 

  Reg 
  Usha 

  ----- Original Message ----- 
  From: <[email-masked]> 
  To: <[email-masked]> 
  Sent: Thursday, October 18, 2001 2:17 PM 
  Subject: [Megaco] Context Id choose 

  MODIFY