Subject: RE: [Megaco] Subtract command with null context.

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Oct 2001 07:53:24 -0400

Why would you think so?  I personally don't like creating
errors out of "dumb" actions.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 8:08 PM
> To: Rosen, Brian
> Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> Subject: Re: [Megaco] Subtract command with null context.
> 
> 
> Subtracting a termination from the NULL context is not an 
> No-OP it is a
> definite error in the protocol. It should be reported back as such.
> 
> Christian
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 11 Oct 2001 10:38:27 +1000

In 7.2.3 it states "Subtract of termination from the NULL context is not
allowed." Its not dumb (OK it is dumb :)) but its wrong also. Now if
someone is not allowed to do something and they do it, do you say OK or
that there not meant to do it? ie. an error code 410 - Incorrect ID
returned with the context ID NULL.

Christian

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 11 Oct 2001 11:28:56 +0530

The requested action cannot be serviced ( for whatever reason ).This should
be reported to the requesting entity as it is a protocol violation .
 (Error code 401 ( Protocol Error ) also seems appropriate )

Reg
Usha

----- Original Message -----
From: Christian Groves <[email-masked]>
To: Rosen, Brian <[email-masked]>
Cc: 'Usha Iyer' <[email-masked]>; 'Muthukrishnan SivaKumaran'
<[email-masked]>; <[email-masked]>
Sent: Thursday, October 11, 2001 6:08 AM
Subject: Re: [Megaco] Subtract command with null context.

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 11 Oct 2001 12:02:01 +0530

-Ref Annex L
Error Code 410 Name: Incorrect identifier
(Definition: The transaction request(s) has been disregarded due to a syntax error (illegal length or illegal character) ....)
----------------

Take a case of context id representation, the allowed identifiers(ABNF) are  $, * ,  -  or any specific value 
Any other value other than the above would be termed illegal  
So with reference to subtract from a null conxtext , the command request is syntactically correct, (the command is basically a protocol error )