Subject: [Megaco] how to handle topology?

From: Leis Peter <[email-masked]>
Date: Wed, 10 Oct 2001 13:09:37 +0200

Hi,

how do I have to handle the following situation:

the MGC sends the following command and the MG fails to execute the second topology 
triple (i.e. TermA,$,isolate) due to internal problems

MGC to MG1:
   MEGACO/1 [x.x.x.x]: 27000
   Transaction = 1234 {
       Context = 1 
Topology TermA,EphA,isolate, TermA,$,isolate, EphA,$,bothway{
          Add = $ {
              Media {
                        {
                     LocalControl {
                         Mode = ReceiveOnly,
                    },
                     Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4
                }
             }
          }
       }
   }

what will be the correct reaction in the MG?

Undo the add command, undo the first topology and respond with error (what error code) to the MGC?

thanks,
Peter

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 11 Oct 2001 10:52:17 +1000

G'Day Peter, 

As you execute actions sequentially, if there was a fault in the
topology descriptor you would get an error code back for that and the
Add would not be executed. The error code to use depends on what your
internal problems were. ie. 510 Insufficient Resources.

Christian