Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination ID s and context ID s

From: Padmaja Musti <[email-masked]>
Date: Wed, 10 Oct 2001 18:27:39 +0530

Brian,
I agree with you on ALL/NULL/CHOOSE usage in representing
the termination ID. My question is on representing the
context ID. There are values reserved in context ID
say 0x0 for NULL. So when I send the NULL context ID 
in ABNF can send it as "-"

Transation = 10006 {
   Context = - { ...}
   ..
   }

or can I also use the following notation since '0' is reserved for
NULL Context ID.

Transation = 10006 {
   Context = 0 { ...}
   ..
   }

regards,
Padma

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 5:51 PM
To: 'Padmaja Musti'; [email-masked]
Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
ID s and context ID s

You can say Common* and trunk/*/digital
You can even say Foo/$, that is, choose any termination
starting with "Foo/"

Null is a single value however.

Brian

> -----Original Message-----
> From: Padmaja Musti [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:02 AM
> To: [email-masked]
> Subject: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination IDs
> and context ID s
> 
> 
> Hi,
> ContextID is basically UINT32 and three values are reserved
> to represent NULL/CHOOSE/ALL for ASN. In ABNF these
> are represented using "-"/"$"/"*". Since three values are reserved
> why can't we use the same values in ABNF as well instead of using
> "-"/"$"/"*". Is it done to be inline with TerminationID.
> 
> ContextID = (UINT32/ "*"/"-"/"$")
> 
> 
> Context ID        Reserved Value          ABNF text
> 
>     NULL            0x0                         -
>   
>     CHOOSE          0xFFFFFFFE(4294967295)      $
> 
>     ALL             0xFFFFFFFF(4294967295)      *
> 
> regards,
> Padma
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Oct 2001 10:09:46 -0400

> or can I also use the following notation since '0' is reserved for

I was about to reply that Pradmaja was mixing ABNF and
ASN.1 defined values when I noticed the following comment
in the ABNF.

   ;The values 0x0, 0xFFFFFFFE and 0xFFFFFFFF are reserved.
   ContextID            = (UINT32 / "*" / "-" / "$")

I'm not sure of the intent here.  Maybe you can use the numeric
reserves and '*', '-', and '$' are just more readable alternatives?

-troy