Subject: [Megaco] Doubt in IG B.2 ABNF Syntax Specification

From: "Sundareswaram P V" <[email-masked]>
Date: Tue, 30 Oct 2001 10:15:51 +0530

Hi,
    The Definition VALUE according to the IG says that Integer, Double,Unsigned Integer all are accepteble either in decimal or Hexadecimal format.
    My question is - How will the Hexadecimal form of a Double be represented(for fractional numbers), or rather i'm not very clear of encoding and decoding of hexadecimal value for Double value.
   eg:- how to represent 17.17 in hexadecimal format for encoding or even decoding.
   Cud any one help me in this case.   

rgds,
Sundar.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 31 Oct 2001 19:12:50 -0500

It seems to me fractional values can only be represented by ASCII strings of
digits including the decimal point, unless a compound structure has been
defined (e.g. {whole part INTEGER, fractional part  INTEGER}).  Hence the
hexadecimal encoding of 17.17 would be 31372e3137.

-----Original Message-----
From: Sundareswaram P V [mailto:[email-masked]]
Sent: Tuesday, October 30, 2001 4:46 AM
To: megaco
Subject: [Megaco] Doubt in IG B.2 ABNF Syntax Specification

Hi,
    The Definition VALUE according to the IG says that Integer,
Double,Unsigned Integer all are accepteble either in decimal or Hexadecimal
format.
    My question is - How will the Hexadecimal form of a Double be
represented(for fractional numbers), or rather i'm not very clear of
encoding and decoding of hexadecimal value for Double value.
   eg:- how to represent 17.17 in hexadecimal format for encoding or even
decoding.
   Cud any one help me in this case.   

rgds,
Sundar.

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 31 Oct 2001 19:12:50 -0500

-----Original Message-----
From: Sundareswaram P V [mailto:[email-masked]]
Sent: Tuesday, October 30, 2001 4:46 AM
To: megaco
Subject: [Megaco] Doubt in IG B.2 ABNF Syntax Specification

Hi,

rgds,
Sundar.