Subject: RE: [Megaco] Context Id choose

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 19 Oct 2001 11:06:41 -0400

Yes.  But I don't see where that statement says that the CHOOSE wildcard
MUST create a new context.  Add and Move, by their very nature, have the
capability of creating new contexts.  Modify does not.  There is NO
restriction against using C=$ with a Modify command - and the statement in
8.1.2 does not, in my opinion, extend to Modify, since Modify can't create a
new context.  In this case, common sense says that CHOOSE will do exactly
that - pick the context where the termination resides.

If we wish to add a statement to the IG that CHOOSE is used solely for
creating new contexts, and make a mention in the Modify, Subtract,
ServiceChange, AuditValue and AuditCapability commands that a context of
CHOOSE is not allowed, then I have no problem with that.  But, the way the
text stands, there is nothing that prohibits the behavior I described above.

Kevin

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Friday, October 19, 2001 12:05 AM
To:	Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc:	[email-masked]; [email-masked]; megaco
Subject:	RE: [Megaco] Context Id choose

 << File: Internet HTML >> 

Section 8.1.2 on Context Identifiers specifies
"   The CHOOSE wildcard is used to request that the Media Gateway create
   a new Context."
So the action at MG for a command containing CHOOSE in ContextID shall
create a
new Context.
Thus a Modify is *not* allowed with CHOOSE context

Sachin Mittal

"Kevin Boyle" <[email-masked]> on 10/18/2001 10:19:18 PM

To:   [email-masked], Vivek Bansal/HSS@HSS, megaco <[email-masked]>
cc:    (bcc: Sachin Mittal/HSS)

Subject:  RE: [Megaco] Context Id choose

Modify on a CHOOSE context will work fine as long as the Termination ID is
specified - it will return the context the term is in.  This scenario does
not require an Add/Move.

Kevin

 -----Original Message-----
From:     [email-masked] [mailto:[email-masked]]
Sent:     Thursday, October 18, 2001 7:05 AM
To:  vibansal; megaco
Subject:  Re: [Megaco] Context Id choose

 << File: Wipro_Disclaimer.txt >> Vivek,

  Refer Annex L for the definition of error code ' 412 Name: No ContextIds
available',
  (It implies that 'Move' with ContextId as 'choose' is legal)
Using ContextId as 'choose' for 'Modify' command should also work fine as
long as Modify command is preceeded  with Add/Move command  in the Action to
get the specified termination in the context

Reg
Usha

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 18, 2001 2:17 PM
Subject: [Megaco] Context Id choose

>
>
>
> Hi
>
> I wanted to know if it is right to send context Id choose with MOVE or
MODIFY
> command?
> I could not find the relevant text in the rfc.
>
> Please clarify.
>
> Regards
> Vivek
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco

---

From: William McNicol <[email-masked]>
Date: Fri, 19 Oct 2001 17:16:33 +0100

rfc3015 has in 8.1.2 

Context Identifiers

   The CHOOSE wildcard is used to request that the Media Gateway create
   a new Context.  The MGC shall not use partially specified ContextIDs
   containing the CHOOSE wildcard.

The IG says in 6.1.1:

> ContextID. A wildcarding mechanism using two types of wildcards can be used with ContextIDs.  The two wildcards are ALL and CHOOSE.  The former is used to address ALL (except the NULL context) Contexts at once in a command request and/or reply, while the latter is used to indicate to a media gateway that it must create a Context.  

So I'd say, that it is NOT allowed to have a CHOOSE wildcard
where the FIRST command is MODIFY, or at the least it should
create a context and then report that the addressed Termination
isn't in it (and then destroy the context since it's got no
terminations in it).

I'd dearly love to see a table in the IG with all combinations of:
ContextID:     Null, Choose, All, FullySpecified
Command:       Add, Modify, Subtract, Move, AuditValue, AuditCapabilities, Notify, ServiceChange
TerminationID: Root, All, Wildcard with $, Wildcard with *, FullySpecified
with a statement as to the legality and semantics of each combination.

This could be populated from what the standard already
explicitly allows or outlaws and then we could apply the
common sense test on what the remaining entries mean.
  
William.

> Kevin Boyle wrote:
> 
> Yes.  But I don't see where that statement says that the CHOOSE wildcard MUST create a new context.  Add and Move, by their very nature, have the capability of creating new contexts.  Modify does not.  There is NO restriction against using C=$ with a
> Modify command - and the statement in 8.1.2 does not, in my opinion, extend to Modify, since Modify can't create a new context.  In this case, common sense says that CHOOSE will do exactly that - pick the context where the termination resides.
> 
> If we wish to add a statement to the IG that CHOOSE is used solely for creating new contexts, and make a mention in the Modify, Subtract, ServiceChange, AuditValue and AuditCapability commands that a context of CHOOSE is not allowed, then I have no
> problem with that.  But, the way the text stands, there is nothing that prohibits the behavior I described above.
> 
> Kevin
> 
> So the action at MG for a command containing CHOOSE in ContextID shall create a
> new Context.