Subject: RE: [Megaco] MG capabilities

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 24 Oct 2001 08:17:35 -0400

There are two mechanisms:
The Profile and the Audit.

When the MG first registers with the MGC, one of the items in the
ServiceChange is the Profile.  A profile is a document that describes
a complete set of capabilities.  It might include a list of packages,
a set of termination naming conventions, a transport protocol and
an encoding choice - often a profile will make a choice for every
option defined in the protocol.  When the MG asks the MGC for service,
the MGC looks at the offered profile.  If it can handle that profile,
it might decide to accept the MG for service.  However, if it doesn't
implement that profile, it might decline.  The MG would then seach
further for an MGC which could support it.

After the ServiceChange, the MGC can use AuditCapability and AuditValue
to discover what the MG can do.  In particular, auditing of Packages
tells you what packages are implemented on a termination or wildcarded
set of terminations.

> -----Original Message-----
> From: Niraj Kedar [mailto:[email-masked]]
> Sent: Wednesday, October 24, 2001 5:42 AM
> To: [email-masked]
> Subject: [Megaco] MG capabilities
> 
> 
> Is there some form of negotiation of the capabilities
> between the MG(s) and the controlling MGC. Does the
> MGC have to be informed of the packages that an MG,
> which it is controlling, is implementing before they
> communicate with each other? If yes whats the
> mechanism of doing this.
> 
> The underspecified (using CHOOSE) and overspecified
> values can lead to the MG replying with the
> descriptors it has. But this can happen only after
> they have initiated communication?
> 
> thanx
> niraj
> 
> __________________________________________________
> Do You Yahoo!?
> Make a great connection at Yahoo! Personals.
> http://personals.yahoo.com
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 25 Oct 2001 10:44:21 +1000

There is of course another non-protocol means and that is via
provisioning. In many cases you know what sort of device and its
capabilities you are connecting to before you establish a H.248/megaco
link.

Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 25 Oct 2001 10:44:21 +1000

Christian