Subject: [Megaco] byte order question

From: [email-masked]
Date: Tue, 23 Oct 2001 10:05:37 +0300

Hi, all interested 

It is said in the speification as follows: 

 PkgdName ::= OCTET STRING(SIZE(4))
   -- represents Package Name (2 octets) plus Property Name (2 octets)
   -- To wildcard a package use 0xFFFF for first two octets, choose
   -- is not allowed. To reference native property tag specified in
   -- Annex C, use 0x0000 as first two octets.
   -- Wildcarding of Package Name is permitted only if Property Name is
   -- also wildcarded.

So, let's assume that there would be Package name 0x1234 and Property name
0x5678.
Is the right form
a) 12345678   or
b) 34127856  ?

I think that this is not clearly said. Is the logic clarified somewhere else
in the spec? This far I have not found.
Could you please help me to find the answer.

regards,
Markus Ahokangas
Nokia Networks

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Tue, 23 Oct 2001 11:37:40 -0400

> Could you please help me to find the answer.

Markus,

It its clearly said that it's a string of 4 bytes, not an integer.
"First two octets" means just that.

PkgdName[0] = 0x12
PkgdName[1] = 0x34
PkgdName[2] = 0x56
PkgdName[3] = 0x78

You can certainly represent it as an integer in your implementation
if you want, but that's your issue.

-troy