Subject: RE: [Megaco] Subtract command with null context.

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 11:38:24 -0400

It's a protocol error.  Incorrect ID would apply if the termination isn't
really in the NULL context.

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 8:38 PM
To: Rosen, Brian
Cc: [email-masked]; 'Muthukrishnan SivaKumaran'; [email-masked]
Subject: Re: [Megaco] Subtract command with null context.

In 7.2.3 it states "Subtract of termination from the NULL context is not
allowed." Its not dumb (OK it is dumb :)) but its wrong also. Now if
someone is not allowed to do something and they do it, do you say OK or
that there not meant to do it? ie. an error code 410 - Incorrect ID
returned with the context ID NULL.

Christian

"Rosen, Brian" wrote:
> 
> Why would you think so?  I personally don't like creating
> errors out of "dumb" actions.
> 
> Brian
> 
> > -----Original Message-----
> > From: Christian Groves [mailto:[email-masked]]
> > Sent: Tuesday, October 09, 2001 8:08 PM
> > To: Rosen, Brian
> > Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> > Subject: Re: [Megaco] Subtract command with null context.
> >
> >
> > Subtracting a termination from the NULL context is not an
> > No-OP it is a
> > definite error in the protocol. It should be reported back as such.
> >
> > Christian
> >

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 12 Oct 2001 09:24:10 +0530

RE: [Megaco] Subtract command with null context.In case the termination isn't in the NULL context error code 435 (Termination Id not in specified context) would apply
  ----- Original Message ----- 
  From: Tom-PT Taylor 
  To: 'Christian Groves' ; Rosen, Brian 
  Cc: [email-masked] ; 'Muthukrishnan SivaKumaran' ; [email-masked] 
  Sent: Thursday, October 11, 2001 9:08 PM
  Subject: RE: [Megaco] Subtract command with null context.

  It's a protocol error.  Incorrect ID would apply if the termination isn't really in the NULL context. 

  -----Original Message----- 
  From: Christian Groves [mailto:[email-masked]] 
  Sent: Wednesday, October 10, 2001 8:38 PM 
  To: Rosen, Brian 
  Cc: [email-masked]; 'Muthukrishnan SivaKumaran'; [email-masked] 
  Subject: Re: [Megaco] Subtract command with null context. 

  Christian