Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination ID s and context ID s

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 10 Oct 2001 14:55:47 -0400

No, it is as Brian said: you have to reserve them because of the possibility
that the same MG could be involved in multiple control associations in
sequence, where one was in text and another in binary.  This could happen,
for instance, if the encoding to use was configured in the MG along with the
MGC contact data.

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 10:46 AM
To: Rosen, Brian
Cc: Padmaja Musti; [email-masked]
Subject: Re: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
IDs and context ID s

So the question is what does "reserved" mean in this comment?
Clearly those 3 values cannot be used to represent a normal
Context.

But there's no reason to make them illegal to send in a text message.
'0' is equivalent to '-' here.

Or is human readability so important to the text encoding that
0xFFFFFFFE and 0xFFFFFFFF are scary?

-troy

"Rosen, Brian" wrote:
> 
> I think we did that so that if you did have both a binary and
> a text implementation, the ALL/CHOOSE values that would otherwise
> be legal for text, but conflicting with binary, were made to be
> illegal as ContextIds for both.
> 

> > > or can I also use the following notation since '0' is reserved for
> > > NULL Context ID.
> > >
> > > Transation = 10006 {
> > >    Context = 0 { ...}
> > >    ..
> > >    }
> >
> >
> > I was about to reply that Pradmaja was mixing ABNF and
> > ASN.1 defined values when I noticed the following comment
> > in the ABNF.
> >
> >
> >    ;The values 0x0, 0xFFFFFFFE and 0xFFFFFFFF are reserved.
> >    ContextID            = (UINT32 / "*" / "-" / "$")
> >
> >
> > I'm not sure of the intent here.  Maybe you can use the numeric
> > reserves and '*', '-', and '$' are just more readable alternatives?

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Oct 2001 16:56:31 -0400

Tom,

I don't think you got my point. "0" could still mean NULL,
just like "-" does.  It's just another way of encoding NULL.

This would have no conflict when mixing text and binary
control associations.  There's no conflict because '0'
would mean NULL in both text and binary.

If you disagree and think "0" should be illegal in the text
encoding, that's fine.  But the IG should change "reserved" to
"illegal" because "reserved" could mean "reserved for these 
special meanings -- not to be used as a standard Context".

-troy

> Tom-PT Taylor wrote: