Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination ID s and context ID s

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Oct 2001 10:10:47 -0400

So you "could" say
Context=7665*{TerminationID=*{Audit{})

Brian

> -----Original Message-----
> From: Padmaja Musti [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:58 AM
> To: 'Rosen, Brian'; [email-masked]
> Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination
> ID s and context ID s
> 
> 
> Brian,
> I agree with you on ALL/NULL/CHOOSE usage in representing
> the termination ID. My question is on representing the
> context ID. There are values reserved in context ID
> say 0x0 for NULL. So when I send the NULL context ID 
> in ABNF can send it as "-"
> 
> Transation = 10006 {
>    Context = - { ...}
>    ..
>    }
> 
> or can I also use the following notation since '0' is reserved for
> NULL Context ID.
> 
> Transation = 10006 {
>    Context = 0 { ...}
>    ..
>    }
> 
> regards,
> Padma
> 
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 5:51 PM
> To: 'Padmaja Musti'; [email-masked]
> Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination
> ID s and context ID s
> 
> 
> You can say Common* and trunk/*/digital
> You can even say Foo/$, that is, choose any termination
> starting with "Foo/"
> 
> Null is a single value however.
> 
> Brian
> 
> > -----Original Message-----
> > From: Padmaja Musti [mailto:[email-masked]]
> > Sent: Wednesday, October 10, 2001 8:02 AM
> > To: [email-masked]
> > Subject: [Megaco] Representation of ALL/NULL/CHOOSE for 
> > Termination IDs
> > and context ID s
> > 
> > 
> > Hi,
> > ContextID is basically UINT32 and three values are reserved
> > to represent NULL/CHOOSE/ALL for ASN. In ABNF these
> > are represented using "-"/"$"/"*". Since three values are reserved
> > why can't we use the same values in ABNF as well instead of using
> > "-"/"$"/"*". Is it done to be inline with TerminationID.
> > 
> > ContextID = (UINT32/ "*"/"-"/"$")
> > 
> > 
> > Context ID        Reserved Value          ABNF text
> > 
> >     NULL            0x0                         -
> >   
> >     CHOOSE          0xFFFFFFFE(4294967295)      $
> > 
> >     ALL             0xFFFFFFFF(4294967295)      *
> > 
> > regards,
> > Padma
> > 
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > http://www1.ietf.org/mailman/listinfo/megaco
> > 
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 11 Oct 2001 10:56:15 +1000

G'Day Brian,

Are you saying that we can partially wildcard a context ID?
The context ID can only be choose, NULL, specific or ALL.

Christian