Subject: RE: [Megaco] What exactly constitutes Version 1 ?

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Oct 2001 09:27:12 -0400

The problem is how to "limit" new features.
Everyone has what they think are good reasons for
their own new feature.  I even have some of my own :)
The thing is, all the ones I have heard about
are in the nice-to-have category, at best.
So far, there haven't been any ideas that are critical
to achieving some important goal.

Once you open the door, we don't have any way to distinguish
worthwhile effort from things that are actually harmful. 

On the other hand, with the approved IG, and the soon-to-appear
Internet Draft showing what the corrected text would look like,
you have V1+IG for further implementations.  That is quite
sufficient I think.  No need for an official V2 for that
reason alone.

One more reason:  I think that although we have a lot of
edits in the IG, we haven't changed the protocol at all;
just fixed bugs.  With some deployment experience, we could
advance the IETF process to Proposed Standard.  If we added
any of the proposed features, we could not do that.  I think
that having a stable standard at Proposed is much more useful
than having a couple of minor features and having the IETF
process recycled at Draft Standard.

So I think we should just sit tight.

Brian

> -----Original Message-----
> From: Marcello Pantaleo (EED) 
> [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 9:09 AM
> To: 'Rosen, Brian'
> Cc: [email-masked]'; Christian Groves (EPA)
> Subject: RE: [Megaco] What exactly constitutes Version 1 ?
> 
> 
> V2 isn't exactly V1+IG, it does add new features.
> Is this sufficient to motivate a new version?
> Personally I'm in favor of a "clean" V2 plus a limited 
> number of new features.
> 
> Marcello
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 1:49 PM
> To: 'Christian Groves'
> Cc: [email-masked]'
> Subject: RE: [Megaco] What exactly constitutes Version 1 ?
> 
> 
> Implementation and deployment are two very different things.
> Deployment experience is very valuable.  We don't have much.
> We have some limited implementation experience.  Too limited,
> in my opinion.  If V2 is exactly V1+IG, I have less heartburn.
> If it adds features, I want to wait.
> 
> Brian
> 
> 
> > -----Original Message-----
> > From: Christian Groves [mailto:[email-masked]]
> > Sent: Monday, October 08, 2001 9:24 PM
> > To: [email-masked]
> > Subject: Re: [Megaco] What exactly constitutes Version 1 ?
> > 
> > 
> > I believe we have sufficient experience to fix v1 and 
> produce a v2. V1
> > was decided/approved June 2000. If a new version is approved 
> > in Feb 2002
> > it will have had 20 months of review and experience. With all the
> > discussion on what constitutes v1 I believe its a necessity to get a
> > "clean" version 2 of the protocol out that plugs several holes.
> > 
> > Christian
> > 
> > Troy Cauble wrote:
> > > 
> > > I also agree.
> > > 
> > > Paul Long wrote:
> > > >
> > > > Brian,
> > > >
> > > > I agree. Let's sit on this one for awhile.
> > > >
> > > > Paul Long
> > > > ipDialog, Inc.
> > > >
> > > > -----Original Message-----
> > > > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > > Rosen, Brian
> > > Sent: Monday, October 08, 2001 8:03 AM
> > > To: 'Christian Groves'; Tom-PT Taylor
> > > Cc: Glen Freundlich; 'Harry Suede'; [email-masked]
> > > Subject: RE: [Megaco] What exactly constitutes Version 1 ?
> > >
> > > Of course I am one of those who wants to wait.
> > >
> > > We have very little deployment experience with Megaco/H.248
> > >
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > http://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Paul Long" <[email-masked]>
Date: Tue, 9 Oct 2001 11:15:45 -0500

Brian,

I agree. We should stick with V1+IG for the time being with no additional
features no matter how insignificant.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Rosen, Brian
Sent: Tuesday, October 09, 2001 8:27 AM
To: 'Marcello Pantaleo (EED)'
Cc: [email-masked]'
Subject: RE: [Megaco] What exactly constitutes Version 1 ?

Brian

---

From: Christian Groves <[email-masked]>
Date: Wed, 10 Oct 2001 11:03:06 +1000

What is the problem to limit features? The whole idea of the list and
contributions to SG16 is that proposals are presented, discussed and
accepted or not. It is this step that weeds out the harmful ideas. So I
don't buy that emotional argument.

I don't agree that the implementors' guide just fixed a few bugs. Look
at the size of it now and it doesn't fix all problems ie. exceeding
message sizes. It has become unwieldly to use the original spec. We need
something that other standards bodies can reference. An implementors'
guide isn't normative.

As for the new features they are fixing things that are needed in real
systems and its because of experience that they've been added. ie.
Individual auditing so that you don't blow out the message size on the
reply, procedures to handle the case where a reply message will exceed
message size, having all descriptors being extended by packages so you
can introduce new features without protocol updates.

I don't think that because of the state (or lack of it) of individual
companies implementations that this should prevent the standard from
moving forward. 

Cheers, Christian

---

From: "Paul Long" <[email-masked]>
Date: Tue, 9 Oct 2001 20:44:04 -0500

Christian,

The IG not normative? Back when H.324 was developed, its IG was definitely
not normative because it was truly an _implementer's guide_, like the name
indicates, and not a corregendum, like they are now. It was my understanding
that as of H.323, which would now include H.248, "IGs" became normative.
However, the only thing I can find that says that they are anything close to
normative is the statement in the IGs that, "[This document] must be read in
conjunction with the Recommendation to serve as an additional authorative
source of information for implementors."

I've always been told that IGs are normative, that version X of a
Recommendation is defined by the Recommendation _and_ its corresponding IG,
so I suppose it comes down to how you interpret this statement.
Unfortunately, the Recommendations themselves do not make any reference to
their corresponding IG.

Finally, I believe that it is the concensus that the IG is normative, based
on the statement I cited, above.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christian Groves
Sent: Tuesday, October 09, 2001 8:03 PM
To: [email-masked]'
Subject: Re: [Megaco] What exactly constitutes Version 1 ?

Cheers, Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 10 Oct 2001 13:40:04 +1000

Paul,

From my understanding (A series of recommendations) an IG is an
historical document detailing the defect and the steps leading to its
correction. An amendment/corrigenda to a recommendation performs the
actual normative correction. Whilst I think IG is a practical way of
detailing all the changes and has been the accepted method in sg16, the
question is how do non-SG16 groups normatively refer to the IG? Another
issue is that an IG is not translated for non-english speakers. They
need to be able to do the updates too. The status of the IG is probably
best discussed on the SG16 mailing list.

However, if we issue a H248v2 then we don't have the above problems.

Regards, Christian

---

From: "Paul Long" <[email-masked]>
Date: Tue, 9 Oct 2001 23:09:44 -0500

(You're right. I have therefore moved this thread to
[email-masked] by responding to your email there with the
new Subject, "Implementors Guide not normative?")

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christian Groves
Sent: Tuesday, October 09, 2001 10:40 PM
To: Paul Long
Cc: [email-masked]
Subject: Re: [Megaco] What exactly constitutes Version 1 ?

Paul,

Regards, Christian