Subject: RE: [Megaco] Subtract command with null context.

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Oct 2001 07:46:33 -0400

A Subtract from Null context is at best a no-op (if the termination was
already in the
null context) or at worst an error.  I'd say it was a no-op.  Of course,
since Subtract
causes properties to revert to default values, it would do that if the
termination was in 
Null, so it's not quite a no-op.
 
Brian

-----Original Message-----
From: Muthukrishnan SivaKumaran [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 5:00 AM
To: [email-masked]
Subject: [Megaco] Subtract command with null context.

Hi,
 
Whether the protocol supports a Subtract command with null context. In real
scenario Subtract with null context won't come at all. Is it true. Clarify.

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 9 Oct 2001 19:27:12 +0530

Brian
  I did not get why u are specifying '"if the termination was already in the null context" 
  The TerminationIds are scoped by the contextId , so when the ContextId is specified as NULL , u'd be addressing only those terminations which are in Null context 
   Returning a termination to NULL context restores their default/provisioned properties. So for a termination already in NULL context, Subtract is basically a no-op  
        Or am i missing something ?

Reg 
Usha
  ----- Original Message ----- 
  From: Rosen, Brian 
  To: 'Muthukrishnan SivaKumaran' ; [email-masked] 
  Sent: Tuesday, October 09, 2001 5:16 PM
  Subject: RE: [Megaco] Subtract command with null context.

  A Subtract from Null context is at best a no-op (if the termination was already in the
  null context) or at worst an error.  I'd say it was a no-op.  Of course, since Subtract
  causes properties to revert to default values, it would do that if the termination was in 
  Null, so it's not quite a no-op.

  Brian
    -----Original Message-----
    From: Muthukrishnan SivaKumaran [mailto:[email-masked]]
    Sent: Tuesday, October 09, 2001 5:00 AM
    To: [email-masked]
    Subject: [Megaco] Subtract command with null context.

    Hi,

    Whether the protocol supports a Subtract command with null context. In real scenario Subtract with null context won't come at all. Is it true. Clarify.

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 9 Oct 2001 19:27:09 +0530

Hi , 
Acc to the Implementors' guide :
"6.13 Termination Subtract from NULL context 

        Subtract of termination from the NULL context is not allowed. "

My question is whether 'not allowed' translates to an error . In case it does, what would be the error code for the above .In case it doesn't , consider the foll. 

"  7.1.18 Topology Descriptor : (T1, T2, oneway) means that the Terminations that match T2 receive media from the Terminations matching T1, but not vice versa.  In this case use of the ALL wildcard such that there are Terminations that match both T1 and T2 is not allowed "

Does this also translate to a 'no-op' or do we flag an error ? Preferably the error should be reported

Reg

Usha

  ----- Original Message ----- 
  From: Rosen, Brian 
  To: 'Muthukrishnan SivaKumaran' ; [email-masked] 
  Sent: Tuesday, October 09, 2001 5:16 PM
  Subject: RE: [Megaco] Subtract command with null context.

  Brian
    -----Original Message-----
    From: Muthukrishnan SivaKumaran [mailto:[email-masked]]
    Sent: Tuesday, October 09, 2001 5:00 AM
    To: [email-masked]
    Subject: [Megaco] Subtract command with null context.

    Hi,