Subject: FW: [Megaco] Abrogation of Error Code 504

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 10:35:08 -0400

-----Original Message-----
From: Taylor, Tom-PT [CAR:B881:EXCH] 
Sent: Thursday, October 11, 2001 10:35 AM
To: Sean Leahy
Subject: RE: [Megaco] Abrogation of Error Code 504

OK, I've carried the argument far enough.  What are other people's views?
If there are no objections, I'll give the action to Sean to draft a very
short I-D documenting the error code for purposes of IANA registration.  The
ITU will have to figure out their process for amending Annex L.

-----Original Message-----
From: Sean Leahy [mailto:[email-masked]]
Sent: Thursday, October 11, 2001 4:10 AM
To: Taylor, Tom-PT [CAR:B881:EXCH]
Subject: RE: [Megaco] Abrogation of Error Code 504

Tom,
     Re: Your comments:

     Comment: "OK, let's generalize your requirement slightly.  You want a
means for an MG to indicate to an MGC with
which it has a trust relationship that no control association exists
between them.  Why not simply 401 Protocol Error,
since the problem is a protocol violation?  There is also 402 Unauthorized
."

     Reply : Well we do not think it is a 401 protocol error and we want
the specific information that the reason for the error is
that the MG does not have the control association with the particular
(known) sub-entity of the MGC. The definition for Error
402 in Annex L seems to suggest that the error is specific to the
conjunction of a particular termination with a particular
command rather than a general problem to do with the relationship between
the MGC and MG.

     Comment: "I have to confess that I have been unable to find language in
H.248 forbidding responses to MGCs not in an active
association with the MG.  It was certainly a consideration in our definition
of error codes."

     Reply: Error 504 'Command Received from unauthorised entity' seemed to
us to fit the bill (if you assume 'authorised'
includes the concept of 'within a control relationship') but it is currently
defined as 'not used'.

     Regards,
     Sean Leahy

---

From: Christian Groves <[email-masked]>
Date: Fri, 12 Oct 2001 14:20:53 +1000

G'Day Tom,

You wanted other opinions so I must agree with you I think 402 is
sufficient. The reason 504 was abrogated was that it overlapped with
402.

402 Unauthorized
The command is not executed due to the originator of a command is not
authorised to execute that command for the termination(s) affected by
it.
504 Command Received from unauthorized entity

I fail to see the difference between the codes. ie.
o Originator = entity
o not authorised = unauthorised
o termination(s) - every H.248 command references termination(s)

If 402 wasn't for this case can someone give me an example of a
completely difference case where it would be used.

Regards, Christian

Tom-PT Taylor wrote:
> OK, I've carried the argument far enough.  What are other people's
> views?  If there are no objections, I'll give the action to Sean to
> draft a very short I-D documenting the error code for purposes of IANA
> registration.  The ITU will have to figure out their process for
> amending Annex L.
> 
>      Comment: "I have to confess that I have been unable to find
> language in H.248 forbidding responses to MGCs not in an active
> 
> association with the MG.  It was certainly a consideration in our
> definition of error codes."
> 
>      Reply: Error 504 'Command Received from unauthorised entity'
> seemed to us to fit the bill (if you assume 'authorised'
> 
> includes the concept of 'within a control relationship') but it is
> currently defined as 'not used'.
> 
>      Regards,
>      Sean Leahy

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco