Subject: [Megaco] Fax call Flow for discussion and comments required

From: "Zahid Anwar" <[email-masked]>
Date: Mon, 08 Oct 2001 15:18:30 +0800

In reply to the message posted asking about fax callflow. I propose the following callflow. But there are a few confusions for example exchange of SDP formats, sequence of messages and about the fax package id which is not specified in the RFC. Comments on the following callflow is requested from all. Any help would be greatly appreciated.

Messages Exchanged between MGC and Gatways in order to establish Fax call between GW1 and GW2. It is assumed that both gatways are registered, codecs have been exchanged and a normal call has been established and both terminations are in on-hook state at this point.

The caller termination at MG1 detects a fax tone and notifies the MGC.

MG1 to MGC

MEGACO/1 [125.125.125.111]:55555
Transaction = 50005 {
Context = 1 {
Notify = Phy/1 {ObservedEvents =1234 {
19990729T22020002:faxpkg/faxtone}}}}

The MGC sends a notify reply.

MGC to MG1

MEGACO/1 [123.123.123.4]:55555
Reply = 50005 {
Context = 1 {Notify = Phy/1}}

MGC sends a modify to the caller sending it the fax codec in the local of the the media descriptor.

MGC to MG1:
MEGACO/1 [123.123.123.4]:55555
Transaction = 50006{
Context = 1{Modify = Eph/1{Media{
Stream = 1{
Local{
v=0
c=IN IP4 0.0.0.0
m=audio 3456 RTP!
/AVP 0
a=ptime:30
}}}}}}

MG1 sends a reply filling the attributes of its particular fax codecs in the local descriptor

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 50006 {
Context = 1 {
Modify= Eph/1{Media {
Stream = 1 {
Local {
v=0
o=faxgw1 2890846 2890846 IN IP4 ift.here.com
c=IN IP4 125.125.125.111
m=image 15002 udptl t38
a=T38FaxVersion:0
a=T38maxBitRate:14400
a=T38FaxFillBitRemoval:0
a=T38FaxMaxBuffer:72
}}}}}}

MGC sends a modify signal to GW2 to ask it to play fax tone

MGC to MG2
MEGACO/1 [123.123.123.4]:55555
Transaction = 50007 {
Context = 1{
Modify = phy/2 {
Signals {faxpkg/faxtone}}}}

MG2 sends a modify reply

MG2 to MGC

MEGACO/1 [123.123.123.4]:55555
Reply = 50007 {
Context = 1 {Modify = Phy/2}}

Now the MGC asks MG2 for its codes filling the codes of the caller in the remote

MGC to M!
G2:
MEGACO/1 [123.123.123.4]:55555
Transaction = 50008{
Co
ntext = 1{
Modify = Eph/1{Media{Stream = 1 {
Local{
v=0
c=IN IP4 0.0.0.0
m=audio 3456 RTP/AVP 0
a=ptime:30
}Remote{
v=0
o=faxgw1 2890846 2890846 IN IP4 ift.here.com
c=IN IP4 125.125.125.111
m=image 15002 udptl t38
a=T38FaxVersion:0
a=T38maxBitRate:14400
a=T38FaxFillBitRemoval:0
a=T38FaxMaxBuffer:72
}}}}}}

MG2 sends a reply

MG2 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 50008 {
Context = 1 {
Modify= Eph/2{Media {
Stream = 1 {Local {
v=0
o=faxgw1 2890846 2890846 IN IP4 ift.here.com
c=IN IP4 125.125.125.111
m=image 15002 udptl t38
a=T38FaxVersion:0
a=T38maxBitRate:14400
a=T38FaxFillBitRemoval:0
a=T38FaxMaxBuffer:72
}}}}}}

MGC sends the codes of MG2 to MG1

MGC to MG1:
MEGACO/1 [124.124.124.222]:55555
Transaction = 50009 {
Context = 1 {
Modify= Eph/1{Media {
Stream = 1 {
Remote
{
v=0
o!
=faxgw1 2890846 2890846 IN IP4 ift.here.com
c=IN IP4 125.125.125.111
m=image 15002 udptl t38
a=T38FaxVersion:0
a=T38maxBitRate:14400
a=T38FaxFillBitRemoval:0
a=T38FaxMaxBuffer:72

}}}}}}

MG1 replies to MGC

MEGACO/1 [124.124.124.222]:55555
Reply = 50009 {
Context = 1 { Modify = Eph/2}}

Regards

Zahid Anwar.

--

_______________________________________________

Sign-up for your own FREE Personalized E-mail at Mail.com

Have you downloaded the latest calling software from Net2Phone? Click here to get it now!

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 08 Oct 2001 11:33:54 -0400

Annexes to T.38 already specify callflows for H.248 (and H.323, SIP,
etc) in a fair amount of detail including details on fax tone
detection.  I believe that there are some problems with the flow and
have reported these to the editor, but since they are part of T.38 they
have a normative status.  It would be more productive to work on getting
any problems in these fixed than to ignore them and begin a parallel
effort.

Zahid Anwar wrote:

> In reply to the message posted asking about fax callflow. I propose
> the following callflow. But there are a few confusions for example
> exchange of SDP formats, sequence of messages and about the fax
> package id which is not specified in the RFC. Comments on the
> following callflow is requested from all. Any help would be greatly
> appreciated.
>
> Messages Exchanged between MGC and Gatways in order to establish Fax
> call between GW1 and GW2. It is assumed that both gatways are
> registered, codecs have been exchanged and a normal call has been
> established and both terminations are in on-hook state at this point.
>
> m=audio 3456 RTP! /AVP 0
> MGC to M! G2:
> Co ntext = 1{
> o! =faxgw1 2890846 2890846 IN IP4 ift.here.com
> c=IN IP4 125.125.125.111
> m=image 15002 udptl t38
> a=T38FaxVersion:0
> a=T38maxBitRate:14400
> a=T38FaxFillBitRemoval:0
> a=T38FaxMaxBuffer:72
>
> }}}}}}
>
> MG1 replies to MGC
>
> _______________________________________________ Megaco mailing list
> [email-masked] http://www1.ietf.org/mailman/listinfo/megaco

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla