Subject: RE: [Megaco] Service Change Request Descripency

From: Padmaja Musti <[email-masked]>
Date: Thu, 25 Oct 2001 17:26:00 +0530

Hi,
That means whether ASN/ABNF only one TransactionID can 
be sent in ServiceChangeRequest/Reply. Which is not inline 
with the section 7.2.8 description quoted below. 
My concern is if only say 3 terminations went down and
are up again out of total say 10 terminations on the Gateway,
ServiceChangeRequest should be sent with "ROOT" (which means
that CallAgent does the Audit) or is it possible to specify 
these terminations in the ServiceChangeRequest (looks like
not possible with the current definition - then the
7.2.8 should be corrected to reflect this.)

"The TerminationID parameter specifies the Termination(s) that are taken out
of or returned to service. Wildcarding of Termination names is permitted,
with the exception that the CHOOSE mechanism shall not be used. Use of the
"Root" TerminationID indicates a ServiceChange affecting the entire Media
Gateway. "

regards,
Padma

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 9:13 PM
To: Padmaja Musti
Cc: [email-masked]'
Subject: Re: [Megaco] Service Change Request Descripency

Padma,

This is from the comments at the beginning of Annex A.
I don't know why this was done.

-troy

--    NOTE - The ASN.1 specification below contains a clause defining
--    TerminationIDList as a sequence of TerminationIDs.  The length of
--    this sequence SHALL be one, except possibly when used in
--    contextAuditResult.

Padmaja Musti wrote:
> 
> But I see difference in the ASN and ABNF definitions. ASN it is list but
> ABNF it is not.
> Is this corrected in the IG - i could not find it. If not can it be taken
as
> a correction. Same
> is true for Reply as well.
> 
> ASN Definition for Service Change Request:
> 
> ServiceChangeRequest ::= SEQUENCE
> {
>         terminationID           TerminationIDList,
>         serviceChangeParms      serviceChangeResult,
>         ....
> }
> 
> ABNF Definition for Service Change Request:
> 
> serviceChangeRequest = SeriveChangeToken EQUAL TerminationID

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Padmaja Musti <[email-masked]>
Date: Thu, 25 Oct 2001 17:26:00 +0530

Hi,

regards,
Padma

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 9:13 PM
To: Padmaja Musti
Cc: [email-masked]'
Subject: Re: [Megaco] Service Change Request Descripency

Padma,

-troy

as

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 25 Oct 2001 11:52:55 -0400

Why wouldn't you just send a ServiceChange for each term that went out of
service?  Sending  ServiceChanges on Root will have other consequences that
are undesirable (like tearing down valid calls on the other terminations,
potentially).

Kevin

 -----Original Message-----
From: 	Padmaja Musti [mailto:[email-masked]] 
Sent:	Thursday, October 25, 2001 7:56 AM
To:	'Troy Cauble'; Padmaja Musti
Cc:	[email-masked]'
Subject:	RE: [Megaco] Service Change Request Descripency

Hi,

regards,
Padma

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 9:13 PM
To: Padmaja Musti
Cc: [email-masked]'
Subject: Re: [Megaco] Service Change Request Descripency

Padma,

-troy

as

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 25 Oct 2001 11:52:55 -0400

Kevin

 -----Original Message-----
From: 	Padmaja Musti [mailto:[email-masked]] 
Sent:	Thursday, October 25, 2001 7:56 AM
To:	'Troy Cauble'; Padmaja Musti
Cc:	[email-masked]'
Subject:	RE: [Megaco] Service Change Request Descripency

Hi,

regards,
Padma

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 9:13 PM
To: Padmaja Musti
Cc: [email-masked]'
Subject: Re: [Megaco] Service Change Request Descripency

Padma,

-troy

as

---

From: "chris rigano" <[email-masked]>
Date: Thu, 25 Oct 2001 13:35:40 -0700

I could under stand that when a GW goes out of service that you take all related Tps out. This cuts down on traffic (I thought that's the way things worked to begin with). But when there are partial failures  Individual terminals should be treated individually when their status cannot be communicated other wise. This reminds me a bit of managing ATM connection points. If a major hub went down then event notifications to all NMSs flooded the bandwidth. Is this the same situation

Best regards,

Chris
    -----Original Message-----
    From: Kevin Boyle <[email-masked]>
    To: Padmaja Musti <[email-masked]>; 'Troy Cauble' <[email-masked]>
    Cc: [email-masked]' <[email-masked]>
    Date: Thursday, October 25, 2001 9:03 AM
    Subject: RE: [Megaco] Service Change Request Descripency

    Why wouldn't you just send a ServiceChange for each term that went out of service?  Sending  ServiceChanges on Root will have other consequences that are undesirable (like tearing down valid calls on the other terminations, potentially).

    Kevin 

     -----Original Message----- 
    From:   Padmaja Musti [mailto:[email-masked]] 
    Sent:   Thursday, October 25, 2001 7:56 AM 
    To:     'Troy Cauble'; Padmaja Musti 
    Cc:     [email-masked]' 
    Subject:        RE: [Megaco] Service Change Request Descripency 

    Hi, 

    regards, 
    Padma 

    -----Original Message----- 
    From: Troy Cauble [mailto:[email-masked]] 
    Sent: Tuesday, October 23, 2001 9:13 PM 
    To: Padmaja Musti 
    Cc: [email-masked]' 
    Subject: Re: [Megaco] Service Change Request Descripency 

    
    Padma, 

    -troy 

    
    as

---

From: "chris rigano" <[email-masked]>
Date: Thu, 25 Oct 2001 13:35:40 -0700

Best regards,

Chris
    -----Original Message-----
    From: Kevin Boyle <[email-masked]>
    To: Padmaja Musti <[email-masked]>; 'Troy Cauble' <[email-masked]>
    Cc: [email-masked]' <[email-masked]>
    Date: Thursday, October 25, 2001 9:03 AM
    Subject: RE: [Megaco] Service Change Request Descripency

    Kevin 

     -----Original Message----- 
    From:   Padmaja Musti [mailto:[email-masked]] 
    Sent:   Thursday, October 25, 2001 7:56 AM 
    To:     'Troy Cauble'; Padmaja Musti 
    Cc:     [email-masked]' 
    Subject:        RE: [Megaco] Service Change Request Descripency 

    Hi, 

    regards, 
    Padma 

    -----Original Message----- 
    From: Troy Cauble [mailto:[email-masked]] 
    Sent: Tuesday, October 23, 2001 9:13 PM 
    To: Padmaja Musti 
    Cc: [email-masked]' 
    Subject: Re: [Megaco] Service Change Request Descripency 

    
    Padma, 

    -troy 

    
    as

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 25 Oct 2001 13:30:15 -0400

There is no reason not to use a wildcard with a SeviceChange.  For example,
if a T1 called MyT1, with terminations
MyT1/1 through MyT1/24 went down, sending ServiceChange=MyT1/*{.... is a
very usefull command.
The really curious thing is what ContextId you want to use.  In some sense,
wildcarding the ContextId is what you
want.  CHOOSE would have the right effect if we allowed it (we just had a
thread about that).
 
You have to decide if you want a wildcard response!
 
Brian

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 11:53 AM
To: Padmaja Musti; 'Troy Cauble'
Cc: [email-masked]'
Subject: RE: [Megaco] Service Change Request Descripency

Kevin 

 -----Original Message----- 
From:   Padmaja Musti [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent:   Thursday, October 25, 2001 7:56 AM 
To:     'Troy Cauble'; Padmaja Musti 
Cc:     [email-masked]' 
Subject:        RE: [Megaco] Service Change Request Descripency 

Hi, 

regards, 
Padma 

-----Original Message----- 
From: Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, October 23, 2001 9:13 PM 
To: Padmaja Musti 
Cc: [email-masked]' 
Subject: Re: [Megaco] Service Change Request Descripency 

Padma, 

-troy 

as 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
http://www1.ietf.org/mailman/listinfo/megaco
<http://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 25 Oct 2001 13:30:15 -0400

Brian

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 11:53 AM
To: Padmaja Musti; 'Troy Cauble'
Cc: [email-masked]'
Subject: RE: [Megaco] Service Change Request Descripency

Kevin 

 -----Original Message----- 

Hi, 

regards, 
Padma 

-----Original Message----- 
From: Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, October 23, 2001 9:13 PM 
To: Padmaja Musti 
Cc: [email-masked]' 
Subject: Re: [Megaco] Service Change Request Descripency 

Padma, 

-troy 

as