Subject: RE: [Megaco] Context Id choose

From: [email-masked]
Date: Fri, 19 Oct 2001 09:34:45 +0530

Section 8.1.2 on Context Identifiers specifies
"   The CHOOSE wildcard is used to request that the Media Gateway create
   a new Context."
So the action at MG for a command containing CHOOSE in ContextID shall create a
new Context.
Thus a Modify is *not* allowed with CHOOSE context

Sachin Mittal

"Kevin Boyle" <[email-masked]> on 10/18/2001 10:19:18 PM

To:   [email-masked], Vivek Bansal/HSS@HSS, megaco <[email-masked]>
cc:    (bcc: Sachin Mittal/HSS)

Subject:  RE: [Megaco] Context Id choose

Modify on a CHOOSE context will work fine as long as the Termination ID is
specified - it will return the context the term is in.  This scenario does
not require an Add/Move.

Kevin

 -----Original Message-----
From:     [email-masked] [mailto:[email-masked]]
Sent:     Thursday, October 18, 2001 7:05 AM
To:  vibansal; megaco
Subject:  Re: [Megaco] Context Id choose

 << File: Wipro_Disclaimer.txt >> Vivek,

  Refer Annex L for the definition of error code ' 412 Name: No ContextIds
available',
  (It implies that 'Move' with ContextId as 'choose' is legal)
Using ContextId as 'choose' for 'Modify' command should also work fine as
long as Modify command is preceeded  with Add/Move command  in the Action to
get the specified termination in the context

Reg
Usha

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 18, 2001 2:17 PM
Subject: [Megaco] Context Id choose

>
>
>
> Hi
>
> I wanted to know if it is right to send context Id choose with MOVE or
MODIFY
> command?
> I could not find the relevant text in the rfc.
>
> Please clarify.
>
> Regards
> Vivek
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 19 Oct 2001 10:40:02 +0530

Exactly, that's why Modify as the first command in the action with ContextId as Choose is an error 
  I fail to see why Add/Move followed with Modify is an error though. ""Transactions guarantee ordered Command processing", 
 u execute ContextId = 'Choose' first, move/add the spec. termination to the context ,so when u execute Modify, u are addressing a termination in a specific Context 

 Can somebody pls carify 

Thx
Usha 

----- Original Message ----- 
  From: [email-masked] 
  To: Kevin Boyle 
  Cc: [email-masked] ; [email-masked] ; megaco 
  Sent: Friday, October 19, 2001 9:34 AM
  Subject: RE: [Megaco] Context Id choose

  Sachin Mittal

  Kevin

   -----Original Message-----
  From:     [email-masked] [mailto:[email-masked]]
  Sent:     Thursday, October 18, 2001 7:05 AM
  To:  vibansal; megaco
  Subject:  Re: [Megaco] Context Id choose

  Reg
  Usha

  ----- Original Message -----
  From: <[email-masked]>
  To: <[email-masked]>
  Sent: Thursday, October 18, 2001 2:17 PM
  Subject: [Megaco] Context Id choose

  MODIFY

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 19 Oct 2001 10:40:48 +0530

Exactly, that's why Modify as the first command in the action with ContextId as Choose is an error 
  I fail to see why Add/Move followed by Modify is an error though. ""Transactions guarantee ordered Command processing", 
 u execute ContextId = 'Choose' first, move/add the spec. termination to the context ,so when u execute Modify, u are addressing a termination in a specific Context 

 Can somebody pls carify 

Thx
Usha 
  ----- Original Message ----- 
  From: [email-masked] 
  To: Kevin Boyle 
  Cc: [email-masked] ; [email-masked] ; megaco 
  Sent: Friday, October 19, 2001 9:34 AM
  Subject: RE: [Megaco] Context Id choose

  Sachin Mittal

  Kevin

   -----Original Message-----
  From:     [email-masked] [mailto:[email-masked]]
  Sent:     Thursday, October 18, 2001 7:05 AM
  To:  vibansal; megaco
  Subject:  Re: [Megaco] Context Id choose

  Reg
  Usha

  ----- Original Message -----
  From: <[email-masked]>
  To: <[email-masked]>
  Sent: Thursday, October 18, 2001 2:17 PM
  Subject: [Megaco] Context Id choose

  MODIFY