Subject: [Megaco] Base Root Package property change.

From: [email-masked]
Date: Mon, 29 Oct 2001 12:42:05 +0530

HI list,
By provisioning interface if MG changes its Base Root Package properties viz.
MaxNrofContexts and MaxTerminationPerContext. then how can MG report this change
to MGC. As there is no such method as "MG Capability change" in Service Change.
or MGC has to periodically audit these properties (which is not an elegant
method).

Regards,
Siddhartha Sharma

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 29 Oct 2001 09:45:30 -0500

It's really unlikely that such a change would be possible by provisioning,
and if it was, then restarting the MG seems to be not unreasonable.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, October 29, 2001 2:12 AM
> To: [email-masked]
> Subject: [Megaco] Base Root Package property change.
> 
> 
> 
> 
> HI list,

---

From: John Stock <[email-masked]>
Date: Mon, 29 Oct 2001 09:24:27 -0800

I have a couple of follow-up questions w/respect to this:

1. It seems that it may be possible to change the properties mentioned below
via a software or hardware in-service upgrade, and would not be desirable to
restart the MG at that time.  In that case, would it be possible to inform
the MGC of the change via a ServiceChange message?
 
2. If it is indeed necessary to perform a restart, when restarting the MG
must the connection data (context/termination associations), be lost, or is
the status simply re-queried/audited?

Thank you,
John Stock

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, October 29, 2001 6:46 AM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Base Root Package property change.

Brian

---

From: John Stock <[email-masked]>
Date: Mon, 29 Oct 2001 09:24:27 -0800

Thank you,
John Stock

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, October 29, 2001 6:46 AM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Base Root Package property change.

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 29 Oct 2001 13:55:07 -0500

The number of terminations per context is usually determined by
the mixing capability of the gateway.  There is no reason to
artificially lower it by provisioning - to get the same effect,
you would provision the MGC, not all the MGs.

The Max number of contexts is also a limit imposed by the design,
plus the memory complement of the MG.  There is also no reason
to artificially lower it for the same reason.  I thought of the
idea of being able to do a non-service affecting increase in memory,
that could conceivably allow you to increase the number of contexts.
I really don't think that you would actually do this.

If you really worry about this level of problem, then you probably have
a mechanism that recognizes that the MGC may be out of sync with the
MG.  The response is a full audit of the MG.  So, trigger that.

Brian

> From: John Stock [mailto:[email-masked]]
> Sent: Monday, October 29, 2001 12:24 PM
> To: 'Rosen, Brian'; [email-masked]'; [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 29 Oct 2001 13:55:07 -0500

Brian