Subject: [Megaco] Subtract command with null context.

From: "Muthukrishnan SivaKumaran" <[email-masked]>
Date: Tue, 9 Oct 2001 14:30:04 +0530

Hi,

Whether the protocol supports a Subtract command with null context. In real scenario Subtract with null context won't come at all. Is it true. Clarify.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 11:41:54 -0400

See the I-G item 6.13.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, October 11, 2001 10:05 AM
To: 'Christian Groves'
Cc: [email-masked]; 'Muthukrishnan SivaKumaran'; [email-masked]
Subject: RE: [Megaco] Subtract command with null context.

What version of the protocol are you looking at?
RFC3015 does not have this statement in 7.2.3
My copy of Recommendation H.248 doesn't seem to say that either.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:38 PM
> To: Rosen, Brian
> Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> Subject: Re: [Megaco] Subtract command with null context.
> 
> 
> In 7.2.3 it states "Subtract of termination from the NULL 
> context is not
> allowed." Its not dumb (OK it is dumb :)) but its wrong also. Now if
> someone is not allowed to do something and they do it, do you 
> say OK or
> that there not meant to do it? ie. an error code 410 - Incorrect ID
> returned with the context ID NULL.
> 
> Christian
> 
> "Rosen, Brian" wrote:
> > 
> > Why would you think so?  I personally don't like creating
> > errors out of "dumb" actions.
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: Christian Groves [mailto:[email-masked]]
> > > Sent: Tuesday, October 09, 2001 8:08 PM
> > > To: Rosen, Brian
> > > Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> > > Subject: Re: [Megaco] Subtract command with null context.
> > >
> > >
> > > Subtracting a termination from the NULL context is not an
> > > No-OP it is a
> > > definite error in the protocol. It should be reported 
> back as such.
> > >
> > > Christian
> > >
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Winter Johannes <[email-masked]>
Date: Thu, 11 Oct 2001 18:09:05 +0200

Hi list, 

is there a general rule which error value shall be used in the reply message
for such combinations of ContextIDs and TerminationsIDs which are not
allowed from the protocol? 

Is it error value 401 Protocol Error, value 410 Incorrect Identifier, or
value 422 Syntax Error in Action?
(according to: H.248, chapter 8.2.2
"If the receiver encounters an error such it cannot determine a legal
Action, it will return a Transaction Reply consisting of the TransactionID
and a single error descriptor, 422 Syntax Error in Action")

And what is the "right level" for the error descriptor in this case? 
Shall the error descriptor to be set within the Transaction Reply, the
action reply or the command reply? 

Please clarify.

best regards

Johannes 

-----Original Message-----
From: Usha Iyer
To: Christian Groves; Rosen Brian
Cc: 'Muthukrishnan SivaKumaran'; [email-masked]
Sent: 11/10/01 07:58
Subject: Re: [Megaco] Subtract command with null context.

The requested action cannot be serviced ( for whatever reason ).This
should
be reported to the requesting entity as it is a protocol violation .
 (Error code 401 ( Protocol Error ) also seems appropriate )

Reg
Usha

----- Original Message -----
From: Christian Groves <[email-masked]>
To: Rosen, Brian <[email-masked]>
Cc: 'Usha Iyer' <[email-masked]>; 'Muthukrishnan SivaKumaran'
<[email-masked]>; <[email-masked]>
Sent: Thursday, October 11, 2001 6:08 AM
Subject: Re: [Megaco] Subtract command with null context.

> In 7.2.3 it states "Subtract of termination from the NULL context is
not
> someone is not allowed to do something and they do it, do you say OK
or
> > > definite error in the protocol. It should be reported back as
such.
> > > Christian

 <<Wipro_Disclaimer.txt>>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 13:42:58 -0400

In the particular case under discussion, the command and action will parse
properly, hence it is not a syntax error.  It violates the rules of the
protocol as expressed either in the comments to the syntax or (as in the
present case) in the body of the protocol specification.  As to the level of
reporting: it is valid to make reference to a termination in the NULL
syntax.  By hypothesis, the TerminationID for the command was that of a
termination in the NULL context.  The problem was with the command itself.
Hence the error is reported at the level of the command rather than the
action.

I was trying to work out a general rule for inconsistencies between the
action (i.e. contextID) and the commands within the action.  So long as the
contextID is either a wildcard or a specific value which exists, I think the
error would be reported at the command level.  Maybe someone can think of a
counter-example, but my reasoning goes like this: the action is specified
first, then the command.  Hence the action takes priority in determining
where the error is. 

-----Original Message-----
From: Winter Johannes [mailto:[email-masked]]
Sent: Thursday, October 11, 2001 12:09 PM
To: [email-masked] '
Cc: [email-masked]; 'Christian Groves '; 'Rosen Brian '
Subject: RE: [Megaco] Subtract command with null context.

Hi list, 

Please clarify.

best regards

Johannes 

-----Original Message-----
From: Usha Iyer
To: Christian Groves; Rosen Brian
Cc: 'Muthukrishnan SivaKumaran'; [email-masked]
Sent: 11/10/01 07:58
Subject: Re: [Megaco] Subtract command with null context.

Reg
Usha

----- Original Message -----
From: Christian Groves <[email-masked]>
To: Rosen, Brian <[email-masked]>
Cc: 'Usha Iyer' <[email-masked]>; 'Muthukrishnan SivaKumaran'

not
or
such.

 <<Wipro_Disclaimer.txt>>