Subject: [Megaco] FW: Correct response to a message with no command?

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 8 Oct 2001 21:48:25 -0400

Did we intend that responses to action requests without commands should echo
the input, or was this an oversight?

>  -----Original Message-----
> From: 	Boyle, Kevin [NCRTP:3Z30:EXCH]  
> Sent:	Thursday, October 04, 2001 2:22 PM
> To:	Tom-pt Taylor
> Cc:	Davis, James [NCRTP:3Z60:EXCH]; Cromwell, David [NCRTP:B933:EXCH]
> Subject:	Correct response to a message with no command?
> 
> Tom,
> 
> While hunting around through the protocol, I noticed a possibility that I
can't quite resolve.  Assume the MG has received the following message:
> 
> !/1 [1.2.3.4]:2944 T=25{C=12{TP{term1,term2,isolate}}}
> 
> What, exactly, should the response look like?
> 
> This was my first guess, and is illegal under the current definition:
> 
> !/1 [1.2.3.4]:2944 P=25{C=12{}}
> 
> Another attempt, that is legal, but cumbersome:
> 
> !/1 [1.2.3.4]:2944 P=25{C=12{TP{term1,term2,isolate}}}
> 
> What I don't like about this one is that it repeats the information right
back to the MGC - something that is not done in any other case.
> 
> The same issue arises with both Priority and Emergency (and the
ContextAttr Descriptor in v2).
> 
> Is there a definitive answer that I've missed somewhere, or should I take
this to the list?
> Kevin

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Oct 2001 07:58:02 -0400

Oversight I think.  We never considered an action with no commands.
Kevin's first response is close, but didn't we try to avoid empty
brackets?  So, maybe:
!/1 [1.2.3.4]:2944 P=25{C=12} 

In the ABNF, the production:
  actionReply          = CtxToken EQUAL ContextID LBRKT  
                          ( errorDescriptor / commandReply ) RBRKT 

could be changed to:
  actionReply          = CtxToken EQUAL ContextID [ LBRKT  
                          ( errorDescriptor / commandReply ) RBRKT ]

Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, October 08, 2001 9:48 PM
To: [email-masked]'
Cc: Kevin Boyle; James Davis; David Cromwell
Subject: [Megaco] FW: Correct response to a message with no command?

this to the list?

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 9 Oct 2001 16:59:55 -0400

This looks OK to me.  IG item?
 
-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 7:58 AM
To: Taylor, Tom-PT [CAR:B881:EXCH]; [email-masked]'
Cc: Boyle, Kevin [NCRTP:3Z30:EXCH]; Davis, James [NCRTP:3Z60:EXCH];
Cromwell, David [NCRTP:B933:EXCH]
Subject: RE: [Megaco] FW: Correct response to a message with no command?
 
-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, October 08, 2001 9:48 PM
To: [email-masked]'
Cc: Kevin Boyle; James Davis; David Cromwell
Subject: [Megaco] FW: Correct response to a message with no command?
this to the list?