Subject: RE: [Megaco] Subtract command with null context.

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 11 Oct 2001 10:05:01 -0400

What version of the protocol are you looking at?
RFC3015 does not have this statement in 7.2.3
My copy of Recommendation H.248 doesn't seem to say that either.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:38 PM
> To: Rosen, Brian
> Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> Subject: Re: [Megaco] Subtract command with null context.
> 
> 
> In 7.2.3 it states "Subtract of termination from the NULL 
> context is not
> allowed." Its not dumb (OK it is dumb :)) but its wrong also. Now if
> someone is not allowed to do something and they do it, do you 
> say OK or
> that there not meant to do it? ie. an error code 410 - Incorrect ID
> returned with the context ID NULL.
> 
> Christian
> 
> "Rosen, Brian" wrote:
> > 
> > Why would you think so?  I personally don't like creating
> > errors out of "dumb" actions.
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: Christian Groves [mailto:[email-masked]]
> > > Sent: Tuesday, October 09, 2001 8:08 PM
> > > To: Rosen, Brian
> > > Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
> > > Subject: Re: [Megaco] Subtract command with null context.
> > >
> > >
> > > Subtracting a termination from the NULL context is not an
> > > No-OP it is a
> > > definite error in the protocol. It should be reported 
> back as such.
> > >
> > > Christian
> > >
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 11 Oct 2001 10:28:32 -0400

The sentence Christian quotes was added in IG item 6.13.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 11 Oct 2001 11:07:48 -0400

HI All,
The Subtract command basically is intended to remove terminations from
non-Null contexts to Null context. If the termination is already in the NULL
Context, this basically will be a "NO-OP" provided the protocol doesn't
specifically mention that "Subtract of termination from the NULL context is
not allowed". As pointed by Terry, the protocol does say that this is not
allowed, IMO the MG should generate a "protocol error".
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Rosen, Brian
Sent: Thursday, October 11, 2001 10:05 AM
To: 'Christian Groves'
Cc: 'Usha Iyer'; 'Muthukrishnan SivaKumaran'; [email-masked]
Subject: RE: [Megaco] Subtract command with null context.

Brian