Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination ID s and context ID s

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Oct 2001 10:16:41 -0400

I think we did that so that if you did have both a binary and
a text implementation, the ALL/CHOOSE values that would otherwise
be legal for text, but conflicting with binary, were made to be
illegal as ContextIds for both.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 10:10 AM
> To: Padmaja Musti
> Cc: 'Rosen, Brian'; [email-masked]
> Subject: Re: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination
> IDs and context ID s
> 
> 
> Padmaja Musti wrote:
> > 
> > Brian,
> > I agree with you on ALL/NULL/CHOOSE usage in representing
> > the termination ID. My question is on representing the
> > context ID. There are values reserved in context ID
> > say 0x0 for NULL. So when I send the NULL context ID
> > in ABNF can send it as "-"
> > 
> > Transation = 10006 {
> >    Context = - { ...}
> >    ..
> >    }
> > 
> > or can I also use the following notation since '0' is reserved for
> > NULL Context ID.
> > 
> > Transation = 10006 {
> >    Context = 0 { ...}
> >    ..
> >    }
> 
> 
> I was about to reply that Pradmaja was mixing ABNF and
> ASN.1 defined values when I noticed the following comment
> in the ABNF.
> 
> 
>    ;The values 0x0, 0xFFFFFFFE and 0xFFFFFFFF are reserved.
>    ContextID            = (UINT32 / "*" / "-" / "$")
> 
> 
> I'm not sure of the intent here.  Maybe you can use the numeric
> reserves and '*', '-', and '$' are just more readable alternatives?
> 
> -troy
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Oct 2001 10:45:57 -0400

So the question is what does "reserved" mean in this comment?
Clearly those 3 values cannot be used to represent a normal
Context.

But there's no reason to make them illegal to send in a text message.
'0' is equivalent to '-' here.

Or is human readability so important to the text encoding that
0xFFFFFFFE and 0xFFFFFFFF are scary?

-troy