Subject: RE: [Megaco] What exactly constitutes Version 1 ?

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 8 Oct 2001 09:03:17 -0400

Of course I am one of those who wants to wait.

We have very little deployment experience with Megaco/H.248

We have no pressing problems = things we HAVE to do that we
CAN'T do with the existing protocol.  What we have is a lot
of ideas that might make the protocol better.

There is a heck of a lot of merit in keeping the protocol stable
until we have a reasonable amount of experience, and using that
experience to guide us.  It is often the case that things you
thought would work, don't.  It is even more common to discover
that things you thought would be needed, aren't.  That is the
real danger with V2.  Without experience, we might load up the
protocol with all kinds of do-dads we don't need.

We have this cake; it's all baked and decorated.  No-one has
tasted it, but we want to go ahead and change the recipe.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Sunday, October 07, 2001 8:58 PM
> To: Tom-PT Taylor
> Cc: Glen Freundlich; 'Harry Suede'; [email-masked]
> Subject: Re: [Megaco] What exactly constitutes Version 1 ?
> 
> 
> G'Day Tom,
> 
> I don't believe that the meeting report from the IETF indicated there
> was any consensus to not to progress the work on H.248v2. 
> Certainly I am
> in favour in getting out an updated version (and I am part of 
> the list)
> that contains the IG and some small additions. It will be cleaner and
> more complete than v1.
> 
> Christian
> 
> Glen Freundlich wrote:
> > 
> > Tom,
> > 
> > I only recall one or two people stating any opposition to a new
> > version of Megaco/H.248 (and if I review your notes, I find only one
> > person stating opposition, two people stating support) - was that
> > really a clear consensus?
> > 
> > "Discussion of this topic at the last IETF meeting revealed a fairly
> > clear consensus that Megaco participants don't want to see another
> > version of Megaco/H.248 for another year, until we get solid
> > deployment experience.  If this is also the list consensus, I can
> > report this view into the next SG 16 Rapporteur's meeting at the end
> > of the month."
> > 
> > Glen
> > 
> > 
> > Tom-PT Taylor wrote:
> > 
> > >
> > >
> > > I'll give you two answers: the practical one, and the formal one.
> > >
> > > The practical answer is that Version 1 consists of the protocol as
> > > documented in RFC 3015 or ITU-T Rec. H.248 (June, 2000) plus the
> > > latest approved H.248 Implementor's Guide (June, 2001).  Note that
> > > RFC 3015 has a few small errors compared with the H.248 document.
> > > The URL you cite probably gives the June 2001 approved version of
> > > the IG, but for safety you should get the official version, just
> > > posted last week, at
> > >
> > > http://www.itu.int/itudoc/itu-t/com16/implgd/h248-ig.html
> > >
> > > The formal answer is that because the IETF lacks the equivalent to
> > > the ITU Implementor's Guide, RFC 3015 is the official IETF view of
> > > Version 1.  Normally we would recycle that document in a movement
> > > toward Draft Standard, so you would have an Internet Draft
> > > containing the latest view of the protocol including corrections.
> > > The problem is that we don't want to risk divergence 
> between Megaco
> > > and H.248, so the more likely update route will be to 
> co-develop the
> > > next version of the H.248 Recommendation with SG 16.  
> Discussion of
> > > this topic at the last IETF meeting revealed a fairly clear
> > > consensus that Megaco participants don't want to see 
> another version
> > > of Megaco/H.248 for another year, until we get solid deployment
> > > experience.  If this is also the list consensus, I can report this
> > > view into the next SG 16 Rapporteur's meeting at the end of the
> > > month.
> > >
> > > I am left with one thought.  Should we have an I-D on the table
> > > consisting of RFC 3015 plus approved corrections (i.e.) the latest
> > > approved version of the Implementor's Guide?
> > >
> > > -----Original Message-----
> > > From: Harry Suede [mailto:[email-masked]]
> > > Sent: Monday, October 01, 2001 4:16 AM
> > > To: [email-masked]
> > > Subject: [Megaco] What exactly constitutes Version 1 ?
> > >
> > > Hi All
> > >
> > >  I am a bit unsure about what exactly constitutes 
> 'Version 1' of the
> > > MEGACO protocol.
> > > Is it just the RFC 3015 ? Or do the subsequent IGs also 
> form a part
> > > of it.
> > >
> > >  RFC 3015 was itself made up of megaco_merged_01.txt and 
> IGv3, right
> > > ?
> > >
> > >  Is the document located at
> > >
> > > 
> tp://standard.pictel.com/avc-site/0105_Por/PL-015_H248_imp_guide.zip,
> > > the  the latest approved IG ? Where does this doc stand vis-a-vis
> > > 'Version 1' ?
> > >
> > >  Could someone please clarify ?
> > >
> > > Regards
> > > Harry
> > >
> > > --
> > >
> > > _______________________________________________
> > > Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes
> > > free!
> > > http://www.net2phone.com/cgi-bin/link.cgi?143
> > >
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > Megaco mailing list
> > > [email-masked]
> > > http://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Paul Long" <[email-masked]>
Date: Mon, 8 Oct 2001 11:38:56 -0500

Brian,

I agree. Let's sit on this one for awhile.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Rosen, Brian
Sent: Monday, October 08, 2001 8:03 AM
To: 'Christian Groves'; Tom-PT Taylor
Cc: Glen Freundlich; 'Harry Suede'; [email-masked]
Subject: RE: [Megaco] What exactly constitutes Version 1 ?

Brian

---

From: Troy Cauble <[email-masked]>
Date: Mon, 08 Oct 2001 15:47:37 -0400

I also agree.

---

From: Christian Groves <[email-masked]>
Date: Tue, 09 Oct 2001 11:24:06 +1000

I believe we have sufficient experience to fix v1 and produce a v2. V1
was decided/approved June 2000. If a new version is approved in Feb 2002
it will have had 20 months of review and experience. With all the
discussion on what constitutes v1 I believe its a necessity to get a
"clean" version 2 of the protocol out that plugs several holes.

Christian