Subject: [Megaco] Audio Server - Digits

From: CHATRAS Bruno FTRD/DAC/ISS <[email-masked]>
Date: Mon, 1 Oct 2001 12:13:22 +0200

Tom,

I have question about the use of the variable type "Digits" in H.248 Annex
M.1. I assume that this variable type is intended to be used for
representing telephone numbers in variable announcements. However, I don't
understand how to use it in countries (e.g.; France) where telephone numbers
digits are not spoken one by one.

In France (and possibly is some other countries), 6137360961 (the example
given in H.248 Annex M.1) would be spoken as "Sixty one, thirty seven,
thirty six, zero night, sixty one". 

It seems that we need a new subtype value for supporting this kind of
format. More generally, I think that the subtype should allow to specify the
number of digits to be spoken as a single number. 

cadence = 	"gen" /   		; One by one, no pause
		"nadn" /  		; One by one, North American
DIrectory Number format.
		"group:" 1*DIGIT		; Digits are spoken by
group, with a pause between each group.

Any views ?

Regards,
Bruno

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "David Cromwell" <[email-masked]>
Date: Thu, 11 Oct 2001 11:00:17 -0400

There is a case for applying the tones approach (which defines a generic
name for each tone but leaves the specifics of how to produce regional
variations of a tone to the MG) to the Digits Variable.  However I don't
see that this argument can be extended to other variables having subtypes
that are not usually specific to a region and over which an application
might want control.  

In the US both the 12 and 24 hour time subtypes of the Time Variable are
valid as are the Month-Day-Year and Day-Month-Year subtypes of the Date
Variable. The cardinal and ordinal subtypes of the Integer Variable are
valid in all countries.  None of these subtypes are particularly telephony
related, all of them are independent of locality (although there is the
occasional per-language exception), and all of them are things over which an
application running in the MGC might want to control.

For the Digits Variable we could allow both nodes of operation by creating a
new subtype, Generic DN, which puts the responsibility for formatting on the
MG, and by extending the range of specific DN subtypes to include
International DN, French DN, etc.  Unless there is an exhaustive list of DN
formats somewhere on which to base these subtypes we could leave the range
open to new additions.

Regards,
David
--
[email-masked]                   Nortel Networks Cable
Telephony Solutions, Inc. 
Tel:   919-991-8870  (esn 351)                     35 Davis Dr
Fax:  919-991-4088                                    RTP, NC 27709

> -----Original Message-----
> From:	CHATRAS Bruno FTRD/DAC/ISS [SMTP:[email-masked]]
> Sent:	Monday, October 08, 2001 4:38 PM
> To:	'Troy Cauble'; Taylor, Tom-PT [CAR:B881:EXCH]
> Cc:	CHATRAS Bruno FTRD/DAC/ISS; [email-masked]'
> Subject:	RE: [Megaco] Audio Server - Digits
> 
> 
> If we follow this kind of approach, the current specification can be
> further
> simplified because variable types such as "time" and "date" do no need
> subtypes any longer. Moreover, the reference to the NPA format for
> "Digits"
> (in section 2.2.3) is not consistent with this approach. 
> 
> I'm not sure that this is the right approach anyway. Unlike call progress
> tones, the format used to speak digits may need to be selected on a per
> call
> basis. In the context of mobility services, it might be necessary to
> request
> an MG located in a given country to speak digits according to the format
> used in the calling party's home country.
> 
> We have two options:
> 
> - Consistently follow, throughout the whole document, the approach that we
> have (deliberately?) used for tones and simplify the current draft. 
> 
> - Extend the syntax of the digit subtype to support other format than the
> NPA format.
> 
> The second option looks more flexible to me.
> 
> 
> 
> 
> > -----Message d'origine-----
> > De : Troy Cauble [mailto:[email-masked]]
> > Envoyé : lundi 8 octobre 2001 22:10
> > À : Tom-PT Taylor
> > Cc : 'CHATRAS Bruno FTRD/DAC/ISS'; [email-masked]'
> > Objet : Re: [Megaco] Audio Server - Digits
> > 
> > 
> > 
> > 
> > The Call Progress Tones Generator package specifies
> > things like "busy tone" and "dial tone".  It doesn't
> > specify what these are, presumably because they vary
> > from country to country.  Even the referenced ITU-T 
> > document, E.180, only specifies really wide, *recommended* 
> > characteristics.
> > 
> > I always assumed this was deliberate.  Who wants a bunch of
> > packages with busy_germany and busy_france?  Let the MG decide
> > what "busy tone" means.
> > 
> > Wouldn't this same approach, general protocol - specific
> > implementation, apply here too?
> > 
> > -troy
> > 
> > 
> > > Tom-PT Taylor wrote:
> > > 
> > > This is definitiely interesting.  What do other people 
> > think: is there a
> > > general requirement to speak a string of digits as a series 
> > of N-digit
> > > numbers?
> > > 
> > > -----Original Message-----
> > > From: CHATRAS Bruno FTRD/DAC/ISS
> > > [mailto:[email-masked]]
> > > Sent: Monday, October 01, 2001 6:13 AM
> > > To: [email-masked]'
> > > Subject: [Megaco] Audio Server - Digits
> > > 
> > > Tom,
> > >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 12:25:30 -0400

Your generalization is perhaps valid, perhaps not -- announcements,
particularly in interactive situations, are constructed differently from
tones.

I'll add one more variable to the discussion.  David Cromwell pointed out to
me privately that the original intention was that the set capability applied
to the complete announcement including standalone variables.  The current
placement of selectors in the query part of URLs is useful for remote
retrieval of segments, but it comes at the cost of separate selector
specification for each segment.  I'm working out the syntax for adding
selectors to standalone variable specifications.  Could selectors be used
instead of subtypes? 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, October 11, 2001 11:53 AM
To: CHATRAS Bruno FTRD/DAC/ISS
Cc: Taylor, Tom-PT [CAR:B881:EXCH]; [email-masked]'
Subject: Re: [Megaco] Audio Server - Digits

Technically, per-call behavior COULD be useful to call 
progress tones too.

When I call France from the US using the PSTN I hear French
call progress tones.  IF your goal is to emulate the PSTN,
you'd need per-call progress tones.  (In this sense, it's
exactly the same as the M.1 digit reading.)

I have no strong opinion on which way to go with Annex M.1.
Consider this post and my previous one in this thread
observational.

-troy

further
"Digits"
call
request

---

From: CHATRAS Bruno FTRD/DAC/ISS <[email-masked]>
Date: Fri, 12 Oct 2001 09:21:05 +0200

> For the Digits Variable we could allow both nodes of operation by creating
a new subtype, Generic DN, which puts the responsibility 
> for formatting on the MG, and by extending the range of specific DN
subtypes to include International DN, French DN, etc.  Unless there is 
> an exhaustive list of DN formats somewhere on which to base these subtypes
we could leave the range open to new additions.
 
An alternative to this approach would be to create a syntax which allows to
specify the number of digits that need to be spoken as a single decimal
number. This I believe would be more felxible than extending the subtype
with the list of countries/languages... ? 

 -----Message d'origine-----
De : David Cromwell [mailto:[email-masked]]
Envoyé : jeudi 11 octobre 2001 17:00
À : 'CHATRAS Bruno FTRD/DAC/ISS'; 'Troy Cauble'; Tom-PT Taylor
Cc : [email-masked]'
Objet : RE: [Megaco] Audio Server - Digits

Regards, 
David 

	-----Original Message----- 

	If we follow this kind of approach, the current specification can be
further 
simplified because variable types such as "time" and "date" do no need 
subtypes any longer. Moreover, the reference to the NPA format for "Digits" 
(in section 2.2.3) is not consistent with this approach. 

	I'm not sure that this is the right approach anyway. Unlike call
progress 
tones, the format used to speak digits may need to be selected on a per call

basis. In the context of mobility services, it might be necessary to request

	We have two options: 

	- Consistently follow, throughout the whole document, the approach
that we 
have (deliberately?) used for tones and simplify the current draft. 

	- Extend the syntax of the digit subtype to support other format
than the 
NPA format. 

> De : Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
> > [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > group, with a pause between each group. 
<http://www1.ietf.org/mailman/listinfo/megaco>  

	_______________________________________________ 
Megaco mailing list 
[email-masked] 
http://www1.ietf.org/mailman/listinfo/megaco
<http://www1.ietf.org/mailman/listinfo/megaco>