Subject: RE: [Megaco] Subtract command with null context.

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Oct 2001 10:05:21 -0400

If the termination is not in the null context, subtracting it from the null
context is an
error for sure.
 
If a termination was in the null context, and you MODIFYed some property,
and then
you did a Subtract, I'd expect it to return the modified property back to
default value.
That is not a no-op exactly.
 
Brian

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 9:57 AM
To: Rosen Brian; 'Muthukrishnan SivaKumaran'; [email-masked]
Subject: Re: [Megaco] Subtract command with null context.

Brian
  I did not get why u are specifying '"if the termination was already in the
null context" 
  The TerminationIds are scoped by the contextId , so when the ContextId is
specified as NULL , u'd be addressing only those terminations which are in
Null context 
   Returning a termination to NULL context restores their
default/provisioned properties. So for a termination already in NULL
context, Subtract is basically a no-op  
        Or am i missing something ?
 
Reg 
Usha

----- Original Message ----- 
From: Rosen, Brian <mailto:[email-masked]>  
To: 'Muthukrishnan  <mailto:[email-masked]> SivaKumaran'
; [email-masked] <mailto:[email-masked]>  
Sent: Tuesday, October 09, 2001 5:16 PM
Subject: RE: [Megaco] Subtract command with null context.

A Subtract from Null context is at best a no-op (if the termination was
already in the
null context) or at worst an error.  I'd say it was a no-op.  Of course,
since Subtract
causes properties to revert to default values, it would do that if the
termination was in 
Null, so it's not quite a no-op.
 
Brian

-----Original Message-----
From: Muthukrishnan SivaKumaran [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 5:00 AM
To: [email-masked]
Subject: [Megaco] Subtract command with null context.

Hi,
 
Whether the protocol supports a Subtract command with null context. In real
scenario Subtract with null context won't come at all. Is it true. Clarify.

---

From: Christian Groves <[email-masked]>
Date: Wed, 10 Oct 2001 10:08:01 +1000

Subtracting a termination from the NULL context is not an No-OP it is a
definite error in the protocol. It should be reported back as such.

Christian

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco