Subject: RE: [Megaco] Context Id choose

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 18 Oct 2001 12:49:18 -0400

Modify on a CHOOSE context will work fine as long as the Termination ID is
specified - it will return the context the term is in.  This scenario does
not require an Add/Move.

Kevin

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Thursday, October 18, 2001 7:05 AM
To:	vibansal; megaco
Subject:	Re: [Megaco] Context Id choose

 << File: Wipro_Disclaimer.txt >> Vivek,

  Refer Annex L for the definition of error code ' 412 Name: No ContextIds
available',
  (It implies that 'Move' with ContextId as 'choose' is legal)
Using ContextId as 'choose' for 'Modify' command should also work fine as
long as Modify command is preceeded  with Add/Move command  in the Action to
get the specified termination in the context

Reg
Usha

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 18, 2001 2:17 PM
Subject: [Megaco] Context Id choose

>
>
>
> Hi
>
> I wanted to know if it is right to send context Id choose with MOVE or
MODIFY
> command?
> I could not find the relevant text in the rfc.
>
> Please clarify.
>
> Regards
> Vivek
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 23 Oct 2001 09:49:49 +0530

Sorry, the mail that i was referring to was posted in Feb, 
  Have pasted the relevant section from the mail for reference.

Reg
Usha

----------------------------
Subject: 
           Re: Wildcard in ContextId 
       Date: 
           Thu, 1 Feb 2001 09:27:48 -0500 
      From: 
           Tom Taylor <[email-masked]> 
   Reply-To: 
           Tom-PT Taylor <[email-masked]> 
 Organization: 
           Nortel Networks 
        To: 
           [email-masked] 
  References: 
           1 

I think Chuong's inference is right.  An ANY placeholder as you propose 
it is an attractive v2 option.  In the meantime, the workaround is that 
the MGC has to be precise in its commands, giving the exact context for 
each termination to be subtracted. 

Kapil Nayar wrote: 
> 
> Hi 
> 
> Taking a clue from Chuong's example, 
> Context = * { Subtract = a/b/c/t123* } or Context = * { Subtract = * } 
> may result in a large number of command replies with error descriptors. 
> 
> We may all agree that the reasonable way to handle this is to resolve the 
> contexts and then resolve the terminations in those contexts, which is 
> against the assumption that context ids are resolved based upon the first 
> command in the action. 
> 
> Observing this thread of discussion, I wondered if we have ever thought 
> of a wildcarded option ANY(?) for context id in the protocol 
> (in addition to "ALL"(*), "CHOOSE"($) and "NULL"(-) existing in the 
protocol) 
> (ANY may refer to any existing context including NULL but doesn't 
specifically 
> refer to any one or all context ids). 
> 
> The ANY context id : 
> -    Cannot be partially wildcarded. 
> -    May be actively used for Subtract command with wildcarded termination 
id. 
> -    in Audit Value (termination wild carded) - audit of all matching 
>      terminations (even in NULL context). 
> Since, ANY would resolve to any (all including NULL) context ids, its usage 
> can be restricted to avoid any further confusion

---

From: Winter Johannes <[email-masked]>
Date: Wed, 24 Oct 2001 16:06:52 +0200

Hi list,

> -----Ursprüngliche Nachricht-----
> Von: William McNicol [mailto:[email-masked]]
> Gesendet am: Freitag, 19. Oktober 2001 18:17
> An: Kevin Boyle
> Cc: [email-masked]; [email-masked]; [email-masked];
> megaco; [email-masked]
> Betreff: Re: [Megaco] Context Id choose

> ...

> I'd dearly love to see a table in the IG with all combinations of:
> ContextID:     Null, Choose, All, FullySpecified
> Command:       Add, Modify, Subtract, Move, AuditValue, 
> AuditCapabilities, Notify, ServiceChange
> TerminationID: Root, All, Wildcard with $, Wildcard with *, 
> FullySpecified
> with a statement as to the legality and semantics of each combination.
> 
> This could be populated from what the standard already
> explicitly allows or outlaws and then we could apply the
> common sense test on what the remaining entries mean.
>   
> William.

I also think that such a table in the IG is a very good idea. 
To start a discussion, please have a look at the following table with
ContextId/TerminationId combinations for the MODIFY, SUBTRACT, MOVE and
AUDIT Value/Capablities commands. 
The table reflects my view, so, comments/corrections are very welcome. 

regards

Johannes 

ContextID   TerminationID 	MODIFY	SUBTRACT	MOVE
AUDIT Value
	
AUDIT Capabilities	
----------------------------------------------------------------------------
---------
Choose	Choose	 	x		x		x		x
Choose      All		 	x		x		ok?
x
Choose      specific		x		x		ok?
x
Choose      Root			x		x		x
x
All	      Choose		x		x		x
x
All         All			ok		ok		x
ok
All         specific		ok?		ok?		x
ok
All         Root			x		x		x
ok
specific    Choose		x		x		x
x
specific    All			ok		ok		ok
ok
specific    specific		ok		ok		ok
ok
specific    Root			x		x		x
x
Null	      Choose		x		x		x
x
Null        All			ok		x		x
ok
Null        specific		ok		x		x
ok
Null        Root			ok		x		x
ok
----------------------------------------------------------------------------
---------
x = forbidden