Subject: [Megaco] Service Change Request Descripency

From: Padmaja Musti <[email-masked]>
Date: Tue, 23 Oct 2001 18:05:57 +0530

Hi,
As per the section section 7.2.8 it is mentioned that parameter
TerminationID could be a list
as quoted below.

"The TerminationID parameter specifies the Termination(s) that are taken out
of or returned to service. Wildcarding of Termination names is permitted,
with the exception that the CHOOSE mechanism shall not be used. Use of the
"Root" TerminationID indicates a ServiceChange affecting the entire Media
Gateway. "

But I see difference in the ASN and ABNF definitions. ASN it is list but
ABNF it is not.
Is this corrected in the IG - i could not find it. If not can it be taken as
a correction. Same
is true for Reply as well.

ASN Definition for Service Change Request:

ServiceChangeRequest ::= SEQUENCE
{
	terminationID		TerminationIDList,
	serviceChangeParms	serviceChangeResult,
	....
}

ABNF Definition for Service Change Request:

serviceChangeRequest = SeriveChangeToken EQUAL TerminationID
			LBRKT serviceChangeDescriptor RBRKT

regards,
Padma

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Tue, 23 Oct 2001 11:42:57 -0400

Padma,

This is from the comments at the beginning of Annex A.
I don't know why this was done.

-troy

--    NOTE - The ASN.1 specification below contains a clause defining
--    TerminationIDList as a sequence of TerminationIDs.  The length of
--    this sequence SHALL be one, except possibly when used in
--    contextAuditResult.