Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination ID s and context ID s

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Oct 2001 08:20:42 -0400

You can say Common* and trunk/*/digital
You can even say Foo/$, that is, choose any termination
starting with "Foo/"

Null is a single value however.

Brian

> -----Original Message-----
> From: Padmaja Musti [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:02 AM
> To: [email-masked]
> Subject: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination IDs
> and context ID s
> 
> 
> Hi,
> ContextID is basically UINT32 and three values are reserved
> to represent NULL/CHOOSE/ALL for ASN. In ABNF these
> are represented using "-"/"$"/"*". Since three values are reserved
> why can't we use the same values in ABNF as well instead of using
> "-"/"$"/"*". Is it done to be inline with TerminationID.
> 
> ContextID = (UINT32/ "*"/"-"/"$")
> 
> 
> Context ID        Reserved Value          ABNF text
> 
>     NULL            0x0                         -
>   
>     CHOOSE          0xFFFFFFFE(4294967295)      $
> 
>     ALL             0xFFFFFFFF(4294967295)      *
> 
> regards,
> Padma
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 10 Oct 2001 10:20:41 -0400

You are confusing binary and text encoding.  In text encoding, a context
value of 0 is not allowed.  Binary encoding makes use of 0x0 because it is a
logical and convenient choice for the NULL context.  Text encoding does not
need to pick a number, necessarily, to represent a messaging portion.  The
use of "-" makes it very clear that the MGC really means NULL, and is not
signalling a bad context ID (through a bug, or some other problem).

As for ALL and CHOOSE, text parsing is faster with a single character
identifier, rather than a long number as an identifier.  There are many
instances where a MGC would want to signal ALL or CHOOSE, and it would be a
waste of message space and processing time to choose some arbitrarily large
number to represent those concepts, when $ and * work just as well.

Kevin

 -----Original Message-----
From: 	Padmaja Musti [mailto:[email-masked]] 
Sent:	Wednesday, October 10, 2001 8:58 AM
To:	'Rosen, Brian'; [email-masked]
Subject:	RE: [Megaco] Representation of ALL/NULL/CHOOSE for
Termination ID s  and context ID s

Brian,
I agree with you on ALL/NULL/CHOOSE usage in representing
the termination ID. My question is on representing the
context ID. There are values reserved in context ID
say 0x0 for NULL. So when I send the NULL context ID 
in ABNF can send it as "-"

Transation = 10006 {
   Context = - { ...}
   ..
   }

or can I also use the following notation since '0' is reserved for
NULL Context ID.

Transation = 10006 {
   Context = 0 { ...}
   ..
   }

regards,
Padma

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 5:51 PM
To: 'Padmaja Musti'; [email-masked]
Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
ID s and context ID s

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 10 Oct 2001 14:50:32 -0400

We didn't define the ABNF that way and that's that.  I suppose binary-coded
text would have been one way to compromise when we were defining the
protocol :-) but your proposal is out of scope for v1.

-----Original Message-----
From: Padmaja Musti [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 8:58 AM
To: 'Rosen, Brian'; [email-masked]
Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
ID s and context ID s

Brian,

Transation = 10006 {
   Context = - { ...}
   ..
   }

Transation = 10006 {
   Context = 0 { ...}
   ..
   }

regards,
Padma

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 5:51 PM
To: 'Padmaja Musti'; [email-masked]
Subject: RE: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
ID s and context ID s

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 11 Oct 2001 10:11:13 -0400

Woops, should have checked more carefully; we explicitly
disallow that:

From 8.1.2:
The MGC shall not use partially specified ContextIDs 
containing the CHOOSE wildcard.

Sorry for the confusion, you can't partially wildcard a ContextId.

Brian

> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 8:56 PM
> To: Rosen, Brian
> Cc: 'Padmaja Musti'; [email-masked]
> Subject: Re: [Megaco] Representation of ALL/NULL/CHOOSE for 
> Termination
> IDs and context ID s
> 
> 
> G'Day Brian,
> 
> Are you saying that we can partially wildcard a context ID?
> The context ID can only be choose, NULL, specific or ALL.
> 
> Christian
> 
> "Rosen, Brian" wrote:
> > 
> > So you "could" say
> > Context=7665*{TerminationID=*{Audit{})
> > 
> > Brian
> >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 11 Oct 2001 11:31:41 -0400

I myself am extremely reluctant to change the protocol by adding numeric
codes for text wildcards.  Other people may have their opinions, but I think
you would agree it is a protocol change.

Our use of the word "reserved" is consistent with practice in other
standards documents.  In Q.933, for instance, the first use of the word
"reserved" (beyond the copyright statement) is in the Protocol
Discriminator, where certain values are reserved because they would cause
confusion with X.25.

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 4:57 PM
To: Taylor, Tom-PT [CAR:B881:EXCH]
Cc: Rosen, Brian; Padmaja Musti; [email-masked]
Subject: Re: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
ID s and context ID s

Tom,

I don't think you got my point. "0" could still mean NULL,
just like "-" does.  It's just another way of encoding NULL.

This would have no conflict when mixing text and binary
control associations.  There's no conflict because '0'
would mean NULL in both text and binary.

If you disagree and think "0" should be illegal in the text
encoding, that's fine.  But the IG should change "reserved" to
"illegal" because "reserved" could mean "reserved for these 
special meanings -- not to be used as a standard Context".

-troy

> Tom-PT Taylor wrote:
> 
> No, it is as Brian said: you have to reserve them because of the
possibility
> that the same MG could be involved in multiple control associations in
> sequence, where one was in text and another in binary.  This could happen,
> for instance, if the encoding to use was configured in the MG along with
the
> MGC contact data.
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 10:46 AM
> To: Rosen, Brian
> Cc: Padmaja Musti; [email-masked]
> Subject: Re: [Megaco] Representation of ALL/NULL/CHOOSE for Termination
> IDs and context ID s
> 
> So the question is what does "reserved" mean in this comment?
> Clearly those 3 values cannot be used to represent a normal
> Context.
> 
> But there's no reason to make them illegal to send in a text message.
> '0' is equivalent to '-' here.
> 
> Or is human readability so important to the text encoding that
> 0xFFFFFFFE and 0xFFFFFFFF are scary?
> 
> -troy
> 
> "Rosen, Brian" wrote:
> >
> > I think we did that so that if you did have both a binary and
> > a text implementation, the ALL/CHOOSE values that would otherwise
> > be legal for text, but conflicting with binary, were made to be
> > illegal as ContextIds for both.
> >
> 
> > > I was about to reply that Pradmaja was mixing ABNF and
> > > ASN.1 defined values when I noticed the following comment
> > > in the ABNF.
> > >
> > >
> > >    ;The values 0x0, 0xFFFFFFFE and 0xFFFFFFFF are reserved.
> > >    ContextID            = (UINT32 / "*" / "-" / "$")
> > >
> > >
> > > I'm not sure of the intent here.  Maybe you can use the numeric
> > > reserves and '*', '-', and '$' are just more readable alternatives?