Subject: [Megaco] Deprecating Binary

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 13 Dec 2001 12:13:39 -0500

As you all know, I'm not in favor of changing the protocol any time
soon (the "V2" argument).  However, since we are discussing protocol
changes, and discussions are always welcome, I'd like to propose that
we deprecate binary.

We have found in actual implementations, that there is very little
difference between binary and text in both message size and
processing time, and in both cases, text is superior (yes folks,
text messages are, on average SMALLER then the equivalent binary).

We have also found that few implementations exist of binary (around
1 or 2 out of 20).

For these reasons, I suggest that binary be deprecated.  Of course,
we can leave "backwards compatibility" language.

Brian

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 13 Dec 2001 19:22:06 -0500

It's a serious proposal, and I know which dogs I'm kicking.

Is there anyone aware of a binary-only implementation?
I am not aware of any.  About 80-90% of implementations
are text-only.  That settles the issue of which one we chop.

There are no technical arguments in favor of binary.
At the time of the original design, there were technical
arguments put forward.  Those have proven by experience
to not be true.  There remain political, or "taste"
arguments.  They have no place in either the IETF or the ITU.

Simplicity is a powerful technical argument.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, December 13, 2001 6:47 PM
> To: [email-masked]'
> Subject: Re: [Megaco] Deprecating Binary
> 
> 
> I checked the date and its not April 1st so this must 
> actually be a real
> proposal. Let sleeping dogs lie. There are implementations of 
> both text
> and binary. We could equally propose to remove the text 
> option to reduce
> options etc.
> 
> Regards, Christian
> 
> "Blatherwick, Peter" wrote:
> > 
> > I agree with this thought.  Reasoning for me is complexity 
> of stack implementation, which leads to larger footprint, 
> higher development cost and reduced reliability.  Also, it 
> has taken a great deal of WG effort just to produce the 
> encoding and keep them in synch -- a headache which distracts 
> us from getting important stuff that actually makes a 
> functional difference right.
> > 
> > -- Peter Blatherwick
> > (at risk of being hit in some of the cross-fire which is 
> almost certain to come up ;-)
> > 
> > -----Original Message-----
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: December 13, 2001 12:14
> > To: [email-masked]'
> > Subject: [Megaco] Deprecating Binary
> >

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 13 Dec 2001 19:22:06 -0500

Brian

---

From: "Andrade, Ricardo" <[email-masked]>
Date: Thu, 13 Dec 2001 17:47:53 -0800

Another question on top of this one:

On the open h323 project (www.openh323.org) there's code for
encoding/decoding the h323 asn.1, which can be used as base for an h.248
encoder/decoder. Is there any open source project using text encoding where
a parser could be find?

My 2 cents, on the topic now. H.323 uses binary enconding only. On the other
hand, SIP uses text encoding. I would say that based on the network where
the MGC is it would easier to use one or the other encoding method. Also it
depends on the method that the MG is using since MGC is supposed to support
both. In my opinion, h.248 could support both (just like it already does)
and the implementations will depend on where you want to connect your
product to.

Ricardo Andrade
Embedded SW Engineer
Siemens ICN
San Jose, CA USA
> Sent: Thursday, December 13, 2001 4:22 PM
> To: 'Christian Groves'; [email-masked]'
> Subject: RE: [Megaco] Deprecating Binary
> 
>

---

From: "Andrade, Ricardo" <[email-masked]>
Date: Thu, 13 Dec 2001 17:47:53 -0800

Ricardo Andrade
Embedded SW Engineer
Siemens ICN
San Jose, CA USA