Subject: [Megaco] ServiceChangeReply parameters

From: "J.H. Kim" <[email-masked]>
Date: Tue, 11 Dec 2001 15:51:21 +0900

Hi, all.

In the draft-ietf-megaco-h248v2-00 :

The ServiceChangeResult of ServiceChangeReply is defined as Mandatory in Megaco ASN.1 description 
But it is definded as OPTIONAL in Megaco ABNF description.

I think the application that use the Megaco stack should have consistent view for the Megaco data.
But the same one is defined as OPTIONAL in ABNF and defined as Mandatory in ASN.1.

Who can help me to solve the isssue?

Thanks forward for your help.

in ASN.1
====================================================
ServiceChangeReply ::= SEQUENCE
{
 terminationID         TerminationIDList,
 serviceChangeResult   ServiceChangeResult,
 ...
}
ServiceChangeResult ::= CHOICE
{
 errorDescriptor         ErrorDescriptor,
 serviceChangeResParms   ServiceChangeResParm
}
====================================================

in ABNF
====================================================
serviceChangeReply   = ServiceChangeToken EQUAL TerminationID
                       [LBRKT (errorDescriptor / 
                       serviceChangeReplyDescriptor) RBRKT]
====================================================

G'Day

---------------------------------------------------------
Jay H Kim 
R&D Center  XENER Systems Inc.
Office: +82-2-3482-4901. ext.411 
Fax: +82-2-3483-4902 
+mailto:[email-masked] 
Homepage: www.xener.com
--------------------------------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 11 Dec 2001 13:04:11 +0530

Hello,

     ServiceChangeResult is a choice so only one of ErrorDescriptor or
ServiceChangeResParm
     is taken.
     All the pameters of ServiceChangeResParm of ServiceChangeResult are
optional .
     So in this way ServiceChangeResult of ServiceChangeReply becomes OPTIONAL
in ASN.1 also.

Regards
Monika Puri
Hughes Software Systems

"J.H. Kim" <[email-masked]> on 12/11/2001 12:21:21 PM

To:   [email-masked]
cc:    (bcc: Monika Puri/HSS)

Subject:  [Megaco] ServiceChangeReply parameters

Hi, all.

The ServiceChangeResult of ServiceChangeReply is defined as Mandatory in Megaco
ASN.1 description
But it is definded as OPTIONAL in Megaco ABNF description.

I think the application that use the Megaco stack should have consistent view
for the Megaco data.
But the same one is defined as OPTIONAL in ABNF and defined as Mandatory in
ASN.1.

in ASN.1

in ABNF

G'Day

---

From: [email-masked]
Date: Tue, 11 Dec 2001 13:04:11 +0530

Hello,

Regards
Monika Puri
Hughes Software Systems

To:   [email-masked]

Hi, all.

in ASN.1

in ABNF

G'Day