Subject: RE: [Megaco] Deprecating Binary

From: "Blatherwick, Peter" <[email-masked]>
Date: Thu, 13 Dec 2001 12:43:20 -0500

I agree with this thought.  Reasoning for me is complexity of stack implementation, which leads to larger footprint, higher development cost and reduced reliability.  Also, it has taken a great deal of WG effort just to produce the encoding and keep them in synch -- a headache which distracts us from getting important stuff that actually makes a functional difference right.  

-- Peter Blatherwick
(at risk of being hit in some of the cross-fire which is almost certain to come up ;-)  

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: December 13, 2001 12:14
To: [email-masked]'
Subject: [Megaco] Deprecating Binary

As you all know, I'm not in favor of changing the protocol any time
soon (the "V2" argument).  However, since we are discussing protocol
changes, and discussions are always welcome, I'd like to propose that
we deprecate binary.

We have found in actual implementations, that there is very little
difference between binary and text in both message size and
processing time, and in both cases, text is superior (yes folks,
text messages are, on average SMALLER then the equivalent binary).

We have also found that few implementations exist of binary (around
1 or 2 out of 20).

For these reasons, I suggest that binary be deprecated.  Of course,
we can leave "backwards compatibility" language.

Brian

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 14 Dec 2001 10:47:25 +1100

I checked the date and its not April 1st so this must actually be a real
proposal. Let sleeping dogs lie. There are implementations of both text
and binary. We could equally propose to remove the text option to reduce
options etc.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Fri, 14 Dec 2001 10:47:25 +1100

Regards, Christian

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 26 Dec 2001 22:40:15 -0500

I agree.

Let's go for a binary-only version of H.248.

Then maybe H.248 will just go away, in favor of J.162 ;-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christian Groves
Sent: Thursday, December 13, 2001 6:47 PM
To: [email-masked]'
Subject: Re: [Megaco] Deprecating Binary

Regards, Christian

"Blatherwick, Peter" wrote:
>
> I agree with this thought.  Reasoning for me is complexity of stack
implementation, which leads to larger footprint, higher development cost and
reduced reliability.  Also, it has taken a great deal of WG effort just to
produce the encoding and keep them in synch -- a headache which distracts us
from getting important stuff that actually makes a functional difference
right.

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 26 Dec 2001 22:40:15 -0500

I agree.

-----Original Message-----

Regards, Christian