Subject: RE: [Megaco] Audit termination hook status

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 10 Dec 2001 12:46:36 -0500

Why do you need this?  The hook state can be easily discovered by scanning
for one or the other, and setting the strict parm appropriately (either
state, or failWrong).  The MGC should have a pretty good guess about what
the current hook state is, and, therefore, scan for the other.  If the
strict parm is set to state, then if the MG is already in that state, it
will report it right away with a parm to indicate if it was an explicit
change or not.  In the case of failWrong, an error will be returned.  The
MGC can then act appropriately.
 
Kevin
 
-----Original Message-----
From: Taylor, Tom-PT [CAR:B800:EXCH] 
Sent: Monday, December 10, 2001 12:04 PM
To: 'Chuong N. Nguyen'; [email-masked]
Subject: RE: [Megaco] Audit termination hook status
 
Only if we define it as a property.  Then auditing becomes easy.
 
New lines package?  Is this of general interest?
-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Sunday, December 09, 2001 5:46 PM
To: [email-masked]
Subject: [Megaco] Audit termination hook status
Tom 
Can we add Audit termination hook status (on-hook, off-hook) to v2? 
Thanks 
Chuong 
  
-- 
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 10 Dec 2001 13:08:35 -0600

Hi Kevin

It is for the case where MGC did  not get the Notify for the change in
hook state from MG for whatever reason.

What do you mean by scanning?

Kevin Boyle wrote:

> Why do you need this?The hook state can be easily discovered by
> scanning for one or the other, and setting the strict parm
> appropriately (either state, or failWrong).The MGC should have a
> pretty good guess about what the current hook state is, and,
> therefore, scan for the other.If the strict parm is set to state, then
> if the MG is already in that state, it will report it right away with
> a parm to indicate if it was an explicit change or not.In the case of
> failWrong, an error will be returned.The MGC can then act
> appropriately.
>
> Kevin
>

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 10 Dec 2001 13:08:35 -0600

Hi Kevin

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 10 Dec 2001 13:14:11 -0600

Hi Kevin

For whatever reason, said MGC did not get the Notify from MG.

What do you mean by scanning for one or the other?

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 10 Dec 2001 13:14:11 -0600

Hi Kevin