Subject: [Megaco] ";at-most-once" in the Megaco ABNF

From: "J.H. Kim" <[email-masked]>
Date: Mon, 10 Dec 2001 17:46:35 +0900

Hi, all

Could anybody tell me the meaning of the "; at-most-once" the ABNF description of Megaco?

================================
contextAudit	   = ContextAuditToken LBRKT contextAuditProperties *(COMMA  contextAuditProperties) RBRKT
; at-most-once
contextAuditProperties = ( TopologyToken / EmergencyToken / PriorityToken /  IndAudcontextAttrDescriptor /
                        ContextAttrDescriptorCapAud/IndAudContextAttrCap / ContextAttrPackages)
=================================

Does the above description mean that the TopologyToken can appear at most one time in the contextAudit?

Thanks forward for your help.

G'Day

---------------------------------------------------------
Jay H Kim 
R&D Center  XENER Systems Inc.
Office: +82-2-3482-4901. ext.411 
Fax: +82-2-3483-4902 
+mailto:[email-masked] 
Homepage: www.xener.com
--------------------------------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 10 Dec 2001 15:06:58 +0530

Hello,

===============================
contextAudit      = ContextAuditToken LBRKT contextAuditProperties *(COMMA
contextAuditProperties) RBRKT
; at-most-once
contextAuditProperties = ( TopologyToken / EmergencyToken / PriorityToken /
IndAudcontextAttrDescriptor /
                        ContextAttrDescriptorCapAud/IndAudContextAttrCap /
ContextAttrPackages)
=================================

The meaning of "at-most-once" here is that each of the tokens/parameters of
contextAuditProperties can
come only once in contextAudit.

for e.g:-

contextAudit = ContextAuditToken LBRKT TopologyToken COMMA TopologyToken RBRKT
is not allowed.

Regards,
Monika Puri
Hughes Software Systems

"J.H. Kim" <[email-masked]> on 12/10/2001 02:16:35 PM

To:   [email-masked]
cc:    (bcc: Monika Puri/HSS)

Subject:  [Megaco] ";at-most-once" in the Megaco ABNF

Hi, all

Could anybody tell me the meaning of the "; at-most-once" the ABNF description
of Megaco?

================================
contextAudit      = ContextAuditToken LBRKT contextAuditProperties *(COMMA
contextAuditProperties) RBRKT
; at-most-once
contextAuditProperties = ( TopologyToken / EmergencyToken / PriorityToken /
IndAudcontextAttrDescriptor /
                        ContextAttrDescriptorCapAud/IndAudContextAttrCap /
ContextAttrPackages)
=================================

Does the above description mean that the TopologyToken can appear at most one
time in the contextAudit?

G'Day

---

From: [email-masked]
Date: Mon, 10 Dec 2001 17:41:12 +0530

Hello,

     Yes there seems to be a difference between the ABNF and ASN.1 grammar
relating to the specified structure.

Regards,
monika

"J.H. Kim" <[email-masked]> on 12/10/2001 04:06:53 PM

To:   Monika Puri/HSS@HSS
cc:   Rajendra D Patil/HSS@HSS, [email-masked]

Subject:  RE: [Megaco] ";at-most-once" in the Megaco ABNF

Thanks Monika Puri,
In the ASN.1 Megaco description,

===============================
ContextAttrAuditRequest ::= SEQUENCE
{
            topology     NULL OPTIONAL,
     emergency NULL OPTIONAL,
     priority  NULL OPTIONAL,
     ...,
     contextPropAud SEQUENCE OF IndAudPropertyParm OPTIONAL
            contextAttrDescriptorCapAud     NULL OPTIONAL,
     contextPropCapAud        SEQUENCE OF IndAudPropertyParm OPTIONAL,
     contextPackagesAud  NULL OPTIONAL
}

IndAudPropertyParm ::= SEQUENCE
{
     name           PkgdName,
     ...
}

The topology can be appeared at most once as your example.
The contextPropAud can have multiple IndAudPropertyParms. but in the ABNF Megaco
description the IndAudcontextAttrDescriptor can be appeared at most once.

===============================
IndAudcontextAttrDescriptor = ContextAudValToken LBRKT pkgdName RBRKT
===============================

Does the ASN.1 description and the ABNF description say different one or there
is some misunderstanding to me?

G'Day

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, December 10, 2001 6:37 PM
To: J.H. Kim
Cc: [email-masked]; [email-masked]
Subject: Re: [Megaco] ";at-most-once" in the Megaco ABNF

Hello,

for e.g:-

Regards,
Monika Puri
Hughes Software Systems

To:   [email-masked]

Hi, all

G'Day

---

From: [email-masked]
Date: Mon, 10 Dec 2001 17:41:12 +0530

Hello,

Regards,
monika

To:   Monika Puri/HSS@HSS

Thanks Monika Puri,

G'Day

-----Original Message-----

Hello,

for e.g:-

Regards,
Monika Puri
Hughes Software Systems

To:   [email-masked]

Hi, all

G'Day