Subject: [Megaco] RE: [Megaco]how can I describe the SDP in binary encoding for Meg aco?

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 18 Dec 2001 11:02:50 -0500

This came to me alone, since you addressed it to [email-masked]
rather than [email-masked].

To address your question, I believe you have it correct, except that there
would be double-wrapping: the OCTET STRINGS would contain IA5Strings.

-----Original Message-----
From: Sung-Hoon Lee [mailto:[email-masked]]
Sent: Thursday, December 13, 2001 7:18 AM
To: [email-masked]
Subject: [Megaco]how can I describe the SDP in binary encoding for Megaco?

Hi, all.

Anybody tell me how can describe the SDP in binary encoding for Megaco.
The rfc3015 has example for the ABNF description only.

The following is my understanding of the rfc3015.
for example,
        1)      v=0                               
                c=IN IP4 124.124.124.222                               
                m=audio 2222 RTP/AVP 4
                a=ptime:30
                a=recvonly

           LocalRemoteDescriptor{
                PropertyGroup {
                        PropertyParm{
                                name=SDP_V
                                value=0
                        }
                        PropertyParm{
                                name=SDP_C
                                value=IN IP4 124.124.124.222
                        }
                        PropertyParm{
                                name=SDP_M
                                value=audio 2222 RTP/AVP 4
                        }
                        PropertyParm{
                                name=SDP_A
                                value=ptime:30
                        }                      
                        PropertyParm{
                                name=SDP_A
                                value=recvonly
                        }
                }      
        }

Could anybody tell me anything is wrong?  If there is something wrong
description, could you fix that one?
Thanks forward for your help.

G'Day

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 18 Dec 2001 11:02:50 -0500

-----Original Message-----
From: Sung-Hoon Lee [mailto:[email-masked]]
Sent: Thursday, December 13, 2001 7:18 AM
To: [email-masked]
Subject: [Megaco]how can I describe the SDP in binary encoding for Megaco?

Hi, all.

           LocalRemoteDescriptor{
                PropertyGroup {
                        PropertyParm{
                                name=SDP_V
                                value=0
                        }
                        PropertyParm{
                                name=SDP_C

G'Day