Subject: [Megaco] topology optional to implement

From: [email-masked]
Date: Mon, 24 Dec 2001 19:05:48 +0530

Hi All

  RFC 3015 states that topology is optional to implement.
How does the MGC know whether the MG supports Topology ?
Will it be preconfigured ?

BTW, are there any other components of the protocol which are 'optional to
implement' ?

Regards
Shiv Kumar

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 31 Dec 2001 15:52:03 -0500

Hi.  Answers below.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, December 24, 2001 8:36 AM
To: [email-masked]
Subject: [Megaco] topology optional to implement

Hi All

[PTT]
I expect that would be the normal way.  Alternatively the MGC could run a
test to see how the the MG responds.
[\PTT]

[PTT] In the main protocol, the only other optional-to-implement element I
could spot is sequential signal lists.  There are some things it is not
mandatory to send but they must be handled gracefully when received, such as
text in error descriptors.  I have a feeling a lot of the occurrences of the
word "optional" in the specification should be replaced with "conditionally
mandatory", meaning that the item must be present in a message under stated
circumstances.  The section on ServiceChange is especially bad in this
respect.

Beyond that is the obvious stuff.  You could just implement one encoding
(binary, text).  All packages are optional.  The various transports are
optional, although MGCs SHOULD implement TCP and UDP/ALF.
[\PTT]

Regards
Shiv Kumar

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 31 Dec 2001 15:52:03 -0500

Hi.  Answers below.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, December 24, 2001 8:36 AM
To: [email-masked]
Subject: [Megaco] topology optional to implement

Hi All

[PTT]

Regards
Shiv Kumar