Subject: [Megaco] one dount on RFC3015 as to the requirement on RFC2805

From: "zhangzhong" <[email-masked]>
Date: Fri, 28 Dec 2001 11:40:14 +0800

Hi :
In the rfc 2805, there have a request to H.248:
        Provide a mechanism to discover the current available resources
        in the MG, where resources are dynamically consumed by
        connections and the MGC cannot reasonably or reliably track the
        consumption of such resources. It should also be possible to
        discover resources currently in use, in order to reconcile
        inconsistencies between the MGC and the MG.

This means MGC can know the resource consume in the MGW , for example , if There have 1000 G.711 channel resource , if 500 is busy , How can MGC know this through RFC3015?
If can't , The RFC3015 is inconsist with the RFC2805

Thanks for the reply.
Regards
Zhangzhong

---

From: "Shashi Kumar" <[email-masked]>
Date: Fri, 28 Dec 2001 10:25:16 +0530

we have provision to audit the MG resource, which clearlty defined by
Megaco/H.248. By means of Auduting the MG resources we can always
"reconcile inconsistencies between the MGC and the MG"

thanks,
shashi

> zhangzhong wrote:
> This means MGC can know the resource consume in the MGW , for example
> , if There have 1000 G.711 channel resource , if 500 is busy , How can
> MGC know this through RFC3015?

---

From: "Shashi Kumar" <[email-masked]>
Date: Fri, 28 Dec 2001 10:25:16 +0530

thanks,
shashi

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 28 Dec 2001 09:44:25 -0500

HI Shashi,All,
Its true that Audit will help MGC to reconcile the inconsistency. But for
the specific scenario Zhang has pointed, How this resource information is
exchanged between the MG and the MGC. According to my knowledge there is no
parameter or anything as such to "quantitatively" identify G711 or any such
channel resource.
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Shashi Kumar
Sent: Thursday, December 27, 2001 11:55 PM
To: zhangzhong
Cc: [email-masked]
Subject: Re: [Megaco] one dount on RFC3015 as to the requirement on
RFC2805

thanks,
shashi

> If can't , The RFC3015 is inconsist with the RFC2805

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 28 Dec 2001 09:44:25 -0500

HI Shashi,All,

-----Original Message-----

thanks,
shashi

---

From: "Shashi Kumar" <[email-masked]>
Date: Fri, 28 Dec 2001 21:14:07 +0530

Hi Madhu,

   I totally agree with you. But can we make Deductions from the
available data at a given point of time? like, if termination is not in
NULL context, that termination is Busy etc. such Deduction(s) shall
definitely cater to the requirement(s), which Zhang quoted from RFC
2805.

Thanks,
Shashi

---

From: "Shashi Kumar" <[email-masked]>
Date: Fri, 28 Dec 2001 21:14:07 +0530

Hi Madhu,

Thanks,
Shashi

---

From: "Raju" <[email-masked]>
Date: Fri, 28 Dec 2001 11:18:38 -0500

May be we should have a package which 'monitors common Gateway resources'
like Terminations, Contexts, Codesc etc.
To monitor other uncommon resources one should extend this package.
This is very useful in finding a common Codec between two Gateways before
setting up a call. Without such a package
it involves more messages to Gateway (like Modify to change codec) to make a
single call. And often it results in failed
calls.

The 'Audit way' of reconcillation is not a standard way of doing it and
ambigous.

> Sent: Friday, December 28, 2001 10:44 AM
> To: Madhu Babu Brahmanapally; [email-masked]; [email-masked]

---

From: "Raju" <[email-masked]>
Date: Fri, 28 Dec 2001 11:18:38 -0500

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 28 Dec 2001 11:36:05 -0500

HI Raju,
As far as Megaco is concerned, Audit is "the" way.

Regards
Madhubabu

-----Original Message-----
From: Raju [mailto:[email-masked]]
Sent: Friday, December 28, 2001 11:19 AM
To: Shashi Kumar; Madhu Babu Brahmanapally; [email-masked];
[email-masked]
Subject: RE: [Megaco] one dount on RFC3015 as to the requirement on
RFC2805

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 28 Dec 2001 11:36:05 -0500

HI Raju,

Regards
Madhubabu

-----Original Message-----
From: Raju [mailto:[email-masked]]
Sent: Friday, December 28, 2001 11:19 AM
To: Shashi Kumar; Madhu Babu Brahmanapally; [email-masked];
[email-masked]

---

From: "zhangzhong" <[email-masked]>
Date: Sat, 29 Dec 2001 10:16:44 +0800

Hi all,
1  I think the method below can  reach the aim in theory , It is a idea in the present protocol, but not very good. And Because it is very ambiguous . It will introduct the difficulity of interwork between MGC and MGW with more difficulity. If the MGW has a big capability , the management of these termination has problems .
The method is not the idea of MEGACO, because  operations of sending tone or playing announcemnt  are all done on  the same termination which receive/send media from/to outside not specified.

Thans for your reply and help.
Regards
Zhangzhong

----- Original Message ----- 
Hi Zhangzhong,

as of current understanding we should admit that there is no direct was
of doing, but we have the information with in the Megaco scope to do
this.

we shall take your specific example of G.711 resource issue...
1. Each G.711 resource is identified as a Termination (using Termination
ID), which is a provisioned info( or otherwise)
2. At any Given point of time, you know how many termination's are in
(a) context(s) ( in both MG and MGC instance of protocol), which shall
be take as G.711 resource which is busy....

with the above info it is very easy to identify how many of G.711
resource are free...

hope this helps...

shashi

---

From: "zhangzhong" <[email-masked]>
Date: Sat, 29 Dec 2001 10:16:44 +0800

Hi all,

----- Original Message ----- 
Hi Zhangzhong,

hope this helps...

shashi

---

From: "Raju" <[email-masked]>
Date: Mon, 31 Dec 2001 09:56:02 -0500

I do agree with Zhangzhong.

Infact calculation of available resources by MGC becomes more tough and
ambigous if the GW supports more than one codec
(e.g. G.723 and G.711), which is generally be the case.
The number of available G.711 codecs depends on the number of G.723 codecs
in use, as G.723 uses more MIPS.
MGC can't understand these dependencies and calculate the exact number of
free resources available, only MG
knows how eactly to calculate the free or available resources.

Pls read my previous mail below.

Thanks
Raju

> zhangzhong
> Sent: Friday, December 28, 2001 9:17 PM
> To: Madhu Babu Brahmanapally; 'Shashi Kumar'
> Cc: [email-masked]
> 1  I think the method below can  reach the aim in theory , It is
> a idea in the present protocol, but not very good. And Because it
> is very ambiguous . It will introduct the difficulity of
> interwork between MGC and MGW with more difficulity. If the MGW
> has a big capability , the management of these termination has problems .
> The method is not the idea of MEGACO, because  operations of
> sending tone or playing announcemnt  are all done on  the same
> termination which receive/send media from/to outside not specified.
>
>

---

From: "Raju" <[email-masked]>
Date: Mon, 31 Dec 2001 09:56:02 -0500

Thanks
Raju