Subject: [Megaco] Embedded descriptor processing with buffered events

From: [email-masked]
Date: Thu, 21 Mar 2002 19:54:28 +0530

Hi

Assuming a scenario when eventbuffercontrol property is lockstep and
events are being buffered by the MG.

If an event descriptor is received with an embedded event and
signal descriptor -
E=10{ p1/e1{ EB{ SG=p1/s1,E=20{ p1/e2{ EB{SG=p1/s2}}}}}}

Note: Package 'p1' is defined with events 'e1','e2' and signals 's1','s2'.

Assuming events in the events buffer are - e1->e2->e1->e2.
The normal processing upon receiving the above events descriptor shall
be:
-    Remove event e1 from event buffer.
-    NOTIFY event e1.
-    Activate embedded event descriptor.
-    Start signal s1 ??
-    Remove event e2 from event buffer.
-    NOTIFY event e2.
-    Stop signal s1 ??
-    Start signal s2.

The MG is starting and stopping the signal s1 at the same instant.
Is this the correct interpretation and expectation from MGCs point
of view.
RFC does say that in the above situation treat an embedded descriptor
as a new events descriptor. However, it does not say anything about
the embedded signals descriptor in above situation.
Any comments...

Kapil Nayar
Hughes Software Systems Ltd.
http://www.hssworld.com

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual  to whom it is
addressed. It may contain  privileged or confidential information  and should
not be circulated or used for any purpose other than for what it is intended. If
you have received this message in error, please notify the originator
immediately. If you are not the intended recipient, you are notified that you
are strictly prohibited from using, copying, altering, or disclosing the
contents of this message. HSS accepts no responsibility for loss or damage
arising from the use of the information transmitted by this email including
damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 21 Mar 2002 20:36:54 +0530

Hi Kapil,
	I guess, that's the interpretation from MGC's point of
view, with a minor modification to the sequence i.e. swap 3 and 4
('Activate embedded event descriptor' and 'Start signal s1 ??'.
It would be better, if we start activating the EmbeddedEventsDescriptor
the last in the event handling process, as activating an
EmbeddedEventsDescriptor starts the next cycle of event handling.
This assures us the correct sequence of operations.
Any comments?
Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 21 Mar 2002 20:36:54 +0530

Hi Kapil,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,