Subject: [Megaco] How to send a request from MG->MGC

From: John Stock <[email-masked]>
Date: Mon, 4 Mar 2002 18:11:48 -0800

How would "request" be sent from the MG->MGC?  For example, if the MG wishes
to perform a channel test on a DN and wishes the MGC to reserve the line for
some period of time.  The only thing that seems possible is by using a
Notify command with an ObservedEvents descriptor indicating the channel test
request.  However this kind of seems inappropriate - it's not really an
event to be notified it's more of a request to be made.

Thanks.

John Stock
Systems Engineer
Advanced Fibre Communications
1465 N. McDowell Blvd.
Petaluma, CA 94954
Tel. 707-792-6249

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 05 Mar 2002 10:12:41 -0500

What you are asking for is not allowed in H.248/MEGACO.  MGC is the controller
and MG is a slave that does not make such decisions.  Of course it is certainly
possible to have a GUI on an MG to initiate such a test, but it would have to
send a request the MGC using some other protocol (e.g., SNMP) and the MGC would
then perform/control the test.  In most systems, MGC has the only signaling
connection to the other end of the PSTN line (e.g., switch) and would be needed
to coordinate the test.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 05 Mar 2002 10:12:41 -0500

--