Subject: RE: [Megaco] Legal Intercept using MEGACO

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 1 Mar 2002 08:34:17 -0500

I'm sorry, but this is highly unlikely to be true.
Unless the addresses, message sequences and parameters of 
trace and handover were identical - and handover happened on every
call to particular endpoints - it would be trivial to determine
that a call was being traced by examining sniffed messages.

I believe there is no way to support legal intercept with Megaco
(or MGCP or SIP or ...).  You either have to force routing of all
calls through a trace box, or something like the access router/switch
has to do the intercept.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, February 28, 2002 6:23 PM
> To: Tom-PT Taylor
> Cc: [email-masked]'; [email-masked]'
> Subject: Re: [Megaco] Legal Intercept using MEGACO
> 
> 
> G'Day Tom,
> 
> Even with a message trace this is not necessarily the case if topology
> is being used for other things in the MG ie. handover.
> 
> Christian
> 
> Tom-PT Taylor wrote:
> > 
> > It can be done using the existing protocol.  To 
> discriminate between the two
> > directions of conversation, you need the topology 
> descriptor.  Brian Rosen
> > raised the point that someone doing a message trace on the 
> MG would be able
> > to tell that legal interception was happening.
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, February 28, 2002 11:25 AM
> > To: [email-masked]
> > Subject: [Megaco] Legal Intercept using MEGACO
> > 
> > Hi All,
> >       Probably this has been discussed below, so if someone 
> can point me to
> > the
> > archive, it will help...
> >       My main query is whether legal intercept can be 
> supported using
> > existing
> > MEGACO protocol.
> >       This could be to support a Packet-based IAP or a circuit IAP
> > (Intercept
> > Access Point) depending
> >       on the deployment requirements. If the existing 
> MEGACO does not
> > support
> > this, then would a package
> >       help or would these be better done as modifications 
> to the base
> > protocol.
> > 
> > Thanks,
> >   Rohit Gupta
> >   www.hssworld.com
> > 
> > "DISCLAIMER: This message is proprietary to Hughes Software 
> Systems Limited
> > (HSS) and is intended solely for the use of the individual  
> to whom it is
> > addressed. It may contain  privileged or confidential 
> information  and
> > should
> > not be circulated or used for any purpose other than for what it is
> > intended. If
> > you have received this message in error, please notify the 
> originator
> > immediately. If you are not the intended recipient, you are 
> notified that
> > you
> > are strictly prohibited from using, copying, altering, or 
> disclosing the
> > contents of this message. HSS accepts no responsibility for 
> loss or damage
> > arising from the use of the information transmitted by this 
> email including
> > damage from virus."
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 04 Mar 2002 14:07:43 +1100

G'Day Brian,

It seems we disagree. I can agree that when Megaco is used for a
residential MG scenario then you will have a problem with sniffing.
However for large MG scenarios that are processing tens of thousands of
messages over a secure MGC-MG link then you do not have the problem as
the end users will be completely unaware what happens across the link.
In this scenario it is quite acceptable to use Megaco to connect a 3rd
party.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Mon, 04 Mar 2002 14:07:43 +1100

G'Day Brian,

Regards, Christian

---

From: "Naveen Krishnan" <[email-masked]>
Date: Mon, 4 Mar 2002 14:28:20 +0800

Hi all,
         Can U please suggest me the solution for the below:

1 How to implement Wildcard in Megaco which algorithom is better for
implementation of the same ?
Naveen: We have the solution for the same by it is not satiafactory, so need
a experts suggestion, thanks in advance

2 Is the TDM termination is Fixed in case of Megaco, what is the latest ? i
case of 3G Nokia a propsed a naming convenation for this solution , i would
like to know what is the status.AS per this Nokia doc the TID is fixed and
will have 8 BYTE .

3 If i want to apply the same Wildcard for the MGCP also, what should i take
care.

4 Also i heared each MG vendor might Use diffrent structure, in this case
how are we going to  solve the issue, once solution is Config the
TID(Termination ID) in MGC who is going to Control MG...are if there in any
better solition , please help us out?

-Naveen Krishnan
Note: In our recent discussion on Block and Unblock of TDM Circuit is going
nice.

---

From: "Naveen Krishnan" <[email-masked]>
Date: Mon, 4 Mar 2002 14:28:20 +0800

Hi all,

-Naveen Krishnan