Subject: [Megaco] Restrictions on parameter names.

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 1 Mar 2002 16:29:48 -0500

The restriction on parameter names in Annex B has always puzzled me.  Now I
think I see what is wrong.  At the neginning of section 12.2 we have added:

"The textual ParameterID of parameters to Events and Signals shall not start
with "EPA" and "SPA", respectively. ..."

In Annex B, however, just before the list of tokens we have this:

; New Tokens added to sigParameter must take the format of SPA*
; * may be of any form ie. SPAM
; New Tokens added to eventParameter must take the form of EPA*
; * may be of any form ie. EPAD

I think the Annex B comments are missing "not".

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 04 Mar 2002 14:11:27 +1100

G'Day Tom,

I believe what is stated is correct. The idea of the text was to
distinguish between package defined properties and those properties
defined in the core protocol. This was to prevent any future overlap. So
parameters added to the core protocol MUST start with SPA/EPA.
Parameters added to the package MUST NOT start with SPA/EPA.

Cheers, Christian

---

From: Christian Groves <[email-masked]>
Date: Mon, 04 Mar 2002 14:11:27 +1100

G'Day Tom,

Cheers, Christian

---

From: Troy Cauble <[email-masked]>
Date: Mon, 04 Mar 2002 11:15:37 -0500

Tom,

Yes, what's stated is correct.  The problem being solved is 
that due to the ABNF, some ABNF *Tokens* share their name
space with package parameters.

For example, if there was a package with a parameter named
"Duration", it would be impossible to distinguish from
sigDuration when parsing sigParameter.

Are there new Tokens in V2 ??
Have they followed the naming restriction ??
If not, they may be impacting existing packages.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Mon, 04 Mar 2002 11:15:37 -0500

Tom,

-troy