Subject: RE: [Megaco] Statistics and Move

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 12 Mar 2002 07:57:55 -0500

Frankly, I think anyone who does Move to Null rather than Subtract is asking
for
all sorts of bizarre behavior.  I'd say you don't get any special behavior
if you Move
to Null.  Does it actually say somewhere that Moving an ephemeral to Null
causes it
to go away?  I'm not so sure it should.  Then again, I don't know why you
would do
it.  I'd even go so far as to recommend that the text state Move to Null
produces 
undefined behavior.
 
Brian

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 4:06 AM
To: Terry L Anderson
Cc: David Barr; 'Al Varney'; Megaco Mailing List
Subject: Re: [Megaco] Statistics and Move

Hi, 

I wonder if we should treat the statistics different depending on if a
Termination is moved to another non-NULL context, or a NULL context. IF we
move it to the NULL context I think we could "reset" the statistics, because
that's also what happens when we move an emphemeral termination to the NULL
context (since the termination is deleted). 

Comments? 

Regards, 

Christer Holmberg 
Ericsson Finland 

Terry L Anderson wrote: 

Thanks for noticing this.  You are right.  We did fix the "call" language
during the editing session in Geneva and the change made it into V2 but
failed to make it into the IG and get swept into V1 Amendment 1 (or
Corrigendum 1 whichever name sticks) 

What do folks think?  Do we need to fix the language in V1 as well through
an IG entry? 

But this still does not address the issue that referring to "Context" here
and in 7.1.15 makes it confusing that Move does not effect it.  Perhaps
language like: 

"when the Termination is subtracted so that it ceases to exist or is
returned to the NULL Context."  Would make it clearer that the issue is
"recycling" the termination and not its relationship to a Context. 

David Barr wrote: 

I've noticed that the reference to "the call" has been removed in v2, look
at section 6.2 in: 
http://search.ietf.org/internet-drafts/draft-ietf-megaco-h248v2-01.txt
<http://search.ietf.org/internet-drafts/draft-ietf-megaco-h248v2-01.txt>  
It now says: 
"Statistics are reported ... when the Termination is subtracted from a
context." 

-----Original Message----- 
From: Al Varney [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, March 08, 2002 12:10 AM 
To: Terry L Anderson 
Cc: Megaco Mailing List 
Subject: Re: [Megaco] Statistics and Move 

That still leaves the 6.2 ambiguity regarding "the call".  IMO the concept 
of a call should not exist in H.248, other than perhaps in 
examples.  Asking an MG to understand how it is being used (as a call 
controller vs. a fancy video server) requires a lot of guessing in 
implementations.  My (hypothetical) video server would never be involved in 
"calls", but I need the statistics to bill hotel guests. 

    Other than examples, glossary and other areas where the term "call" is 
used descriptively, 6.2 appears to be the only area where a "requirement" 
uses this term.  I suggest it be clarified.  Perhaps: 

   "Statistics on a termination are automatically 
    reported only when a termination is Subtracted 
    from a context." 

Al Varney 

At 05:34 PM 3/7/02 -0500, Terry L Anderson wrote: 
>I thought this had been discussed before but nothing got added to IG and I 
>could not find the discussion.  I have no problem either way, I just want
it 
>unambiguous and I am afraid the current document is ambiguous and probably 
>closer to implying zeroing because of the references to Context.  If we 
>agree with Brian then we should change the language in 7.1.15 to not refer 
>to Context in the first sentence (and then need no changes to language
about 
>reporting or clearing). 
> 
>This adds to the distinction between Move and Subtract followed by Add
which 
>is not a bad thing. 
> 
>"Rosen, Brian" wrote: 
> > Huh, I thought we had decided that they were NOT zeroed on 
> > a MOVE which is why they aren't automatically reported. 

> > > From: Terry L Anderson [ mailto:[email-masked] <mailto:[email-masked]>
] 
> 
> > > Statistics on a termination are defined in two ways: 
> > > 1.     6.2 says: 
> > >     "Statistics are reported...when the termination is taken 
> > > out of the 
> > > call it is in." 
> 
> > > 2.    7.1.15 says: 
> > >     "The Statistics parameter provides information describing 
> > > the status 
> > > and usage of a Termination during its existence with a specific 
> > > Context." 
> 
> > > I don't think a "call" is a well defined concept in H.248, but perhaps

> > > these two statements are consistent if we associate a "call" with a 
> > > context.  The issue is, if a termination is Moved to a different 
> > > termination, is it in the same call (one party is probably 
> > > the same but 
> > > the other may not be)?  Or, more specifically are its statistics 
> > > zero'ed. 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco> 

-- 

------------------------------------------------------------ 
Terry L Anderson             mailto:[email-masked] <mailto:[email-masked]>  
Tel:908.582.7013   Fax:908.582.6729 
Lucent Technologies/INS/Voice Over IP Access Networks 
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
http://its.lucent.com/~tla <http://its.lucent.com/~tla>  (Lucent internal)
http://www.gti.net/tla <http://www.gti.net/tla>

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 12 Mar 2002 19:05:25 +0530

Hi,

7.1.15  states  - "Statistics are reset when a Termination is Subtracted
from a Context."
(Also "Move" command cannot be used to move terminations to NULL context)

Reg,
usha
  ----- Original Message -----
  From: Rosen, Brian
  To: 'Christer Holmberg' ; Terry L Anderson
  Cc: David Barr ; 'Al Varney' ; Megaco Mailing List
  Sent: Tuesday, March 12, 2002 6:27 PM
  Subject: RE: [Megaco] Statistics and Move

  Frankly, I think anyone who does Move to Null rather than Subtract is
asking for

  Brian
    -----Original Message-----
    From: Christer Holmberg [mailto:[email-masked]]
    Sent: Tuesday, March 12, 2002 4:06 AM
    To: Terry L Anderson
    Cc: David Barr; 'Al Varney'; Megaco Mailing List
    Subject: Re: [Megaco] Statistics and Move

    Hi,

    Comments?

    Regards,

    Christer Holmberg
    Ericsson Finland

    Terry L Anderson wrote:

      Thanks for noticing this.  You are right.  We did fix the "call"
language during the editing session in Geneva and the change made it into V2
but failed to make it into the IG and get swept into V1 Amendment 1 (or
Corrigendum 1 whichever name sticks)
      What do folks think?  Do we need to fix the language in V1 as well
through an IG entry?

      But this still does not address the issue that referring to "Context"
here and in 7.1.15 makes it confusing that Move does not effect it.  Perhaps
language like:

      David Barr wrote:

        I've noticed that the reference to "the call" has been removed in
v2, look at section 6.2 in:

http://search.ietf.org/internet-drafts/draft-ietf-megaco-h248v2-01.txt
        It now says:
        "Statistics are reported ... when the Termination is subtracted from
a context."

        -----Original Message-----
        From: Al Varney [mailto:[email-masked]]
        Sent: Friday, March 08, 2002 12:10 AM
        To: Terry L Anderson
        Cc: Megaco Mailing List
        Subject: Re: [Megaco] Statistics and Move

        That still leaves the 6.2 ambiguity regarding "the call".  IMO the
concept
        of a call should not exist in H.248, other than perhaps in
        examples.  Asking an MG to understand how it is being used (as a
call
        controller vs. a fancy video server) requires a lot of guessing in
        implementations.  My (hypothetical) video server would never be
involved in
        "calls", but I need the statistics to bill hotel guests.

            Other than examples, glossary and other areas where the term
"call" is
        used descriptively, 6.2 appears to be the only area where a
"requirement"
        uses this term.  I suggest it be clarified.  Perhaps:

        Al Varney

        At 05:34 PM 3/7/02 -0500, Terry L Anderson wrote:
        >could not find the discussion.  I have no problem either way, I
just want it
        >to Context in the first sentence (and then need no changes to
language about
        >reporting or clearing).
        >
        >This adds to the distinction between Move and Subtract followed by
Add which

        > > > From: Terry L Anderson [mailto:[email-masked]]
        >

      --
      ------------------------------------------------------------
      Terry L Anderson             mailto:[email-masked]
      Tel:908.582.7013   Fax:908.582.6729
      Lucent Technologies/INS/Voice Over IP Access Networks
      Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
      http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: "Usha Iyer" <[email-masked]>
Date: Tue, 12 Mar 2002 19:05:25 +0530

Hi,

Reg,
usha
  ----- Original Message -----
  From: Rosen, Brian
  To: 'Christer Holmberg' ; Terry L Anderson
  Cc: David Barr ; 'Al Varney' ; Megaco Mailing List
  Sent: Tuesday, March 12, 2002 6:27 PM
  Subject: RE: [Megaco] Statistics and Move

  Brian
    -----Original Message-----
    From: Christer Holmberg [mailto:[email-masked]]
    Sent: Tuesday, March 12, 2002 4:06 AM
    To: Terry L Anderson
    Cc: David Barr; 'Al Varney'; Megaco Mailing List
    Subject: Re: [Megaco] Statistics and Move

    Hi,

    Comments?

    Regards,

    Christer Holmberg
    Ericsson Finland

    Terry L Anderson wrote:

      David Barr wrote:

        -----Original Message-----
        From: Al Varney [mailto:[email-masked]]
        Sent: Friday, March 08, 2002 12:10 AM
        To: Terry L Anderson
        Cc: Megaco Mailing List
        Subject: Re: [Megaco] Statistics and Move

        Al Varney

just want it
language about
Add which