Subject: [Megaco] Provisional response frequency

From: Sarika Gupta <[email-masked]>
Date: Sat, 16 Mar 2002 09:15:03 +0000 (GMT)

Hi list
What is the optimized frequency of Provisional
response (Transaction Pending)? I mean the standard
says the provisional response should be sent only when
a duplicate transaction request is received for a
transaction that is still under processing. It should
be just this or should the entity receiving the
request should send provisional responses in between
requests also ie after the expiry of some provisional
timer.
If the later is true then should the requesting side
entertain the provisional responses even after its
retries expires? Assuming the retries/timer values are
lesser on the requesting side.

Regards
Sarika

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sat, 16 Mar 2002 11:45:23 -0500

We added a bunch of material in H.248v2 that makes this clearer.  See
updated section 8.2.3.

-----Original Message-----
From: Sarika Gupta [mailto:[email-masked]]
Sent: Saturday, March 16, 2002 3:15 AM
To: [email-masked]
Subject: [Megaco] Provisional response frequency

Hi list

Regards
Sarika

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sat, 16 Mar 2002 11:45:23 -0500

-----Original Message-----
From: Sarika Gupta [mailto:[email-masked]]
Sent: Saturday, March 16, 2002 3:15 AM
To: [email-masked]
Subject: [Megaco] Provisional response frequency

Hi list

Regards
Sarika

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 18 Mar 2002 14:37:27 -0500

The text says:
   Executing some transactions may require a long time. Long execution
   times may interact with the timer based retransmission procedure.
   This may result either in an inordinate number of retransmissions,
   or in timer values that become too long to be efficient. Entities
   that can predict that a transaction will require a long execution
   time may send a provisional response, "Transaction Pending".  They
   SHOULD send this response if they receive a repetition of a
   transaction that is still being executed.

There are TWO conditions when you send a pend.  One is if you get
a repeat of the request before you send a reply.
The other is you send a pend when execution of the command
takes longer than normalMGExecutionTime/normalMGGExecutionTime, or
it's own estimation of the retransmission interval.

Lets say that normalMGExecutionTime is 10ms.  Suppose a command
is sent to the MG that may take 100ms to execute.  Then
roughly every 10 ms, the MG sends Pend.  You don't have to
know in advance how long it will take, in the example, you
simply send Pend every 10 ms until the command execution
finishes.  This means the last interval from pend to
actual reply will be less than 10 ms.

Brian

> Sent: Saturday, March 16, 2002 4:15 AM
> To: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 18 Mar 2002 14:37:27 -0500

The text says:

Brian