Subject: RE: [Megaco] Sending wildcard response in Audit commands

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 15 Mar 2002 14:51:40 -0500

It can be useful to determine the range of options supported.  It would make
more sense with AuditCapability that AuditValue for that reason. 

-----Original Message-----
From: SHRI KUMAR [mailto:[email-masked]]
Sent: Friday, March 15, 2002 11:14 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Sending wildcard response in Audit commands

Hi Tom/ List

I have a question about the very sanctity of
wildcarded responses. The RFC says about the wildcard
responses:
"This convention may reduce the volume of data
required to audit a group of terminations".
But, it seems the UNION of the responses for
individual terminations would change the semantics of
the information in audit responses...by de-linking it
from individual terminations and linking it to a
wildcarded
term name. Can somebody identify what use is this
information to an MGC ?

What does a MGC do with a wildcarded UNION response
like:
Context = *{
   AuditValue = T*{ 
      Media{ 
         Stream= 1{ 
            LocalControl{ p1=a, p2=b,c, p3=d }
         }
      }
   }
}
or
Context = *{
   AuditValue = T*{ 
      Media{ 
         Stream= 1{ 
            LocalControl{ p1=a, p2=b }
         }
      },
      Media{ 
         Stream= 1{ 
            LocalControl{ p2=c, p3=d }
         }
      }
   }
}

The MGC will ultimately need to know:
Context = *{
   AuditValue = Ta{ 
      Media{ 
         Stream= 1{ 
            LocalControl{ p1=a, p2=b }
         }
      },
   AuditValue = Tb{ 
      Media{ 
         Stream= 1{ 
            LocalControl{ p2=c, p3=d }
         }
      }
   }
}
unless we have a situation where, both Ta and Tb have
only p1=a and p2=b and the response is:
Context = *{
   AuditValue = T*{ 
      Media{ 
         Stream= 1{ 
            LocalControl{ p1=a, p2=b }
         }
      }
   }
}

Except for this last special situation where all
descriptors with properties and property values are
similar on all resolved terminations, I don't see any
value in sending a wild-carded response.

Rgds,
Manikaran

Tom P. Taylor wrote....
>OK, let's clean this one up.  Currently the one
>example shown in the text
>(section 7.2.5) is this:
>
>  "The command:
>         Context=*{W-AuditValue=t1/*{Audit{Packages}}
>   Returns:
        
>Context=*{W-AuditValue=t1/*{Packages{aaa,bbb}}"

>where t1/1 and t1/2 both support the two packages
>shown.

>Unfortunately this doesn't resolve the question of
>whether aggregation is at
>the atomic level, since both terminations would give
>the same result.
>Similarly, section 6.2.2 is ambiguous, because it is
>too abstract:

>"If individual responses are not required, a wildcard
>response may be
>requested.  In such a case, a single response is
>generated, which contains
>the UNION of all of the individual responses which
>otherwise would have been
>generated, with duplicate values suppressed.    For
>instance, given a
>Termination Ta with properties p1=a, p2=b and
>Termination Tb with properties
>p2=c, p3=d, a UNION response would consist of a
>wildcarded TerminationId and
>the sequence of properties p1=a, p2=b,c and p3=d. 
>Wildcard response may be
>particularly useful in the Audit commands."

>On a close reading of this last, however, I am
>inclined to believe that it
>is the descriptors which are repeated.  The phrase
>"UNION of all the
>individual responses" suggests a logical operation on
>fully-formed responses
>rather than something done by disassembling and
>reassembling them.  In other
>words, I think I was wrong earlier.

>Other opinions?

________________________________________________________________________
Looking for a job?  Visit Yahoo! India Careers
      Visit http://in.careers.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: SHRI KUMAR <[email-masked]>
Date: Mon, 18 Mar 2002 08:37:53 +0000 (GMT)

Hello Tom

It would make "more" or "only" sense with Audit
capability. 
But, even with Audit Cap, I think MGC would like to
know the capabilities of each termination individually
or as a group (wildcarded) if the set of terminations
have similar capabilities.

Any comments....
 
Njoy

________________________________________________________________________
For live cricket scores download  Yahoo! Score Tracker
 at: http://in.sports.yahoo.com/cricket/tracker.html

---

From: SHRI KUMAR <[email-masked]>
Date: Mon, 18 Mar 2002 08:37:53 +0000 (GMT)

Hello Tom

Any comments....
 
Njoy

---

From: SHRI KUMAR <[email-masked]>
Date: Fri, 22 Mar 2002 08:05:03 +0000 (GMT)

Hi

Yet no reply on this one?
 --- SHRI KUMAR <[email-masked]> wrote: >
Hello Tom
> > more sense with AuditCapability that AuditValue
> for
> > that reason. 
> > 
> > >individual responses" suggests a logical
> operation
> > on
> > >fully-formed responses

---

From: SHRI KUMAR <[email-masked]>
Date: Fri, 22 Mar 2002 08:05:03 +0000 (GMT)

Hi