Subject: [Megaco] Re: Multiplixed termination

From: Y Hu <[email-masked]>
Date: Wed, 20 Mar 2002 14:17:11 -0800 (PST)

Hi,

I posted the following message last night, but did not
see on the list, sorry if it is duplicated.

In the multiplexed termination scenario, for example,
if H.245 is used for opening mux (located in MG)
logical channels, the MGC needs to tell MG to add MUX,
to open logical channels and to link mux and
terminations. Could anyone please clarify the
following questions:

1. Does the megaco maps H.245 commands such as open
logical channel into ADD termination command to the
MG? Or, the H.245 message is entirely carried by the
SCTP, the megaco does not involve to relay H.245
commands to the MGs?

2. If the megaco is used to translates H.245 message
to its commands, what megaco commands are used and
what descriptors are used to send mux parameters to
the MG? It seems that the muxDescriptor does not
contains any mux parameters except a
terminationIDList?

Thank you in advance.

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Y Hu <[email-masked]>
Date: Wed, 20 Mar 2002 14:17:11 -0800 (PST)

Hi,

Thank you in advance.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 21 Mar 2002 09:35:34 -0500

Hi.  Answers marked by [PTT].

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Wednesday, March 20, 2002 4:17 PM
To: [email-masked]
Subject: [Megaco] Re: Multiplixed termination

Hi,

[PTT]
This is done by the MGC.  If we are talking H.324, H.321, or H.310, the
H.245 will definitely pass through the MG.  It can go from there to the MGC
in two ways: as a media stream of type "control", or in the form of events,
where each event passes an H.245 PDU.  Annex M.4 defines such events IIRC.

[PTT]
See above.  The MGC is responsible for setting up everything, based on call
signalling to start with.

Thank you in advance.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 21 Mar 2002 09:35:34 -0500

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Wednesday, March 20, 2002 4:17 PM
To: [email-masked]
Subject: [Megaco] Re: Multiplixed termination

Hi,

[PTT]

[PTT]

Thank you in advance.

---

From: Y Hu <[email-masked]>
Date: Thu, 21 Mar 2002 16:19:46 -0800 (PST)

Thanks Tom.

> This is done by the MGC.  If we are talking H.324,
H.321, or H.310, the H.245 will 
> definitely pass through the MG.  It can go from
there to the MGC in two ways: as a 
> media stream of type "control", or in the form of
events, where each event passes 
> an H.245 PDU.  Annex M.4 defines such events IIRC.

Yes, event passes an H.245 PDU is what I am looking
for.  But, I am not clear which event does this
function in the Annex M.4. Are you talking about event
"Incoming H.245 Message"? It seems to me that the
event is for MG to detect the H245 message according
to the sublist of the H245 message type. And it does
not include H245 PDU encapsulation. 

I actually want the MGC to pass the H.245 PDU to the
MG and to require the MG taking action according to
the H.245 Command such as open logical channel. I've
looked at different events in Annex M.4, but I could
not figure out which one can be used to encapsulate
the H.245 PDU, please enlighten me.

Thank you.

Yude

At 09:35 AM 21/03/2002 -0500, Tom-PT Taylor wrote:

Hi, 

[PTT] 
This is done by the MGC.  If we are talking H.324,
H.321, or H.310, the H.245 will definitely pass
through the MG.  It can go from there to the MGC in
two ways: as a media stream of type "control", or in
the form of events, where each event passes an H.245
PDU.  Annex M.4 defines such events IIRC.

[PTT] 
See above.  The MGC is responsible for setting up
everything, based on call signalling to start with. 

Thank you in advance.

---

From: Y Hu <[email-masked]>
Date: Thu, 21 Mar 2002 16:19:46 -0800 (PST)

Thanks Tom.

Thank you.

Yude

Hi, 

[PTT] 

[PTT] 

Thank you in advance.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 22 Mar 2002 13:37:46 -0500

Theoretically you can do what you want by using the Annex C encapsulation of
H.245 OLC and passing it in Local and Remote.  If you go there, however, I'd
be surprised if anyone else followed.

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 6:20 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: Re: Multiplixed termination

Thanks Tom.

Thank you.

Yude

Hi, 

[PTT] 

[PTT] 

Thank you in advance.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 22 Mar 2002 13:37:46 -0500

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 6:20 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: Re: Multiplixed termination

Thanks Tom.

Thank you.

Yude

Hi, 

[PTT] 

[PTT] 

Thank you in advance.