Subject: [Megaco] WILD carded termination

From: "vidya g" <[email-masked]>
Date: 14 Mar 2002 05:00:49 -0000

hi all

     As per RFC, preparing wildcarded response is very mentioned 
with a trivial example.. where do I get more
information on how to prepare wild carded response.. ? or is it 
mandatory to prepare wild carded response if
wild carded response is mentioned in the request .. ?

regs
vdy

On Wed, 13 Mar 2002 Madhu Babu Brahmanapally wrote :
>Hi Vidya,
>"W-" is the option to be used for that.
>Regards
>Madhubabu
>
>-----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
>Behalf Of
>vidya g
>Sent: Wednesday, March 13, 2002 2:03 AM
>To: [email-masked]
>Subject: [Megaco] WILD carded termination
>
>
>Hi all
>
>    according to RFC, "If individual responses are not required, 
>a
>wildcard response may be requested."
>is mentioned. But how do we request for wildcarded response.. ?
>
>    regs
>vdy
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>---
>[This E-mail was scanned for viruses and is clean.]
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 14 Mar 2002 10:40:25 -0500

Well, it's up to the MG how it responds to a wildcard response, and it
would be legal, but ill advised to respond to it the same way you would
respond to a non-wildcarded command.

I would do something like the following:
	Enumerate the set of terminations covered by the command
	For each descriptor covered by the command
		For each potential item in the descriptor
			Determine the number of dissimilar values for each
of
			the terminations
		Emit one descriptor
			For each item that is expressed as a property=value,
				use the ALTERNATIVE construction to show all
				dissimilar values
			For each item that is a simple list, show all values
				in the list

Brian

> From: vidya g [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2002 11:59 PM
> To: Madhu Babu Brahmanapally
> Cc: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 14 Mar 2002 10:40:25 -0500

Brian