Subject: RE: [Megaco] questions about syntax error

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 6 Mar 2002 07:43:11 -0500

Hi.  Answers below.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, March 04, 2002 4:55 AM
To: [email-masked]
Subject: [Megaco] questions about syntax error

hi, list. 
consider the example message below. 
MEGACO/1 [125.125.125.111]:55555 
Transaction = 10000 { 
    Context - 5000 { 
        // syntax error in Action 
        Subtract= A4444 { 
             ... 
        } 
    }, 
    Context = 4900 { 
        Add=A5555 { 
            ... 
         } 
         Add=A7777 { 
           ... 
         } 
    } 
} 
In real application, I think this example maybe hardly happens. but anyway, 
in above case, shall the second action be processed by MG? or shall MG just
send TransactionReply 
with a error descriptor about the first action and do not precess the
second action? 

[PTT] The first error encounters stops the processing of the transaction.
You get the error descriptor for the first action and that is all.  See
section 8.2.2.

if error descriptor and action reply be sent at the same transaction reply, 
then ABNF grammer does not allow this. 
ABNF grammer reads 
" 
transactionReply=ReplyToken EQUAL TransactionID LBRKT 
                         [ImmAckRequiredToken COMMA] 
                         (errorDescriptor/actionReplyList) RBRKT 
" 
and the second example message below 
(it is originally come from Sundareswaram P V) 
case 1) 
MEGACO/1 [125.125.125.111]:55555 
Transaction = 50009 { 
   Context = 5000 { 
      Subtract = A5555 { 
         Statistics { 
            ........ 
         } 
       }, 
       abc = A5556 { 
                    // --- request type is corrupted 
                    // instead of subtract it become 'abc' 
               Statistics { 
                  ...... 
                    nt/os=62345, ; octets sent 
                    rtp/pr=780, ; packets received 
                    nt/or=45123, ; octets received 
               } 
           } 
        } 
 } 

[PTT] We modified the ABNF to accommodate this case.  actionReply is now
defined as

actionReply  = CtxToken EQUAL ContextID LBRKT 
               ( errorDescriptor / commandReply /
	           (commandReply COMMA errorDescriptor) ) RBRKT

case 2) 
MEGACO/1 [125.125.125.111]:55555 
Transaction = 50009 { 
   Context = 5000 { 
       abc = A5556 { 
                    // --- request type is corrupted 
                    // instead of subtract it become 'abc' 
               Statistics { 
                  ...... 
                    nt/os=62345, ; octets sent 
                    rtp/pr=780, ; packets received 
                    nt/or=45123, ; octets received 
               } 
           } 
        }, 
      Subtract = A5555 { 
         Statistics { 
            ........ 
         } 
       } 
 } 
In case 1, Can I think in following manner? 
        1) it is neeed to send both error descriptor and command reply, and 
        2) ABNF grammer will address this problem 
In case 2, as long as a parser can not determine the first command is
"optional", must not  the second command be processed by MG? and will a
error descriptor for the first command be placed in actionReply?
thanks in advance. 

[PTT] In the text encoding, an optional command is indicated by a preceding
"O-" tag.  If this tag is present AND the end of the faulty command can be
detected, then an error descriptor for the optional command plus a further
response for following commands should be sent.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Cristina Sanchez <[email-masked]>
Date: Thu, 07 Mar 2002 11:34:02 +0100

Hi.
A related question with an example taken from a real application.
Consider that Context 34 does not exist in an MG  and it receives the following
...
   Transaction=1 {
       Context= 34 {O-Substract = *},   ; Optional command
       Context= - {Modify=A5555{...}}
   }
Shall the second command be processed by the MG ?
What would be the Reply message ?

Regards,
Cristina

--
Cristina Sanchez Moreno.                Phone   : +341 330 8290
Alcatel SRD Wireline Systems            Alcanet :     2414 8290

---

From: Cristina Sanchez <[email-masked]>
Date: Thu, 07 Mar 2002 11:34:02 +0100

Hi.

Regards,
Cristina