Subject: [Megaco] Event Processing concerns

From: "Singh, Subhash" <[email-masked]>
Date: Tue, 5 Mar 2002 14:57:20 -0800

Hi All,
After review the Event handling procedure in RFC I am not clear about the
embedded event handling  method .

RFC says 
"If the value of the EventBufferControl property equals LockStep, following
detection of such an event, normal handling of events is suspended. Any
event which is subsequently detected and occurs in the EventBuffer
Descriptor is added to the end of the EventBuffer (a FIFO queue), along with
the time that it was detected.   The MG SHALL wait for a new
EventsDescriptor to be loaded.  A new EventsDescriptor can be loaded either
as the result of receiving a command with a new EventsDescriptor, or by
activating an embedded EventsDescriptor."

My concerns  are : 

1)If an event is observed  when LockStep is set  and event  is found in
EventBuffer Descriptor , then will it be put in  EventBuffer or it will be
handled as per the currently active Event Descriptor and subsequent  event
will be  buffered.. If it is processed  , then what does "normal handling of
events is suspended "  implies ??
  
2) As per the specification when LockStep is set , normal handling of event
is suspended . If this Event Descriptor  have an Embedded Event descriptor
then how will that be activated , when an event is observed . ( as this
event buffer descriptor has been suspended  ) 

Regards,
Subhash

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Singh, Subhash" <[email-masked]>
Date: Wed, 6 Mar 2002 10:56:30 -0800

Hi,

It appear from the following explanation that event is always processed as
per the current Event descriptor (immaterial weather EventBufferControl is
OFF or LOCKSTEP) , and if event is not found in Current descriptor or if it
does not have EmbeddedEvent Descriptor then only it is processed according
to EvevtBuffer descriptor. 

Is this accurate ?

Regards,
Subhash

 -----Original Message-----
From: 	Giri Rajasekhar Saladi [mailto:[email-masked]] 
Sent:	Tuesday, March 05, 2002 9:15 PM
To:	Singh, Subhash
Cc:	[email-masked]'
Subject:	Re: [Megaco] Event Processing concerns

Hi Subhash,
	You may follow (a), (b) and (c) for your concern 1 and (d)
for your concern 2

(a) When EventBufferControl is LockStep, and an event is detected,
the current EventsDescriptor is no longer active.

(b) EventsDescriptor becomes active with one of the following
1) On receiving a new EventsDescriptor from MGC or
2) the event detected above has an EmbeddedEventsDescriptor, which
replaces the current EventsDescriptor

(c) During this interval between above (a) and (b), enters a state
say buffering where "normal handling of events is suspended". In
this, the events are matched against EventBufferDescriptor rather
than the usual EventsDescriptor and the event will be added to the
end of the EventBuffer (a FIFO queue), along with the time that it
was detected instead of sending a Notification to MGC.

(d) Activating an EmbededEventsDescriptor can be well explained with
the following example.
This is independent of EventBufferControl being either OFF or LOCKSTEP.
Say X is the current EventsDescriptor, with a and b as events.
    P is the EmbeddedEventsDescriptor inside event a
    Q is the EmbeddedEventsDescriptor inside event b
X = {a, b}
a = {P}
b = {Q}
P = {u, v}
Q = {x, y, z}
case 1: If event 'a' has occured,
        then 'a' is notified and current eventsDescriptor is replaced with
P.
        Now if event 'u' or 'v' occurs, then it is notified to MGC else any
        other event is discarded.
case 2: If event 'b' has occured,
        then 'b' is notified and current eventsDescriptor is replaced with
Q.
        Now if event 'x', 'y' or 'z' occurs, then it is notified to MGC else
        any other event is discarded.
Hope this answers your questions.
Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>