Subject: [Megaco] question about 'Z' in DigitMap

From: "toni.yang" <[email-masked]>
Date: Thu, 7 Mar 2002 17:33:53 +0800

hi, Kevin J. Boyle,
This is a question about 'Z' duration modifier in digitmap.
Suppose I have collected 1011 so far.
My two possible patterns at this point are "1011Zxx" and "10116x". The
differentiator is that fifth position:

I used to think that MG at this point start two timers. 
One is Long Timer(16s), the other is new Long Timer(16s longer).
While MG received "6" before Long Timer's expiration, the second pattern is
the one I shall keep. 
Whild MG received "6" before new Long Timer's expiration, the first pattern
is the one I shall keep.
If MG is the way, how long is the new Long Timer ?

Once MG received "1" before Long Timer's expiration, MG shall notify MGC
with "10111 PM".Is that so?

Thanx and Best Regards
Toni Yang

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 7 Mar 2002 16:01:26 +0530

Hi Toni,
My comments are inline and marked with AS>>>

Thanks
Ashish Singh

"toni.yang" <[email-masked]> on 03/07/2002 03:03:53 PM

To:   [email-masked]
cc:   "[email-masked]" <[email-masked]> (bcc: Ashish Singh/HSS)

Subject:  [Megaco] question about 'Z' in DigitMap

hi, Kevin J. Boyle,

AS>>>The role of Z is different than other timers.  All of the other timers are
concerned about the interval between tones.
But Z is concerned with the duration of the tone itself. That means that there
is no need to start two timers.
Only Normal LOng timer will be started.

AS>>> If Short 6 (i.e. 6 is not a long event) is reported before Long timer
expiry, then one shall keep second pattern.

AS>>> If Long 6 (i.e. 6 is a long event) is reported before Long timer expiry,
then one shall keep first pattern.

AS>>> In this case, Dial String "1011" with Method PM should be reported. and
the last event "1" will be reported according to active event descriptor.

Thanx and Best Regards
Toni Yang

---

From: [email-masked]
Date: Thu, 7 Mar 2002 16:01:26 +0530

Hi Toni,

Thanks
Ashish Singh

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 7 Mar 2002 10:49:08 -0500

Ashish's comments are correct.  Z is the long DURATION timer, so the length
of the detected digit is the crucial information for matching in that case.

As for your one unanswered question below, the length of the Z timer is
dependent upon several things, including what applications the MG is
intended to fulfill, and the reason digits are being collected.  It should
be provisioned on the MG.  In version 2, it can be dynamically assigned per
digitmap, just like the other timers.

Also, Annex M.edd provides a method for returning the mismatched digit with
the returned digitstring, if you need it for generating partial dial logs,
billing records, etc.  This means that with the annex, it is possible that
the MG would NOT process the mismatched digit according to the current
Events descriptor.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 5:31 AM
To: toni.yang
Cc: Boyle, Kevin [NCRTP:3Z30:EXCH]; [email-masked]
Subject: Re: [Megaco] question about 'Z' in DigitMap

Hi Toni,

Thanks
Ashish Singh

hi, Kevin J. Boyle,

AS>>>The role of Z is different than other timers.  All of the other timers
are
concerned about the interval between tones.
But Z is concerned with the duration of the tone itself. That means that
there
is no need to start two timers.
Only Normal LOng timer will be started.

AS>>> If Long 6 (i.e. 6 is a long event) is reported before Long timer
expiry,
then one shall keep first pattern.

AS>>> In this case, Dial String "1011" with Method PM should be reported.
and
the last event "1" will be reported according to active event descriptor.

Thanx and Best Regards
Toni Yang

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 7 Mar 2002 10:49:08 -0500

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 5:31 AM
To: toni.yang
Cc: Boyle, Kevin [NCRTP:3Z30:EXCH]; [email-masked]
Subject: Re: [Megaco] question about 'Z' in DigitMap

Hi Toni,

Thanks
Ashish Singh

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 7 Mar 2002 21:43:26 -0500

'Z' is about the duration of the tone, not the duration of the interval
between tones.  So when the "6" tone starts, a timer is started.  When the
"6" tone stops, the duration timer is stopped.  If the duration exceeded the
long tone threshold (e.g. 1 second), the first pattern is considered to be
matched, otherwise, the second pattern.

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 4:34 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: [Megaco] question about 'Z' in DigitMap

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 7 Mar 2002 21:43:26 -0500

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 4:34 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: [Megaco] question about 'Z' in DigitMap

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 11 Mar 2002 09:41:46 -0500

The user produces a long tone by holding down the key/button longer than the
threshold period of time.  The reason for using this capability is to
resolve the ambiguity between DTMF tone signalling the user provides to
communicate with something like IVR at the far end, and DTMF tone signalling
meant to be acted on by the network (for example, to originate a new call
using credit card information previously entered).  Typically toll provider
network equipment will listen for something like a long "#" to provide the
latter service.

And I don't know if you realize it, but "Better give me an example" is
phrased as if you were my master giving me orders.  A "Please" would soften
the effect.

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Monday, March 11, 2002 1:02 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Subject: RE: [Megaco] question about 'Z' in DigitMap

hi, Tom-PT Taylor,
I got a new question.
How to produce a long tone "6"?
What is the purpose of a long tone?
Better show me an example.

Best Regards
Toni Yang

-------Original Message-------

From: Tom-PT Taylor
Date: 2002Äê03ÔÂ08ÈÕ 10:46:10
To: 'toni.yang'
Cc: [email-masked]
Subject: RE: [Megaco] question about 'Z' in DigitMap

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 4:34 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: [Megaco] question about 'Z' in DigitMap

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang

 .

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 11 Mar 2002 09:41:46 -0500

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Monday, March 11, 2002 1:02 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Subject: RE: [Megaco] question about 'Z' in DigitMap

hi, Tom-PT Taylor,
I got a new question.

Best Regards
Toni Yang

-------Original Message-------

From: Tom-PT Taylor

-----Original Message-----
From: toni.yang [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 4:34 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: [Megaco] question about 'Z' in DigitMap

hi, Kevin J. Boyle,

Thanx and Best Regards
Toni Yang