Subject: [Megaco] HOW to get package name

From: "vidya g" <[email-masked]>
Date: 15 Mar 2002 06:24:19 -0000

Hi all

     In AmmsDescriptor, if I am getting signal descriptor, I have 
to apply those signals to the
packages in my termination. But from signal how do I map to 
package or in other words, how do I get package name
based on signal name .. ?

vdy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 15 Mar 2002 08:38:25 -0500

I'm confused by your question, but in any place you name a signal,
you use the package name/signal name syntax.

So Add=foo{Signals{pkg1/sig1, pkg2/sig2}}

Brian

> -----Original Message-----
> From: vidya g [mailto:[email-masked]]
> Sent: Friday, March 15, 2002 1:24 AM
> To: [email-masked]
> Cc: Madhu Babu Brahmanapally
> Subject: [Megaco] HOW to get package name
> 
> 
> Hi all
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 15 Mar 2002 08:38:25 -0500

Brian

---

From: "vidya g" <[email-masked]>
Date: 15 Mar 2002 14:25:36 -0000

Hi

   I am sorry for not making the question clear.  SignalDescriptor 
data structure is given below

typedef struct SignalsDescriptor {
     unsigned int    count;
     struct SignalRequest *value;
} SignalsDescriptor;

typedef struct SignalRequest {
     unsigned short  choice;
#       define      signal_chosen 1
#       define      seqSigList_chosen 2
     union {
         Signal          signal;  /* to choose, set choice to 
signal_chosen */
         SeqSigList      seqSigList;  /* to choose, set choice 
to
                                       * seqSigList_chosen */
     } u;
} SignalRequest;

typedef struct Signal {
     unsigned char   bit_mask;
#       define      Signal_streamID_present 0x80
#       define      sigType_present 0x40
#       define      duration_present 0x20
#       define      notifyCompletion_present 0x10
#       define      Signal_keepActive_present 0x08
     SignalName      signalName;
     StreamID        streamID;  /* optional; set in bit_mask
                                 * Signal_streamID_present if 
present */
     SignalType      sigType;  /* optional; set in bit_mask 
sigType_present if
                                * present */
     unsigned short  duration;  /* optional; set in bit_mask 
duration_present if
                                 * present */
     NotifyCompletion notifyCompletion;  /* optional; set in 
bit_mask
                                          * 
notifyCompletion_present if
                                          * present */
     ossBoolean      keepActive;  /* optional; set in bit_mask
                                   * Signal_keepActive_present if 
present */
     struct {
         unsigned int    count;
         struct SigParameter *value;
     } sigParList;
} Signal

    In this I will be getting only SignalName which is defined 
below..

typedef PkgdName        SignalName;

typedef struct PkgdName {
     unsigned short  length;
     unsigned char   value[4];
} PkgdName;

   here I am getting only 4 bytes values for one signal component. 
I feel it is nothing but signalID .. from
this if I wanted to map the package how do I do that ..? If no 
signalIDs are duplicated in packages, I can search
in the packages and get the corresponding package to set the 
signal. But I am not able to find the provision for the puting 
packageId and signalId .. that is my confusion ...

    one more thing is What is this secondEventsDescriptor stands 
for .. ? what is the phisical meaning of that in hardware .. ?

regs
vdy

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 15 Mar 2002 17:11:06 -0500

I looked at the results and think they primary one - BER is faster
is invalid.

Basically, they attempt to compare one implementation's binary
with another implementation's text.  That isn't valid.

The erlang.org results are more meaningfull, since they compare
two encodings from the same implementation.

If the OSS Nokalva folks put as much effort into a text encode/decode
as they did the BER tools, then I believe they would find what 
erlang.org did, but that is speculation.  Of course they claim that's
the problem with the erlang code!

They also appear to agree that BER is bigger.

Of course, none of this matters, as encode/decode time is a pretty
small fraction of execution time on either MG or MGC, and size of
message isn't different enough to matter.

Brian

> From: Paul Long [mailto:[email-masked]]
> Sent: Friday, March 15, 2002 1:33 PM
> To: [email-masked]
> Subject: RE: [Megaco] HOW to get package name
> 
> 
> Brian,
> 
> I agree with what you say about the number of binary versus 
> text Megaco
> implementations, but--since you brought it up first--I 
> disagree with your
> assessment of binary-versus-text in general and specifically 
> Megaco BER vs
> text. Check out this recent comparison:
> http://www.asn1.org/benchmark/benchmark1.htm
> 
> Paul Long
> ipDialog, Inc.
> 
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Rosen, Brian
> > Sent: Friday, March 15, 2002 9:15 AM
> > To: 'Madhu Babu Brahmanapally'; 'vidya g'
> > Cc: [email-masked]
> > Subject: RE: SPAM: Re: RE: [Megaco] HOW to get package name
> >
> >
> > And please remember that most Megaco implementations are text only,
> > with a very small number both text and binary, and none that I know
> > of that are binary only.  Making a binary-only implementation might
> > lead you into a very small number of compatible implementations.
> >
> > Megaco binary implementations have been shown to be slower and
> > to produce larger messages than text implementations.
> >
> > Brian
> 
>