Subject: RE: [Megaco] HOW to get package name

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 15 Mar 2002 17:11:06 -0500

I looked at the results and think they primary one - BER is faster
is invalid.

Basically, they attempt to compare one implementation's binary
with another implementation's text.  That isn't valid.

The erlang.org results are more meaningfull, since they compare
two encodings from the same implementation.

If the OSS Nokalva folks put as much effort into a text encode/decode
as they did the BER tools, then I believe they would find what 
erlang.org did, but that is speculation.  Of course they claim that's
the problem with the erlang code!

They also appear to agree that BER is bigger.

Of course, none of this matters, as encode/decode time is a pretty
small fraction of execution time on either MG or MGC, and size of
message isn't different enough to matter.

Brian

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Friday, March 15, 2002 1:33 PM
> To: [email-masked]
> Subject: RE: [Megaco] HOW to get package name
> 
> 
> Brian,
> 
> I agree with what you say about the number of binary versus 
> text Megaco
> implementations, but--since you brought it up first--I 
> disagree with your
> assessment of binary-versus-text in general and specifically 
> Megaco BER vs
> text. Check out this recent comparison:
> http://www.asn1.org/benchmark/benchmark1.htm
> 
> Paul Long
> ipDialog, Inc.
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Rosen, Brian
> > Sent: Friday, March 15, 2002 9:15 AM
> > To: 'Madhu Babu Brahmanapally'; 'vidya g'
> > Cc: [email-masked]
> > Subject: RE: SPAM: Re: RE: [Megaco] HOW to get package name
> >
> >
> > And please remember that most Megaco implementations are text only,
> > with a very small number both text and binary, and none that I know
> > of that are binary only.  Making a binary-only implementation might
> > lead you into a very small number of compatible implementations.
> >
> > Megaco binary implementations have been shown to be slower and
> > to produce larger messages than text implementations.
> >
> > Brian
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Paul Long" <[email-masked]>
Date: Sat, 16 Mar 2002 15:00:00 -0600

Brian,

Very good point. I agree that OSS's BER implementation may have just been
optimized better than Erlang's text implementation. But it is equally
possible that the opposite is true--that Erlang's text is more optimized
than OSS's BER, and the latter still came out ahead. Also, just because
Erlang implemented both their text and BER codecs does not mean that their
codecs are somehow equivalent, e.g., equally optimized. As they themselves
say, other implementations may obtain different results, so Erlang's results
are no more meaningful than OSS's.

Yes, BER is big, but it is perhaps the worst possible choice for a binary
encoding. I think it was Bancroft Scott that said many years ago on the
ASN.1 reflector (way before Megaco) that BER should never be used for new
standards. BER was the first set of encoding rules developed for ASN.1, and
subsequent encoding rules, e.g., DER and PER, should be used instead. I wish
this advice had made it into the decision-making process for Megaco, but it
is of course too late now.

If "none of this matters," why did you raise the issue in the first place?
Seems like at one time LOTS of folks thought that this mattered a great
deal. I think many still do.

As it stands, binary codecs have been shown to be faster than text codecs.
The Megaco test suite and protocol are freely available. If someone thinks
that a text codec is faster, let them perform the same tests and publish the
results.

Paul Long
ipDialog, Inc.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Rosen, Brian
> Sent: Friday, March 15, 2002 4:11 PM
> To: 'Paul Long'; [email-masked]

---

From: "Paul Long" <[email-masked]>
Date: Sat, 16 Mar 2002 15:00:00 -0600

Brian,

Paul Long
ipDialog, Inc.