Subject: RE: [Megaco] what is the meaning of Reserve Value and Reserve Gro up

From: [email-masked]
Date: Fri, 22 Mar 2002 13:43:40 +0530

Hi Tom

I couldn't find this restriction mentioned in RFC or the IG.
Could you give a pointer to this restriction in v1(RFC3105) or the related IG ?

Regards,
Kapil Nayar
Hughes Software Systems Ltd.
http://www.hssworld.com

"Tom-PT Taylor" <[email-masked]> on 03/19/2002 12:28:19 AM

To:   Kapil Nayar/HSS@HSS
cc:   "'Zhang, Yuyong'" <[email-masked]>, "'Christian Groves'"
      <[email-masked]>, John Joseph Chooracken
      <[email-masked]>, "[email-masked]'" <[email-masked]>

Subject:  RE: [Megaco] what is the meaning of Reserve Value and Reserve Gro  up

Hi.  Your first sentence is correct.  And in Geneva we retained the
restriction that a single session description can contain only one m= line.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, March 18, 2002 2:11 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: 'Zhang, Yuyong'; 'Christian Groves'; John Joseph Chooracken;
[email-masked]'
Subject: RE: [Megaco] what is the meaning of Reserve Value and Reserve
Gro up

Hi Tom

Does that mean that Reserve Group has no meaning, when a single session
descriptor is being used. Or can it be applicable to multiple media
descriptor (m= fields) in a single session descriptor in this case.

Thanks,
Kapil Nayar
Hughes Software Systems Ltd.
http://www.hssworld.com

"Tom-PT Taylor" <[email-masked]> on 03/16/2002 04:17:53 AM

To:   "'Zhang, Yuyong'" <[email-masked]>, "'Christian Groves'"
      <[email-masked]>, John Joseph Chooracken
      <[email-masked]>
cc:   "[email-masked]'" <[email-masked]> (bcc: Kapil Nayar/HSS)

Subject:  RE: [Megaco] what is the meaning of Reserve Value and Reserve Gro
up

A group is equivalent to a session description (i.e. the v=0 line and what
follows).  So ReserveGroup indicates whether to choose and reserve resources
for one of a set of session descriptions, or to reserve resources for all of
them.  Within each, ReserveValue indicates whether to choose and reserve one
of a set of alternative values (particularly codecs) or to be prepared to
handle all of the presented values.  Christian's examples below translate
into

Case 1:

Local={
v=0
o=...
s=...
c=IP IP4 ...
m=audio ? rtp/avp 96
a=rtpmap: 96 AMR
[see draft-ietf-avt-rtp-amr-13.txt]
v=0
o=...
s=...
c=ATM ...
m=audio ? AAL1/ATMF 0
[see RFC 3108]
etc.
}

ReserveGroup=true would cause resources to be reserved for both AMR over IP
and PCM mu-law over AAL1.  ReserveGroup=false would cause the MG to choose
one of these two possibilities, with the first being preferred.

Case 2:

Local={
v=0
o=...
s=...
c=ATM ...
m=audio ? AAL1/ATMF 96 97
a=atmmap: 96 AMR
a=atmmap: 97 PCMU
[references as above]
etc.
}

ReserveValue=true would cause resources to be reserved to support both AMR
and PCM mu-law over AAL1.  ReserveValue=false would cause resources to be
reserved for just one of these possibilities, with AMR preferred.

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Friday, March 15, 2002 2:38 PM
To: 'Christian Groves'; John Joseph Chooracken
Cc: [email-masked]'
Subject: RE: [Megaco] what is the meaning of Reserve Value and Reserve
Gro up

Hi Christian, all

How the Group information are represented in the SDP? Please give a example
in SDP syntax about the usage of Group (the c-line, m-line, a-line
combination.

Regards,

Yuyong

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 4:22 PM
To: John Joseph Chooracken
Cc: [email-masked]'
Subject: Re: [Megaco] what is the meaning of Reserve Value and Reserve
Group

Hello John,

Reserve Group allows you to reserve resources for different sets of a
number of properties/SDP lines. eg.
Group ID 1
     pkg1/codec = AMR
     pkg2/transport = IP
Group ID 2
     pkg1/codec = G711
     pkg2/transport = ATM

Whereas reserve value only reserves values for single properties. eg.
     pkg1/codec = AMR, G711
     pkg2/transport = ATM

Regards, Christian

John Joseph Chooracken wrote:
>
> Hi ,
>
>    Please tell me  what is the difference between Reserve Value and
Reserve
> Group in Local Control Descriptor.
>
> Thanx in advance.
>
> Regards,
> John
> "Scientists study the world as it is, engineers create the world that
never
> has been. "
> -- Theodore Von Karman
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 22 Mar 2002 10:55:55 -0500

This restriction was added as IG item 6.98 after an email discussing in Sep 2001.
It appeared in the draft submitted to the Dublin (Oct 2001) meeting, but all such
changes were swept into the new H.248v1 Amendment 1 consented at Geneva Feb, 2002
and H.248V2 consented at the same meeting (it appears in 7.1.8).  Because these
were swept into the full versions (and approved there) it never appeared in an
offically approved version of the IG.  The consented text of H.248v2 was issued by
Tom as draft-ietf-megaco-h248v2-01.txt

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:732.949.5628   Fax:732.949.7016
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 22 Mar 2002 10:55:55 -0500

--