Subject: RE: [Megaco] Sending wildcard response in Audit commands

From: SHRI KUMAR <[email-masked]>
Date: Sat, 23 Mar 2002 18:05:04 +0000 (GMT)

Hi Kevin

That is exactly what I wanted to know. Is there
somebody on the MGC side who finds worth in the
wildcard responses.

Well at least the more experienced on the list should
be able to reply about the reasons for providing a
feature. At least one typical case where the wildcard
response is sufficient and the MGC wouldn't need to
know individual responses. At least we haven't seen
anything supporting this even at the MEGACO interops.

THis is important from the MG developer's point of
view. Handling wildcard terminations is already a
complex note, extending such a feature would be more
complex, but is it worth adding this to MG. 

Thanks in adv if you can help..
-SHRI KUMAR

 --- Kevin Boyle <[email-masked]> wrote: >
It largely depends on your particular
> implementation, and the function in
> question, whether getting individual responses is
> required, or if the
> wildcard response is sufficient.
> 
> Kevin
> 
> -----Original Message-----
> From: SHRI KUMAR [mailto:[email-masked]]
> Sent: Friday, March 22, 2002 3:05 AM
> To: SHRI KUMAR; Taylor, Tom-PT [CAR:B800:EXCH]
> Cc: [email-masked]
> Subject: RE: [Megaco] Sending wildcard response in
> Audit commands
> 
> 
> Hi
> 
> Yet no reply on this one?
>  --- SHRI KUMAR <[email-masked]> wrote: >
> Hello Tom
> > 
> > It would make "more" or "only" sense with Audit
> > capability. 
> > But, even with Audit Cap, I think MGC would like
> to
> > know the capabilities of each termination
> > individually
> > or as a group (wildcarded) if the set of
> > terminations
> > have similar capabilities.
> > 
> > Any comments....
> >  
> > Njoy
> > 
> >  --- Tom-PT Taylor <[email-masked]>
> > wrote:
> > > 
> > > It can be useful to determine the range of
> options
> > > supported.  It would make
> > > more sense with AuditCapability that AuditValue
> > for
> > > that reason. 
> > > 
> > > -----Original Message-----
> > > From: SHRI KUMAR
> > [mailto:[email-masked]]
> > > Sent: Friday, March 15, 2002 11:14 AM
> > > To: Taylor, Tom-PT [CAR:B800:EXCH]
> > > Cc: [email-masked]
> > > Subject: RE: [Megaco] Sending wildcard response
> in
> > > Audit commands
> > > 
> > > 
> > > Hi Tom/ List
> > > 
> > > I have a question about the very sanctity of
> > > wildcarded responses. The RFC says about the
> > > wildcard
> > > responses:
> > > "This convention may reduce the volume of data
> > > required to audit a group of terminations".
> > > But, it seems the UNION of the responses for
> > > individual terminations would change the
> semantics
> > > of
> > > the information in audit responses...by
> de-linking
> > > it
> > > from individual terminations and linking it to a
> > > wildcarded
> > > term name. Can somebody identify what use is
> this
> > > information to an MGC ?
> > > 
> > > What does a MGC do with a wildcarded UNION
> > response
> > > like:
> > > Context = *{
> > >    AuditValue = T*{ 
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p1=a, p2=b,c, p3=d }
> > >          }
> > >       }
> > >    }
> > > }
> > > or
> > > Context = *{
> > >    AuditValue = T*{ 
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p1=a, p2=b }
> > >          }
> > >       },
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p2=c, p3=d }
> > >          }
> > >       }
> > >    }
> > > }
> > > 
> > > The MGC will ultimately need to know:
> > > Context = *{
> > >    AuditValue = Ta{ 
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p1=a, p2=b }
> > >          }
> > >       },
> > >    AuditValue = Tb{ 
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p2=c, p3=d }
> > >          }
> > >       }
> > >    }
> > > }
> > > unless we have a situation where, both Ta and Tb
> > > have
> > > only p1=a and p2=b and the response is:
> > > Context = *{
> > >    AuditValue = T*{ 
> > >       Media{ 
> > >          Stream= 1{ 
> > >             LocalControl{ p1=a, p2=b }
> > >          }
> > >       }
> > >    }
> > > }
> > > 
> > > Except for this last special situation where all
> > > descriptors with properties and property values
> > are
> > > similar on all resolved terminations, I don't
> see
> > > any
> > > value in sending a wild-carded response.
> > > 
> > > Rgds,
> > > Manikaran
> > > 
> > > 
> > > Tom P. Taylor wrote....
> > > >OK, let's clean this one up.  Currently the one
> > > >example shown in the text
> > > >(section 7.2.5) is this:
> > > >
> > > >  "The command:
> > > >        
> > > Context=*{W-AuditValue=t1/*{Audit{Packages}}
> > > >   Returns:
> > >         
> > > >Context=*{W-AuditValue=t1/*{Packages{aaa,bbb}}"
> > > 
> > > >where t1/1 and t1/2 both support the two
> packages
> > > >shown.
> > > 
> > > >Unfortunately this doesn't resolve the question
> > of
> > > >whether aggregation is at
> > > >the atomic level, since both terminations would
> > > give
> > > >the same result.
> > > >Similarly, section 6.2.2 is ambiguous, because
> it
> > > is
> > > >too abstract:
> > > 
> > > >"If individual responses are not required, a
> > > wildcard
> > > >response may be
> > > >requested.  In such a case, a single response
> is
> > > >generated, which contains
> > > >the UNION of all of the individual responses
> > which
> > > >otherwise would have been
> > > >generated, with duplicate values suppressed.   
> > For
> > > >instance, given a
> > > >Termination Ta with properties p1=a, p2=b and
> > > >Termination Tb with properties
> > > >p2=c, p3=d, a UNION response would consist of a
> > > >wildcarded TerminationId and
> > > >the sequence of properties p1=a, p2=b,c and
> p3=d.
> > 
> > > >Wildcard response may be
> > > >particularly useful in the Audit commands."
> > > 
> > > >On a close reading of this last, however, I am
> > > >inclined to believe that it
> > > >is the descriptors which are repeated.  The
> > phrase
> 
=== message truncated === 

________________________________________________________________________
For live cricket scores download  Yahoo! Score Tracker
 at: http://in.sports.yahoo.com/cricket/tracker.html

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: SHRI KUMAR <[email-masked]>
Date: Sat, 23 Mar 2002 18:05:04 +0000 (GMT)

Hi Kevin