Subject: [Megaco] Interdigit Timing With DTMF Generation Package

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 15 Mar 2002 09:47:17 -0500

Is it the common understanding that with the DTMF tone generation package
(Annex E.5), the duration not only of the digit tone but of silence
following that tone is provisioned in the MG?  That is, if one uses the dg
signals to play a sequence of digits, e.g.

Signal{SignalList=1{dg/da,dg/d3,dg/d1,dg/d9,dg/d7,dg/dc}}

can one assume that there will be pauses between the digits, and the length
of those pauses is provisioned as part of the tone definition?

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Sun, 17 Mar 2002 11:46:10 +0200

I think this example helps a lot to clarify what Kevin has been saying about
brief signals.  Would it be accurate to say that both timeout and brief
signals have finite durations, the difference being that for a brief signal,
the duration is known only to the MG?

Raphael Tryster

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Friday, 15 March, 2002 4:47 PM
	To:	[email-masked]'
	Cc:	David Barr; Kevin Boyle
	Subject:	[Megaco] Interdigit Timing With DTMF Generation
Package

	Is it the common understanding that with the DTMF tone generation
package
	(Annex E.5), the duration not only of the digit tone but of silence
	following that tone is provisioned in the MG?  That is, if one uses
the dg
	signals to play a sequence of digits, e.g.

	can one assume that there will be pauses between the digits, and the
length
	of those pauses is provisioned as part of the tone definition?

	Tom Taylor

---

From: Raphael Tryster <[email-masked]>
Date: Sun, 17 Mar 2002 11:46:10 +0200

Raphael Tryster

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Friday, 15 March, 2002 4:47 PM
	To:	[email-masked]'
	Cc:	David Barr; Kevin Boyle
	Subject:	[Megaco] Interdigit Timing With DTMF Generation
Package

	Tom Taylor

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 18 Mar 2002 13:45:59 -0500

Yes, that is an accurate summation.

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Sunday, March 17, 2002 3:46 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Cc: Barr, David [HAL02:HF20:EXCH]; Boyle, Kevin [NCRTP:3Z30:EXCH]
Subject: RE: [Megaco] Interdigit Timing With DTMF Generation Package

Raphael Tryster

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 18 Mar 2002 13:45:59 -0500

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Sunday, March 17, 2002 3:46 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Cc: Barr, David [HAL02:HF20:EXCH]; Boyle, Kevin [NCRTP:3Z30:EXCH]
Subject: RE: [Megaco] Interdigit Timing With DTMF Generation Package

Raphael Tryster