Subject: RE: [Megaco] Statistics and Move

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 7 Mar 2002 17:22:03 -0500

Huh, I thought we had decided that they were NOT zeroed on
a MOVE which is why they aren't automatically reported.

Of course, if you want them, you just ask for them!

The language should, of course be specific about the issue.

To my way of thinking, MOVE does not zero statistics, you
don't get it automatically!

Brian

> -----Original Message-----
> From: Terry L Anderson [mailto:[email-masked]]
> Sent: Thursday, March 07, 2002 4:23 PM
> To: Megaco Mailing List
> Subject: [Megaco] Statistics and Move
> 
> 
> Statistics on a termination are defined in two ways:
> 1.     6.2 says:
>     "Statistics are reported...when the termination is taken 
> out of the
> call it is in."
> 
> 2.    7.1.15 says:
>     "The Statistics parameter provides information describing 
> the status
> and usage of a Termination during its existence with a specific
> Context."
> 
> I don't think a "call" is a well defined concept in H.248, but perhaps
> these two statements are consistent if we associate a "call" with a
> context.  The issue is, if a termination is Moved to a different
> termination, is it in the same call (one party is probably 
> the same but
> the other may not be)?  Or, more specifically are its statistics
> zero'ed.
> 
> Subtract clearly zeros them since ephemerals disappear and 
> physicals get
> default values when returned to NULL context, and we state this as the
> last sentence in 7.1.15.  The issue is for a Move.  We never clearly
> state this for Move, but from the current language defining what
> statistics mean, I assume that they ARE zero'ed.  It would 
> help if that
> last sentence in 7.1.15 included Move (or if they are NOT cleared, we
> state that).
> 
> We report statisics, by default, on a Subtract, but NOT on a Move.  So
> if statistics are zero'ed by the move, then one must remember to add a
> Statistics Descriptor to Move to get them where this is not 
> needed for a
> Subtract.  It would seem to be consistent we would have reported
> statistics by default on all commands that zero them rather 
> than only on
> Subtract.
> 
> --
> 
> ------------------------------------------------------------
> Terry L Anderson              mailto:[email-masked]
> Tel:908.582.7013   Fax:908.582.6729
> Lucent Technologies/INS/Voice Over IP Access Networks
> Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 07 Mar 2002 17:34:49 -0500

I thought this had been discussed before but nothing got added to IG and I
could not find the discussion.  I have no problem either way, I just want it
unambiguous and I am afraid the current document is ambiguous and probably
closer to implying zeroing because of the references to Context.  If we
agree with Brian then we should change the language in 7.1.15 to not refer
to Context in the first sentence (and then need no changes to language about
reporting or clearing).

This adds to the distinction between Move and Subtract followed by Add which
is not a bad thing.

--

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 07 Mar 2002 17:34:49 -0500

--

---

From: Al Varney <[email-masked]>
Date: Thu, 07 Mar 2002 18:10:01 -0600

That still leaves the 6.2 ambiguity regarding "the call".  IMO the concept 
of a call should not exist in H.248, other than perhaps in 
examples.  Asking an MG to understand how it is being used (as a call 
controller vs. a fancy video server) requires a lot of guessing in 
implementations.  My (hypothetical) video server would never be involved in 
"calls", but I need the statistics to bill hotel guests.

    Other than examples, glossary and other areas where the term "call" is 
used descriptively, 6.2 appears to be the only area where a "requirement" 
uses this term.  I suggest it be clarified.  Perhaps:

   "Statistics on a termination are automatically
    reported only when a termination is Subtracted
    from a context."

Al Varney

---

From: Al Varney <[email-masked]>
Date: Thu, 07 Mar 2002 18:10:01 -0600

Al Varney