Subject: [Megaco] Audit of Events

From: [email-masked]
Date: Tue, 28 May 2002 20:18:59 +0530

Hi List,

Suppose MGC sends 1st Modify Command to the Term T1 in NULL context.

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

Now MGC Sends 2nd Modify Command to the same Term T1 in NULL context.

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },
               Events = 2224 { cd/std { tl = * }  }
           }
       }
   }

Now there are two options for Events Descriptor to be returned Modify Response
to MGC.

1) Since Audit descriptor is present before Events descriptor, hence al/on
should be returned in Events descriptor.
2) Since there is overspecified parameter in Events descriptor, hence cd/std
should be returned with resolved TL parameter.

Now what should be returned in Events Descriptor in Modify Response to MGC.

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 28 May 2002 22:35:54 -0400

Section 7.2.9 has some text that perhaps sets a precedent here:

<quote>
The MGC may audit a specific Context to determine the current value of
individual context properties.  The MGC may determine the current values for
all existing (non-NULL) Contexts by specifying ContextID ALL in the Audit
request. If context attributes are added or have been modified by the same
action as the Audit Value request the value/s returned shall be after the
action has been applied.
</quote>

Conclusion from this precedent is that the results returned because of the
Audit descriptor should be those holding AFTER the rest of the command has
been carried out.  The event returned should be cd/std, with its list of
toneIDs from Annex E.7.3.

We probably need some text to this effect in section 7.2.1 where the
AuditDescriptor is explained.  We could also put it in section 7.1.12.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 10:49 AM
To: [email-masked]
Subject: [Megaco] Audit of Events

Hi List,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },

Now there are two options for Events Descriptor to be returned Modify
Response
to MGC.

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 28 May 2002 22:35:54 -0400

<quote>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 10:49 AM
To: [email-masked]
Subject: [Megaco] Audit of Events

Hi List,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Thu, 30 May 2002 20:19:18 +0530

Hi Tom,

Thanks for the response. U have stated that "The results returned because of the
Audit descriptor should be those holding AFTER the rest of the command has been
carried out."

Would it also holds true in case we have Audit descriptor with Events token and
Events descriptor without any wildcarded parameters.

I think in that case placement of Audit descriptor in command will decide the
returned Events descriptor. If Audit Desc precedes Events Desc, then returned
Events Desc should contain the events which are active before processing of
current Events desc. If Audit Desc succedes Events Desc, then returned Events
Desc should contain the events which will be active after processing of current
Events desc.

Let me give a small example to be more clear.
Suppose MGC sends 1st Modify Command to the Term T1 in NULL context.

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },
               Events = 2224 { al/of }
           }
       }
   }

Since Audit descriptor precedes Events descriptor, hence returned Events
descriptor should contain al/on.

Now MGC Sends 3rd Modify Command to the same Term T1 in NULL context.

   Transaction = 10003 {
       Context = - {
           Modify = T1 {
               Events = 2225 { al/fl },
               Audit { Events }
           }
       }
   }

Since Audit descriptor succedes Events descriptor, hence returned Events
descriptor should contain al/fl.

Pls. correct my understanding on the effect of placement of audit desc in
command.

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

"Tom-PT Taylor" <[email-masked]> on 05/29/2002 08:05:54 AM

To:   Ashish Singh/HSS@HSS, [email-masked]
cc:

Subject:  RE: [Megaco] Audit of Events

<quote>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 10:49 AM
To: [email-masked]
Subject: [Megaco] Audit of Events

Hi List,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Thu, 30 May 2002 20:19:18 +0530

Hi Tom,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },
               Events = 2224 { al/of }
           }
       }
   }

   Transaction = 10003 {
       Context = - {
           Modify = T1 {
               Events = 2225 { al/fl },
               Audit { Events }
           }
       }
   }

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

<quote>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 10:49 AM
To: [email-masked]
Subject: [Megaco] Audit of Events

Hi List,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 30 May 2002 13:19:00 -0400

Hi,

I think it should not: for consistency, to simplify the text parser life 
(or should I
say entity which handles the results of the parser) and the fact that we 
already
have order requirements for commands to be executed. That is if you need to
Audit before the descriptor is changed, then explicit AuditValue can be placed
before Modify in the same transaction.

Thanks
         Aleks

At 12:32 PM 5/30/2002, Tom-PT Taylor wrote:
>I wonder if other people have an opinion: should the results from an Audit
>Descriptor in a non-Audit command depend on it's ordering within the command
>parameters?
>
>Sent: Thursday, May 30, 2002 10:49 AM
>To: Taylor, Tom-PT [CAR:B602:EXCH]
>Cc: [email-masked]
>been

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 30 May 2002 13:19:00 -0400

Hi,

Thanks
         Aleks

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 30 May 2002 12:32:54 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 10:49 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Audit of Events

Hi Tom,

Thanks for the response. U have stated that "The results returned because of
the
Audit descriptor should be those holding AFTER the rest of the command has
been
carried out."

Would it also holds true in case we have Audit descriptor with Events token
and
Events descriptor without any wildcarded parameters.

I think in that case placement of Audit descriptor in command will decide
the
returned Events descriptor. If Audit Desc precedes Events Desc, then
returned
Events Desc should contain the events which are active before processing of
current Events desc. If Audit Desc succedes Events Desc, then returned
Events
Desc should contain the events which will be active after processing of
current
Events desc.

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },
               Events = 2224 { al/of }
           }
       }
   }

   Transaction = 10003 {
       Context = - {
           Modify = T1 {
               Events = 2225 { al/fl },
               Audit { Events }
           }
       }
   }

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

<quote>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 10:49 AM
To: [email-masked]
Subject: [Megaco] Audit of Events

Hi List,

   Transaction = 10001 {
       Context = - {
           Modify = T1 {
               Events = 2223 { al/on  }
           }
       }
   }

   Transaction = 10002 {
       Context = - {
           Modify = T1 {
               Audit { Events },

Thanks in advance,

Thanks N Regards
Ashish Singh
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Fri, 31 May 2002 18:11:12 +0530

Hi,

If you send two instances of the same descriptor back to MGC with different
contents, what will
MGC make out of it. Is the first one depicts the situation at MG? or the second
one? or the union ?

I think the option of including multiple descriptors make sense only when
disclosing capability
or specifying alternates that are available.

Sachin
Hughes Software
www.hssworld.com

"Usha Iyer" <[email-masked]> on 05/31/2002 05:43:01 PM

To:   "Christian Groves" <[email-masked]>, "Tom-PT Taylor"
      <[email-masked]>
cc:   Ashish Singh/HSS@HSS, [email-masked] (bcc: Sachin Mittal/HSS)

Subject:  Re: [Megaco] Audit of Events

Hi Tom/All,

      Descriptors should be processed in the order that they appear. 7.2
explicitly states this. It makes sense to specify the sequence of processing
in case of ContextAttribute audits because of the syntax for actionRequest .
    Also, the syntax enforces the "at-most-once" rule for the descriptors
only for the requests.The replies do not have this restriction.  7.2.5
states that " Values appearing in multiple instances of a descriptor are
defined to be alternate values  supported, with each parameter in a
descriptor considered independent. "
    Since multiple instances of a descriptor are allowed in AuditValue
reply, can we extend this to command replies in general, so that we can have
a command request with Audit desc. as well as another desc. with
overspecifed/underspecifed values ?

regards,
usha
  ----- Original Message -----
  From: Christian Groves
  To: Tom-PT Taylor
  Cc: [email-masked]' ; [email-masked]
  Sent: Friday, May 31, 2002 8:45 AM
  Subject: Re: [Megaco] Audit of Events

  G'Day Tom,

  My opinion is that the audit value should be executed and returned after
all the
  descriptors are executed. The syntax actually enforces it. You can't have
  multiple replies of the same descriptor which you would need in the case
that
  the auditvalue is executed first and another descriptor has a wildcard.

  Regards, Christian