Subject: [Megaco] Sequencing of commands on UDP

From: "Rakesh Nigudkar" <[email-masked]>
Date: Tue, 7 May 2002 14:14:53 +0530

Hi Tom/List,
As per section 9.1 point 3
For transport that do not guarantee in sequence delivery of messages (ie. UDP), on a given Termination, there should normally be at most one outstanding Notify command at any time.

Also the lockstep mode achieves the same functionality (i.e sequencing event notification ) for reporting of events on UDP tranport layer.
Even if EventBufferControl equals OFF, as per section 9.1 point 3 (quoted above) sequene of event notification would be maintained although at an implementation level.

Does it mean that sequencing is mandatory whatever the value of  EventBufferControl (i.e OFF or lockstep) and that lockstep is a protocol provision for maintaining sequence of event notification? Else the sequencing is left to implementation?
Or am I missing something?

Regs
Rakesh

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 7 May 2002 10:05:47 -0400

Assuming always that we are talking UDP or some other non-sequencing
transport, yes, it is up to the implementation (SHOULD strength) to ensure
sequenced delivery by not sending a new NOTIFY before the previous one was
acknowledged.  The use of Lockstep is not mandatory, but may be imposed by
the MGC (again depending on implementation in the MGC and network-specific
factors).

-----Original Message-----
From: Rakesh Nigudkar [mailto:[email-masked]]
Sent: Tuesday, May 07, 2002 4:45 AM
To: meglist
Subject: [Megaco] Sequencing of commands on UDP

Hi Tom/List,
As per section 9.1 point 3
For transport that do not guarantee in sequence delivery of messages (ie.
UDP), on a given Termination, there should normally be at most one
outstanding Notify command at any time.
 
Also the lockstep mode achieves the same functionality (i.e sequencing event
notification ) for reporting of events on UDP tranport layer.
Even if EventBufferControl equals OFF, as per section 9.1 point 3 (quoted
above) sequene of event notification would be maintained although at an
implementation level.
 
Does it mean that sequencing is mandatory whatever the value of
EventBufferControl (i.e OFF or lockstep) and that lockstep is a protocol
provision for maintaining sequence of event notification? Else the
sequencing is left to implementation?
Or am I missing something?
 
Regs
Rakesh 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 7 May 2002 10:05:47 -0400

-----Original Message-----
From: Rakesh Nigudkar [mailto:[email-masked]]
Sent: Tuesday, May 07, 2002 4:45 AM
To: meglist
Subject: [Megaco] Sequencing of commands on UDP

Hi Tom/List,

 
Regs
Rakesh