Subject: RE: [Megaco] RE: Deleting DigitMap from a Termination

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 30 May 2002 20:06:03 -0400

Hi,

         I know its been a while since this email, but I was going through
digit map declarations in the 3015corr draft and noticed that ABNF does not
seem to permit empty digitMapValue using empty braces:

digitMapDescriptor = DigitMapToken EQUAL ( ( LBRKT digitMapValue RBRKT ) /
         (digitMapName [ LBRKT digitMapValue RBRKT ]) )

That is for the example below to be correct it should be changed to:

digitMapDescriptor = DigitMapToken EQUAL ( ( LBRKT [ digitMapValue ] RBRKT ) /
         (digitMapName [ LBRKT [ digitMapValue ] RBRKT ]) )

or the example should be modified as follow to omit braces:

Transaction = 1 {
    Context = - {
       Modify = TermA {
          DigitMap = Dmap1 ; empty value for a name
       }
    }
}

Which one would be right? Or am I reading it all wrong?

Also I'm trying to understand a usage of nameless digit maps defined by 
DigitMapDescriptor.
Ether I'm missing something obvious (my apologies then), or it does not 
seem to be possible
to reference in EventDM such previously defined nameless digit map using 
ether ASN.1, or
ABNF. It also seems to be impossible with current ABNF syntax to delete 
nameless digit map.
Can someone clarify this for me please?

Thanks
         Aleks

At 06:32 PM 4/10/2002, Tom-PT Taylor wrote:
>You are correct.  See section 7.1.14.1.
>
>-----Original Message-----
>From: Sudhir Kumar Appana [mailto:[email-masked]]
>Sent: Wednesday, April 10, 2002 2:15 PM
>To: [email-masked]
>Cc: Sudhir (E-mail)
>Subject: [Megaco] RE: Deleting DigitMap from a Termination
>
>
>Tom,
>Can you please respond to this mail.
>Thanks,
>Sudhir
>
>
>-----Original Message-----
>From: Sudhir Kumar Appana [mailto:[email-masked]]
>Sent: Wednesday, April 10, 2002 5:13 PM
>To: [email-masked]
>Cc: Sudhir (E-mail)
>Subject: Deleting DigitMap from a Termination
>
>
>Hi,
>
>Is MGC can delete the DigitMap that is already defined using the
>following packet:
>
>Transaction = 1 {
>    Context = - {
>       Modify = TermA {
>          DigitMap = Dmap1 { }  ; empty value for a name
>       }
>    }
>}
>
>First of all, MGC can Modify DigitMap on a Termination which is in NULL
>Context.
>
>Thanks,
>Sudhir
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 30 May 2002 20:06:03 -0400

Hi,

Transaction = 1 {
    Context = - {
       Modify = TermA {

Thanks
         Aleks