Subject: RE: [Megaco] Mode in LocalControl ***

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 1 May 2002 08:14:59 -0400

The default value for Mode is inactive.  That means you MUST set it on all
terminations through which you want media to flow.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, May 01, 2002 8:03 AM
To: [email-masked]
Subject: [Megaco] Mode in LocalControl ***

Hello,
In the 3015 RFC there is an example of sending the Mode to both physical
and ephemeral terminations?
What should be done if only one of them receives a "Mode" parameter?
What should be done if there are two different Modes for the physical and
ephemeral terminations?

MEGACO/1 [123.123.123.4]:55555
   Transaction = 50003 {
       Context = $ {
          Add = A5555  { Media {
               Stream = 1 {
                    LocalControl {Mode = SendReceive} }},
                Events=1234{al/of},
               Signals {al/ri}
               },
          Add  = $ {Media {
               Stream = 1 {
                    LocalControl {
                       Mode = SendReceive,
                       nt/jit=40 ; in ms
                    },
                    Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4

   a=ptime:30
                    },
                    Remote {
   v=0
   c=IN IP4 124.124.124.222
   m=audio 2222 RTP/AVP 4
   a=ptime:30
                    } ; RTP profile for G.723 is 4
                }
             }
         }
      }
   }

Regards,

Dana H.
SW Engineer
NGTS ECI Telecom

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 03 May 2002 09:44:02 +0300

Hi,

A while ago there was a discussion about the use of mode in "internal"
terminations, eg a MUX termination. It was then said that mode can be
used even for such terminations, to describe the media flow.

However, chapter 6.1.1 very cleary says that MODE is used for the media
flow of the media at the ingress/egress of the media gateway, and that
TOPOLOGY is used for media between terminations within a context. By
reading that text one DOES get the understanding that mode is not needed
for the mux termination, so my question is if some clarifications are
needed?

Regards,

Christer Holmberg
Ericsson Finland

Tom-PT Taylor wrote:

>
>
> The default value for Mode is inactive.  That means you MUST set it on
> all terminations through which you want media to flow.
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 03 May 2002 09:44:02 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland