Subject: [Megaco] urgent

From: milton mukhopadhyaya <[email-masked]>
Date: Tue, 14 May 2002 23:52:40 -0700 (PDT)

Hi,
 I need some clarifications on the following doubts:
1> How does MGC get to know the semi-permanent
termination IDs provisioned in the MG when it
instructs the MG to act upon a particular termination?

2>How two streams get connected in the implementation
of MG? For example suppose we have an audio stream
originating from a physical termination T1 and we have
created an ephemeral termination to carry that audio
stream, then when the flow starts how should they be
connected in the gateway? 

          regards,
            MILTON

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rakesh Nigudkar" <[email-masked]>
Date: Wed, 15 May 2002 13:23:39 +0530

Hi,
1.  The semi -permanent terminations (ephemeral) are created by ADD command
and destroyed by SUBTRACT. After SUBTRACT the ephemeral terminations cease
to exist unlike permanent terminations which move to NULL context.
Replies to ADD (from MG)contain the ephemeral term ID which the MGC can use
to modify properties on those ephemeral terminations.
The naming schema for the termIds rests with the MG.Also MODIFY to ephemeral
terminations can be executed only after these terminations come into
existence(i.e. after ADD) and at this point of time one has access to the
ephemeral term IDs.(in the REPLY for ADD)

2. Streams is a concept local to MG and MGC. Terminations in a context
having the same stream id are connected, again a concept local to MG/MGC
however hardware resources on an MG would have to be
initialized(implementation specific) to achieve the required connection.
Regs
Rakesh

---

From: "Rakesh Nigudkar" <[email-masked]>
Date: Wed, 15 May 2002 13:23:39 +0530

Hi,

---

From: Christian Groves <[email-masked]>
Date: Thu, 16 May 2002 10:50:56 +1000

G'Day,

Semi-permanent connections could be either physical or euphemeral.
Semi-permanent is a category given to a line/connection through a switch.
Currently there's no way for the MGC/MG to determine if a termination relates to
semi-permanent connection. The most practical way would be a termination state
property = semi-permanent that way the MGC and MG could perform the correct
procedures at restart etc.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 16 May 2002 10:50:56 +1000

G'Day,

Regards, Christian

---

From: "Rakesh Nigudkar" <[email-masked]>
Date: Thu, 16 May 2002 15:00:39 +0530

Hi,
Since the behaviour of SVC(ROOT,restart) depends on the type of termination
(semi-permanent)
Does it imply that ephemerals would be of two types
1. semi-permanent ephemeral terminations  (which need to be initialised on
SVC(ROOT,restart)
2. normal ephemeral terminations
Also does it mean that semi-permanent ephemeral terms (could be IP,ATM )
move to null context after SUBTRACT on a context while the normal ephemeral
terminations cease to exist after a SUBTRACT?

Regs
Rakesh

---

From: "Rakesh Nigudkar" <[email-masked]>
Date: Thu, 16 May 2002 15:00:39 +0530

Hi,

Regs
Rakesh

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 16 May 2002 15:26:09 +0530

Hi,
      Ref 6.2:  " Terminations representing physical entities have a
semi-permanent existence. For example, a Termination representing a TDM
channel might exist for as long as it is provisioned in the gateway.
Terminations representing ephemeral information flows, such as RTP flows,
would usually exist only for the duration of their use "
    Ephemeral Terminations are destroyed on Subtract.

The Termination IDs of  physical terminations are provisioned in the MG .
MGC can either be provisioned with the termination IDs or it can optionally
do an audit for the same at restart. Also, the profile mechanism allows the
MG to convey the Termination naming convention to the MGC.

Reg,
usha

  ----- Original Message -----
  From: Rakesh Nigudkar
  To: Christian Groves
  Cc: milton mukhopadhyaya ; [email-masked]
  Sent: Thursday, May 16, 2002 3:00 PM
  Subject: Re: [Megaco] urgent

  Hi,
  Since the behaviour of SVC(ROOT,restart) depends on the type of
termination
  (semi-permanent)
  Does it imply that ephemerals would be of two types
  1. semi-permanent ephemeral terminations  (which need to be initialised on
  SVC(ROOT,restart)
  2. normal ephemeral terminations
  Also does it mean that semi-permanent ephemeral terms (could be IP,ATM )
  move to null context after SUBTRACT on a context while the normal
ephemeral
  terminations cease to exist after a SUBTRACT?

  Regs
  Rakesh
  ----- Original Message -----
  From: "Christian Groves" <[email-masked]>
  To: "Rakesh Nigudkar" <[email-masked]>
  Cc: "milton mukhopadhyaya" <[email-masked]>; <[email-masked]>
  Sent: Thursday, May 16, 2002 6:20 AM
  Subject: Re: [Megaco] urgent

  > > Replies to ADD (from MG)contain the ephemeral term ID which the MGC
can
  use

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 16 May 2002 15:26:09 +0530

Hi,

Reg,
usha

  ----- Original Message -----
  From: Rakesh Nigudkar
  To: Christian Groves
  Cc: milton mukhopadhyaya ; [email-masked]
  Sent: Thursday, May 16, 2002 3:00 PM
  Subject: Re: [Megaco] urgent

  Hi,

  Regs
  Rakesh
  ----- Original Message -----
  From: "Christian Groves" <[email-masked]>
  To: "Rakesh Nigudkar" <[email-masked]>
  Cc: "milton mukhopadhyaya" <[email-masked]>; <[email-masked]>
  Sent: Thursday, May 16, 2002 6:20 AM
  Subject: Re: [Megaco] urgent

can
  use

---

From: Christian Groves <[email-masked]>
Date: Fri, 17 May 2002 10:46:23 +1000

Hello Usha and Rakesh,

I believe the original question refers to Semi-permanent connections described
in ITU-T Q.931 sections 5.5.2 and 6. Any existing termination can be made
semi-permanent through the use of O&M. Q.931 describes the behaviour of
semi-permanent connections with regards to release. As I mentioned below we
probably need a property in a new package to indicate the status of the
connection with regards to semi-permanent connections. Its something I've been
meaning to do for a while.

Regards, Christian

Usha Iyer wrote:
> The Termination IDs of  physical terminations are provisioned in the MG . MGC
> can either be provisioned with the termination IDs or it can optionally do an
> audit for the same at restart. Also, the profile mechanism allows the MG to
> convey the Termination naming convention to the MGC.
> 
> Reg,
> usha
> 
> 
> 
> 
>      > Currently there's no way for the MGC/MG to determine if a
>      termination
>      relates to
>      > semi-permanent connection. The most practical way would be a
>      termination
>      state
>      > property = semi-permanent that way the MGC and MG could perform
>      the
>      correct
>      > > 1.  The semi -permanent terminations (ephemeral) are created by
>      ADD
>      command
>      > > and destroyed by SUBTRACT. After SUBTRACT the ephemeral
>      terminations
>      cease
>      > > Replies to ADD (from MG)contain the ephemeral term ID which the
>      MGC can
>      use
>      > > The naming schema for the termIds rests with the MG.Also MODIFY
>      to
>      ephemeral
>      > > existence(i.e. after ADD) and at this point of time one has
>      access to
>      the
>                                Name: InterScan_Disclaimer.txt
>    InterScan_Disclaimer.txt    Type: Plain Text (text/plain)
>                            Encoding: 7bit

---

From: Christian Groves <[email-masked]>
Date: Fri, 17 May 2002 10:46:23 +1000

Hello Usha and Rakesh,

Regards, Christian