Subject: RE: [Megaco] BOOLEAN type for Parameter Value in Packages

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 7 May 2002 09:23:46 -0400

I know development has to move forward, sometimes regardless of the state of
standardization.  My suggestion is to anticipate standards development the
best you can.  In the Q.1950 example, it looks like some cleaning up is
needed when SG 11 can get around to it -- maybe in the Q.1950 IG, to start
with.  Christian Groves can speak to that one.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 07, 2002 12:08 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]; Megaco
Subject: RE: [Megaco] BOOLEAN type for Parameter Value in Packages

Hi Tom,
     As per your suggestion, I believe this changing of the type of these
parameter values from
 boolean to enumerated would be done in the next draft only, till then what
should be done.
Whether the values ON/OFF be used or define our own enumerated values or
those
given in the
drafts be used :
Like in Q.1950 draft
     PropertyID: 0x0001, RII
     Type: Boolean
     Possible Values: Not_Reuse_Idle [0x00], ReUse_Idle [0x01]
     Default: Not_Reuse_Idle [0x00]

We change the type to enumerated and take the values as NOT_REUSE_IDLE for
0x00
and RE_USE_IDLE for 0x01.

regards/
Amit Kalra
(MEGACO Stack Development Team)

Hughes Software Systems
Gurgaon, INDIA

"Tom-PT Taylor" <[email-masked]> on 05/06/2002 08:04:24 PM

To:   Vivek Bansal/HSS@HSS
cc:   Amit Kalra/HSS@HSS, Megaco <[email-masked]>

Subject:  RE: [Megaco] BOOLEAN type for Parameter Value in Packages

Yes, you might want to consider an enumerated type.  0 and 1 were also
pretty cryptic.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 06, 2002 10:12 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]; Megaco
Subject: RE: [Megaco] BOOLEAN type for Parameter Value in Packages

Hi Tom

So are you saying for this example with

     Property Id: rrsvpsmod (0x0001)
      Type: Boolean
     Possible values:
          0 for Guaranteed QoS and
           1 for Controlled Load Service.

     we encode "off"  for guranteed QoS and "on" for Controlled loadservice.
     But now looking at the PDU it is dificult to interpret the values.
Shouldn't  we have type as ENUM for these cases rather than BOOLEAN.

Regards
Vivek

www.hssworld.com

"Tom-PT Taylor" <[email-masked]> on 05/06/2002 07:26:49 PM

To:   Amit Kalra/HSS@HSS, Megaco <[email-masked]>
cc:    (bcc: Vivek Bansal/HSS)

Subject:  RE: [Megaco] BOOLEAN type for Parameter Value in Packages

From the notes preceding the ABNF in Annex B:

; Boolean:  Boolean values are encoded as "on" and "off" and are
; case insensitive.  The SafeChar form of VALUE MUST be used.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 06, 2002 8:07 AM
To: Megaco
Subject: [Megaco] BOOLEAN type for Parameter Value in Packages

Hi,
     In packages where the type of the parameter values is given as BOOLEAN,
     the possible values are given to be 0 or 1, in some packages the
strings
     TRUE/FALSE or ON/OFF are used :

     PropertyID: permact (0x0004)
      Type: Boolean
      Possible Values:
          True: permanent activation is installed
          False: activation/de-activation procedure necessary
     in draft-bouwen-megaco-isdn-pack-00.txt

     Whereas in other packages the values 0 and 1 are mentioned and
     a description is given as in

     Property Id: rrsvpsmod (0x0001)
      Type: Boolean
     Possible values:
          0 for Guaranteed QoS and
           1 for Controlled Load Service.

     in draft-madhubabu-megaco-qospackage-00.txt

     Now I am not clear whether what is the possible value here
     although the type BOOLEAN is specified. Shouldn't there be a standard
code,
     otherwise if we want to specify possible values can't we specify the
type
as ENUMERATED

regards/
Amit Kalra
(MEGACO Stack Development Team)

Hughes Software Systems
Gurgaon, INDIA

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 08 May 2002 10:02:51 +1000

G'Day Tom,

I'd suggest that you submit a contribution to SG11 for an update to the Q.1950
Amendment. I would suggest leaving BOOLEAN and update to On and Off as we only
need 2 values.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 08 May 2002 10:02:51 +1000

G'Day Tom,

Regards, Christian