Subject: RE: [Megaco] About RGW PBX application

From: "SND Wang JuLin" <[email-masked]>
Date: Wed, 8 May 2002 15:29:05 +0800

Anil,
You hit the point.
MGC configured PBX just as one  termination,taking  its phone number as "5000" for example,and MGC don't know the ext numbers which PBX had allocated.

In case of MGCP application,see below:
Scenario 1:caller just dial once(out of band transfer,no ext number)
TEL1------Gateway1----------MGC-----Gateway2-----PBX------TEL2
..
..
step1-11(omitted)
step12:
            RQNT:
MGC----------->Gateway2
step13:
                Off-Hook
Gateway2----------->PBX
 step14:
                  dialtone
Gateway2<-----------PBX   
step15:
           RQNT
MGC----------->Gateway2
step16:
                 digit(xxxx)
Gateway2----------->PBX
step17:
                  ringing
PBX ---------------->TEL2
step18:
                     ringback
Gateway2<--------------------PBX 
step19:
                  NTFY
MGC<-----------------Gateway2
 
Scenario  2:caller dial twice(inband transfer)
step1-11(omitted)
step12:
            RQNT:
MGC----------->Gateway2
step13:
                Off-Hook
Gateway2----------->PBX

step14:
           dialtone:
TEL1<-----------PBX
step15:
            digit(xxxx)
TEL1----------->PBX

In case of H.248 out-of-band dtmf transfering application,can MGC use dg package to inform Gateway2 the ext numbers ?(and thus Gateway2 send dtmf signal to make PBX side ringing.)
As belows:    (802 is the TEL2's ext number )
T=15{C=-{MF=rgw_7501/1{E=589829{al/of{strict=exact},al/on{strict=exact},g/sc},SG{dg/d8,dg/d0,dg/d2}}}
It is just my suggestion to use  SG{dg/d8,dg/d0,dg/d2}   (might not defined in the protocol).

BTW, PBX is not connected to PSTN. What  i refered here is just a device connected to the RGW  acting  as mutilple phones.

Thanks  a lot!

best  regards
> :-)Jerry Wang
tel:(8621)58541240 ext 9615
mailto:[email-masked]
Shanghai Bell Co.LTD

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 9:12 PM
To: 'Tom-PT Taylor'; SRD Wang JuLin; An Leurs; Megaco (E-mail); MadhuBabu Brahmanapally (E-mail)
Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
Subject: RE: [Megaco] About RGW PBX application

Hi PTT,

this is a typical scenario as follows.
Tel1 --> RGW1 --> Softswitch ---> RGW2 ---> PBX ---> Tel2.
In this case, the PBX is one of the endpoints configured on the RGW2, and
also would have been configured as one of the route in softswitch (I assume
that both the gateways are configured in the same softswitch). Now the call
is assumed to be established between the caller and the callee (in this set
up case, it is PBX), and then once the media is established, PBX would play
a file asking to dial the ext number. Once the PBX receives the digits, it
will send an alert to the ext inside its own network.

The question, here is in the context... how the dialed digits (after the
media is established) are being passed to the PBX. One method is to send the
inband DTMF, which has inherent problems of low frequency signal
transmission (I took the reference of the link:
http://www.cs.columbia.edu/sip/drafts/draft-sinnreich-sigdevctrl-00.txt see
6.2. DTMF Signaling Issues). 

In case of out of band digit transmission, the RGW1 can be programmed to
send NTFY (in case of MGCP) to the softswitch. But I couldn't find out how
the softswitch would inform it to the RGW2, and ultimately to the PBX.

/anil.

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Tuesday, April 30, 2002 6:13 PM
> To: 'SRD Wang JuLin'; An Leurs; Megaco (E-mail); MadhuBabu 
> Brahmanapally
> (E-mail)
> Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
> Subject: RE: [Megaco] About RGW PBX application
> 
> 
> Why does the callee side need the ext number?  Normally it is 
> up to the MGC
> to translate between the called number and a terminationID 
> representing the
> called party in the destination RGW.
> 
> -----Original Message-----
> From: SRD Wang JuLin [mailto:[email-masked]]
> Sent: Tuesday, April 30, 2002 4:48 AM
> To: An Leurs; Megaco (E-mail); MadhuBabu Brahmanapally (E-mail)
> Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
> Subject: [Megaco] About RGW PBX application
> 
> 
> Hi,
>  
> Currently,we are take consideration of RGW (FXS type)PBX 
> application.I have
> a question to consult:
> Suppose that the caller located in one RGW firstly dial a 
> number to connect
> to the PBX which are lined to another RGW. After call connected and
> establish rtp stream,the  PBX will send dialtone directly to 
> the caller
> indicating the caller  to dial the ext(callee's) number 
> (callee lined to the
> PBX).So the caller can send the  ext number to Softswtich in Notify
> message.(use dtmf inband transfer is another case)But i 
> wonder how can the
> Softswtich send the ext number to the callee side?Use dg package???
> Pls clear my mind about it!
> Thanks a lot! 
>  
> best  regards 
> JJerry Wang 
> tel:(8621)58541240 ext 9615 
> mailto:[email-masked] 
> Shanghai Bell Co.LTD 
>  
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "SND Wang JuLin" <[email-masked]>
Date: Wed, 8 May 2002 15:29:05 +0800

Anil,
You hit the point.

step14:
           dialtone:
TEL1<-----------PBX
step15:
            digit(xxxx)
TEL1----------->PBX

Thanks  a lot!

best  regards

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 9:12 PM
To: 'Tom-PT Taylor'; SRD Wang JuLin; An Leurs; Megaco (E-mail); MadhuBabu Brahmanapally (E-mail)
Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
Subject: RE: [Megaco] About RGW PBX application

Hi PTT,

/anil.