Subject: [Megaco] contextTerminationAudit - ambiguous syntax?

From: Raphael Tryster <[email-masked]>
Date: Thu, 30 May 2002 16:07:32 +0200

Should

		   contextTerminationAudit = EQUAL CtxToken (
terminationIDList / 
		                          LBRKT errorDescriptor RBRKT ) 

be written like this?

		   contextTerminationAudit = EQUAL CtxToken (
terminationIDList / 
		                          (LBRKT errorDescriptor RBRKT )) 

Raphael Tryster

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 30 May 2002 09:30:19 -0400

I believe that the latter is the intent.  This looks to be a typo that
should be corrected. (Good catch!)

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 10:08 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] contextTerminationAudit - ambiguous syntax?

Should 
   contextTerminationAudit = EQUAL CtxToken ( terminationIDList /
                          LBRKT errorDescriptor RBRKT ) 
be written like this? 
   contextTerminationAudit = EQUAL CtxToken ( terminationIDList /
                          (LBRKT errorDescriptor RBRKT )) 

Raphael Tryster 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 30 May 2002 17:00:51 +0200

I was looking for consistency in the ABNF, and I saw lots of parentheses
used in other places in RFC 3015 where they might not strictly be needed.
For example:

commandReply       = (( contextProperties [COMMA commandReplyList] )
                           / commandReplyList )

It seems pretty clear that the outer set of parentheses is superfluous.  If
Giri is right, then the inner set is superfluous too.  However, I would be
very sorry to see them eliminated, because the world of hi tech is
complicated enough without having to remember ABNF operator precedence
rules.

Raphael Tryster

	-----Original Message-----
	From:	Giri Rajasekhar Saladi [SMTP:[email-masked]]
	Sent:	Thursday, 30 May, 2002 3:48 PM
	To:	Kevin Boyle
	Cc:	Raphael Tryster; 'Megaco_IETF (E-mail)
	Subject:	Re: [Megaco] contextTerminationAudit - ambiguous
syntax?

	Hi Raphael/Kevin,
	        The alternate operator '|' is lesser in precedence
	 to concatenation. I guess the paranthesis in ABNF grammar
	are to override the precedence of operators, nothing more
	than that. Can you clarify me how does this change suggested
	is going to eliminate the ambiguity, if present?. It's only
	confusing I believe.
	Thanks,
	Giri

	-- 

	Giri Rajasekhar Saladi
	HCL Technologies Ltd.,
	51, Jawaharlal Nehru Road 
	Guindy Industrial Estate,
	Ekkatuthangal,
	Chennai - 600 097.

	Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
	Fax : +91 44 234 4256
	e-mail : [email-masked]
<mailto:[email-masked]>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 30 May 2002 18:40:03 +0200

You mean sometimes a machine would process these definitions like a C
preprocessor, where sometimes you need to put parentheses around #defined
values because of the context in which they are used?

Here's a curious one.  I don't see what information the parentheses could
possibly add in any context:

notifyRequest        = NotifyToken EQUAL TerminationID
                          LBRKT ( observedEventsDescriptor
                                [ COMMA errorDescriptor ] ) RBRKT

Raphael Tryster

	-----Original Message-----
	From:	Terry L Anderson [SMTP:[email-masked]]
	Sent:	Thursday, 30 May, 2002 5:29 PM
	To:	Raphael Tryster
	Cc:	[email-masked]; Kevin Boyle; 'Megaco_IETF
(E-mail)

	I believe that the outer set are needed because of the context where

	commandReply will be used but the inner set are, I believe,
superfluous. 
	 And, as Giri suggests,  the current contextTerminationAudit is ok.

	Raphael Tryster wrote:

	> I was looking for consistency in the ABNF, and I saw lots of 
	> parentheses used in other places in RFC 3015 where they might not 
	> strictly be needed.  For example:
	>
	> It seems pretty clear that the outer set of parentheses is 
	> superfluous.  If Giri is right, then the inner set is superfluous 
	> too.  However, I would be very sorry to see them eliminated,
because 
	> the world of hi tech is complicated enough without having to
remember 
	> ABNF operator precedence rules.
	>
	> Raphael Tryster
	>
	>       > I believe that the latter is the intent.  This looks to be
a
	>       typo that
terminationIDList /
terminationIDList /
	>       >                           (LBRKT errorDescriptor RBRKT ))
<https://www1.ietf%0Alman/listinfo/megaco%3C/A%3E%3C/FONT%3E%0A%3C/P%3E%0A%0
A%3CP%3E%3CFONT%20SIZE=2%20FACE=>
	>       Guindy Industrial Estate,
<https://www1.ietf%0Alman/listinfo/megaco%3C/A%3E%3C/FONT%3E%0A%3C/P%3E%0A%0
A%3CP%3E%3CFONT%20SIZE=2%20FACE=>
<https://www1.ietf%0Alman/listinfo/megaco%3C/A%3E%3C/FONT%3E%0A%3C/P%3E%0A%0
A%3CP%3E%3CFONT%20SIZE=2%20FACE=>
	>       e-mail : [email-masked] <
	>
<https://www1.ietf%0Alman/listinfo/megaco%3C/A%3E%3C/FONT%3E%0A%3C/P%3E%0A%0
A%3CP%3E%3CFONT%20SIZE=2%20FACE=>mailto:[email-masked]>

	-- 

	------------------------------------------------------------
	Terry L Anderson              mailto:[email-masked]
	Tel:732.949.5628   Fax:732.949.7016
	Lucent Technologies/INS/Voice Over IP Access Networks
	Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
	http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 30 May 2002 18:40:03 +0200

Raphael Tryster

	-----Original Message-----
	From:	Terry L Anderson [SMTP:[email-masked]]
	Sent:	Thursday, 30 May, 2002 5:29 PM
	To:	Raphael Tryster
	Cc:	[email-masked]; Kevin Boyle; 'Megaco_IETF
(E-mail)

because 
remember 
a
terminationIDList /
terminationIDList /

	--

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 30 May 2002 12:02:20 -0400

They are actually the same, if you look at the ABNF spec (RFC 2234).  The
"/" operator takes precedence over concatenation.  Here is the relevant
quotation:

<quote>
3.5  Sequence Group                             (Rule1 Rule2)

...

        elem foo / bar blat

   matches (elem foo) or (bar blat).

        NOTE:     It is strongly advised to use grouping
                  notation, rather than to rely on proper reading of
                  "bare" alternations, when alternatives consist of
                  multiple rule names or literals.

   Hence it is recommended that instead of the above form, the form:

        (elem foo) / (bar blat)

   be used.  It will avoid misinterpretation by casual readers.
</quote>

-----Original Message-----
From: Boyle, Kevin [NCRTP:3R90:EXCH] 
Sent: Thursday, May 30, 2002 9:30 AM
To: Raphael Tryster; 'Megaco_IETF (E-mail)
Subject: RE: [Megaco] contextTerminationAudit - ambiguous syntax?

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 10:08 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] contextTerminationAudit - ambiguous syntax?

Should 

Raphael Tryster

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 30 May 2002 12:02:20 -0400

<quote>

...

        elem foo / bar blat

        (elem foo) / (bar blat)

-----Original Message-----
From: Boyle, Kevin [NCRTP:3R90:EXCH] 
Sent: Thursday, May 30, 2002 9:30 AM
To: Raphael Tryster; 'Megaco_IETF (E-mail)
Subject: RE: [Megaco] contextTerminationAudit - ambiguous syntax?

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 10:08 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] contextTerminationAudit - ambiguous syntax?

Should 

Raphael Tryster

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 30 May 2002 12:50:46 -0400

Well, I stated the precedence wrongly, but the principle stands.  A lot of
the parentheses we have added are for readability.  The parentheses already
present in the contextTerminationAudit production are there out of
necessity.  The ones Ralph proposes are not necessary, but might help
readability.

-----Original Message----- 
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, May 30, 2002 10:08 AM 
To: 'Megaco_IETF (E-mail) 
Subject: [Megaco] contextTerminationAudit - ambiguous syntax? 

Should 

Raphael Tryster

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 30 May 2002 12:50:46 -0400

-----Original Message----- 
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, May 30, 2002 10:08 AM 
To: 'Megaco_IETF (E-mail) 
Subject: [Megaco] contextTerminationAudit - ambiguous syntax? 

Should 

Raphael Tryster