Subject: [Megaco] question about context

From: [email-masked]
Date: Fri, 24 May 2002 16:56:12 +0800

hi,folks
   i think h248 context is too simple.in a multimedia multipoint call,the
audio and video can have different context type.for example,audio is
mixed,but video is multicasting.
   so i think per media type need a context instead of per termination.
   please give some comments

thank in advance!

wu.y.m

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 24 May 2002 18:26:46 +0530

Hi Wu,
	What you want can be achieved thru stream modes? Topology decides how the media
in a stream should flow between the terminations inside the context. MEGACO
gives the freedom of connecting the termination streams independently.
We can implement multicasting for video mode by 
    (T1, T2, oneway)
    (T1, T2, oneway)

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 24 May 2002 18:26:46 +0530

Hi Wu,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 24 May 2002 18:38:45 +0530

Hi Wu,
        What you want can be achieved thru stream 
modes? Topology decides how the media in a stream should 
flow between the terminations inside the context. MEGACO
gives the freedom of connecting the termination streams
independently.

We can implement multicasting for video stream by specifying topology descriptor
as
    (T1, T2, oneway)
    (T1, T3, oneway)
     ..
     ..
     ..
    (T1, Tn, oneway)
and since defalut is both-way, nothing to specify for 
audio stream.
Hope this is clear.
Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 24 May 2002 18:38:45 +0530

Hi Wu,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,