Subject: [Megaco] Negative transaction reply

From: [email-masked]
Date: Thu, 30 May 2002 16:00:51 +0300

Hello,

Suppose the MG does not support the codec sent by the MGC within Media
descriptor of ADD (ephemeral) command.

According to RFC 3015:
"The TransactionReply includes the return values for the Commands that were
executed successfully,and the Command and error descriptor for any Command
that failed"

What about the following example: Is it OK the send NACK for the whole
action without processing even the first ADD command?

MEGACO/1 [123.123.123.4]:55555
   Transaction = 50003 {
       Context = $ {
          Add = A5555  { Media {
               Stream = 1 {
                    LocalControl {Mode = SendReceive} }},
                Events=1234{al/of},
               Signals {al/ri}
               },
          Add  = $ {Media {
               Stream = 1 {
                    LocalControl {
                       Mode = SendReceive,
                       nt/jit=40 ; in ms
                    },
                    Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4

   a=ptime:30
                    },
                    Remote {
   v=0
   c=IN IP4 124.124.124.222
   m=audio 2222 RTP/AVP 4
   a=ptime:30
                    } ; RTP profile for G.723 is 4
                }
             }
         }
      }
   }

Dana H.
SW Engineer
NGTS ECI Telecom

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 30 May 2002 09:28:22 -0400

No.  You must process the commands in order.  If the first command is
successful and the second fails, the reply would show that.

If it is important to detect the codec failure in the example you've shown
before adding the physical, then swap the order of the commands.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 9:01 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: [Megaco] Negative transaction reply

Hello,

According to RFC 3015:

   a=ptime:30
                    },
                    Remote {
   v=0
   c=IN IP4 124.124.124.222
   m=audio 2222 RTP/AVP 4
   a=ptime:30

Dana H.
SW Engineer
NGTS ECI Telecom

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 30 May 2002 09:28:22 -0400

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 9:01 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];

Hello,

According to RFC 3015:

   a=ptime:30
                    },
                    Remote {
   v=0
   c=IN IP4 124.124.124.222
   m=audio 2222 RTP/AVP 4
   a=ptime:30

Dana H.
SW Engineer
NGTS ECI Telecom