Subject: RE: [Megaco] Error Code #506 : Number of TransactionPendings Exce eded

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 29 May 2002 14:36:49 -0400

The sender of the original Transaction is the receiver of Pendings, and the
SENDER of this error code.  The command is assumed to have failed at that
time.  The receiver of the error code (which is the entity sending Pendings)
should halt processing of the command, just as if it had encountered an
error.

Note that the entity sending Pendings will almost always be the MG.
Receiving the "Too many Pendings" error from the MGC would be equivalent to
attempting to execute a command and failing for some other reason.

Kevin

-----Original Message-----
From: Susumu YAMAMOTO [mailto:[email-masked]]
Sent: Wednesday, May 29, 2002 5:49 AM
To: [email-masked]
Subject: [Megaco] Error Code #506 : Number of TransactionPendings
Exceeded

Hi all,

I have a question about the usage for new error code #906 "Number of
TransactionPendings Exceeded" below.

---quotation from amendment document for Annex.L---
L.4.2.xx
Error Code # : 506
Name: Number of TransactionPendings Exceeded
Definition: Indicates that the maximum number of TransactionPendings
                have been received and that the transaction can be assumed
                to be in error.
Package: -
Reference: -
Error Text in the error Descriptor: -
Comment: -
-----------------------------------------------

Which side of the MEGACO entity will receive this error code, the receiver
ot the TransactionPendings or the sender ?

I assume that the receiver of the TransactionPendings would not have
available message sent with error code, because the receiver is originally
the sender of the TransactionRequest for the Transaction.

Considering of assumed reaction of the receiver of this error code, however
the sender of TransactionPendings should receive this message.

Could you please tell me how (and by whom) this error code will be received,
and what the reaction of the receiver is assumed ?

-*-*-*-
SUSUMU YAMAMOTO, NTT Corporation

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 29 May 2002 14:36:49 -0400

Kevin

-----Original Message-----
From: Susumu YAMAMOTO [mailto:[email-masked]]
Sent: Wednesday, May 29, 2002 5:49 AM
To: [email-masked]
Subject: [Megaco] Error Code #506 : Number of TransactionPendings
Exceeded

Hi all,

---quotation from amendment document for Annex.L---
L.4.2.xx
Error Code # : 506

-*-*-*-