Subject: RE: [Megaco] contextTerminationAudit - ambiguous syntax?

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 30 May 2002 09:30:19 -0400

I believe that the latter is the intent.  This looks to be a typo that
should be corrected. (Good catch!)

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, May 30, 2002 10:08 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] contextTerminationAudit - ambiguous syntax?

Should 
   contextTerminationAudit = EQUAL CtxToken ( terminationIDList /
                          LBRKT errorDescriptor RBRKT ) 
be written like this? 
   contextTerminationAudit = EQUAL CtxToken ( terminationIDList /
                          (LBRKT errorDescriptor RBRKT )) 

Raphael Tryster 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 30 May 2002 19:18:20 +0530

Hi Raphael/Kevin,
        The alternate operator '|' is lesser in precedence
 to concatenation. I guess the paranthesis in ABNF grammar
are to override the precedence of operators, nothing more
than that. Can you clarify me how does this change suggested
is going to eliminate the ambiguity, if present?. It's only
confusing I believe.
Thanks,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 30 May 2002 19:18:20 +0530

Hi Raphael/Kevin,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,