Subject: RE: [Megaco] SDP equivalent in ASN.1

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 27 May 2002 09:14:30 -0400

It's my view that we are in new territory here, so this is a matter of what
we agree.  Certainly the EOL is unnecessary, as the ASN.1 itself provides a
clear delineation of each line.  So the question is whether having the EOL
makes it easier to unpack the SDP and pass it to an SDP parser, or whatever
people do.

Comments, please, from anyone who has explored this territory.

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]]
Sent: Sunday, May 26, 2002 10:30 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] SDP equivalent in ASN.1

Hi
When using the SDP equivalences for the ASN.1, should the string still be
finished with EOL?
Nurit

****************************************************************************
********************************
This email and any files transmitted with it are confidential material.
They are intended solely for the use of the individual or entity to whom
they are addressed.
If you have received this email in error please notify
[email-masked]
and permanently delete the e-mail and files.
****************************************************************************
*******************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Tue, 28 May 2002 09:32:47 -0400

I think not.

The ASN.1 standard for strings is to not include the EOL, and
Annex A specifies this as an IA5String.

Adding NULLs would not make unpacking easier, but would increase
message size.

I currently support a parser/encoder that uses the Annex C
SDP equivs without the NULLs.  It has interoperated with
other stacks using this format.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Tue, 28 May 2002 09:32:47 -0400

I think not.

-troy