Subject: Re: [Megaco] Codec Selection

From: Christer Holmberg <[email-masked]>
Date: Tue, 14 May 2002 16:00:47 +0300

Hi,

If you want the MG to reserve ALL (or, as many as possible) of the
codecs, the ReserveValue MUST be "ON". In your example you use "OFF",
which means that only ONE codec shall be reserved.

Regards,

Christer Holmberg
Ericsson Finland

Rajeev K R wrote:

> Hi All,
>
> Please clarify the following message Sequence:
>
> I send the following command to MG. My intention is to reserve all the
> 4 codecs that this MG can support:
>
> MEGACO/1 [10.11.10.71]:2944
> T=707{C=${A=MP1002{M{ST=1{O{MO=SR,RV=OFF,RG=OFF}}},E=6{al/on{strict=failWrong}}},
>
> A=${M{ST=1{O{MO=RC,RV=ON,RG=ON},L{v=0
>
> c=IN IP4 $
>
> m=audio $ RTP/AVP 8 0 4 18
>
> }}}}}}
>
> I expect a response from MG with local descriptor filled with all
> these 4 codecs. Bu the response contain only one codec(first in the
> list I have provided):
>
> MEGACO/1 [10.11.9.83]:2944 P=707{C=1{A=MP1002,A=RTP/1{M{ST=1{L{v=0
>
> c=IN IP4 10.11.9.83
>
> m=audio 4000 RTP/AVP 8}}}}}}
>
>
>
> Is this the correct behaviour as per the Megaco RFC ?
>
> Regards,
>
> Rajeev
>
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 14 May 2002 16:00:47 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Rajeev K R" <[email-masked]>
Date: Tue, 14 May 2002 10:05:36 +0800

Hi All,

I send the following command to MG. My intention is to reserve all the 4 codecs that this MG can support:

MEGACO/1 [10.11.10.71]:2944 T=707{C=${A=MP1002{M{ST=1{O{MO=SR,RV=OFF,RG=OFF}}},E=6{al/on{strict=failWrong}}},

c=IN IP4 $

}}}}}}

I expect a response from MG with local descriptor filled with all these 4 codecs. Bu the response contain only one codec(first in the list I have provided):

c=IN IP4 10.11.9.83

Regards,

Rajeev