Subject: [Megaco] Error Code #506 : Number of TransactionPendings Exceeded

From: Susumu YAMAMOTO <[email-masked]>
Date: Wed, 29 May 2002 18:48:51 +0900

Hi all,

I have a question about the usage for new error code #906 "Number of
TransactionPendings Exceeded" below.

---quotation from amendment document for Annex.L---
L.4.2.xx
Error Code # : 506
Name: Number of TransactionPendings Exceeded
Definition: Indicates that the maximum number of TransactionPendings
                have been received and that the transaction can be assumed
                to be in error.
Package: -
Reference: -
Error Text in the error Descriptor: -
Comment: -
-----------------------------------------------

Which side of the MEGACO entity will receive this error code, the receiver
ot the TransactionPendings or the sender ?

I assume that the receiver of the TransactionPendings would not have
available message sent with error code, because the receiver is originally
the sender of the TransactionRequest for the Transaction.

Considering of assumed reaction of the receiver of this error code, however
the sender of TransactionPendings should receive this message.

Could you please tell me how (and by whom) this error code will be received,
and what the reaction of the receiver is assumed ?

-*-*-*-
SUSUMU YAMAMOTO, NTT Corporation

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Susumu YAMAMOTO <[email-masked]>
Date: Thu, 30 May 2002 13:39:36 +0900

Hello Kevin,

Thank you for reply.

I understand the outline of the usage for this error code, but I still have
some questions below.

* What is the assumed image of the MEGACO message with this error
    code sent from the MGC ?
    I assume that the ErrorDescriptor including errorCode shall be placed
    within ActionReply. It seems unordinary that the MGC would send
    error code within TransactionReply for the TransactionID of which
    TransactionRequest was originally sent from the same MGC.

* What is the reaction when this error code would have been received
    just after the reply for the Transaction was sent ?
    I am worried about inconsistency of the call status in the end of this
    procedure.

Thanks,

Susumu

---
>The sender of the original Transaction is the receiver of Pendings, and the
>SENDER of this error code.  The command is assumed to have failed at that
>time.  The receiver of the error code (which is the entity sending Pendings)
>should halt processing of the command, just as if it had encountered an
>error.
>
>Note that the entity sending Pendings will almost always be the MG.
>Receiving the "Too many Pendings" error from the MGC would be equivalent to
>attempting to execute a command and failing for some other reason.
>
>Kevin
>
>-----Original Message-----
>From: Susumu YAMAMOTO [mailto:[email-masked]]
>Sent: Wednesday, May 29, 2002 5:49 AM
>To: [email-masked]
>Subject: [Megaco] Error Code #506 : Number of TransactionPendings
>Exceeded
>
>
>Hi all,
>

-*-*-*-

---

From: Susumu YAMAMOTO <[email-masked]>
Date: Thu, 30 May 2002 13:39:36 +0900

Hello Kevin,

Thank you for reply.

Thanks,

Susumu

---

-*-*-*-