Subject: [Megaco] question about context

From: [email-masked]
Date: Fri, 24 May 2002 16:56:12 +0800

hi,folks
   i think h248 context is too simple.in a multimedia multipoint call,the
audio and video can have different context type.for example,audio is
mixed,but video is multicasting.
   so i think per media type need a context instead of per termination.
   please give some comments

thank in advance!

wu.y.m

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 24 May 2002 08:24:16 -0400

The MGC can do anything it wants to.  If it wants to have a context per
media type, it can do that.

The kinds of problems you are worried about don't actually occur, I think.
The example you gave - multicasting video and mixing audio is, I think,
"mixing" apples and oranges.  If you have multiple video sources,
and corresponding multiple audio sources, and you want a single
audio and a single video stream going back to each participant, then
multimedia contexts work just fine, regardless of whether the
resulting audio is a mixed unicast, and the resulting video is
a selected multicast.  The SDP would describe this quite
reasonably.  

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 24, 2002 4:56 AM
> To: [email-masked]
> Subject: [Megaco] question about context
> 
> 
> hi,folks

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 24 May 2002 08:24:16 -0400

Brian