Subject: [Megaco] Codec Selection

From: "Rajeev K R" <[email-masked]>
Date: Tue, 14 May 2002 10:05:36 +0800

Hi All,

Please clarify the following message Sequence:

I send the following command to MG. My intention is to reserve all the 4 codecs that this MG can support:

MEGACO/1 [10.11.10.71]:2944 T=707{C=${A=MP1002{M{ST=1{O{MO=SR,RV=OFF,RG=OFF}}},E=6{al/on{strict=failWrong}}},

A=${M{ST=1{O{MO=RC,RV=ON,RG=ON},L{v=0

c=IN IP4 $

m=audio $ RTP/AVP 8 0 4 18 

}}}}}}

I expect a response from MG with local descriptor filled with all these 4 codecs. Bu the response contain only one codec(first in the list I have provided):

MEGACO/1 [10.11.9.83]:2944 P=707{C=1{A=MP1002,A=RTP/1{M{ST=1{L{v=0

c=IN IP4 10.11.9.83

m=audio 4000 RTP/AVP 8}}}}}}

Is this the correct behaviour as per the Megaco RFC ?

Regards,

Rajeev

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 14 May 2002 09:32:41 -0400

The MG could return just one codec if it does not have the resources to
support more.  Here's what the specification says (section 7.1.7):

"If the value of a Reserve property is True, the MG SHALL reserve resources
for all alternatives specified in the local and/or remote descriptors for
which it currently has resources available.  It SHALL respond with the
alternatives for which it reserves resources."

By the way, your context identifier (shown as MP1002) should be all numeric,
the v=0 should come at the beginning of a line, and RG=ON makes no
difference because you show only one session description.

-----Original Message-----
From: Rajeev K R [mailto:[email-masked]]
Sent: Monday, May 13, 2002 10:06 PM
To: Megaco
Subject: [Megaco] Codec Selection

Hi All,
Please clarify the following message Sequence:
I send the following command to MG. My intention is to reserve all the 4
codecs that this MG can support:
MEGACO/1 [10.11.10.71]:2944
T=707{C=${A=MP1002{M{ST=1{O{MO=SR,RV=OFF,RG=OFF}}},E=6{al/on{strict=failWron
g}}},
A=${M{ST=1{O{MO=RC,RV=ON,RG=ON},L{v=0
c=IN IP4 $
m=audio $ RTP/AVP 8 0 4 18 
}}}}}}
I expect a response from MG with local descriptor filled with all these 4
codecs. Bu the response contain only one codec(first in the list I have
provided):
MEGACO/1 [10.11.9.83]:2944 P=707{C=1{A=MP1002,A=RTP/1{M{ST=1{L{v=0
c=IN IP4 10.11.9.83
m=audio 4000 RTP/AVP 8}}}}}}

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 14 May 2002 09:32:41 -0400

-----Original Message-----
From: Rajeev K R [mailto:[email-masked]]
Sent: Monday, May 13, 2002 10:06 PM
To: Megaco
Subject: [Megaco] Codec Selection

Hi All,

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 14 May 2002 09:38:10 -0400

Rajeev meant the second termination, which does have ReserveValue on.

Forget what I said about non-standard context identifier -- my eye skipped
over the $, I guess, and picked up the terminationID.

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Tuesday, May 14, 2002 9:01 AM
To: Rajeev K R
Cc: Megaco
Subject: Re: [Megaco] Codec Selection

Hi, 
If you want the MG to reserve ALL (or, as many as possible) of the codecs,
the ReserveValue MUST be "ON". In your example you use "OFF", which means
that only ONE codec shall be reserved. 
Regards, 
Christer Holmberg 
Ericsson Finland 

Rajeev K R wrote: 
Hi All,