Subject: [Megaco] how to stop detect an Event

From: "derrick.ding" <[email-masked]>
Date: Thu, 30 May 2002 11:35:39 +0800

Hi,Terry！
     I met a problem when MGC stop detecting event, and eager for your help:
     First MGC:
      Context = ${
         Add = T1/1{
           Events = 1{g/sc,aasb/audfail}
                   }
                 }
     after MG reply add OK. 
Now I wanna stop detecting before MG dectect the EVENTS:
I prefer to set event descriptor = NULL:
      Context = 1{
         Mod = T1/1{
           Events = 1{}
                   }
                 }
But encode is failed.

What can I do? to modify the Encode module, but it's bought from trillium.
wait for your reply

Thanks and Best Regards           

***************************************
**** derrick.ding
**** [email-masked]
**** TEL: 0755-6983555-3655
**** Addr:Shenzhen Hi-Tech Industry Park
****      Legend building 3Floor 
****      UTStarCom
**** ZIP: 518057
****************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 30 May 2002 18:23:17 +0530

Hi Ding,
	As per the ABNF grammar in RFC 3015,

   eventsDescriptor     = EventsToken EQUAL RequestID LBRKT
                         requestedEvent *( COMMA requestedEvent ) RBRKT

   requestedEvent       = pkgdName [ LBRKT eventParameter
                          *( COMMA eventParameter ) RBRKT ]

One have to specify atleast one 'requestedEvent', I guess, which implies
one can't specify as you mentioned.

And as per ABNF grammar in the drat 'draft-ietf-megaco-h248v2-00.txt',

 eventsDescriptor  = EventsToken [ EQUAL RequestID LBRKT
                       requestedEvent *( COMMA requestedEvent ) RBRKT ]
    
   requestedEvent       = pkgdName [ LBRKT eventParameter
                          *( COMMA eventParameter ) RBRKT ]

which allows an empty EventsDescriptor. See the brackets ('[' and ']')
present in the production rule of 'eventsDescriptor' that are not present
in RFC 3015, that imply 'optional'(Ref: RFC 2234).

You can change the ABNF grammar, for your Encode & Decode routines to send
an empty eventsdescriptor. And the empty descriptor looks like this..

       Context = 1{
          Mod = T1/1{
            Events
                    }
                  }
but not as
       Context = 1{
          Mod = T1/1{
            Events = 1{}
                    }
                  }
Regds.,
Giri

"derrick.ding" wrote:
> Hi,Terry£¡

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 30 May 2002 18:23:17 +0530

Hi Ding,

    

       Context = 1{
          Mod = T1/1{
            Events
                    }
                  }
but not as
       Context = 1{
          Mod = T1/1{
            Events = 1{}
                    }
                  }
Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,