Subject: [Megaco] question about Mode

From: [email-masked]
Date: Tue, 7 May 2002 10:59:16 -0400

I saw something earlier today that confused me: the fact that signals and
events are not affected by mode. This is in section 7.1.7 Local Control
descriptor.

So what would happen to a termination that was in Receive Only mode, and
which was requested to play an announcement (Signal) towards the exterior
of the context. Then before the announcement finishes, it is Modified into
Send Receive mode?

Regards,
Dave

David Franklin
Principal Software Engineer
Advanced Platforms Group
NMS Communications
[email-masked]
tel. +1.508.271.1038

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 7 May 2002 11:06:00 -0400

The result is certainly not specified.  The MG could choose to pass through
any media flow from the other terminations in the context, thus garbling or
overriding the announcement, or it could give priority to the announcement.
I would say the former action is safer in that it makes MG behaviour more
predictable, and it is up to the MGC to avoid conflicts like this.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 07, 2002 10:59 AM
To: [email-masked]
Subject: [Megaco] question about Mode

Regards,
Dave

David Franklin

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 7 May 2002 11:06:00 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 07, 2002 10:59 AM
To: [email-masked]
Subject: [Megaco] question about Mode

Regards,
Dave

David Franklin