Subject: [Megaco] when rejecting MGs' registration

From: [email-masked]
Date: Mon, 27 May 2002 15:47:45 +0900

Hi, List.

When a MG sends ServiceChange to a specific MGC, 
If the MGC could not accept the MG, and could not provide a secondary MGC,
then,
What Should the MGC do?
  1) do not reply the MG's request
  2) send Send ServiceChangeReply with "MgcId"=it's own id"
  3) any alternatives

thanks in advance.

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 28 May 2002 08:48:53 -0400

The MG may be provisioned with a list of potential MGCs.  
If it doesn't get service from one, try the next.  

Many MGs may have multiple Profiles.  Normally, it would 
attempt to get service at it's most "complex" Profile, 
but it may also support less complex Profiles.
It may choose to run through its list looking for support 
at the "highest" profile, and, failing to find a compatible MGC, 
it might go through the list again with a "lesser" profile.

If it fails to find an MGC to service it, it has to give up.

A Megaco Error message would be problematic, as it has no MGC 
to complain to. Presumably it would have a management system, 
to which it would indicate an error.

Brian
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 27, 2002 2:48 AM
To: [email-masked]
Subject: [Megaco] when rejecting MGs' registration

Hi, List. 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 28 May 2002 08:48:53 -0400

Brian
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 27, 2002 2:48 AM
To: [email-masked]
Subject: [Megaco] when rejecting MGs' registration

Hi, List.

---

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 28 May 2002 14:00:48 -0400

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 27, 2002 2:48 AM
To: [email-masked]
Subject: [Megaco] when rejecting MGs' registration

Hi, List. 
 
[KJBII] I think this is the favorable option.  This helps minimize network-
flooding-type denial of service attacks.  If the MGC were to send
responses, then there are twice the number of messages on the network,
increasing the congestion.  The MG would, after retransmission has
completed with no response, move on to the next MGC in its list.

[KJBII] Sending an error to a known MG is an option, although you must use
caution -- you wouldn't want to extend any (inadvertant) denial of service
attacks by responding to repeated requests.  Although an MG should run
through its list of MGCs, and then wait some period of time before trying
again, there is nothing preventing an MG from having only one MGC in its
list, and having NO waiting period between attempts to come in service.
This would cause the MG to "attack" the MGC, and replying to the messages
would only make the problem worse by adding to network congestion (thereby
extending the "attack" to the entire network).
 
thanks in advance.

---

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 28 May 2002 14:00:48 -0400

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 27, 2002 2:48 AM
To: [email-masked]
Subject: [Megaco] when rejecting MGs' registration

Hi, List. 

 
thanks in advance.