Subject: [Megaco] Residential Gateway

From: "Miao, Kai" <[email-masked]>
Date: Wed, 8 May 2002 12:39:28 -0400

Hello, Everyone,

Does anyone have any information regarding the specific requirements for
tone handling and callerID for a Residential Gateway in the context of
Megaco or MGCP?

Appreciate your help.

Kai Miao
Intel 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle"<[email-masked]>
Date: Wed, 8 May 2002 12:51:19 -0400

In Megaco, Caller ID is provided by the andisp package as defined in
draft-boyle-megaco-alerting-03.  For Megaco tones, there are a several
documents to look in for definitions besides the spec itself (Annex E),
including ITU-T Recommendation Q.1950 and draft-boyle-megaco-tonepkgs-07.

As for requirements on when/how to apply tones and caller ID, you will have
to see the appropriate requirements and standards documents for wherever the
MG will be providing service.  For North America, these are
produced/provided by Telcordia.  ETSI provides some definitions for Europe,
although each country has it's own toneset.  Other localities have their own
regulatory bodies.

Kevin

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 12:39 PM
To: [email-masked]
Subject: [Megaco] Residential Gateway

Hello, Everyone,

Appreciate your help.

Kai Miao
Intel

---

From: "Kevin Boyle"<[email-masked]>
Date: Wed, 8 May 2002 12:51:19 -0400

Kevin

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 12:39 PM
To: [email-masked]
Subject: [Megaco] Residential Gateway

Hello, Everyone,

Appreciate your help.

Kai Miao
Intel

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Thu, 9 May 2002 12:27:00 -0300

You are right, the answer for MGCP is in the basic packages of the RFC 2705,
but I'm not sure how does MEGACO handle Caller ID servcies in residencial
gateway.

I remeber that some mouths ago two drafts were published in the IETF about
alerting packages and tone packages for MEGACO:

draft-boyle-megaco-alerting-02.txt ("Enhanced Alerting Packages for
Megaco/H.248")

draft-boyle-megaco-tonepkgs-06.txt("Supplemental Tones Packages for
Megaco/H.248")
   
Can anyone answer me::
Have these documents became obsolet?.
Will FRC 3015 (or perhaps a new annex) take into account the packages
mencionated in these two document?

> -----Mensaje original-----
> De:	Flemming Andreasen [SMTP:[email-masked]]
> Enviado el:	Jueves 9 de Mayo de 2002 11:25
> Para:	Miao, Kai
> CC:	[email-masked]
> Asunto:	Re: [Megaco] Residential Gateway
> 
> For MGCP, you will find the relevant packages in the "Basic MGCP Packages"
> document
> (http://search.ietf.org/internet-drafts/draft-foster-mgcp-basic-packages-0
> 4.txt).
> In particular, you probably want to take a look at the "Generic Media",
> "DTMF" and "Line" packages.
> 
> -- Flemming
> 
> 
> "Miao, Kai" wrote:
> 
> > Hello, Everyone,
> >

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Thu, 9 May 2002 12:27:00 -0300

Can anyone answer me::

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 9 May 2002 12:42:21 -0400

These will be published as independent RFCs.  The IESG is looking at the
first one now.  The tonepkgs document got bounced on a formatting
technicality and awaits recycling.

-----Original Message-----
From: Pellegrino Jose Luis [mailto:[email-masked]]
Sent: Thursday, May 09, 2002 11:27 AM
To: 'Flemming Andreasen'; Miao, Kai
Cc: [email-masked]
Subject: RE: [Megaco] Residential Gateway

   
Can anyone answer me::

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 9 May 2002 12:42:21 -0400

-----Original Message-----
From: Pellegrino Jose Luis [mailto:[email-masked]]
Sent: Thursday, May 09, 2002 11:27 AM
To: 'Flemming Andreasen'; Miao, Kai
Cc: [email-masked]
Subject: RE: [Megaco] Residential Gateway

   
Can anyone answer me::