Subject: [Megaco] Question related to SG, MGC and MG

From: Xin Chen <[email-masked]>
Date: Wed, 12 Jun 2002 11:07:01 +0100

Hi, 

As a beginner of learning megaco, there are some questions I have in mind.

To my understanding:

The MGC must also be the signalling gateway or have the signalling gateway
function, is it correct?

Do the MGC and MG have to be in the same network (Domain)? Does Megaco
support inter-domain control? What I mean is that can I use Megaco to
control a MG which is not in my domain?

From transcoding's point of view, is it a safe assumption that the
transcoding will be performed in the same network in  which the signalling
gateway resides?

Thanks

Xin Chen
Mobile Network Architecture
Fujitsu Laborratories of Europe
Tel: +44(0)2086064453
E-mail: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 08:49:11 -0400

>The MGC must also be the signalling gateway or have the signalling 
>gateway function, is it correct? 

No, although in most cases the MGC will have at least a connection, via SCTP
to a signalling gateway.  

>control a MG which is not in my domain?
Sure, as long as you can send UDP to it, you can, in theory, control it.
That would not be a good idea unless you had IPsec enabled however.

>transcoding will be performed in the same network in  which the 
>signalling gateway resides?
Transcoding from what to whom?

Usually, when someone talks about transcoding they mean transcoding
the bearer channel and not a signalling channel.  If there is
this kind of transcoding, it would be in the MG and would be enabled
and controlled by the MGC (codec choice in SDP on the local/remote
descriptors).

Brian

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Xin Chen <[email-masked]>
Date: Wed, 12 Jun 2002 14:00:48 +0100

Hi Brian, thanks for the help.

Why does the MGC have to connect the SG via SCTP? Can the MGC terminate the
ISUP/MTP3/MTP2 and directly convert them to SIP/UDP or TCP/IP instead of
using SCTP or M3UA?

Yes, the transcoding I mean is the transcode between RTP/UDP/IP and the
voice truck. It looks that Megaco can also be used between SG and MG, is it
correct?

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: Xin Chen <[email-masked]>
Date: Wed, 12 Jun 2002 14:00:48 +0100

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 12 Jun 2002 08:56:58 -0400

Welcome.  Answers below.

-----Original Message-----
From: Xin Chen [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 6:07 AM
To: [email-masked]'
Subject: [Megaco] Question related to SG, MGC and MG

Hi, 
As a beginner of learning megaco, there are some questions I have in mind. 
To my understanding: 
The MGC must also be the signalling gateway or have the signalling gateway
function, is it correct? 
[PTT]
The signalling gateway function changes the lower layers beneath call
signalling so that signalling can be delivered to the appropriate point in
the IP network.  The MGC has to process the call signalling itself.  It is
thus a function separate from the signalling gateway function.
[/PTT]

Do the MGC and MG have to be in the same network (Domain)? Does Megaco
support inter-domain control? What I mean is that can I use Megaco to
control a MG which is not in my domain?
[PTT]
Megaco is neutral to domains, as far as I know, so long as the necessary
security relationships can be set up.
[/PTT]

From transcoding's point of view, is it a safe assumption that the
transcoding will be performed in the same network in  which the signalling
gateway resides?
[PTT]
The signalling gateway lies on the path of call signalling.  Transcoding
presumably lies in the media path.  I would expect that typically the same
network would be the entry point for both call signalling and media, but may
not always be true.
[/PTT]

Thanks 
Xin Chen

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 12 Jun 2002 09:06:10 -0400

To understand the relative roles of SG, MG, and MGC, I suggest you look at
RFC 2719.  You can get it at
http://www.ietf.org/rfc/rfc2719.txt

It is certainly possible that the SG and MGC functions are in the same box,
so you would get the direct conversion you ask about in your first question.

-----Original Message-----
From: Xin Chen [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 9:01 AM
To: 'Rosen, Brian'; Xin Chen; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 12 Jun 2002 09:06:10 -0400

-----Original Message-----
From: Xin Chen [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 9:01 AM
To: 'Rosen, Brian'; Xin Chen; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 09:14:23 -0400

The SG function can be in the MGC or it can be remote, and connected via
SCTP.  It does not HAVE to be in the MGC, which is what you asked.
Many softswitches do have the SG function remote; that is simply because
it's
often more practical to put the physical interfaces in a chassis that is
not the MGC computer.  Some systems, especially smaller systems, incorporate
the SG function in the MGC.

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 09:14:23 -0400

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 08:49:11 -0400

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 12 Jun 2002 08:56:58 -0400

Welcome.  Answers below.

-----Original Message-----
From: Xin Chen [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 6:07 AM
To: [email-masked]'
Subject: [Megaco] Question related to SG, MGC and MG

Hi, 

Thanks 
Xin Chen

---

From: Xin Chen <[email-masked]>
Date: Thu, 20 Jun 2002 11:09:50 +0100

Dear all,

I know that TRIP can be used to discover a SG, is there any protocol to
discover a MGC?

I am thinking a case that a SIP terminal is calling a PSTN terminal, and the
SIP domain doesn't have MGC, or it has a MGC but it prefers a MGC which is
in other network maybe for saving long distance call charging purpose, so in
this case, how can the SIP domain to find a proper MGC?

I am not sure whether here is the right place to ask this question, if not,
could you plase point to me the right group or right RFC, draft?

Thanks

Xin Chen
Mobile Network Architecture
Fujitsu Laboratories of Europe
Tel: +44(0)2086064453
E-mail: [email-masked]

-----Original Message-----
From: Xin Chen 
Sent: 12 June 2002 14:01
To: 'Rosen, Brian'; Xin Chen; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Usually, when someone talks about transcoding they mean transcoding the
bearer channel and not a signalling channel.  If there is this kind of
transcoding, it would be in the MG and would be enabled and controlled by
the MGC (codec choice in SDP on the local/remote descriptors).

Brian

---

From: Xin Chen <[email-masked]>
Date: Thu, 20 Jun 2002 11:09:50 +0100

Dear all,

Thanks

Xin Chen

-----Original Message-----
From: Xin Chen 
Sent: 12 June 2002 14:01
To: 'Rosen, Brian'; Xin Chen; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 12 June 2002 13:49
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 20 Jun 2002 08:40:43 -0400

ENUM is one answer - put E.164 in, get URL (of SIP proxy server, 
MGC, whatever) out.  It's a pretty good answer in general because 
your example is that the called party is a PSTN terminal, and 
therefore has an E.164.  With ENUM, you still have to route (IP routing) 
to the server.  That server would redirect you to the appropriate 
SIP UA, which would be a gateway in this case.

Brian

> Sent: Thursday, June 20, 2002 6:10 AM
> To: [email-masked]'

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 20 Jun 2002 08:40:43 -0400

Brian

---

From: Xin Chen <[email-masked]>
Date: Thu, 20 Jun 2002 13:59:13 +0100

Thanks Brian,

And if in the case a PSTN calling SIP, ENUM can be used as well. I think in
this case the PSTN provider has to have its own MGC in order to use ENUM to
get the entry of a SIP domain. Is it correct?

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 20 June 2002 13:41
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: Xin Chen <[email-masked]>
Date: Thu, 20 Jun 2002 13:59:13 +0100

Thanks Brian,

Xin Chen

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: 20 June 2002 13:41
To: 'Xin Chen'; [email-masked]'
Subject: RE: [Megaco] Question related to SG, MGC and MG

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 20 Jun 2002 11:25:43 -0400

Sure, where there is an E.164 corresponding to the SIP terminal.
This case is actually more interesting because an aware client could
determine that there were two ways to reach the sip terminal, one
through the PSTN (via an appropriate gateway) and one directly via
sip.  It would choose the sip path if it was capable of doing so,
and believed it could supply acceptable service.

The PSTN provider would have an MGC of some sort.  Of course, that could
be a simple SIP UA in the gateway and a smart proxy server doing ENUM
lookups.  In that case, which device is the "MGC" - the SIP UA or
the SIP Proxy Server?  

You could build the gateway in two parts - the gateway mechanism and
a computer that realized the tens of thousands of UA instances.  If
you did so, you could use Megaco between the parts.  Then the SIP UA
is an MGC, right?  Of course you could also put enough compute 
horsepower in the gateway to realize all those SIP UAs.  Then you don't
have any Megaco.  Is the UA still an MGC?  In either case, the ENUM
aware component is a SIP Proxy Server.  YMMV!

Brian

> Sent: Thursday, June 20, 2002 8:59 AM

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 20 Jun 2002 11:25:43 -0400

Brian