Subject: Fwd: [Megaco] ASN.1 mtpAddress in 3015corr (was Re: [Megaco] draft-ietf-megaco-3015corr-01.txt)

From: Aleksandr Ryabin <[email-masked]>
Date: Fri, 21 Jun 2002 10:06:54 -0400

Hi folks,

         Any comments/pointers on this?

Thanks
         Aleks

>Date: Wed, 19 Jun 2002 18:20:00 -0400
>To: "Tom-PT Taylor" <[email-masked]>, [email-masked]
>From: Aleksandr Ryabin <[email-masked]>
>Subject: [Megaco] ASN.1 mtpAddress in 3015corr (was Re: [Megaco]
>  draft-ietf-megaco-3015corr-01.txt)
>
>Hi,
>
>         Why is ASN.1 definition of mtpAddress in MId differ from the one in
>ServiceChangeAddress? I believe they were the same in corr-00 as well as
>they are the same in v2.
>
>Also there are several ASN.1 vs ABNF inconsistencies below. They are not 
>errors,
>and I know that technically result is the same, but ASN.1 compilers will 
>define two
>completely different entities for each case and a user would have to 
>implement code
>for both of them:
>
>1. There are two different definitions of mtpAddress for ASN.1 for MId
>and ServiceChangeAddress. Shouldn't it be defined once and included in MId
>and ServiceChangeAddress like it is done in ABNF?
>
>2. ASN.1 definitions for both ServiceChangeAddress and MId are defined 
>directly through
>its components (e.g. ipv4address, etc.) while ABNF defines 
>ServiceChangeAddress
>through MId. Shouldn't ASN.1 ServiceChangeAddress also be defined through MId
>like it is done in ABNF?
>
>I understand that it is probably too much trouble to change these in the 
>existing (e.g. v1)
>protocol although it would be nice if it could be changed in next versions.
>
>Thanks
>         Aleks
>
>At 09:51 AM 5/29/2002, you wrote:
>>This draft is now available on the IETF site.  Except as noted in the
>>introduction, it is identical to the prepublished version the ITU-T are
>>putting up on their web site this week.
>>
>>My intention is to give people a few days to look it over, then send it on
>>to the IESG for ratification as a replacement for RFC 3015.
>>
>>I hope to give the same editorial treatment to H.248 v2.  As I indicated
>>earlier, my intention is that this will be a separate RFC of its own, rather
>>than a replacement for 3015corr.  That is consistent with the treatment the
>>ITU-T is providing.
>>
>>Tom Taylor
>>[email-masked]
>>Ph. +1 613 736 0961 (ESN 396 1490)
>>
>>
>>_______________________________________________
>>Megaco mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/megaco
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Fri, 21 Jun 2002 11:14:39 -0400

>> ServiceChangeAddress? I believe they were the same in corr-00 as well as

Looks like a typo.  They're the same in H248v1Corr.pdf too.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Fri, 21 Jun 2002 11:14:39 -0400

-troy