Subject: [Megaco] Transaction Processing

From: "Cooper, Eric" <[email-masked]>
Date: Tue, 11 Jun 2002 13:42:10 -0400

Hi all,

Suppose that the first command in a transaction (containing 2 commands) fails.  It is not marked 'optional'.  

According to section 8, the processing of commands within that transaction stops. 
Also according to section 8, a transaction reply should contain the return values for commands that executed successfully, and the command(s) and error descriptor(s) for commands that failed. 

Is the second command in the transaction deemed to have 'failed'?  If so, what error code should be used?  If not, does that mean that the sender must know that the failure of the first command implies that the second command will never see a response?

Thanks,

Eric Cooper
Mitel Networks.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 11 Jun 2002 23:40:17 -0400

>Is the second command in the transaction deemed to have 'failed'?  If so, what error code should be used?  If not, does that mean that the sender must know that the failure of the first command impl…
All responses for a single transaction must appear in the same message, 
so when the response arrives, MGC knows that the omitted command 
responses will never arrive, because it is must include all responses 
for the transaction and because the last response is an error response.

-- 
-------------------------------------------------------
Terry L Anderson, DMTS                   [email-masked]
Lucent Technologies /INS/ Voice over IP Access Networks
Rm 2B-121,   600 Mountain Ave, Murray Hill, NJ 07974
Voice:908 582-7013  FAX:908 582-6226   Org:18E75000000
http://its.lucent.com/~tla  (Lucent internal)
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 11 Jun 2002 23:40:17 -0400