Subject: [Megaco] When to provide ringback tone?

From: Jose Garcia <[email-masked]>
Date: Wed, 19 Jun 2002 18:44:11 -0700 (PDT)

Hi Megaco experts,
  I have some doubts about translating "normal phone
behavior" to Megaco MG behavior.
  In the call flow examples ringback is applied
immediately to the calling party's termination. But
what if the called party is busy? Will the calling
party get a ringback tone then a busy tone? (I
remember a previous thread on which this behavior was
judged as not good). So then, when should MGC give
ringback tone signal to MG?
  In general I've this confusion about ALL VoIP
protocols. E.g. in SIP, if caller's INVITE gets a 200
OK response instead of 180 RINGING, when will he hear
a ringback at all? 180 RINGING is optional.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "SND Wang JuLin" <[email-masked]>
Date: Thu, 20 Jun 2002 10:41:05 +0800

Hi,
Since MGC maintains a statemachine,it will know the state of the teminating side.
If the called party is busy,MGC will directly tell the orignating side with busy tone signal.
IN a normal case,MGC can send ringback tone  indication either  to orignating side if terminating side is ringing
or to the terminating side to transfer the ringback tone inband.

 best  regards
> :-)Jerry Wang
tel:(8621)58541240 ext 9615
mailto:[email-masked] 
Shanghai Bell Co.LTD

#-----Original Message-----
#From: Jose Garcia [mailto:[email-masked]]
#Sent: Thursday, June 20, 2002 9:44 AM
#To: [email-masked]
#Subject: [Megaco] When to provide ringback tone?
#
#
#Hi Megaco experts,
#  I have some doubts about translating "normal phone
#behavior" to Megaco MG behavior.
#  In the call flow examples ringback is applied
#immediately to the calling party's termination. But
#what if the called party is busy? Will the calling
#party get a ringback tone then a busy tone? (I
#remember a previous thread on which this behavior was
#judged as not good). So then, when should MGC give
#ringback tone signal to MG?
#  In general I've this confusion about ALL VoIP
#protocols. E.g. in SIP, if caller's INVITE gets a 200
#OK response instead of 180 RINGING, when will he hear
#a ringback at all? 180 RINGING is optional.
#
#
#__________________________________________________
#Do You Yahoo!?
#Yahoo! - Official partner of 2002 FIFA World Cup
#http://fifaworldcup.yahoo.com
#
#_______________________________________________
#Megaco mailing list
[email-masked]
#https://www1.ietf.org/mailman/listinfo/megaco
#

---

From: "SND Wang JuLin" <[email-masked]>
Date: Thu, 20 Jun 2002 10:41:05 +0800

Hi,

 best  regards

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Thu, 20 Jun 2002 15:29:07 -0300

Hi José, 

In order to avoid sending ring back tone when the called party is busy, we
must have in mind two questions, specially when the called party is acceded
by a trunking gateway

FIRST.
the ring back tone always must be generated by the destination switch. So
if the called party is busy, no ring back tone will be generated.

SECOND.
Another problem appears: the ring back tone must be able to be
trasnportated, so:
MGC should understand/process (resolve) MEGACO/MGCP commands before the
destination network sends back the ACM Message.
Then, when the called party switch sends back the ACM,  the media connection
is already made, so  the ring back tone can be transported from	the
destination to the calling party by the IP network.
In other case, MGC commands not yet full processed,  may cause the
destination switch send back the ring back tone before the media connection
was established and then the tone will not pass through. Even more, if the
destination suscriber hangs off, he will not be able to talk before the
media connection be completed.

One possible way to do this is as follow:

*	The MGC sends forward the #IAM with the parameter &NAT indicating
"COT in precedent network" (Bit D=1 bit C=0). so the destination switch will
no send back the #ACM. 

*	After sending MODIFY and receiving the replay, the MGC will send
foreward a #COT with &COT indicating <<succefull test>>.
*	The the destination switch will send back the  #ACM.

> -----Mensaje original-----
> De:	Jose Garcia [SMTP:[email-masked]]
> Enviado el:	Miércoles 19 de Junio de 2002 22:44
> Para:	[email-masked]
> Asunto:	[Megaco] When to provide ringback tone?
> 
> Hi Megaco experts,

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Thu, 20 Jun 2002 15:29:07 -0300

Hi José, 

FIRST.

SECOND.