Subject: [Megaco] sending dialled digits info from MGC to MG

From: Jose Garcia <[email-masked]>
Date: Tue, 11 Jun 2002 15:15:20 -0700 (PDT)

Hi,
  I've two MGs 1 & 2 connected to an MGC. No matter
what number is dialled at MG1, MGC asks MG2 to ADD a
TDM and an RTP termination in a context and provides
MG2 with the remote descriptor (of the RTP termination
in MG1). How can MGC inform MG2 what number was
dialled at MG1 by the user?

In other words, in the steps below, I am stuck at step
5.

1. MGC -> MG1: Look for offhook, then collect dialled
digits using digitmap.
2. MG1 to MGC: TDM T1 went offhook, then user dialled
5555555.
3. MGC to MG1: Add T1 and RTP T2 in a context.
4. MG1 to MGC: Done, T2 is using IP address
10.10.10.10 and UDP port 6666 (and codec = G.711 etc)
5. MGC to MG2: <<< Add TDM term $ in a context,
dialled digits were 5555555 >>> and Add RTP term $ in
the same context, remote SDP descriptor = (what MGC
got from MG1 for T2).

I am having trouble for composing command in <<< >>>.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Wed, 12 Jun 2002 10:27:59 -0300

Hi
In the TIPHON archuitecture, usualy MGC doesn't send the digits to
destination MG (MG2), but there are some trunking aplications where you have
asociated  SCN7 links at MG. In those cases, MGC needs to send/receive  SCN7
to/from the MG ( MG2 in the example). So, you should use SCTP (SIGTRAN
working group) and the adecuate adaptation layer (M3UA, M2UA, V5UA, etc) to
send SCN7 from MGC to MG2.

Jose Luis Pellegrino

> -----Mensaje original-----
> De:	Al Varney [SMTP:[email-masked]]
> Enviado el:	Martes 11 de Junio de 2002 20:56
> Para:	[email-masked]
> Asunto:	Re: [Megaco] sending dialled digits info from MGC to MG
> 
> At 03:15 PM 6/11/02 -0700, Jose wrote:
> >Hi,
>     It is rather unusual to ask MG2 to select from ANY TDM circuit to 
> complete the call -- or were you expecting MG2 to use the dialed digits to
> 
> select an appropriate TDM termination?  The latter ("routing the call" in 
> telephony terms) is typically done in the MGC, and a specific TDM 
> termination or termination range ("dallastx/$") is sent by the MGC to MG2.
> 
>     The normal need for dialed digits at MG2 is for signaling to the next 
> switch (MGC/MG) in the connection, and that depends on the type of 
> signaling.  ISUP, PRI, BRI would be out-of-band, R1/R2 MF would use 
> signals/events per an appropriate package.  For example, the R1 package 
> uses the "address" signal with "ds" parameter to express an outpulsed
> digit 
> string, often embedded in a "siezeback" event descriptor.
> 
>     draft-ietf-megaco-callflows-00.txt has several examples.
> 
> Al Varney
> 
>

---

From: Pellegrino Jose Luis <[email-masked]>
Date: Wed, 12 Jun 2002 10:27:59 -0300

Hi

Jose Luis Pellegrino