Subject: Re: [Megaco] how to stop detect an Event

From: Christer Holmberg <[email-masked]>
Date: Tue, 04 Jun 2002 17:21:43 +0300

Hi,

This is probably a bug in the grammar, because in some cases we DO include LBRKT
and RBRKT even if the descriptor itself is empty.

So, my opinion is that either we ALWAYS use LBRKT and RBRKT for ANY kind of empty
descriptor, or we NEVER use LBRKT and RBRKT...

Regards,

Christer Holmberg
Ericsson Finland

Giri Rajasekhar Saladi wrote:

> Hi Ding,
>         As per the ABNF grammar in RFC 3015,
>
>    eventsDescriptor     = EventsToken EQUAL RequestID LBRKT
>                          requestedEvent *( COMMA requestedEvent ) RBRKT
>
>    requestedEvent       = pkgdName [ LBRKT eventParameter
>                           *( COMMA eventParameter ) RBRKT ]
>
> One have to specify atleast one 'requestedEvent', I guess, which implies
> one can't specify as you mentioned.
>
> And as per ABNF grammar in the drat 'draft-ietf-megaco-h248v2-00.txt',
>
>  eventsDescriptor  = EventsToken [ EQUAL RequestID LBRKT
>                        requestedEvent *( COMMA requestedEvent ) RBRKT ]
>
>    requestedEvent       = pkgdName [ LBRKT eventParameter
>                           *( COMMA eventParameter ) RBRKT ]
>
> which allows an empty EventsDescriptor. See the brackets ('[' and ']')
> present in the production rule of 'eventsDescriptor' that are not present
> in RFC 3015, that imply 'optional'(Ref: RFC 2234).
>
> You can change the ABNF grammar, for your Encode & Decode routines to send
> an empty eventsdescriptor. And the empty descriptor looks like this..
>
>        Context = 1{
>           Mod = T1/1{
>             Events
>                     }
>                   }
> but not as
>        Context = 1{
>           Mod = T1/1{
>             Events = 1{}
>                     }
>                   }
> Regds.,
> Giri
>
> "derrick.ding" wrote:
> >
> > Hi,Terry£¡
> >      I met a problem when MGC stop detecting event, and eager for your help:
> >      First MGC:
> >       Context = ${
> >          Add = T1/1{
> >            Events = 1{g/sc,aasb/audfail}
> >                    }
> >                  }
> >      after MG reply add OK.
> > Now I wanna stop detecting before MG dectect the EVENTS:
> > I prefer to set event descriptor = NULL:
> >       Context = 1{
> >          Mod = T1/1{
> >            Events = 1{}
> >                    }
> >                  }
> > But encode is failed.
> >
> > What can I do? to modify the Encode module, but it's bought from trillium.
> > wait for your reply
> >
> > Thanks and Best Regards
> >
> > ***************************************
> > **** derrick.ding
> > **** [email-masked]
> > **** TEL: 0755-6983555-3655
> > **** Addr:Shenzhen Hi-Tech Industry Park
> > ****      Legend building 3Floor
> > ****      UTStarCom
> > **** ZIP: 518057
> > ****************************************
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
>
> --
>
> Giri Rajasekhar Saladi
> HCL Technologies Ltd.,
> 51, Jawaharlal Nehru Road
> Guindy Industrial Estate,
> Ekkatuthangal,
> Chennai - 600 097.
>
> Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
> Fax : +91 44 234 4256
> e-mail : [email-masked] <mailto:[email-masked]>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 04 Jun 2002 17:21:43 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 04 Jun 2002 12:03:44 -0400

It WAS a bug that RFC 3015 did not allow any form of empty events list, but this was fixed through the IG and appears corrected in H.248 Corrigendum and V2 as:

The empty events list is NOT and empty LBRKT RBRKT but also omits the EQUAL and the useless RequestID.  While empty descriptors are sometimes formed from empty LBRKT RBRKT there are reasons for other forms in some places.

-- 

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:732.949.5628   Fax:732.949.7016
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 04 Jun 2002 12:03:44 -0400

--