Subject: [Megaco] AuditValue of DigitMap descriptor -- which format is returned?

From: "David Barr" <[email-masked]>
Date: Tue, 25 Jun 2002 09:28:48 +0100

Hello megaco list,

I have a query regarding what should be returned for AuditValue{DigitMap}.

H.248v1 section 7.2.5 states:
"DigitMapDescriptor returns the name OR value of the current DigitMap for
the Termination."

Does that mean that the MG should not return both the name AND value?

I.e. consider the following:

(1) MGC to MG1:
MEGACO/1 [123.123.123.4]:2944
Transaction = 10001 { 
       Context = - { 
           Modify = A4444 { 
               Events = 2223 { dd/ce {DigitMap=Dialplan0}  }, 
               DigitMap= Dialplan0{ (0| 00|[1-7]xxx) }    
           } 
       } 
}  

(2) MG1 to MGC: 
MEGACO/1 [124.124.124.222]:2944
Reply = 10001 { 
       Context = - {Modify = A4444} 
} 

(3) MGC to MG1
MEGACO/1 [123.123.123.4]:2944
Transaction = 50007 { 
      Context = - {AuditValue = A4444{  
         Audit{DigitMap} 
      }   
} 

What is the response from MG1?  Which of the following:

(4a) MG1 to MGC
MEGACO/1 [125.125.125.111]:55555 
Reply = 50007 { 
      Context = - { AuditValue = A4444 { 
           DigitMap=Dialplan0
             } 
       }     
}

(4b) MG1 to MGC
MEGACO/1 [125.125.125.111]:55555 
Reply = 50007 { 
      Context = - { AuditValue = A4444 { 
           DigitMap=Dialplan0{ (0| 00|[1-7]xxx) }
             } 
       }     
}

Thanks,
David Barr
Nortel Networks

---

From: [email-masked]
Date: Wed, 26 Jun 2002 12:47:17 +0530

Hi David/List,

If only name is returned DigitMapDescriptor, it will lead to ambiguity if two
Digitmaps with same name are defined on ROOT as well as on termination. It will
not be clear which digitmap is active on termination.

Thus in returned DigitMapDescriptor, both name and value should be returned for
clarity.

Thanks N Regards,
Ashish Singh
Hughes Software Systems
www.hssworld.com

"David Barr" <[email-masked]> on 06/25/2002 01:58:48 PM

To:   "[email-masked]'" <[email-masked]>
cc:    (bcc: Ashish Singh/HSS)

Subject:  [Megaco] AuditValue of DigitMap descriptor -- which format is
      returned?

Hello megaco list,

(1) MGC to MG1:

(2) MG1 to MGC:

(3) MGC to MG1

(4a) MG1 to MGC

(4b) MG1 to MGC

Thanks,
David Barr
Nortel Networks

---

From: [email-masked]
Date: Wed, 26 Jun 2002 12:47:17 +0530

Hi David/List,

Thanks N Regards,
Ashish Singh
Hughes Software Systems
www.hssworld.com

Hello megaco list,

(1) MGC to MG1:

(2) MG1 to MGC:

(3) MGC to MG1

(4a) MG1 to MGC

(4b) MG1 to MGC

Thanks,
David Barr
Nortel Networks