Subject: [Megaco] TerminationState: ServiceState in Add command

From: "Chuong N. Nguyen" <[email-masked]>
Date: Tue, 11 Jun 2002 16:10:11 -0500

Hi

The following syntax is allowed by the Standard.

But can MGC tells MG to put a termination to InService w/Add command?

Transaction = 2{ Context = 5 {Add = tdm/1/3 {Media{
            LocalControl {Mode = ReceiveOnly},
            TerminationState {ServiceStates = InService}}}}}

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 11 Jun 2002 20:45:38 -0400

I always knew this was going to come up.  One possibility would be to to
make ServiceStates a read-only property so it can only be changed through a
ServiceChange.  However, this would make it impossible to set ServiceState
to "test".  I think we're stuck with two ways to change state.

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Tuesday, June 11, 2002 5:10 PM
To: [email-masked]
Subject: [Megaco] TerminationState: ServiceState in Add command

Hi 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 11 Jun 2002 20:45:38 -0400

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Tuesday, June 11, 2002 5:10 PM
To: [email-masked]
Subject: [Megaco] TerminationState: ServiceState in Add command

Hi

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 08:43:00 -0400

I think this is one of those things where the syntax may allow it, 
some implementations may implement it, but it's not guaranteed to work.  
So I would say:
    If you are building an MG, you probably should allow it
    If you are building an MGC, you probably shouldn't send it.

Brian
-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Tuesday, June 11, 2002 5:10 PM
To: [email-masked]
Subject: [Megaco] TerminationState: ServiceState in Add command

Hi

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Jun 2002 08:43:00 -0400

Brian
-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Tuesday, June 11, 2002 5:10 PM
To: [email-masked]
Subject: [Megaco] TerminationState: ServiceState in Add command

Hi