Subject: Re: [Megaco] Audit of Events

From: Christian Groves <[email-masked]>
Date: Mon, 03 Jun 2002 14:15:16 +1000

We don't have a correlation mechanism in the protocol between descriptor in a
request and response. So despite being able to return mutliple descriptors the
MGC won't know which response is which. The MG isn't mandated to return every
descriptor that was in the request in order, so the MGC is left to guessing what
it wanted. We have error 448 for a command with 2 or more of the same
descriptors which says to me that there must have bee a reason to add this.

You can already get the flexibility you want by including a Auditvalue command
before the ADD or MOD in the same transaction.

I'm still not sure what practical application there is for auditing a descriptor
and setting it before the MGC has a chance to react on what it requested.

Regards, Christian

Fernando Vallejo Lazaro wrote:
> 
> Hi,
> 
> I don' think so.
> IMO the audit value should be returned in the order it comes in the
> transaction. In this way if you want to know the situation after the
> rest of the descriptors are executed you just need to put it at the end.
> If you prefer to know the situation at the beginning place it on the
> beginning... I think it is more flexible.
> 
> Regards
> Fernando
> 
> 
> 
> Christian Groves wrote:
> 
> > G'Day Tom,
> >
> > My opinion is that the audit value should be executed and returned after all
> > the
> > descriptors are executed. The syntax actually enforces it. You can't have
> > multiple replies of the same descriptor which you would need in the case
> > that
> > the auditvalue is executed first and another descriptor has a wildcard.
> >
> > Regards, Christian
> >
> > Tom-PT Taylor wrote:
> > >
> > > I wonder if other people have an opinion: should the results from an Audit
> >
> > > Descriptor in a non-Audit command depend on it's ordering within the
> > command
> > > parameters?
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Thursday, May 30, 2002 10:49 AM
> > > To: Taylor, Tom-PT [CAR:B602:EXCH]
> > > Cc: [email-masked]
> > > Subject: RE: [Megaco] Audit of Events
> > >
> > > Hi Tom,
> > >
> > > Thanks for the response. U have stated that "The results returned because
> > of
> > > the
> > > Audit descriptor should be those holding AFTER the rest of the command has
> >
> > > been
> > > carried out."
> > >
> > > Would it also holds true in case we have Audit descriptor with Events
> > token
> > > and
> > > Events descriptor without any wildcarded parameters.
> > >
> > > I think in that case placement of Audit descriptor in command will decide
> > > the
> > > returned Events descriptor. If Audit Desc precedes Events Desc, then
> > > returned
> > > Events Desc should contain the events which are active before processing
> > of
> > > current Events desc. If Audit Desc succedes Events Desc, then returned
> > > Events
> > > Desc should contain the events which will be active after processing of
> > > current
> > > Events desc.
> > >
> > > Let me give a small example to be more clear.
> > > Suppose MGC sends 1st Modify Command to the Term T1 in NULL context.
> > >
> > >    Transaction = 10001 {
> > >        Context = - {
> > >            Modify = T1 {
> > >                Events = 2223 { al/on  }
> > >            }
> > >        }
> > >    }
> > >
> > > Now MGC Sends 2nd Modify Command to the same Term T1 in NULL context.
> > >
> > >    Transaction = 10002 {
> > >        Context = - {
> > >            Modify = T1 {
> > >                Audit { Events },
> > >                Events = 2224 { al/of }
> > >            }
> > >        }
> > >    }
> > >
> > > Since Audit descriptor precedes Events descriptor, hence returned Events
> > > descriptor should contain al/on.
> > >
> > > Now MGC Sends 3rd Modify Command to the same Term T1 in NULL context.
> > >
> > >    Transaction = 10003 {
> > >        Context = - {
> > >            Modify = T1 {
> > >                Events = 2225 { al/fl },
> > >                Audit { Events }
> > >            }
> > >        }
> > >    }
> > >
> > > Since Audit descriptor succedes Events descriptor, hence returned Events
> > > descriptor should contain al/fl.
> > >
> > > Pls. correct my understanding on the effect of placement of audit desc in
> > > command.
> > >
> > > Thanks in advance,
> > >
> > > Thanks N Regards
> > > Ashish Singh
> > > Hughes Software Systems
> > > www.hssworld.com
> > >
> > > "Tom-PT Taylor" <[email-masked]> on 05/29/2002 08:05:54 AM
> > >
> > > To:   Ashish Singh/HSS@HSS, [email-masked]
> > > cc:
> > >
> > > Subject:  RE: [Megaco] Audit of Events
> > >
> > > Section 7.2.9 has some text that perhaps sets a precedent here:
> > >
> > > <quote>
> > > The MGC may audit a specific Context to determine the current value of
> > > individual context properties.  The MGC may determine the current values
> > for
> > > all existing (non-NULL) Contexts by specifying ContextID ALL in the Audit
> > > request. If context attributes are added or have been modified by the same
> >
> > > action as the Audit Value request the value/s returned shall be after the
> > > action has been applied.
> > > </quote>
> > >
> > > Conclusion from this precedent is that the results returned because of the
> >
> > > Audit descriptor should be those holding AFTER the rest of the command has
> >
> > > been carried out.  The event returned should be cd/std, with its list of
> > > toneIDs from Annex E.7.3.
> > >
> > > We probably need some text to this effect in section 7.2.1 where the
> > > AuditDescriptor is explained.  We could also put it in section 7.1.12.
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Tuesday, May 28, 2002 10:49 AM
> > > To: [email-masked]
> > > Subject: [Megaco] Audit of Events
> > >
> > > Hi List,
> > >
> > > Suppose MGC sends 1st Modify Command to the Term T1 in NULL context.
> > >
> > >    Transaction = 10001 {
> > >        Context = - {
> > >            Modify = T1 {
> > >                Events = 2223 { al/on  }
> > >            }
> > >        }
> > >    }
> > >
> > > Now MGC Sends 2nd Modify Command to the same Term T1 in NULL context.
> > >
> > >    Transaction = 10002 {
> > >        Context = - {
> > >            Modify = T1 {
> > >                Audit { Events },
> > >                Events = 2224 { cd/std { tl = * }  }
> > >            }
> > >        }
> > >    }
> > >
> > > Now there are two options for Events Descriptor to be returned Modify
> > > Response
> > > to MGC.
> > >
> > > 1) Since Audit descriptor is present before Events descriptor, hence al/on
> >
> > > should be returned in Events descriptor.
> > > 2) Since there is overspecified parameter in Events descriptor, hence
> > cd/std
> > > should be returned with resolved TL parameter.
> > >
> > > Now what should be returned in Events Descriptor in Modify Response to
> > MGC.
> > >
> > > Thanks in advance,
> > >
> > > Thanks N Regards
> > > Ashish Singh
> > > Hughes Software Systems
> > > www.hssworld.com
> > >
> > > DISCLAIMER: This message is proprietary to Hughes Software Systems
> > > Limited (HSS) and is intended solely for the use of the individual
> > > to whom it is addressed. It may contain  privileged or confidential
> > > information  and should not be circulated or used for any purpose other
> > > than for what it is intended. If you have received this message in error,
> > > please notify the originator immediately. If you are not the intended
> > > recipient, you are notified that you are strictly prohibited from using,
> > > copying, altering, or disclosing the contents of this message. HSS accepts
> >
> > > no responsibility for loss or damage arising from the use of the
> > information
> > > transmitted by this email including damage from virus.
> > >
> > > _______________________________________________
> > > Megaco mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/megaco
> > >
> > > _______________________________________________
> > > Megaco mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/megaco
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> 
> --
> Fernando Vallejo Lazaro
> Phone:  +34 91 330 8279
> SW  Wireline ASD-Madrid
>        ALCATEL
> 
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 03 Jun 2002 14:15:16 +1000

Regards, Christian