Subject: RE: [Megaco] version in megaco V2 message header

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 5 Jun 2002 09:23:33 -0400

Registrations require !/1.  All other ServiceChanges use !/2 for version 2
signalling.

Kevin

-----Original Message-----
From: Keshava Murthy K.S. [mailto:[email-masked]]
Sent: Wednesday, June 05, 2002 3:58 AM
To: [email-masked]
Subject: [Megaco] version in megaco V2 message header

What should be the version in megaco message header(!/1 or !/2)
when  MG complying to megaco V2 is sending SVC restart to MGC.

Regards,
Keshav

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 05 Jun 2002 12:26:33 -0400

Just to avoid confusion, let me add a bit more detail.  This is defined 
in 11.3 of H.248v2.  The SC that registers an MG shall use version 1 
encoding (and so use /1 in the header) but may specify version 2 in the 
ServiceChangeVersion of the message.  This allows MGC to choose V2 for 
the relationship if it supports it (returning version 2 in the 
ServiceChangeVersion of the response) or if  MGC does not support V2 it 
returns version 1 in the response.  This allows version negotiation 
between MG MGC.  

-- 

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked] 
Tel:732.949.5628   Fax:732.949.7016 
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 05 Jun 2002 12:26:33 -0400

--