Subject: [Megaco] sending dialled digits info from MGC to MG

From: Jose Garcia <[email-masked]>
Date: Tue, 11 Jun 2002 15:15:20 -0700 (PDT)

Hi,
  I've two MGs 1 & 2 connected to an MGC. No matter
what number is dialled at MG1, MGC asks MG2 to ADD a
TDM and an RTP termination in a context and provides
MG2 with the remote descriptor (of the RTP termination
in MG1). How can MGC inform MG2 what number was
dialled at MG1 by the user?

In other words, in the steps below, I am stuck at step
5.

1. MGC -> MG1: Look for offhook, then collect dialled
digits using digitmap.
2. MG1 to MGC: TDM T1 went offhook, then user dialled
5555555.
3. MGC to MG1: Add T1 and RTP T2 in a context.
4. MG1 to MGC: Done, T2 is using IP address
10.10.10.10 and UDP port 6666 (and codec = G.711 etc)
5. MGC to MG2: <<< Add TDM term $ in a context,
dialled digits were 5555555 >>> and Add RTP term $ in
the same context, remote SDP descriptor = (what MGC
got from MG1 for T2).

I am having trouble for composing command in <<< >>>.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Al Varney <[email-masked]>
Date: Tue, 11 Jun 2002 18:55:53 -0500

>I am having trouble for composing command in <<< >>>.

    It is rather unusual to ask MG2 to select from ANY TDM circuit to 
complete the call -- or were you expecting MG2 to use the dialed digits to 
select an appropriate TDM termination?  The latter ("routing the call" in 
telephony terms) is typically done in the MGC, and a specific TDM 
termination or termination range ("dallastx/$") is sent by the MGC to MG2.

    The normal need for dialed digits at MG2 is for signaling to the next 
switch (MGC/MG) in the connection, and that depends on the type of 
signaling.  ISUP, PRI, BRI would be out-of-band, R1/R2 MF would use 
signals/events per an appropriate package.  For example, the R1 package 
uses the "address" signal with "ds" parameter to express an outpulsed digit 
string, often embedded in a "siezeback" event descriptor.

    draft-ietf-megaco-callflows-00.txt has several examples.

Al Varney

---

From: Al Varney <[email-masked]>
Date: Tue, 11 Jun 2002 18:55:53 -0500

Al Varney

---

From: Jose Garcia <[email-masked]>
Date: Tue, 11 Jun 2002 18:12:42 -0700 (PDT)

Hi Al,
  thanks for your response. The need is for MG2 to
signal dialled digits to the next MG/MGC. It is not
needed to pick ANY TDM circuit, but there may be a $
(as you pointed out, like trunk1/$) 
Also thanks for pointing to
draft-ietf-megaco-callflows-00.txt. I think the
closest example to my case is section 2.10 - Call
between SS7 trunk in TGW and R1 trunk in TGW where MGC
informs the R1 TGW to seize a circuit, get seizeack
from the remote R1 exchange, then apply the address
signal. I don't think MG1 needs to be necessarily an
SS7 TGW, even if it is an RGW, the example message
exchange between MGC and the R1 TGW (MG2 in my case)
will be the same. Correct?

---

From: Jose Garcia <[email-masked]>
Date: Tue, 11 Jun 2002 18:12:42 -0700 (PDT)

Hi Al,