Subject: [Megaco] Question about ServiceChangeAddress

From: Liang Yaosheng <[email-masked]>
Date: Thu, 20 Jun 2002 17:3:9 +0800

Hi,

   In the "Registration" example from "draft-ietf-megaco-callflows-00.txt", MG generates the registration message to the default port of MGC, it also specifies the service change address to which the MGC has to send further messages. MGC also specifies the new transport address so that when MG generates any messages it generates to this address instead of the default transport address for the MGC.
   It seems simple when UDP is used as the protocol transport. But in the TCP case, the existing connection shall be closed, and which side should initiate a new one? Still MG? But the first subsequent message may be sent by MGC. Or shall the address change only apply in UDP case?   

Best Regards,

Liang Yaosheng
Dascom Technology, Beijing

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jun 2002 08:08:15 -0400

The protocol is designed so that an MG does not have to be a TCP server,
just
a client.  Therefore, it is the MG's responsibility to create all TCP
connections.
I suspect it won't be easy to write an MG where it uses one address port for
the registration request, but specifies another in the service change
address,
but it could.

The MGC will probably specify at least a new port in it's response, and
maybe
a new address.  The MG must create a new TCP connection, and presumably
it would always use it's "new" address/port to create that connection.

Brian

> -----Original Message-----
> From: Liang Yaosheng [mailto:[email-masked]]
> Sent: Thursday, June 20, 2002 9:30 PM
> To: [email-masked]
> Subject: [Megaco] Question about ServiceChangeAddress
> 
> 
> Hi,
> 
>    In the "Registration" example from 
> "draft-ietf-megaco-callflows-00.txt", MG generates the 
> registration message to the default port of MGC, it also 
> specifies the service change address to which the MGC has to 
> send further messages. MGC also specifies the new transport 
> address so that when MG generates any messages it generates 
> to this address instead of the default transport address for the MGC.
>    It seems simple when UDP is used as the protocol 
> transport. But in the TCP case, the existing connection shall 
> be closed, and which side should initiate a new one? Still 
> MG? But the first subsequent message may be sent by MGC. Or 
> shall the address change only apply in UDP case?   
> 
> Best Regards,
> 
> Liang Yaosheng

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jun 2002 08:08:15 -0400

Brian

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 10:44:16 -0700

First of all MG always initiates is the thumb rule.
If you refer to previous discussions on this mailing list, if MG is using
TCP as transport, it should not specify service change address. This was
captured in Implementation Guide too.

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

   In the "Registration" example from "draft-ietf-megaco-callflows-00.txt",
MG generates the registration message to the default port of MGC, it also
specifies the service change address to which the MGC has to send further
messages. MGC also specifies the new transport address so that when MG
generates any messages it generates to this address instead of the default
transport address for the MGC.
   It seems simple when UDP is used as the protocol transport. But in the
TCP case, the existing connection shall be closed, and which side should
initiate a new one? Still MG? But the first subsequent message may be sent
by MGC. Or shall the address change only apply in UDP case?   

Best Regards,

Liang Yaosheng

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 10:44:16 -0700

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: [email-masked]
Date: Fri, 21 Jun 2002 23:47:21 +0530

Hi Bharat

I am not aware to which implementation guide you are referring to, but I don't
see any reason why we should such a restriction. There can be implementations
where MG uses different address for sending requests to MGC and different
address for receiving indications from MGC. In this case MG will use the field
ServiceChangeAddress to specify its address.

It is agreed that MG should always initiate connection.

Regards
Vivek Bansal

NGN Group
Hughes Software Systems
Off: 0124-6346666 Extn 3603
www.hssworld.com

"Kaul, Bharat" <[email-masked]> on 06/21/2002 11:14:16 PM

To:   "'Liang Yaosheng'" <[email-masked]>, [email-masked]
cc:    (bcc: Vivek Bansal/HSS)

Subject:  RE: [Megaco] Question about ServiceChangeAddress

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: [email-masked]
Date: Fri, 21 Jun 2002 23:47:21 +0530

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 12:18:32 -0700

Vivek,

If you refer to discussion in Sept 2000 on megaco mailing list, there was a
consensus on MG not having a TCP server (implying that MGC never sets up TCP
connections). And as Brian also indicated the protocol isn't designed liked
that. I had done that addition (along with Christian Groves I think) to the
implementation guide after that discussion. Now, if we have any such
implementations out there, it is their choice and they would run the risk of
interoperability problems.

Also, here is something that I found in section 7.2.8 of H.248-corr1
document. Although it is not phrased like we did in IG but the same spirit
is represented here.

"Note that the use of ServiceChangeAddress is not encouraged.  MGCs and MGs
must be able to cope with the ServiceChangeAddress being either a full
address or just a port number in the case of TCP transports"

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

I am not aware to which implementation guide you are referring to, but I
don't
see any reason why we should such a restriction. There can be
implementations
where MG uses different address for sending requests to MGC and different
address for receiving indications from MGC. In this case MG will use the
field
ServiceChangeAddress to specify its address.

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 12:18:32 -0700

Vivek,

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: [email-masked]
Date: Sat, 22 Jun 2002 01:35:35 +0530

If this is the case then how does MGC  decides to which address he should send
requests to? Are we assuming that the MGC is preconfigured with the transport
address of MG.

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

"Kaul, Bharat" <[email-masked]> on 06/22/2002 12:48:32 AM

To:   Vivek Bansal/HSS@HSS
cc:   "'Liang Yaosheng'" <[email-masked]>, [email-masked]

Vivek,

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 13:49:39 -0700

I am not sure I understand where the issue is. But here is how things work:

MG establishes connection with MGC on the specified port (based on
text/binary encoding). MG and MGC both use the same connection for
communication. 

Protocol wise, when MG establishes connection with MGC, MGC may specify
service change address to MG. MG will be required to establish new
connection to the MGC on the specified address. 

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 1:06 PM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

If this is the case then how does MGC  decides to which address he should
send
requests to? Are we assuming that the MGC is preconfigured with the
transport
address of MG.

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

To:   Vivek Bansal/HSS@HSS

Vivek,

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: [email-masked]
Date: Sat, 22 Jun 2002 01:35:35 +0530

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

To:   Vivek Bansal/HSS@HSS

Vivek,

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 21 Jun 2002 13:49:39 -0700

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 1:06 PM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

To:   Vivek Bansal/HSS@HSS

Vivek,

- Bharat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 21, 2002 11:17 AM
To: Kaul, Bharat
Cc: 'Liang Yaosheng'; [email-masked]
Subject: RE: [Megaco] Question about ServiceChangeAddress

Hi Bharat

Regards
Vivek Bansal

NGN Group
Hughes Software Systems

- Bharat

-----Original Message-----
From: Liang Yaosheng [mailto:[email-masked]]
Sent: Thursday, June 20, 2002 6:30 PM
To: [email-masked]
Subject: [Megaco] Question about ServiceChangeAddress

Hi,

Best Regards,

Liang Yaosheng

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jun 2002 18:11:57 -0400

This is correct, but I think it would be slightly better
to observe that the MGC is LIKELY to send a new PORT.
There are certainly MGCs out there with multiple NICs,
or multiprocessor systems with load balancers that cause
the address to change.  You almost always will get
at least a port change because otherwise the MGC could
only serve on MG at the well-known port.

Of course, the MG could be provisioned with a specific
port which was solely for it to use, but I think most MGC
implementations will listen on the well known port and
respond with a dynamically allocated port for further
communications.

Brian

> From: Kaul, Bharat [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 4:50 PM
> To: [email-masked]'
> "draft-ietf-megaco-callflows-00.txt",
> send further
> transport. But in the

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 Jun 2002 18:11:57 -0400

Brian