Subject: [Megaco] How can MGC detect MG's ring timer expired?

From: 노정민 <[email-masked]>
Date: Wed, 12 Jun 2002 09:29:30 +0900

Hi all.

I'm developing MEGACO Media Gateway.

I was confused about how can MGC detect MG's ring timeout.

When MGC sent ring signal ( "al/ri") to MG then MG start timer and generate ring signal to user.

If ring timer expired then how can MG notify it to MGC?

Or how can MGC detect ring timer expired?

My goal is MGC sent busy tone to calling MG in this case.

------------------------------------------------------------------------------
MG                                                     MGC                                                              MG

--------------------------------> digit 
                                                                ----------------------------------> "al/ri"
                                                                                                                                 |
                                                                                                                                 |
                                                                                                                            ring timer expired
                                                                                                                                 |
                                                             ?   <------------------------------------

cg/bt <----------------------------

---

From: [email-masked]
Date: Wed, 12 Jun 2002 08:32:32 +0530

Hi,

MGC should sent "g/sc" in event descriptor and "al/ri" in signal descriptor with
ADD/MODIFY command to MG.

If the ring timer expired then MG will notify the "g/sc" event with signal Id=
"al/ri" and method= TO to MGC.

regards,
Amaresh

노정민 <[email-masked]> on 06/12/2002 06:59:30 AM

To:   [email-masked]
cc:    (bcc: Amaresh Ram/HSS)

Subject:  [Megaco] How can MGC detect MG's ring timer expired?

Hi all.

When MGC sent ring signal ( "al/ri") to MG then MG start timer and generate ring
signal to user.

MG                                                     MGC
MG

----------------------------------> "al/ri"
|
|
ring timer expired
|
                                                             ?
<------------------------------------