Subject: [Megaco] When to provide ringback tone?

From: Jose Garcia <[email-masked]>
Date: Wed, 19 Jun 2002 18:44:11 -0700 (PDT)

Hi Megaco experts,
  I have some doubts about translating "normal phone
behavior" to Megaco MG behavior.
  In the call flow examples ringback is applied
immediately to the calling party's termination. But
what if the called party is busy? Will the calling
party get a ringback tone then a busy tone? (I
remember a previous thread on which this behavior was
judged as not good). So then, when should MGC give
ringback tone signal to MG?
  In general I've this confusion about ALL VoIP
protocols. E.g. in SIP, if caller's INVITE gets a 200
OK response instead of 180 RINGING, when will he hear
a ringback at all? 180 RINGING is optional.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 20 Jun 2002 10:57:38 -0400

> ringback tone signal to MG?

The flows with the main megaco are just messaging examples.
You'll need to write your own flows to model the PSTN.

You are correct that "immediately" applying ringtone is
problematic.  One might argue that if the called party's
MG is mangaged by the MGC, the MGC always knows whether
the MG is busy or not.  But you might want to consider
glare conditions.

When & how to do ringback will depend on the MGC's access
to the called party.  If the called party is accessed via
a trunking gateway, it might make sense to set up the media
connection and let the call progress tones be heard via the
media stream.

Real world flows will be more complex than the examples.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Thu, 20 Jun 2002 10:57:38 -0400

-troy