Subject: [Megaco] Move command with Mux Descriptor

From: "gokulc" <[email-masked]>
Date: Wed, 7 Aug 2002 18:53:12 +0530

Hi,

If a existing termination needs to be moved with Mux descriptor to a
different context,
then which of the following cases would be logical/valid.

CASE A:
1.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}
Reply with context = 1 and Add = Term1

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}
Reply with context=2 and Add = Term2

3. context =2{
    Move = Term1{
         Mux = H221{T1/ch0, T1/ch1}
     }
}

OR

CASE B:
1.context = ${
    Add = ${
        Mux = H221{T1/ch0, T1/ch1},
        Media{
             stream = 1{...},
             stream = 2{...}
        }
    }
}
Reply with context = 1 and Add = MuxTerm1

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}
Reply with context=2 and Add = Term2

3.context = 2{
      Move = MuxTerm1{
           Mux = H221{T1/ch0, T1/ch1}
      }
}

Thanks
gokul

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 7 Aug 2002 12:59:58 -0400

Case B looks reasonable; Case A looks strange.  I can't readily see an use
case that would let you turn any other termination type into a multiplexing
termination after you move it.

I should note that you don't have to repeat the Mux descriptor on the move
in case B -- it retains its value if it is omitted from the command.

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 9:23 AM
To: [email-masked]
Cc: Taylor, Tom-PT [CAR:B602:EXCH]
Subject: Move command with Mux Descriptor

Hi,

CASE A:
1.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

3. context =2{
    Move = Term1{

OR

CASE B:
1.context = ${
    Add = ${

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

3.context = 2{
      Move = MuxTerm1{

Thanks
gokul

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 7 Aug 2002 12:59:58 -0400

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 9:23 AM
To: [email-masked]
Cc: Taylor, Tom-PT [CAR:B602:EXCH]
Subject: Move command with Mux Descriptor

Hi,

CASE A:
1.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

3. context =2{
    Move = Term1{

OR

CASE B:
1.context = ${
    Add = ${

2.context = ${
    Add = ${
         Media{
	stream = 1{...},
	stream = 2{...}
    }
}

3.context = 2{
      Move = MuxTerm1{

Thanks
gokul