Subject: RE: [Megaco] ABNF TerminationId definition

From: Raphael Tryster <[email-masked]>
Date: Tue, 13 Aug 2002 16:01:47 +0200

Here is something I found in the archive that nobody answered.  In addition
to Steven's questions, for which I would also be interested in the answers,
I am curious about the following:

What is the purpose of the leading "*" in pathNAME?  Following it with NAME
seems to restrict wildcarding in strange ways.  For example:

[email-masked] <mailto:[email-masked]>  is allowed.
abc/[email-masked] <mailto:abc/[email-masked]>  is allowed.
abc/[email-masked] <mailto:abc/[email-masked]>  is allowed.
*/[email-masked] <mailto:*/[email-masked]>  is not allowed.

Can anyone explain the reasoning?

Raphael Tryster

	-----Original Message-----
	From:	Steven Weisz [SMTP:[email-masked]]
	Sent:	Monday, 15 October, 2001 10:53 PM
	To:	[email-masked]'
	Subject:	[Megaco] ABNF TerminationId definition

	Hi List,

		I've taken a close look at the H.248 document and the latest
IG and
	I noticed that the ABNF does not allow TerminationIds in the form

	[email-masked] 

	OR

	[email-masked]

	If you look closely at the ABNF we have:

	; Total length of pathNAME must not exceed 64 chars.
	pathNAME             = ["*"] NAME *("/" / "*"/ ALPHA / DIGIT /"_" /
"$" ) 
	                       ["@" pathDomainName ]

	; ABNF allows two or more consecutive "." although it is meaningless

	; in a path domain name. 
	pathDomainName       = (ALPHA / DIGIT / "*" ) 
	                       *63(ALPHA / DIGIT / "-" / "*" / ".")
	                       
	TerminationID        = "ROOT" / pathNAME / "$" / "*"

	What I'm wondering, are [email-masked] and [email-masked] valid TerminationIds
and the
	ABNF doesn't cover them or are they not allowed.

	Thanks,

	Steven

	_______________________________________________
	Megaco mailing list
	[email-masked]
	http://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Tue, 13 Aug 2002 16:01:47 +0200

Raphael Tryster

	-----Original Message-----
	From:	Steven Weisz [SMTP:[email-masked]]
	Sent:	Monday, 15 October, 2001 10:53 PM
	To:	[email-masked]'
	Subject:	[Megaco] ABNF TerminationId definition

	Hi List,

	[email-masked] 

	OR

	[email-masked]

	; in a path domain name. 

	Thanks,

	Steven