Subject: [Megaco] AuditValue on ALL Context Question

From: Carl Rutter <[email-masked]>
Date: Tue, 13 Aug 2002 09:11:26 -0400

I thought this was a simple one, anyone care to respond?
Thx,
Carl

I need a clarification on the following 2 scenarios:

1) AuditValue ALL Context on a specific Termination(which is in the NULL
Context)
    The reply should be on the ALL context with error 435 right?
2) If the AuditValue was on the ALL Context and the Termination was
wildcarded to 
    say the T1 level(24) and say 21 of the 24 are in the NULL context, 
    Should the reply contain the 3 good replies and 21 435 Errors?  Or am I
missing
    something where you can omitt the 435s?  I ask this because I have seen
flows
    that don't show the 435s.

Thx,
Carl 

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 14 Aug 2002 15:42:19 -0400

Comments inline. [KJBII]

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]] 
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question

[KJBII] Correct.

[KJBII] I don't see any use for returning 3 replies and then an error
(remember, processing halts once an error is detected!)  Also, this might be
only one good response, and an error, or possibly just an error, since the
order of wildcard matching is determined by the MG.  Given that this is the
case, different MGs may have different matching algorithms, and therefore
the reply will not be deterministic from MG to MG.  So, in my opinion, an
error should only be returned if there are NO matching wildcards.
Otherwise, return only the matches.

Thx,
Carl 

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 08:45:56 +0200

Kevin,

I agree with your conclusion, but not with how you reached it.

"If a command contains a wildcarded TerminationID, the command is attempted
with each of the actual TerminationIDs matching the wildcard.  A response
within the TransactionReply is included for each matching TerminationID,
even if one or more instances generated an error.  If any TerminationID
matching a wildcard results in an error when executed, any commands
following the wildcarded command are not attempted".

From the above, it is clear that processing halts after the wildcard, not in
the middle of it, otherwise you could not have more than one instance
generating an error.  So even if you returned errors, the result WOULD be
deterministic.

I agree with your conclusion because auditing all terminations in all
contexts would be pretty useless if the MG returned an error for every
termination in the null context.  I have the impression that the intention
of the standard is to perform set intersection between termination id
(wildcarded or not) and context id, and return an error if the resulting set
is empty.  Of course, this applies only to those commands where the
terminations are expected to be in the context before the command is issued
- Modify, Subtract, and Audit.

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 9:42 PM
	To:	Carl Rutter; [email-masked]
	Cc:	Brad Steinka
	Subject:	RE: [Megaco] AuditValue on ALL Context Question

	Comments inline. [KJBII] 

	-----Original Message----- 
	From: Carl Rutter [ mailto:[email-masked]
<mailto:[email-masked]> ] 
	Sent: Tuesday, August 13, 2002 9:11 AM 
	To: [email-masked] 
	Cc: Brad Steinka 
	Subject: [Megaco] AuditValue on ALL Context Question 

	1) AuditValue ALL Context on a specific Termination(which is in the
NULL 
	Context) 
	    The reply should be on the ALL context with error 435 right? 

	[KJBII] Correct. 

	2) If the AuditValue was on the ALL Context and the Termination was
wildcarded to 
	    say the T1 level(24) and say 21 of the 24 are in the NULL
context, 
	    Should the reply contain the 3 good replies and 21 435 Errors?
Or am I missing 
	    something where you can omitt the 435s?  I ask this because I
have seen flows 
	    that don't show the 435s. 

	[KJBII] I don't see any use for returning 3 replies and then an
error (remember, processing halts once an error is detected!)  Also, this
might be only one good response, and an error, or possibly just an error,
since the order of wildcard matching is determined by the MG.  Given that
this is the case, different MGs may have different matching algorithms, and
therefore the reply will not be deterministic from MG to MG.  So, in my
opinion, an error should only be returned if there are NO matching
wildcards.  Otherwise, return only the matches.

	Thx, 
	Carl 

	Carl Rutter 
	Telica, Inc. 
	Building G, Suite 100 
	734 Forest Street 
	Marlboro, MA 01752 
	Email [email-masked] 
	Voice 508-480-0909 x8178 
	Fax 508-480-0922 
	www.telica.com 

	_______________________________________________ 
	Megaco mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 08:45:56 +0200

Kevin,

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 9:42 PM
	To:	Carl Rutter; [email-masked]
	Cc:	Brad Steinka
	Subject:	RE: [Megaco] AuditValue on ALL Context Question

	Comments inline. [KJBII] 

	-----Original Message----- 

	[KJBII] Correct. 

	Thx, 
	Carl 

	Carl Rutter 
	Telica, Inc. 
	Building G, Suite 100 
	734 Forest Street 
	Marlboro, MA 01752 
	Email [email-masked] 
	Voice 508-480-0909 x8178 
	Fax 508-480-0922 
	www.telica.com

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 08:59:04 +0200

But, if my reading of the standard as I quoted in my hasty reply to Kevin is
correct, there is no option to terminate processing at the first error in a
wildcard.  You will always get all the errors from the wildcard (and
therefore it's a good idea to limit them as Kevin said).  The O- only
affects whether you will process the commands following the wildcard.

Raphael Tryster

	-----Original Message-----
	From:	Ron Stoughton [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 11:53 PM
	To:	Kevin Boyle; Carl Rutter; [email-masked]
	Cc:	Brad Steinka
	Subject:	RE: [Megaco] AuditValue on ALL Context Question

		2) If the AuditValue was on the ALL Context and the
Termination was wildcarded to 
		    say the T1 level(24) and say 21 of the 24 are in the
NULL context, 
		    Should the reply contain the 3 good replies and 21 435
Errors?  Or am I missing 
		    something where you can omitt the 435s?  I ask this
because I have seen flows 
		    that don't show the 435s. 

		[KJBII] I don't see any use for returning 3 replies and then
an error (remember, processing halts once an error is detected!)  Also, this
might be only one good response, and an error, or possibly just an error,
since the order of wildcard matching is determined by the MG.  Given that
this is the case, different MGs may have different matching algorithms, and
therefore the reply will not be deterministic from MG to MG.  So, in my
opinion, an error should only be returned if there are NO matching
wildcards.  Otherwise, return only the matches.

		This is contrary to what other people have said on this
thread -- e.g., see recent message from Christer Holmberg regarding "Context
= * { ServiceChange = DS1/3/1/* }" which requests a service change for all
timeslots on a particular DS1 interface.  It was his opinion that an error
should be returned for the first matching termination encountered which is
in the null context, and if the MG did not want the MGC to terminate
processing at the first error, the MG should set the command optional --
i.e., "O-ServiceChange".
		 
		There needs to be a clear understanding on this, and I think
the understanding is far from clear at this stage.
		 
		Ron Stoughton
		[email-masked] <mailto:[email-masked]>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 08:59:04 +0200

Raphael Tryster

	-----Original Message-----
	From:	Ron Stoughton [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 11:53 PM
	To:	Kevin Boyle; Carl Rutter; [email-masked]
	Cc:	Brad Steinka
	Subject:	RE: [Megaco] AuditValue on ALL Context Question

		 
		 
		Ron Stoughton

---

From: Carl Rutter <[email-masked]>
Date: Thu, 15 Aug 2002 10:13:45 -0400

OK,
 
The gray area here is 

I like what Raph stated that 

"I agree with your conclusion because auditing all terminations in all
contexts would be pretty useless if the MG returned an error for every
termination in the null context.  "

This does seem silly.  I guess the only thing I'm struggling with on this is
why is it apprpraite to send the

435 in the single Audit case and not in the Wildcarded Termination  "O-"
case?

Carl

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 2:46 AM
To: Kevin Boyle; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	BM__MailData-----Original Message----- 

	Comments inline. [KJBII] 

	-----Original Message-----
From: Carl Rutter [  <mailto:[email-masked]> mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question 

	[KJBII] Correct. 

	Thx,
Carl 

	Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922
www.telica.com

---

From: Carl Rutter <[email-masked]>
Date: Thu, 15 Aug 2002 11:41:37 -0400

Interesting viewpoint,
I could live with this explanation if there are no objections.
 
One question:
Say all of the wildcarded terminations are in the NULL.
Then the reply wouldn't have anything in it, right?
 
Carl
-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 11:19 AM
To: Carl Rutter; 'Raphael Tryster'; Kevin Boyle; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Hi,

        I might be wrong here, but if you view termination ID wildcard
matching as matching
against terminations that are not in NULL context (that is 3 in your case)
and not against all
terminations on MG that can possibly match given wildcard (that is 24 in
your case) then 
reply with 3 good audits is the only option since no error occurred. While
in case of a single
termination ID it will not match any of these 3 terminations and thus you
will get an error.

If you view it like that then there is no gray area, and the only reason MGC
would want to
put -O is if more commands follow after that AuditValue and MGC wants them
to be 
executed even if all terminations (on that T1) are in NULL context.

Just my two cents.
        Aleks.

At 10:13 AM 8/15/2002, Carl Rutter wrote:

OK,
 
The gray area here is 

Carl

-----Original Message-----
From: Raphael Tryster [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Thursday, August 15, 2002 2:46 AM
To: Kevin Boyle; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	BM__maildata-----Original Message----- From:   Kevin Boyle
[SMTP:[email-masked]] Sent:  Wednesday, 14 August, 2002 9:42 PM
To:    Carl Rutter; [email-masked] Cc:    Brad Steinka Subject:       RE:
[Megaco] AuditValue on ALL Context Question 

Comments inline. [KJBII] -----Original Message----- From: Carl Rutter [
<mailto:[email-masked]> mailto:[email-masked]] Sent: Tuesday, August
13, 2002 9:11 AM To: [email-masked] Cc: Brad Steinka Subject: [Megaco]
AuditValue on ALL Context Question I thought this was a simple one, anyone
care to respond? Thx, Carl I need a clarification on the following 2
scenarios: 1) AuditValue ALL Context on a specific Termination(which is in
the NULL Context)     The reply should be on the ALL context with error 435
right? [KJBII] Correct. 2) If the AuditValue was on the ALL Context and the
Termination was wildcarded to     say the T1 level(24) and say 21 of the 24
are in the NULL context,     Should the reply contain the 3 good replies and
21 435 Errors?  Or am I missing     something where you can omitt the 435s?
I ask this because I have seen flows     that don't show the 435s. [KJBII] I
don't see any use for returning 3 replies and then an error (remember,
processing halts once an error is detected!)  Also, this might be only one
good response, and an error, or possibly just an error, since the order of
wildcard matching is determined by the MG.  Given that this is the case,
different MGs may have different matching algorithms, and therefore the
reply will not be deterministic from MG to MG.  So, in my opinion, an error
should only be returned if there are NO matching wildcards.  Otherwise,
return only the matches. Thx, Carl 

Carl Rutter Telica, Inc. Building G, Suite 100 734 Forest Street Marlboro,
MA 01752 Email [email-masked] Voice 508-480-0909 x8178 Fax 508-480-0922
www.telica.com <http://www.telica.com/>  

_______________________________________________ Megaco mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 15 Aug 2002 16:56:02 -0400

Commands, by definition, act on a term in a context (whether that be a
"real" context, or NULL).  If the term specified is not in the context
specified, then the command fails, and an error is returned.  So, that means
that contextID plays an important role in wildcarded termIDs.
 
For example, this:
 
T=1{C=1{SC=*{...}}}
 
would only match termIDs that actually exist in context 1.  In the same way,
this:
 
T=1{C=*{SC=*{...}}}
 
would only match termIDs that are not in NULL.
 
I don't see the perceived inconsistency.  If a term is not in the context,
then don't reply for it.  If there are NO terms in the context (or, no
matching terms in the context), then return an error.  But let's not return
one positive reply and 23 errors for a T1, just because the command is
trying to isolate one or two active members.
 
Kevin

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]] 
Sent: Thursday, August 15, 2002 4:30 PM
Cc: [email-masked]
Subject: Re: [Megaco] AuditValue on ALL Context Question

I agree w/what Aleksandr is saying. 

But now I am confused as to what caused Carl to ask the question in the
first place. 
I just read the July discussion on this topic. 
Wasn't this discussed in July "Wildcarded Action Reply"? 

From Alek's responses in July. 

If we are to be consistent across all the commands and say that we match 
"both" (that is context and termination) then a reply to command with 
wildcarded termination and wildcarded context will never contain error 431 
except the case when there are no matches at all. 

I am wondering if the confusion was due to single termination as Carl said
plus ServiceChange usage of wildcard 
as indicated by Ron using Christer Holmberg's email or nothing has been
officially put into the text. 

Or taking individual paragraphs out of the Standard and combining these
paragraphs to come up 
w/an interpretation are leading to some different interpretation? 
For example. 

Section 6.2.2 TerminationIDs 

   A wildcarding mechanism using two types of wildcards can be used with 
   TerminationIDs. The two wildcards are ALL and CHOOSE. The former is 
   used to address multiple Terminations at once, 

   When ALL is used in the TerminationID of a command, the effect is 
   identical to repeating the command with each of the matching 
   TerminationIDs. 

This section does not mention anything about contextId. 

Do the above wordings imply that terminationId wildcarding is a way to
compact the same commands 
into a single command (the very original driver behind having wildcard at
command level)? 

Thus it is not about defining how to use wildcard to match something. 

So should we define how terminationId or contextId wildcarding for each
command should be interpretated? 
It is done for AuditValue. 
--- 

The following text for AuditValue does clearly indicated - attempt
(executation of cmd??) is only 
made for matching terminationId. 

Section 7.2.5 AuditValue 

If the wildcard matches 
   more than one TerminationID, all possible matches are attempted, with 
   results reported for each one. 

Also the following example given in this section (3015corr), does imply that
error is not returned. 
But terminationId in NULL is not used. 
Should we expand the example to include terminationId in NULL. 
   The command: 

     Context=*{AuditValue=t2/*{Audit{Packages}}} 

   Returns: 

     Context=1{AuditValue=t2/1{Packages{ccc,ddd}}}, 
     Context=2{AuditValue=t2/2{Packages{ccc,ddd}}} 

But the following (also in this section) seems to imply that contextId is
not used at all. 
(Unless there is already a correction for this statement) 

DigitMap requested in an AuditValue command with 
   TerminationID ALL returns all DigitMaps in the gateway 

If someone wants to do the above, what contextId should be used? 
The above wording implied that the contexId does not matter. 
Thus it doesn't matter whether the contextId is NULL, ALL or specific??? 

Aleksandr Ryabin wrote: 

 No, actually since no terminations match then MGC should get "no match" 431
error. 
This is basically the same ether you give a wildcard termination, or a
single 
termination and thus consistent. The only diff is an error number: 431 "no
match" for 
wildcard termination audit and 435 "not in ctx" for single termination
audit. 

Aleks 

At 11:41 AM 8/15/2002, Carl Rutter wrote: 

Interesting viewpoint, 

One question: 

Carl 
-----Original Message----- 
From: Aleksandr Ryabin [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, August 15, 2002 11:19 AM 
To: Carl Rutter; 'Raphael Tryster'; Kevin Boyle; [email-masked] 
Cc: Brad Steinka 
Subject: RE: [Megaco] AuditValue on ALL Context Question 

Hi, 

I might be wrong here, but if you view termination ID wildcard matching as
matching 

Just my two cents. 
Aleks. 

OK, 

The gray area here is 

Carl

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 15 Aug 2002 16:56:02 -0400

For example, this:
 
T=1{C=1{SC=*{...}}}

T=1{C=*{SC=*{...}}}

 
Kevin

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]] 
Sent: Thursday, August 15, 2002 4:30 PM
Cc: [email-masked]
Subject: Re: [Megaco] AuditValue on ALL Context Question

Section 7.2.5 AuditValue 

If the wildcard matches 

   Returns: 

  

Aleksandr Ryabin wrote: 

Aleks 

Interesting viewpoint, 

One question: 

Carl 
-----Original Message----- 

Hi, 

Just my two cents. 
Aleks. 

OK, 

The gray area here is 

Carl

---

From: Carl Rutter <[email-masked]>
Date: Thu, 15 Aug 2002 17:04:39 -0400

I think the inconsistency in my mind is if you
did an AuditValue on the ALL context for a single termination
that would be an error 435.

If did the same O-AuditValue on a Wildcard inwhich that termination
was included you wouldn't report the error.

I agree it doesn't make sense to send back 23 etc errors.
I just wanted to make sure we weren't ignoring something here.

Thx,
Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 4:56 PM
To: Chuong N. Nguyen; [email-masked]
Subject: RE: [Megaco] AuditValue on ALL Context Question

For example, this:
 
T=1{C=1{SC=*{...}}}

T=1{C=*{SC=*{...}}}

 
Kevin

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]] 
Sent: Thursday, August 15, 2002 4:30 PM
Cc: [email-masked]
Subject: Re: [Megaco] AuditValue on ALL Context Question

Section 7.2.5 AuditValue 

If the wildcard matches 

   Returns: 

  

Aleksandr Ryabin wrote: 

Aleks 

Interesting viewpoint, 

One question: 

Carl 
-----Original Message----- 

Hi, 

Just my two cents. 
Aleks. 

OK, 

The gray area here is 

Carl

---

From: Carl Rutter <[email-masked]>
Date: Thu, 15 Aug 2002 17:04:39 -0400

Thx,
Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 4:56 PM
To: Chuong N. Nguyen; [email-masked]
Subject: RE: [Megaco] AuditValue on ALL Context Question

For example, this:
 
T=1{C=1{SC=*{...}}}

T=1{C=*{SC=*{...}}}

 
Kevin

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]] 
Sent: Thursday, August 15, 2002 4:30 PM
Cc: [email-masked]
Subject: Re: [Megaco] AuditValue on ALL Context Question

Section 7.2.5 AuditValue 

If the wildcard matches 

   Returns: 

  

Aleksandr Ryabin wrote: 

Aleks 

Interesting viewpoint, 

One question: 

Carl 
-----Original Message----- 

Hi, 

Just my two cents. 
Aleks. 

OK, 

The gray area here is 

Carl

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 26 Aug 2002 22:13:43 -0400

I'm afraid the intention when we drafted this text was that each iteration
of the wildcarded command was a "command" for purposes of the stopping rule.
Thus the first error would terminate execution unless the "O-" override was
present.

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 2:46 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	Comments inline. [KJBII] 

	-----Original Message-----
From: Carl Rutter [  <mailto:[email-masked]> mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question 

	[KJBII] Correct. 

	Thx,
Carl 

	Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922
www.telica.com

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 26 Aug 2002 22:13:43 -0400

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 2:46 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	Comments inline. [KJBII] 

	-----Original Message-----
From: Carl Rutter [  <mailto:[email-masked]> mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question 

	[KJBII] Correct. 

	Thx,
Carl 

	Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922
www.telica.com

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 28 Aug 2002 11:55:02 +0200

Tom,

Of the 3 sentences in the paragraph I quoted, it is possible to qualify the
first two by saying that they apply only when O- was specified.  But this
cannot be said of the third sentence:

"If any TerminationID matching a wildcard results in an error when executed,
any commands following the wildcarded command are not attempted".

Since O- applies to the whole wildcard, if execution of the rest of the
wildcard continued in spite of an error, then the command following the O-
wildcard SHOULD be executed.

It seems to me that either the text or the intention needs to be amended.

Raphael Tryster

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Tuesday, 27 August, 2002 4:14 AM
	To:	'Raphael Tryster'; Kevin Boyle; Carl Rutter; [email-masked]
	Cc:	Brad Steinka
	Subject:	RE: [Megaco] AuditValue on ALL Context Question

	I'm afraid the intention when we drafted this text was that each
iteration
	of the wildcarded command was a "command" for purposes of the
stopping rule.
	Thus the first error would terminate execution unless the "O-"
override was
	present.

	-----Original Message-----
	From: Raphael Tryster [mailto:[email-masked]]
	Sent: Thursday, August 15, 2002 2:46 AM
	To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
	Cc: Brad Steinka
	Subject: RE: [Megaco] AuditValue on ALL Context Question

	Kevin, 

	"If a command contains a wildcarded TerminationID, the command is
attempted
	with each of the actual TerminationIDs matching the wildcard.  A
response
	within the TransactionReply is included for each matching
TerminationID,
	even if one or more instances generated an error.  If any
TerminationID
	matching a wildcard results in an error when executed, any commands
	following the wildcarded command are not attempted".

	From the above, it is clear that processing halts after the
wildcard, not in
	the middle of it, otherwise you could not have more than one
instance
	generating an error.  So even if you returned errors, the result
WOULD be
	deterministic.

	I agree with your conclusion because auditing all terminations in
all
	contexts would be pretty useless if the MG returned an error for
every
	termination in the null context.  I have the impression that the
intention
	of the standard is to perform set intersection between termination
id
	(wildcarded or not) and context id, and return an error if the
resulting set
	is empty.  Of course, this applies only to those commands where the
	terminations are expected to be in the context before the command is
issued
	- Modify, Subtract, and Audit.

	Raphael Tryster 

		Comments inline. [KJBII] 

		-----Original Message-----
	From: Carl Rutter [  <mailto:[email-masked]>
mailto:[email-masked]]
	Sent: Tuesday, August 13, 2002 9:11 AM
	To: [email-masked]
	Cc: Brad Steinka
	Subject: [Megaco] AuditValue on ALL Context Question 

		1) AuditValue ALL Context on a specific Termination(which is
in the
	NULL
	Context)
	    The reply should be on the ALL context with error 435 right? 

		[KJBII] Correct. 

Termination was
Or am I
have seen

		[KJBII] I don't see any use for returning 3 replies and then
an
	error (remember, processing halts once an error is detected!)  Also,
this
	might be only one good response, and an error, or possibly just an
error,
	since the order of wildcard matching is determined by the MG.  Given
that
	this is the case, different MGs may have different matching
algorithms, and
	therefore the reply will not be deterministic from MG to MG.  So, in
my
	opinion, an error should only be returned if there are NO matching
	wildcards.  Otherwise, return only the matches.

		Thx,
	Carl 

		Carl Rutter
	Telica, Inc.
	Building G, Suite 100
	734 Forest Street
	Marlboro, MA 01752
	Email [email-masked]
	Voice 508-480-0909 x8178
	Fax 508-480-0922
	www.telica.com

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 28 Aug 2002 11:55:02 +0200

Tom,

Raphael Tryster

	-----Original Message-----
	From: Raphael Tryster [mailto:[email-masked]]
	Sent: Thursday, August 15, 2002 2:46 AM
	To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
	Cc: Brad Steinka
	Subject: RE: [Megaco] AuditValue on ALL Context Question

	Kevin, 

	Raphael Tryster 

		Comments inline. [KJBII] 

		-----Original Message-----

		[KJBII] Correct. 

		Thx,
	Carl 

		Carl Rutter
	Telica, Inc.
	Building G, Suite 100
	734 Forest Street
	Marlboro, MA 01752
	Email [email-masked]
	Voice 508-480-0909 x8178
	Fax 508-480-0922
	www.telica.com

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 30 Aug 2002 02:47:04 -0400

What I said below is correct, but may have caused confusion with the
resolution of this thread.  I should have read everything first -- always
the old dilemma about how to catch up.  Aleks' interpretation is correct --
no errors because the terminationIDs in the NULL context do not match the
query.

-----Original Message-----
From: Taylor, Tom-PT [CAR:B602:EXCH] 
Sent: Monday, August 26, 2002 10:14 PM
To: 'Raphael Tryster'; Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter;
[email-masked]
Cc: Brad Steinka

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 2:46 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	Comments inline. [KJBII] 

	-----Original Message-----
From: Carl Rutter [  <mailto:[email-masked]> mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question 

	[KJBII] Correct. 

	Thx,
Carl 

	Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922
www.telica.com

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 30 Aug 2002 02:47:04 -0400

-----Original Message-----
From: Taylor, Tom-PT [CAR:B602:EXCH] 
Sent: Monday, August 26, 2002 10:14 PM
To: 'Raphael Tryster'; Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter;
[email-masked]
Cc: Brad Steinka

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 2:46 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Carl Rutter; [email-masked]
Cc: Brad Steinka
Subject: RE: [Megaco] AuditValue on ALL Context Question

Kevin, 

Raphael Tryster 

	Comments inline. [KJBII] 

	-----Original Message-----
From: Carl Rutter [  <mailto:[email-masked]> mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 9:11 AM
To: [email-masked]
Cc: Brad Steinka
Subject: [Megaco] AuditValue on ALL Context Question 

	[KJBII] Correct. 

	Thx,
Carl 

	Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922
www.telica.com