Subject: RE: [Megaco] Statistics and Move

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 6 Aug 2002 13:52:06 -0400

But, in theory you could audit for statistics while in the NULL context.  In
that particular instance, I believe the MG should return 0 for all
statistics, since there are none being kept.  The packages are still
realized, so the statistics still "exist" on the termination, they just have
nothing recorded.

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Sunday, August 04, 2002 10:03 PM
To: Terry L Anderson
Cc: Megaco Mailing List
Subject: Re: [Megaco] Statistics and Move

G'Day Terry,

I think your updated text is an improvement.

I'm not sure statistics are something that should be counted in a NULL
context.
Certainly you can't rely on a subtract from the NULL context returning
statistics.... its not allowed.

Regards, christian

> >>7.1.5:
> >>The Statistics parameter provides information describing the status and
> >>usage of a Termination during its existence [REPLACE: "within a specific
> >>Context", WITH: "outside the null context"].  There is a set of standard
> >>
> >>
> >
> >[CHG] "Outside the null context" is not correct for euphemeral
terminations. Why
> >not just strike "within a specific context"?
> >
> Well, I'm trying to insure the language covers both cases, but perhaps
> my choice still wasn't perfect.  Just striking it, might make it appear
> that it continues even after a physical termination returns to null,
> since it really still "exists".  That's why said "outside the null
> context".  I believe that even ephemerals are "outside the null context"
> they are just never "inside", but I am open to other wording such as:
>     "...during its existence (ephemeral) or while it is outside the null
> context (physical)."
> 
> Do we have another issue here?  What is the proper behavior if
> statistics are requested of a termination IN the null context?  From
> this description it would appear that it has none.  I do not see a
> proper error code.  Does MG simply return 0 for all statistics?
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Tue, 27 Aug 2002 12:09:00 +0200

Hi all,

Regarding the silence suppression:
Is there any solution adopted?
As far as I know there are several posibilities:

a)

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 96
a=rtmap:96 G729D
a=fmtp:96 annexb=yes
}}}

b)

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=SilenceSupp:on
}}}

c) new version of tdmc

Media={Stream=1{
LocalControl { tdmc/ss = on}}}

Can anybody take the lead here?

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Tue, 27 Aug 2002 12:09:00 +0200

Hi all,

a)

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 96
a=rtmap:96 G729D
a=fmtp:96 annexb=yes
}}}

b)

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=SilenceSupp:on
}}}

c) new version of tdmc

Media={Stream=1{

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL