Subject: RE: [Megaco] Reverse polarity

From: Martin Taylor <[email-masked]>
Date: Thu, 22 Aug 2002 09:16:07 -0400

Fernando

In specifying the signals in the xal package, we tried to stay consistent
with the style that was used in other packages concerned with legacy line
types, for example the CAS trunk packages, where the signals and events are
defined in terms of service-related functions rather than physical line
conditions.  The idea is to minimize the amount of knowledge that the MGC
has to have about physical line signaling conditions, which tend to vary a
lot from one region to another, and to provision this knowledge in the MG.

Can you tell us more about the service function that your proposed reverse
polarity signal is intended to perform?  If the xal package is missing an
important service capability for analog lines then of course we want to
cover it.

Martin

==============
Martin Taylor
CopperCom
3600 FAU Blvd
Boca Raton, FL 33431
561 239 6694

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 3:55 AM
To: [email-masked]
Subject: [Megaco] Reverse polarity

Hi all, 
Is there any signal which implies a reverse polarity on the line? 
I think xal/las is not valid because has another meaning. 
A signal could be added like the following in draft-taylor-megaco-enhalpkgs:

      Line Polarity 
  
      SignalID: lp (0x000?) 
  
      Force a change in the polarity of the line of the user. 
  
      Signal Type: Boolean 
      Possible Values: 
            "reverse" (reverse the polarity of the line) 
            "normal"  (set the polarity to the normal state) 
      The default is "normal" 
      Defined In: LocalControlDescriptor. 
      Additional Parameters: None 
Regards 
Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL
  
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Aug 2002 09:34:59 -0400

This is not the intent of this package, and you will have a lot of work
ahead of you if you do not already support the andisp package to implement
it.  Remember, you cannot pick and choose pieces of packages.  You have to
implement entire packages.
 
It sounds like you are trying to implement cutoff on disconnect.  If you are
trying to indicate that the far end has disconnected, then there is an
existing signal in the xal package for this (xal/nd).  What the MG actually
does upon receipt of the request is up to the MG, and would be provisioned
per local requirements (whether it's removal of voltage, or tip/ring
reversal, or whatever).
 
Kevin

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Friday, August 23, 2002 3:02 AM
To: Martin Taylor
Cc: [email-masked]
Subject: Re: [Megaco] Reverse polarity

Hi, 

In some countries some services require a reversal 
on the polarity of the line, e.g. the answer machines. 
So who should be in charge of applying it to the line? 
From my point of view it should be the MGC which 
knows much more about the profile of the user. 
Why should the MG apply this signal without command 
of the MGC? Isn't this a contradiction? 

In any case I was told that there is a signal which 
covers this signal: andisp/data{tas=lr}. 

Thanks 
Fernando 

Martin Taylor wrote: 

Fernando 

Martin 

============== 
Martin Taylor 
CopperCom 
3600 FAU Blvd 
Boca Raton, FL 33431 
561 239 6694 

-----Original Message----- 
From: Fernando Vallejo Lazaro [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, August 22, 2002 3:55 AM 
To: [email-masked] 
Subject: [Megaco] Reverse polarity 

Hi all, 

      Line Polarity 

      SignalID: lp (0x000?) 

      Signal Type: Boolean 
      Possible Values: 

-- 
Fernando Vallejo Lazaro 
Phone:  +34 91 330 8279 
SW  Wireline ASD-Madrid 
       ALCATEL 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco> 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Aug 2002 09:34:59 -0400

Kevin

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Friday, August 23, 2002 3:02 AM
To: Martin Taylor
Cc: [email-masked]
Subject: Re: [Megaco] Reverse polarity

Hi, 

Thanks 
Fernando 

Martin Taylor wrote: 

Fernando 

Martin 

============== 
Martin Taylor 
CopperCom 
3600 FAU Blvd 
Boca Raton, FL 33431 
561 239 6694 

-----Original Message----- 

Hi all, 

      Line Polarity 

      SignalID: lp (0x000?) 

      Signal Type: Boolean 
      Possible Values: 

-- 
Fernando Vallejo Lazaro 
Phone:  +34 91 330 8279 
SW  Wireline ASD-Madrid 
       ALCATEL 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

---

From: Al Varney <[email-masked]>
Date: Fri, 23 Aug 2002 10:20:49 -0500

>per local requirements (whether it's removal of voltage, or tip/ring

    Background:  Polarity reversal is used (in the USA) in some specialized 
line signaling.  One instance is in a PBX or Key System interface -- 
polarity is reversed if a call from the PBX is a "toll call" (toll alerting 
feature).  This allows the PBX to drop the call if the calling phone/caller 
does not have toll-call privileges.  (The PBX thus does not have to have a 
call rating table.  This is probably used less in today's telecom marketplace.)

    Another case is a feature that reverses polarity when the called party 
goes on-hook.  This action normally does not disconnect a call, but starts 
a timer allowing the called party to pick up another phone (or recover from 
dropping the handset on the switchhook).  (ITU-T Recommendation Q.118 
suggests the delayed disconnect treatment on clear-back signals, which is 
what the network generates to report called-party on-hook to the 
originating exchange.)

    Telemarketing and automated calls are applications that benefit from 
quickly recognizing called-party on-hook, often mandated to disconnect ASAP 
from such an occurrence.  Absent this signal, the called party will not be 
able to originate a new call until the caller disconnects, or a 10-16 
second clear-back timer expires.

    Note that this signal is NOT the same as the open interval generated to 
indicate the local exchange has disconnected the line from a call.  In some 
cases, this interval only occurs at the called-party end.  A forced 
disconnect at the calling-party end might only result in an announcement, 
followed by receiver-off-hook tone.

    So -- unless a lot of "feature knowledge" is embedded in the MG, it 
might be useful for an MGC to have low-level control over both "open" and 
"polarity reversal" states.  These correspond directly to a couple of 
signals/commands in the GR-303 (and V5.2?) digital loop carrier 
interfaces.  So at least packages designed to control MGs with those 
interfaces will need explicit Megaco signals.

Al Varney

---

From: Al Varney <[email-masked]>
Date: Fri, 23 Aug 2002 10:20:49 -0500

Al Varney