Subject: RE: [Megaco] Doubt on package extension

From: Raphael Tryster <[email-masked]>
Date: Wed, 14 Aug 2002 17:45:55 +0200

Hello Tom and list,

The concept of toneId seems to be introduced by the way in the package
section of the standard, and I have a few questions related to the
discussion below.

1.	Are "dtmfgen",  "playtone" and "toneidList" valid ABNF long forms of
"dg", "pt" and "tl", or were they used just for readability in the email?

2.	What is the scope of a toneId? Is it global (and therefore d0,cw is
correct syntax) or local to the package (and therefore it should be dg/d0,
cg\cw)?

3.	Depending on the previous answer, is it permitted/required to use
pkgdName syntax for tone Ids in a list?  If so, why is the only valid value
of tonedet/std (tl = *) and not tonedet/std (tl = */*)?

Raphael Tryster

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Wednesday, 30 January, 2002 4:07 PM
	To:	'Usha Iyer'; [email-masked]
	Subject:	RE: [Megaco] Doubt on package extension

	Assuming DTMFgen defines d0 as both a signal and a toneId, and
similarly for
	cw in callProgToneGen, then either B or C is valid.

	-----Original Message-----
	From: Usha Iyer [mailto:[email-masked]]
	Sent: Wednesday, January 30, 2002 3:01 AM
	To: [email-masked]
	Subject: [Megaco] Doubt on package extension

	Hi ,
	 
	DTMF Gen and Call ProgressToneGen pkg both extend tone gen package .

	So for a termination that supports ToneGen, DTMFGen and Call
ProgToneGen Pkg
	, suppose i want to play d0 follwed by call  waiting tone , which of
the
	foll apply . 
	 
	A - tonegen/playtone(toneid list= d0,cw ) 
	B -dtmfgen/playtone(toneid list= d0 )  followed by
	callprogtonegen/playtone(toneid list= cw )
	C -dtmfgen/d0 followed by callprogtonegen/cw 

	Reg
	Usha

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 14 Aug 2002 17:45:55 +0200

Hello Tom and list,

Raphael Tryster

	-----Original Message-----
	From: Usha Iyer [mailto:[email-masked]]
	Sent: Wednesday, January 30, 2002 3:01 AM
	To: [email-masked]
	Subject: [Megaco] Doubt on package extension

	Hi ,

	 

	Reg
	Usha

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 14 Aug 2002 16:01:10 -0400

I do not understand how we can allow making base packages understand values
in extension packages.  That means that an implementation must potentially
understand extensions that it doesn't use.

The only reason I can come up with is that playtone is nearly useless
without the ability to use values defined in other packages.
Newpkg/pt{tl=(Newpkgtone, otherpkgtone)} would be illegal unless toneIDs
defied the normal package hierarchy guidelines.  Luckily for us, SignalList
allows the same functionality.  Some might argue that SignalList is better,
because the signal parms (like duration) can be redefined on the fly with
SignalList, but can't with playtone.

ToneIDs and pkgdName are two different things.  Cg/cw is the pkgdName, but
cw is the toneID.  Also, there are no alternate forms for package items.  I
believe the author of the email used them for readability.

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Wednesday, August 14, 2002 11:46 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Usha Iyer'; [email-masked]
Subject: RE: [Megaco] Doubt on package extension

Hello Tom and list, 
The concept of toneId seems to be introduced by the way in the package
section of the standard, and I have a few questions related to the
discussion below.
Are "dtmfgen",  "playtone" and "toneidList" valid ABNF long forms of "dg",
"pt" and "tl", or were they used just for readability in the email? 

What is the scope of a toneId? Is it global (and therefore d0,cw is correct
syntax) or local to the package (and therefore it should be dg/d0, cg\cw)? 

Depending on the previous answer, is it permitted/required to use pkgdName
syntax for tone Ids in a list?  If so, why is the only valid value of
tonedet/std (tl = *) and not tonedet/std (tl = */*)? 

Raphael Tryster 
-----Original Message----- 
From:   Tom-PT Taylor [SMTP:[email-masked]] 
Sent:   Wednesday, 30 January, 2002 4:07 PM 
To:     'Usha Iyer'; [email-masked] 
Subject:        RE: [Megaco] Doubt on package extension 
Assuming DTMFgen defines d0 as both a signal and a toneId, and similarly for

-----Original Message----- 
From: Usha Iyer [mailto:[email-masked]] 
Sent: Wednesday, January 30, 2002 3:01 AM 
To: [email-masked] 
Subject: [Megaco] Doubt on package extension 

Hi , 
  
DTMF Gen and Call ProgressToneGen pkg both extend tone gen package .  
So for a termination that supports ToneGen, DTMFGen and Call ProgToneGen Pkg

, suppose i want to play d0 follwed by call  waiting tone , which of the 
foll apply . 

Reg 
Usha

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 14 Aug 2002 16:01:10 -0400

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Wednesday, August 14, 2002 11:46 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Usha Iyer'; [email-masked]
Subject: RE: [Megaco] Doubt on package extension

Hello Tom and list, 

Raphael Tryster 

-----Original Message----- 
From: Usha Iyer [mailto:[email-masked]] 
Sent: Wednesday, January 30, 2002 3:01 AM 
To: [email-masked] 
Subject: [Megaco] Doubt on package extension 

Hi , 

  

Reg 
Usha

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 09:25:24 +0200

See [FSRT] inline.

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 10:01 PM
	To:	Raphael Tryster; Tom-PT Taylor; 'Usha Iyer'; [email-masked]
	Subject:	RE: [Megaco] Doubt on package extension

	I do not understand how we can allow making base packages understand
values in extension packages.  That means that an implementation must
potentially understand extensions that it doesn't use.

	The only reason I can come up with is that playtone is nearly
useless without the ability to use values defined in other packages.
Newpkg/pt{tl=(Newpkgtone, otherpkgtone)} would be illegal unless toneIDs
defied the normal package hierarchy guidelines.

	[FSRT] Does your phrasing imply that the Megaco community has not
yet decided whether it is legal or not and what the correct syntax is?

	  Luckily for us, SignalList allows the same functionality.  Some
might argue that SignalList is better, because the signal parms (like
duration) can be redefined on the fly with SignalList, but can't with
playtone.

	[FSRT] I was wondering why we need playtone if we have SignalList.
The only advantage I can see with tonegen/pt is the ability to specify
inter-signal duration.  The tone lists in tonedet do seem to provide finer
control than regular events. 

	ToneIDs and pkgdName are two different things.  Cg/cw is the
pkgdName, but cw is the toneID.  

	[FSRT] Are you saying that the package name MUST be omitted in a
toneId?  Does this imply a prohibition on other packages defining signals
whose names clash with a toneId?

	Also, there are no alternate forms for package items.  I believe the
author of the email used them for readability.

	Kevin 

	-----Original Message----- 
	From: Raphael Tryster [ mailto:[email-masked]
<mailto:[email-masked]> ] 
	Sent: Wednesday, August 14, 2002 11:46 AM 
	To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Usha Iyer'; [email-masked] 
	Subject: RE: [Megaco] Doubt on package extension 

	Hello Tom and list, 
	The concept of toneId seems to be introduced by the way in the
package section of the standard, and I have a few questions related to the
discussion below.

	Are "dtmfgen",  "playtone" and "toneidList" valid ABNF long forms of
"dg", "pt" and "tl", or were they used just for readability in the email? 

	What is the scope of a toneId? Is it global (and therefore d0,cw is
correct syntax) or local to the package (and therefore it should be dg/d0,
cg\cw)? 

	Depending on the previous answer, is it permitted/required to use
pkgdName syntax for tone Ids in a list?  If so, why is the only valid value
of tonedet/std (tl = *) and not tonedet/std (tl = */*)? 

	Raphael Tryster 
	-----Original Message----- 
	From:   Tom-PT Taylor [SMTP:[email-masked]] 
	Sent:   Wednesday, 30 January, 2002 4:07 PM 
	To:     'Usha Iyer'; [email-masked] 
	Subject:        RE: [Megaco] Doubt on package extension 
	Assuming DTMFgen defines d0 as both a signal and a toneId, and
similarly for 
	-----Original Message----- 
	From: Usha Iyer [ mailto:[email-masked]
<mailto:[email-masked]> ] 
	Sent: Wednesday, January 30, 2002 3:01 AM 
	To: [email-masked] 
	Subject: [Megaco] Doubt on package extension 

	Hi , 

	  

	Reg 
	Usha 
	  
	_______________________________________________ 
	Megaco mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 15 Aug 2002 09:25:24 +0200

See [FSRT] inline.

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 14 August, 2002 10:01 PM
	To:	Raphael Tryster; Tom-PT Taylor; 'Usha Iyer'; [email-masked]
	Subject:	RE: [Megaco] Doubt on package extension

	Kevin 

	-----Original Message----- 

	Hello Tom and list, 

	Raphael Tryster 
	-----Original Message----- 
	From:   Tom-PT Taylor [SMTP:[email-masked]] 
	Sent:   Wednesday, 30 January, 2002 4:07 PM 
	To:     'Usha Iyer'; [email-masked] 
	Subject:        RE: [Megaco] Doubt on package extension 
	Assuming DTMFgen defines d0 as both a signal and a toneId, and
similarly for 
	-----Original Message----- 

	Hi , 

	  

	Reg 
	Usha

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 26 Aug 2002 22:21:11 -0400

I am processing my mail backlog in sequence, so maybe this has been
answered.  toneIds are parameter values, not signals, events, properties, or
statistics.  Hence they are used without a preceding package name.  HOWEVER,
if the toneID is defined in package X, then the invocation of playtone is as
a signal in package X (i.e. X/playtone{ <toneId> } ).  Thus the normal
package inheritance rules apply.  It is not that support of the basic tone
package implies support of all toneIDs, but support of a toneID implies
support of the basic tone package as inherited into the package defining the
toneID.

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 3:25 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Raphael Tryster; Taylor, Tom-PT
[CAR:B602:EXCH]; 'Usha Iyer'; [email-masked]
Subject: RE: [Megaco] Doubt on package extension

See [FSRT] inline. 
Raphael Tryster 
-----Original Message----- 
From:   Kevin Boyle [SMTP:[email-masked]] 
Sent:   Wednesday, 14 August, 2002 10:01 PM 
To:     Raphael Tryster; Tom-PT Taylor; 'Usha Iyer'; [email-masked] 
Subject:        RE: [Megaco] Doubt on package extension 
I do not understand how we can allow making base packages understand values
in extension packages.  That means that an implementation must potentially
understand extensions that it doesn't use.
The only reason I can come up with is that playtone is nearly useless
without the ability to use values defined in other packages.
Newpkg/pt{tl=(Newpkgtone, otherpkgtone)} would be illegal unless toneIDs
defied the normal package hierarchy guidelines.
[FSRT] Does your phrasing imply that the Megaco community has not yet
decided whether it is legal or not and what the correct syntax is?
  Luckily for us, SignalList allows the same functionality.  Some might
argue that SignalList is better, because the signal parms (like duration)
can be redefined on the fly with SignalList, but can't with playtone.
[FSRT] I was wondering why we need playtone if we have SignalList.  The only
advantage I can see with tonegen/pt is the ability to specify inter-signal
duration.  The tone lists in tonedet do seem to provide finer control than
regular events. 
ToneIDs and pkgdName are two different things.  Cg/cw is the pkgdName, but
cw is the toneID.  
[FSRT] Are you saying that the package name MUST be omitted in a toneId?
Does this imply a prohibition on other packages defining signals whose names
clash with a toneId?
Also, there are no alternate forms for package items.  I believe the author
of the email used them for readability. 
Kevin 

-----Original Message-----
From: Raphael Tryster [ mailto:[email-masked]]
Sent: Wednesday, August 14, 2002 11:46 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Usha Iyer'; [email-masked]
Subject: RE: [Megaco] Doubt on package extension 

Hello Tom and list,
-----Original Message-----
From: Usha Iyer [ mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 3:01 AM
To: [email-masked]
Subject: [Megaco] Doubt on package extension 

Hi ,

Reg
Usha

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 26 Aug 2002 22:21:11 -0400

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 3:25 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; Raphael Tryster; Taylor, Tom-PT

See [FSRT] inline. 
Raphael Tryster 

-----Original Message-----
From: Raphael Tryster [ mailto:[email-masked]]
Sent: Wednesday, August 14, 2002 11:46 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Usha Iyer'; [email-masked]
Subject: RE: [Megaco] Doubt on package extension 

Hello Tom and list,
-----Original Message-----
From: Usha Iyer [ mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 3:01 AM
To: [email-masked]
Subject: [Megaco] Doubt on package extension 

Hi ,

Reg
Usha