Subject: RE: [Megaco] Reverse polarity

From: Martin Taylor <[email-masked]>
Date: Thu, 22 Aug 2002 09:16:07 -0400

Fernando

In specifying the signals in the xal package, we tried to stay consistent
with the style that was used in other packages concerned with legacy line
types, for example the CAS trunk packages, where the signals and events are
defined in terms of service-related functions rather than physical line
conditions.  The idea is to minimize the amount of knowledge that the MGC
has to have about physical line signaling conditions, which tend to vary a
lot from one region to another, and to provision this knowledge in the MG.

Can you tell us more about the service function that your proposed reverse
polarity signal is intended to perform?  If the xal package is missing an
important service capability for analog lines then of course we want to
cover it.

Martin

==============
Martin Taylor
CopperCom
3600 FAU Blvd
Boca Raton, FL 33431
561 239 6694

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 3:55 AM
To: [email-masked]
Subject: [Megaco] Reverse polarity

Hi all, 
Is there any signal which implies a reverse polarity on the line? 
I think xal/las is not valid because has another meaning. 
A signal could be added like the following in draft-taylor-megaco-enhalpkgs:

      Line Polarity 
  
      SignalID: lp (0x000?) 
  
      Force a change in the polarity of the line of the user. 
  
      Signal Type: Boolean 
      Possible Values: 
            "reverse" (reverse the polarity of the line) 
            "normal"  (set the polarity to the normal state) 
      The default is "normal" 
      Defined In: LocalControlDescriptor. 
      Additional Parameters: None 
Regards 
Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL
  
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Fri, 23 Aug 2002 09:02:07 +0200

Hi,

In some countries some services require a reversal
on the polarity of the line, e.g. the answer machines.
So who should be in charge of applying it to the line?
From my point of view it should be the MGC which
knows much more about the profile of the user.
Why should the MG apply this signal without command
of the MGC? Isn't this a contradiction?

In any case I was told that there is a signal which
covers this signal: andisp/data{tas=lr}.

Thanks
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Fri, 23 Aug 2002 09:02:07 +0200

Hi,

Thanks
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Troy Cauble <[email-masked]>
Date: Fri, 23 Aug 2002 08:58:36 -0400

One could make a similar argument for the open-open signal as described in
Telcordia GR-505-CORE and GR-506-CORE.

In an MG I support, I've applied open-open in response to subtractRequest,
but that makes certain assumptions about how the MGC is doing release-timing.
(See Telcordia GR-505-CORE section 5 and GR-506-CORE section 13 for
release-timing info.)

-troy

---

From: Troy Cauble <[email-masked]>
Date: Fri, 23 Aug 2002 08:58:36 -0400

-troy