Subject: [Megaco] In the transaction reply..

From: "hmask" <[email-masked]>
Date: Thu, 10 Oct 2002 11:17:25 +0900

How about do it this situation..?

MGC send this transaction to MG. And MG process this transaction.

      +----------------------------------------------------------+ 
      | Transaction x                                                                               | 
      |  +------------------------------------------------------+  | 
      |  | Action 1                                                                                 |  | 
      |  | +----------+  +----------+  +----------+  +----------+   |  | 
      |  | | Command |  | Command |  | Command |  | Command |  |  | 
      |  | |    1            |  |    2            |  |    3            |  |    4            |  |  | 
      |  | +----------+  +----------+  +----------+  +----------+   |  | 
      |  +------------------------------------------------------+  | 

MG process Command1,2,3. But, It takes a long time to process Command 4.

In this situation, does MG can separate transaction reply?

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 10 Oct 2002 09:25:17 -0400

No separate reply.  A transaction has to be executed and replied as a unit.

-----Original Message-----
From: hmask [mailto:[email-masked]] 
Sent: Wednesday, October 09, 2002 10:17 PM
To: [email-masked]
Subject: [Megaco] In the transaction reply..

      | Transaction x
| 
      |  | Action 1
|  | 
      |  | |    1            |  |    2            |  |    3            |  |
4            |  |  | 

In this situation, does MG can separate transaction reply?
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 10 Oct 2002 16:25:48 +0200

You can save yourself the trouble of predicting how long the command will
take, by simply sending a provisional response whenever a set amount of time
has passed since the command was received, and you have not yet sent a final
response.

Raphael Tryster

	-----Original Message-----
	From:	Anil Jangam [SMTP:[email-masked]]
	Sent:	Thursday, 10 October, 2002 4:11 PM
	To:	[email-masked]
	Cc:	'hmask'; Tom-PT Taylor
	Subject:	Re: [Megaco] In the transaction reply..

	However in this case, MG may send a provisional response
(transaction
	pending) to the MGC before sending the actual response just to make
sure
	that MGC does not retransmit the message.

	I have one doubt: What are the factors/threshold which will decide
that a
	given command is going to take a long time to execute??

	/anil.

	----- Original Message -----
	From: "Tom-PT Taylor" <[email-masked]>
	To: "'hmask'" <[email-masked]>; <[email-masked]>
	Sent: Thursday, October 10, 2002 7:13 PM
	Subject: RE: [Megaco] In the transaction reply..

	> No separate reply.  A transaction has to be executed and replied
as a
	unit.
	>       |  | |    1            |  |    2            |  |    3
|
	|

	*********************************************************
	Disclaimer

	This message (including any attachments) contains 
	confidential information intended for a specific 
	individual and purpose, and is protected by law. 
	If you are not the intended recipient, you should 
	delete this message and are hereby notified that 
	any disclosure, copying, or distribution of this
	message, or the taking of any action based on it, 
	is strictly prohibited.

	*********************************************************
	Visit us at http://www.mahindrabt.com

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 10 Oct 2002 16:25:48 +0200

Raphael Tryster

	-----Original Message-----
	From:	Anil Jangam [SMTP:[email-masked]]
	Sent:	Thursday, 10 October, 2002 4:11 PM
	To:	[email-masked]
	Cc:	'hmask'; Tom-PT Taylor
	Subject:	Re: [Megaco] In the transaction reply..

	/anil.

	----- Original Message -----
	From: "Tom-PT Taylor" <[email-masked]>
	To: "'hmask'" <[email-masked]>; <[email-masked]>
	Sent: Thursday, October 10, 2002 7:13 PM
	Subject: RE: [Megaco] In the transaction reply..

as a
	unit.
|
	|

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 10:25:26 -0400

Yes, it is applicable when multiple actions are present in the transaction.
And there is explicit language in the specification to say that transactions
sent grouped in a single message may be replied in separate messages.

> From: Anil Jangam [mailto:[email-masked]] 
> Sent: Friday, October 11, 2002 7:19 AM
> To: Taylor, Tom-PT [CAR:B602:EXCH]
> Cc: [email-masked]
> Hi Tom,
> Is this rule applicable when there are multiple actions 
> received in the given transaction request?? aLso can I send 
> each transaction in seperate message, when all the 
> transaction requests have come together in one message?
> 
> /anil.
> 
> > No separate reply.  A transaction has to be executed and 
> replied as a
> unit.
> >
> > MG process Command1,2,3. But, It takes a long time to 
> process Command 
> > 4.
> >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 10:25:26 -0400