Subject: [Megaco] Service change graceful

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Tue, 08 Oct 2002 16:13:49 +0200

Hi all,

Imagine we have a Termination in conversation in a certain context.
Then the operator decides to put the user out of service after the
conversation.

The MG may send a ServiceChange (graceful, delay=0).
When the conversation has finished the MGC sends a Subtract.

Now,

Does the MG need to send another ServiceChange or
can we consider that from the moment it has returned to the
NULL context is out of service?

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 8 Oct 2002 10:35:45 -0400

I believe your second alternative holds: the termination is out of service
already and no second ServiceChange need be sent.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Tuesday, October 08, 2002 10:14 AM
To: Megaco
Subject: [Megaco] Service change graceful

Hi all, 
  
-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL  
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 8 Oct 2002 11:22:27 -0400

I think you have to send a ServiceChange (Restart) to undo the first one.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Tuesday, October 08, 2002 10:45 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: Megaco
Subject: Re: [Megaco] Service change graceful

Hi, 
And what happens if the operator decides to 
put the termination in service again before the user has finished the
conversation? 
Do we have to send a ServiceChange (Restart) during the call, 
or at the end of the call...? Is there any way to undo the ServiceChange
(Graceful)? 

Thanks 
Fernando 
  
Tom-PT Taylor wrote: 
-----Original Message----- 
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Tuesday, October 08, 2002 10:14 AM 
To: Megaco 
Subject: [Megaco] Service change graceful 
Hi all,

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 8 Oct 2002 11:22:27 -0400

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Tuesday, October 08, 2002 10:45 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: Megaco
Subject: Re: [Megaco] Service change graceful

Hi, 

Thanks 
Fernando 
  
Tom-PT Taylor wrote: 
-----Original Message----- 
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Tuesday, October 08, 2002 10:14 AM 
To: Megaco 
Subject: [Megaco] Service change graceful 
Hi all,

---

From: "Nejat Ilhan" <[email-masked]>
Date: Tue, 8 Oct 2002 18:37:45 +0300

It is stated in  Megaco/H.248 Call flow examples document that by the time the subtract is received by MG, the termination is out-of-service.
 
I think MGC realizes the subtract of termination when it gets subtract response from MG.
 
Sincerely
 
Nejat ILHAN
Telenity Inc.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Tuesday, October 08, 2002 5:14 PM
To: Megaco
Subject: [Megaco] Service change graceful

Hi all, 

Now, 

Regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

---

From: "Nejat Ilhan" <[email-masked]>
Date: Tue, 8 Oct 2002 18:37:45 +0300

Sincerely
 
Nejat ILHAN
Telenity Inc.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]]
Sent: Tuesday, October 08, 2002 5:14 PM
To: Megaco
Subject: [Megaco] Service change graceful

Hi all, 

Now, 

Regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

---

From: Susumu YAMAMOTO <[email-masked]>
Date: Wed, 09 Oct 2002 19:11:53 +0900

Hi all,

If the network between a MGC and a MG fails and the graceful message for
some terminations from the MG is lost, how can the MGC knows after the
connection recovered that the terminations are to be in out-of-service
after the conversation?

I think that the only thing what the MGC can do is to audit the all terminations
after the network restored, but no parameters or properties of the terminations
indicate to be in out-of-service gracefully.

So, I think the MG should re-send the ServiceChange message with forced
method after the conversation end, and take the status of the termination to
be out-of-service after subtraction from the MGC.

Please let me know if my idea is wrong.

Regards,
Susumu

---
>It is stated in  Megaco/H.248 Call flow examples document that by the time 
>the subtract is received by MG, the termination is out-of-service.
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 10 Oct 2002 17:32:26 -0400

Comments inline. [KJBII]

-----Original Message-----
From: Susumu YAMAMOTO [mailto:[email-masked]] 
Sent: Thursday, October 10, 2002 1:05 AM
To: Megaco
Subject: Re: [Megaco] Service change graceful

Hi,

I think that the MG send Disconnected message for the lost messages, then
the MGC audit to re-synchronize the state of the MG and all the
terminations. The former possibility does not seems to fit good for the
MEGACO.

[KJBII] The MG does not send Disconnected because a message was lost.  That
is why we have retransmission.  Disconnected is sent upon re-establishment
of a lost CONNECTION.  The MG could detect the connection loss in several
ways, but I would not classify loss of a single message as loss of
connection.

So, I think that the latter one would be better choice. The MGC should be
able to audit all of the states of the MG and the terminations.

[KJBII] We already have a problem reconciling the state of the ServiceStates
parameter with effects of ServiceChange commands.  I do not think it wise to
add a FOURTH (not third) state to the parameter, at least until some
reconciliation between ServiceStates and ServiceChange can occur.

Then, what about lost of the graceful message with ROOT ?
The MGC also cannot audit the state of the MG shutting down after all the
conversations end.

[KJBII] If the MG has shut down, and the MGC sends it a message, the MG can
either ignore the message, or send an error.  The MGC can then deduce that
the MG is out of service.

Regards,
Susumu

---
>Hi,
>
>There are, at least, two possibilities:
>
>1) If the ServiceChange Graceful is lost the MG can
>detect it and therefore it can resend it when the communication with 
>the MGC is recovered. This avoids sending it in any case.
>
>2) A third state can be created for the TerminationState: "shutting 
>down". Meaning that the termination is waiting for a timeout (due to a 
>ServiceChange Graceful) or for the end of the conversation to be out of 
>service. I don't know if this has been discussed before.
>
>comments are welcome
>
>Regards
>Fernando
>
>Susumu YAMAMOTO wrote:
>>Hi all,
>>
>>If the network between a MGC and a MG fails and the graceful message 
>>for some terminations from the MG is lost, how can the MGC knows after 
>>the connection recovered that the terminations are to be in 
>>out-of-service after the conversation?
>>
>>So, I think the MG should re-send the ServiceChange message with 
>>forced method after the conversation end, and take the status of the 
>>termination to be out-of-service after subtraction from the MGC.
>>
>> >It is stated in  Megaco/H.248 Call flow examples document that by 
>> >the time the subtract is received by MG, the termination is 
>> >out-of-service.
>> >
>> >From: Fernando Vallejo Lazaro
>> [<mailto:[email-masked]>mailto:Fernando.Vallejo_L
>> [email-masked]]
>>
>> >can we consider that from the moment it has returned to the NULL 
>> >context is out of service?
>> >
>> >Regards
>> >Fernando
>> >
>> >--
>> >Fernando Vallejo Lazaro
>> >Phone:  +34 91 330 8279
>> >SW  Wireline ASD-Madrid
>> >        ALCATEL
>> >
>>
>><https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/m
>>ailman/listinfo/megaco
>
>--
>Fernando Vallejo Lazaro
>Phone:  +34 91 330 8279
>SW  Wireline ASD-Madrid
>        ALCATEL
>

-*-*-*-
SUSUMU YAMAMOTO, NTT Corporation

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 10 Oct 2002 17:32:26 -0400

Comments inline. [KJBII]

-----Original Message-----
From: Susumu YAMAMOTO [mailto:[email-masked]] 
Sent: Thursday, October 10, 2002 1:05 AM
To: Megaco
Subject: Re: [Megaco] Service change graceful

Hi,

Regards,
Susumu

---

-*-*-*-