Subject: [MEGACO] Which error to send when trying to ring while off-hook?

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 10 Oct 2002 11:17:09 +0200

Hello

When MG gets a ring command (i.e al/ri) but the hook state is off-hook, which would be the correct error code to return? The closest I have found is 540 (UNEXPECTED INITIAL HOOK STATE) but this was defined for the detection of hook state with 'FailWrong' parameter.

Nurit

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 10 Oct 2002 14:13:45 +0200

Hi

Case 1 solves the ringing while off hook, but there are also the cases that the MG gets a command to play CPT and the phone is on-hook. You can say that the same rule apply - add an al/on event with strict=failwrong. But I think that the gateway should return some error even if the on-hook or off-hook events were not part of the message.
I don't agree that the MGC is unaware of the hook state, as this drives the MGC state machine. So if the MGC sent an illegal command, like ringing while off-hook or CPT while on-hook, the MG should reply with an error. And again the question is: Which error?

Nurit

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Thursday, October 10, 2002 2:07 PM
To: Nurit Shenhar
Cc: [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while off-hook?

Hi,

I would consider two cases as explained below:

Case 1:
if you want to return an error descriptor in this case, the MGC could
send a command (eg:modify) look like this:

modify = T123 {
       events = 1234 { al/of(strict=failwrong)},
       signals {al/ri}
}
In this case, what you say about error code 540 is applicable, if your
intention is to apply al/ri only if hook-state is onhook.

Case 2:
if your modify looks like this, i dont think there should be any error
reported. The ring signal should be applied, as the MG is not aware of
the hook-state.

modify = T123 {
       signals {al/ri}
}

thanks,
shashi

---

From: "Nurit Shenhar" <[email-masked]>
Date: Sun, 13 Oct 2002 17:11:38 +0200

Hello

As the one who started this discussion, I can answer that I was talking about an analog gateway, with a standard phone connected to each line. My concern is from some loss of state in the MGC, that causes the MGC to send a command which does not match the current hook state. (i.e ringing while off-hook, or playing a tone while on-hook). In this case the gateway should return an error to the MG, just like we have an error of 'Termination belongs to another context' when getting a command with mismatching termination and context.

Nurit

-----Original Message-----
From: Reddy, Muralidhar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 4:23 PM
To: 'Shashi Kumar'; Tom-PT Taylor
Cc: Nurit Shenhar; [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while off-hook?

Hello Shashi,

   Let me know this discussion is pertaining to a Normal PSTN phone or an IP
phone( where U have more
   than one line ?.
   let me know , whether we can have a display Device on a phone(PSTN) ,
where in MGC can drive MG to display saying 
   there is a call to answer (in offhook state)??. 
   And also a race condition what You people are discussing with ??.
   Like 1. MGC has initiated to ring the Phone and also user has attempted
to make a call ( off-hook), where 
   MGC is still not aware of this.
   In that case , it is always better to use Strict descriptor as shish
explained (suggestion).
   
thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

   In the above modify command...
   we are playing a signal(al/ri) and we are not aware of the hook state
at MG, why do we need to return an error code?  please clarify.

thanks,
shashi

Tom-PT Taylor wrote:
> 
> We need a general "Termination state incompatible" error code.  Does
someone
> want to write one up in an I-D?
> 
> > From: Nurit Shenhar [mailto:[email-masked]]
> > Sent: Thursday, October 10, 2002 5:17 AM
> > To: [email-masked]
> > Subject: [MEGACO] Which error to send when trying to ring
> > while off-hook?
> >
> >
> > Hello
> >
> > When MG gets a ring command (i.e al/ri) but the hook state is
> > off-hook, which would be the correct error code to return?
> > The closest I have found is 540 (UNEXPECTED INITIAL HOOK
> > STATE) but this was defined for the detection of hook state
> > with 'FailWrong' parameter.
> >
> > Nurit
> >
> >
> >
> >

---

From: "Nurit Shenhar" <[email-masked]>
Date: Sun, 13 Oct 2002 17:11:38 +0200

Hello

Nurit

-----Original Message-----
From: Reddy, Muralidhar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 4:23 PM
To: 'Shashi Kumar'; Tom-PT Taylor
Cc: Nurit Shenhar; [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while off-hook?

Hello Shashi,

thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi

someone