Subject: [Megaco] Add on a termination OutofService

From: [email-masked]
Date: Fri, 11 Oct 2002 09:28:48 +0200

In RFC3015 in sections 7.2.1  about Add  command it is written :

Add SHOULD NOT be used on a termination with a serviceState of
"OutofService"

What should be the behaviour of the MG if it receives the add command
while the termination is in OutofService state ?

I would expect a reply with an appropraite error code.

Thank-you for your help
Regards,
Jean-Luc

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 10:29:46 -0400

The reason that's a SHOULD rather than a MUST is out of concern that there
might be some test scenario where the termination is put into a context to
test it before returning it to service.  I think this is a case where the MG
should hope that the MGC knows what it is doing, so no error is recognized.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Friday, October 11, 2002 3:29 AM
> To: [email-masked]
> Subject: [Megaco] Add on a termination OutofService
> 
> 
> 
> Add SHOULD NOT be used on a termination with a serviceState 
> of "OutofService"
> 
> What should be the behaviour of the MG if it receives the add 
> command while the termination is in OutofService state ?
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 10:29:46 -0400