Subject: [Megaco] Wildcard request and reply

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 16 Oct 2002 15:01:15 +0200

Hi all,

There is an example of use of wildcard response:
When the MGC sends the command:
      Context=*{W-AuditValue=t1/*{Audit{Packages}}}
   Returns:

      Context=*{W-AuditValue=t1/*{Packages{aaa,bbb}}}

But in the ABNF the standard says:

   commandReply      = (( contextProperties [COMMA commandReplyList] ) /

                           commandReplyList )
   commandReplyList     = commandReplys *(COMMA commandReplys )

   commandReplys        = (serviceChangeReply / auditReply / ammsReply /

                           notifyReply )

So, is the result of the example wrong?
Shouldn't  it return:

      Context=*{AuditValue=t1/*{Packages{aaa,bbb}}}

or is the ABNF wrong?

regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 16 Oct 2002 10:22:43 -0400

The ABNF is correct.  The W- is dropped in the reply.
 
Kevin

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Wednesday, October 16, 2002 9:01 AM
To: Megaco
Subject: [Megaco] Wildcard request and reply

Hi all, 

  

or is the ABNF wrong? 

regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 16 Oct 2002 10:22:43 -0400

Kevin

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Wednesday, October 16, 2002 9:01 AM
To: Megaco
Subject: [Megaco] Wildcard request and reply

Hi all, 

  

or is the ABNF wrong? 

regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL