Subject: RE: [Megaco] In the transaction reply..

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 10 Oct 2002 09:25:17 -0400

No separate reply.  A transaction has to be executed and replied as a unit.

-----Original Message-----
From: hmask [mailto:[email-masked]] 
Sent: Wednesday, October 09, 2002 10:17 PM
To: [email-masked]
Subject: [Megaco] In the transaction reply..

How about do it this situation..?

MGC send this transaction to MG. And MG process this transaction.

      +----------------------------------------------------------+ 
      | Transaction x
| 
      |  +------------------------------------------------------+  | 
      |  | Action 1
|  | 
      |  | +----------+  +----------+  +----------+  +----------+   |  | 
      |  | | Command |  | Command |  | Command |  | Command |  |  | 
      |  | |    1            |  |    2            |  |    3            |  |
4            |  |  | 
      |  | +----------+  +----------+  +----------+  +----------+   |  | 
      |  +------------------------------------------------------+  | 

MG process Command1,2,3. But, It takes a long time to process Command 4.

In this situation, does MG can separate transaction reply?
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 10 Oct 2002 19:29:24 +0530

However in this case, MG may send a provisional response (transaction
pending) to the MGC before sending the actual response just to make sure
that MGC does not retransmit the message.

I have one doubt: What are the factors/threshold which will decide that a
given command is going to take a long time to execute??

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

>       |  | |    1            |  |    2            |  |    3            |
|

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 10 Oct 2002 19:29:24 +0530

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

|

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 11 Oct 2002 16:38:27 +0530

Hi Tom,

Is this rule applicable when there are multiple actions received in the
given transaction request??
aLso can I send each transaction in seperate message, when all the
transaction requests have come together in one message?

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

|

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 11 Oct 2002 16:38:27 +0530

Hi Tom,

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

|

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 11 Oct 2002 16:39:55 +0530

Hi Tom,

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

|

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 11 Oct 2002 16:39:55 +0530

Hi Tom,

/anil.

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'hmask'" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 10, 2002 7:13 PM
Subject: RE: [Megaco] In the transaction reply..

|

---

From: "Venkatesh Seshasayee" <[email-masked]>
Date: Fri, 11 Oct 2002 17:52:34 +0530

Anil,

answers inline.

> given transaction request??

Yes. The rule (A transaction has to be executed and replied as a unit) 
is applicable for any number of actions for a given transaction.

Also, a message can contain a number of transactions with each 
transaction having no necessary relationship with any other transaction 
in the message.

> transaction requests have come together in one message?

Yes, you can send each transaction reply in a separate message. The 
transactions in a message maybe executed in any order.

Please lookup Section 8 (and specifically section 8.3) of the 
draft-ietf-megaco-3015corr-02.txt.

hope this suffices.

>>No separate reply.  A transaction has to be executed and replied as a
> 
> unit.
>

---

From: "Venkatesh Seshasayee" <[email-masked]>
Date: Fri, 11 Oct 2002 17:52:34 +0530

Anil,

answers inline.

hope this suffices.