Subject: [Megaco] KeepActive and Signal Handling

From: "Shashi Kumar" <[email-masked]>
Date: Wed, 16 Oct 2002 19:09:56 +0530

Dear List:

   Let us assume, 'Event E1 with *KeepActive*' and 'Signal S1' are active on a termination T1. MG detects event E1 and reports same to MGC. Since KeepActive is specified with Event E1, signal S1 shall continue to be active on termination T1.

   Question is: In the next modify command, if I specify a emply events desriptor, should I stop signal S1?

   If answere to above is NO, then, is there any other way to stop the Signal S1, apart from sending a emply Signals Descriptor in the next modify??

thanks,
shashi

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Sat, 19 Oct 2002 15:58:50 -0400

I think the answer is NO. To stop the signal S1, an empty
SignalDescriptor need to be sent or a new EventDescriptor with the
keepActive flag removed for event E1 has to be sent and on the new
occurrence of the event E1, the signal S1 would stop.
 
Thanks,
Bala

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Shashi Kumar
Sent: Wednesday, October 16, 2002 9:40 AM
To: [email-masked]
Subject: [Megaco] KeepActive and Signal Handling

Dear List:

   Let us assume, 'Event E1 with *KeepActive*' and 'Signal S1' are
active on a termination T1. MG detects event E1 and reports same to MGC.
Since KeepActive is specified with Event E1, signal S1 shall continue to
be active on termination T1.

   Question is: In the next modify command, if I specify a emply events
desriptor, should I stop signal S1?

   If answere to above is NO, then, is there any other way to stop the
Signal S1, apart from sending a emply Signals Descriptor in the next
modify??

thanks,
shashi

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Sat, 19 Oct 2002 15:58:50 -0400

Thanks,
Bala

-----Original Message-----

Dear List:

thanks,
shashi