Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

From: "Noh Jeong Min" <[email-masked]>
Date: Wed, 16 Oct 2002 15:37:42 +0900

I understood that transaction pending generated by receiver.

And, receiver generate transaction pending when the MGProvisionalResponseTimerValue expired.

what is difference normalMGExecutionTime and  MGProvisionalResponseTimerValue?

And why normalMGExecutionTime set by MGC?

Thanks in advance your help.

Noh Jeong-Min

[email-masked]
IMT development team.
MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 12:57:18 +0530

Hi Noh Jeong Min,

I am not sure from where you get these timers..... MGProvisionalResponseTimerValue & normalMGExecutionTime.
Otherwise the "MGProvisionalResponseTimerValue" timer is pre-calculated timer value by the MG. It may be based on the transaction processing dynamics of the stack, and it may vary. This timer, when expires MG sends a provisional response indicating that the given transaction is going to take longer timer to execute so to avoide the retransmissions at the sender's end.

I am not sure if there is another timer associcated with the NormalExecution of the transaction... this is implementation specific. 
In fact both the timers are implementation specific.... MG may apply different logic to send the provisional responses....

hope this helps..
/anil.

  ----- Original Message ----- 
  From: Noh Jeong Min 
  To: [email-masked] 
  Sent: Wednesday, October 16, 2002 12:11 PM
  Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Noh Jeong-Min

  [email-masked]
  IMT development team.
  MERCURY Corporation

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 12:57:18 +0530

Hi Noh Jeong Min,

hope this helps..
/anil.

  ----- Original Message ----- 
  From: Noh Jeong Min 
  To: [email-masked] 
  Sent: Wednesday, October 16, 2002 12:11 PM
  Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Noh Jeong-Min

  [email-masked]
  IMT development team.
  MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 17:52:23 +0530

HI,

Please ignore my earlier reply to this question....

MO... is as follows...

normalMGExecutionTime : 
This is the time whe expires, MGC would retransmit the message to the MG. In other words, this is the time (maximum) MG should take to process a Transaction.

MGProvisionalResponseTimerValue
This is the time when expires, MG would send the provisional response to the MGC. This indicates that the given transaction is going to take longer timer to execute so to avoide the retransmissions at the sender's end. The reception of provisional response would also result in restarting the "normalMGExecutionTime" for the given transaction.

Now about the difference....
The "normalMGExecutionTime" is ued to retrasmit the message where as "MGProvisionalResponseTimerValue" is used to control this retrasmission.

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 17:52:23 +0530

HI,

MO... is as follows...

normalMGExecutionTime : 

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 18:14:44 +0530

HI,

MO... is as follows...

normalMGExecutionTime : 
This is the time when expires, MGC would retransmit the message to the MG. In other words, this is the time (maximum) MG should take to process a Transaction.

My question is, does MG have control over the normalMGExecutionTime. Can MG alter the value of it?? as service change can go from either MG or MGC.

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 18:14:44 +0530

HI,

MO... is as follows...

normalMGExecutionTime : 

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 18:14:44 +0530

HI,

MO... is as follows...

normalMGExecutionTime : 

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 16 Oct 2002 18:14:44 +0530

HI,

MO... is as follows...

normalMGExecutionTime : 

/anil.

----- Original Message ----- 
  From: Anil Jangam 
  To: Noh Jeong Min 
  Cc: [email-masked] 
  Sent: Wednesday, October 16, 2002 1:05 PM
  Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

  Hi Noh Jeong Min,

  hope this helps..
  /anil.

    ----- Original Message ----- 
    From: Noh Jeong Min 
    To: [email-masked] 
    Sent: Wednesday, October 16, 2002 12:11 PM
    Subject: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

    Noh Jeong-Min

    [email-masked]
    IMT development team.
    MERCURY Corporation

---

From: Christian Groves <[email-masked]>
Date: Thu, 17 Oct 2002 18:41:34 +1000

Hello Anil,

Your assessment of the situation is nearly correct but the difference is not as
correct as it could be. The "normalMGexecutionTime" is the time used wehereby
the MGC will know that the MG has hung on processing a certain transaction. Its
not particular to retransmission. The "MGProvisionalResponseTimerValue" is as
you say used to control the transmission of the TransactionPending.

Christian 

HI,

MO... is as follows...
 
normalMGExecutionTime : 
This is the time when expires, MGC would retransmit the message to the MG. In
other words, this is the time (maximum) MG should take to process a
Transaction.
MGProvisionalResponseTimerValue
This is the time when expires, MG would send the provisional response to the
MGC. This indicates that the given transaction is going to take longer timer
to execute so to avoide the retransmissions at the sender's end. The reception
of provisional response would also result in restarting the
"normalMGExecutionTime" for the given transaction.
Now about the difference....
The "normalMGExecutionTime" is ued to retrasmit the message where as
"MGProvisionalResponseTimerValue" is used to control this retrasmission.
 
My question is, does MG have control over the normalMGExecutionTime. Can MG
alter the value of it?? as service change can go from either MG or
MGC.
 
/anil.
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 17 Oct 2002 18:41:34 +1000

Hello Anil,

Christian 

HI,

MO... is as follows...
 
normalMGExecutionTime : 

/anil.