Subject: RE: [MEGACO] Which error to send when trying to ring while off-ho ok?

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 10 Oct 2002 13:38:45 -0400

We need a general "Termination state incompatible" error code.  Does someone
want to write one up in an I-D?

> -----Original Message-----
> From: Nurit Shenhar [mailto:[email-masked]] 
> Sent: Thursday, October 10, 2002 5:17 AM
> To: [email-masked]
> Subject: [MEGACO] Which error to send when trying to ring 
> while off-hook?
> 
> 
> Hello
> 
> When MG gets a ring command (i.e al/ri) but the hook state is 
> off-hook, which would be the correct error code to return? 
> The closest I have found is 540 (UNEXPECTED INITIAL HOOK 
> STATE) but this was defined for the detection of hook state 
> with 'FailWrong' parameter.
> 
> Nurit
> 
> 
>  
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Shashi Kumar <[email-masked]>
Date: Fri, 11 Oct 2002 11:01:22 +0530

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

   In the above modify command...
   we are playing a signal(al/ri) and we are not aware of the hook state
at MG, why do we need to return an error code?  please clarify.

thanks,
shashi

---

From: Shashi Kumar <[email-masked]>
Date: Fri, 11 Oct 2002 11:01:22 +0530

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi