Subject: [Megaco] Definition of mediaDescriptor in ABNF and ASN.1

From: "Anil Jangam" <[email-masked]>
Date: Fri, 25 Oct 2002 13:45:45 +0530

Hi,

Look out for the definition of the MediaDescriptor in both, ABNF and in
ASN.1. In ABNF, it is defined that either streamParam(s) or
streamDescriptor(s) but not both. In ASN.1, the definiton says that streams
could be either "oneStreamParms" or "SEQUENCE OF StreamDescriptor" (its
choice between the two).

The question/doubt is:-
What is the significance of the "streamParm(s)" in ABNF?? Does it (the
factor '(s)' in the text) mean that there could be multiple streamParm in
the list of mediaParm?? If yes, then ASN.1 says something different, which
is "oneStreamParms", means that only one streamParam. Isn't it contradicting
with the definition of the ABNF. What is the consistency between these
two.....??

------------
mediaDescriptor  = MediaToken LBRKT mediaParm *(COMMA mediaParm) RBRKT

; at-most one terminationStateDescriptor
; and either streamParm(s) or streamDescriptor(s) but not both
mediaParm   = (streamParm / streamDescriptor /
                           terminationStateDescriptor)

MediaDescriptor ::= SEQUENCE
{
      termStateDescr TerminationStateDescriptor OPTIONAL,
      streams     CHOICE
      {
         oneStreamParms,
         multiStream SEQUENCE OF StreamDescriptor
      } OPTIONAL,
      ...
 }

====

Regards,

Anil Jangam

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 25 Oct 2002 04:46:25 -0400

I don't know where your quote of the ASN.1 is from, but here I cut the
definition straight from the H.248.1 (02/02) document (H.248 v1 Corr 1):

					oneStream	StreamParms,
					multiStream	SEQUENCE OF
StreamDescriptor
				} OPTIONAL,
	...
}

StreamParms ::= SEQUENCE
{
	localControlDescriptor 		LocalControlDescriptor OPTIONAL,
	localDescriptor        		LocalRemoteDescriptor OPTIONAL,
	remoteDescriptor       		LocalRemoteDescriptor OPTIONAL,
	...
}

As you can see, the oneStream construct allows a LC,L and R descriptor, just
like the ABNF.  I don't see an issue.

Kevin

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]] 
Sent: Friday, October 25, 2002 4:28 AM
To: [email-masked]
Subject: [Megaco] Definition of mediaDescriptor in ABNF and ASN.1
Importance: High

Hi,

The question/doubt is:-

------------

====

Regards,

Anil Jangam

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 25 Oct 2002 04:46:25 -0400

StreamParms ::= SEQUENCE
{

Kevin

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]] 
Sent: Friday, October 25, 2002 4:28 AM
To: [email-masked]
Subject: [Megaco] Definition of mediaDescriptor in ABNF and ASN.1
Importance: High

Hi,

The question/doubt is:-

------------

====

Regards,

Anil Jangam