Subject: [Fwd: [Megaco] KeepActive and Signal Handling]

From: Shashi Kumar <[email-masked]>
Date: Sat, 19 Oct 2002 14:12:50 +0530

re-posting the question, as there was no response from the list...
implementors guide is also not clear on this issues.

thanks,
shashi

Subject: [Megaco] KeepActive and Signal Handling
From: "Shashi Kumar" <[email-masked]>
To: <[email-masked]>
Date: Wed, 16 Oct 2002 19:09:56 +0530
List-Id: Media Gateway Control <megaco.ietf.org>

Dear List:

   Let us assume, 'Event E1 with *KeepActive*' and 'Signal S1' are active on a termination T1. MG detects event E1 and reports same to MGC. Since KeepActive is specified with Event E1, signal S1 shall continue to be active on termination T1.

   Question is: In the next modify command, if I specify a emply events desriptor, should I stop signal S1?

   If answere to above is NO, then, is there any other way to stop the Signal S1, apart from sending a emply Signals Descriptor in the next modify??

thanks,
shashi

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 21 Oct 2002 03:03:12 -0400

Sending Events descriptors has never affected signal playout.  Detection of
Events, and replacement of the Signals descriptor WILL affect signal
playout, unless the KA parameter is included.  In your example, a new Events
descriptor will NOT halt the signal, but a new Signals descriptor will.

Kevin

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]] 
Sent: Saturday, October 19, 2002 4:43 AM
To: [email-masked]'
Subject: [Fwd: [Megaco] KeepActive and Signal Handling]

thanks,
shashi

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 21 Oct 2002 03:03:12 -0400

Kevin

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]] 
Sent: Saturday, October 19, 2002 4:43 AM
To: [email-masked]'
Subject: [Fwd: [Megaco] KeepActive and Signal Handling]

thanks,
shashi