Subject: [Megaco] *** cleaning the Events Descriptor

From: [email-masked]
Date: Sun, 20 Oct 2002 12:52:38 +0300

Hello,

According to the ABNF, there is no possibility to send an empty Events
Descriptor.
What is the way to clean an existing Events Descriptor without sending more
(new) requested events.

Regards,

Dana H.
SW Engineer
NGTS ECI Telecom

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Sun, 20 Oct 2002 13:15:12 +0200

Terry Anderson answered this on the 4th of June:

It WAS a bug that RFC 3015 did not allow any form of empty events list, but
this was fixed through the IG and appears corrected in H.248 Corrigendum and
V2 as:
eventsDescriptor     = EventsToken [ EQUAL RequestID LBRKT
	requestedEvent *( COMMA requestedEvent ) RBRKT ]
The empty events list is NOT and empty LBRKT RBRKT but also omits the EQUAL
and the useless RequestID.  While empty descriptors are sometimes formed
from empty LBRKT RBRKT there are reasons for other forms in some places.

Raphael Tryster

	-----Original Message-----
	From:	[email-masked]
[SMTP:[email-masked]]
	Sent:	Sunday, 20 October, 2002 11:53 AM
	To:	[email-masked]
	Cc:	[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]
	Subject:	[Megaco] *** cleaning the Events Descriptor

	Hello,

	According to the ABNF, there is no possibility to send an empty
Events
	Descriptor.
	What is the way to clean an existing Events Descriptor without
sending more
	(new) requested events.

	Regards,

	Dana H.
	SW Engineer
	NGTS ECI Telecom

---

From: Raphael Tryster <[email-masked]>
Date: Sun, 20 Oct 2002 13:15:12 +0200

Raphael Tryster

	-----Original Message-----

	Hello,

	Regards,

	Dana H.
	SW Engineer
	NGTS ECI Telecom

---

From: [email-masked]
Date: Tue, 22 Oct 2002 16:46:54 +0530

Hi

The protocol document states....

"An empty EventBuffer Descriptor clears the EventBuffer and disables all event
accumulation in LockStep mode: the only events reported will be those occurring
while an Events Descriptor is active."

Just as a clarification....
The empty EBD does not cause any change to the LockStep mode. Although, the
event accumulation is disabled, the LockStep mode remains active (unless EBCP is
set to Off by MGC).

1). If a Modify command is received with a new non-empty ED as well as a
non-empty EBD. ED is activated first. Upon reporting an event to MGC, the ED is
de-activated and the new EBD is used for event accumulation.

2). If a Modify command is received with a new non-empty ED. ED is activated
first. Upon reporting an event to MGC, the ED is de-activated. Since the EBD is
still empty, the MG waits for the next new ED for event reporting.

Do we need any more text in the standards document..

thanks
Kapil Nayar
Hughes Software Systems Ltd.
www.hssworld.com

Raphael Tryster <[email-masked]> on 10/20/2002 05:45:12 PM

To:   [email-masked], [email-masked]
cc:   [email-masked], [email-masked], [email-masked],
      [email-masked], [email-masked],
      [email-masked] (bcc: Kapil Nayar/HSS)

Subject:  RE: [Megaco] *** cleaning the Events Descriptor

Raphael Tryster

     -----Original Message-----

     Hello,

     Regards,

     Dana H.
     SW Engineer
     NGTS ECI Telecom

---

From: [email-masked]
Date: Tue, 22 Oct 2002 16:46:54 +0530

Hi

thanks
Kapil Nayar

Raphael Tryster

     -----Original Message-----

     Hello,

     Regards,

     Dana H.
     SW Engineer
     NGTS ECI Telecom