Subject: RE: [Megaco] RTP profiles clarification

From: Raphael Tryster <[email-masked]>
Date: Mon, 21 Oct 2002 15:00:57 +0200

When a dynamic payload type is used, does the payload type field of the RTP
header contain the dynamic payload type, or the static payload type to which
it is mapped?  For example:

m=audio 7204 RTP/AVP 96
a=rtpmap:96 G726-32/8000

Does the RTP header contain 96 or 2, which is the static payload type for
G726-32?

If the answer is 96, does this mean that the other subscriber in the call
must also associate dynamic payload 96 with G726-32?

Raphael Tryster

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Thursday, 17 October, 2002 7:50 PM
	To:	'Troy Cauble'; [email-masked]
	Subject:	RE: [Megaco] RTP profiles clarification

	The AVT people have provided such encouragement, for a start.  Here
is a
	relevant passage from draft-ietf-avt-profile-new-12.txt. 

	   This specification establishes the policy that no additional
static
	   payload types will be assigned beyond the ones defined in this
	   document. Establishing this policy avoids the problem of trying
to
	   create a set of criteria for accepting static assignments and
	   encourages the implementation and deployment of the dynamic
payload
	   type mechanisms.

	 I know it doesn't go quite as far as what I said, and I can't find
	supporting information in the SDP draft.  I'm reporting what I think
I've
	heard, and perhaps I was wrong.

	> -----Original Message-----
	> From: Troy Cauble [mailto:[email-masked]] 
	> Sent: Thursday, October 17, 2002 1:34 PM
	> To: [email-masked]
	> Subject: Re: [Megaco] RTP profiles clarification
	> 
	> 
	> Tom-PT Taylor wrote:
	> 
	> >You can use a dynamic payload type for any codec that has a 
	> registered 
	> >MIME type, which, thanks to the rtp-mime draft cited above,
includes 
	> >all of the codecs which have been assigned static payload 
	> types.  These 
	> >days you are encouraged to use dynamic payload types for
everything.
	> >
	> >  
	> >
	> Just curious.  Who's encouraging this and why?
	> 
	> -troy
	> 
	> _______________________________________________
	> Megaco mailing list
	> [email-masked]
	> https://www1.ietf.org/mailman/listinfo/megaco
	> 
	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Mon, 21 Oct 2002 11:40:31 -0400

When an MGC sends a LocalDescriptor to an MG, the general practice is to 
ALWAYS
use wildcards and let the MG choose certain values, for example the 
local port number.  

Do we need to clarify that the MGC is not allowed to specify certain 
local values?

-troy

---

From: Troy Cauble <[email-masked]>
Date: Mon, 21 Oct 2002 11:40:31 -0400

-troy