Subject: RE: [Megaco] Query in MOVE

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 09:36:05 -0400

Hi.  My responses marked with [PTT].

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, October 03, 2002 5:33 AM
> To: [email-masked]
> Subject: [Megaco] Query in MOVE
> 
> 
> 
> 
> 
> Hi list,
> 
> I have some queries in MOVE command,
> 
> Consider following scenario:
> 
> Context   1 with terminaition T10 and T20
> Context   2 with termination  T41 and T42
> 
> 1 > For following transaction
>      Transaction = 50003 {
>      Context = 2 {
>           Move    = T4*
>      }
> }
> 
> What will be the error code? Should the result for 
> terminations present in Context 2 be reported?
[PTT]
I see the reasoning in two steps:
  a) When executing a Move command, does the MG consider only those matching
terminations for which the Move would be legal?
  b) Is it legal to Move a termination to the context in which it already
resides?

We have had lots of discussion of the effect of wildcarding in the past.  I
would have to go back and review it to see whether a positive answer to a)
represents a violation of well-established precedent.  I expect our view is
that all terminations matching T4* are considered, even if they are in the
NULL context or in the target context.  (Side thought: would wildcarding be
more useful if there were an implicit limiting of scope to legally usable
values?)

Assuming that T41 and T42 are considered, we come to question b).  Seems to
me the quick answer is that to Move a termination to the context in which it
already resides is a no-op, not an error.  Successful Moves would be
reported for T41 and T42.
 
> 
> 
> 2>  Suppose the maximum number of terminations that are possible in a 
> 2> context in
> 2. Then what should be the error code for the transaction give below
> 
>      Transaction = 50004 {
>      Context = 2 {
>           Move    = *
>      }
> }
[PTT]
434 Max number of Terminations in a Context exceeded.

> 
> Will the error be repeated for all the terminations ?
[PTT]
First error stops the transaction unless the optional marker ("o-") is used,
despite the phrasing in the Move command description which says that all
possible matches will be tried.

> 
> 
> 3> Is there any practical application where wilcarding can be used in 
> 3> MOVE
> command
> 
[PTT]
I could see two possibilities, with only the second one likely at all:
  a) the terminationIds incorporate the contextID in which they were
created, so wildcarding really addresses only one source context

  b) a related group of terminations has to be brought into a single context
so they can be operated on as a group.  I have in mind an emergency alerting
service where groups of lines are rung at a time and an announcement is
played out to them on answer.

Of course, there is always the possibility the MGC is using special-purpose
logic to reduce message lengths in the (likely very rare) case where by
coincidence wildcarding would address the desired set of terminations.
> 
> 
> Thanks in advance
> Shobhit
> 
> 
> DISCLAIMER: This message is proprietary to Hughes Software 
> Systems Limited (HSS) and is intended solely for the use of 
> the individual to whom it is addressed. It may contain  
> privileged or confidential information  and should not be 
> circulated or used for any purpose other than for what it is 
> intended. If you have received this message in error, please 
> notify the originator immediately. If you are not the 
> intended recipient, you are notified that you are strictly 
> prohibited from using, copying, altering, or disclosing the 
> contents of this message. HSS accepts no responsibility for 
> loss or damage arising from the use of the information 
> transmitted by this email including damage from virus.
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: SHRI KUMAR <[email-masked]>
Date: Fri, 4 Oct 2002 06:15:44 +0100 (BST)

Hello Tom

As far as I rememeber from the mail archives, the
precedent for wild-card resolution of terminations
also considers the context ID specified directly/
indirectly in the command.
eg:- 
1). MODIFY (context=Null, term=phy*) resolves to
terminations with naming phy* and in the Null Context.
2). SUBTRACT (context=1, term=phy*) resolves to
terminations with naming phy* and in ContextID 1.
3). ADD (context=2, term=phy*) resolves to
terminations with naming phy* and in the Null Context.
Now, how can we exclude MOVE from a similar
interpretation. MOVE is a special command which does
not refer to the source context, but protocol defines
all the legal combinations for the MOVE. Therefore,
4). MOVE (context=3, term=phy*) resolves to
terminations with naming phy* and NOT in Null Context
(remember MOVE from and to Null context is illegal)
and NOT in ContextID 3.

This seems logical!
Any comments on the logic?

rgds
-shri

> > transmitted by this email including damage from

________________________________________________________________________
Missed your favourite TV serial last night? Try the new, Yahoo! TV.
       visit http://in.tv.yahoo.com
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: SHRI KUMAR <[email-masked]>
Date: Fri, 4 Oct 2002 06:15:44 +0100 (BST)

Hello Tom

This seems logical!

rgds
-shri