Subject: [MEGACO] Which error to send when trying to ring while off-hook?

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 10 Oct 2002 11:17:09 +0200

Hello

When MG gets a ring command (i.e al/ri) but the hook state is off-hook, which would be the correct error code to return? The closest I have found is 540 (UNEXPECTED INITIAL HOOK STATE) but this was defined for the detection of hook state with 'FailWrong' parameter.

Nurit

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Shashi Kumar <[email-masked]>
Date: Thu, 10 Oct 2002 17:37:06 +0530

Hi,

I would consider two cases as explained below:

Case 1:
if you want to return an error descriptor in this case, the MGC could
send a command (eg:modify) look like this:

modify = T123 {
       events = 1234 { al/of(strict=failwrong)},
       signals {al/ri}
}
In this case, what you say about error code 540 is applicable, if your
intention is to apply al/ri only if hook-state is onhook.

Case 2:
if your modify looks like this, i dont think there should be any error
reported. The ring signal should be applied, as the MG is not aware of
the hook-state.

modify = T123 {
       signals {al/ri}
}

thanks,
shashi

---

From: Shashi Kumar <[email-masked]>
Date: Thu, 10 Oct 2002 17:37:06 +0530

Hi,

Case 1:

modify = T123 {

Case 2:

modify = T123 {
       signals {al/ri}
}

thanks,
shashi