Subject: RE: [Megaco] data call using NAS pkg

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 31 Oct 2002 10:24:13 -0500

This was sent a long time ago.  Now Fernando has stirred me to action -- I
will try to close on thse issues and others this week so I can reissue the
NAS and SDP-TDM drafts.  Here are my responses, to get the discussion
started.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2002 12:05 PM
To: Megaco
Subject: [Megaco] data call using NAS pkg

Hi all, 
Looking at the draft of the NAS pkg I dont understand  why 
it says that the user requests outgoing service is outside 
the scope of the document (See 8.5 procedures).

[PTT] What it says is that HOW the user requests outgoing service is outside
the document scope.  Theoretically it could be a request passed from AAA,
except that the required options don't exist, at least in RADIUS.  In any
event, it is not through the Megaco protocol, and hence out of scope.
 
Initially when the user calls a ISP (Internet Service Provider) 
the MG does not know that it is a data call. 

The MGC must tell the MG that it is a data call and 
inform of  the IP of the BroadBand Access server of that ISP. 
(I guess this is the third case of an outgoing NAS Call). 
Then the MG will act accordingly and ( e.g. the modem may need a special 
configuration ) pass the PPP packets 
of the user to the broadband access server for the authentication 
of the user (transparently to the MG). Then all data packets will 
be sent to the Broadband server (which will send them to the ISP). 

The MG usually does not know of ISP numbers or broadband access 
server. It is the MGC which has all the information. In the worst case 
the MGC will enroute the traffic as a normal call. 
I think this is a common scenario... 

Am I missing something ? 

[PTT]
This is different from the understanding I had when writing the draft.  My
understanding was that the MG is provisioned with the address of the AAA
server, which in turn gives it all the information it needs to set up the
call.

Thanks 
Fernando 

  
-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL  
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 31 Oct 2002 11:08:43 -0500

We are talking about an incoming data call here, in the sense used by my
packages.  Yes, it is the MGC that knows that it is a call to an ISP.  It
uses the incoming package to set up the call on the MG.

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Thursday, October 31, 2002 10:59 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: Megaco
Subject: Re: [Megaco] data call using NAS pkg

Hi, 
But starting from the very beginning: 
e.g.  the user wants to contact an ISP  and the MG 
receives the digit string of its phone number: 
How does the MG know that it is a data call? 
Who should have this information? 
IMO it is the MGC which knows that phone number 
corresponds to an ISP. is it right? 
Fernando 
  
Tom-PT Taylor wrote: 
-----Original Message----- 
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2002 12:05 PM 
To: Megaco 
Subject: [Megaco] data call using NAS pkg 
Hi all, 

  
-- 
Fernando Vallejo Lazaro 
Phone:  +34 91 330 8279 
SW  Wireline ASD-Madrid 
       ALCATEL
-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 31 Oct 2002 11:08:43 -0500

-----Original Message-----
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Thursday, October 31, 2002 10:59 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: Megaco
Subject: Re: [Megaco] data call using NAS pkg

Hi, 
  
Tom-PT Taylor wrote: 
-----Original Message----- 
From: Fernando Vallejo Lazaro [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2002 12:05 PM 
To: Megaco 
Subject: [Megaco] data call using NAS pkg 
Hi all, 

  
-- 
Fernando Vallejo Lazaro 
Phone:  +34 91 330 8279 
SW  Wireline ASD-Madrid 
       ALCATEL
-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL