Subject: RE: [MEGACO] Which error to send when trying to ring while off-ho ok?

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 10 Oct 2002 13:38:45 -0400

We need a general "Termination state incompatible" error code.  Does someone
want to write one up in an I-D?

> -----Original Message-----
> From: Nurit Shenhar [mailto:[email-masked]] 
> Sent: Thursday, October 10, 2002 5:17 AM
> To: [email-masked]
> Subject: [MEGACO] Which error to send when trying to ring 
> while off-hook?
> 
> 
> Hello
> 
> When MG gets a ring command (i.e al/ri) but the hook state is 
> off-hook, which would be the correct error code to return? 
> The closest I have found is 540 (UNEXPECTED INITIAL HOOK 
> STATE) but this was defined for the detection of hook state 
> with 'FailWrong' parameter.
> 
> Nurit
> 
> 
>  
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Reddy, Muralidhar" <[email-masked]>
Date: Fri, 11 Oct 2002 10:22:47 -0400

Hello Shashi,

   Let me know this discussion is pertaining to a Normal PSTN phone or an IP
phone( where U have more
   than one line ?.
   let me know , whether we can have a display Device on a phone(PSTN) ,
where in MGC can drive MG to display saying 
   there is a call to answer (in offhook state)??. 
   And also a race condition what You people are discussing with ??.
   Like 1. MGC has initiated to ring the Phone and also user has attempted
to make a call ( off-hook), where 
   MGC is still not aware of this.
   In that case , it is always better to use Strict descriptor as shish
explained (suggestion).
   
thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

   In the above modify command...
   we are playing a signal(al/ri) and we are not aware of the hook state
at MG, why do we need to return an error code?  please clarify.

thanks,
shashi

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 11:03:52 -0400

Another note has pointed out cases where it is acceptable for ringing to be
applied to an off-hook line.  However, in some cases this is an error and it
would be desirable not to go through with it.  We are typically talking
about a race condition where the off-hook was recognized and sent to the MGC
but the MGC had already sent the request to ring the line.  Because of the
timing, the MGC may think this is subscriber answer.  At the same time,
because the off-hook event was detected before the signal was applied, the
ringing signal will not be stopped and will persist until the called party
hangs up.  The recognition of an error situation has to be done by the MG
based on the line type.

The reason I propose a general state mismatch error is because it could also
cover other such situations.

> To: Taylor, Tom-PT [CAR:B602:EXCH]
> Subject: Re: [MEGACO] Which error to send when trying to ring 
> while off-hook?
> 
> 
> Hi Tom,
> 
>    modify = T123 {
>         signals {al/ri}
>    }
> 
>    we are playing a signal(al/ri) and we are not aware of the 
> hook state at MG, why do we need to return an error code?  
> please clarify.
> 
> 
> thanks,
> shashi
> 
> 
> Tom-PT Taylor wrote:
> > 
> > We need a general "Termination state incompatible" error 
> code.  Does 
> > someone want to write one up in an I-D?
> > 
> > > Subject: [MEGACO] Which error to send when trying to ring while 
> > > off-hook?
> > >
> > >
> > > Hello
> > >
> > > off-hook, which would be the correct error code to return? The 
> > > closest I have found is 540 (UNEXPECTED INITIAL HOOK
> > > STATE) but this was defined for the detection of hook state with 
> > > 'FailWrong' parameter.
> > >
> > > Nurit
> > >
> > >
> > >
> > >
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
> > >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 11:03:52 -0400

---

From: "Reddy, Muralidhar" <[email-masked]>
Date: Fri, 11 Oct 2002 10:22:47 -0400

Hello Shashi,

thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 11 Oct 2002 13:38:02 -0400

If the MG can detect on- and off-hook as per the analog lines package, then
the MG MUST be aware of the hook state.  The strict parameter of the al/on
and al/of events may mandate that the hook state be renotified, or an error
descriptor be returned.

Kevin

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]] 
Sent: Friday, October 11, 2002 1:31 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

   In the above modify command...
   we are playing a signal(al/ri) and we are not aware of the hook state at
MG, why do we need to return an error code?  please clarify.

thanks,
shashi

Tom-PT Taylor wrote:
> 
> We need a general "Termination state incompatible" error code.  Does

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 11 Oct 2002 13:38:02 -0400

Kevin

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]] 
Sent: Friday, October 11, 2002 1:31 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 14:30:28 -0400

This presumably is under the assumption that al/of is enabled.  And that's a
good point: it wouldn't make sense to initiate ringing without enabling this
event.  To avoid the race condition I pointed out in my previous note, the
al/ri signal would be started first, then the al/of event enabled with
strict parameter value.  That way the off-hook would stop ringing almost
before it started, a desirable state of affairs given the situation.  Not
lately, but certainly in the past I had the experience of picking up the
phone to make a call, only to discover someone at the other end.

> From: Boyle, Kevin [NCRTP:3R90:EXCH] 
> Sent: Friday, October 11, 2002 1:38 PM
> To: Shashi Kumar; Taylor, Tom-PT [CAR:B602:EXCH]
> Subject: RE: [MEGACO] Which error to send when trying to ring 
> while off-hook?
> 
> 
> If the MG can detect on- and off-hook as per the analog lines 
> package, then the MG MUST be aware of the hook state.  The 
> strict parameter of the al/on and al/of events may mandate 
> that the hook state be renotified, or an error descriptor be returned.
> 
> Kevin
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 Oct 2002 14:30:28 -0400

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 14 Oct 2002 05:43:07 -0400

If the MGC lost state, would it not attempt to scan for hook state again?
At that time, it would receive the current hook state back from the MG, and
can realign itself.  Further, the instant there is one usecase where the MGC
may wish to request something that differs from the perceived norm, the MG
should not, and cannot, decide to refuse such requests.

Tom indicated that he has seen a usecase where power ringing may be applied
to an off-hook phone.  Therefore, the assumption that this is an illegal
state is invalid, and cannot be enforced by the MG.

It is the MGC's problem to keep call processing states aligned between the
MG and MGC.  The MG, in this particular case, should do what it is requested
to do by the MGC.  If it is truly impossible to do what the MGC asks, then
by all means return an error code (513?).  But otherwise, the call
processing function resides in the MGC, not the MG, and it is up to the MGC
to make appropriate call processing decisions.

Kevin

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]] 
Sent: Sunday, October 13, 2002 11:12 AM
To: [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while
off-hook?

Hello

As the one who started this discussion, I can answer that I was talking
about an analog gateway, with a standard phone connected to each line. My
concern is from some loss of state in the MGC, that causes the MGC to send a
command which does not match the current hook state. (i.e ringing while
off-hook, or playing a tone while on-hook). In this case the gateway should
return an error to the MG, just like we have an error of 'Termination
belongs to another context' when getting a command with mismatching
termination and context.

Nurit

-----Original Message-----
From: Reddy, Muralidhar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 4:23 PM
To: 'Shashi Kumar'; Tom-PT Taylor
Cc: Nurit Shenhar; [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while
off-hook?

Hello Shashi,

thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi

> We need a general "Termination state incompatible" error code.  Does
someone

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 14 Oct 2002 05:43:07 -0400

Kevin

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]] 
Sent: Sunday, October 13, 2002 11:12 AM
To: [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while
off-hook?

Hello

Nurit

-----Original Message-----
From: Reddy, Muralidhar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 4:23 PM
To: 'Shashi Kumar'; Tom-PT Taylor
Cc: Nurit Shenhar; [email-masked]
Subject: RE: [MEGACO] Which error to send when trying to ring while
off-hook?

Hello Shashi,

thanks,
Murali

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Friday, October 11, 2002 1:31 AM
To: Tom-PT Taylor
Cc: 'Nurit Shenhar'; [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while
off-hook?

Hi Tom,

   modify = T123 {
        signals {al/ri}
   }

thanks,
shashi

someone