Subject: RE: [MEGACO] Which error to send when trying to ring while off-hook?

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 10 Oct 2002 14:13:45 +0200

Hi

Case 1 solves the ringing while off hook, but there are also the cases that the MG gets a command to play CPT and the phone is on-hook. You can say that the same rule apply - add an al/on event with strict=failwrong. But I think that the gateway should return some error even if the on-hook or off-hook events were not part of the message.
I don't agree that the MGC is unaware of the hook state, as this drives the MGC state machine. So if the MGC sent an illegal command, like ringing while off-hook or CPT while on-hook, the MG should reply with an error. And again the question is: Which error?

Nurit

-----Original Message-----
From: Shashi Kumar [mailto:[email-masked]]
Sent: Thursday, October 10, 2002 2:07 PM
To: Nurit Shenhar
Cc: [email-masked]
Subject: Re: [MEGACO] Which error to send when trying to ring while off-hook?

Hi,

I would consider two cases as explained below:

Case 1:
if you want to return an error descriptor in this case, the MGC could
send a command (eg:modify) look like this:

modify = T123 {
       events = 1234 { al/of(strict=failwrong)},
       signals {al/ri}
}
In this case, what you say about error code 540 is applicable, if your
intention is to apply al/ri only if hook-state is onhook.

Case 2:
if your modify looks like this, i dont think there should be any error
reported. The ring signal should be applied, as the MG is not aware of
the hook-state.

modify = T123 {
       signals {al/ri}
}

thanks,
shashi

Nurit Shenhar wrote:
> 
> Hello
> 
> When MG gets a ring command (i.e al/ri) but the hook state is off-hook, which would be the correct error code to return? The closest I have found is 540 (UNEXPECTED INITIAL HOOK STATE) but this was defined for the detection of hook state with 'FailWrong' parameter.
> 
> Nurit
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Shashi Kumar <[email-masked]>
Date: Thu, 10 Oct 2002 18:40:45 +0530

Nurit,

  Was referring to MG not being aware of the hook-state(untill and
unless instructed otherwise by MGC to scan for the hook-state).  MGC is
quite aware of the hook state and to avoid situations like 'ringing
while off-hook or CPT while on-hook', we could build checks at MGC when
building the message. One such  mechanisms we have is usage of 'strict'
in the events descriptor.
  You can also refer to  Kevin's reply to the subject "[Megaco] Audit
termination hook status" on a similar issue. Coming back to error code
in your case, i think use of 540 would be appropriate if we use 'strict
parameter' in the events descriptor.

thanks,
shashi
   
   please see my comments in line [shashi]

thanks,
shashi

---

From: Shashi Kumar <[email-masked]>
Date: Thu, 10 Oct 2002 18:40:45 +0530

Nurit,

thanks,
shashi

thanks,
shashi