Subject: RE: [Megaco] Service change graceful

From: Susumu YAMAMOTO <[email-masked]>
Date: Wed, 09 Oct 2002 19:11:53 +0900

Hi all,

If the network between a MGC and a MG fails and the graceful message for
some terminations from the MG is lost, how can the MGC knows after the
connection recovered that the terminations are to be in out-of-service
after the conversation?

I think that the only thing what the MGC can do is to audit the all terminations
after the network restored, but no parameters or properties of the terminations
indicate to be in out-of-service gracefully.

So, I think the MG should re-send the ServiceChange message with forced
method after the conversation end, and take the status of the termination to
be out-of-service after subtraction from the MGC.

Please let me know if my idea is wrong.

Regards,
Susumu

---
>It is stated in  Megaco/H.248 Call flow examples document that by the time 
>the subtract is received by MG, the termination is out-of-service.
>
>I think MGC realizes the subtract of termination when it gets subtract 
>response from MG.
>
>Sincerely
>
>Nejat ILHAN
>Telenity Inc.
>-----Original Message-----
>From: Fernando Vallejo Lazaro [mailto:[email-masked]]
>Sent: Tuesday, October 08, 2002 5:14 PM
>To: Megaco
>Subject: [Megaco] Service change graceful
>
>Hi all,
>
>Imagine we have a Termination in conversation in a certain context.
>Then the operator decides to put the user out of service after the
>conversation.
>
>The MG may send a ServiceChange (graceful, delay=0).
>When the conversation has finished the MGC sends a Subtract.
>
>Now,
>
>Does the MG need to send another ServiceChange or
>can we consider that from the moment it has returned to the
>NULL context is out of service?
>
>Regards
>Fernando
>
>--
>Fernando Vallejo Lazaro
>Phone:  +34 91 330 8279
>SW  Wireline ASD-Madrid
>        ALCATEL
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 09 Oct 2002 12:54:48 +0200

Hi,

There are, at least, two possibilities:

1) If the ServiceChange Graceful is lost the MG can
detect it and therefore it can resend it when the communication
with the MGC is recovered. This avoids sending it in any case.

2) A third state can be created for the TerminationState:
"shutting down". Meaning that the termination is waiting for a timeout
(due to a ServiceChange Graceful) or for the end of the conversation
to be out of service. I don't know if this has been discussed before.

comments are welcome

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 09 Oct 2002 12:54:48 +0200

Hi,

comments are welcome

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Susumu YAMAMOTO <[email-masked]>
Date: Thu, 10 Oct 2002 14:04:53 +0900

Hi,

I think that the MG send Disconnected message for the lost messages,
then the MGC audit to re-synchronize the state of the MG and all the
terminations. The former possibility does not seems to fit good for the
MEGACO.

So, I think that the latter one would be better choice. The MGC should
be able to audit all of the states of the MG and the terminations.

Then, what about lost of the graceful message with ROOT ?
The MGC also cannot audit the state of the MG shutting down after all
the conversations end.

Regards,
Susumu

---
>> >From: Fernando Vallejo Lazaro 
>> [<mailto:[email-masked]>mailto:[email-masked]] 
>>
>><https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/mailman/listinfo/megaco
>
>--
>Fernando Vallejo Lazaro
>Phone:  +34 91 330 8279
>SW  Wireline ASD-Madrid
>        ALCATEL
>

-*-*-*-
SUSUMU YAMAMOTO, NTT Corporation

---

From: Susumu YAMAMOTO <[email-masked]>
Date: Thu, 10 Oct 2002 14:04:53 +0900

Hi,

Regards,
Susumu

---

-*-*-*-