Subject: [Megaco] Query in MOVE

From: [email-masked]
Date: Thu, 3 Oct 2002 15:03:01 +0530

Hi list,

I have some queries in MOVE command,

Consider following scenario:

Context   1 with terminaition T10 and T20
Context   2 with termination  T41 and T42

1 > For following transaction
     Transaction = 50003 {
     Context = 2 {
          Move    = T4*
     }
}

What will be the error code? Should the result for terminations present in
Context 2 be reported?

2>  Suppose the maximum number of terminations that are possible in a context in
2. Then what should be the error code for the transaction give below

     Transaction = 50004 {
     Context = 2 {
          Move    = *
     }
}

Will the error be repeated for all the terminations ?

3> Is there any practical application where wilcarding can be used in MOVE
command

Thanks in advance
Shobhit

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 09:36:05 -0400

Hi.  My responses marked with [PTT].

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, October 03, 2002 5:33 AM
> To: [email-masked]
> Subject: [Megaco] Query in MOVE
> 
> 
> 
> 
> 
> Hi list,
> 
> What will be the error code? Should the result for 
> terminations present in Context 2 be reported?
[PTT]
I see the reasoning in two steps:
  a) When executing a Move command, does the MG consider only those matching
terminations for which the Move would be legal?
  b) Is it legal to Move a termination to the context in which it already
resides?

We have had lots of discussion of the effect of wildcarding in the past.  I
would have to go back and review it to see whether a positive answer to a)
represents a violation of well-established precedent.  I expect our view is
that all terminations matching T4* are considered, even if they are in the
NULL context or in the target context.  (Side thought: would wildcarding be
more useful if there were an implicit limiting of scope to legally usable
values?)

Assuming that T41 and T42 are considered, we come to question b).  Seems to
me the quick answer is that to Move a termination to the context in which it
already resides is a no-op, not an error.  Successful Moves would be
reported for T41 and T42.
 
> 
> 
> 2>  Suppose the maximum number of terminations that are possible in a 
> 2> context in
[PTT]
434 Max number of Terminations in a Context exceeded.

> Will the error be repeated for all the terminations ?
[PTT]
First error stops the transaction unless the optional marker ("o-") is used,
despite the phrasing in the Move command description which says that all
possible matches will be tried.

> 
> 
> 3> Is there any practical application where wilcarding can be used in 
> 3> MOVE
> command
> 
[PTT]
I could see two possibilities, with only the second one likely at all:
  a) the terminationIds incorporate the contextID in which they were
created, so wildcarding really addresses only one source context

  b) a related group of terminations has to be brought into a single context
so they can be operated on as a group.  I have in mind an emergency alerting
service where groups of lines are rung at a time and an announcement is
played out to them on answer.

Of course, there is always the possibility the MGC is using special-purpose
logic to reduce message lengths in the (likely very rare) case where by
coincidence wildcarding would address the desired set of terminations.
> 
> 
> Thanks in advance
> Shobhit
> 
> 
> DISCLAIMER: This message is proprietary to Hughes Software 
> Systems Limited (HSS) and is intended solely for the use of 
> the individual to whom it is addressed. It may contain  
> privileged or confidential information  and should not be 
> circulated or used for any purpose other than for what it is 
> intended. If you have received this message in error, please 
> notify the originator immediately. If you are not the 
> intended recipient, you are notified that you are strictly 
> prohibited from using, copying, altering, or disclosing the 
> contents of this message. HSS accepts no responsibility for 
> loss or damage arising from the use of the information

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 09:48:27 -0400

Ooops -- got one of my answers wrong.

> From: Taylor, Tom-PT [CAR:B602:EXCH] 
> Sent: Thursday, October 03, 2002 9:36 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Megaco] Query in MOVE
> 
> 
[snip]
> First error stops the transaction unless the optional marker 
> ("o-") is used, despite the phrasing in the Move command 
> description which says that all possible matches will be tried.
> 
[PTT again]
The relevant paragraph is in section 8:

"At the first failing Command in a Transaction, processing of the remaining
Commands in that Transaction stops. If a command contains a wildcarded
TerminationID, the command is attempted with each of the actual
TerminationIDs matching the wildcard. A response within the TransactionReply
is included for each matching TerminationID, even if one or more instances
generated an error. If any TerminationID matching a wildcard results in an
error when executed, any commands following the wildcarded command are not
attempted."
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 09:48:27 -0400

[snip]
[PTT again]

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 3 Oct 2002 17:58:49 +0200

Tom,

Your first answer was not exactly an "oops", as you have taken the same
position before.  Please recall the following portion of an unfinished
exchange, in which I claimed that your second answer to
Shobhit<[email-masked]'> today is the only one that could be
consistent with the wording of the standard.  Hope this doesn't sound like
nitpicking; I would just like to verify whether you have changed your mind,
or whether I am misinterpreting something.

Regards,

Raphael Tryster

	Tom, 

	Of the 3 sentences in the paragraph I quoted, it is possible to
qualify the first two by saying that they apply only when O- was specified.
But this cannot be said of the third sentence:

	"If any TerminationID matching a wildcard results in an error when
executed, any commands following the wildcarded command are not attempted".

	Since O- applies to the whole wildcard, if execution of the rest of
the wildcard continued in spite of an error, then the command following the
O- wildcard SHOULD be executed.

	It seems to me that either the text or the intention needs to be
amended. 

	Raphael Tryster 

	-----Original Message----- 
	From:   Tom-PT Taylor [SMTP:[email-masked]]
<mailto:[SMTP:[email-masked]]>  
	Sent:   Tuesday, 27 August, 2002 4:14 AM 
	To:     'Raphael Tryster'; Kevin Boyle; Carl Rutter; [email-masked]
<mailto:[email-masked]>  
	Cc:     Brad Steinka 
	Subject:        RE: [Megaco] AuditValue on ALL Context Question 

	I'm afraid the intention when we drafted this text was that each
iteration 
	of the wildcarded command was a "command" for purposes of the
stopping rule. 
	Thus the first error would terminate execution unless the "O-"
override was 
	present. 

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Thursday, 03 October, 2002 3:48 PM
	To:	[email-masked]'; [email-masked]
	Subject:	RE: [Megaco] Query in MOVE

	[snip]
	[PTT again]

	"At the first failing Command in a Transaction, processing of the
remaining
	Commands in that Transaction stops. If a command contains a
wildcarded
	TerminationID, the command is attempted with each of the actual
	TerminationIDs matching the wildcard. A response within the
TransactionReply
	is included for each matching TerminationID, even if one or more
instances
	generated an error. If any TerminationID matching a wildcard results
in an
	error when executed, any commands following the wildcarded command
are not
	attempted."
	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 3 Oct 2002 17:58:49 +0200

Tom,

Regards,

Raphael Tryster

	Tom, 

	Raphael Tryster 

	-----Original Message-----
	From:	Tom-PT Taylor [SMTP:[email-masked]]
	Sent:	Thursday, 03 October, 2002 3:48 PM
	To:	[email-masked]'; [email-masked]
	Subject:	RE: [Megaco] Query in MOVE

	[snip]
	[PTT again]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 11:20:33 -0400

Not very consistent, am I?  However, I think my second answer today was the
right one, in view of the unambiguous wording in section 8.

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, October 03, 2002 11:59 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; [email-masked]'; [email-masked]
Subject: RE: [Megaco] Query in MOVE

Tom, 
Your first answer was not exactly an "oops", as you have taken the same
position before.  Please recall the following portion of an unfinished
exchange, in which I claimed that your second answer to
Shobhit<[email-masked]'> today is the only one that could be
consistent with the wording of the standard.  Hope this doesn't sound like
nitpicking; I would just like to verify whether you have changed your mind,
or whether I am misinterpreting something.
Regards, 
Raphael Tryster 
Tom, 
Of the 3 sentences in the paragraph I quoted, it is possible to qualify the
first two by saying that they apply only when O- was specified.  But this
cannot be said of the third sentence:
"If any TerminationID matching a wildcard results in an error when executed,
any commands following the wildcarded command are not attempted".
Since O- applies to the whole wildcard, if execution of the rest of the
wildcard continued in spite of an error, then the command following the O-
wildcard SHOULD be executed.
It seems to me that either the text or the intention needs to be amended. 
Raphael Tryster 
-----Original Message-----
From:   Tom-PT Taylor [SMTP:[email-masked]]
Sent:   Tuesday, 27 August, 2002 4:14 AM
To:     'Raphael Tryster'; Kevin Boyle; Carl Rutter; [email-masked]
Cc:     Brad Steinka
Subject:        RE: [Megaco] AuditValue on ALL Context Question 
I'm afraid the intention when we drafted this text was that each iteration
of the wildcarded command was a "command" for purposes of the stopping rule.
Thus the first error would terminate execution unless the "O-" override was
present. 

-----Original Message----- 
From:   Tom-PT Taylor [SMTP:[email-masked]] 
Sent:   Thursday, 03 October, 2002 3:48 PM 
To:     [email-masked]'; [email-masked] 
Subject:        RE: [Megaco] Query in MOVE 
[snip] 
[PTT again]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Oct 2002 11:20:33 -0400

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, October 03, 2002 11:59 AM
To: Taylor, Tom-PT [CAR:B602:EXCH]; [email-masked]'; [email-masked]
Subject: RE: [Megaco] Query in MOVE

Tom, 

-----Original Message----- 
From:   Tom-PT Taylor [SMTP:[email-masked]] 
Sent:   Thursday, 03 October, 2002 3:48 PM 
To:     [email-masked]'; [email-masked] 
Subject:        RE: [Megaco] Query in MOVE 
[snip] 
[PTT again]

---

From: [email-masked]
Date: Fri, 4 Oct 2002 10:23:36 +0530

Hi Tom,

Thanks for your responses.
I have another query.
For first question you said that the succuessful move would be reported for T41
and T42.

Taking case of ADD command if an ADD command comes for a termination that is
already
in the same context on which the ADD command applies, will a successful ADD be
reported.

      Transaction = 5001 {
      Context = 2 {
           Add    = T41
      }
 }

Thanks and Resgards
Shobhit

"Tom-PT Taylor" <[email-masked]> on 10/03/2002 07:06:05 PM

To:   Shobhit Bansal/HSS@HSS, [email-masked]
cc:

[PTT]

[PTT]

[PTT]

[PTT]

---

From: [email-masked]
Date: Fri, 4 Oct 2002 10:23:36 +0530

Hi Tom,

      Transaction = 5001 {
      Context = 2 {
           Add    = T41
      }
 }

Thanks and Resgards
Shobhit

[PTT]

[PTT]

[PTT]

[PTT]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 4 Oct 2002 11:39:15 -0400

Error 433 "TerminationID is already in a Context" would apply.

> Sent: Friday, October 04, 2002 12:54 AM
> To: Taylor, Tom-PT [CAR:B602:EXCH]
> Cc: [email-masked]
> For first question you said that the succuessful move would 
> be reported for T41 and T42.
> 
> Taking case of ADD command if an ADD command comes for a 
> termination that is already in the same context on which the 
> ADD command applies, will a successful ADD be reported.
> 
>       Transaction = 5001 {
>       Context = 2 {
>            Add    = T41
>       }
>  }
> 
> 
> Thanks and Resgards
> Shobhit
> 
> 
> 
> 
> 
> 
> > What will be the error code? Should the result for terminations 
> > present in Context 2 be reported?
> [PTT]
>   a) When executing a Move command, does the MG consider only 
> those matching terminations for which the Move would be legal?
>   b) Is it legal to Move a termination to the context in 
> which it already resides?
> 
> We have had lots of discussion of the effect of wildcarding 
> in the past.  I would have to go back and review it to see 
> whether a positive answer to a) represents a violation of 
> well-established precedent.  I expect our view is that all 
> terminations matching T4* are considered, even if they are in 
> the NULL context or in the target context.  (Side thought: 
> would wildcarding be more useful if there were an implicit 
> limiting of scope to legally usable
> values?)
> 
> Assuming that T41 and T42 are considered, we come to question 
> b).  Seems to me the quick answer is that to Move a 
> termination to the context in which it already resides is a 
> no-op, not an error.  Successful Moves would be reported for 
> T41 and T42.
> 
> >
> >
>   a) the terminationIds incorporate the contextID in which 
> they were created, so wildcarding really addresses only one 
> source context
> 
>   b) a related group of terminations has to be brought into a 
> single context so they can be operated on as a group.  I have 
> in mind an emergency alerting service where groups of lines 
> are rung at a time and an announcement is played out to them 
> on answer.
> 
> Of course, there is always the possibility the MGC is using 
> special-purpose logic to reduce message lengths in the 
> (likely very rare) case where by coincidence wildcarding 
> would address the desired set of terminations.
> >
> >
> > Thanks in advance
> > Shobhit
> >
> >
> > Limited (HSS) and is intended solely for the use of the 
> individual to 
> > whom it is addressed. It may contain privileged or confidential 
> > information  and should not be circulated or used for any purpose 
> > other than for what it is intended. If you have received 
> this message 
> > in error, please notify the originator immediately. If you 
> are not the

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 4 Oct 2002 11:39:15 -0400

---

From: [email-masked]
Date: Tue, 8 Oct 2002 16:33:34 +0530

Hi

1 > Does this mean that processing of same type of scenario will be different
for different commands.
i.e. if an add command resolves to termination that is already present in
context in command, an error is to be raised
      if a move command resolves to termination that is already present in
context in command, a success should be sent

2> If case some descriptors are present with move command. Will they be applied
on terminations that
are already present in the destination context if the termination name specified
in the command matches
termination name present in destination context.

Regards
Shobhit

"Tom-PT Taylor" <[email-masked]> on 10/04/2002 09:09:15 PM

To:   Shobhit Bansal/HSS@HSS
cc:   [email-masked]

---

From: [email-masked]
Date: Tue, 8 Oct 2002 16:33:34 +0530

Hi

Regards
Shobhit