Subject: [Megaco] Which scenario is correct in the hairpin connection?

From: "Noh Jeong Min" <[email-masked]>
Date: Thu, 7 Nov 2002 17:12:41 +0900

Hi, MEGACO list again.

I would like to get some clarification on hairpin connection.
When the two physical terminations are added to context, then how do we set topology or  localcontrol mode ?

There are two kinds of Add scenario. Which scenario is correct in the hairpin connection?

1) When the two physical terminations are added to context, MGC set topology(A,B,isolate). 
   And if callee subscriber hook off, then MGC change topology( A,B,bothway).
2) When the two physical terminations are added to context, MGC set localcontrol mode(Inactive).
   And if callee subscriber hook off, then MGC change localcontrol mode(SendReceive).
3)  1,2 are also incorrect. It needs another scenario.

Wait for your reply.
Thanks and best regards.

CASE 1: Use a topology descriptor.

   Step 1) MGC to MG1: 
   MEGACO/1 [123.123.123.4]:55555 
   Transaction = 10004{ 
        Context = ${ 
            Topology = { LINE/1, LINE/2, isolate },
                Add = LINE/2{ 
                      Media{ Stream = 1{ LocalControl {Mode = SendReceive} }}, 
                        Events=1234{al/of(strict=state)},  
                        Signals{al/ri}   ; start ringing 
                },
                Add = LINE/1{ 
                        Media{ Stream = 1{ LocalControl {Mode = SendReceive} }}, 
                        Signals {cg/rt} ; start ringback
                }
       } 
   } 
   Step 2) reply MG to MGC
   Step 3) MG to MGC, Notify =LINE/2{Events{al/of}}
   Step 4) MGC to MG, Reply

   Step 5) MGC to MG1: 
   MEGACO/1 [123.123.123.4]:55555 
   Transaction = 10006 { 
      Context = 2000 { 
       Topology = { LINE/1, LINE/2, bothway },
         Modify = LINE/1 { 
            Signals { } ; to turn off ringback
         }, 
         Modify = LINE/2 { 
            Events = 1235 {al/on(strict=state)}, 
            Signals { } ; to turn off ringing  
         } 
      } 
   } 

CASE 2 : Use a localcontrol mode.

   Step 1) MGC to MG1: 
   MEGACO/1 [123.123.123.4]:55555 
   Transaction = 10004{ 
        Context = ${ 
                ; default Topology (LINE/1,LINE/2,bothway)
                Add = LINE/2{ 
                      Media{ Stream = 1{ LocalControl {Mode = inactive} }}, 
                        Events=1234{al/of(strict=state)},  
                        Signals{al/ri}  ; start ringing
                },
                Add = LINE/1{ 
                        Media{ Stream = 1{ LocalControl {Mode = inactive} }}, 
                        Signals {cg/rt}  ; start ringback
                }
       } 
   } 
   Step 2) reply MG to MGC
   Step 3) MG to MGC, Notify =LINE/2{Events{al/of}}
   Step 4) MGC to MG, Reply
   Step 5) MGC to MG1: 

   MEGACO/1 [123.123.123.4]:55555 
   Transaction = 10006 { 
      Context = 2000 { 
         Modify = LINE/1 { 
            Media{ Stream = 1{ LocalControl {Mode = SendReceive} }},
            Signals { } ; to turn off ringback
         }, 
         Modify = LINE/2 {
            Media{ Stream = 1{ LocalControl {Mode = SendReceive} }}, 
            Events = 1235 {al/on(strict=state)}, 
            Signals { } ; to turn off ringing  
         } 
      } 
   } 

Noh Jeong Min.
IMT System Development Group.
MERCURY Corporation. Ltd.
Tel : +82 031 310 5714, +82 031 310 5718
Email : [email-masked]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 7 Nov 2002 10:23:54 -0500

I may be contradicting what is shown in the call flows, but they are
intended to be examples rather than normative.  I would set caller Mode to
RecvOnly until called party off-hook, then set it to sendReceive.  I would
set called party Mode to sendReceive from the beginning.

Use of topology is not incorrect, but is not guaranteed to work because
support of topology is optional.

-----Original Message-----
From: Noh Jeong Min [mailto:[email-masked]] 
Sent: Thursday, November 07, 2002 3:13 AM
To: [email-masked]
Subject: [Megaco] Which scenario is correct in the hairpin connection?

Hi, MEGACO list again.

I would like to get some clarification on hairpin connection.
When the two physical terminations are added to context, then how do we set
topology or  localcontrol mode ?

There are two kinds of Add scenario. Which scenario is correct in the
hairpin connection?

1) When the two physical terminations are added to context, MGC set
topology(A,B,isolate). 
   And if callee subscriber hook off, then MGC change topology(
A,B,bothway).
2) When the two physical terminations are added to context, MGC set
localcontrol mode(Inactive).
   And if callee subscriber hook off, then MGC change localcontrol
mode(SendReceive).
3)  1,2 are also incorrect. It needs another scenario.

Wait for your reply.
Thanks and best regards.

   Step 1) MGC to MG1: 
                      Media{ Stream = 1{ LocalControl {Mode = SendReceive}
}}, 
                        Media{ Stream = 1{ LocalControl {Mode = SendReceive}
}}, 

   Step 5) MGC to MG1: 

   Step 1) MGC to MG1: 
                        Media{ Stream = 1{ LocalControl {Mode = inactive}
}}, 

Noh Jeong Min.
IMT System Development Group.
MERCURY Corporation. Ltd.
Tel : +82 031 310 5714, +82 031 310 5718
Email : [email-masked]
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 7 Nov 2002 10:23:54 -0500

-----Original Message-----
From: Noh Jeong Min [mailto:[email-masked]] 
Sent: Thursday, November 07, 2002 3:13 AM
To: [email-masked]
Subject: [Megaco] Which scenario is correct in the hairpin connection?

Hi, MEGACO list again.

Wait for your reply.
Thanks and best regards.

   Step 1) MGC to MG1: 

   Step 5) MGC to MG1: 

   Step 1) MGC to MG1: 

Noh Jeong Min.

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 7 Nov 2002 14:20:33 -0500

I would like to point out again that mode is relative to the exterior of the
context.  For control of media flow internal to the context, you have to use
the topology descriptor.  They are related, but not exactly the same.  You
could control both internal and external media flows using mode OR topology
when you have only two terms in a context, but it becomes impossible to
manage data flows correctly for contexts with more than two terms if you
choose not to use topology.  

Kevin

-----Original Message-----
From: Noh Jeong Min [mailto:[email-masked]] 
Sent: Thursday, November 07, 2002 3:13 AM
To: [email-masked]
Subject: [Megaco] Which scenario is correct in the hairpin connection?

Hi, MEGACO list again.

I would like to get some clarification on hairpin connection. When the two
physical terminations are added to context, then how do we set topology or
localcontrol mode ?

Wait for your reply.
Thanks and best regards.

   Step 1) MGC to MG1: 

   Step 5) MGC to MG1: 

   Step 1) MGC to MG1: 

Noh Jeong Min.
Email : [email-masked] _______________________________________________

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 7 Nov 2002 14:20:33 -0500

Kevin

-----Original Message-----
From: Noh Jeong Min [mailto:[email-masked]] 
Sent: Thursday, November 07, 2002 3:13 AM
To: [email-masked]
Subject: [Megaco] Which scenario is correct in the hairpin connection?

Hi, MEGACO list again.

Wait for your reply.
Thanks and best regards.

   Step 1) MGC to MG1: 

   Step 5) MGC to MG1: 

   Step 1) MGC to MG1: 

Noh Jeong Min.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 7 Nov 2002 16:37:11 -0500

Kevin kindly didn't say so explicitly, but I got my directions reversed in
my earlier reply.

> From: Boyle, Kevin [NCRTP:3R90:EXCH] 
> Sent: Thursday, November 07, 2002 2:21 PM
> To: Taylor, Tom-PT [CAR:B602:EXCH]; 'Noh Jeong Min'; [email-masked]
> I would like to point out again that mode is relative to the 
> exterior of the context.  For control of media flow internal 
> to the context, you have to use the topology descriptor.  
> They are related, but not exactly the same.  You could 
> control both internal and external media flows using mode OR 
> topology when you have only two terms in a context, but it 
> becomes impossible to manage data flows correctly for 
> contexts with more than two terms if you choose not to use topology.  
> 
> Kevin
> 
> I may be contradicting what is shown in the call flows, but 
> they are intended to be examples rather than normative.  I 
> would set caller Mode to RecvOnly until called party 
> off-hook, then set it to sendReceive.  I would set called 
> party Mode to sendReceive from the beginning.
> 
> Use of topology is not incorrect, but is not guaranteed to 
> work because support of topology is optional.
> 
> When the two physical terminations are added to context, then 
> how do we set topology or  localcontrol mode ?
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 7 Nov 2002 16:37:11 -0500