Subject: [Megaco] two transactions in the same message

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Tue, 12 Nov 2002 09:12:15 +0100

Hi all,

If I wish to send two transactions within the
same message which of the next two options is the right one?

Option a)

MEGACO/1 [123.123.123.4]:55555
   Transaction = 9999 {
       Context = - {
           Modify = A4444 {... }
        }
  }
   Transaction = 10000 {
       Context = - {
           Modify = A4445 {... }
        }
  }

Option b)

MEGACO/1 [123.123.123.4]:55555
   Transaction = 9999 {
       Context = - {
           Modify = A4444 {... }
        }
  },                                            <----- Note the comma
here
   Transaction = 10000 {
       Context = - {
           Modify = A4445 {... }
        }
  }

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Anil Jangam" <[email-masked]>
Date: Tue, 12 Nov 2002 14:16:33 +0530

Hi,

As per the protocol encoding rule, there is NO COMMA separator between two transactions in a message. Hence the your option-b may result into a syntax error (400). The option-a is correct one. You have to read each transaction with the transaction token and corresponding start and end brace.

Note: What was the reason for not using any separator for multiple transactions in a message unlike in other cases?

/anil.

  ----- Original Message ----- 
  From: Fernando Vallejo Lazaro 
  To: Megaco 
  Sent: Tuesday, November 12, 2002 1:48 PM
  Subject: [Megaco] two transactions in the same message

  Hi all, 

  Option a) 

  Option b) 

  MEGACO/1 [123.123.123.4]:55555 
     Transaction = 9999 { 
         Context = - { 
             Modify = A4444 {... } 
          } 
    },                                            <----- Note the comma here 
     Transaction = 10000 { 
         Context = - { 
             Modify = A4445 {... } 
          } 
    } 

  Regards 
  Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: Venkatesh Seshasayee <[email-masked]>
Date: Tue, 12 Nov 2002 14:30:02 +0530

Option A is the right one, according to the grammar....

> MEGACO/1 [123.123.123.4]:55555

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Venkatesh Seshasayee <[email-masked]>
Date: Tue, 12 Nov 2002 14:30:02 +0530

---

From: "Anil Jangam" <[email-masked]>
Date: Tue, 12 Nov 2002 14:16:33 +0530

Hi,

/anil.

  ----- Original Message ----- 
  From: Fernando Vallejo Lazaro 
  To: Megaco 
  Sent: Tuesday, November 12, 2002 1:48 PM
  Subject: [Megaco] two transactions in the same message

  Hi all, 

  Option a) 

  Option b) 

  Regards 
  Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL