Subject: RE: [Megaco] Initial handle in MGC for all Ephemeral terminations call

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 13 Nov 2002 02:16:14 -0500

I'll just add to that that each command is acknowledged in the order it was
presented in the transaction, so one you get the right transaction number
you just match the request with the reply.  As Anil points out, with
wildcarding you also have to look at the contextIDs.

> -----Original Message-----
> From: Anil Jangam [mailto:[email-masked]] 
> Sent: Tuesday, November 12, 2002 6:32 AM
> To: Majeed Arif-P27336
> Cc: [email-masked]
> Subject: Re: [Megaco] Initial handle in MGC for all Ephemeral 
> terminations call
> 
> 
> Hi,
> 
> A given command will always work with reference to the 
> contextID (here contextID could be absolute or wildcarded). 
> So whatever number of add commands are there in the given 
> transaction, MGC will always relate it to which contextID it 
> has been programmed while it was sent to MG. Thus its quite 
> possible that each add command may be programmed under 
> seperate contextID. As far as the assignment of the contextID 
> by MG is concerned, it will assign it only when it is 
> reuqested to do so (if you use CHOOSE wild card). In this 
> case, MG will assign an unique contextID and return it to the 
> MGC in the reply to the command with the same transactionID, 
> which was there in the transaction request. Hope it helps.
> 
> Regds,
> /anil.
> 
> ----- Original Message -----
> From: "Majeed Arif-P27336" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, November 12, 2002 1:34 AM
> Subject: [Megaco] Initial handle in MGC for all Ephemeral 
> terminations call
> 
> > Hi All,
> >
> > How does an MGC relates an ADD command to a reply in an all 
> IP media 
> > call?
> The Context is assigned by the MG and there are no physical 
> termination IDs. The only thing available to the MGC is the 
> transaction ID which may be at transaction layer and there 
> may be many ADD command in the same transaction.
> >
> > Arif
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> >
> 
> *********************************************************
> Disclaimer
> 
> This message (including any attachments) contains 
> confidential information intended for a specific 
> individual and purpose, and is protected by law. 
> If you are not the intended recipient, you should 
> delete this message and are hereby notified that 
> any disclosure, copying, or distribution of this
> message, or the taking of any action based on it, 
> is strictly prohibited.
> 
> *********************************************************
> Visit us at http://www.mahindrabt.com
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 13 Nov 2002 02:16:14 -0500