Subject: [Megaco] Muliple ContextIDs Allowed in One Transaction?

From: Maschoff Mark-P53708 <[email-masked]>
Date: Tue, 19 Nov 2002 17:33:49 -0700

Megaco Members:
 
Can a single Transaction contain more than one ContextID (see example below)?   This would be helpful in terms of efficiency in certain MG failure cases where the loss of a MG resource affects multiple Contexts.    
 
MEGACO/1 [IPv4address>]:<portNumber> 
Transaction = <TransactionID> {
Context = <ContextID1> {ServiceChange = * { Services {Method = Forced} } } 
Context = <ContextID2> {ServiceChange = * { Services {Method = Forced} } } 
Context = <ContextID3> {ServiceChange = * { Services {Method = Forced} } } 
.
.
.
Context = <ContextIDn> {ServiceChange = * { Services {Method = Forced} } } 
 
}
 
Thanks in advance,
 
Mark

---

From: "Noh Jeong Min" <[email-masked]>
Date: Wed, 20 Nov 2002 11:50:05 +0900

Yes. Transaction consist of one or more Actions. Each action typically specifies a ContextID.

Multiple Actions separated by ",".  Refer the clause 8.

     TransactionRequest(TransactionId { 
         ContextID {Command ... Command},  
            . . . 
         ContextID {Command ... Command } }) 

     TransactionReply(TransactionID { 
         ContextID { Response ... Response }, 
            . . . 
         ContextID { Response ... Response } }) 

In your example, ServiceChange of all matching terminations in the context1, 2, 3 ... n .

Noh Jeong Min.
IMT System Development Group.
MERCURY Corporation. Ltd.
Tel : +82 031 310 5714, +82 031 310 5718
Email : [email-masked]

----- Original Message ----- 
  From: Maschoff Mark-P53708 
  To: [email-masked] 
  Sent: Wednesday, November 20, 2002 9:33 AM
  Subject: [Megaco] Muliple ContextIDs Allowed in One Transaction?

  Megaco Members:

  }

  Thanks in advance,

  Mark

---

From: "Noh Jeong Min" <[email-masked]>
Date: Wed, 20 Nov 2002 11:50:05 +0900

Noh Jeong Min.

----- Original Message ----- 
  From: Maschoff Mark-P53708 
  To: [email-masked] 
  Sent: Wednesday, November 20, 2002 9:33 AM
  Subject: [Megaco] Muliple ContextIDs Allowed in One Transaction?

  Megaco Members:

  }

  Thanks in advance,

  Mark