Subject: RE: [Megaco] Implementing Packages (URGENT !!)

From: Raphael Tryster <[email-masked]>
Date: Mon, 18 Nov 2002 10:41:58 +0200

The set of packages that a termination implements indicates the complete set
of features it is capable of providing if requested, not the events or
signals that it is currently detecting or playing.  Thus a new command from
the MGC has no effect on the set of implemented packages.

Raphael Tryster

	-----Original Message-----
	From:	Kanika Garg [SMTP:[email-masked]]
	Sent:	Monday, 18 November, 2002 9:20 AM
	To:	[email-masked]
	Subject:	[Megaco] Implementing Packages (URGENT !!)

	Hi all,

	As stated in the name patterns drafts of Megaco,
	terminations implementing same set of packages belong
	to one type.  I wanted to know what does implementing
	same set of packages, actually mean?

	If suppose at the time of adding a termination to a
	context, MGC specifies some events that are to be
	detected.  Those events would be defined in some
	packages, say in pckg. p1 and p2.  Now, suppose in a
	modify command MGC requests to detect some other event
	on the same termination as before, but this event is
	defined in some other package, say p4,  then does this
	mean that the term. is implementing a diff. set of
	packages now, and hence it belongs to a diff. type. If
	this is so, then the type of termination would keep on
	changing dynamically.

	Please do clarify, it's urgent.
	Thanks

	Kanika Garg

	=====
	Kanika Garg
	Engineer Trainee,
	Next Generation Networks Group,
	HFCL, R&D Division, Gurgaon

	+91-124-8901601/701 (Extn. 315)
	9818082414

	__________________________________________________
	Do you Yahoo!?
	Yahoo! Web Hosting - Let the expert host your site
	http://webhosting.yahoo.com
	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Kanika Garg <[email-masked]>
Date: Tue, 19 Nov 2002 22:49:37 -0800 (PST)

Hi all,

What does complete set of features include?? Does it
include all the properties, signals, events,
statistics etc. or what else, if not this.  I want to
know WHEN and HOW is the "type" of a termination
defined?? 

When a termination, be it physical or ephemeral, is
added to a context, then we may specify some
properties in the descriptors of the ADD command. How
do they effect the properties of a termination, and
does that change the type of the termination.  And
WHEN do u specify, what packages a termination
implements... All these are really getting messed up.

Looking forward for clarifications,
Thanks,

Kanika Garg

=====
Kanika Garg
Engineer Trainee,

---

From: Kanika Garg <[email-masked]>
Date: Tue, 19 Nov 2002 22:49:37 -0800 (PST)

Hi all,

Kanika Garg

=====
Kanika Garg
Engineer Trainee,