Subject: RE: [Megaco] Stop dial tone after receiving the first digit

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 21 Nov 2002 13:04:33 -0500

Detected events stop signals by default. See sections 7.1.9 and 7.1.11.

Kevin

-----Original Message-----
From: zhaobo [mailto:[email-masked]] 
Sent: Wednesday, November 20, 2002 11:17 PM
To: [email-masked]
Subject: [Megaco] Stop dial tone after receiving the first digit

Hi all:
    For DTMF phone, dial tone is always stopped when first digit is sent.
How is this behaviour specified for a MGW in a H.248 message? Seems not the
type of signal(on/off, brief, or timeout). 
    Maybe just because in any case the dial tone shall be stopped after
receiving a digit,  it's not neccessary to specified in H.248?
    Thanks.
    
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: zhaobo <[email-masked]>
Date: Fri, 22 Nov 2002 14:35:38 +0800

RE: [Megaco] Stop dial tone after receiving the first digitHi Kevin, which I mean is "the first digit", not an EVENT. In the digital map case, only a macth makes a EVENT. For example, when the digitmap is 2XXX, a digit "2" stops the dialtone, but a event will not be make until the other three digits be dialed.

-----Original Message----- 
From: zhaobo [mailto:[email-masked]] 
Sent: Wednesday, November 20, 2002 11:17 PM 
To: [email-masked] 
Subject: [Megaco] Stop dial tone after receiving the first digit 

Hi all: 
    For DTMF phone, dial tone is always stopped when first digit is sent. How is this behaviour specified for a MGW in a H.248 message? Seems not the type of signal(on/off, brief, or timeout). 
    Maybe just because in any case the dial tone shall be stopped after receiving a digit,  it's not neccessary to specified in H.248?
    Thanks.

---

From: zhaobo <[email-masked]>
Date: Fri, 22 Nov 2002 14:35:38 +0800

-----Original Message----- 
From: zhaobo [mailto:[email-masked]] 
Sent: Wednesday, November 20, 2002 11:17 PM 
To: [email-masked] 
Subject: [Megaco] Stop dial tone after receiving the first digit 

Hi all:

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 22 Nov 2002 20:42:03 -0500

Please note the following from 7.1.14.7

> While the digit map is activated, detection is enabled for all events
> defined in the package containing the specified digit map completion
> event. Normal event behaviour (e.g. stopping of signals unless the
> digit completion event has the KeepActive flag enabled) continues to
> apply for each such event detected

This means that each digit event becomes an "event" implicitly when the
digitmap completion event is added to the list. They are not notified
but DO stop signals.

-- 
-------------------------------------------------------
Terry L Anderson                     [email-masked]
Voice: +1 908.766.4463	        Mobile: +1 908.342.9595
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 22 Nov 2002 20:42:03 -0500