Subject: [Megaco] trouble with wildcarding

From: milton mukhopadhyaya <[email-masked]>
Date: Sat, 2 Nov 2002 01:12:01 -0800 (PST)

Hi,
I have problems in the following scenarios.Can u
please provide clarification?

1.Scenario: 

Context=c1 {
		Modify=a/b/* { …}
           }
a/b/* resolves in a set of terminations {a/b/t1,a/b/t2
,a/b/t3,a/b/t4}. In this set a/b/t4 belongs to the
context c1, but a/b/t1, a/b/t2, a/b/t3 do not belong
to the context c1. Should we generate error messages
for a/b/t1, a/b/t2 and a/b/t3?Which error code is to
be sent (431 or 435)?

2.

trouble with wild-card-return token -:
Scenario:

Context 1 -> {t1/1, t1/2}
Context 2 -> {t1/3}
Termination t1/1  supports package aaa, package bbb
Termination t1/2  supports package ccc
Termination t1/3  supports package bbb

>From MGC to MG:

Context = * {w-auditvalue = t1/*{
                           audit{packages}
             }

	     modify = t1/*{
			   signals{…}
			  }
	}

>From MG to MGC:
MG may reply to the above request in the following two
ways:

Reply 1: 

Context = *{w-auditvalue = t1/* { packages { aaa, bbb,
ccc}}}
Context = 1 { modify = t1/1, modify = t1/2}
Context = 2 { modify = t1/3}

Reply 2: 

Context = 1 { w-auditvalue = t1/* {aaa, bbb,ccc}
		Modify = t1/1
		Modify = t1/2
		}
Context = 2 { w-auditvalue = t1/* {bbb}
		Modify = t1/3
		}	

WHICH ONE IS RIGHT?
Mukta Vasudeva

__________________________________________________
Do you Yahoo!?
HotJobs - Search new jobs daily now
http://hotjobs.yahoo.com/
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 4 Nov 2002 14:49:53 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: milton mukhopadhyaya [mailto:[email-masked]] 
Sent: Saturday, November 02, 2002 4:12 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Megaco] trouble with wildcarding

Hi,

1.Scenario: 

Context=c1 {
		Modify=a/b/* { ...}
           }
a/b/* resolves in a set of terminations {a/b/t1,a/b/t2 ,a/b/t3,a/b/t4}. In
this set a/b/t4 belongs to the context c1, but a/b/t1, a/b/t2, a/b/t3 do not
belong to the context c1. Should we generate error messages for a/b/t1,
a/b/t2 and a/b/t3?Which error code is to be sent (431 or 435)?

[KJBII] The response will contain the single matching term, and NO error
descriptors for those not in the specified context.

2.

	     modify = t1/*{
			   signals{...}
			  }
	}

Reply 1: 

Reply 2: 

WHICH ONE IS RIGHT?

[KJBII] Reply 1 is correct.

Mukta Vasudeva

http://hotjobs.yahoo.com/ _______________________________________________

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 4 Nov 2002 14:49:53 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: milton mukhopadhyaya [mailto:[email-masked]] 
Sent: Saturday, November 02, 2002 4:12 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Megaco] trouble with wildcarding

Hi,

1.Scenario: 

Context=c1 {
		Modify=a/b/* { ...}
           }

2.

	     modify = t1/*{
			   signals{...}
			  }
	}

Reply 1: 

Reply 2: 

WHICH ONE IS RIGHT?

Mukta Vasudeva

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 04 Nov 2002 15:59:54 -0500

Once small correction: reply will not have "W-"
         Aleks

>Comments inline. [KJBII]
...
>Context = 2 { modify = t1/3}
...

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 04 Nov 2002 15:59:54 -0500

...
...