Subject: [Megaco] two transactions in the same message

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Tue, 12 Nov 2002 09:12:15 +0100

Hi all,

If I wish to send two transactions within the
same message which of the next two options is the right one?

Option a)

MEGACO/1 [123.123.123.4]:55555
   Transaction = 9999 {
       Context = - {
           Modify = A4444 {... }
        }
  }
   Transaction = 10000 {
       Context = - {
           Modify = A4445 {... }
        }
  }

Option b)

MEGACO/1 [123.123.123.4]:55555
   Transaction = 9999 {
       Context = - {
           Modify = A4444 {... }
        }
  },                                            <----- Note the comma
here
   Transaction = 10000 {
       Context = - {
           Modify = A4445 {... }
        }
  }

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: [email-masked]
Date: Tue, 12 Nov 2002 14:45:38 +0530

Hi,
     Option a) is correct as per the ABNF Specification.

regards
Rakhi Verma
Hughes Software Systems
www.hssworld.com

Fernando Vallejo Lazaro <[email-masked]> on 11/12/2002
01:42:15 PM

To:   Megaco <[email-masked]>
cc:    (bcc: Rakhi Verma/HSS)

Subject:  [Megaco] two transactions in the same message

Hi all,

Option a)

Option b)

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: [email-masked]
Date: Tue, 12 Nov 2002 14:45:38 +0530

Hi,

regards
Rakhi Verma
Hughes Software Systems
www.hssworld.com

Hi all,

Option a)

Option b)

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 13 Nov 2002 02:16:16 -0500

Quite simply, we didn't think about it.

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]] 
Sent: Tuesday, November 12, 2002 10:00 AM
To: Fernando Vallejo Lazaro; Megaco
Cc: Taylor, Tom-PT [CAR:B602:EXCH]; Madhu Babu Brahmanapally
Subject: Re: [Megaco] two transactions in the same message

[snip]

Note: What was the reason for not using any separator for multiple
transactions in a message unlike in other cases?

/anil.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 13 Nov 2002 02:16:16 -0500

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]] 
Sent: Tuesday, November 12, 2002 10:00 AM
To: Fernando Vallejo Lazaro; Megaco
Cc: Taylor, Tom-PT [CAR:B602:EXCH]; Madhu Babu Brahmanapally
Subject: Re: [Megaco] two transactions in the same message

[snip]

/anil.