Subject: Re: [Megaco] Stop dial tone after receiving the first digit

From: [email-masked]
Date: Thu, 21 Nov 2002 19:05:08 +0100

Zhaobo,

You have to send a modify command on the termination with en empty
signal descriptor Signals {} to stop the dial tone.

Jean-Luc Lecuyer

zhaobo <[email-masked]>@ietf.org on 21/11/2002 05:16:54

Sent by:    [email-masked]

To:    [email-masked]
cc:
Subject:    [Megaco] Stop dial tone after receiving the first digit

Hi all:
    For DTMF phone, dial tone is always stopped when first digit is sent.
    How is this behaviour specified for a MGW in a H.248 message? Seems not
    the type of signal(on/off, brief, or timeout).
    Maybe just because in any case the dial tone shall be stopped after
    receiving a digit,  it's not neccessary to specified in H.248?
    Thanks.

_______________________________________________
Megaco mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 21 Nov 2002 13:21:44 -0500

No.  Kevin was correct.  Any event implicitly stops active signals by 
default.  An empty signals descriptor is only needed to stop a signal 
without an event or if the event had KeepActive set.

-- 
-------------------------------------------------------
Terry L Anderson                     [email-masked]
Voice: +1 908.766.4463	        Mobile: +1 908.342.9595
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 21 Nov 2002 13:21:44 -0500

---

From: zhaobo <[email-masked]>
Date: Fri, 22 Nov 2002 14:26:33 +0800

But in the case of digimap, the first received digit may not be an event. A event isn't generated till a match.

---

From: zhaobo <[email-masked]>
Date: Fri, 22 Nov 2002 14:26:33 +0800