Subject: RE: [Megaco] Stop dial tone after receiving the first digit

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 22 Nov 2002 14:47:36 -0500

This is incorrect.  The digit map allows detection of individual digit
events, but collects them into one response.  Each detected digit is a
separate event, and signal processing would halt upon detection of each
digit.

Kevin

-----Original Message-----
From: zhaobo [mailto:[email-masked]] 
Sent: Friday, November 22, 2002 1:36 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; [email-masked]
Subject: Re: [Megaco] Stop dial tone after receiving the first digit

RE: [Megaco] Stop dial tone after receiving the first digitHi Kevin, which I
mean is "the first digit", not an EVENT. In the digital map case, only a
macth makes a EVENT. For example, when the digitmap is 2XXX, a digit "2"
stops the dialtone, but a event will not be make until the other three
digits be dialed.

----- Original Message ----- 
From: Kevin Boyle 
To: zhaobo ; [email-masked] 
Sent: Friday, November 22, 2002 2:04 AM
Subject: RE: [Megaco] Stop dial tone after receiving the first digit

Detected events stop signals by default. See sections 7.1.9 and 7.1.11. 
Kevin 
-----Original Message----- 
From: zhaobo [mailto:[email-masked]] 
Sent: Wednesday, November 20, 2002 11:17 PM 
To: [email-masked] 
Subject: [Megaco] Stop dial tone after receiving the first digit 

Hi all: 
    For DTMF phone, dial tone is always stopped when first digit is sent.
How is this behaviour specified for a MGW in a H.248 message? Seems not the
type of signal(on/off, brief, or timeout). 
    Maybe just because in any case the dial tone shall be stopped after
receiving a digit,  it's not neccessary to specified in H.248?
    Thanks. 
    
_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Vance Shipley <[email-masked]>
Date: Fri, 22 Nov 2002 15:45:23 -0500

And when is the event signaled, at the leading or trailing edge?

A DMS breaks dialtone when you release the key while a 5ESS will
break dialtone as soon as the tone is recognized.  To pick a nit.

	-Vance

---

From: Vance Shipley <[email-masked]>
Date: Fri, 22 Nov 2002 15:45:23 -0500

-Vance