Subject: [Megaco] Implementing Packages (URGENT !!)

From: Kanika Garg <[email-masked]>
Date: Sun, 17 Nov 2002 23:20:08 -0800 (PST)

Hi all,

As stated in the name patterns drafts of Megaco,
terminations implementing same set of packages belong
to one type.  I wanted to know what does implementing
same set of packages, actually mean?

If suppose at the time of adding a termination to a
context, MGC specifies some events that are to be
detected.  Those events would be defined in some
packages, say in pckg. p1 and p2.  Now, suppose in a
modify command MGC requests to detect some other event
on the same termination as before, but this event is
defined in some other package, say p4,  then does this
mean that the term. is implementing a diff. set of
packages now, and hence it belongs to a diff. type. If
this is so, then the type of termination would keep on
changing dynamically.

Please do clarify, it's urgent.
Thanks

Kanika Garg

=====
Kanika Garg
Engineer Trainee,
Next Generation Networks Group,
HFCL, R&D Division, Gurgaon

+91-124-8901601/701 (Extn. 315)
9818082414

__________________________________________________
Do you Yahoo!?
Yahoo! Web Hosting - Let the expert host your site
http://webhosting.yahoo.com
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Mon, 18 Nov 2002 10:41:58 +0200

The set of packages that a termination implements indicates the complete set
of features it is capable of providing if requested, not the events or
signals that it is currently detecting or playing.  Thus a new command from
the MGC has no effect on the set of implemented packages.

Raphael Tryster

	-----Original Message-----
	From:	Kanika Garg [SMTP:[email-masked]]
	Sent:	Monday, 18 November, 2002 9:20 AM
	To:	[email-masked]
	Subject:	[Megaco] Implementing Packages (URGENT !!)

	Hi all,

	Kanika Garg

	=====
	Kanika Garg
	Engineer Trainee,

---

From: [email-masked]
Date: Thu, 21 Nov 2002 14:41:47 +0530

Hi Kanika,

This doesn't change type of termination, but only those properties are
configured for those termination.
PACKAGES has PROPERTIES  which can be configured either while ADD command or
using MODIFY command.

On MG side, these packages are implemented for that particular termination. So
if neccessary software and hardware exist
at MG for supporting, say DTMF tone geneartor package, then the termination
supports that package. So MGC or any controlling entity can
AUDIT these terminations to know which all PACKAGES the terminations support.
And with AUDIT command, controlling entity can know
what all packages are supported by that termination, usually at startup time,
when terminations are in NULL context.

With Regards,
- Deepak

Kanika Garg <[email-masked]> on 11/21/2002 02:03:57 PM

To:   "K.V.N. Sridhar" <[email-masked]>, Megaco Mailing List
      <[email-masked]>
cc:    (bcc: Deepak Nagrath/HSSDLF)

Subject:  Re: [Megaco] Implementing Packages (URGENT !!)

Hello Sridhar,

I got your point clearly. But one thing that is left
unanswered is -

"When a termination, be it physical or ephemeral, is
added to a context, then we may specify some
properties in the descriptors of the ADD command. How
do they effect the properties of a termination, and
the packages it is implementing... does that change
the type of the termination."

>> What packages are implemented on what termination
>> is *provisioned* in the MG.

WHEN are these details specified, i mean to say, when
the terminations are in NULL Context or when they are
actively involved in a call, i.e. in some particular
context.

Your views on these ques. as well, would be beneficial
Looking forward for a reply,
Thanks,

Kanika Garg

--- "K.V.N. Sridhar" <[email-masked]> wrote:
>
> Packages implemented on the termination specify all
> possible
> signals, events etc it can receive dynamically.
> What packages are implemented on what termination is
> *provisioned*
> in the MG. MGC can learn either by profile or by
> Auditing the
> terminations.
> Eg. FXS terminations implement Analog Supervision ,
> Dtmf detection,
> Call progress tone generation  .. packages
> and whatever signals or events ... they receive from
> MGC will
> be within these packages. So these kind of
> terminations for a
> *TYPE* for convenience.
>
> Sridhar
> --
>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>                         K.V.N SRIDHAR
>                         Senior Engineer - R&D
>                         HFCL-IISC Research Project
>                         IISc Campus - Bangalore -
> 560 012
>                         Voice: (+91)-80-3562062
>                         Email:
> [email-masked]
>                     [email-masked]
>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

=====
Kanika Garg
Engineer Trainee,

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus ? Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 21 Nov 2002 14:41:47 +0530

Hi Kanika,

With Regards,
- Deepak

Hello Sridhar,

Kanika Garg

=====
Kanika Garg
Engineer Trainee,