Subject: [Megaco] Hairpin Connection Doubts

From: mukta vasudeva <[email-masked]>
Date: Wed, 27 Nov 2002 12:36:34 +0000 (GMT)

hey everyone,greetings.

I have some queries..concerning Haripin connections. I need to know how the handling of hairpin connections 

a.)with respect to MGC : How it handles Megaco messages for this situation.

b) with respect to MG : How it implements the above scenario

The way i see it ,there could be two ways of proceeding:

Case 1.Maintains ONE Context that contains the two TDM Terminations.Then  MGC sends the respective commands to terminations within the same MG,and same ContextID.That is,for the MGC, the source and destination ContextID are same.

Case2: TWO Contexts are maintaned in the same MG for the connection.One Context contains the source TDM termination and one RTP Termination.The other Context contains the destination TDM Termination and one RTP Termination.  The MGC now creates the connection and manages it in the usual style: except that the ContextIDs are different but reside on the same Media Gateway ,and the RTP voice path is local to the Media Gateway..

I dont know about the feasibilty of either of the above situations so I need some input here as to how this situation is actually handled.          

Thankyou . 

Mukta Vasudeva 

1

Catch all the cricket action. Download Yahoo! Score tracker

---

From: "Noh Jeong Min" <[email-masked]>
Date: Thu, 28 Nov 2002 09:28:52 +0900

I think case1 is more suitable for hairpin connection.

Hairpin connection is between subscribers connected to the same MG. So, Ephemeral(RTP) Termination could be replace by physical termination in the
hairpin connection.

I think MGC should add two physical terminations into one context. My example is below. (LINE/0001 makes a call to LINE/0002)

MGC->MG
MEGACO/1 [123.123.123.4]:55555 
   Transaction = 10004{ 
        Context = ${
                Add = LINE/0001{ 
                        Media{ Stream = 1{ LocalControl {Mode = ReceiveOnly, tdmc/ec=off} }},  
                        Signals{cg/rt}
                } 
                Add = LINE/0002{ 
                        Media{ Stream = 1{ LocalControl {Mode = SendReceive, tdmc/ec=off} }}, 
                        Events=1234{al/of(strict=state)},  
                        Signals{al/ri}
                },
       } 
   }   

MG -> MGC: 
MEGACO/1 [124.124.124.222]:55555 
   Reply = 10004 { 
      Context = 2000 {Add = LINE/0001, Add = LINE/0002} 
   } 

Noh Jeong Min.
IMT System Development Group. MERCURY Corporation. Ltd.
Tel : +82 031 310 5714
Email : [email-masked]
  ----- Original Message ----- 
  From: mukta vasudeva 
  To: [email-masked] 
  Sent: Wednesday, November 27, 2002 9:36 PM
  Subject: [Megaco] Hairpin Connection Doubts

  hey everyone,greetings.

  Thankyou . 

  Mukta Vasudeva 

  1

---

From: "Noh Jeong Min" <[email-masked]>
Date: Thu, 28 Nov 2002 09:28:52 +0900

MGC->MG

MG -> MGC: 

Noh Jeong Min.
  ----- Original Message ----- 
  From: mukta vasudeva 
  To: [email-masked] 
  Sent: Wednesday, November 27, 2002 9:36 PM
  Subject: [Megaco] Hairpin Connection Doubts

  hey everyone,greetings.

  Thankyou . 

  Mukta Vasudeva 

  1