Subject: Re: [Megaco] Fate Of SDP-TDM Draft

From: Christian Groves <[email-masked]>
Date: Wed, 06 Nov 2002 10:36:48 +1100

Hello,

I don't understand why SDP is mapped to H.245 if H.323 is used?? For a couple of
reasons: 1. the H.323 termination is not a TDM termination, 2. SDP is not used
in ISUP/ISDN/H323 systems.

The USI would come into the MGC in its native form and can also be used in H323
this way. As todays TDM systems understand the USI in its native binary form I
don't see the point in duplicating the same information in SDP form. Q.1950
already defines the USI (in hex coded binary form) to be carried between the MGC
and MG.

Regards, Christian

[email-masked] wrote:
> 
> Hi Tom,
>            The MGC may be using H.323 as a signaling mechanism with another MGC.
> In that case
>   detailed parsing of MGC would be required to map SDP parameters to H.245
> capability elements.
> 
> Rgds,
> 
> Vikas Bajaj
> Next Generation Networks Group
> Hughes Software Systems Ltd
> 
> "Tom-PT Taylor" <[email-masked]> on 10/31/2002 10:37:04 AM
> 
> To:   "[email-masked]'" <[email-masked]>
> cc:    (bcc: Vikas Bajaj/HSS)
> 
> Subject:  [Megaco] Fate Of SDP-TDM Draft
> 
> I'm asking what to do with the SDP-TDM draft
> (draft-taylor-mmusic-sdp-tdm-01.txt).  Christian Groves raised the proposal
> that the bearer capability and related information elements be extracted
> from call signalling and passed to the MG in their binary form, rather than
> undergo the text transformation provided in the draft.
> 
> This is an architectural issue.  I know that there is a school of thought
> that tries to avoid detailed parsing and generation of SDP in the MGC,
> viewing SDP as something more in the nature of MG-to-MG signalling.  My
> draft forces the MGC to become intimately involved in that process.
> 
> So it's up to you: does the draft go forward, or do I let it die?  I haven't
> sent this to the mmusic list because I never seem to get any comments from
> that quarter.
> 
> Tom Taylor
> [email-masked]
> Ph. +1 613 736 0961 (ESN 396 1490)
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 06 Nov 2002 10:36:48 +1100

Hello,

Regards, Christian