Subject: Re: [Megaco] A query about normalMGExecutionTime, MGProvisionalResponseTimerValue.

From: Christian Groves <[email-masked]>
Date: Fri, 08 Nov 2002 17:44:23 +1100

G'Day Anil,

I'm afraid I misled you with my earlier answer (a colleague spotted it), I mixed
up the order of the timers my answer should read:

> Your assessment of the situation is nearly correct but the difference is not as
> correct as it could be. The "MGProvisionalResponseTimerValue" is the time used 
> whereby the MGC will know that the MG has hung on processing a certain > transaction. Its
> not particular to retransmission. The "normalMGexecutionTime" is as
> you say used to control the transmission of the TransactionPending.

Regards, Christian

Christian Groves wrote:
> 
> Hello Anil,
> 
> Your assessment of the situation is nearly correct but the difference is not as
> correct as it could be. The "normalMGexecutionTime" is the time used wehereby
> the MGC will know that the MG has hung on processing a certain transaction. Its
> not particular to retransmission. The "MGProvisionalResponseTimerValue" is as
> you say used to control the transmission of the TransactionPending.
> 
> Christian
> 
> HI,
> 
> Please ignore my earlier reply to this question....
> 
> MO... is as follows...
> 
> normalMGExecutionTime :
> This is the time when expires, MGC would retransmit the message to the MG. In
> other words, this is the time (maximum) MG should take to process a
> Transaction.
> MGProvisionalResponseTimerValue
> This is the time when expires, MG would send the provisional response to the
> MGC. This indicates that the given transaction is going to take longer timer
> to execute so to avoide the retransmissions at the sender's end. The reception
> of provisional response would also result in restarting the
> "normalMGExecutionTime" for the given transaction.
> Now about the difference....
> The "normalMGExecutionTime" is ued to retrasmit the message where as
> "MGProvisionalResponseTimerValue" is used to control this retrasmission.
> 
> My question is, does MG have control over the normalMGExecutionTime. Can MG
> alter the value of it?? as service change can go from either MG or
> MGC.
> 
> /anil.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 08 Nov 2002 17:44:23 +1100

G'Day Anil,

Regards, Christian