Subject: [Megaco] doubts in reserve property

From: mukta vasudeva <[email-masked]>
Date: Wed, 4 Dec 2002 05:56:18 +0000 (GMT)

hi all,  

When Reserve Value or Reserve Group is true, multiple resources  are reserved in MG. How does the MG decide to use a particular resource from the available options that it has already reserved. 

E.g.  MGC specified ReserveValue= True & 

Local Descriptor looks like:

Local={

v=0

o=...

s=...

c=ATM ...

m=audio ? RTP/AVP 0 1

}

In response MG reserved both the codec types specified.

So at which point does the MG find out which of the two codecs that it has reserved resources for will be used?

But the Rfc Specifies :  If the Mode property of the LocalControl descriptor is 

         RecvOnly, SendRecv, or LoopBack, the MG must be prepared to 

         receive media encoded according to any of the alternatives 

         included in its response to the MGC. 

Does the above clause mean that in this case MG has to recognize the Codec Type dynamically, that is, Codec Type  will be determined from the RTP header field : Payload Type?

Relevant Clause from RFC : page 31. : If media begins to flow while more than a single alternative is  reserved, media packets may be sent/received on any of the  alternatives and must be processed, although only a single  alternative may be active at any given time. 

 regards,

mukta vasudeva

Catch all the cricket action. Download Yahoo! Score tracker

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 13 Dec 2002 09:45:26 -0500

Assuming reserveValue (for instance) remains set to TRUE:

  -- on the receiving side, the MG has to detect the payload type
dynamically and process the media accordingly.  The MG has expressed a
preference by the order in which it listed the codecs in Local.

  -- on the sending side, the MG has a choice.  The far end has expressed
its preference by the order of codecs given in Remote, so that is one way to
choose.  Unfortunately I couldn't figure out how to enforce symmetry (same
codec at each end) when we were working out the negotiation rules.  That is
generally desirable, since it conserves resources.  In the present
circumstances, one possibility is to have a second round of negotiation to
narrow down the selection, like some of the 3GPP call flows.

-----Original Message-----
From: mukta vasudeva [mailto:[email-masked]] 
Sent: Friday, December 13, 2002 3:47 AM
To: [email-masked]
Subject: RE: [Megaco] doubts in reserve property

hi wang, 
you seem to have shown the normative procedure. 
(Wang) 
"I think 
1) 
the calling side will  report all  the list of codecs when MGC set
reserveGroup and  reserveValue to true.
2)
the callee side will  choose out of the list of codecs with decreasing
priority when reserveValue set to false.
3)When MGC send modify to calling side,it will select a specific codec which
calling side have to use."

>>(Mukta) But my question is, what should be the method of operation of MG,
if for some reason MGC does not send the above message choosing a specific
codec out of all the reserved codecs?

(Wang)
"
4)It is obvious that the calling MG will change codec which it reserves
according to the command from MGC during the call."
Thanking You, 
Mukta . 
 VND Wang JuLin <[email-masked]> wrote: 
I think 
1) 
the calling side will  report all  the list of codecs when MGC set
reserveGroup and  reserveValue to true.
2)
the callee side will  choose out of the list of codecs with decreasing
priority when reserveValue set to false.
3)When MGC send modify to calling side,it will select a specific codec which
calling side have to use.
4)It is obvious that the calling MG will change codec which it reserves
according to the command from MGC during the call.
-----Original Message-----
From: mukta vasudeva [mailto:[email-masked]]
Sent: Wednesday, Decembeer 04, 2002 1:56 PM
To: [email-masked]
Subject: [Megaco] doubts in reserve property

hi all,  
When Reserve Value or Reserve Group is true, multiple resources  are
reserved in MG. How does the MG decide to use a particular resource from the
available options that it has already reserved. 
E.g.  MGC specified ReserveValue= True & 
Local Descriptor looks like:
 Local={v=0o=...s=...c=ATM ...m=audio ? RTP/AVP 0 1 } In response MG
reserved both the codec types specified.
So at which point does the MG find out which of the two codecs that it has
reserved resources for will be used?
 
But the Rfc Specifies :  If the Mode property of the LocalControl descriptor
is 
         RecvOnly, SendRecv, or LoopBack, the MG must be prepared to 
         receive media encoded according to any of the alternatives 
         included in its response to the MGC. 
 
Does the above clause mean that in this case MG has to recognize the Codec
Type dynamically, that is, Codec Type  will be determined from the RTP
header field : Payload Type?

Relevant Clause from RFC : page 31. : If media begins to flow while more
than a single alternative is  reserved, media packets may be sent/received
on any of the  alternatives and must be processed, although only a single
alternative may be active at any given time. 
 regards,
mukta vasudeva
 Catch all the cricket action. Download Yahoo! Score tracker
 Catch all the cricket action. Download Yahoo! Score tracker
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 13 Dec 2002 09:45:26 -0500

-----Original Message-----
From: mukta vasudeva [mailto:[email-masked]] 
Sent: Friday, December 13, 2002 3:47 AM
To: [email-masked]
Subject: RE: [Megaco] doubts in reserve property

hi wang, 

(Wang)
"
-----Original Message-----
From: mukta vasudeva [mailto:[email-masked]]
Sent: Wednesday, Decembeer 04, 2002 1:56 PM
To: [email-masked]
Subject: [Megaco] doubts in reserve property

hi all,