Subject: RE: [Megaco] about Streams

From: Raphael Tryster <[email-masked]>
Date: Tue, 31 Dec 2002 10:08:27 +0200

Dan,

Let me see if I understand you correctly.  Are we talking about a single
ephemeral termination, with 3 streams?  Do the local descriptors of the 3
streams share the same IP address but a different port for each, thus 3 UDP
sockets?  What about the remote descriptors?  Is there any requirement that
they all share the same IP address?

Could the same thing be implemented  by creating 3 ephemeral terminations,
each with one stream?  Is there any intrinsic property that dictates what
constitutes a single ephemeral termination?

Regards,

Raphael Tryster

	-----Original Message-----
	From:	Dan  Elbert [SMTP:[email-masked]]
	Sent:	Thursday, 01 August, 2002 2:34 PM
	To:	'Fhuval Hittay'; [email-masked]
	Subject:	RE: [Megaco] about Streams

	Actually is 6 ports - 3 locals and 3 remotes.

	-----Original Message-----
	From: Fhuval Hittay [mailto:[email-masked]]
	Sent: Thursday, August 01, 2002 2:12 PM
	To: [email-masked]
	Subject: [Megaco] about Streams

	 Hello everybody!
	 Could anyone say, if for example one ephemeral termination have 3
streams
	on 
	it, does it mean that that termination have 3 RTP ports - each with
its own 
	Local, Remote and LocalControl Descriptors?

	Please, answer ASAP...
	----
	  http://www.rambler.ru

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Tue, 31 Dec 2002 10:08:27 +0200

Dan,

Regards,

Raphael Tryster

	-----Original Message-----
	From: Fhuval Hittay [mailto:[email-masked]]
	Sent: Thursday, August 01, 2002 2:12 PM
	To: [email-masked]
	Subject: [Megaco] about Streams

	 Hello everybody!

	Please, answer ASAP...
	----
	  http://www.rambler.ru

---

From: Dan Elbert <[email-masked]>
Date: Tue, 31 Dec 2002 13:54:43 +0200

Hi
I meant to say that if the ephemeral termination has 3 streams on it (for
example, audio,video and data) for each stream will be a Local Descriptor
and a Remote Descriptor.
It seems like the most natural implementation will be that a separate UDP
socket is used to receive each of the streams, and they all share the same
IP address, but there is no specific requirement on this. Is an
implementation issue.
You can implement this with 3 ephemeral termination, but you loose some of
the advantages. For example, if you move the termination to a different
context, you have to do it now 3 times, etc.
I also think that there is an implicit assumption that all media streams in
the same termination are synchronized, but I may be wrong on this.
 
Dan

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Tuesday, December 31, 2002 10:08 AM
To: Dan Elbert; 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] about Streams

Dan, 

Let me see if I understand you correctlyms?  Do the local descriptors of the
3 streams share the same IP address but a different port for each, thus 3
UDP sockets?  What about the remote descriptors?  Is there any requirement
that they all share the same IP address?

Regards, 

Raphael Tryster 

	BM__MailData-----Original Message----- 

	-----Original Message----- 
From: Fhuval Hittay [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, August 01, 2002 2:12 PM 
To: [email-masked] 
Subject: [Megaco] about Streams 

	 Hello everybody! 
 Could anyone say, if for example one ephemeral termination have 3 streams 
on 
it, does it mean that that termination have 3 RTP ports - each with its own 
Local, Remote and LocalControl Descriptors? 

	Please, answer ASAP... 
---- 
  http://www.rambler.ru <http://www.rambler.ru>  

	_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>  

	_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: Dan Elbert <[email-masked]>
Date: Tue, 31 Dec 2002 13:54:43 +0200

Hi
 
Dan

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Tuesday, December 31, 2002 10:08 AM
To: Dan Elbert; 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] about Streams

Dan, 

Regards, 

Raphael Tryster 

	-----Original Message----- 
From: Fhuval Hittay [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, August 01, 2002 2:12 PM 
To: [email-masked] 
Subject: [Megaco] about Streams 

	 Hello everybody! 

	Please, answer ASAP... 
----