Subject: [Megaco] doubt in draft-boyle-megaco-alerting-03.txt

From: Alan Chou <[email-masked]>
Date: Mon, 23 Dec 2002 20:44:11 +0800

Hi all,
In Analog Display Signaling Package defined signal Display with Alerting
(dwa) which has two parameters Pattern and Display Data Block (ddb), if
the user is in on-hook state, the pattern means cw signal should be
played on the user line, to generate call waiting indication (generation
of distinctive waiting tones according the pattern parameters). 
My doubt is how can MG play CW signal and also dwa data on the user line
at same time? Shall MG play dwa data after the CW signal tone finished
or use other kind of alerting method instead of play tone? If use
another alerting method to altering, can you tell me which kind is
normal?
Thanks & Regards
------------------------------------------------------------------------
----
Alan Chou
Huawei Technologies Co, Ltd.
3rd floor Luneng Building, No. 1 Shangdi 6th Street,
Haidian district,  Beijing, China 100085
Fax      : +86 (0)10 82882937
Phone  : +86 (0)10 82882599
E-mail  :  <mailto:[email-masked]> [email-masked]
Web    :  <http://www.huawei.com> http://www.huawei.com
------------------------------------------------------------------------
----

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Mon, 23 Dec 2002 17:30:34 +0100

Hi,
 
The pattern implies the cw signal when the user is in "off-hook" state (not "on-hook"). If the user is in "on-hook" state, the pattern implies a ringing signal.
 
Normal behaviour in North-America and ETSI-compliant countries is as follows: The MG plays the CW tone first, then it sends a Dual-Tone Alerting Signal to signal to the terminal equipement that data transmission is to be expected. It waits for an ACK digit from the terminal and sends the ddb contents.
 
There might be alternative implementations in other regions.
 
Regards,
Bruno Chatras
 
-----Message d'origine-----
De : Alan Chou [mailto:[email-masked]]
Envoyé : lundi 23 décembre 2002 13:44
à : [email-masked]; [email-masked]; CHAPRON Jean-Emman FTRD/DAC; CHATRAS Bruno FTRD/DAC
Cc : [email-masked]
Objet : doubt in draft-boyle-megaco-alerting-03.txt

Hi all,
In Analog Display Signaling Package defined signal Display with Alerting (dwa) which has two parameters Pattern and Display Data Block (ddb), if the user is in on-hook state, the pattern means cw signal should be played on the user line, to generate call waiting indication (generation of distinctive waiting tones according the pattern parameters). 
My doubt is how can MG play CW signal and also dwa data on the user line at same time? Shall MG play dwa data after the CW signal tone finished or use other kind of alerting method instead of play tone? If use another alerting method to altering, can you tell me which kind is normal?
Thanks & Regards
----------------------------------------------------------------------------
Alan Chou
Huawei Technologies Co, Ltd.
3rd floor Luneng Building, No. 1 Shangdi 6th Street,
Haidian district,  Beijing, China 100085
Fax      : +86 (0)10 82882937
Phone  : +86 (0)10 82882599
E-mail  :  <mailto:[email-masked]> [email-masked]
Web    :  <http://www.huawei.com> http://www.huawei.com
----------------------------------------------------------------------------

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Mon, 23 Dec 2002 17:30:34 +0100

Hi,

 
 
Regards,
Bruno Chatras
 
-----Message d'origine-----
De : Alan Chou [mailto:[email-masked]]
Envoyé : lundi 23 décembre 2002 13:44
à : [email-masked]; [email-masked]; CHAPRON Jean-Emman FTRD/DAC; CHATRAS Bruno FTRD/DAC
Cc : [email-masked]
Objet : doubt in draft-boyle-megaco-alerting-03.txt

Hi all,