Subject: RE: [Megaco] Querying MG for supported Codecs

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 19 Dec 2002 15:37:06 -0500

When we were defining the negotiating rules, the intention was that setting
ReserveValue and/or ReserveGroup to TRUE would bring out a comprehensive
list of what the MG was prepared to support for that termination.  Beyond
that, we should look forward to how we can use SDPng.

> -----Original Message-----
> From: marianne picha [mailto:[email-masked]] 
> Sent: Thursday, December 19, 2002 10:47 AM
> To: [email-masked]
> Subject: [Megaco] Querying MG for supported Codecs
> 
> 
> Does anyone know of a way in which the MGC can determine via 
> H.248 the types of Codecs supported in the media gateway? I'm 
> wondering if this can be done without defining a new package.
> 
> Thanks in advance for your thoughts/ideas.
> M. Picha
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Dec 2002 10:40:40 +1100

One way is to instantiate ephermal termination or a physical codec (without any
instantiation) and then audit capabilities on the codec property using
IndAuditCapabilities. You then get a list of codecs that can be supported for
that termination type.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Dec 2002 10:40:40 +1100

Regards, Christian

---

From: Manuel Poza <[email-masked]>
Date: Fri, 20 Dec 2002 11:29:26 +0100

Hi, Marianne
An example of how codecs could be audited could be the following:

The MGC audits MG1.
MGC to MG1:
MEGACO/1.0 [123.123.123.4]:55555
          Transaction = 50 {
              Context = - {W-AuditValue = * {Audit{Media, Packages}}}
           }; W indicates that Audit reply must use wildcards

MG1 replies. MG1 to MGC:
MEGACO/1.0 [125.125.125.111]:55555
           Reply = 50 {
            Context = - {
             AuditValue = * {
              Media {
               Stream = 1 {
                Local  {
                     v=0
                     c=IN IP4 $
                     m=audio $ RTP/AVP 4
                     v=0
                     c=IN IP4 $
                     m=audio $ RTP/AVP 0
                         } ;
                       }},
            Packages {al, rtp, ipfax, fax, ctyp, cg}
             } }}

Best regards,
Manuel

---

From: Manuel Poza <[email-masked]>
Date: Fri, 20 Dec 2002 11:29:26 +0100

Hi, Marianne

The MGC audits MG1.
MGC to MG1:

MG1 replies. MG1 to MGC:

Best regards,
Manuel