Subject: [Megaco] two transactions in the same message

From: "Anil Jangam" <[email-masked]>
Date: Tue, 31 Dec 2002 11:59:32 +0530

Hi,

Is it possible to have differing type of the transactions in the same message
or
Does the message always contains the same type of transactions and another type of transaction (e.g. TransactionReply) goes into separate message.

with regds,
/anil.

  ----- Original Message ----- 
  From: Anil Jangam 
  To: Fernando Vallejo Lazaro ; Megaco 
  Cc: Tom-PT Taylor ; Madhu Babu Brahmanapally 
  Sent: Tuesday, November 12, 2002 2:33 PM
  Subject: Re: [Megaco] two transactions in the same message

  Hi,

  As per the protocol encoding rule, there is NO COMMA separator between two transactions in a message. Hence the your option-b may result into a syntax error (400). The option-a is correct one. You have to read each transaction with the transaction token and corresponding start and end brace.

  Note: What was the reason for not using any separator for multiple transactions in a message unlike in other cases?

  /anil.

    ----- Original Message ----- 
    From: Fernando Vallejo Lazaro 
    To: Megaco 
    Sent: Tuesday, November 12, 2002 1:48 PM
    Subject: [Megaco] two transactions in the same message

    Hi all, 
    If I wish to send two transactions within the 
    same message which of the next two options is the right one? 

    Option a) 

    MEGACO/1 [123.123.123.4]:55555 
       Transaction = 9999 { 
           Context = - { 
               Modify = A4444 {... } 
            } 
      } 
       Transaction = 10000 { 
           Context = - { 
               Modify = A4445 {... } 
            } 
      } 

    Option b) 

    MEGACO/1 [123.123.123.4]:55555 
       Transaction = 9999 { 
           Context = - { 
               Modify = A4444 {... } 
            } 
      },                                            <----- Note the comma here 
       Transaction = 10000 { 
           Context = - { 
               Modify = A4445 {... } 
            } 
      } 

    Regards 
    Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

  *********************************************************
  Disclaimer

  This message (including any attachments) contains 
  confidential information intended for a specific 
  individual and purpose, and is protected by law. 
  If you are not the intended recipient, you should 
  delete this message and are hereby notified that 
  any disclosure, copying, or distribution of this
  message, or the taking of any action based on it, 
  is strictly prohibited.

  *********************************************************
  Visit us at http://www.mahindrabt.com

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Tue, 31 Dec 2002 11:59:32 +0530

Hi,

with regds,
/anil.

  ----- Original Message ----- 
  From: Anil Jangam 
  To: Fernando Vallejo Lazaro ; Megaco 
  Cc: Tom-PT Taylor ; Madhu Babu Brahmanapally 
  Sent: Tuesday, November 12, 2002 2:33 PM
  Subject: Re: [Megaco] two transactions in the same message

  Hi,

  /anil.

    ----- Original Message ----- 
    From: Fernando Vallejo Lazaro 
    To: Megaco 
    Sent: Tuesday, November 12, 2002 1:48 PM
    Subject: [Megaco] two transactions in the same message

    Hi all, 

    Option a) 

    Option b) 

    Regards 
    Fernando 

-- 
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL