Subject: RE: [Megaco] Service change Restart

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 18 Mar 2003 13:57:46 -0500

The current plan is to incorporate it back into both V1 and V2 (since the
new Annex doesn't change the existing spec, it only makes clarifications).
The current timeline is May, however, I wouldn't be surprised if the Annex
will be held until February 2004.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 17, 2003 10:55 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]; [email-masked];
Megaco List
Subject: RE: [Megaco] Service change Restart

Hi Kevin

Thanks for the useful pointer...
I did like to know if the Annex-F is intended to be part of H.248v2 only or
will also be applicable to H.248v1. Any information about the time lines by
when it would be finalised/ freezed.

regards,
-kapil nayar
http://www.hssworld.com

"Kevin Boyle" <[email-masked]> on 03/14/2003 08:33:23 PM

To:   "Tom-PT Taylor" <[email-masked]>, Kushanava Laha/HSS@HSS
cc:   Sachin Gupta-PNGN/HSS@HSS, Megaco List <[email-masked]> (bcc: Kapil
      Nayar/HSS)

Subject:  RE: [Megaco] Service change Restart

This work is ongoing in SG16 as future Annex F.  Both of these items are
intended to be clarified by the new work.

The input documents to the San Jose Rapporteurs' Meeting can be found as
AVD-2310, AVD-2311, and AVD-2298 at
ftp://standard.pictel.com/avc-site/0302_San/.

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Friday, March 14, 2003 9:30 AM
To: [email-masked]
Cc: [email-masked]; Megaco List
Subject: Re: [Megaco] Service change Restart

This is where the RFC is completely inadequate as it stands.  I wouldn't
mind seeing it rewritten to specify separately what happens for
ServiceChange on ROOT vs. ServiceChange on individual terminations.  With
regard to the latter, there is also something else I'd like to see ironed
out: the service state is a writable property in TerminationState, yet it is
manipulated by ServiceChange.  One or the other of these should go.

I am quite prepared to submit a proposal for new text for section 7.2.8 in
particular.  Would there be interest in reviewing such a proposal?  We could
submit it as a contribution into SG 16's May meeting if that is workable.

[email-masked] wrote:
>
> How about ServiceChange Restart on ROOT from MGC?Does the protocol 
> inhibit it? (It can be an easier means for the MGC to inform MG to 
> delete all contexts rather than 'Subtract'ing each of them, when MGC 
> is taken gracefully
> out-of-service)
>
>
>
>
>
> Tom Taylor <[email-masked]> on 03/14/2003 12:27:35 AM
>
> To:   Sachin Gupta-PNGN/HSS@HSS, Megaco List <[email-masked]>
> cc:    (bcc: Kushanava Laha/HSS)
>
> Subject:  Re: [Megaco] Service change Restart
>
>
>
> I agree that it's very difficult to assign any real meaning to an 
> MGC-initiated restart of a termination.  My background in switch 
> software development tells me that a restart clears certain aspects of 
> state.  However, that makes little sense in the Megaco case, because 
> the MGC can do that directly by subtracting the termination from any 
> context it is in and resetting descriptors if it is not in a
context.
>
> Conclusion: the only thing an MGC-initiated restart of a termination 
> does is change its state to in-service if it is not already there.
>
> [email-masked] wrote:
>
>>Hi List
>>I have a query regarding the processing of Service Change Restart. 
>>consider the following scenario:
>>
>>Termination is in state InService.
>>Command recieved from MGC to Restart the termination (with or wothout 
>>delay).
>>
>>what MG could possibly do in this case?
>>
>>
>>Thanks
>>Sachin Gupta
>>
>
> [disclaimer snipped]
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
>
>
>
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 20 Mar 2003 11:04:15 +1100

G'Day,

I don't think it has been decided to incorporate it back into both v1 and v2.
>From discussion at SanJose I thought we would take the decision on what to do
with the work ie. annex, appendix or merging when it came nearer to the time to
approve the work.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 20 Mar 2003 11:04:15 +1100

G'Day,

Regards, Christian