Subject: Re: [Megaco] OT: "equivalent" codecs

From: "Paul Long" <[email-masked]>
Date: Tue, 04 Mar 2003 11:07:16 -0500

Troy,

G.729 and G.729a put the same bits on the wire, so the receiver cannot 
distinguish between the two; therefore, they can be used 
interchangeably. G.729a just defines a reduced-complexity 
_implementation_ of G.729. Signaling protocols should never have 
introduced Annex A as an audio codec distinct from the base standard. 
It causes needless confusion such as what you're experiencing.

Paul

> 
> If a gateway is asked to use G729A, which it doesn't have,
> but it has a G729 implementation, should it use it?
> 
> And vice versa?
> 
> -troy
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Tue, 04 Mar 2003 11:45:50 -0500

Just playing devil's advocate...

There is a voice quality tradeoff for the complexity, yes?

What about the notion of the RGC wanting control over
the voice quality level and the RG's resources?
The RGC may require G729 voice quality not G729A.
The RGC may require G729A resource consumption not G729.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Tue, 04 Mar 2003 11:45:50 -0500

-troy