Subject: [Megaco] Megaco Media format related Queries!!

From: "Mohan Hadimani" <[email-masked]>
Date: Mon, 17 Mar 2003 20:53:31 -0800

Hi,

I would like to know the answer for following 2 queries.

1). Its required to send multiple media formats in ADD command.
     Among the following, in which way I can send the ADD request to MG?

      v=0
      c=IN IP4 $
      m=audio $ RTP/AVP fmt1 fmt2 fmt3 fmt4

      or

      v=0
      c=IN IP4 $
      m=audio $ RTP/AVP fmt1

      v=0
      c=IN IP4 $
      m=audio $ RTP/AVP fmt2

      v=0
      c=IN IP4 $
      m=audio $ RTP/AVP fmt3

      v=0
      c=IN IP4 $
      m=audio $ RTP/AVP fmt4

2). In which case MG will report multiple media formats in ADD reply?
     Because I tried by sending multiple formats in the above 2 methods,
     but MG is always reporting only the first format(default - according to 2327)
     in ADD reply.

Thanx & Regards
Mohan

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 18 Mar 2003 01:02:57 +0200

Hi,

> Among the following, in which way I can send the ADD request to
> MG?       v=0      c=IN IP4 $      m=audio $ RTP/AVP fmt1 fmt2 fmt3
> fmt4      or       v=0      c=IN IP4 $      m=audio $ RTP/AVP
> fmt1       v=0      c=IN IP4 $      m=audio $ RTP/AVP fmt2
> v=0      c=IN IP4 $      m=audio $ RTP/AVP fmt3       v=0      c=IN
> IP4 $      m=audio $ RTP/AVP fmt4
>
> [CHH] I guess you can use either alternative, and for your specific
> example I would go for the first alternative.  H.248 DOES allow you to
> send multiple media formats (codecs) in a single m= line (H.248 allows
> only a single m= line per SDP, but that's another issue...)
> [CHH] The MG can report multiple media formats in EITHER case,
> depending on the values you give to ReserveValue and ReserveGroup.
> but MG is always reporting only the first format(default - according
> to 2327) in ADD reply.
>
> [CHH] Again, it depends on the ReserveGroup and ReserveValue property
> values (and also on the capabilities of your MG, I guess). But, like I
> said earlier, I would use the first alternative, unless there is some
> specific reason you can't do so.
>
> Regards,
>
> Christer Holmberg
> Ericsson Finland

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 18 Mar 2003 01:02:57 +0200

Hi,