Subject: [Megaco] Service change Restart

From: [email-masked]
Date: Thu, 13 Mar 2003 09:07:04 +0530

Hi List
I have a query regarding the processing of Service Change Restart.
consider the following scenario:

Termination is in state InService.
Command recieved from MGC to Restart the termination (with or wothout delay).

what MG could possibly do in this case?

Thanks
Sachin Gupta

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Thu, 13 Mar 2003 13:57:35 -0500

I agree that it's very difficult to assign any real meaning to an MGC-initiated 
restart of a termination.  My background in switch software development tells me 
that a restart clears certain aspects of state.  However, that makes little sense in 
the Megaco case, because the MGC can do that directly by subtracting the termination 
from any context it is in and resetting descriptors if it is not in a context.

Conclusion: the only thing an MGC-initiated restart of a termination does is change 
its state to in-service if it is not already there.

> what MG could possibly do in this case?
[disclaimer snipped]

---

From: Tom Taylor <[email-masked]>
Date: Thu, 13 Mar 2003 13:57:35 -0500

[disclaimer snipped]