Subject: [Megaco] RE: A question about CID pakage

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 31 Mar 2003 08:19:11 -0500

Instead of using a flag, it is possible to address your concerns by
utilizing the signals themselves to handle V5.  Because the MG and MGC will
know that the subscriber is a V5 agent, it should be fairly easy to get both
boxes to work together successfully.

Because the MG doesn't know the line state, the data signal (andisp/data)
for V5 on-hook data transmission and the dwa signal (andisp/dwa) for V5
off-hook data transmission. For andisp/data, the tas parameter specifies
whether a Dual Tone Alerting Signal (DT-AS) shall be applied or not:
tas=dt : send DT-AS signal
tas=nt : do not send DT-AS signal
Note that the dwa signal cannot differentiate.

Therefore, the MG signalling would be dependent upon what the MGC sent and
the MG would still not have to have knowledge of the line state. For
example:
andisp/data, tas=nt = line on-hook, data transmission without DT-AS signal
sent
andisp/data, tas=dt = line on-hook, data transmission utilizing DT-AS signal
sent
andisp/dwa = line off-hook, data transmission utilizing DT-AS signal is sent

Does this solve your problem?

Kevin

-----Original Message-----
From: ZHAO BO [mailto:[email-masked]] 
Sent: Monday, March 31, 2003 4:43 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: A question about CID pakage

Hi Kevin:
    In andisp package, the same signal dwa is used for all the types of CID,

include normal CID and call waiting ID. It's the responsibility of MGW to
decide the CID type and make proper action.
    My question rises here:  For MGW+V5 combination, the MGW may have no way

to know the status of a V5 subsriber(onhook, offhook), because the user
signalling 
is transported transparently from AN to MGC via V5UA. As a result, MGW can't

dicide the CID type(normal or call waiting). Maybe a flag is still needed in
this 
case?
    Best regards

Zhao Bo
Huawei Technologies
2003/03/31

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 31 Mar 2003 08:19:11 -0500

Kevin

-----Original Message-----
From: ZHAO BO [mailto:[email-masked]] 
Sent: Monday, March 31, 2003 4:43 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: A question about CID pakage

Hi Kevin:

Zhao Bo
Huawei Technologies
2003/03/31