Subject: [Megaco] query regarding the use of SDP

From: "Abhi" <[email-masked]>
Date: Fri, 14 Mar 2003 16:03:20 +0530

Hi,
As we know SDP is used to ecode and decode local and remote descriptor. I have certain doubts about some SDP paramters. They  are as follows:-
1. Do we reqire "o=" line in megaco?
    if present then
    a. Can we set username to hypen ("-")?
    b. Can NTP timestamp be used for session id and 
        version?
 2.Do we need sesion name?
    If present can we use hyphen for that?
3..Do we need sesion and media information "i=" line ?
4..Do we need URI ?
5. How to use bandwidth "b=" line?
6. How to use "t=" line?
    If present, can we have a permanent session?
 NOTE :- RFC-3435(MGCP )  says
    * The start time may be set to zero.
   * The stop time should be set to zero.

7. .Do we need attributes
            a) a=cat:<category>
            b) a=keywds:<keywords>
            c) a=tool:<name & version of tool>?
8. Aren't "recvonly", "senrecv", "sendonlly" are redundant in 
    Megaco?
9. How to use "a=type:<conference type>" in Megaco?
10 How to use attributes "a=sdplang" & "a=lang" in Megaco?

Thanks and regards
Abhishek Bansal

---

From: Tom Taylor <[email-masked]>
Date: Mon, 17 Mar 2003 15:54:46 -0500

Some new answers below.

Abhi wrote:
> Hi,
> As we know SDP is used to ecode and decode local and remote descriptor. 
> I have certain doubts about some SDP paramters. They  are as follows:-

No special use in Megaco.  I suspect this is most useful in the original use of SDP 
for session announcements, rather than interative session negotiation.

>    * The stop time should be set to zero.

No special Megaco instructions.  Basically should take your cue from SIP.

>             c) a=tool:<name & version of tool>?

Very application dependent.  a) and b) would only be useful in a system where the MG 
can display the information conveyed by these attributes to an user.  c) might be 
useful to a specialized MG which supports the tool concerned.

> 8. Aren't "recvonly", "senrecv", "sendonlly" are redundant in

Yes.  They must not be used.

> 9. How to use "a=type:<conference type>" in Megaco?

Similarly application-dependent.  I suspect the information conveyed by this 
attribute is only meaningful at the MGC level.

> 10 How to use attributes "a=sdplang" & "a=lang" in Megaco?

Once more: these relate to information that may be displayed to an user.  This is a 
querstion of MG and user terminal design and the interface between them.
> Abhishek Bansal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Mon, 17 Mar 2003 15:54:46 -0500

Some new answers below.