Subject: [Megaco] Another Question About Caller ID Package

From: Zhao Bo <[email-masked]>
Date: Thu, 23 Oct 2003 14:27:53 +0800

Hi Kevin:
    In some countries the Caller ID is sent to user by DTMF, with the message format like:
    <A><S1>...<Sn>...<C>
    which is quite different from the FSK SDMF/MDMF format. 
    The caller id package, andisp, define the data block as SDMF/MDMF format, do you think it's also suitable for DTMF caller id case?
    Thanks very much and best regard.

Zhao Bo

*****************************************************************
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
*****************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 23 Oct 2003 10:59:30 -0400

It seems to me that you have two possibilities:

Decode the FSK in the andisp signal and translate that to DTMF digits.
Use the DTMF Generation package to produce the digits.

My gut feeling is that you should do the latter.

Kevin

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Thursday, October 23, 2003 2:28 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Another Question About Caller ID Package

Hi Kevin:
    In some countries the Caller ID is sent to user by DTMF, with the
message format like:
    <A><S1>...<Sn>...<C>
    which is quite different from the FSK SDMF/MDMF format. 
    The caller id package, andisp, define the data block as SDMF/MDMF
format, do you think it's also suitable for DTMF caller id case?
    Thanks very much and best regard.

Zhao Bo

*****************************************************************
This e-mail and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!
*****************************************************************

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 23 Oct 2003 10:59:30 -0400

Kevin

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Thursday, October 23, 2003 2:28 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Another Question About Caller ID Package

Hi Kevin:

Zhao Bo

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 24 Oct 2003 13:43:59 -0400

Caller ID between the first and second rings is a North American
requirement.  Other regions/locales have different requirements.

If the MGC has to apply ringing and the DTMF for CallerID in such a way that
the timing is impossible using the DG package, then certainly encoding the
digits as FSK and utilizing the andisp package is a viable way of sending
the callerID info to the MG.  The caveat is that the MG will have to be able
to decode the FSK to be able to generate the digits.

Kevin

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Friday, October 24, 2003 1:00 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] RE: Another Question About Caller ID Package

If I do the latter, MGC will have to send both a DTMF siganl and a ringing
signal. 
In most case caller id shall be between the 1st and the 2nd ringing, if MGC
sends two signals, maybe the time requirement can't be assured?

----- Original Message ----- 
From: "Kevin Boyle" <[email-masked]>
To: "Zhao Bo" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, October 23, 2003 10:59 PM
Subject: [Megaco] RE: Another Question About Caller ID Package

> HUAWEI, which is intended only for the person or entity whose address 
> is listed above. Any use of the information contained herein in any 
> way (including, but not limited to, total or partial disclosure, 
> reproduction, or dissemination) by persons other than the intended 
> recipient(s) is prohibited. If you receive this e-mail in error, 
> please notify the sender by phone or email immediately and delete it!

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 24 Oct 2003 13:43:59 -0400

Kevin