Subject: Re: [Megaco] Re: Event descriptor handling for static logic inter

From: Christian Groves <[email-masked]>
Date: Fri, 03 Oct 2003 09:30:12 +1000

Hello Kevin and Thomas,

As this exact and strict functionality seems to be tied to several packages is 
this something that we could perhaps add to the core protocol ie. H.248.1v3? It 
seems to me to control protocol operation rather than providing specific 
functionality.

Regards, Christian

Kevin Boyle wrote:

> Apparently, I misunderstood what you were looking for.  Unless I hear 
> any objections, I will add that function to ICAS for the next meeting.
> 
> Of course, this does nothing for the BCAS spec -- I assume we will need 
> the same change there?  This will require an amendment to H.248.25... I 
> don't think this kind of change will be acceptable as an IG change.
> 
> Comments?
> 
> Kevin
> 
> -----Original Message-----
> From: Thomas Voith [mailto:[email-masked]]
> Sent: Thursday, October 02, 2003 10:09 AM
> To: Boyle, Kevin [NCRTP:3Z40:EXCH]
> Cc: Christian Groves; [email-masked]; [email-masked]
> Subject: Re: [Megaco] Re: Event descriptor handling for static logic 
> interfaces like CAS
> 
> 
> Hello Kevin
> 
> What you mean is a general behavior, but MGC can not control it. This 
> does not solve the problem which I ment.
> 
> To make it easy I take the example for 'al/on al/of':
> 
> The MGC want to be notified for 'al/on' and 'al/of'.
> MGC assumes that the line is in state 'al/on'.
> 
> With Events{al/on{strict='exact'},al/of{strict='state'},....}
> the MGC do not get a Notify for al/on, because it is not necessary.
> 
> When MGC then knows with the next notify, that the line is off-hook, it 
> send perhaps a new EventsDescriptor containing the DigitMap, but now 
> with Events{al/on{strict='state'},al/of{strict='exact'},....}
> 
> This avoids again not needed Notify's.
> 
> Same applies for CAS, where you have more states.
> With this mechanism you can update the EventsDescriptor for other things 
> bind to this termination like R2 register signalling without again
> 
> a not needed Notify AND in addition all static events are detected, not
> only the good case next step.
> 
> Regards
> 
> Thomas
> 
> 
> 
>  > Kevin Boyle wrote:
>  >
>  > Thomas,
>  >
>  > The function you want already exists in the package.  Each one of the
>  > line signalling events in both ICAS and BCAS have descriptions that
>  > contain the following:
>  >
>  > The event is reported by the MG if either the timed transition to this
>  > line signal is detected or the line signal already exists.
>  >
>  > This means that the strict=state behavior is already inherent in these
>  > events.  I see no problem with this, and no need for a change to these
>  > packages.
>  >
>  > Kevin
>  >
>  > -----Original Message-----
>  > From: Thomas Voith [mailto:[email-masked]]
>  > Sent: Thursday, October 02, 2003 4:00 AM
>  > To: Christian Groves
>  > Cc: [email-masked]; [email-masked]
>  > Subject: Re: [Megaco] Re: Event descriptor handling for static logic
>  > interfaces like CAS
>  >
>  > Hello Christian
>  >
>  > I want both,
>  > - strict parameter for CAS Line signals and in future for all
>  > 'static'signalling interfaces.
>  > - optionally a default strict="state" to shorten the Events Descriptor
>  >
>  > In my opinion, this should be used for all 'static' signalling
>  > interfaces. With 'static' I mean that this interface has always a
>  > state, when MG receives an EventsDescriptor from MGC. For
>  > synchronizing the states from MGC with MG the strict mechanism is very
>  > useful. Doing the same with EventBuffer, Embedded Descriptor
>  >
>  > is much more complex and increases extreme with the number of possible
>  > states on the interface.
>  >
>  > Note: This 'strict' parameter is just used by MG to determine, 
> whether a Notify
>  >       for the existing state on the interface has to be sent or not.
>  >       Further on normal event handling applies.
>  >       This approach has the advantage, that EventBuffer and Embedded 
> can still be used
>  >       in addition.
>  >
>  > For all 'dynamic' events like pulses, DTMF, SPCM, normal event
>  > handling applies.
>  >
>  > Best regards
>  >
>  > Thomas
>  >
>  > Christian Groves wrote:
>  > >
>  > > Hello Thomas,
>  > >
>  > > Are you wanting a general purpose mechanism such as the off-hook one
>  > > or do you just want the default stated for H.248.26 and H.246.ICASC?
>  > >
>  > > Kevin Boyle is the editor of these he may have some opinion on this.
>  > >
>  > > Its always possible to make amendments to existing recommendations.
>  > > Bring in a contribution for consideration to SG16 or propose a
>  > > detailed solution on the Megaco list for experts to review. If they
>  > > are agreeable then the change will be added.
>  > >
>  > > Regards, Christian
>  > >
>  > > Thomas Voith wrote:
>  > >
>  > > > Dear list-members,
>  > > >
>  > > > H.248.26 and in H.248.ICAS I miss a feature, which has been used
>  > > > already for On-Hook, Off-Hook  the 'strict' parameter.
>  > > >
>  > > > All interfaces, which have static states, should implement such a
>  > > > mechanism.
>  > > >
>  > > > The problem is that the EventsDescriptor EventBufferDescriptor or
>  > > > an embedded EventsDescriptor may discard events, if the newly
>  > > > received or replacing Event Descriptor does not match the event.
>  > > >
>  > > > In the Megaco Secnarios, always just the good case is shown.
>  > > >
>  > > > e.g. a static interface with 4 logical incoming events (
>  > > > S1,S2,S3,S4) would then set the EventsDescripror like:
>  > > >
>  > > > MGC guess the MG is in state i1, no Notify will be sent by MG,
>  > > > when state of interface is still i1.
>  > > >
>  > > > Events {
>  > > > S1{strict="exact"},S2{strict="state"},S3{strict="state"},S4{strict
>  > > > ="
>  > > > state"} }
>  > > >
>  > > > ( Note: in case "state" is the default, then EventsDescriptor
>  > > > could be shorter)
>  > > >
>  > > > The events descriptor remains active, after Notification is sent.
>  > > > The strict parameter avoids unnecessary Notifications for the
>  > > > already by MGC known state.
>  > > >
>  > > > This mechanism would be very simple and avoids lost of any events,
>  > > > which is strong required for signalling interfaces on MG
>  > > > transferred via H.248 to an MGC.
>  > > >
>  > > >
>  > > > For a better illustration I have attached a Excel-File containing
>  > > > a simple scenario.
>  > > >
>  > > > So my question/proposal is:
>  > > >
>  > > > - Is it possible to extend the existing static state 
> interfacepackages like H.248.26 with this
>  > > >   strict feature?
>  > > > - If not, can I get this functionality otherwise ?
>  > > >
>  > > > Kind regards
>  > > >
>  > > > Thomas Voith
>  > > >
>  > >
>  > > _______________________________________________
>  > > Megaco mailing list
>  > > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
>  >
>  > -- _______________________________________________________________
>  >           _
>  >           V                    | Thomas Voith
>  >   +---------------+            | Dept. VS/EAC2 [Systems]
>  >   | A L C A T E L |            | FL/2/50
>  >   +---------------+            |
>  >                                | Tel:   +49 711 821-40293
>  >                                | Alcanet:       259-40293
>  > Alcatel SEL AG                 | Fax:   +49 711 821-40211
>  > Fixed Networks Division        |
>  > Lorenzstr. 10                  | mailto:[email-masked]
>  > D-70435 Stuttgart, Germany     |
>  > _______________________________________________________________
>  >
>  > _______________________________________________
>  > Megaco mailing list
>  > [email-masked]
>  > https://www1.ietf.org/mailman/listinfo/megaco
> 
> -- 
> _______________________________________________________________
>           _
>           V                    | Thomas Voith                  
>   +---------------+            | Dept. VS/EAC2 [Systems]     
>   | A L C A T E L |            | FL/2/50
>   +---------------+            |
>                                | Tel:   +49 711 821-40293
>                                | Alcanet:       259-40293
> Alcatel SEL AG                 | Fax:   +49 711 821-40211
> Fixed Networks Division        |
> Lorenzstr. 10                  | mailto:[email-masked]
> D-70435 Stuttgart, Germany     |
> _______________________________________________________________
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 03 Oct 2003 09:30:12 +1000

Hello Kevin and Thomas,

Regards, Christian