Subject: [Megaco] Event descriptor handling for static logic interfaces like CAS

From: Thomas Voith <[email-masked]>
Date: Wed, 01 Oct 2003 13:52:14 +0200

Dear list-members,

H.248.26 and in H.248.ICAS I miss a feature, which has been used
already for On-Hook, Off-Hook  the 'strict' parameter.

All interfaces, which have static states, should implement such
a mechanism.

The problem is that the EventsDescriptor EventBufferDescriptor or an
embedded EventsDescriptor may discard events, if the newly received or
replacing Event Descriptor does not match the event.

In the Megaco Secnarios, always just the good case is shown.

e.g. a static interface with 4 logical incoming events ( S1,S2,S3,S4)
would then set the EventsDescripror like:

MGC guess the MG is in state i1, no Notify will be sent by MG, when
state of interface is still i1.

Events { S1{strict="exact"},S2{strict="state"},S3{strict="state"},S4{strict="state"} }

( Note: in case "state" is the default, then EventsDescriptor could be shorter)

The events descriptor remains active, after Notification is sent.
The strict parameter avoids unnecessary Notifications for the already by MGC known state.

This mechanism would be very simple and avoids lost of any events, which is strong
required for signalling interfaces on MG transferred via H.248 to an MGC.

For a better illustration I have attached a Excel-File containing a simple scenario.

So my question/proposal is:

- Is it possible to extend the existing static state interfacepackages like H.248.26 with this
  strict feature?
- If not, can I get this functionality otherwise ?

Kind regards

Thomas Voith

-- 
_______________________________________________________________
          _
          V                    | Thomas Voith                   
  +---------------+            | Dept. VS/EAC2 [Systems]      
  | A L C A T E L |            | FL/2/50
  +---------------+            | 
                               | Tel:   +49 711 821-40293
                               | Alcanet:       259-40293
Alcatel SEL AG                 | Fax:   +49 711 821-40211
Fixed Networks Division        |
Lorenzstr. 10                  | mailto:[email-masked] 
D-70435 Stuttgart, Germany     | 
_______________________________________________________________

---

From: Christian Groves <[email-masked]>
Date: Thu, 02 Oct 2003 13:52:31 +1000

Hello Thomas,

Are you wanting a general purpose mechanism such as the off-hook one or do you 
just want the default stated for H.248.26 and H.246.ICASC?

Kevin Boyle is the editor of these he may have some opinion on this.

Its always possible to make amendments to existing recommendations. Bring in a 
contribution for consideration to SG16 or propose a detailed solution on the 
Megaco list for experts to review. If they are agreeable then the change will be 
added.

Regards, Christian

> - If not, can I get this functionality otherwise ?

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 02 Oct 2003 13:52:31 +1000

Hello Thomas,

Regards, Christian

---

From: Thomas Voith <[email-masked]>
Date: Thu, 02 Oct 2003 09:59:33 +0200

Hello Christian

I want both, 
- strict parameter for CAS Line signals and in future for all 'static'signalling interfaces.
- optionally a default strict="state" to shorten the Events Descriptor

In my opinion, this should be used for all 'static' signalling interfaces.
With 'static' I mean that this interface has always a state, when MG
receives an EventsDescriptor from MGC.
For synchronizing the states from MGC with MG the strict mechanism
is very useful. Doing the same with EventBuffer, Embedded Descriptor 
is much more complex and increases extreme with the number of possible states on the interface.

Note: This 'strict' parameter is just used by MG to determine, whether a Notify
      for the existing state on the interface has to be sent or not.
      Further on normal event handling applies.
      This approach has the advantage, that EventBuffer and Embedded can still be used
      in addition.
 
For all 'dynamic' events like pulses, DTMF, SPCM, normal event handling applies.

Best regards

Thomas

---

From: Thomas Voith <[email-masked]>
Date: Thu, 02 Oct 2003 09:59:33 +0200

Hello Christian

I want both, 

 

Best regards

Thomas

---

From: Thomas Voith <[email-masked]>
Date: Thu, 02 Oct 2003 09:59:33 +0200

Hello Christian

I want both, 

 

Best regards

Thomas

---

From: Thomas Voith <[email-masked]>
Date: Thu, 02 Oct 2003 09:59:33 +0200

Hello Christian

I want both, 

 

Best regards

Thomas