Subject: [Megaco] How to retrieve the context name of an existing termination

From: "El Moussawi, Ali" <[email-masked]>
Date: Thu, 2 Oct 2003 17:28:43 +0200

Hello,
Suppose that a MGC receives a IAM message, and the IAM message contains
a CIC = 3.
This means that this CIC has been already reserved at the MG level,
right ?
If the MGC and MG speeks MEGACO, this means that there is already a
context having a termination named Trunk1/line3 (is the name right ?) in
the MG. And the termination is in ReceiveOnly mode.
How can we retrieve the name of the context ?
If the MGC sends :
MEGACO/1 [1.0.0.0]:1
	Transaction = 1{
		Context = $ {
			Modify = Trunk1/line3 {
				Media {
							LocalControl
{Mode=SendReceive}
				}
				          }
				}
				}

Will it receive the context name in the reply ?
MEGACO/1 [2.0.0.0]:2
	Transaction = 1{
		Context = 1 {
					Modify = Trunk1/line3 
				}
				}

Thanks

Ali

---

From: Christian Groves <[email-masked]>
Date: Fri, 03 Oct 2003 09:20:49 +1000

Hello Ali,

The Termination Trunk1/line will be in the NULL context. To initiate a 
connection in the MG you will first have to ADD this termination to a context. 
The context ID at this stage can be wildcarded. The reply will contain the 
correct context ID.

eg.
 >         Transaction = 1{
 >                 Context = $ {
 >                         Add.request = Trunk1/line3 {...}
 >         Transaction = 1{
 >                 Context = 5 {
 >                         Add.reply = Trunk1/line3 {}

Regards, Christian

El Moussawi, Ali wrote:
> This means that this CIC has been already reserved at the MG level, right ?
>                         Modify.Req = Trunk1/line3 {
> 
>                                                             Media {
> 
>                                                         LocalControl 
> {Mode=SendReceive}
> 
>                                                                         }
> 
>                                                                       }
> 
>                                     }
> 
>                               }
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 03 Oct 2003 09:20:49 +1000

Hello Ali,

eg.

Regards, Christian

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 02 Oct 2003 20:27:55 -0400

Hi,

In other words MG does not know anything about the CIC being "reserved"
It is a job of MGC "to let MG know" about it by issuing the Add command.

Regards,
         Aleks

At 07:20 PM 10/2/2003, Christian Groves wrote:
>connection in the MG you will first have to ADD this termination to a 
>context. The context ID at this stage can be wildcarded. The reply will 
>contain the correct context ID.
>
>eg.
> >         Transaction = 1{
> >                 Context = $ {
>>Suppose that a MGC receives a IAM message, and the IAM message contains a 
>>CIC = 3.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 02 Oct 2003 20:27:55 -0400

Hi,

Regards,
         Aleks