Subject: [Megaco] Support of a H.248 package

From: "Jan Lindquist (AL/EAB)" <[email-masked]>
Date: Fri, 19 Mar 2004 09:04:25 +0100

Hello Megaco fans,

I need clarification on the statement in section 6.2.3 in the H.248 version 2 standard, more specifically on the 4th paragraph.

"To support a particular package the MG must support all properties, signals, events and statistics defined in a package. It must also support all Signal and Event parameters. The MG may support a subset of the values listed in a package for a particular Property or Parameter."

Our interpretation is that as long as the MG recognises the property, signal or event (ie. doesn't response with a syntax error, 451, 452, 453, 454 etc) then a property, signal or event is supported. If the functionality behind the property, signal or event is not implemented then error code 501 is returned.  However some have mentioned that this may not be correct? Can anyone clarify the behaviour?

Best regards,
Jan Lindquist

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Mar 2004 09:58:06 +1100

Hello Jan,

"Must Support" is a little different from "it is mandatory to implement all the 
functionality in the package." So I believe we put these words in so that the MG 
had to support the reception of properties, signal, events and statistics. By 
this I mean that it must not return a syntax error or unknown ID for any of 
these elements. However the MG could give a meaningful response such as 501 not 
implemented. This shows that the MG has at least considered the complete 
package. Of course it is encouraged to support the complete functionality of a 
package however it is better to return 501 and using an existing package rather 
than creating new packages with the functionality contained in existing 
packages. We have tried to prevent duplicate packages in Megaco. So you are 
correct in supporting 501.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Mar 2004 09:58:06 +1100

Hello Jan,

Regards, Christian

---

From: "Rashim Anand" <[email-masked]>
Date: Mon, 22 Mar 2004 15:38:05 -0800

Hi,

Where can the latest corr document (non ITU-T copy) for H.248.4 (transport
over SCTP) be found?

Thanks in advance,
-Rashim

---

From: "Rashim Anand" <[email-masked]>
Date: Mon, 22 Mar 2004 15:38:05 -0800

Hi,

Thanks in advance,
-Rashim

---

From: Troy Cauble <[email-masked]>
Date: Mon, 22 Mar 2004 19:00:07 -0500

Christian Groves wrote:
> Hello Jan,
> 
> "Must Support" is a little different from "it is mandatory to implement 
> all the functionality in the package." So I believe we put these words 
> in so that the MG had to support the reception of properties, signal, 
> events and statistics. By this I mean that it must not return a syntax 
> error or unknown ID for any of these elements. However the MG could give 
> a meaningful response such as 501 not implemented.

Wow!  Good to know!
Could we see this clarification in a doc sometime?

-troy

---

From: Troy Cauble <[email-masked]>
Date: Mon, 22 Mar 2004 19:00:07 -0500

Wow!  Good to know!

-troy