Subject: [Megaco] Megaco over TDM trunks

From: "MARCELO TAKASHI UEMURA" <[email-masked]>
Date: Thu, 25 Mar 2004 06:26:32 -0300

Dear all,
 
anybody knows about the possibility to transport Megaco in TDM trunks instead of IP, using MTP (Message Transfer Part from Narrowband ISUP) as message transport? Is there any draft or specification about this?
 
Thanks in advance.
 
Marcelo Uemura

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "MARCELO TAKASHI UEMURA" <[email-masked]>
Date: Thu, 25 Mar 2004 12:14:38 -0300

Hi Kevin,
 
maybe there is a misunderstanding. My question is about sending Megaco messages from the Call Agent to the Media Gateway through TDM links instead of IP.
 
Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Kevin Boyle [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 03:09 
	An: MARCELO TAKASHI UEMURA; [email-masked] 
	Cc: 
	Betreff: RE: [Megaco] Megaco over TDM trunks

	TDM terminations are certainly supported, as is MTP.  The base spec talks about both. 

	Kevin 

	-----Original Message----- 
	From: MARCELO TAKASHI UEMURA [mailto:[email-masked]] 
	Sent: Thursday, March 25, 2004 4:27 AM 
	To: [email-masked] 
	Subject: [Megaco] Megaco over TDM trunks 

	Dear all, 

	Thanks in advance. 
	  
	Marcelo Uemura

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 25 Mar 2004 10:09:24 -0500

TDM terminations are certainly supported, as is MTP.  The base spec talks
about both.

Kevin 

-----Original Message-----
From: MARCELO TAKASHI UEMURA [mailto:[email-masked]] 
Sent: Thursday, March 25, 2004 4:27 AM
To: [email-masked]
Subject: [Megaco] Megaco over TDM trunks

Dear all,
 
anybody knows about the possibility to transport Megaco in TDM trunks
instead of IP, using MTP (Message Transfer Part from Narrowband ISUP) as
message transport? Is there any draft or specification about this?
 
Thanks in advance.
 
Marcelo Uemura

---

From: "MARCELO TAKASHI UEMURA" <[email-masked]>
Date: Thu, 25 Mar 2004 12:14:38 -0300

Hi Kevin,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Kevin Boyle [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 03:09 
	An: MARCELO TAKASHI UEMURA; [email-masked] 
	Cc: 
	Betreff: RE: [Megaco] Megaco over TDM trunks

	Kevin 

	-----Original Message----- 
	From: MARCELO TAKASHI UEMURA [mailto:[email-masked]] 
	Sent: Thursday, March 25, 2004 4:27 AM 
	To: [email-masked] 
	Subject: [Megaco] Megaco over TDM trunks 

	Dear all, 

	Thanks in advance. 
	  
	Marcelo Uemura

---

From: "MARCELO TAKASHI UEMURA" <[email-masked]>
Date: Fri, 26 Mar 2004 05:11:13 -0300

Hello Christian,
 
thanks, I´ve looked this description but I am looking for any description about transporting Megaco over MTP level defined in ITU Q.701 standard (used by ISUP Narrowband). One problem is that the standard limits the length of octets in the user level by 272 octets. Another problem would be some procedures taken by MTP concerning the user part.
 
Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,
	
	The ability to transport Megaco over MTP is defined in H.248.5 "Transport over ATM".
	
	Regards, Christian
	
	> message transport? Is there any draft or specification about this?

	This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.
	
	E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "MARCELO TAKASHI UEMURA" <[email-masked]>
Date: Fri, 26 Mar 2004 05:11:13 -0300

Hello Christian,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,

	Regards, Christian

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Fri, 26 Mar 2004 09:34:30 +0100

I'm not aware of any standard document describing how to carry MEGACO messages iver narrowband SS7. However, I believe that if one would like to implement this, the SS7 SCCP layer - Q.71x - (used in connectionless mode) would have to be added between MTP and MEGACO. This would provide more flexibility in terms of addressing. Moreover, recent versions of SCCP include segmenting and reassembly procedures, which would solve you concerns regarding the size limit on the length MTP user data.

Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de MARCELO TAKASHI UEMURA
Envoyé : vendredi 26 mars 2004 09:11
À : Christian Groves
Cc : [email-masked]
Objet : AW: [Megaco] Megaco over TDM trunks

Hello Christian,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,

	Regards, Christian

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Fri, 26 Mar 2004 09:34:30 +0100

Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de MARCELO TAKASHI UEMURA
Envoyé : vendredi 26 mars 2004 09:11
À : Christian Groves
Cc : [email-masked]
Objet : AW: [Megaco] Megaco over TDM trunks

Hello Christian,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,

	Regards, Christian

---

From: "Alf Heidermark (AS/EAB)" <[email-masked]>
Date: Fri, 26 Mar 2004 09:26:40 +0100

Hello Marcelo
I think the main problem is the message lenghth. There are not many messages you are able to transmit over 272 octets. This was the reason for recommending the ATM based MTP. I do not see your problem with User Part. H.248 is given a SIO value. 

Alf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
MARCELO TAKASHI UEMURA
Sent: den 26 mars 2004 09:11
To: Christian Groves (MC/EPA)
Cc: [email-masked]
Subject: AW: [Megaco] Megaco over TDM trunks

Hello Christian,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,

	Regards, Christian

---

From: "Alf Heidermark (AS/EAB)" <[email-masked]>
Date: Fri, 26 Mar 2004 09:26:40 +0100

Hello Marcelo

Alf

-----Original Message-----

Hello Christian,

Regards,
 
Marcelo

	-----Ursprüngliche Nachricht----- 
	Von: Christian Groves [mailto:[email-masked]] 
	Gesendet: Do 25/3/2004 10:19 
	An: MARCELO TAKASHI UEMURA 
	Cc: [email-masked] 
	Betreff: Re: [Megaco] Megaco over TDM trunks

	Hello Marcelo,

	Regards, Christian