Subject: [Megaco] "internal" termination

From: Kalleitner Franz <[email-masked]>
Date: Wed, 3 Mar 2004 15:44:40 +0100

Hello megaco-list members,

for specific applications it would be helpful if an internal terminations
residing within the same context connected with other bearer terminations
but never inheriting the role of a source /sink for media streams outside
the context is supported by H248 syntax.
However, I went several times though the H248 recommendations but I didn't
found any statement neither it is supported nor it is not.
Mux Termination is an exception, but since the handling of Mux Termination
is quite complex any other approach is welcomed.
Further it would be interesting how an "internal" termination could be
addressed by MGC.
It would be great if anybody could provide some information.

Thanks in advance

Franz

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 04 Mar 2004 09:37:24 +1100

Hello Franz,

I'm not sure what you mean by:
"But never inheriting the role of a source /sink for media streams outside the 
context is supported by H248 syntax."

Nevertheless the following type scenario is supported by H.248.1:

                            MG
             +--------------------------------+
UserA ------|-T1<--[C1]-->T2--T3<--[C2]-->T4-|---- UserB
             +--------------------------------+

In this case T2 and T3 would be internal terminations. In terms of addressing 
that could use really any type of addressing so long as the MG can determine 
that a connection should take place internally. Ie. T2 and T3 could be given the 
same IP address then the MG would realise that they could be connected internally.

Regards, Christian

> It would be great if anybody could provide some information.

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: Christian Groves <[email-masked]>
Date: Thu, 04 Mar 2004 09:37:24 +1100

Hello Franz,

                            MG

Regards, Christian