Subject: [Megaco] Reserved Group = ON

From: [email-masked]
Date: Mon, 15 Mar 2004 17:11:49 +0200

Hello,
Suppose the following command:

MEGACO/1 [1.1.1.1]:2727
Transaction=111 {Context=$ {Add=Physical1{Media{LocalControl{Mode =
SendOnly}}},
Add =$ {Media {LocalControl {Mode = ReceiveOnly,ReservedGroup=ON}, Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP $
}}}}}

Which reply is correct?

Option #1: (Could be right if each audio payload type is considered a
different group)
MEGACO/1
[2.2.2.2]:2427
Reply = 222{Context = 4{Add = Physical1,Add = Ephemeral1{Media{Local{
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 0
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 8
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 18
}}}}}

Option #2: (Could be right if all audio payload types are in the same
group, suppose "audio" group)
MEGACO/1
[2.2.2.2]:2427
Reply = 222{Context = 4{Add = Physical1,Add = Ephemeral1{Media{Local{
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 0
}}}}}

Regards,
Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 15 Mar 2004 16:32:20 +0100

Hi,

I would say that option #2 is correct, because I don't think the MG should start creating SDPs on it's own. You provided one SDP, and one you shall get back (no matter what the value of the ReserveGroup property is, because it doesn't have any meaning when you send one SDP).

Regards,

Christer Holmberg
Ericsson Finland

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: 15. maaliskuuta 2004 17:12
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Megaco] Reserved Group = ON
> 
> 
> Hello,

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 15 Mar 2004 16:32:20 +0100

Hi,

Regards,

Christer Holmberg
Ericsson Finland