Subject: RE : [Megaco] Support of a H.248 package

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Tue, 23 Mar 2004 09:19:33 +0100

Hello Christian,

I think it would be useful to include such an explanation in the IG and/or H.248 V3 as I believe that the "must support" statement has already been misunderstood in a number of occasions. For example, ITU-T Rec J.171 Annex B defines an ISUP Trunk Tones Generator package that contains only two tones (Ringback tone and a Congestion Tone), both of which are already defined - with different signal Ids - in H.248 Annex E (Call Progress Tone Generator Package).

Regards,
Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Christian Groves
Envoyé : lundi 22 mars 2004 23:58
À : Jan Lindquist (AL/EAB)
Cc : [email-masked]'
Objet : Re: [Megaco] Support of a H.248 package

Hello Jan,

"Must Support" is a little different from "it is mandatory to implement all the 
functionality in the package." So I believe we put these words in so that the MG 
had to support the reception of properties, signal, events and statistics. By 
this I mean that it must not return a syntax error or unknown ID for any of 
these elements. However the MG could give a meaningful response such as 501 not 
implemented. This shows that the MG has at least considered the complete 
package. Of course it is encouraged to support the complete functionality of a 
package however it is better to return 501 and using an existing package rather 
than creating new packages with the functionality contained in existing 
packages. We have tried to prevent duplicate packages in Megaco. So you are 
correct in supporting 501.

Regards, Christian

Jan Lindquist (AL/EAB) wrote:

> Hello Megaco fans,
> 
> I need clarification on the statement in section 6.2.3 in the H.248 
> version 2 standard, more specifically on the 4th paragraph.
> 
> "To support a particular package the MG must support all properties, 
> signals, events and statistics defined in a package. It must also 
> support all Signal and Event parameters. The MG may support a subset 
> of the values listed in a package for a particular Property or 
> Parameter."
> 
> Our interpretation is that as long as the MG recognises the property, 
> signal or event (ie. doesn't response with a syntax error, 451, 452, 
> 453, 454 etc) then a property, signal or event is supported. If the 
> functionality behind the property, signal or event is not implemented 
> then error code 501 is returned.  However some have mentioned that 
> this may not be correct? Can anyone clarify the behaviour?
> 
> Best regards,
> Jan Lindquist
> 
> 
> This communication is confidential and intended solely for the 
> addressee(s). Any unauthorized review, use, disclosure or distribution 
> is prohibited. If you believe this message has been sent to you in 
> error, please notify the sender by replying to this transmission and 
> delete the message without disclosing it. Thank you.
> 
> E-mail including attachments is susceptible to data corruption, 
> interruption, unauthorized amendment, tampering and viruses, and we 
> only send and receive e-mails on the basis that we are not liable for 
> any such corruption, interception, amendment, tampering or viruses or 
> any consequences thereof.
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Mar 2004 21:07:20 +1100

Hello Bruno and Troy,

I will draft something for inclusion to v3 and an IG clarifying this for the May 
SG16 meeting.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Mar 2004 21:07:20 +1100

Hello Bruno and Troy,

Regards, Christian