Subject: [Megaco] ReservedGroup=ON, another clarification needed

From: [email-masked]
Date: Mon, 15 Mar 2004 17:52:17 +0200

Hello again,
Suppose the following command:

MEGACO/1 [1.1.1.1]:2727
Transaction=111 {Context
=$ {Add=Physical1{Media{LocalControl{Mode=SendOnly}}},
Add =$ {Media {LocalControl {Mode = ReceiveOnly,ReservedGroup=ON}, Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 8
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
v=0
c=IN IP4 $
m=audio $ RTP/AVP 18
v=0
c=IN IP4 $
m=image $ udptl t38
}}}}}

Which reply is correct?

Option #1: (Could be right if two different groups are "audio" and "image")
MEGACO/1
[2.2.2.2]:2427
Reply = 222{Context = 4{Add = Physical1,Add = Ephemeral1{Media{Local{
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 0
v=0
c=IN IP4 1.2.3.4
m=image 5680 udptl t38
}}}}}

Option #2: (Could be right if each SDP is a different group no matter what
the "m" line type is" - audio or video)
MEGACO/1
[2.2.2.2]:2427
Reply = 222{Context = 4{Add = Physical1,Add = Ephemeral1{Media{Local{
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 0
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 8
v=0
c=IN IP4 1.2.3.4
m=audio 5678 RTP/AVP 18
v=0
c=IN IP4 1.2.3.4
m=image 5680 udptl t38
}}}}}

Regards,
Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Tue, 16 Mar 2004 08:29:48 +0100

Hi,

In this case I would say option #2 is correct. You are not allowed to switch data from one group to another just because they happen to have a common media type.

Regards,

Christer Holmberg
Ericsson Finland

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: 15. maaliskuuta 2004 17:52
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Megaco] ReservedGroup=ON, another clarification needed
> 
> 
> 
> Hello again,

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Tue, 16 Mar 2004 08:29:48 +0100

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: [email-masked]
Date: Tue, 16 Mar 2004 09:55:36 +0200

Thanks for the comments,

What is considered to be a "Group" when "ReservedGroup"=ON:
1. Is it each SDP set?

2. Is it each SDP with different media type (and then all "audio" SDP sets
are the same "Group")?

Regards,
Dana H.

                      "Christer Holmberg                                                                                                    
                      (JO/LMF)"                     To:      "[email-masked]'" <[email-masked]>,     
                      <christer.holmberg@er         [email-masked]                                                                         
                      icsson.com>                   cc:      [email-masked]                                                    
                      Sent by:                      Subject: RE: [Megaco] ReservedGroup=ON, another clarification needed                    
                      [email-masked]                                                                                                 

                      16/03/2004 09:29                                                                                                      

Hi,

In this case I would say option #2 is correct. You are not allowed to
switch data from one group to another just because they happen to have a
common media type.

Regards,

Christer Holmberg
Ericsson Finland

> Option #1: (Could be right if two different groups are

This communication is confidential and intended solely for the
addressee(s). Any unauthorized review, use, disclosure or distribution is
prohibited. If you believe this message has been sent to you in error,
please notify the sender by replying to this transmission and delete the
message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption,
interruption, unauthorized amendment, tampering and viruses, and we only
send and receive e-mails on the basis that we are not liable for any such
corruption, interception, amendment, tampering or viruses or any
consequences thereof.

---

From: [email-masked]
Date: Tue, 16 Mar 2004 09:55:36 +0200

Thanks for the comments,

Regards,
Dana H.

                      "Christer Holmberg                                                                                                    

                      16/03/2004 09:29                                                                                                      

Hi,

Regards,

Christer Holmberg
Ericsson Finland