Subject: [Megaco] about add command failure

From: "FCG Huang Qiang (B300)" <[email-masked]>
Date: Mon, 19 Apr 2004 13:51:26 +0800

hello!
for the case gived:
MEGACO/1 [<IP>]:<port>
Transaction=1 {Context=$ {Add=${Media{LocalControl{Mode = SendOnly}}}}
wihle add command fail, then the termination will be deleted from the context created successfully, and then MG will delete the empty context.

But for another case: context contains two commands, show below:
MEGACO/1 [<IP>]:<port>
Transaction=1 {Context=$ 
{Add=tdm/1/1/1{Media{LocalControl{Mode = SendReceive}}},
{Add=${Media{LocalControl{Mode = SendOnly}}}
}
while add tdm success and the second add command is failure, MGC and MG how to process it?
will MG detele the rtp terminater and still leave one tdm terminater in the context created ?

BR
huangq

---

From: [email-masked]
Date: Mon, 19 Apr 2004 11:41:24 +0530

Hi Huangq
      From the protocol perspective as mentioned in section 8 of the
protocol RFC 3525:
" A TransactionReply includes the results for all of the Commands in
   the corresponding TransactionRequest.  The TransactionReply includes
   the return values for the Commands that were executed successfully,
   and the Command and error descriptor for any Command that failed."

So in your case the transaction reply would consist of :
1) Add reply for the tdm termination and context id would be that of newly
created context
2) command level error for the rtp termination.

MG should not delete the tdm termination of its own. Its the MGC
responsibility to continue with the call by giving another add command or
freeing the context by giving subtract command for the tdm termination
added.

Regards
Venkat
Hughes Software Systems
www.hssworld.com

"FCG Huang Qiang (B300)" <[email-masked]>@ietf.org on
04/19/2004 11:21:26 AM

Sent by:    [email-masked]

To:    <[email-masked]>
cc:

Subject:    [Megaco] about add command failure

hello!
for the case gived:
MEGACO/1 [<IP>]:<port>
Transaction=1 {Context=$ {Add=${Media{LocalControl{Mode = SendOnly}}}}
wihle add command fail, then the termination will be deleted from the
context created successfully, and then MG will delete the empty context.

But for another case: context contains two commands, show below:
MEGACO/1 [<IP>]:<port>
Transaction=1 {Context=$
{Add=tdm/1/1/1{Media{LocalControl{Mode = SendReceive}}},
{Add=${Media{LocalControl{Mode = SendOnly}}}
}
while add tdm success and the second add command is failure, MGC and MG how
to process it?
will MG detele the rtp terminater and still leave one tdm terminater in the
context created ?

BR
huangq

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 19 Apr 2004 11:41:24 +0530

Hi Huangq

Regards
Venkat
Hughes Software Systems
www.hssworld.com

To:    <[email-masked]>
cc:

hello!
for the case gived:
MEGACO/1 [<IP>]:<port>

BR
huangq