Subject: RE: [Megaco] Continuity tests

From: Aleksandr Ryabin <[email-masked]>
Date: Wed, 28 Apr 2004 14:11:44 -0400

Yes, the type of test depends on what a circuit is connected to.

But, I was actually coming from the view that MGC "controls" MG
and as such only MGC should have knowledge on what test to execute
(i.e. what is connected to the other side of a circuit).

If this information is left in MG, then each circuit has to be provisioned
with that information such that MG can make intelligent decision on what
type of test to execute. Thus every time a circuit connection is changed,
directly or indirectly, MG circuit needs to be re-provisioned.

I think that configuration should  be kept on MGC and the decision should
come from MGC instead.

         Aleks

At 02:30 PM 4/28/2004, Kevin Boyle wrote:

>Is it possible to run more than one kind of continuity test on a 
>particular circuit?  If no, then the provisioning model holds and there is 
>no need for a change.  If yes, then we may need to add something to the 
>package to allow selection of a ct test type.
>
>Kevin
>
>-----Original Message-----
>From: Aleksandr Ryabin [<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Wednesday, April 28, 2004 1:21 PM
>To: [email-masked]
>Subject: [Megaco] Continuity tests
>
>Hi,
>
>There are several continuity test types (i.e 2-wire, 4-wire, etc) While 
>provisioning of physical test parameters (i.e. frequencies, sequence, 
>timeouts, etc) in MG makes sense, IMHO choosing a type of continuity test 
>seem logical to be left to MGC.
>
>Basic Continuity Package (ct) does not allow to choose the type of a test.
>It implies that type of a test is provisioned on MG (per termination?)
>
>Is there another (extended) continuity test package which allows MGC to 
>choose the type of a continuity test to be performed?
>
>If not, does anyone see a need to have such a package?
>Comments?
>
>Thanks
>         Aleks
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
><https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/mailman/listinfo/megaco 
>

---

From: Zhao Bo <[email-masked]>
Date: Thu, 29 Apr 2004 13:14:00 +0800

Can H.248.17 "line test packages"  be used to test these circuits?
  ----- Original Message ----- 
  From: Aleksandr Ryabin 
  To: Kevin Boyle ; [email-masked] 
  Sent: Thursday, April 29, 2004 2:11 AM
  Subject: RE: [Megaco] Continuity tests

          Aleks

    Is it possible to run more than one kind of continuity test on a particular circuit?  If no, then the provisioning model holds and there is no need for a change.  If yes, then we may need to add something to the package to allow selection of a ct test type.

    Kevin 

    -----Original Message----- 
    From: Aleksandr Ryabin [mailto:[email-masked]] 
    Sent: Wednesday, April 28, 2004 1:21 PM 
    To: [email-masked] 
    Subject: [Megaco] Continuity tests 

    Hi, 

    There are several continuity test types (i.e 2-wire, 4-wire, etc) While provisioning of physical test parameters (i.e. frequencies, sequence, timeouts, etc) in MG makes sense, IMHO choosing a type of continuity test seem logical to be left to MGC.

    Is there another (extended) continuity test package which allows MGC to choose the type of a continuity test to be performed?

    Thanks 
            Aleks 

    _______________________________________________ 
    Megaco mailing list 
    [email-masked] 
    https://www1.ietf.org/mailman/listinfo/megaco

---

From: Zhao Bo <[email-masked]>
Date: Thu, 29 Apr 2004 13:14:00 +0800

----- Original Message ----- 
  From: Aleksandr Ryabin 
  To: Kevin Boyle ; [email-masked] 
  Sent: Thursday, April 29, 2004 2:11 AM
  Subject: RE: [Megaco] Continuity tests

          Aleks

    Kevin 

    -----Original Message----- 
    From: Aleksandr Ryabin [mailto:[email-masked]] 
    Sent: Wednesday, April 28, 2004 1:21 PM 
    To: [email-masked] 
    Subject: [Megaco] Continuity tests 

    Hi, 

    Thanks 
            Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 29 Apr 2004 10:30:47 -0400

Packages defined in H.248.17 do not cover continuity tests.

If the experts agree that MGC should be able to control type of continuity test
then ether basic ct package needs to be amended to include new functionality,
or H.248.17 needs to be amended to include new "extended" continuity package
Commends? Suggestions?

         Aleks

At 01:14 AM 4/29/2004, Zhao Bo wrote:
>From: <mailto:[email-masked]>Aleksandr Ryabin
>To: <mailto:[email-masked]>Kevin Boyle ; 
><mailto:[email-masked]>[email-masked]
>>particular circuit?  If no, then the provisioning model holds and there 
>>is no need for a change.  If yes, then we may need to add something to 
>>the package to allow selection of a ct test type.
>>
>>Kevin
>>
>>[<mailto:[email-masked]>mailto:[email-masked]]

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 29 Apr 2004 10:30:47 -0400

Aleks

---

From: Tom Taylor <[email-masked]>
Date: Thu, 29 Apr 2004 11:18:54 -0400

I for one disagree with your philosophy.  I think the physical details of the 
termination should be provisioned in the MG rather than the the MGC.  However, I 
have no direct implementation responsibility, so I should let those who do speak up.

Aleksandr Ryabin wrote:

>>     From: Aleksandr Ryabin <mailto:[email-masked]>
>>     To: Kevin Boyle <mailto:[email-masked]> ;
>>     [email-masked] <mailto:[email-masked]>
>>>         Is it possible to run more than one kind of continuity test
>>>         on a particular circuit?  If no, then the provisioning model
>>>         holds and there is no need for a change.  If yes, then we may
>>>         need to add something to the package to allow selection of a
>>>         ct test type.
>>>
>>>         Kevin
>>>
>>>         There are several continuity test types (i.e 2-wire, 4-wire,
>>>         etc) While provisioning of physical test parameters (i.e.
>>>         frequencies, sequence, timeouts, etc) in MG makes sense, IMHO
>>>         choosing a type of continuity test seem logical to be left to
>>>         MGC.
>>>
>>>         Is there another (extended) continuity test package which
>>>         allows MGC to choose the type of a continuity test to be
>>>         performed?
>>>

---

From: Tom Taylor <[email-masked]>
Date: Thu, 29 Apr 2004 11:18:54 -0400