Subject: RE: [Megaco] Continuity tests

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 29 Apr 2004 12:25:51 -0400

Kevin, exactly, the type of COT test does not only depend on the physical
details of a termination the MGC controls, but also on physical
details of circuit which *eventually* is connected to that termination.

My point is that the final far-end *final* connection can change without
a change to immediate connection to MG termination and only MGC
would know about it.

For example, if MG is digital trunking gateway, it does not mean that
only pure 4-wire tests will be used all the time. If the other side connected
trough set of intermediate switches and finally lands at the time of the test
say on analog 2-wire circuit then the test to be executed is 2-wire test.

I guess it is possible to somehow tie up configuration of MG termination
dynamically to changes which happens to those intermediate switches,
but it does not seem right. On the contrary, that information would come to
MGC naturally, since it is a controlling element.

Also putting a burden of configuring of a test type per every single
termination seems to be too much for MG, especially if we are talking
about high density MGs which handle hundred thousands terminations.

BTW This is a real problem we run into in our MGC implementation and
are trying to solve. I thought that instead of having a proprietary package
I might as well give it a shot to see if there is any interest to make the
solution public instead.

Thanks.
         Aleks

At 11:23 AM 4/29/2004, Kevin Boyle wrote:

>I agree with Tom.  The fact that the circuit is connected to a single 
>entity means that only a single type of continuity test is actually 
>valid.  MGs are expected to know how to handle their terminations.  Who 
>the termination is connected to is certainly part of that 
>handling.  Because the far-end connection changes the nature of the 
>termination, this becomes an MG-knowledge problem.
>
>I believe the package is fine as it stands, and the MG should know what 
>"run a continuity test" means for its terminations.
>
>Kevin
>
>-----Original Message-----
>From: Taylor, Tom-PT [CAR:5N00:EXCH]
>Sent: Thursday, April 29, 2004 11:19 AM
>To: Aleksandr Ryabin
>Cc: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
>Subject: Re: [Megaco] Continuity tests
>
>I for one disagree with your philosophy.  I think the physical details of 
>the termination should be provisioned in the MG rather than the the 
>MGC.  However, I have no direct implementation responsibility, so I should 
>let those who do speak up.
>
>Aleksandr Ryabin wrote:
>
> > Packages defined in H.248.17 do not cover continuity tests.
> >
> > If the experts agree that MGC should be able to control type of
> > continuity test then ether basic ct package needs to be amended to
> > include new functionality, or H.248.17 needs to be amended to include
> > new "extended" continuity package Commends? Suggestions?
> >
> >         Aleks
> >
> > At 01:14 AM 4/29/2004, Zhao Bo wrote:
> >
> >> Can H.248.17 "line test packages"  be used to test these circuits?
> >>
> >>     ----- Original Message -----
> >>     From: Aleksandr Ryabin 
> <<mailto:[email-masked]>mailto:[email-masked]>
> >>     To: Kevin Boyle 
> <<mailto:[email-masked]>mailto:[email-masked]> ;
> >>     [email-masked] <<mailto:[email-masked]>mailto:[email-masked]>
> >>     Sent: Thursday, April 29, 2004 2:11 AM
> >>     Subject: RE: [Megaco] Continuity tests
> >>
> >>     Yes, the type of test depends on what a circuit is connected to.
> >>
> >>     But, I was actually coming from the view that MGC "controls" MG
> >>     and as such only MGC should have knowledge on what test to execute
> >>     (i.e. what is connected to the other side of a circuit).
> >>
> >>     If this information is left in MG, then each circuit has to be
> >>     provisioned
> >>     with that information such that MG can make intelligent decision
> >>     on what
> >>     type of test to execute. Thus every time a circuit connection is
> >>     changed,
> >>     directly or indirectly, MG circuit needs to be re-provisioned.
> >>
> >>     I think that configuration should  be kept on MGC and the decision
> >>     should
> >>     come from MGC instead.
> >>
> >>             Aleks
> >>
> >>     At 02:30 PM 4/28/2004, Kevin Boyle wrote:
> >>
> >>>         Is it possible to run more than one kind of continuity test
> >>>         on a particular circuit?  If no, then the provisioning model
> >>>         holds and there is no need for a change.  If yes, then we may
> >>>         need to add something to the package to allow selection of a
> >>>         ct test type.
> >>>
> >>>         Kevin
> >>>
> >>>         -----Original Message-----
> >>>         From: Aleksandr Ryabin 
> [<mailto:[email-masked]>mailto:[email-masked]]
> >>>         Sent: Wednesday, April 28, 2004 1:21 PM
> >>>         To: [email-masked]
> >>>         Subject: [Megaco] Continuity tests
> >>>
> >>>         Hi,
> >>>
> >>>         There are several continuity test types (i.e 2-wire, 4-wire,
> >>>         etc) While provisioning of physical test parameters (i.e.
> >>>         frequencies, sequence, timeouts, etc) in MG makes sense, IMHO
> >>>         choosing a type of continuity test seem logical to be left to
> >>>         MGC.
> >>>
> >>>         Basic Continuity Package (ct) does not allow to choose the
> >>>         type of a test.
> >>>         It implies that type of a test is provisioned on MG (per
> >>>         termination?)
> >>>
> >>>         Is there another (extended) continuity test package which
> >>>         allows MGC to choose the type of a continuity test to be
> >>>         performed?
> >>>
> >>>         If not, does anyone see a need to have such a package?
> >>>         Comments?
> >>>
> >>>         Thanks
> >>>                 Aleks
> >>>
> >>>         _______________________________________________
> >>>         Megaco mailing list
> >>>         [email-masked]
> >>> 
> <https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/mailman/listinfo/megaco 
>
> >>

---

From: Christian Groves <[email-masked]>
Date: Fri, 30 Apr 2004 10:17:16 +1000

Hello Aleksandr,

Is this really a problem? The Continuity test is a link by link procedure not an 
end to end procedure. I tend to support Kevin and Tom on this one.

Regards, Christian

Aleksandr Ryabin wrote:
>> valid.  MGs are expected to know how to handle their terminations.  
>> Who the termination is connected to is certainly part of that 
>> I believe the package is fine as it stands, and the MG should know 
>> what "run a continuity test" means for its terminations.
>>
>> Kevin
>>
>> I for one disagree with your philosophy.  I think the physical details 
>> of the termination should be provisioned in the MG rather than the the 
>> MGC.  However, I have no direct implementation responsibility, so I 
>> should let those who do speak up.
>>
>> Aleksandr Ryabin wrote:
>>
>> >>     From: Aleksandr Ryabin <mailto:[email-masked]>
>> >>     To: Kevin Boyle <mailto:[email-masked]> ;
>> >>     [email-masked] <mailto:[email-masked]>
>> >>>         From: Aleksandr Ryabin [mailto:[email-masked]]
>> >>>         https://www1.ietf.org/mailman/listinfo/megaco
>> >> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 30 Apr 2004 10:17:16 +1000

Hello Aleksandr,

Regards, Christian

---

From: David Auerbach <[email-masked]>
Date: Fri, 30 Apr 2004 02:05:34 -0700

COT is not an end to end test.  COT is a test between two adjacent 
switches.  Each subsequent
switch makes an independent decision to apply COT to the next step of the 
routing path.

David

---

From: David Auerbach <[email-masked]>
Date: Fri, 30 Apr 2004 02:05:34 -0700

David

---

From: Aleksandr Ryabin <[email-masked]>
Date: Fri, 30 Apr 2004 10:39:14 -0400

Hi Christian,

There could be "dumb" switches in the middle of the path
(for example DACS) which are not capable of any testing/signalling.
Their only role is to split/redirect links and as such the nature
of a circuit can change, and thus the type of COT test.

Regards,
         Aleks

At 08:17 PM 4/29/2004, Christian Groves wrote:
>Hello Aleksandr,
>
>Is this really a problem? The Continuity test is a link by link procedure 
>not an end to end procedure. I tend to support Kevin and Tom on this one.
>
>Regards, Christian
>
>Aleksandr Ryabin wrote:

---

From: Aleksandr Ryabin <[email-masked]>
Date: Fri, 30 Apr 2004 10:39:14 -0400

Hi Christian,

Regards,
         Aleks