Subject: [Megaco] steam Descriptor handling

From: Papapanagiotou Serafim <[email-masked]>
Date: Wed, 8 Sep 2004 10:11:55 +0300

Dear Megaco-List members,

I am a little bit confused with the way that a "Stream Descriptor" is really
used.

Consider the case where we have a SIP call. At the initial offer we receive
an indication from an "invite" message with two "m-lines" for two different
streams(audio, video). (only the SDP part of  the "invite" is presented
below)
	
	INVITE tel:....
	Via: SIP/2.0/UDP  ....	
	....
	v=0
	o=...
	m= audio 2222 RTP/AVP  97
	a= rtpmap:97 ....
	....
	m= video 3333 RTP/AVP 98
	a= rtpmap:98 ....
	....

The problem is how we should format it to a megaco message focussing to the
"stream Descriptor"? 
Suppose that we send an ADDrequest. Are we going to use two different
"stream Descriptors" with a different streamID and a single m-line will be
contained in Local Descriptor? i.e.

MEGACO/2 [...]
Transaction =.... {
Context =$ {
Add $ {
media {
	stream=1 {	LocalControl	{mode = ....
							   Local
{	v=0
	
o=...
	
m= audio 2222 RTP/AVP  97
	
a= rtpmap:97 ....
	
....
	
}
	stream=2 {	LocalControl	{mode = ....
							   Local
{	v=0
	
o=...
	
m= video 3333 RTP/AVP  98
	
a= rtpmap:98 ....
	
....
	
}

}}}}}}
 	       
OR  should we only have one "stream Descriptor" where the two different
stream sessions will be included in the Local Descriptor as multiple
m-llines with ReserveGroup=true?  i.e

MEGACO/2 [...]
Transaction =.... {
Context =$ {
Add $ {
media {
	LocalControl	{mode = ...., ReserveGroup= true
							   Local
{	v=0
	
o=...
	
m= audio 2222 RTP/AVP  97
	
a= rtpmap:97 ....
	
....
	
v=0
	
o=...
	
m= video 3333 RTP/AVP  98
	
a= rtpmap:98 ....
	
....
	
}
}}}}}}

...here streamID is considered to be 1, according to the protocol.
		
Actually what is the difference of the two approaches above? 
Is a "stream descriptor" representing different  RTP stream sessions or only
the m-lines are a direct mapping of different RTP stream sessions according
to the RTP protocol?

Thanks,

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Wed, 08 Sep 2004 09:13:39 -0400

It's your first alternative: one stream descriptor per media stream.