Subject: RE: [Megaco] steam Descriptor handling

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 8 Sep 2004 10:43:35 -0400

Note that H.248.1 specifically prohibits multiple m= lines in the same local
or remote descriptor.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Wednesday, September 08, 2004 9:14 AM
To: Papapanagiotou Serafim
Cc: [email-masked]
Subject: Re: [Megaco] steam Descriptor handling

It's your first alternative: one stream descriptor per media stream.

Papapanagiotou Serafim wrote:
> Dear Megaco-List members,
> 
> I am a little bit confused with the way that a "Stream Descriptor" is 
> really used.
> 
> Consider the case where we have a SIP call. At the initial offer we 
> receive an indication from an "invite" message with two "m-lines" for 
> two different streams(audio, video). (only the SDP part of  the 
> "invite" is presented
> below)
> 	
> 	INVITE tel:....
> 	Via: SIP/2.0/UDP  ....	
> 	....
> 	v=0
> 	o=...
> 	m= audio 2222 RTP/AVP  97
> 	a= rtpmap:97 ....
> 	....
> 	m= video 3333 RTP/AVP 98
> 	a= rtpmap:98 ....
> 	....
> 
> The problem is how we should format it to a megaco message focussing 
> to the "stream Descriptor"?
> Suppose that we send an ADDrequest. Are we going to use two different 
> "stream Descriptors" with a different streamID and a single m-line 
> will be contained in Local Descriptor? i.e.
> 
> MEGACO/2 [...]
> Transaction =.... {
> Context =$ {
> Add $ {
> media {
> 	stream=1 {	LocalControl	{mode = ....
> 							   Local
> {	v=0
> 	
> o=...
> 	
> m= audio 2222 RTP/AVP  97
> 	
> a= rtpmap:97 ....
> 	
> ....
> 	
> }
> 	stream=2 {	LocalControl	{mode = ....
> 							   Local
> {	v=0
> 	
> o=...
> 	
> m= video 3333 RTP/AVP  98
> 	
> a= rtpmap:98 ....
> 	
> ....
> 	
> }
> 
> }}}}}}
>  	       
> OR  should we only have one "stream Descriptor" where the two 
> different stream sessions will be included in the Local Descriptor as 
> multiple m-llines with ReserveGroup=true?  i.e
> 
> MEGACO/2 [...]
> Transaction =.... {
> Context =$ {
> Add $ {
> media {
> 	LocalControl	{mode = ...., ReserveGroup= true
> 							   Local
> {	v=0
> 	
> o=...
> 	
> m= audio 2222 RTP/AVP  97
> 	
> a= rtpmap:97 ....
> 	
> ....
> 	
> v=0
> 	
> o=...
> 	
> m= video 3333 RTP/AVP  98
> 	
> a= rtpmap:98 ....
> 	
> ....
> 	
> }
> }}}}}}
> 
> ...here streamID is considered to be 1, according to the protocol.
> 		
> Actually what is the difference of the two approaches above? 
> Is a "stream descriptor" representing different  RTP stream sessions 
> or only the m-lines are a direct mapping of different RTP stream 
> sessions according to the RTP protocol?
> 
> 
> 
> Thanks,
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Jon Rowland <[email-masked]>
Date: Wed, 8 Sep 2004 16:17:21 +0100

Kevin,

I don't think that's quite true. H.248.1 prohibits multiple m= lines within
the same session description within a Local or Remote descriptor. Individual
session descriptions can be delimited by v= lines.

>From 7.1.8:
"A Stream descriptor specifies a single bidirectional media stream and so a
single session description MUST NOT include more than one media description
("m=" line).  A Stream descriptor may contain additional session
descriptions as alternatives." ... "When multiple session descriptions are
provided in one descriptor, the "v=" lines are required as delimiters..."

Indeed, there is an example call flow in Appendix I that uses exactly this
syntax (I.1.2 Step 12).

However, in this particular case, I agree that multiple Stream descriptors
should be used as the audio and video are separate media, not alternatives.

Regards,
Jon.

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: 08 September 2004 15:44
To: Tom-PT Taylor; Papapanagiotou Serafim
Cc: [email-masked]
Subject: RE: [Megaco] steam Descriptor handling

Kevin

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 8 Sep 2004 12:47:36 -0400

Yes... You are correct.  I was thinking about two different things when
writing the email, and I ended up merging them together to make one
completely incorrect statement.

By splitting the m= lines with v= lines, the two session descriptions become
alternatives for the same stream.  If you really want two different streams,
then you need to put the descriptions in two different stream descriptors.

I hereby remove my foot from my mouth and will go on with my day... ;)

Kevin 

-----Original Message-----
From: Jon Rowland [mailto:[email-masked]] 
Sent: Wednesday, September 08, 2004 11:17 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Taylor, Tom-PT [CAR:5N00:EXCH];
Papapanagiotou Serafim
Cc: [email-masked]

Kevin,

Regards,
Jon.

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: 08 September 2004 15:44
To: Tom-PT Taylor; Papapanagiotou Serafim
Cc: [email-masked]
Subject: RE: [Megaco] steam Descriptor handling

Kevin