Subject: [Megaco]:Dynamic Tone Definition Package

From: "Geetha" <[email-masked]>
Date: Wed, 29 Sep 2004 17:47:20 -0700

All,

The "Dynamic Tone definition package" defined in H.248.6 (11/2000) has the properties "ToneID" and "Tone String"

1. For "Tone ID"
The type is given as 'expanding enumeration' with possible values defined as 'Existing package_id, tone id described in supported packages that extend tonegen or new tones to be added'. How this has to be taken.. Is it package Id, followed by tone id?

2. For "Tone String"
The possible valuesis given as 

********************************************************************************************************
DefToneString = "(" DefToneElement ["*" RepeatCount ] ")" [","/"+"/"X" DefToneString]

DefToneElement = ToneName ["," ToneDuration [ "," ToneAmplitude ]]

ToneName = (Package id, Tone id) / "#"FreqValue / "&"AnnouncementParameterList

Package id = 1*VCHAR; Unique package identity string or value

Tone id = 1*VCHAR; Unique tone identity string or value

FreqValue = %d0-4000; in Hertz

AnnouncementParameterList = AnnouncementID ["," SubstitutionString]

AnnouncementID = 1*VCHAR; Unique identifier for an audio announcement

SubstitutionString = """1*VCHAR"""; a string to be inserted into an announcement.

ToneDuration = %d1-32767 / %d0; in milliseconds

ToneAmplitude = "-"%d32-1 / %d0; in dBm0

An example of tone definition follows.

RingingTone = ((0x0005,0x0031),((#480)+(#620)),250,-24)*0

*******************************************************************************************

where the character "#" is used. But in H.248 version 2 "#" is not present in SafeChar. Then how it is used here?

Thanks in advance,

Geetha 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 30 Sep 2004 09:39:28 +1000

Hello Geetha,

For 1:
"Expanding enumeration" is not a keyword. It should simply read "Enumeration". I 
think the original author was trying to convey that the toneIDs could be 
extended or modified at any time thus, "expanding".

For 2:
If you want to use "#" then you would have to use it in the quoted string form.
ie.
VALUE                = quotedString / 1*(SafeChar)
quotedString         = DQUOTE *(SafeChar / RestChar / WSP) DQUOTE
RestChar             = ";" / "[" / "]" / "{" / "}" / ":" / "," / "#" /
                        "<" / ">" / "="
This is covered by H.248.1 Annex B.2 eg.
"; String:  A string MUST use the quotedString form of VALUE and can
; contain anything allowable in the quotedString form."

Regards, Christian

Geetha wrote:

> All,
>  
> The "Dynamic Tone definition package" defined in H.248.6 (11/2000) has 
> the properties "ToneID" and "Tone String"
>  
> 1. For "Tone ID"
> The type is given as 'expanding enumeration' with possible values 
> defined as 'Existing package_id, tone id described in supported packages 
> that extend tonegen or new tones to be added'. How this has to be 
> taken.. Is it package Id, followed by tone id?
>  
> 2. For "Tone String"
> where the character "#" is used. But in H.248 version 2 "#" is not 
> present in SafeChar. Then how it is used here?
> 
> Thanks in advance,
> 
> Geetha 
> 
> 
> ------------------------------------------------------------------------
>

---

From: "Geetha" <[email-masked]>
Date: Thu, 30 Sep 2004 14:41:02 -0700

Hi,

Thanks for your reply. I need a little more clarification on both the
issues.

For 1:
Its now clear that the type is enumeration. However, its still not clear
what values are to be used.. Is it only ToneId, Pkg Id or both.. As per the
text of the spec, the possible values are defined as -

"Existing package_id, tone id described in supported packages that extend
tonegen or new tones to be added".

This description is unclear since it does not explicitly tell whether ToneId
is -

ToneId = pkgId SLASH toneId

Or

ToneId = pkgId COMMA toneId

The same lack of clarity exists for ASN encoding too. Could you please help
me get this doubt cleared?

For 2:
The description for Tone string is given as -

****************************************************************************

The syntax for the tone definition string is recursive and uses parenthesis
as a delimiter of elements.

DefToneString below is the tone string(tst):

DefToneString = "(" DefToneElement ["*" RepeatCount ] ")" [","/"+"/"X"
DefToneString]

****************************************************************************

Since characters like "#" can only be present in the quotedString form of
VALUE, shouldn't the above rule actually be something like -

DefToneString =  DQUOTE "(" DefToneElement ["*" RepeatCount ] ")"
[","/"+"/"X" DefToneString]  DQUOTE

Note the encloding DQUOTEs in the modified rule. Is my understanding
correct?

Thanks in Advance,

Geetha

----- Original Message -----
From: "Christian Groves" <[email-masked]>
To: "Geetha" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 29, 2004 4:39 PM
Subject: Re: [Megaco]:Dynamic Tone Definition Package

> RestChar             = ";" / "[" / "]" / "{" / "}" / ":" / "," / "#" /
****************************************************************************
****************************
> > RingingTone = ((0x0005,0x0031),((#480)+(#620)),250,-24)*0
****************************************************************************
***************

---

From: Christian Groves <[email-masked]>
Date: Fri, 01 Oct 2004 11:13:18 +1000

Hello Geetha,

On point 1:
Yes property TID is confusing. Unfortunately when this package was first done we 
  were busy with H.248.1 itself and this passed through without much review. The 
original authors were:
E-mail: [email-masked]
E-mail: [email-masked].

I'd be interested to here it anyone is actually using this package?

The only way I could see this working is that TID is:

Type: 			Sub-list of Enumeration
Possible Values:
			First position in list: Package ID
			Second position in list:   Tone ID

On point 2:
DQUOTE is not needed because by default if you use String DQUOTE is required ie. 
DQUOTE DefToneString DQUOTE.

There's several other issues with the package eg.
Issue 1:
ToneName = (Package id, Tone id) it doesn't mention the seperator. My guess is 
that it should read:
ToneName = (Packageid "/" ToneID)

Issue 2:
The example is misleading. It states:
RingingTone = ((0x0005,0x0031),((#480)+(#620)),250,-24)*0
Is the example for text or binary? This needs to be explained better.

Christian

Geetha wrote:

>>"Expanding enumeration" is not a keyword. It should simply read
> 
> "Enumeration". I
> 
>>If you want to use "#" then you would have to use it in the quoted string
> 
> form.
> 
>>ie.