Subject: [Megaco] Modify wildcard

From: "Gillian Wang" <[email-masked]>
Date: Mon, 13 Sep 2004 16:09:43 +1000

Dear Megaco Members,

When an MGC send the Modify command to MG using wildcard terminationID (*)
for offhook detection and dial tone application, which is the standard
response? 1/ or 2/?

MEGACO/1 [MGC's IP Address]: 2944
Transaction=1000{
Context=-{
	Modify=*{
		Media{Stream=1{
				LocalConrol{Mode=SendReceive,	tdmc/fain=2,tdmc/ec=on}}},
		DigitMap=Dialplan1{xxxx},
		Events=1{al/of{Embed{Signals{cg/dt};
					   Events=2{al/on,dd/ce{DigitMAp=Dialplan1}}}}}
		}}}

1/ Respond with individual TerminationIDs

MEGACO/1 [MG's IP Address]:2944
Reply=1000{
	Context=-{
		Modify=al/1/1/1,
		Modify=al/1/1/2,
		..
		Modify=al/1/1/24,
		Modify=al/1/2/1,
		..
		Modify=al/1/2/24,
		..
		Modify=al/24/24}}

2/ Respond with wildcard

MEGACO/1 [MG's IP Address]:2944
Reply=1000{
	Context=-{Modify=*}}

If No.2 is acceptable, is it required to report the MG's TerminationIDs to
the MGC in a profile before restart?

Thanks for clarifications.

Regards
Gillian Wang

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Jon Rowland <[email-masked]>
Date: Mon, 13 Sep 2004 10:36:15 +0100

Gillian,

For the command you have issued below 1/ is the correct response. However,
you can issue a command indicating you want a wildcard response by including
the wildcard-response modifier in the command as follows:

MEGACO/1 [MGC's IP Address]: 2944
Transaction=1000{
Context=-{
	W-Modify=*{
		Media{Stream=1{
				LocalConrol{Mode=SendReceive,
tdmc/fain=2,tdmc/ec=on}}},
		DigitMap=Dialplan1{xxxx},
		Events=1{al/of{Embed{Signals{cg/dt};

The addition of the W- to the modify command should cause the MG to reply
with syntax 2/.

Hope this helps.

Jon.

-----Original Message-----
From: NEC - Gillian Wang 
Sent: 13 September 2004 07:10
To: [email-masked]
Subject: [Megaco] Modify wildcard 

Dear Megaco Members,

MEGACO/1 [MGC's IP Address]: 2944
Transaction=1000{
Context=-{
	Modify=*{
		Media{Stream=1{
				LocalConrol{Mode=SendReceive,
tdmc/fain=2,tdmc/ec=on}}},
		DigitMap=Dialplan1{xxxx},
		Events=1{al/of{Embed{Signals{cg/dt};

2/ Respond with wildcard

Regards
Gillian Wang

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 13 Sep 2004 09:57:37 -0400

Note that the example command is syntactically invalid.  There should not be
a semicolon after the embedded Signals descriptor -- it should be a comma.

As for needing a profile... How can the MGC issue call processing commands
without having knowledge of the TerminationIDs in the MG?  How that
information gets to the MGC is a matter for individual implementations, but
certainly provisioning, among other options, is acceptable.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jon Rowland
Sent: Monday, September 13, 2004 5:36 AM
To: NEC - Gillian Wang
Cc: [email-masked]
Subject: RE: [Megaco] Modify wildcard 

Gillian,

	

Hope this helps.

Jon.

-----Original Message-----
From: NEC - Gillian Wang
Sent: 13 September 2004 07:10
To: [email-masked]
Subject: [Megaco] Modify wildcard 

Dear Megaco Members,

	

2/ Respond with wildcard

Regards
Gillian Wang