Subject: [Megaco] Use of CR and LF in H.248.1 Annex B quotedString construct

From: [email-masked]
Date: Wed, 9 Mar 2005 11:55:43 +0200

Hi all ,

H.248.1 Annex B quotedString construct doesn't permit the use of the characters CR (ASCII carriage return 0x0d)and LF (ASCII newline 0x0a).
Q.1950 Bearer Control Tunneling package defines for the "Bearer Information Transport" Signal that for a text encoded
H.248 interface the "quotedString" alternative for the parameter value to be used.
This Bearer Control Tunneling package is used to establish IP Bearers inside BICC networks with the help of tunneling.
The data to be tunneled are specified inside Q.1990 "BICC Bearer Control Tunneling Protocol" and Q.1970 "BICC IP Bearer Control Protocol".
The Q.1970 "BICC IP Bearer Control Protocol" uses "Session Description Protocol" as defined by RFC 2327.
And the SDP includes CR and LF characters.
H.248.1 permits in Annex B for quotedString only 
quotedString        = DQUOTE *(SafeChar / RestChar/ WSP) DQUOTE

How could this problem be solved, should CR and LF be permitted in the ABNF quotedString construct?

best regards Manfred

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Thu, 10 Mar 2005 10:26:32 -0500

I'd say the problem is in Q.1970.  We can raise the issue at the next SG 11 meeting.