Subject: [Megaco] Descriptor state after out of service for a termination already in NULL context

From: "Giorgos Tintikakis" <[email-masked]>
Date: Wed, 16 Mar 2005 10:55:40 +0200

Hi,

A termination in NULL context with active event descriptor or signal descriptor (for example al/of or cg/dt) 
is malfunctioning or taken out of service by operator command.
ServiceChange (with reason forced or graceful) is sent to MGC.
Should the MGC send a modify command to empty any active descriptors 
or the MG should reset all descriptors autonomously after the reception of the ServiceChange reply ?

The modify command looks as the proper action but I will appreciate your confirmation.

The question have been already discussed in other threads for example:

Re: [Megaco] Re: Descriptor state after out of service

but for the case of a termination which already is in NULL context the answer in not clear enough (at least for me)

Best Regards,
Giorgos

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 22 Mar 2005 11:03:56 +1100

Hell Giorgos,

As per the thread you referenced I think it comes down to the ServiceState. If 
the termination is in Out-of-Serive then it doesn't really matter what the 
contents are because its in-operable.

A ServiceChange "forced or graceful" ultimately result in a termination being 
subtracted. The effect of physical termination being subtracted is that they go 
to the NULL context and revert back to their provisioned default values. If the 
termination is already in the NULL context I still see that the descriptors 
revert back to their provisioned values and no modify is required.

Regards, Christian

Giorgos Tintikakis wrote:

> Re:
> <http://www1.ietf.org/mail-archive/web/megaco/current/msg04031.html>
> [Megaco] Re: Descriptor state after out of service
>  
> but for the case of a termination which already is in NULL context the
> answer in not clear enough (at least for me)
>  
> Best Regards,
> Giorgos
>  
>  
>  
> 
> 
> ------------------------------------------------------------------------
>