Subject: [Megaco] suspected editing errors in T.38

From: Raphael Tryster <[email-masked]>
Date: Thu, 17 Mar 2005 17:00:56 +0200

The Megaco call flow examples at the end of ITU-T T.38 appear to have a
large number of editing errors.  I am referring to the April 2004 edition.

1. First command in III.2.1 is AuditValue, while in III.2.3 it is
AuditCapability.  I think the former is a mistake.

2. Step 3 in III.2.1 is missing the m=image line.  I think it is a mistake.

3. Step 4 in III.2.1 contradicts step 3.  Step 3 mentions codecs 4 and 0,
while step 4 mentions 18 and 0.

4. Should ftmd/dtfmctyp/dtone be ftmd/dtfm, ctyp/dtone wherever it occurs?

5. What should ftmd/dtfmctyp be?

6. Should faxctyp be ctyp wherever it occurs?

7. Should st, sdtt and dtst be changed to dtt wherever they occur as
parameters of ctyp/dtone?

8. Should ansced and cedans be ans?

9. Step 5 in both III.2.1 and III.2.3 says "RTP/2/2 will be assigned", but
step 6 assigns RTP/2.

10. In III.2.1 step 11, fax/faxstate is assigned value Train.  Should this
be TrainT?

11. In III.2.1 step 12, fax/faxstate is assigned value TrainNegotiating.
Should this be Negotiating?

12. In III.2.1 step 19, should fax/dtone be changed to ctyp/dtone?

13. In III.2.2 step 6, should fax/trpt=T38UDPTL be changed to
ipfax/ipftrpt=T38UDPTL?

14. In III.2.2 and III.2.4 step 10, should ipfax/trpt=T38UDPTL be changed to
ipfax/ipftrpt=T38UDPTL?

15. The Notify in III.2.2 step 7 is missing the header.

Raphael Tryster

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 30 Mar 2005 22:20:49 +0200

>No reply received.  Is there another forum to which I should address questions about ITU-T documents? 

ITU-T? 

Regards,

Christer

-----Original Message-----
From: Raphael Tryster 
Sent: Thursday, March 17, 2005 5:01 PM
To: [email-masked]
Subject: [Megaco] suspected editing errors in T.38
 
The Megaco call flow examples at the end of ITU-T T.38 appear to have a large number of editing errors.  I am referring to the April 2004 edition.
1. First command in III.2.1 is AuditValue, while in III.2.3 it is AuditCapability.  I think the former is a mistake. 
2. Step 3 in III.2.1 is missing the m=image line.  I think it is a mistake. 
3. Step 4 in III.2.1 contradicts step 3.  Step 3 mentions codecs 4 and 0, while step 4 mentions 18 and 0. 
4. Should ftmd/dtfmctyp/dtone be ftmd/dtfm, ctyp/dtone wherever it occurs? 
5. What should ftmd/dtfmctyp be? 
6. Should faxctyp be ctyp wherever it occurs? 
7. Should st, sdtt and dtst be changed to dtt wherever they occur as parameters of ctyp/dtone? 
8. Should ansced and cedans be ans? 
9. Step 5 in both III.2.1 and III.2.3 says "RTP/2/2 will be assigned", but step 6 assigns RTP/2. 
10. In III.2.1 step 11, fax/faxstate is assigned value Train.  Should this be TrainT? 
11. In III.2.1 step 12, fax/faxstate is assigned value TrainNegotiating.  Should this be Negotiating? 
12. In III.2.1 step 19, should fax/dtone be changed to ctyp/dtone? 
13. In III.2.2 step 6, should fax/trpt=T38UDPTL be changed to ipfax/ipftrpt=T38UDPTL? 
14. In III.2.2 and III.2.4 step 10, should ipfax/trpt=T38UDPTL be changed to ipfax/ipftrpt=T38UDPTL? 
15. The Notify in III.2.2 step 7 is missing the header. 
 
Raphael Tryster